
2.0 Navigating Bentley Descartes 
 
This chapter describes how to navigate through the user interface to access all functions or features such as 
dialog boxes, tool boxes, tools, or any specific item in the Raster Manager menu structure that is added or 
modified by the Bentley Descartes application. 
 
Bentley Descartes uses the Raster Manager main dialog to display its menus. The Raster Manager menu bar 
provides access to seven menus. 
 

 
 

• The File menu is not modified by the Bentley Descartes application. 
 

• Several items are added to the Edit menu and some items are modified by the Bentley Descartes 
application. 

 
• One (1) item is added to the Display menu by the Bentley Descartes application. 

 
• Three (3) items are added to the Settings menu by the Bentley Descartes application. 

 
• The Tools menu is added to the Raster Manager menu structure by the Bentley Descartes application. 

 
• The Utilities menu is added to the Raster Manager menu structure by the Bentley Descartes 

application. 
 

• The Help menu is added to the Raster Manager menu structure by the Bentley Descartes application. 
 
The table below illustrates the menus and menu items that are specific to Bentley Descartes (highlighted in 
yellow) as well as those that are modified by the Bentley Descartes application (highlighted in blue).  
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2.1 Raster Manager Dialog Box 
 
All Bentley Descartes functions can be accessed from the Raster Manager dialog box. 
 
To open the Raster Manager dialog box 
 

1. From the MicroStation File menu, choose Raster Manager.  
 
or 
 

1

2. From the MicroStation Tools menu, choose Raster > Control to open the Descartes Raster Control 
tool box, then select the Raster Manager tool. 
The Raster Manager dialog box opens, displaying names of any attached raster images. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2

2

1

The Raster Manager dialog list box is customizable. You can selectively disable or enable individual fields 
from the list box menu bar using a contextual menu (right-click). 
 
The following fields can be displayed: 
 

• The Quick Info field is used to display a short description of the raster. When the cursor is placed over 
this field, a tool tip brings up the description corresponding to the raster. 

 
• The File Name field is used to display the file name. 

 
• The Description field is used to present a description of the file. 

 
• The Logical Name field is used to display the file's logical name. 

 
• The Read-Only field is used to indicate if the file is in read-only mode. 

 
• The new On-the-Fly only works with MicroStation GeoGraphics. We do not use MicroStation 

GeoGraphics here at MoDOT at this time. 
 

• The Geo Priority field is used to display the method used to geographically position the image. The 
available choices are Attachment, Raster Header and Sister File. The image may have native 

Navigating Descartes 201



geographic metadata stored in the image itself (raster header) or in a companion file (sister file or 
world file). When no native methods are present, the user geographically positions the image and the 
metadata is stored in the design file. This method is called “attachment”.  

 
The geographic metadata is always preserved and updated in the Attachment. When specified 
otherwise, the alternate location is updated as well as the attachment. Hence, the attachment is 
constantly updated to reflect the current geographic information of the image. 
 
To change the Geo Priority, simply click in the Geo Priority column. This will open the Geo Priority 
dialog box. You can then change the selection. 

 
 
 
 
 
 
 

Upon saving a raster file, the preferred Geo Priority for a raster attachment can be specified. When the 
raster file is reopened, if the raster cannot be reattached with the same Geo Priority, the raster will be 
displayed using a “dark yellowish” color in the Raster Manager dialog.  

 
• The Model field is used to display the origin (design name and model name) of the raster reference. 

We do not use Models here at MoDOT at this time. 
 

• The Status field displays the reference's status (Loaded, Referenced, Self-Referenced or Raster Not 
Found). 

 
To show or hide a field from the list box menu bar 
 

1. Open the Raster Manager dialog box. 
 

2. Position the pointer within the list box menu bar and right-click. 
The contextual menu displays. Enabled fields are indicated with checkmarks. 

 
3. Choose the menu item for the field you want to hide or show. 

 
 
 
2.2 Pull Down Menu Items 
 
Edit menu 
 
The Raster Manager Edit menu gives access to features for modifying, clipping, copying and pasting images. 
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Modify 
 
Used to modify a raster image’s origin, size, rotation or affinity. 
 
Move 
 
Used to move an image to a new location. 
 
Scale 
 
Used to change the proportionate dimensions of an image. 
 
Rotate 
 
Used to rotate an image. 
 
Mirror 
 
Used to mirror the selected raster image horizontally, vertically, or diagonally. Additionally, you can specify the 
axis about which the image is mirrored. 
 
Warp 
 
Used to adjust the size and shape of a raster image with a combination of move, scale, rotate, and skew 
options. 
 
Square 
 
Used to rotate a raster image by squaring a horizontal, vertical, or diagonal axis. 
 
Merge/Crop 
 
Used to copy and merge or to crop one or more images contained within a defined area. 
 
Corridor 
 
Used to copy the regions of one or more images contained within a polygon of the same shape. 
 
Clip 
 
Used to clip a raster image (Clip Boundary), or to define a masked area (Clip Mask). 
 
Modify Clip 
 
Used to modify the clipping polygon for a clipped raster image. 
 
Unclip 
 
Used to remove one or more clipping polygons from a raster image. 
 
Cut 
 
Removes (cuts) the selected element(s) to the clipboard for subsequent pasting. 
 
Copy 
 
Used to copy an area from the active image to the clipboard. 
 
 
 

Navigating Descartes 203



Paste 
 
Used to paste the image area in the clipboard at a specified location in the active image. 
 
Color Table 
 
Used to edit the selected image's color palette. This menu item is not available if 
no image is selected, if more than one image is selected, or if the selected 
image has no color palette.  
 
File menu > Open — Opens the Open Palette dialog box, which is used to load 
a new color table into the color tiles.  
 
File menu > Save As — Opens the Save Palette dialog box, which is used to 
save the Color Table as a color table file.  
 
File menu > Revert — Resets the Color Table to the active color table settings 
without closing the Color Table dialog box. 
 
2.3 Display menu 
 
The Raster Manager Display menu gives access to tools for displaying raster files. 
 

 
 
References 
 
Used to open the MicroStation Reference dialog box. 
 
Bring to Front 
 
Used to bring the selected raster image to the top of the other raster images. 
 
Send to Back 
 
Used to send the selected raster image to the back of the other raster images. 
 
Bring Forward 
 
Used to bring the selected raster image forward one raster image at a time. 
 
Send Back 
 
Used to send the selected raster image back one raster image at a time. 
 
Fit Rasters to View 
 
Used to fit the view to the selected raster image’s boundary. 
 
Fit All Rasters to View 
 
Used to fit the view to all the raster images in the design file. 
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Actual Resolution 
 
Used to view the selected raster image at a 1:1 actual resolution. 
 
Align View to Raster 
 
Used to align the view to the selected raster images rotation. 
 
2.4 Settings menu 
 
The Raster Manager Settings menu gives access to various setting boxes. 
 

 
 
Attachment 
 
The attachment setting shows information about the file information, location, color, and display. 
 
      
 
 
 
 
 
 
 
 
 
 
Descartes Attachment 
 
Shows the transparency and image background color settings. 
 

  
 
 
 
Update Sequence 
 
Used to determine the order in which the raster images update. 
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Raster Snap on Tentative 
 
Used to set up the snap options to a raster image. 
 
Entity 
 
The Entity option menu lets you choose whether to snap at the center of the raster lines (Line), or on the 
edges of the raster objects or lines (Outline), or not to snap at all (None). 
 
Mask 
 
Used to select a color mask from the open Color Mask file, to determine the raster objects or lines on which to 
snap.  
 
 
2.5 Tools menu 
 
With the Raster Manager Tools menu, you can access all Bentley Descartes tool boxes. 
 

 
 
Tool Boxes 
 
Each tool box gives access to a few tools of the same family.  
All tool boxes can be accessed from the Raster Manager Tools menu, where they are listed in alphabetical 
order. 
 
Tool Frame 
 
The Image tool frame is provided with Bentley Descartes. This tool frame can be accessed through the 
MicroStation>Tools>Raster>Descartes menu. It provides access to all the Bentley Descartes tool boxes. 
  
 
Raster 
 
Toggles the display of the main Raster tool box, which contains tools for displaying and controlling raster files. 
 
 
 
 
 
 
 
 
 
Raster Display 
 
Opens the Raster Display tool bar, which contains tools for displaying raster files. 
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Raster Control 
 
Opens the Raster Control tool box, which contains tools for controlling and manipulating raster files. 
 
 
 
 
 
 
 
Raster Descartes 
 
Opens the Image Main tool box, which provides access to all other tool boxes and, consequently, to all the 
functionality of Bentley Descartes. 
 
 
 
 
 
 
 
 
 
 
Color Mask 
 
The Color Mask tool box provides tools to add colors to a mask, to subtract colors from a mask, or to open the 
Color Mask dialog box. 
 
The Color Mask tool box gives access to the following tools: 
 

• Add to Mask tool 
 

• Subtract from Mask tool 
 

• Color Mask Dialog tool 
 
 
 
 
 
 
 
 
 
 
Cut / Copy / Paste 
 
Opens the Cut / Copy / Paste tool box and gives access to the following tools: 
 

• Cut Image Area 
 

• Copy Image Area 
 

• Paste Image Area 
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Mosaic 
 
Opens the Mosaic tool box and gives access to the following tools: 
 

• Balance Tone 
 

• Define Seam 
 
 
 
 
Node File 
 
Opens the Node File tool box and gives access to the following tools: 
 

• New Node File 
 

• Open Node File 
 

• Save Node File 
 

• Save Node File As 
 
 
 
Register 
 
Opens the Register tool box and gives access to the following tools: 
 

• Place Control Points 
 

• Move Control Point 
 

• Delete Control Points 
 

• Register Dialog 
 

• Resample Image 
 

• Resampling Dialog 
 

• Copy Vector 
 

• Move Vector 
 
 
 
Stamp Vector 
 
Opens the Stamp Vector tool box and gives access to the following tools: 
 

• Stamp Vector 
 

• Match Stamp Vector Settings 
 

• Stamp Vector Settings 
 
 
 

Navigating Descartes 208



Text / Cells 
 
Opens the Text / Cells tool box and gives access to the following tools: 
 

• Select Horizontal Text 
 

• Select Oriented Text 
 

• Select Multiple Text 
 

• Delete Text Selection 
 

• Convert Text 
 

• Text Settings 
 

• Convert Cell 
 

• Convert Horizontal Cell 
 

• Convert Oriented Cell 
 
 
Touch-up 
 
Opens the Touch-up tool box and gives access to the following tools: 
 

• Paint 
 

• Erase 
 

• Cleanup 
 
 
 
Vectorize 
 
Opens the Vectorize tool box and gives access to the following tools: 
 

• Place Element 
 

• Continue Element 
 

• Insert Element 
 

• Convert Lines 
 

• Convert All Connected Lines 
 

• Convert Contour Lines 
 

• Convert Circle 
 

• Place Nodes  
 

• Delete Nodes 
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2.6 Utilities menu 
 
The Raster Manager Utilities menu gives access to various dialog boxes for enhancing or registering images, 
creating color composites, and for rasterizing images. 
 

 
 
 
Color Compression 
 
Used to open the Color Compression dialog box. 
 
 
Color Mask 
 
Use to create and manage Color Masks. A mask can be assigned to any image regardless of the pixel type 
(except for binary images). When adding colors to a mask, it is possible to select the area on any image 
currently open in Raster Manager. 
 
 
Register 
 
Used to open the Register dialog box. 
 
 
Resampling 
 
Used to open the Resampling dialog box in order to apply a geometric correction model to an uncorrected 
image. 
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