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3.1 Objectives 

• Learn how to set up a project using Project Manager. 
• Learn how to utilize Project Manager as a workflow guide. 
• Learn how to access GEOPAK dialogs from the Project Manager. 

3.2 Definitions 

Project Manager is a GEOPAK tool that associates a project with its respective gpk job number, 
users, working directories and project files.  Project Manager provides the user with an easy 
workflow system that keeps records of processes run throughout the design of a project.  

3.3 Accessing 

To access Project Manager: 
•  Select Applications >> GEOPAK 
Road >> Project Manager (as shown 
in the figure to the right) or  
 

• Select the Project Manager icon 
from the GEOPAK Road Tools 
(both are shown to the 
left), which are opened by 
selecting Applications >
GEOPAK Road >> 
GEOPAK Road Tools.   

> 

 
The following dialog depicted to the right appears:  

3.4 Project Manager Dialog 

3.4.1 General Description 
The current directory is displayed at the top of the 
dialog box, which can be changed by navigating to a 
different directory in the Directories list box.  This 
navigation is the first step in selecting an existing 
project or creating a new one.  Project files (.prj) 
are displayed in the Projects list box.  The project 
files should be located in the  
t:\br-proj\A_Geopak\district\jobnumber\project 
directory. 
 
The remainder of the Project Manager dialog box displays information after a project has been 
selected from the Projects list box.  At the bottom of the dialog are the OK and Cancel buttons.  
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If the user wishes to exit Project Manager, the Cancel button should be selected.  To continue in 
the Project Manager process, the OK button should be selected. 

3.4.2 Project Manager Menu Bar 
There is three pull down choices on the Menu Bar: Projects, Directory, and Admin.  Each of 
these choices has options contained in the pull down. 

3.4.2.1  Project Tools 
There is four choices under the Projects pull down: 
New, Edit, Delete, and Exit as shown below. 
 
As can be seen from this dialog box, the Windows 
motif also keeps track of the last few processes that 
have been executed.  These may be recalled as 
needed by selecting the desired process.  

3.4.2.1.1 New… 
The New menu option is used to create a new 
project.  The .prj file will be stored in the directory 
shown in the Directory path at the top of the Project 
Manager dialog box.  When the New menu option is 
selected, the Create New Project dialog appears 
(shown at the bottom of the page). 
 
The Project Name can be any number of 
alphanumeric characters.  For MoDOT projects, the 
Project Name needs to be the same as the job 
number. (i.e. j1p0999.prj)  The Working Directory 

specifies the location of the project data files.  The Working Directory may be keyed in or the 
Select button may be chosen and the appropriate directory selected.  For MoDOT Bridge, the 
Working Directory should be set to t:\br-proj\A_Geopak\district\jobnumber\data. 
 
The next field is for typing in the 
COGO job number, or the Select 
button may be chosen and the 
appropriate COGO job number 
selected. 
 
Next the Preferences button 
should be chosen and the Project 
Preferences dialog appears, 
which is depicted on the 
following page. 
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The user may set the particular 
parameters for each project as 
well as the Working 
Directory.  This keeps the u
from re-setting them when
changing projects since the 
project’s preferences are 
recalled when entering the 
project.  After all of the 
information is entered, select 
OK to accept the changes, or 
Cancel to reject them.  For 
more about User Preferences, 
see Section 1.5 in Chapter 1. 

ser 
 

 
Shown below is a sample project that includes a project description, which may be keyed in at 
the bottom of the Create New Project or Project Info Edit dialog box.  The Working 
Directory is set to: 

t:\br-proj\a_geopak\d5\j5p0100\data. 
 

 

3.4.2.1.2 Edit… 
The Edit menu option is used to change any settings associated with the currently selected 
project.  When chosen, the Project Info Edit dialog box shown above appears. 

3.4.2.1.3 Delete… 
The Delete menu option is used to delete any project that has been stored.  The user highlights 
the project in the Projects and selects Delete. 

3.4.2.1.4 Exit 
The Exit menu option closes the Project Manager and writes the settings to a resource file. 
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3.4.2.2 Directory Tools 
There are two options under the Directory pull down, Create New Directory and Current 
Working Directory as shown below. 

 

 
 

The Create New Directory option creates a new directory on the disk. 
 
If the Current Working Directory option is chosen, the directory path in Project Manager is 
changed to that directory. 

3.4.2.3 Administration Tools 
The Administration menu option is used to set a password on a project.  It is recommended that 
a password not be used since the project will need to be accessed by more than one user. 
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3.5 Project Users Dialog 

Once a project is highlighted and OK is selected, the Project Users dialog appears.  
 
This dialog has three sections: Project Users, 
User Info, and Description.  The Project 
Users list displays a list of users that have been 
created to work with any project that resides in 
the current projects home directory.  The names 
shown in Project Users will be the userid’s of 
the people working on that project as specified 
in the Start Job dialog.  Within the User Info 
group box, the Full Name field further 
identifies the user, and displays the full name of 
the user that is currently selected.  The OP 
Code field displays the GEOPAK Operator 
Code of the currently selected user.  The 
GEOPAK Operator Code is used for all 
coordinate geometry operations during this 
session.  The Operator Code, along with the Job 
Number, will be utilized whenever an input or 
output file is created by the software.  The 
Operator Code will be the user’s first and last 
initials.  The Description field displays the 
description of the currently selected user. 
 
Four tools are supported on the Project Users 
pull down as depicted in the exploded view to 
the right. 

3.5.1 New 
The New pull down menu option creates new users.  This option is not to be used in MoDOT.  
To create a new user for a project, use Start Job/Add User under the MoDOT menu with Add 
Userids to Existing Job activated, as show in the following figure.  Start Job/Add User must be 
used for the user to have the default MoDOT runs. 
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3.5.2 Edit 
The Edit pull down menu option allows the user to change any of the parameters of the currently 
selected user.  (Note: The User cannot be changed.  This will change the user information for the 
current project only.) 

3.5.3 Password 
The Password tool creates or modifies a password for the selected user.  If the selected user 
already has a password, the user is prompted to enter the current password before continuing. 

3.5.4 Exit 
The Exit option closes the User dialog and returns back to the Project Manager dialog. 

3.6 Road Project Dialog 

After a minimum of one user has been defined, selecting the OK button on the lower left corner 
of the Project Users dialog or double clicking on a Project User will open the Road Project 
dialog. 
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3.6.1 General Description 
The top of the dialog displays the Working Directory, Working Alignment (if defined), User 
and GEOPAK Job Number.  In addition, a toggle for Working Alignment Influence Runs is 
also supported.  The bottom portion of the dialog box displays the various processes supported 
during the design process.  The small square in the upper right corner (to the right of the Job 
Number) will condense the dialog as depicted in the graphic below. 
 

 
 

3.6.2 Road Project Dialog Menu Bar 
The three pull down menu bar options are: F
Remember, and Options.  When the File 
option is selected, the choices are Close and 
Exit.  

ile, 

or 

ediately 
., which 

ggle is 

 
If the Close option is selected, the user is 
returned to the Project Manager dialog.  If Exit is selected, the user is exited from Project 
Manager. 
 
When the Remember option is selected, the 
user can instruct the software to remember the 
Project or the User in subsequent sessions.  F
example, if all both toggles are activated, and 
the Project Manager is completely closed, the 
invocation of the Project Manager imm
invokes the Road Project dialog (flow chart) and utilizes the project name, username, etc
were active when the Remember toggles were selected.  If only the Project toggle is activated, 
the user is returned to the Project Users dialog in subsequent sessions.  If only the User to
activated, the user is returned to the Project Manager dialog in later sessions, but will skip the 
Project Users dialog.  This option is particularly useful when the user is working on more than 
one project but always enters Road using a single user id. 
 
The Options menu allows the user to toggle on 
the Auto Sink option.  When toggled on, this 
option sinks (move behind the open drawing 
views) the Road Project Manager dialog when a 
tool is chosen from the Project Manager.  When 
a tool is closed, the Road Project Manager 
dialog becomes the active dialog. 
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3.6.3 Working Alignment 
The concept of a working alignment enables the designer to organize a project and to access 
project information without continually typing the required information.  On a simple project, 
only one working alignment may be needed.  However, on a more complicated project, an 
unlimited number of working alignments may be defined.  The designer can easily change from 
one working alignment to another by highlighting the desired alignment listed in the Select 
dialog.  Three tools relating to working alignments are located at the top of the Road Project 
dialog: 
 

• Select Button 
• Define Button 
• Working Alignment Influence Runs (toggle on left side of dialog) 

 

 
 

3.6.4 Select Option 
When the Select button is pressed, the Select Working Alignment dialog appears as depicted to 
the right.  If no working alignments have been defined, MoDOT appears in the Run List box.  If 
working alignments have been defined, they are listed with the last run time.  The description of 
the working alignment can be seen in the bottom of the dialog when each Name is highlighted.  
To select a previously defined working alignment, highlight the run from the list then press the 
OK button at the bottom of the dialog.  Double clicking on the Name also selects a previous 
working alignment for subsequent processing.  Pressing the Cancel button closes the Select 
Working Alignment dialog without any 
working alignment change.  Several file 
option are supported as depicted in the 
exploded view below.  These include 
New, Copy, Rename, and Delete.  
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• Run > New – allows the user to 
create a new working alignment.  
(Do not use this option as it will 
not copy the default MoDOT 
settings for the working alignment.  
Instead, use Run>>Copy>>Run to 
copy the MoDOT run.) 

 
• File > Copy – allows the user to 

copy an existing Project, User or 
Run. 

 
• File > Rename – allows the user t

change the name of the existing 
working alignment. 

o 

t 
gnment 

 
• File > Delete – allows the user to 

delete an existing working 
alignment. 

 

3.6.5 Define Option 
Once a Working Alignment is 
selected, pressing the Define button 
invokes the dialog depicted to the 
right.  The information that can be 
associated with a working alignment is 
listed in the left portion of the dialog 
box.  As each option is chosen, the 
right side of the dialog box changes to 
reflect the information needed as can 
be seen in the dialog box to the right 
after Profile View was selected.  
 
All information entered in these fields 
can be used in subsequent processes 
run from Project Manager.  In the 
beginning of a project, much of this 
information is not known but, as the 
user goes through the design process, i
can be added to the working ali
definitions.   
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For example, as soon as the c
has been stored in COGO, the 
user can enter that infor
the Plan View fields as depicte
to the right.  For a more comple
explanation of each option 
shown, please see the on line 
GEOPAK Help by going to the
MicroStation menu path: 
Applications > GEOPAK Road 
> Help. 

hain 

mation in 
d 
te 

 

3.6.6 Port Viewer 
The Port Viewer is a tool that enables the user to view all three major aspects of a road design 
simultaneously even though they are located in different files.  The three views include: 

• Plan 
• Profile 
• Cross Section 

 
As a prerequisite to invoking the Port Viewer, a working alignment must be defined with the 
following information. 

• Alignment Specification 
• Plan View Design File and Chain 
• Profile Information 
• Cross Section File 
• Digital Terrain Models 

 
The Port Viewer is covered in more detail in Chapter 16 of the manual.  The tool is invoked by 
clicking on the accented button in the following figure.  A error message is generated if all of the 
prerequisite information is not defined prior to activating the tool. 
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3.7 Project Manager Process 

The primary Road Project dialog is depicted below.  The advantage of utilizing the Road 
Project dialog rather than selecting functions directly from the Road menu is that pertinent 
information stored within the Project Manager is automatically displayed within the invoked 
dialog.  Therefore, job numbers, chain names, stationing, file names, and data associated with the 
project do not have to be typed in each time a dialog is utilized.  However, the user can change 
information in the fields. 
 

 
 
Many of the Project Manager processes function identically to their corresponding dialog’s 
invocation from the Road menu.  However, some of the procedures invoke the Select Run dialog 
prior to invoking the actual dialog.  The Select Run dialog allows the user to set up different 
options to use in alternative design choices. 
 
Each of the Road Project dialog processes is covered individually in the remaining chapters. 

3.7.1 Select Run Option 
When certain procedures are selected from the Project Manager dialog, the Select Run dialog 
is invoked.  The Select Run dialog allows the user to save the settings for each procedure in a 
Run that can then be recalled whenever the user needs to execute that same procedure.  With the 
individual runs, a user can keep a history of the project, and can access the various procedures 
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with the settings that were previously 
used.  This way a user can repeat various 
procedures with the same settings 
previously used.  
 
When the Select Run dialog is invoked, 
MoDOT appears in the Run List box.  
(Some Select Run boxes will display 
default run names such as English, 
Metric, I100, I20, etc.)  If Runs have 
been defined, they are listed with the last 
run time.  The description of the Runs 
can be seen in the bottom of the dialog 
when each Name is highlighted.  To 
select a previously defined Run, 
highlight the run from the list, and then 
press the OK button at the bottom of the 
dialog.  Double clicking on the Name 
also selects a previous Run for subsequent processing.  Pressing the Cancel button closes the 
Select Run dialog without any run settings change.  Several file option are supported as depicted 
in the exploded view below.  These include New, Copy, Rename, and Delete.  
 

• File > New – allows the user to 
create a new run.  (Do not use this 
option as it will not copy the 
default MoDOT settings for the 
procedure selected.  Instead, use 
Run>>Copy>>Run to copy the 
MoDOT run.) 

 
• File > Copy – allows the user to 

copy an existing Project, User or 
Run. 

 
• File > Modify – allows the user to 

change the name of the existing 
Run or its description. 

 
• File > Delete – allows the user to 

delete an existing Run. 
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