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17.1 Group Exercise: Paved Approach Design 

Designing an approach can be a complex and iterative process. There are an abundance of 

criteria to consider such as min/max slopes, stopping sight distance, drainage and R/W 

constraints – just to name a few. 

 

There are many techniques in Roadway Designer that can be used to model an approach. This 

presentation will cover the workflow used to model a Paved Approach.   

 

Project Review: Paved Approach – Bighorn 2+97.99 RT 

 

 
 

1) Open the plan.dgn. 

  

Review the plan graphics for the approach at Bighorn Drive 2+97.99 Right 
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2) Using Project Manager open the following project: 
 

    pw:\District CADD\Design\Randolph\J5P0100\project\J5P0100.prj 
 

  
 

 

3) Change the project preferences to the following:. 

 

 

 

4) Select ClsUser as the project user. 
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5) From the GeoPak Road Tool Palette, select Corridor Modeling: 

 

 

 

 

 

 

 
 

 

6) Verify and/or set the following settings in the Preference section: 
 

 
 

Select File > Save As and save the preferences as J5P0100.rdp 

 

 

7) In Corridor Modeling DTM section, import the J5P0100 tin. 

 

 

8) In the Corridor Modeling > Geometry section, import the Bighorn chain and 

BighornEx profile. 

 

Use a Drafting Standard of MoDOT_Proposed_Baseline 
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9) In Corridor Modeling import the following Bighorn plan graphics: 

 

 Remember in order to import plan graphics you have to be in the file that contains the 

plan geometry.  Existing items are located in the topo.dgn, proposed items are located in 

the Plan.dgn. 
 

Plan Graphic  New Chain Name   Drafting Standard 

Right Existing EOP BH_RT_EOP_EXISTING  EOP Existing 

Left Existing EOP  BH_LT_EOP_EXISTING  EOP Existing 

 

Right New EOP  BH_RT_EOP_NEW   EOP New 

Left New EOP  BH_LT_EOP_NEW   EOP New 
 

 
 

Save the Corridor Modeling settings to a file called J5P0100.rdp 
  

 

10) Also in Corridor Modeler import the right Bighorn Sidewalk line and call the new chain 

BH_Sidewalk_RT. 
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11) Open the Create Template dialog and save the file to your data folder calling the file 

J5P0100.itl. 

 

12) In the Create Template dialog create the following directory structure:  

 

J5P0100 > Bighorn  

  

 

 

 

 

13) In Create Template dialog copy the Slope Correction Widening with No Overlay 

from the MoDOT section of the Template Library into the Bighorn folder. 

 

Delete the Right Shoulder and End Conditions and reconstruct the right side using the 

following: 

 

Components: 

 

Right Side 

 

Curb and Gutter Type B – 609-10.52 

Sidewalk Surface 

 

End Conditions: 

 

Right Side 

 

Ditch 1 

Fill Slope Combined 

  

*Notes 

 

a) Use Dynamic Settings, set the Step to 0.1 and toggle on Apply Affixes 

b) Check Priorities on End Conditions. 

c) Save and close the Template Library. 

 

 

14) Back in Corridor Modeling set the Template Library File to the J5P0100.itl located in 

your data folder. 

 

Save the Corridor Modeling settings. 
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15) Open Roadway Designer and create a corridor named “Bighorn” using the Bighorn 

chain and BighornEx profile. 

 

16) In Roadway Designer go to Corridor > Template Drops and apply the Slope 

Correction Widening with No Overlay template to the Bighorn corridor.  

 

Station  1+90.15 

Interval 50ft      

 

 

 

17) In Roadway Designer go to Corridor > Display References and display the following 

three (Plan Graphic) alignments.  

 

 

 

 

 

 

 

 

18) In Roadway Designer review the sections. 

 

19) Save the Roadway Designer settings as J5P0100.ird. 

 

20) Close Roadway Designer 
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21) In Corridor Modeler import the following Plan Graphic along Bighorn at station 2+98 

using the Section Set method and call the new chain BH_DW_RT_2+98. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note - The stationing of this alignment will go from the bottom to the top. 

 

 

22) Also in Corridor Modeler > Plan Graphics import the two radius return curbs and call 

the new chain BH_DW_RT_2+98_CURB. 
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23) In the Create Template dialog create the following directory structure:  

 

J5P0100 > Bighorn > BH_Driveway_RT_2+98 

  

 

 

 

 

24) In Corridor Modeler > Create Template we are going to create a template called 

Driveway Front for the entrance pad portion of the Paved Approach with the following 

component and End Conditions: 

 

First right click on the “BH_Driveway_RT_2+98” folder and select New > Template 

 

Left Side: 

 

Components: 

 

Pavement layer 1 Concrete 

Pavement layer 1 Concrete 

Integral Curb Type A Over 6 inch 609-20.21 

Sidewalk Surface 

 

End Conditions:  

 

Fill Slope 2 (3:1) 

 

 

 

 

 

 

 

 

 

*Notes 

 

a) Use Dynamic Settings, set the Step to 0.1 and toggle on Apply Affixes 

b) Adjust the first pavement width to 2’-3” with a 2” slope (drop). 

c) Adjust the second pavement width to 3’-9” with a -12.22% slope (rise). 

d) Adjust the Curb height to be 8” (modify the “Curb_Surf_Top_L” point) 

e) In the “Pvmt_Layer_1_Conc_T11_L” point set the style constraint to “Driveway”  

f) Change the Sidewalk Width to 1ft.  

g) Save and close the Template Library. 
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25) Continuing in the same template, set up the following Component Display Rule to 

remove the Curb and Sidewalk when no Curb plan graphic is present: 

 

Component Display Rules - This functionality allows you to apply one template that changes 

based on what is occurring at a particular station. It frees you from knowing where a change 

in conditions might require a different template and allows the rules within a template to 

make modifications.  

 

Before we setup the display rule we need to have a switch to either turn on the component if 

GeoPak sees a particular plan graphic style.  To do this we will use a “Null Point”. 

 

Right click and select “Add New Component” > “Null Point”.  Place point 2-3 feet above 

the template origin. 
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26) Continuing with setting up the Component Display Rule. 

 

Double right click on the Integral Curb to open up the Component properties.  Once open 

select “Edit” in the lower right hand corner of the dialog. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select “Add” 
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27) Set the Display Rule setting as follows: 

 

 

 

 

 

 

 

 

 

 

 

 

Select “OK” 

 

In the dialog below highlight the template Display Rule and select “Selected Rule”.  

 

 
 

Click on the equals sign and the rule should equal “False”. 

 

Select “OK” and “Apply” the changes to the component. 
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28) Back at the template the Curb should now be turned off since the SeekCurb null point is 

still sitting at the origin point. 

 

Move the SeekCurb Null Point off the origin and the Curb should reappear. 

 

 

29) To make the Curb surface, Sidewalk, and Fill Slope to all disappear with the Curb we 

need to make them all “Childs” of the Curb. 

 

First make the Curb reappear by moving the “SeekCurb” null point off the origin. 

 

Make the following Parent-Child relationships: 

 

Parent     Child  (edit this component) 

 

Integral Curb Type A > 6"_L  Proposed Finish Grade_L 

Integral Curb Type A > 6"_L  Sidewalk Surface_L 

Sidewalk Surface_L   Proposed Finish Grade1_L 

Sidewalk Surface_L   Fill Slope 2_L 
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30) Continuing in the same template, another Component Display Rule needs to be set up to 

remove the Sidewalk when no Sidewalk plan graphic is present: 

 

Before we setup the display rule we need to have a switch to either turn on the component if 

GeoPak sees a particular plan graphic style.  To do this we will use a “Null Point”. 

 

Right click and select “Add New Component” > “Null Point”.  Place point 1-2 feet above 

the “SeekCurb” Null Point above the template origin. 
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31) Continuing with setting up the Component Display Rule. 

 

Double right click on the Sidewalk to open up the Component properties.  Once open select 

“Edit” in the lower right hand corner of the dialog. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select “Add” 
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32) Set the Display Rule setting as follows: 

 

 

 

 

 

 

 

 

 

 

 

 

Select “OK” 

 

In the dialog below highlight the template Display Rule and select “Selected Rule”.  

 

   
 

Click on the equals sign and the rule should equal “False” when the “SeekSidewalk” Null 

Point is above the template origin. 

 

Select “OK” and “Apply” the changes to the component. 
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33) When no shoulder is present there needs to be an End Condition to tie to ground. 

 

Add the following End Condition to the back of Curb 

 

End Conditions:  

 

Fill Slope 2 (3:1)  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To make the Fill Slope disappear with the Curb we need to make it a “Child” of the Curb. 

 

Make the following Parent-Child relationships: 

 

Parent     Child  (edit this component) 

 

Integral Curb Type A > 6"_L  Fill Slope 2_L 

 

 

 

 

 

 

 

 

 

 

 

 

SeekCurb 

SeekSidewalk 
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34) Move both Null Points off the (X=0) template origin. 

 

In this scenario we have two End Conditions.  The display of the End Condition nearest the 

Curb needs to turn off when the sidewalk is displayed (sidewalk line is found). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Modify the Fill Slope 2 Display Rule to the following: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

SeekCurb 

SeekSidewalk 



 Chapter 17 – Paved Approach Design               GEOPAK Road 3 

17-18 Missouri Department of Transportation 5/10/12 

 

35) Move both Null Point above the template origin. 

 

Save template Library. 

 

 

36) Reopen Roadway Designer and create a corridor named “BH_DW_RT_2+98” using the 

BH_RT_EOP_NEW chain and None for the profile.  Use the following station range: 

 

 

Start Station: 18+17.01 

End Station: 18+56.04 

 

 

37) To set the vertical for this corridor, we are going to use a Point Control to tie to the 

Bighorn Edge of Pavement. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



GEOPAK Road 3 Chapter 17 – Paved Approach Design 

5/10/12 Missouri Department of Transportation 17-19 

 

38) In Roadway Designer go to Corridor > Template Drops and apply the Driveway 

Front template to the BH_DW_RT_2+98 corridor.  

 

Station  18+17.01 

Interval 0.5ft      

 

 

39) In Roadway Designer go to Corridor > Display References and display the following 

two (Plan Graphic) alignments.  

 

 

 

 

 

 

 

 

40) In Roadway Designer go to Corridor > Secondary Alignments and add in the 

following alignment.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

41) In Roadway Designer review the sections. 
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42) Save the Roadway Designer settings as J5P0100.ird. 

 

 

43) In Roadway Designer go to Corridor > Create Surface and create a model in the 

DTM.dgn file. 

 

Review model in area of Bighorn and Paved Approach. 

 

 

44) In the next few steps we are going to fix minor issues in the model. 

 

See next page. 
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45) Fix #1) The Paved approach gutter does not match Curb and Gutter Section. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To fix this issue we are going to use a Parametric Constraint.  We need to modify the points 

that control the slope of the Paved Approach.  Change both to slope values and add in the 

following Labels for each. 

 

Paved Approach 1 Slope = PA 1 SLOPE 

Paved Approach 2 Slope = PA 2 SLOPE 

 

Go to Tools > Parametric Constrains, and set the following values: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Rerun model to see if correction has been made. 
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46) Fix #2) Sidewalks have kink on back edge. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To fix this issue we are going to add in extra sections using the “Key Station” tool. 

 

Go to Corridor > Key Stations, and set the following values: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try getting the station information from Plan.dgn MicroStation file. 

 

Rerun model to see if correction has been made. 
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47) Fix #2) Pavement has kink on back edge. 

 

 
 

To fix this issue we are going to add in extra sections using the “Key Station” tool. 

 

Go to Corridor > Key Stations, and set the following values: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try getting the station information from Plan.dgn MicroStation file. 

 

Rerun model to see if correction has been made. 
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48) Fix #3) Curb should transition down to a Fill Condition only past the sidewalk line.  To 

transition the template from a Curb to a Fill End Condition we are going to use a 

Parametric Constraint.  But first before we can setup the parametric constrain we need to 

modify the constraints in the Curb.  Open the template library and move the “Seek Curb” 

null point to edit curb. 

 

 
 

 

Below is a diagram of the constraints applied in the Curb section of the template: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To make this template transition down from a Curb to just an End condition we will need to 

adjust the constraint.   

 

 

 

Curb_Surf_Top_L 

Pvmt_Layer_1_Conc_T11_L 

Curb_Subsurf_Edge_L 

Curb_Surf_Back_L 

Curb_Subsurf_Back1_L 

Curb_Subsurf_Back_L 
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49) Delete both Constraints on the following points:  

 

Curb_Surf_Back_L, Curb_Subsurf_Back1_L, Curb_Subsurf_Back_L, Curb_Surf_Top_L, 

Curb_Subsurf_Edge_L 

 

Right Click and apply “Full Constraints” to the points in the direction of the arrows below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

50) Using a Value Equation modify the Curb_Surf_Back_L vertical constraint as follows:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Curb_Surf_Top_L 

Pvmt_Layer_1_Conc_T11_L 

Curb_Subsurf_Edge_L 

Curb_Surf_Back_L 

Curb_Subsurf_Back1_L 

Curb_Subsurf_Back_L 
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51) Modify the Curb_Surf_Top_L by switching “Horizontal” constraint to a “Slope” 

constraint as follows:  

 

  

 

 

 

 

 

 

 

52) Using a Value Equation modify the Curb_Surf_Top_L vertical constraint as follows:  

 

 

 

 

 

 

 

 

 

 

 

 

 

53) Using a Value Equation modify the Curb_Subsurf_Back_L vertical constraint as 

follows:  

 

   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



GEOPAK Road 3 Chapter 17 – Paved Approach Design 

5/10/12 Missouri Department of Transportation 17-27 

 

54) Modify the Curb_Subsurf_Edge_L point by switching the Horizontal Constraint’s 

parent point to the Pvmt_Layer_1_Conc_T11_L point:  

 

  

 

 

 

 

 

 

 

55) Modify the Curb_Subsurf_Edge_L point by switching Vertical Constraint’s parent 

point to the Curb_Subsurf_Back_L point:  

 

  

 

 

 

 

 

 

 

 

 

 

56) In order to adjust the curb width using a parametric Constrain we need to create a label 

for the point that controls the width of the Curb.  In this case it will be the 

Curb_Subsurf_Back1_L point. 

 

For that point use a label with the name of “Curb Width” 
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57) Move the “Seek Curb” point back over the origin and save the template Library. 

 

 

58) Back in Roadway Designer update the Template Drop by selecting “Synchronize with 

Library”. 

 

 

59) Select Tools > Parametric Constraints and define the following override values: 

 

Start Station End Station  Start Value  End Value 

18+26.22  18+26.42  -0.50   -0.01 

18+26.42  18+26.61  -0.01   -0.01 

 

18+45.55  18+46.75  -0.01   -0.50 

18+46.27  18+46.55  -0.01   -0.01 
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60) Using the Plan View Labeler tool and the J5P0100.tin extract elevation from the end of 

the Paved Approach.  To get the elevations from the mid section of the Paved Approach 

use either the components view in the dtm.dgn model or the proposed surface tin. 
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61) Using the Store Graphics tool store two chains that represents the edges of the Paved 

Approach: 

 

Job #    100   Job #    100 

Operator Code  CU   Operator Code  CU 

Chain Name   2+98_EDGE_RT Chain Name   2+98_EDGE_LT 

Beginning Point  600   Beginning Point 610 

Beginning Station   0+00   Beginning Station  0+00 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

62) Using the Store Graphics tool now store a chain that represents the CL of the driveway: 

 

 

 

Job #    100  

Operator Code  CU 

Chain Name   BH_DW_2+98_CL 

Beginning Point  310 

Beginning Station  0+00 
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63) Using the Vertical Alignment Generator to create profiles for the two chains just stored 

using the elevation information extracted using the Plan View Labeler. 

 

2+98_EDGE_RT (Use same name for profile) 

 

Station  Elevation 

0+00.00  742.10 

0+26.26  740.18 

 

 

2+98_EDGE_LT (Use same name for profile) 

 

Station  Elevation 

0+00.00  742.01 

0+26.27  739.96 

 

 

BH_DW_2+98_CL (Use same name for profile) 

 

Station  Elevation 

0+00.00  742.14 

0+26.25  740.03 

 

 

64) In the Corridor Modeling >  Geometry section, import the following chains and 

profiles: 

 

Chain   Profile    Drafting Standards 

 

BH_DW_2+98_CL BH_DW_2+98_CL  MoDOT_Proposed_Baseline 

2+98_EDGE_LT   2+98_EDGE_LT  EOP New 

2+98_EDGE_RT   2+98_EDGE_RT  EOP New 
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65) In Corridor Modeler > Create Template we are going to create a template called 

“Driveway Back” for the back portion of the Paved Approach with the following 

component and End Conditions: 

 

 

 

 

 

 

 

 

 

 

 

First right click on the “BH_Driveway_RT_2+98” folder and select New > Template 

 

Left Side:      Right Side 

 

Components:     Components: 

 

Pavement layer 1 Concrete   Pavement layer 1 Concrete 

 

End Conditions:      End Conditions:  

 

Fill Slope 2 (3:1)     Fill Slope 2 (3:1) 

 

*Notes 

 

a) Use Dynamic Settings, set the Step to 0.1 and toggle on Apply Affixes 

b) Adjust the pavement width to 8ft 

c) Merge vertical pavement line 

d) Save and close the Template Library. 

 

 

66) Reopen Roadway Designer and create a corridor named “BH_DW_RT_2+98_BACK” 

using the 2+98_CL chain and profile.   

 

 

67) In Roadway Designer go to Corridor > Template Drops and apply the Driveway Back 

template to the BH_DW_RT_2+98_BACK corridor.  

 

Station  0+00 

Interval 1ft      
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68) In Roadway Designer go to Corridor > Point Control and tie the edge of pavements to 

the two chains and profiles just created.  Set up the point controls as follows:  

 

Control Description Point    Horz. and Vert. Alignment 

 

Tie _LT   Pvmt_Layer_1_T1_L  2+98_EDGE_LT 

Tie _RT   Pvmt_Layer_1_T1_R  2+98_EDGE_RT 
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69) Open the dtm.dgn file and from Roadway Designer select Corridor > Create Surface  

 

Name:   BH_DW_2+98_RT 

Create Surface from: BH_DW_RT_2+98, BH_DW_2+98_BACK, BIGHORN 

Add Exterior Boundary: Checked On 

Components:  Check On 

 

` 
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70) Select Apply to create the Paved Approach model. 

 

Review Paved Approach model in dgn file. 


