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GEOPAK Road 3

Chapter 19 — Special Ditch Profiles

19.1 Exercise: Special Ditch Profiles

1) Open the plan.dgn.

2) Using Project Manager open the following project:

pw:\District CADD\Design\Randolph\J2P0203\project\J2P0203.prj

Projects Directory  Admin

- =] |

| : CADDVDesign\Randolph\J2P0203\project\

Filter: | *.prj Type: Project ™ I
Projects: Directories: =
2P0203.prj []

[projdbs]

€]

O]

[O1]

51 =
Job Number: 203 Unit System: English
Description:
Road 3 Special Ditch

Cancel |

Select ClsUser as the project user.

Project Users: 3.
Users
Elras: User Infa
ClzUsey
[0S User] Full Mame:
Class User
OF Code:
cu
Description:
QK I Cancel
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Chapter 19 — Special Ditch Profiles GEOPAK Road 3

3) From the GeoPak Road Tool Palette, select Corridor Modeling: Road
(7

oo

4) Open Corridor Modeling, load the J2P0203.rdp and then select the Open Create
Template icon.

I} corridor Modeling - pw: \District CADD\Design\Randc _ o] x|
Fle Tools
i 44 4
dob: [203 EX &-F-F
& Preferences Preferences
B DTM
O Geometry
B Plan Graphics Station Lock:  Increment ¥ |
B ALG Viewer Slope Readout: [50% |

Horizontal Chord Height: I 0.100000
Vertical Chord Height: I 0.050000

Template Library: | pw\District CADD\Design\Randolph\J2P0203\data\J2P0203.ITL Q

DTM Files Path: | pw\District CADD\Design\Randolph\J2P0203\datal Q

5) Navigate to the J2P0203 > End Conditions folder and right click to create a new
template called “Special Ditch Profile”.

[H create Template

Eile Edit Add Tools

Template Library:
25 pwilghpwise10:MoDOT\Documents\District CADD\Design\RandolphiJ2P0203\data\.J:
== Point Name List
1 Components
31 End Conditions
38 J2P0203
21 Components
‘23 End Conditions
== Fill (4:1) Cut (3:1)

= G
B Special Ditch Profile
LLROAD1

C1 ROUTEB3
3 Templates
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6) To create the new slope component, right-click on the Template Window and select Add
New Component > End Condition.

Name:
Style:

Style:
Priority:
Surface:

Special Ditch Profile
XS Ground Proposed

Target Type: Style Elevation

Special_Ditch_Right

7) Setup the Current Component portion of the Create Template dialog as follows:

1
<Active>
~Current Component
Name: [Special Ditch Profile Syle:  [xs_Ground_Proposed =
Target Type: ISter Elevation LI Priority: |1
=l [+[special_Ditch_Right [ Benching Count |5
™| Fromm Daturn: Ig_gggc
=t El tionh: NN
Horizontal Vertical 2R Elevallon IU-uwu
Offsets:  |0.0000 0.0000 RoundingLength 0,000

8) For the first point setup the Dynamic Settings dialog as follows:

Point Name: Ditch_Frslp_1 T (select from list)

Point Style: XS_Ground_Proposed

Apply Afhxes:  Disabled Dynamic S
Precisio

E

nnput: xy=0,0 X 93900 Step: [0.0100
y. [8100  sep: oooo |

Point Name: |Dtch_Frst_‘l_T |

Point Style: [XS_Ground_Propo ¥ |

[~ Apply Affixes

P = Joo

Set Dynamic Origin |

With your cursor in the xy=0,0 field, press the “Enter” key on your keyboard./
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Check for Interception:
Place Point at interception:
End Condition is Infinite:
Do Not Construct:

Point Name:

Point Style:

Apply Affixes:

Precision Input:

Enable

Enable

Enable

Disabled
Ditch_Frslp_1 B

XS Ground Proposed
Disabled

hs = 20,-1:6

9) For the second point setup the Dynamic Settings dialog as follows:

Dynamic
X |28.?3{}[]
Ve -5.5900
[v Check for Interception
[¥ Place Paint at Interception

[v End Condition is Infinite

[~ Do Mot Construct

Step: ID.D‘IDD
Step: ID.D‘IDD

X

Point Mame: |Dtch_Frst_‘l_B ;l
Point Style: [xs_Ground_Propo ¥ |
[~ Apply Affixes

[hs- x| |18

Set Dynamic Origin |

With your cursor in the hs = 20,-1:6 field, press the “Enter” key on your keyboard.

10) Right-click on the Current Template window and select Finish.

Setup the Current Component portion of the Create Template dialog as follows:

11) Create the next Ditch Component by Right-clicking in the Current Template window
and select Add New Component > End Condition.

Name: Flat Bottom Ditch
Style: XS Ground Proposed
Target Type: Surface
Priority: 1
Surface: <Active>
r Current Component
Name: IFIatBottom Ditch Style: IXS_Ground_Proposed LI
Target Type: ISurface LI Priority: |-|
Surface |L|<Active> [~ Benching Count IC
[ | Frarm Daturs: Ig_gggg
Horizontal Vertical Siep Elevatin: IC'CCCC
Offsets: 0.0000 0.0000 Rounding Length |D.DDDD
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X Step:  0.10
Y Step:  0.10

Dynanic < X

X 32.8200
Y- -4.3300

12) For the first point setup the Dynamic Settings dialog as follows:

Step: |n_n1nn
Step: |n_n1nn

PointName: | ~]
Point Style: [ -]
[~ Apply Affixes

| [} |

Set Dynamic Origin |

Start the Flat Bottom Ditch by place it’s first point on top of the Dtch_Frslp_1_B point.

Point Name:
Check for Interception:

End Condition is Infinite:
Do Not Construct:
Apply Affixes:

Precision Input:

Press the Enter key

Dtch_Bkslp_1 B (select from list)
Disabled (This forces this line segment to be placed)

Place Point at Interception: Disable

Disabled
Disabled
Disabled
hs = 8,0

With your cursor in the hs = 8,0 field,

Dynamic & X

X 18.0000 Step: ID.D'IDD
Y: -2.5800 Step: |u.u1uu

[~ Check for Interception

[¥ | Rlace Paoint at Interception

[~ End Condition is Infinite

[~ Do Mot Construct

Paint Name: |Dtch_Bks|p_1_B LI

Foint Style: IXS_Ground_Propoﬂ
Apply Affixes

[hs= =] Jso

Set Dynamic Origin |

13) To place the Back of Ditch bottom point, set the Dynamic Settings dialog as follows:
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Chapter 19 — Special Ditch Profiles GEOPAK Road 3

14) To place Slope-Stake point, set up the Dynamic Settings dialog as follows:

Point Name: Dtch_Bkslp_1 T (select from list)

Check for Interception: Enable

Place Point at Interception: Enable | Dynamic x|
End Condition is Infinite: Enable % 92400 Sep: [ooi0
Do Not Construct: Disabled ' ' L

Apply Affixes: Disabled Y: |ﬂ-m‘m Step: [0.0100
Precision Input: hs =5,25% [+ Checkfor Interception

[¥ Place Point at Interception

[v End Condition is Infinite

Toggle on End Condition is Infinite
\_/I_ Do Mot Construct

PointName:  [Dtch_Bksip_1_T v

ol " IXS_Ground_Propoll
[~ Apply Affixes
x| |525%

Ihs=

With your cursor in the hs = 5, 25.0%,

Set Dynamic Origin |
press the Enter key

15) Right-click on the Current Template window and select Finish.

16) Select File > Save to save the template library.

17) Test the End Conditions by selecting the “Test” button located under the Current
Template window.

Try and draw the Active Surface in the test window. You will notice the ditch does not
draw until you introduce the Special Ditch Profile Style Elevation.
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18) Next we need to account for cases where there will be not be Special Ditch Profile. To
do this drag and drop the following MoDOT standard End Conditions into our new
combined End Condition template. Be sure the Dynamic Settings are active and with a

step increment set to 0.01 [ ©

nght Side X -99529 Step: Ig_mgu
Y- 1.9685 Step: W

Fill Slope 1 (6:1) Point Name: | ~|
Ditch _
Point Style: IBarrier_Type_A_E'LI
[~ Apply Affixes
Ihs= LI I
Set Dynamic Origin |

19) Once again test the End Conditions by selecting the “Test” button located under the
Current Template window. A warning will be given about the template having end
condition priority conflicts.

x

WARNING: This template has End Condition Priority conflicts, Use
l % the "Check Priorities™ button to view and fix.
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20) Select Check Priorities on the right side of the Test End Conditions window.

Notice the Ditch_Frslp_1_T point is the point that has the priority conflicts.

End Condition Prig x|
Edit |

Close |

Dich Frslp 1T Help |
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21) In the End Condition Priorities dialog select Edit.

Notice that all the end conditions have the same priority number.

Priority  End Condition Component

|-| Special Ditch Praofile Cancel
|-| Ditch

Help
|-| Fill Slope

Put your cursor in each of the fields and notice the segments highlighting.

dd

The Special Ditch Profile is the most desirable condition, therefore set the priorities as
follows:

Priority  End Condition Component

|-| Special Ditch Profile Cancel
2 Ditch

| Help
|3 Fill Slope

Click OK, and then Close.

dd

22) Select the active surface and click “Draw” on the right side of the Test End Conditions
window. Move your cursor over the end conditions.

Next introduce the Special Ditch Profile by selecting the Special Ditch Profile style and click
“Draw”.

23) Close the Test End Conditions dialog. Save the Template Library by Selecting File >
Save.
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24) In Create Template navigate to the J2P0203/Road1 folder and remove the End
Conditions in the Roadl Two Lane Rural & Urban templates.

25) Set the following Dynamic Settings:

Dynamic Settir x
i |—13_15m Step: W
Y- -1.8400 Step: |u.u1uu
Point Name: I LI
Point Style: Bamier_Type_A 61+ |

[v Apply Affixes

C—

Set Dynamic Origin |

Template Options

—MNaming Options
Component Seed Name:

26) In Create Template go to Tools > Options and confirm the following Affixes are set:

i}

@ From Style Cancel

" Specify: I Preferences...
Point Seed Name: I LI Help |
([ Apply Affixes

Prefix Suffix

Left I |_|_

Right | [R
—Step Options
X |oo100 Y: |D.D‘|DD Slope: ID.DD%

19-10
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27) In Create Template use the following components to modify the Roadl Two Lane
Rural & Urban Templates:

End Conditions:

Left Side Right Side
Special Ditch Profile Special Ditch Profile
*Notes

a) In the Special Ditch Profile_L component of both templates change the Style Elevation
to Special Ditch Left.

b) Save Template Library

c) Close out of Create Template and Corridor Modeler.

28) Store the following 4 Special Ditch Profiles using separate COGO input command for
each:

STORE PROfile ROAD1-LT-1

VPI 1 Station 0+50 Elevation 820.20
VPI 2 Station 12+50 Elevation 820.00
END PROFILE

STORE PROfile ROAD1-LT-2

VPI 1 Station 16+00 Elevation 830.00
VPI 2 Station 25+80 Elevation 848.20
END PROFILE

STORE PROfile ROAD1-RT-1

VPI 1 Station 0+00 Elevation 821.00
VPI 2 Station 11+00 Elevation 818.37
END PROFILE

STORE PROfile ROAD1-RT-2

VPI 1 Station 31+30 Elevation 851.50
VPI 2 Station 35+10 Elevation 855.06
END PROFILE
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29) In order to target multiple profiles using a single style elevation the User will need to
create a chain that incorporates the station range of the special ditch profiles. In this case
we will offset (offset=0) the Road 1 baseline chain to create the reference chains for the

left and right side of the roadway.

F:' Store Offset Chain

=10l x|

Chain Name: | LT-DITCH-REF

Offset: | 0

Begin Paint- | 100

Begin Curve: | C100

Reference Chain

Chain Name: | ROAD1

| ! Begin Station: |0+00.00

End Station: | 35+10.08

Store Chain |

F:' Store Offset Chain

=10l x|

Chain Name: | RT-DITCH-REF

Offset: | 0

Begin Paint: | 200

Begin Curve: | C200

Reference Chain

Chain Name: | ROAD1

| ! Begin Station: |0+00.00

End Station: | 35+10.08

Store Chain |

19-12
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30) Back in Corridor modeling import the following Chain and Profiles:

Chain Profiles Drafting Standard
LT-DITCH-REF ROADI1-LT-1, ROAD1-LT-2 Special_Ditch_Left
RT-DITCH-REF ROADI1-RT-1, ROAD1-RT-2 Special_Ditch_Right
I} Corridor Modeling - pw:\District C _ o] x|
Fle  Tools
Job: [203 O\‘m@ﬁgﬁ
B Preferences Chain | Profile | Drafting Standard |
B D™ ROADT ROAD1EX.ROADIPR MoDOT _Baseline_Proposed d
& Geometry S RFEEASEERTESRR BT =Rrsetrme=Fromsed
5 Plan Graphics LT-DITCH-REF ROAD1-LT-1,ROAD1-LT-2 Special_Ditch_Left
B ALG Viewer RT-DITCH-REF ROAD1-RT-1,ROAD1-RT-2  Special_Ditch_Right X
Chain: [RT-DITCH-REF =l
Drafting Standard: |Special_Ditch_Right Ll
ROAD1-RT-2 J
ROAD1EX
ROADTPR |
Impart |

31) Open Roadway Designer (J2P0203.ird) and verify the active corridor is the Roadl
corridor. Next navigate to the template drop dialog (Corridor > Template Drops).

Update the Template Drops by selecting the drops first and then selecting “Synchronize with
Library”

Current Template Drops:

Revised In | Library

Station | Interval | Template Enable Transition
0 0000 pwiighpwise10:MoDOT\Do
50.0000 pw:\\ghpwise10:

0000 X pwiighpwise10:MoDOT\Do

l Synchronize with Library |l Edit | Delete |
#

Close the Template Drop Dialog
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32) Back in Roadway Designer review the section with the special ditch profiles

[l rRoadway Designer - pw:\\ghpwise10:MoDOT\Doc - |EI|£|
File Corridor  Superelevation Tools  Owverlay Tools
MEEET PEE B o= ||
330‘ """"""" e
8 . .
", : :
‘ az5 - \ Z/f-_l‘- i / """
GoEC 5 BZO e B [
e ..._____,‘-?-_u"-“ o
. . DT e . . . .
| 5-001u-uglg;-ﬂffu-uuzsouwd'-uuzsoul -5 0 0 50 1T
Ao Da =T +-E‘L| _l »
Corridor: [RoAD1 | swion: <] < |[o~0000 >0+ Process Al |
Active Surface: |J2p0203 LI ' Interval 50.0000 Process Visible Range |
Template: Roadl Two Lane Urban Display Mode: (@ Normal
(" Superelevation
~ Overlay
v

One thing you will notice very quickly is that it is very hard to visually determine if the
Special Ditch is properly drawing. To help with this we are going to make some addition
changes to the Special Ditch Profile End Condition.

33) Open the Template Library from within Roadway Designer by selecting the last icon
across the top.

Ol Roadway Designer - pw:\\ghpwise10:MoDOT |

File Corridor Superelevation  Tools  Owerlay Tools

LV E el T R i)
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34) Navigate to the J2P0203 > End Conditions folder and double click on the End
Condition called “Special Ditch Profile” to make it active.

[H Create Template

Eile Edit Add Tools

Template Library:

3 pwilghpwise10:MoDOT\Documents\District CADD\Design\Randolph\J2P0203\data\J:

== Point Name List
31 Components
3 End Conditions
23 J2P0203

1 Components

‘Z3 End Conditions

== Fill (4:1) Cut (3:1)

Ll L
= Special Ditch Profile
ul ADT

1 ROUTESB3
3 Templates

35) Make active the Dynamic Setting dialog with a step increment set to 0.01 or greater.
The first thing we are going to add to the end condition is a Special Ditch point.

Right Click and select Add New Component > Null Point and place a point called
“Special_Ditch” just above the Flat Bottom Ditch.

- B 200000 Step: [o0100
¥ |38 sep o |
" PointName: [Special Ditch =]
: Point Style: IBarrier_Type_A_ﬁﬂ
~- [~ Apply Affixes

Ca—

Set Dynamic Origin |

...................................

+ Special_Ditch

Wy Dtch_Frslp_1_B l.L‘ :
 Dtch_Bkstp_1_B

L e T e

- Dtch_Frsip_1_B1 i

Dtch_Bkslp_1_B1

10/25/13
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36) Within the Special_Ditch Point Properties modify the following constraints:

~Constraints
Constraint 1 Constraint 1 Constraint 2
Type: Vector-Offset Type: IVector-Oﬁset j INone j
Parent 1. Dtch_Frslp_1_B Parent’:  [Dich Fislp 18 v] *]
Parent 2: Dtch_Bkslp_ 1 B S +|
Value:  0.0000 - |pehBiei 18 x|
Value: ID.DDDD
. ~ Constraints
Constraint 2 Constraint 1 Constraint2
Type: Horizontal Type: IVector—Oﬁ’set j IHorizontaI j
Parent1:  Dtch_Frsip_1_B Parent  [Dich Fislp_1 8 v] #| [ochFespis <] #
Value: 4.0000
Pareni2  [Dich Brslp_1.8  v] #|
Value: |D.DDDD |4.DDDD j

To make sure that the Special_Ditch point is always in the middle of the flat bottom ditch we
are going to introduce a Value Equation by clicking on the “=" sign just to the right of the
horizontal value of 4.

Equation: = $(Dtch_Frslp_1 B)-$(Dtch_Bkslp_1_B)*-0.500
Type: Horizontal Difference
Parent 1: Dtch_Frslp_ 1 B
Parent 2: Dtch Bkslp_ 1 B
Multiplier: -0.5
Value Equation il

I=_$(Dtch_Frst_l_E]-$(Dtch_BksI|:|_ = |4 0K |
IHuriznntaI Difference LI Cancel |

|ptch_Frsip_1_B ~] # Help |
| Dtch_Bksip_1_8 ~| #

Multiplier: I.g_5

Now that we have added this point it will show up in all Cross Section where a special ditch
IS present.
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37) Next navigate to the J2P0203/Road1 folder and remove the End Conditions in the Roadl
Two Lane Rural & Urban templates.

38) Set the following Dynamic Settings:

Dynamic Settir

x -13.1500
\'E -1.8400

Point Name:

Point Style:

X
Step: |u.u1uu
Step: |u.u1uu

=l

[v Apply Affixes

Barrier_Type_A_61 j

C—

Set Dynamic Origin |

—MNaming Options
Component Seed Name:

i}

@ From Style Cancel

" Specify: I Preferences...
Point Seed Name: I LI Help |
([ Apply Affixes

Prefix Suffix

Left I |_|_

Right | [R
—Step Options
X |oo100 Y: |D.D‘|DD Slope: ID.DD%

39) In Create Template go to Tools > Options and confirm the following Affixes are set:

Template Options

10/25/13
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40) In Create Template use the following components to modify the Road1 Two Lane
Rural & Urban Templates:

End Conditions:

Left Side Right Side
Special Ditch Profile Special Ditch Profile
*Notes

d) In the Special Ditch Profile_L component of both templates change the Style Elevation
to Special Ditch Left.
e) Save and close the Template Library

41) Open Roadway Designer (J2P0203.ird) and verify the active corridor is the Roadl
corridor. Next navigate to the template drop dialog (Corridor > Template Drops).

Update the Template Drops by selecting the drops first and then selecting “Synchronize with
Library”

Current Template Drops:

RevisedIn | Library

Station Interval | Template Enable Transition

I Synchronize with Library |l Edit | Delete |

Close the Template Drop Dialog
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[l roadway Designer - pw:\\ghpwise10:Mc

File Corridor  Superelevation Tools  Owverlay Tools

HHz=med s & A

. [ —
e T
R e o

e,

42) Back in Roadway Designer review the section with the special ditch profiles

| 5-001u-uglgg.ﬁffu-uuzsouwd'-uuzsoul

= oHIEa
LI Station:

LI o Interval

Corrider: IROADT

Active Surface: |J2p0203

+-E‘L|

Template:

-5l ap 1

Process All |

<] <] [e~0000 BEIE]
50.0000
Roadl Two Lane Urban Display Mode:

Process Visible Range |

@ MNormal
(" Superelevation
~ Overlay

When a special ditch profile is applied a point will be place at the Chain and Profile location.
Therefore with this project the User should see a point at the mid point of our template when
a special ditch profile is active for a particular station.
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