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1 Site Design with GEOPAK 
COURSE OBJECTIVES 

GEOPAK Site is a fully functional 2D/3D modeling software, suitable for design projects ranging 
from Subdivisions, Apartment Complexes, Retail & Urban Complexes, to Commercial and 
Manufacturing Sites, Municipal Facilities, and Golf Courses, Parks and Recreation Areas.  The major 
benefit of GEOPAK Site is the ease with which you can create and revise your designs.   

During the Training we will explore the comprehensive set of civil engineering tools for development 
of sites: survey data management, COGO point management, site modeling, volume earthwork 
analysis, drainage design, plans preparation, and quantity takeoffs.  Based on MicroStation, the 
software combines site design tools with familiar MicroStation commands to provide a truly integrated 
solution for creation and manipulation of your designs. 

Using GEOPAK’s unique, interactive approach to design, we will rapidly create several design objects, 
such as buildings and parking lots created with MicroStation applications, and incorporate these into 
the design.  As the design is developed we will quickly be able to explore alternative design scenarios 
and edit working drawings using powerful, visual site modeling.  We will look at some of the unique 
capabilities of the software designed to enhance productivity like drag-and-drop terrain editing.  Once 
a feature is moved, the terrain model regenerates automatically.  When the design is complete we will 
be able to export design information to a variety of sources. 

GETTING STARTED 
GEOPAK Site is fully integrated with MicroStation.  Therefore, each and every MicroStation function 
can be used in conjunction with each and every GEOPAK tool. 

In order to start the GEOPAK software one needs to simply access a MicroStation design file (.dgn) by 
traditional methods.  To verify that GEOPAK is loaded, scan the MicroStation Menu Bar and look for 
an Applications pull down menu. 

To activate GEOPAK simply access the Applications menu and select 
GEOPAK > Activate GEOPAK.  By doing so you will now have access to 
all available tools from GEOPAK.  Subsequent MicroStation sessions will 
automatically activate GEOPAK. 

Now to see the list of GEOPAK Site tools access the Applications menu 
again and select GEOPAK SITE.  Then select the desired tool.  

To utilize the full potential of GEOPAK, usage of the GEOPAK dialogs may be interspersed with 
generic MicroStation commands.  In addition, numerous dialogs may be opened simultaneously.  To 
close most dialogs, one can simply click on the “X” in the upper right corner of the dialog.  Exiting the 
MicroStation design file automatically closes all GEOPAK dialogs. 
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GEOPAK USER PREFERENCES 

To provide maximum flexibility to the designers, GEOPAK provides numerous system parameters to 
allow the user to easily set or change the formats of decimals, stations, coordinates, units, etc.  These 
parameters are utilized by many of  the GEOPAK functions and can be changed at anytime.  The User 
Preferences dialog can be accessed from Applications > GEOPAK SITE > User Preferences.  The 
following dialog appears. 

The Working Directory identifies 
where the data files for a particular 
project can be found.  If a user does 
not want to work within a specific 
project, the field may be left blank, 
and GEOPAK uses the directory 
wherein the open MicroStation file is 
located. 

 

FEATURE PREFERENCES 

By clicking Feature Preferences, the following dialog is invoked and is utilized when visualizing 
COGO elements with assigned features.  As each element is about to be created, the feature of that 
element is searched for in the .SMD file.   

If a match is found, then the symbology 
for that feature is used.  If a match is not 
found and there is a feature named 
“default” in the .SMD file, then the 
“default” feature symbology is used.  If 
the feature is not found in the .SMD file 
and no “default” feature is defined in the 
.SMD file, the current MicroStation 
symbology is used. 

 

COGO PREFERENCES 

By clicking COGO Preferences, the 
following dialog is invoked. In this dialog, 
the Redefinition of Elements should be 
activated if the COGO overwriting feature 
is desired. 
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GEOPAK Site Tools 

 
GEOPAK SITE TOOLS 

As an alternative to the pull down menus invoking various GEOPAK tools, tool frames and tool boxes 
are supported within GEOPAK.  To activate the tool frame, select Applications > GEOPAK Site > 
GEOPAK Site Tools.  The tool frame is similar to the MicroStation main tool frame.  It is not 
resizable, but dockable.  Each icon in the tool frame is a tool box that one can “tear off” to become a 
“tool box.”  The individual tool boxes can be docked and resized.  There are eight tool boxes, with the 
following titles: 

• Site Modeler 
• Design & Computation Manager 
• DTM (Digital Terrain Modeling) Surface Tools 
• Cross Sections 
• Horizontal & Vertical Geometry 
• Plans Preparation 
• 3D Tools 
• Utility 

 

 

 

SITE MODELER 
The Site Modeler tool box (first column, top row) is depicted has 
three icons.  The left tool invokes the Site Modeler Project Wizard 
dialog as depicted below.  The second tool is the Active Chain 
Control.  The third tool is GPK Attribute tool and is utilized to 
identify the GEOPAK attributes assigned to an element, if any. 

 

 

If the bottom toggle is activated, so the Wizard is bypassed, the Site Modeler application menu bar is 
displayed. An optional tool box is available for all Site Modeler tools and is accessed from the Pull 
down menu Tool Boxes. 
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GEOPAK Site Tools 

 
DESIGN AND COMPUTATION MANAGER 

The Design and Computation Manager tool box 
(first column, second row) has two tools.   

 

The Design and Computation Manager (D&C 
Manager) is a tool that allows the user to 
standardize graphics elements for drafting and pay 
item quantities. 
The second tool is the Quantity Manager, a database 
application which manipulates and sorts quantities, 
creates a variety of reports, and cost estimates. 
A hierarchical database is used with the Design and 
Computation Manager. This database stores 
information concerning functional classification and 
display preferences for each feature and item used 
in a MicroStation file. This file is commonly 
referred to as the DDB file. 

 

Categories are used to group and classify the features and items used in creating construction drawings.  
Two common examples of these categories are Pay Items and Drafting Standards.  These two 
categories each contain sub-categories.  The sub-categories break down each classification into more 
specific sections.  For example, Pay Items may be broken into several additional categories such as 
Pipes and Lighting and Signals.  Pipes may be broken into many different categories representing 
various types of pipes and pipe features that may be used in the design of your project like Flared End 
Sections.  Within the category Flared End Sections, the different pay items for flared end sections may 
be listed. 

Each entry represents a specific pay item.  These entries are not categories, rather they are called items. 
Items can be identified by the various icons: 

• calculator (quantities calculations) 
• paintbrush (draw design elements) 
• report icon (default, pavement design, pavement markings, etc.) 
 

The database may also be password protected if desired. This can be used as a security measure to 
protect the integrity of the database file and ensure its consistent application on a statewide or company 
wide basis. 

 

GEOPAK Site I Copyright © 2003 Bentley Systems, Incorporated Do Not Duplicate 

5/16/2003 1-4 



GEOPAK Site Tools 

 
DTM (DIGITAL TERRAIN MODELING) SURFACE TOOLS 

The DTM tool box (first column, third row) depicted is a single 
icon, which invokes the Digital Terrain Modeling tool frame as 
depicted below.  

A Digital Terrain Model (DTM) represents the topography of a 
project in the form of a triangulated network.  The DTM can be 
drawn in a 2D or 3D file, and then rotated to see the existing 
surface of the project area. 
Digital Terrain Models can be generated from various sources 
including MicroStation Elements, survey data, photogrammetry 
data, GEOPAK cross-sections, and geometry data. 
  

Triangulation is a mathematical process applied to stored elevations points and stored elevations along 
DTM break lines to create surfaces.  The result of triangulation is the creation of a TIN file from which 
existing ground profiles and existing ground cross sections can be generated. 

CROSS SECTIONS 
The Cross Sections tool box (first column, fourth row) contains 
six tools.  These include (from left to right):  
• Cross Section Navigator 
• Draw Cross Sections 
• Draw Cross Section Tabular Data 
• Cross Section Labeling 
• Draw Patterns By Station Range 
• Draw Patterns From Cross Sections 

 

HORIZONTAL AND VERTICAL GEOMETRY 
The Horizontal and Vertical Geometry tool box (second 
column, first row) consists of nine tools (left to right): 
• COGO 
• Graphical COGO 
• Horizontal Alignment Generator 
• VPI Based Vertical Alignment Design Tools 
• Component Based Vertical Alignment Design Tools 
• Store Graphics 
• Auto Store Graphics 
• Ground Profiles 
• Legal Description Editor 
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Additional Modules 

 
 

PLANS PREPARATION 
The Plans Preparation tool box (second column, second 
row) contains eight tools (from left to right): 
• Plan View Labeling 
• DP Station Offset 
• Draw Transition 
• Profile Labeling 
• Draw Profiles 
• Draw Profile Tabular Data 
• Plan / Profile Sheet Composition 
• Tables 

 

DRIVE THROUGH 
The Drive Through tool box (second column, third row) depicted contains the 
single tool - Drive Through. 

 

UTILITIES 
The Utilities tool box (second column, fourth row) depicted contains two 
tools - the GEOPAK Text Editor and Geotechnical tools. 
  

ADDITIONAL MODULES 

GEOPAK DRAINAGE 

 

GEOPAK Drainage is a comprehensive system for designing and analyzing storm drain systems, 
which can leverage many roadway design features to create a seamless information exchange to the 
drainage design process.  A GEOPAK Drainage project may contain multiple drainage networks; each 
comprised of any number of topologically connected drainage areas, inlets, pipes and ditches.  The 
GEOPAK Drainage workflow closely mirrors conventional design processes allowing for the design of 
the surface collection system (i.e. drainage areas, inlets) then the design of the subsequent conveyance 
system. 

GEOPAK Drainage is extremely flexible, in that the hydraulics designer can create and manipulate 
elements of the system, while simultaneously seeing the effects.  Interactive dialogs and design 
visualization make the process easy to learn and efficiently produce results.  Manipulations and 
redesign are accomplished quickly and easily, whether it’s moving a single inlet or developing an 
entire network.  At any time during the process, customized reports can be generated to provide hard 
copy outputs.  
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Additional Modules 

 
Roadway alignments, vertical profile gradelines, and digital terrain models created as part of the design 
process may be used throughout GEOPAK Drainage to provide pertinent information to drainage 
design.  All drainage components feature interactive graphical placement tools for easy spatial 
definition of the drainage system. Visualization tools in GEOPAK Drainage for networks, drainage 
components, and computations all but eliminate the tedium of thumbing through pages of computer 
output to evaluate whether the system is functioning adequately.  The visualization allows for 
immediate evaluation of the drainage system. 

GEOPAK SURVEY 

GEOPAK Survey is a comprehensive software package for the collection and processing 
of survey data for roadway and site projects. 

The software is fully integrated with MicroStation CAD software to permit true 
interactive processing.  With GEOPAK, the CAD drawings become one of the records 
for the project affording true “what you see is what you get” (WYSIWYG) functionality.  
However, the survey database is a compendium of information stored in double precision 
accuracy.   

The package is full functioned; covering most every aspect of a survey project.  
Comprehensive tools are available from data collection to the feature / element editing to 
creation of a DTM.  In addition, GEOPAK includes a number of design tools that 
enhance the right-of-way plans production process.  These tools draw labels, produce 
tables, generate legal descriptions, and perform other tasks that you might normally not 
expect from a survey software package. 

 

Each component of GEOPAK Survey functions together and interacts with each other.  However, there 
are six primary modes of accessing the software. 

• Survey Manager, including powerful processing and editing tools. 
• Coordinate Geometry tools. 
• Digital Terrain Modeling package. 
• Geodetic Conversion tool. 
• Interactive tools accessed while editing a MicroStation file including labeling and tabulations. 
• Legal Description Editor 

WATER AND SEWER 

 

GEOPAK Water and Sewer is extremely flexible, in that the designer can create and manipulate 
elements of the system, while simultaneously seeing the effects.  Interactive dialogs and design 
visualization make the process easy to learn and can efficiently produce results.  Manipulations and 
redesign are accomplished quickly and easily, whether it’s moving a single node or developing an 
entire system.  The Conflict finder tool enables the designer to identify potential problems where 
sewer, water and utilities conflict.   

Roadway alignments, vertical profile gradelines, and digital terrain models created as part of the design 
process may be used throughout GEOPAK Water and Sewer to provide pertinent information to water 
and sewer design.  All water and sewer components feature interactive graphical placement tools for 
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Additional Modules 

 
easy spatial definition of the water and sewer system. The visualization allows for immediate 
evaluation of the water and sewer system.  

A Water and Sewer system is composed of two components:  nodes and lines: 

• Nodes: A node is a point with a defined location.  The location may be in Cartesian coordinates 
(x,y) or in curvilinear coordinates (station, offset).   

• Lines: A line represents a linear feature depicting a path connecting two nodes, running from 
upstream to downstream.  The path may be straight line or curvilinear (along any graphics 
element).   
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2 Digital Terrain Modeling 
CHAPTER OBJECTIVES 

In this chapter, you will learn more about: 

• Extraction of input data 
• Generating a triangulated irregular network (TIN) model 
• Displaying and drawing TIN features 
• Analysis tools 

INTRODUCTION 
GEOPAK offers Digital Terrain Modeling components that employ advanced state-of-the-art 
algorithms and are rich in functionality.  GEOPAK DTM features are not limited to triangulated 
models.  Features include: lattice models, contours, interactive editing of TIN files, integrated pads, 
merged models, surface-to-surface volumetric analyses, thematic analyses, drainage tools, and various 
utilities. 

The GEOPAK DTM tools frame can be accessed by selecting the DTM tool 
from the GEOPAK Site tool frame or from the pull down menu Applications > 
GEOPAK Site > DTM Tools.   
The DTM Menu tool box (first column, top box) is a single tool, which invokes 
the GEOPAK DTM menu bar as depicted below. 

 
 

EXTRACTION OF INPUT DATA 
Digital Terrain Models can be generated from a wide range of data sources including MicroStation 
elements, survey data, ASCII data and GEOPAK cross sections.  An Extract utility is included to 
facilitate the retrieval and formatting of MicroStation graphical elements.  These elements can be 
classified as contours, random points, break lines, voids, islands, and boundary points.   

One of the GEOPAK Extract utilities analyzes the MicroStation elements and formulates 
interpretations.  For example, 2D circular arcs can be segmented with elevations interpolated from spot 
elevations located on the circular arcs and/or upon adjacent elements.  Text strings can be interpreted 
in terms of either the text origin or in terms of the value represented by the text string.  A "765.71" text 
string can be interpreted such that the X and Y coordinates are derived from the origin of the text string 
and the elevation derived from the "765.71" value represented by the text string.   
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Extraction of Input Data 

 
One sample Extract Graphics dialog is depicted below. 

 

Another GEOPAK Extract utility can create DTM input files from various types of ASCII files 
including: TEX, THD, RT40 and CAiCE. 

 

The GEOPAK Survey Manager dialog can prepare an input file for DTM processing directly from 
survey data.  This input file distinguishes between random spot elevations, contours, voids, boundary 
polygons, break lines and other features.  Points stored in a GEOPAK coordinate geometry database 
may also be utilized via the Survey Manager to create a DTM input for spot elevations. 

In total, GEOPAK provides the capability to create DTMs from a wide array of data sources. 

� Extract Graphics 

1. Open the MicroStation design file ..\Data\Geo\Site\Site1\Chapter2\Contours.dgn. 

2. Select the DTM Tools tool frame. (Applications > GEOPAK Site > DTM.) 

3. Click the DTM Menu Tool.  (first tool, first row). 
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Extraction of Input Data 

 
4. Select the Extract Graphics tool (DTM menu:  Extract > Graphics). 

 

5. Enter the Extract Graphics information 

File Name: ground.dat 

File Type: ASCII 

File Open: Create 

Feature: Contours 

Mode: Extraction 

LvNames Enable 

6. Click Match, then select and accept one of the contour lines.  

Notice that all the lines highlight.   

7. Click Display.   

This shows all contours that matched the level name of the one selected.  The picture below 
shows the minor contours as being highlighted (light grey) but the major ones not due to the 
fact that they are on a different level name. 

 

8. Click Match.   
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Generating a Triangulated Model 

 
9. Select and accept one of the major contour lines. 

10. Click Select Levels  to the right of Lv Names.  

The dialog displays the level names that were matched in the previous steps. 

 

11. Verify the Level Mask is set to Exist_Cont_Major and Exist_Cont_Minor. 

12. Click OK. 

13. Set Extract to View 1. 

14. Click the MicroStation Fit View tool from the MicroStation View Controls tools in the lower 
left corner of View Window 1. 

15. Click Apply. 

16. Close the Extract Graphics dialog. 

 

GENERATING A TRIANGULATED MODEL 
The triangulated model is the core of the DTM process.  All subsequent merged models, lattice models 
and calculations are derived from this core triangulated model.  The GEOPAK triangulated model is 
created using state-of-the-art algorithms.  Therefore, processing time is minimal.  The presence of 
state-of-the-art algorithms will be apparent the first time you see the triangulated model display on the 
screen.  Triangles appear from left-to-right in an ordered array; not in a randomized manner as is 
typical with standard Delauney based algorithms.   

The resulting triangulated model is stored in a binary file that stores the data for the triangulated model 
in a triangulated topological network format.  This means that the interrelationships between individual 
points and individual triangles are all recorded in the binary file.  This efficient binary database format 
permits rapid extrapolation of cross sections and other information derived from the triangulated 
model.   
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Generating a Triangulated Model 

 
The triangulated model is generated from binary or ASCII input (DAT) files created by the following 
methods: 

• DTM Extract utility 
• Survey Project Manager 
• Cross Section Reports within GEOPAK Road (DTM Input and DTM 3 Proposed) 
• Collected in the raw ASCII DAT format 
 

The binary DAT file format facilitates faster 
processing since the point and/or break line data can 
be read much faster from a binary file than from an 
ASCII file.  However, other than reduced read time, 
there are no functional differences between the 
ASCII and binary files. 
The Build Triangles dialog creates a binary file 
containing the triangulated model. 
  

� Build Triangles 

1. Select the Build Triangles tool. (DTM Menu: Build > Triangles.) 

 

2. Enter the Build Triangles information. 

Data File ground.dat 

TIN File ground.tin 

Dissolve Option:    Side 

Side Length:          300 

3.  Click Process. 
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Display and Draw TIN Features 

 
DISPLAY AND DRAW TIN FEATURES 

GEOPAK supports a wide variety of options to provide the user with maximum flexibility when 
drawing and displaying DTM Features, all within a single dialog.  The source data can be the DAT 
file, TIN file or Lattice file.  Features can be display only or drawn into the MicroStation file.  Features 
for part of a model can be displayed or drawn by the placement of a MicroStation fence prior to 
processing. 

One sample Load DTM Feature dialog is depicted below. 

 

Different DTM Features can be loaded, then displayed or drawn, depending on the type of source file.  
As the file is selected, the DTM Features automatically change to reflect the selection. 
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Display and Draw TIN Features 

 
� Drawing Contours and Triangles 

1. Select the Load DTM Features tool. (DTM Menu:  Load > DTM Feature) 

 

2. Enter the GEOPAK Load DTM Feature Information. 

Load File TIN 

File ground.tin 

Load Extent 

Display Only Enabled 

Graphic Group Enabled 

3. Double click the Triangles row to turn Display on.   

This can also be accomplished by highlighting the Triangles row and clicking Item On (right 
side of list box).  

4. Double click on the element graphic to set the Triangle Display parameters.  

Level Default 

Color 3 

Weight  0 

Style 0 
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Display and Draw TIN Features 

 
5. Select the Contours row and turn Display on.   

 

6. Click Read. (Lower Right) 

This establishes the minimum and maximum elevation of your TIN File. 

7. Enter the contour information in the bottom of the dialog. 

Minor Interval: 2 

Major Interval: 10 

Smooth Contours: None 

8. Individually highlight the Major Lines, Major Label, and Minor Lines items and turn 
Display on. 

9. Set display preferences for each item. 

Major Lines: Level=Default, Color=0, Style= 0 Weight=1, Display=ON 

Major Labels: Level=1, Color=2, Style=0, Weight=0, Display=ON 

 FT=0, Th=5.0, Tw=5.0, Decimal=0 

 Distance Between Labels=100.0 

Minor Lines: LV=1, CO=1, Weight=0, Style=0, Display=ON 

10. Click Load. 
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Editing Triangles 

 
EDITING TRIANGLES 

A myriad of tools to interactively edit TIN models are located in the TIN Edit Tools dialog. The 
triangulated model can be dynamically edited in terms of adding, deleting or moving spot elevations.  
Break lines can be added, draped or deleted.  As editing is initiated, resultant triangles, contours, flow 
arrows, and voids are optionally displayed "on the fly." 

The list box on the left side of the 
dialog contains the editing options.  
As each tool is selected, the right side 
of the dialog dynamically changes to 
reflect the current tool.  All these 
editing features dynamically show the 
changes as they occur.  In addition, 
the changes are not written 
permanently to the triangulated model 
until the user selects the Save button. 
This allows the User the option of 
saving their modifications (Save) OR 
rejecting the modifications (Undo To 
Last Save). 

 

� TIN Editing Tools 

1. Select the MicroStation Saved Views tool (MS: Utilities menu > Saved Views). 

2. Select EDIT1 and click Apply. 

3. Select the Edit Triangles tool.  (DTM Menu: Edit > Triangles). 

Note Both the TIN Edit Tools dialog and Display Settings dialogs open. 
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Editing Triangles 

 
4. Set the Display Settings. 

Tin File: ground.tin 

Edit View: 1 

Display Triangles Enable 

Display Contours Enable 

Minor Interval 2 

Major Interval 10 

Display Hull Enable 

Display Voids Enable 

5. Set the Color, Weight, and Style of the enabled features to any desired settings. 

6. Click OK. 

7. Select Swap Line. 

 

8. Click Id Line and select and accept the triangle line labeled number 1 in View 1 of 
MicroStation. 

Once selected, the triangle and others associated with it highlight.   

9. Continue to select and accept the other numbered triangle lines. 

The triangles and contours update as shown. 
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Digital Terrain Model Analysis Tools 

 
10. Click Save to commit the changes to the ground.tin file.   

11. Close the Tin Edit Tools dialog. 

DIGITAL TERRAIN MODEL ANALYSIS TOOLS 
The Analysis tool box contains ten tools.   
These are (from left to right): 

• Height 
• Profile 
• Volumes 
• Elevation Difference 
• Slope Area 
• Themes 
• Drainage Tools 
• Visibility  
• Trace Slope Path 
• DTM Camera 

 

The Analysis Tools are an excellent way for the User to gain instant answers from the TIN surface for 
a wide range of analysis questions. 

We will now use 2 of these tools to provide a quick demonstration of the type of data that is available. 

HEIGHT TOOL 
GEOPAK offers a tool by which the plan view 
coordinates; elevation, and slope of the triangulated 
model can be interrogated at any location.  The 
Height dialog automatically updates for each 
successive user defined data point. 

 

� Verifying Elevations 

1. Select the MicroStation Saved Views tool (MS: Utilities menu > Saved Views). 

2. Select ANALY and click Attach. 
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Height Tool 

 
3. Select the Height tool.  (DTM menu: Analysis > Height). 

 

TIN File Ground.tin 

Show Contour Enable, Red 

Show Triangle: Enable, Green 

Show Flow Arrow: Enable, Blue 

4. Click DP. You can now data point at any location where you would like to know the 
elevation. 

5. Data point in several other locations to show the elevation, contour and flow direction 
information. 

6. Click Dynamic and move your cursor over the dataset. 

The cursor point values are constantly updated.   

 
The cross hair and flow arrow indicate the current cursor position. 

7. Reset when finished (normally right mouse button).   

8. Close the GEOPAK Height dialog. 
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Profile Tool 

 
PROFILE TOOL 

The Profile tool enables the user to draw a profile at any location based on a MicroStation element 
draped onto a triangulated model.  

 

The main dialog has three tabs: 

• Selection - TIN file, Model or Object specifications, profile element symbology and create legend 
button. 

• Profile - profile definition and placement buttons and preview window. Allows the User to set the 
alignment where they would like the surface profile extracted from and then provides a preview of 
the surface profile. 

• Preferences - Profile and grid scales, text parameters, elevation and station ranges. 
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Profile Tool 

 
� Creating a Site Profile  

1. Select the Profile tool.  (DTM tool frame: Analysis > Profile). 

 

2. Select the TIN File by clicking Files and selecting ground.tin. 

Set the element symbology by double-clicking the sample line graphic. 

3. Click OK to close Set Feature dialog. 

4. Click Add List Item (right side of dialog).   

5. Click Profile tab. 

6. Click Place Element and data point (twice) to define the beginning and endpoints of the 
desired profile.   

The extracted profile is displayed in the dialog. 

 

7. Click Reset. (Right mouse button) 
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Profile Tool 

 
Note To extract another profile, click the Place Element button again and data point in MicroStation 

View 1. 

8. Click the Preferences tab. 

9. Fill out the dialog as shown below.   

Note The Elevations and Stationing values are automatically read directly from your TIN file and do 
not need to be changed.   

 

10. Switch back to the Profile Tab to see the grid. 

 

11. (Optional) Click Place Profile and data point in the desired location in MicroStation View 1.   

12. Close the GEOPAK Site Profile dialog. 

13. Exit MicroStation. 
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3 GEOPAK Site Modeler 
CHAPTER OBJECTIVES  

In this chapter, you will learn more about: 

• Site Modeler project components 
• Site Modeler main menu 
• Project menu options 

INTRODUCTION 
The GEOPAK Site Modeler enables fast, dynamic development of site models and easy management 
of the many changes that occur on site projects.  It captures design intent as users work and provides 
immediate visual feedback.  The software allows users to perform engineering modeling within a 
Digital Terrain Model (DTM)—without merging or extracting graphics into the DTM.  Many 
traditionally cumbersome processes are reduced to one step: for example, you can dynamically move a 
building pad in a single drag and drop step—without measurement, clipping, merging, and placement 
steps. 

The Site Modeler offers unprecedented flexibility in interactively working with site designs without 
the limitations of traditional iterative steps.  No cumbersome triangle or point editing is necessary.  The 
software maintains existing ground and provides full control over defining elevations and side slopes 
and balancing cut-and-fill.  Analytical tools are included to afford powerful evaluation of site designs. 

GEOPAK Site integrates digital terrain modeling with interactive 3D site design.  The software allows 
you to incorporate design features in the model while maintaining existing ground.  Move building 
pads. Change pond elevations.  Extend retaining walls.  Trim curbs.  Resize berms.  The Site Modeler 
automatically regenerates the DTM, yet retains full integrity of the models and the original DTM.  
There is no need for merging or extracting graphics into the terrain model. Easy, on-the-fly functions 
let you change elevations and side slopes and balance cut-and-fill. You can add features such as 
contours to the model as needed to define your design.  Tools are supported for evaluating the site 
design and producing drawings and site models. 
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Site Modeler Project Components 

 
SITE MODELER PROJECT COMPONENTS 

A GEOPAK Site Project is comprised of three components: Elements, Objects and Models. 

GEOPAK SITE ELEMENTS 

Elements are any MicroStation graphical element assigned an elevation and DTM Feature (breakline, 
boundary, contour, etc.) with GEOPAK Site tools.  They can be placed into a 2D or 3D design file 
utilizing any generic MicroStation command, except Make or Drop Complex Chain.  Once the 
elements are drawn, elevations are assigned with GEOPAK Site tools.  At any time, they can be 
moved, copied or otherwise manipulated.  Once a group of elements is drawn to the designer's 
satisfaction, they can be defined as an object. 

Elements can be modified at any time during the site design process.  To move the location of an 
element in the X-Y plane, utilize any MicroStation command except Create Complex Chain. 

Let's review several types of modifications, their impact on element elevation(s) and their results on 
the site element. If the User takes advantage of the Site Element Association feature, the element 
elevations will be recreated per their original definition. If this feature is disabled or not used, then the 
following will apply to the elevations of the site elements. 

Note All modifications support selection sets and fence operations. 

Extend / Shorten 
Line 

Use generic MicroStation commands to shorten or lengthen.  The Site 
Modeler holds the elevations of the original element and re-proportions 
them. 

Insert Vertex Elevation of new vertices is interpolated between adjacent vertices. 
Move Element Maintains all vertices at the original elevations. 
Scale Maintains the elevations at all vertices. 
Rotate Maintains the elevations at all vertices. 
Mirror Maintains the elevations.  If there are duplicate vertices due to the mirroring, 

the second elevation is utilized. 
Delete Deletes the element from the Site Modeler object. 
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Site Modeler Project Components 

 
GEOPAK SITE OBJECTS 

Site Objects are collections of Site Elements that are grouped together for the purposes of side slope 
definition, merging into the Model, volume quantity calculations or as logical design features.  

Site Object examples include: 

• Parking lots 
• Buildings 
• Ponds 

Each object can contain an unlimited number of elements.  Objects contain their own attributes. 

• Side slopes - defines the interrelationship between the object and the model.  Cut and fill side 
slopes are automatically generated around the extent or boundary of each Object in the model.  
The boundary is automatically determined from the extent of the elements contained in the object.  
Side Slopes can be as basic as a single cut or fill slope from the edge of a building to existing 
ground, or intersecting slopes between two objects, i.e., a building and a parking lot.   

• Quantity Depth - In order to do excavation quantities, an object may have an associated quantity 
depth.  For example, a building may have a quantity depth of two master units which represents 
the amount of granular material required beneath the building.  These quantities can be easily 
changed and quickly computed. 

• Display Settings - A specific set of visualization settings can be applied to each object to control 
the display symbology of each. 

• Maximum Triangle Length – Defines the maximum length for the Object of an external (outside) 
triangle. The triangulation must follow this rule while still including all element data. 

Other things to consider during the creation of Objects: 

• A Site Model is created by merging each of the triangulated Objects specified in the Model FIFO 
list together in the order they are listed within the list.  The designer determines which slopes 
control the merging process by means of a FIFO list.  The first Object, called the Base Object, is 
the starting surface.  Each object is then merged "on the fly" in the order listed.  To change the 
controlling slopes for intersecting, move objects up and down in the Model FIFO list. 

• Site Objects can be raised and lowered in their entirety to easily evaluate design alternatives.  
• The feature types of elements used within an Object have an effect on how that Object will be 

triangulated. Failure to use Boundary elements as the outer most elements of an Object may lead 
to undesired triangulation result. Similarly, using Boundary elements inside an Object may also 
cause an undesired triangulation result. Layout, geometry and DTM feature type of the member 
elements should always be considered. The boundary of the Object is determined from the extent 
of the elements and their feature type. 

 
Objects can be modified at any time during the site design process.  The following are methods of 
modification: 

• Add / remove elements from the object 
• Modify Object Slopes 
• Raise or lower the object 
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Site Modeler Project Components 

 
GEOPAK SITE MODELS 

A Site Model is comprised of an unlimited number of objects arranged based on the “First In – First 
Out” (FIFO) list which dictates the merging order and a base object (i.e., existing ground).   

Note The designer does not have to merge, as it's done automatically "on the fly."  As a new object 
is added to the model, its resultant slopes, contours, etc., can be displayed on the screen.   

Models can be modified at any time during the site design process. This can be accomplished in three 
methods: 

• Add or remove objects from the model 
• Change the base object, i.e., update/change existing ground terrain data 
• Changing the order of Objects in the FIFO list 

The workflow involved in using the Site Modeler is designed to expedite the creation of digital terrain 
models while providing enough flexibility to easily accommodate design changes. The following 
outlines getting started with the Site Modeler. 

• Establish base design planimetrics in 2D or 3D MicroStation design file. This includes design 
graphical features that define the DTM (e.g., centerlines, curbs, berms, ponds, property line etc..). 

• Obtain existing information, such as original ground or survey information, that serves as the basis 
of the initial design. 

• Review the geometric layout of design features and determine a preliminary concept for the type 
and configuration of Site Objects to be used in the design. 

• Start Site Modeler New Project Wizard. 
• Create an empty Model. 
• Import the base design information into the Model. 
• Select a location to begin the design. 
• Create a new Site Object that describes the starting feature. 
• Begin defining the elevations of the Site Elements and adding them to the Active Object. 
• Continue to create Site Objects and Site Elements as needed. 
• Evaluate and analyze the Site Model and adjust Site Elements, Site Objects and Model. 
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Site Modeler Main Menu 

 
SITE MODELER MAIN MENU 

GEOPAK Site is invoked from within a MicroStation design file.  If the Project Wizard dialog is 
bypassed (by activation of the Don't Show this dialog at Startup), the GEOPAK Site Modeler main 
menu bar (along with the Active site Object Control) is automatically displayed.  An alternate method 
of invoking the menu bar is completion (without clicking Cancel) of the Project Wizard.   

 

Each menu selection accesses GEOPAK Site project information, feature placement and tools 
necessary to complete a GEOPAK Site project.  Tool frames and toolboxes are also supported for all 
functions and are accessed via the Tool Boxes pull down.  The current Site working directory and 
Project File are displayed in the header of the menu bar. 

PROJECT MENU OPTIONS 

The Project Menu selections are utilized for creating new GEOPAK Site projects, opening existing 
projects, saving projects, establishing the project Preferences, Importing and Exporting data in and out 
of the project file, and exiting the Modeler. 

When working on a project, frequent use of the File > Save pull down is important.  Any changes 
made in the project are not recorded in the GEOPAK Site File (GSF) file unless a File > Save or File > 
Save As operation is executed.  Hence, any power interruption or other malfunction will result in loss 
of data that can be avoided through the judicious use of the File > Save tool. 

Each GEOPAK Site project contains a set of Preferences. The preferences control the project 
tolerances, visualization settings, update settings and save settings. 

GEOPAK Site Modeler supports two operations to import data into a site project: 

• Data 
• 3D to Object 

In addition, it supports five operations to export data from a site project: 

• Visualization to DGN (Contours, Triangles, etc) 
• Model / Object (Creates DAT & TIN Files) 
• To COGO (Creates Points in the COGO Database) 
• To COGO Profile (Creates a Profile in COGO) 
• Drape Elements 

To exit GEOPAK Site, the designer may utilize the File > Exit tool on the Project menu. When exiting, 
GEOPAK Site Modeler prompts for saving the current project. 
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Workshop: Creating a Site Modeler Project 

 
WORKSHOP: CREATING A SITE MODELER PROJECT 

� Creating a Project 

In this workshop we will set up a project in GEOPAK Site Modeler to include Project Preferences.  
We will import our previously created Digital Terrain Model from the DTM Workshop in Exercise 2. 

1. Open the file C:\Data\Geo\Site\Site1\Chapter3\Siteplan2D.dgn. 

2. Select the Site Modeling Tool (Applications > GEOPAK Site > Site Modeler). 

 

3. Enable Create New Project. 

4. Click Next>. 

 

5. Enter the project file.  (..\Data\Geo\Site\Site1\Chapter3\Siteplan.gsf). 

6. Click Next. 

 

7. Toggle on Create a New Model. 

8. Key in Tower as the Model Name. 
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Project Preferences 

 
PROJECT PREFERENCES 

GEOPAK Site Modeler supports a wide array of user defined Preferences which enables the designer 
to set project specific options, or a larger organization to set parameters to maintain standards.  Each 
GEOPAK Site project contains a set of Preferences and they remain with the project. 

The general groupings of Options are 
displayed in a list box in the left side of the 
dialog. The right side displays parameters 
for the highlighted Option.  As different 
options are selected in the list box, the right 
side of the dialog changes dynamically to 
reflect the parameters for the highlighted 
Option.   

 

The Options and very brief descriptions are listed below. 

Tolerances Tolerance and stroking options used in the creation of Site Elements. 
Visualization Variety of element symbology and display options 
Objects  Standard List of Object Types and default values for Object parameters  
Updating Toggle for automatic updating and setting a Working Boundary 
Save Automatic save and backup options 

On the right side of the dialog, OK and Cancel commence closing the dialog and storing the 
preferences, if required. 
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Project Preferences 

 
TOLERANCES 

 

Linear Stroking Linear Stroking provides additional interpolated elevation values at 
intervals along linear elements based on the value set. 

Curve Stroking Curve Stroking provides additional interpolated values at intervals 
along curve elements.  Segmenting the curve using small chord 
segments creates these interpolated values.  The maximum distance 
between the chord and the original arc will not exceed the value 
specified in the dialog. 

B-Spline Plan Stroking Similar in effect to the Curve Stroking, but this value is applied to B-
Spline elements. 

B-Spline Profile Stroking Used exclusively for the Edit Profile tool. The Stroking tolerance set 
determines how many points are returned from the Edit Profile tool to 
the Site Elements after a proposed profile is accepted. 
This value should be set to the minimum acceptable number of 
vertical elevation decimal. For example, if the User supplies 
elevations to the construction team to 2 decimal places, the value set 
should be 0.001. 

Maximum Triangle Length This value is used to determine what triangles should be removed 
from the outside of an Object. External triangles whose external edge 
is longer in length than the Maximum Triangle Length are dissolved. 

Elevation Decimal The Elevation Decimal controls the number of decimal places 
displayed on the elevation labels for points within the objects and 
models. 

Note Stroking is the process of automatically inserting points along Site Elements by interpolating 
new points from the linear and curved sections of the data. 
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Project Preferences 

 
VISUALIZATION 

A variety of user-defined parameters are supported to provide the designer with maximum flexibility in 
Visualization.  These parameters are briefly detailed below. 

 

View Active 
Object 

When activated, the current object listed in the Active Site Object Control 
dialog is displayed. The Object will maintain the display settings during view 
updates and changes. All visualization settings are derived from the definition 
of the specific object that is active. 

View Active 
Model 

When activated, the current model listed in the Active Site Object Control 
dialog is displayed.  The Model will maintain the display settings during view 
updates and changes.  All visualization settings are derived from the definition 
of the specific model that is active. 

Smooth Contours Contour smoothing is controlled by one of three options.  
None provides no smoothing. Three Point provides minimal smoothing by 
rounding the contour corner at each triangle vertex. B Spline analyses the entire 
triangulated network (Model or Object) and provides a complex algorithm to 
display contours as B-Spline graphical elements. 
The B Spline option is much more processor intensive then the other options 
and it is recommended that this option not be employed until the User is ready 
to draw completed contours into the DGN file. 

Construction 
Elements 

The element symbology for Site Elements created in the modeler that are not 
contained in a Site Object.  It may be desirable to establish Site Elements and 
their elevations purely as a reference or to construct other elements. These Site 
Elements are not needed in the Site Objects themselves and are considered 
Construction Elements.  Site Elements contained in Site Objects are displayed 
according to the object visualization of the object to which they belong.  The 
Construction Elements are displayed using these settings in the preferences. 
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Project Preferences 

 
MODEL VISUALIZATION 

 

The Model Visualization button provides access to the default specifications for all features that are 
available for display in Site Models including triangles, boundaries, and vertices.  These symbology 
will be applied to all models created subsequent to setting these.  All symbology controls, the sample 
line and text graphics in this case, can be set by double clicking the sample graphic and using the Set 
Feature dialog shown below. 

 

Additional options can be invoked by clicking the right mouse button over these sample controls. 
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Project Preferences 

 
OBJECTS 

This option is utilized for creation, deletion, and manipulation of the library of Object Types.  The 
information includes the Object Type and Naming Prefix, visualization settings for that Object type 
and default Object side slopes for that Object type. 

 

This list box displays all Object Types within the active project.  Default types delivered with 
GEOPAK Site Modeler are:  Parking, Building, Pond, Roadway, Lot, Openspace and Ground. 

These Object Types assist in organizing and categorizing design features, controlling standard 
symbology and establishing defaults for Objects created. 

The group box portion of the dialog titled Object Details allows the user to set Visualization of the 
highlighted Object Type.  Each Object Type may have its own settings, providing maximum flexibility 
to the user to display only specified parameters for the particular Object Type.  Note its similarity to 
the Default Model Visualization dialog. 
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Project Preferences 

 
After the Preferences have been set and saved, any new Objects of a particular type that is created 
within the Site project will obtain the default settings. The defaults are applied when an object is 
created and remain in effect until the slopes are modified by editing the Object. Note that any specific 
Objects slopes can be modified at any time.  

Slopes are applied around the boundary of the entire object and are generated as the intersection from 
the Object boundary to the Model.  Three Default Side Slope options are supported: 

• No Slopes 
• Cut - Fill Slope 
• Cut-Fill Table 

Corner Options can be specified to generate either Rounded or Straight slopes around corners of 
Objects and can be projected Radial or Planar.  Supported options for Cut and Fill specifications are: 

• Slope run:rise 
• Slope rise:run 
• Slope % 
• Slope Unit / Unit (ft. / ft. or meter/meter) 

Simply specify the desired slope. 

UPDATING 

 

When the Auto Update Model is active, the model is updated whenever a change is made to an 
element, object or to the FIFO list of the Active Model.  As Models get larger, it may not be necessary 
to update the Model on every single edit.  Deactivating this toggle will speed up the modifications that 
are being performed. The toggle must be re-activated or the Model processed for the Model/Object 
visualization to reflect any changes made. 

Element Association provides a history of how Elements were created. Elements that are created based 
on another Element or Object can always maintain the same dependency to the items referenced during 
their creation.  

When activated (On), Element associations are enabled.  When the reference Element or Object is 
modified, the dependant Element will automatically update/recreate itself.  Turning the toggle off 
(OFF) disables the associations. 
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Workshop: Setting Site Modeler Preferences 

 
SAVE 

 

When the Automatic Backup option is activated, a backup file is always created (in the project 
directory with a *.bak extension) when the project is opened. 

The Automatic Save Option saves the GEOPAK Site project file (.GSF) to the disk at the user 
specified interval.  Automatic Save intervals include 1, 2, 5, 10, & 30 minutes. 

WORKSHOP: SETTING SITE MODELER PREFERENCES 

� Defining the Project Preferences 

1. Click Set Project Preferences. 

 

2. Select Tolerances and set the parameters. 

Linear Stroking 25 

Curve Stroking: 0.05 

B-spline Profile Stroking 0.001 

Maximum Triangle Length: 100 

Elevation Decimal: 3 
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Workshop: Setting Site Modeler Preferences 

 
3. Select Visualization and set the parameters. 

 

View Active Object Enable 

Curve Stroking: Enable 

Smooth Contours None 

4. Click Model Visualization. 

 

5. Enter the Default Model Visualization information. 

Triangles  Disable 

Boundary: Disable 

Vertices: Disable 

Major Contour: 
Elev Interval: 
Label: 

Enable 
10 
Enable 

Minor Contour: 
Elev Interval: 
Label: 

Enable 
2 
Enable 

 

To change the symbology of each item, double click on the sample graphic to open the Set 
Feature dialog.  Make the appropriate changes and then click OK.  

6. Click Apply. 

7. Select Objects. 
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Workshop: Setting Site Modeler Preferences 

 
8. Select the Object Type Ground and set the Visualization preferences as shown.   

 

To change the symbology of each item, just double click on the sample graphic.  Once the 
appropriate changes have been made click OK to save your changes and return to the main 
dialog.  

Hint Use the same visualization settings for Object type “Ground” as were used for the Model 
Visualization. 

9. Click Modify (next to the Object Type/Naming Prefix list). 

10. Click Yes when prompted to modify existing objects. 
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Workshop: Setting Site Modeler Preferences 

 
11. Select the Object Type Building and modify settings as shown.  

 

Triangles  Disable 

Boundary: Disable 

Vertices: Disable 

Major Contour: 
Elev Interval: 
Label: 

Enable 
1.0 
Disable 

Minor Contour: 
Elev Interval: 
Label: 

Enable 
0.2 
Disable 

 

12. Click Modify to accept the visualization changes and Yes to the Alert dialog. 

13. Click Default Slopes.   

 

14. Change the default Cut and Fill slopes to 4:1 (run:rise). 
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Workshop: Setting Site Modeler Preferences 

 
15. Click Modify. 

You may want to modify other Object Types in order to get the desired display preferences. 

16. Select Updating.  

 

17. Enter the Updating information. 

Auto Update Model Enable 

Element Associations On 

18. Select Save. 

 

19. Enable Automatic Save and set to 10 Minutes. 

20. Click OK. 
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Workshop: Setting Site Modeler Preferences 

 
� Completing Project Set-up 

1. Click Next. 

 

2. Enable Open Object Import Wizard. 

3. Click OK. 

 

4. Enable TIN File. 

Note We created a TIN file (ground.tin) in a previous exercise. We will select TIN File as 
the Import Data Type option and use the previously created TIN file.  

5. Click Browse to select ground.tin. 

6. Click Next. 

 

7. Set Select Object Type to Ground.   

By selecting the Ground Object Type, the Enter New Object Name field is automatically 
populated.   

8. Click Next. 

 

 

Use as Base Object for Enable 

Model Tower 
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Workshop: Setting Site Modeler Preferences 

 
9. Click OK.  

This initiates the visualization of the Active Model (Tower) and the Active Object (Ground 
1) into View 1 of MicroStation. 

10. Save the site project. (Site Modeler: Project>Save). 

ACTIVE SITE OBJECT CONTROL TOOLBAR 

Upon opening an existing GEOPAK Site Project or creation of a new project, the Active Site Object 
Control dialog is activated. 

 

The tool bar is resizable and dockable and remains open throughout the entire Site Modeler session. 

Display View When the toggle to the left of Display View is activated, the Active Model 
and/or Active Object are displayed, based on their respective visualization 
settings in the view selected. 

Model Shows the User what Model is currently active.  Selection of any other 
model from the list changes the active model.  When the model is selected, 
all Objects that reside in the models FIFO list will be available in the Object 
listing to the right.  When <All Objects> is selected, all objects in the project 
are listed.  When <Orphan Objects> is selected, all objects that currently do 
not belong to a model are listed. 

Object Shows the User what Model is currently active. The Object list changes 
dynamically based on the Model selection. 

ID?     

 

Clicking ID, and then identifying any Site Modeler element highlights the 
selected element and invokes the Select Object dialog depicted below. 
Clicking OK makes that Object Active. 

 

Center Window On 
Object 

 

Centers and fits the Active Object in the Display View. 
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Workshop: Setting Site Modeler Preferences 

 
MAIN TOOLBAR 

The Tools menu selections provide access to all Tool Boxes.  The Main Tools tool frame is depicted 
below and accesses the other tool boxes. 

Each icon in the tool frame (except single tools) is a tool box that one can "tear off" to become a "tool 
box."  The individual tool boxes (except those which have single tools) can be docked and resized.  
There are six tool boxes, with the following titles (order down first column, then down second 
column): 

• Project Tools 
• Object Tools 
• Analysis Tools 
• Element Tools 
• Model Tools 
• Exit 

 

If the function of an icon is not apparent to the user, position the cursor on the icon.  A detailed 
description is displayed in the status bar and a tool tip (flyover) appears. 

� Saving and Exiting the Project 

1. Close GEOPAK Site Modeler (Modeler: Project > Exit). 

2. Click Yes to save the current project. 

 

3. Click No to the Lock Elements alert. 
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4 
CHAPTER OBJECTIVES 

In this chapter, you will learn more about: 

• Model menu 
• Objects menu 
• Elements menu 
• Designing with Site Modeler 

INTRODUCTION 

GEOPAK Site is invoked from within a MicroStation design file.  If the Project Wizard dialog is 
bypassed (by activation of the “Don't Show this dialog at Startup”), the GEOPAK Site Modeler main 
menu bar (along with the Active Site Object Control) is automatically displayed.  An alternate method 
of invoking the menu bar is completion (without clicking Cancel) of the Project Wizard.  The 
GEOPAK Site Modeler main menu bar is displayed. 

 

Tool frames and toolboxes are also supported for all functions and are activated from the Tool Boxes 
pull down.  The current Site Modeler working directory and Project File are displayed in the header of 
the menu bar. 

MODEL MENU 
The Model menu selections provide the mechanism to add, edit and delete the various 
elements that comprise a Model. This includes display parameters, merging order (FIFO), 
and Display options.  Each of these tools invokes a dialog wherein the specific Model 
information can be added, edited or the entire Model deleted.  

 



Model Menu 
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EDIT MODEL 

The Model editing options provide the mechanism to change the list of Objects contained in the Model 
and to modify the display setting of the Model and its Objects.  At the top of the dialog the active 
Model Name is displayed, however, any Model in the current site project may be selected.   

The three Edit Model options are: 

• FIFOList - "First in, first out" list. 
Determines the merging order of 
all objects in the active Model.  In 
addition, tools are provided to 
manipulate the list. 

• Display Model - a complete range 
of element symbology and text 
parameters utilized for 
visualization for the active model. 

• Display Objects – Additional 
controls for displaying the Object 
Types that make up the Model 
simultaneously and provides 
clipping options for the Model and 
Base Object. 

 

 



Model Menu 
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FIFO FUNCTIONALITY 

The FIFO (First in, First out) List contains the list of all the Site Objects contained in the selected 
Model and the order in which the Objects are to be merged. This Object list is processed from the top 
to bottom. Starting with the Base Object, each Object is merged into the Model in this order – top one 
first, then the second one, etc. Any time a change is made to a Site Object or Site Element contained in 
the Model, the Model is reprocessed.  

The Site Preferences contain an option to disable this automatic updating should this immediate 
feedback be unnecessary or grow too time consuming as the model grows. Since Objects can easily be 
added and removed from the FIFO list, certain time savings can be achieved by removing Objects not 
needed for the current design process and can be added back at the end or at such time as their impact 
is needed. 

The process used in the creation of the final triangulated Site Model is as follows: 

• The Base Object starts as the initial state of the Model. 

• The first Object in the FIFO list is retrieved. 

• The boundary of the Site Object is determined from the extent of all the Site Elements contained 
in it. 

• The Side slopes associated with that Object are applied around the boundary down or up to the 
Model depending on the cut fill situation. 

• This Object is then merged into the Model. 

• This new state of the Model with the first Object and its side slopes merged into the base Object 
becomes the initial sate of the model for the next Object in the FIFO list and the process is 
repeated for all the objects in the list. 



Model Menu 
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DISPLAY MODEL TAB 

The Display Model Tab is utilized to control the visualization settings of the active Model.  The dialog 
is depicted below and contains specifications for features displayed within the Model including 
triangles, boundaries and vertices.  When the toggle to the left of the feature is active the element is 
displayed.  When inactive the feature is not displayed.  To the right of each feature is the level and 
element symbology. 

 

DISPLAY OBJECTS TAB 

 

Object Type List box containing all Object Types in the current model.  If the User clicks the box to the left of 
the Object Type in the list, an “eye” icon is displayed. All objects of the activated type are 
displayed with their visualization settings. 

Clip Objects from Model When activated, this clips every object out of the model prior to display.  It is good for showing 
proposed vs. existing. 

Display Base Object  This toggle indicates whether the Base Object should be displayed with its visualization 
settings. 

Apply  Applies any changes that have been made to this tab. 



Objects Menu 
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OBJECTS MENU 
The Object menu selections provide tools to Add, 
Edit, Copy, Move, Raise, Lower, or Delete an 
Object. Also allows the User to draw Profiles and 
Cross Sections directly from the Site Objects. 

 

EDIT OBJECT 

The Object editing options provide the mechanism to modify an Object's properties, side slopes, 
display settings and to display Slope Indicators.   

 

OBJECT PROPERTIES 

Under the Properties Tab the Object Name for the object to be edited is displayed in the dialog.  A 
description can be entered if desired.  Quantity Depth is the vertical depth beneath an Object where the 
earthwork volume is adjusted to compensate in the total volume.   

Note that this depth is applied to the limits of the Object's elements and is optional 
when Volumes are computed.  Three tools are supported within the Elements group 
box.  Highlight and/or window center Site elements within the Active Site Object.  
Add previously created Site Elements to the Active Site Object and Remove Site 
Elements from the Active Site Object.  

 



Objects Menu 
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OBJECT SLOPES TAB 

The Slopes options dictate the type of side slopes generated from the outer extent or boundary edge of 
the Object.  These slopes are applied when the Object is placed into a Model and computed from the 
Object to whatever the state of the Model when it is merged.  When the Display with Object toggle is 
activated, GEOPAK includes the display of slopes in the Object symbology. 

 

There are four slopes options available:  No Slopes, Cut - Fill Slope, Cut-Fill Table, Dynamic Slopes.  
Corner Options can be specified to generate either Rounded or Straight slopes around corners of 
Objects. 

DISPLAY OPTIONS TAB 

The Edit Object Display tab is 
utilized to control the visualization 
settings of the Object displayed in 
the dialog.  The dialog contains 
specifications for features displayed 
including triangles, boundaries, and 
vertices.  When the toggle to the left 
of the feature is active, the element 
is displayed.  When inactive the 
feature is not displayed.  To the 
right of each feature is the level and 
element symbology. 

 

SLOPE INDICATORS TAB 

The Slope Indicators Tab is used to set the display preferences of Object Slopes Indicators. 
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COPY OBJECT 

The copy tool is useful when the object is 
comprised of numerous elements which 
need to be copied.  When invoked, the 
dialog depicted opens. 

To copy an object, simply key in the Elev 
Diff (0 if there is none), then click Start 
Move / Copy and identify the object to be 
copied.  A second data point defines the 
revised location.  

Note When the Make Copy toggle is not activated, the dialog dynamically changes to a Move 
Object dialog. 

MOVE OBJECT 

To move an object, simply key in the 
Elev Diff (0 if there is none), then click 
Start Move / Copy and identify the object 
to be moved.  A second data point defines 
the revised location. 

 

Note When the Make Copy toggle is activated, the dialog dynamically changes to a copy Object 
dialog. 

RAISE/LOWER OBJECT 

Raise/Lower Object tool can be used to change 
the elevation of an entire object by raising or 
lowering it.  Note the value is in terms of master 
units, i.e., feet or meters. 

 
 

DELETE OBJECT 

The Delete Object tool deletes the entire object 
from the project file and (if desired) all the Site 
elements that are part of the Object. 
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DRAW PROFILES 

The Draw Profile tool enables the 
User to draw several profiles from a 
variety of sources simultaneously. 

• Surfaces: Allows the User to 
draw “ground” profiles for the 
specified Chain based on the 
Model, the Model Base, a 
specific Object, an Object and 
it’s slopes or a TIN file.  

• COGO: Allows the User to 
draw profiles for the specified 
Chain from profiles stored in 
COGO. 

• Projection: Allows the User to 
draw profiles that are based on 
another COGO Chain or 
Survey Chain into the current 
Chain’s Profile Cell. This is 
very useful when designing 
alignments or elements that 
run “parallel” to other roads 
or survey features. 

 
 

 



Objects Menu 
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DRAW CROSS SECTIONS 

The Draw Cross Sections tool draws existing ground cross sections (within a 2D MicroStation design 
file) utilizing a GEOPAK binary DTM file, Site Object or Site Model.  
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ELEMENTS MENU 
The fundamental components in the GEOPAK Site Modeler are Site Elements. Site Elements are 
simply MicroStation graphics (2D or 3D) that have been assigned elevations using one of these Site 
Element tools.  

 

GEOPAK Site Modeler supports a wide variety of tools that when combined with generic 
MicroStation commands create and modify elements. These operations include: 

• Creating / editing elements 

• Changing element feature types 

• Change Element Associations 

• Raising/Lowering of elements 

• Copy parallel existing elements 

• Modifying elements 

• Deleting element Z 

• 3D elements 

• Composite Sections 

• Edit Profile 

• Element Information 

Note The 3D Element is active only within MicroStation 3D design files. 

ELEMENT FEATURE TYPES 

All Site Elements require a Feature Type to describe the way in which to process and interpret the 
element within the digital terrain model. 

A Boundary is used to constrain the external boundary of the object or model.  For example, an L-
shaped building can be defined as a boundary so that no triangles are created within the internal corner.  
If the elements are defined as breaklines, the limits of the object would result from the convex area of 
all the elements contained in the object. 

  

Feature types can be modified at any point in the design to create the desired results.  It is often 
desirable to leave features as break lines until the object design is near completion and then the 
required elements can be specified as boundaries. 
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Break Lines designate linear features such as edges of buildings, parking lots and other pavement.  The 
generated triangles never cross a break line; rather the edges of the triangles are coincident with a 
break line. 

A Contour is an element of constant elevation.  The generated triangles never cross a contour; rather 
the edges of the triangles are coincident with a contour.  

A Void delineates an area of no data or obscured area and is defined in a series of points forming a 
closed element. 

A Hole is extremely useful when the base object surface (i.e., existing ground) is desired within an 
object.  For example, an area of existing within a building footprint is to be landscaped and remain at 
the original ground elevation, while surrounded by a building pad. 

SELECTION SETS 

Many of the Element tools utilize selection sets, therefore, a generic discussion is warranted into the 
operation and use of selection sets.  Two options are supported: the MicroStation Power Selector or 
GEOPAK selection tools within each dialog. 

USE POWER SELECTOR 

When active, the MicroStation Power Selector is utilized.  
To invoke, click Select Elements in the Element Selection 
group box. 

 

 

GEOPAK SELECTION TOOLS 

Selection commands can be utilized without the Power Selector.  
The leftmost button is Select Elements.  Simply click and then 
select the desired elements.  To select multiple elements, depress 
<Control> on the keyboard while selecting.   

 

After utilizing numerous MicroStation commands, the highlighted elements may not be highlighted.  
To display previously selected elements, click Reselect Elements (center of the three) and the 
highlighted elements are displayed again in the specified color.  To remove all selected elements from 
the selection set, press the Reset Selection Set button (rightmost of the three).  The color of the selected 
elements is set with the color picker on the far right side of the group box.  Note that Element Selection 
must be invoked through these selection icons.  While the Site Modeler uses a selection set, it must be 
started through the use of these commands, not the MicroStation Selection set commands. 

Hint To turn off and on handle display, use the Disable Edit Handles setting on the Preferences 
dialog box, Operation category (Workspace > Preferences). If handles are disabled, when you 
select an element it is highlighted with a specified color. 
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NEW/EDIT SITE ELEMENTS 

One of the primary tools within Elements is the New / Edit Elements tool.  When invoked, the dialog 
depicted below is displayed. 

 

The dialog contains five main options:  Element, Point, Section, Side Slope and Display.  When a tab 
is selected, the dialog dynamically changes to reflect the selection.  The fields below are displayed 
regardless of which tab is selected. 

Add to Active 
Object 

When toggled ON, created and/or edited elements are automatically added to 
the active object. The Active Object is displayed on the New/Edit dialog. 

Current Object Located between the Add to Active Object and Apply, the active Object can be 
selected. 

Apply Commences the processing.  This includes redrawing of the elements, 
inclusion into the active object and, if the active object is part of a model, 
reprocessing of the model. 

ELEMENT TAB OPTIONS 

The element options provide for the primary mechanism for the creation and redefinition of Site 
Elements.  When the Element tab is selected, the dialog depicted below is displayed. 
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Six tools to assign or modify elevations are provided.  As each option is selected, the title bar as well 
as the left side of the dialog dynamically changes to reflect the selection.  

Slope/Offset from Site 
Elements  

 

The Slope/Offset from Site Element option is used for assigning 
elevations to Site Elements by placing the elements at an optional slope 
and offset height from existing Site Elements. In calculating the 
elevation from the existing Site Element, a projection is performed 
from the new Site Elements to the reference based on the minimum 
distance from the element to the existing reference element. 

Radial From Existing 
Points 

 

The Radial From Existing Point option is useful for establishing the 
elevation of elements relative to a specific point within another Object 
or Model. The tool uses a reference data point elevation and an optional 
slope and offset height to compute the elevation for the new element 
vertices. 

Along Element From 
Existing Point 

 

The Along Element from Existing Point tool assigns the elevations 
along an element at a constant slope and/or offset height from a data 
point.  The data point will be projected to the element and the distance 
along the element from this point to the vertices will be used in 
conjunction with the slope and offset height to compute the elevation of 
the new element vertices. 

Drape on Model / Object 

 

The Drape on Model/Object tool is used to establish the elevation of 
Site Elements relative to the elevations contained in a model or object. 
It can be useful to set the elevation of elements relative to existing 
ground or another object. 

Constant Elevation 

 

Placing elements at a Constant Elevation may be utilized when the 
desired elevation of an element is known. It can be used to set the 
elevation of a building or even place a contour into an object.  If the 
computed contours within an Object do not exactly match the desired 
results, simply draw the contour wanted and then place in the Object as 
a Contour Feature at a constant elevation. 

Alignment 

 

The Alignment tool is used to create Site Elements from a GEOPAK 
horizontal and vertical alignment.  The alignments must have 
previously been created using one of the GEOPAK Coordinate 
Geometry features or the Horizontal and Vertical Alignment 
Generators.  Once a Site Element is created from an alignment, the 
curbs, edges of pavement, etc., can be created using one of the other 
Site Element Creation tools based on this alignment.  Typically this 
would be the Slope/Offset from Site Element. 
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POINT TAB OPTIONS 

When the Point Tab is selected within the New/Edit Site Element dialog, the dialog changes as 
displayed below. 

 

Point elements can be created and added to Objects to refine the surfaces or edit the vertices of exis ting 
Site Elements.  When placing points, the Site Modeler can detect when an existing Site Element is 
snapped to. If there is an existing vertex at the snapped location it will be reset to the new value.  If no 
existing Site Element is detected, a MS point graphic element will be added to the design file and the 
Active Object. 

If a point is snapped to a Site Element, but not to a natural vertex of the graphic element, the Site 
Modeler will actually insert the point along the Site element. This point is now considered dependent 
on the site Element and as the element is modified or moved, so will the point. 
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Five options are supported within the Point tab.   

 

As each option is selected, the title bar as well as the left side of the dialog dynamically change to 
reflect the selection.  These options include: 

Constant Elevation 

 

Used to add a point or edit a vertex of an existing Site element at a 
constant elevation. 

Drape on Model / Object 

 

The Drape on Model / Object option is useful for placing or editing 
points and placing them at an elevation relative the elevation in a 
Model or Object. 

Slope from Site Element 

 

The Slope from Site Element option is used for placing points at a 
given slope from a Site Element. 

Min. / Max. Elevation at Slope 
From Elements 

 

The Min. / Max Elevation at Slope from Elements option is used for 
placing points at the minimum or maximum elevation computed 
from a set of Site Elements.  It can be used to insure a low point or 
high point amongst elements. 

Slope from Point to New Point 

 

The Slope from Point to New Point option is used to create a point 
at a given slope to an existing point in an object or model. 
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SECTION TAB OPTION 

Sections are special Site Elements that are created and attached to existing Site Elements to define a 
constant vertical and horizontal offset from the existing element(s).  It can be used to attach curb and 
gutter sections to the edge of pavement, retaining walls or benching sections. 

 

Section Elements is another feature where the MS graphics are actually created by the Site Modeler in 
the active MS symbology. Section elements cannot be directly edited; they are locked and connected to 
the elements on which they are placed.  As the Site Elements containing the section are modified, 
moved, deleted or elevations reassigned, the Section Elements are automatically updated accordingly. 

Provisions for assigning sections to multiple Site Elements at once, even disconnected Site Elements, 
are available.  This capability is provided by gathering all the Site Elements selected for section 
placement and assigning the Direction or which side to place the section element.  The Site Modeler 
may not be able to logically determine a direction given very complex sets of Site Elements.  Suitable 
messages are provided in this case and a smaller selection set of Site Elements should be used. 

CREATING SECTIONS 

The following is the procedure for creating Section Elements. 

• Select the Reference Elements to place the section on. It is recommended that the Power Selector 
be used in Single element select mode. If the elements are chosen in an order which would easily 
accommodate chaining the elements together the resulting sections will be simplified. 

• Determine if a cell or table of horizontal and vertical offset is desired and populate the dialog. 

• Click Set and set the direction – this will indicate the side of all the elements for which to place 
the Section Elements. It indicates the positive horizontal offset direction. 

• The Site Modeler attempts to chain all the elements together and then determine the side based on 
a single data point.  If the element selection does not easily facilitate this process, it may be 
necessary to hit any key and reselect a smaller set of elements. 

• Once the Site Modeler has chained the elements together, a dynamic display will indicate which 
direction would correspond to positive offsets. 

• Set the Feature Type and click Apply. 

• The Section Elements are created and added to all the Objects that contain the Site Elements for 
which they were placed. 
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MANIPULATING SECTIONS 

The Manipulate Section has three tools, as detailed in the table below. 

Reverse Section  

 

Flips the sections of the currently selected Site Elements to the other side of the 
Site Elements. 

Remove Section  

 

Removes the sections from the selected Site Elements. Since Section Elements 
are locked, this is the only way to remove them from graphics. 

Query Section  

 

Queries a Site Element to see if it that currently has a section attached and, if it 
does have a section attached, populates the offset table with the values from the 
attached section. 

SIDE SLOPES TAB OPTIONS 

This tab creates Site 
Elements based on a 
variety of slope options.  
It utilizes the stroking 
tolerance of the original 
element during creation.  
One typical application is 
creating bench sections.   

This is a very powerful 
tool that has a large 
number of setting options 
to control the created 
element. 
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DISPLAY TAB OPTIONS 

 

Element symbology is supported in this dialog for the following elements: 

• All Elements 

• Active Model Elements 

• Active Object Elements 

• Construction Elements 

Activate the desired elements option.  Options are also supported for: 

• Selected Elements Only 

• Temporary Elements Only 

Both of these toggles may be active simultaneously.  Reset Display redisplays the Elements within the 
selected group in the desired symbology. 

CHANGE SITE ELEMENT FEATURE & ASSOCIATIONS 

These two element tools can be used to change the feature type of a previously defined site element or 
group of site elements as well a turn on or off the site element associations. 

                      



Elements Menu 

 

 
GEOPAK Site I Copyright © 2003 Bentley Systems, Incorporated Do Not Duplicate 

5/16/2003 4-19 

RAISE/LOWER SITE ELEMENTS 

This tool is utilized to change the elevation(s) of an existing 
element or group of elements.   

 

MODIFY SITE ELEMENTS 

A variety of tools are supported to modify existing site 
elements.   

The tools (from left to right) are: 
• Site Element Extend Line 
• Site Element Extend Arc 
• Site Element Extend to Intersect 
• Site Elements Extend Both to Intersect 
• Site Elements Fillet 
• Site Elements Chamfer 

 

All tools function identically to their generic MicroStation counterparts, except the Extend to Intersect 
and Extend Both To Intersect.  These two commands have elevation options to be considered.  The 
Modify Element Tools are only available within a 2D MicroStation Design File. 

DELETE SITE ELEMENTS 

This tool is used to delete a Site Element that is associated with 
a MicroStation Element. 

It does not delete the MS graphical element – just the Site 
Modeler link to that graphic. 

 

 

3D ELEMENT 

Elements placed at the correct X, Y, Z coordinates within a 
MicroStation 3D design file can be utilized in the Site Model by 
using this tool.  
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COMPOSITE SECTION TOOL 

The Composite Section Tool is used to create multiple Site Elements that will be grouped into a Site 
Object.  This tool can be useful for creating Roadways, Channels, Levees, etc.  

 

EDIT PROFILE 

The Edit Profile tool allows the User to select a single Site Element or a 
series of connected Site Elements and redefine the element/elements 
elevations. 

After the element/elements are selected a profile representation of their 
current elevations is created and placed into a profile cell. Now the User 
can place vertical tangents and curves to redefine a portion or all of the 
profile. The redesigned portions of the profile are then returned to the 
original Site Elements. 

We track the extent of each plan view graphic, which enables us to send the 
new elevations back to the correct elements. 

The selected elements do not need to be in the same Object. 

This is a very powerful tool. 
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SITE ELEMENT INFORMATION 

The Information Tool can be used to display 
coordinate information, Feature type, stroking 
information, Member Objects and Site Element 
Association information.  Most importantly 
however, the Information Tools can be used to 
quickly change element information when 
needed.  The dialog shows one tab of the 
Information Tool dialog.  Any vertices of the 
Site element can be modified and returned to the 
Site Element to achieve the desired result. 
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WORKSHOP: DESIGNING A SITE MODEL 
During this workshop we will learn how to use Site Modeler to assist us in creating a final site design 
surface.  The workshop consists of several exercises.   The exercises will address creating and 
manipulating Site Elements, Site Objects and Site Models within our GEOPAK Site Project. We will 
gain considerable experience in how to create Roadways, Buildings, Parking Lots, Ponds and 
Retaining Walls.  After the successful completion of the workshop in the previous Section, we should 
have a GEOPAK Site Model called Tower, which at this point is composed of our existing ground Site 
Object, Ground1. 

: Opening an Existing Site Project 

1. Open the MicroStation file ..\Data\Geo\Site\Site1\Chapter4\Siteplan2D.dgn. 

2. Select the Site Modeling tool (Applications > GEOPAK Site > Site Modeler> Site Modeling). 

 

3. Enable Open Existing Project. 

4. Click Browse and select ..\data\geo\site\site1\Chapter4\siteplan.gsf. 

5. Click OK. 

The conventional design process may typically start by creating the various access roads first.  
However, for the purpose of this training session, we will start by creating a building.  This will allow 
us to explore some basic tools within GEOPAK Site Modeler before moving on to more sophisticated 
tools that will be used during roadway design. 

: Creating a Building Object Type 

We are now going to create a building pad and add the building pad to our Site Model.  We have a 
previously placed MicroStation shape that represents the footprint of our building.  We will assign an 
elevation to this element based on the current existing ground conditions; place the element in a 
building object that, in turn, will be placed into our model.   

1. Select the MicroStation Saved Views tool (MS: Utilities menu > Saved Views). 

2. Select Bldg . 

3. Click Apply. 

This will center the building graphics in the Microstation view. 
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4. Select the Create New Object tool (Site Modeler menu: Object > New).   

 

5. Enter the New Object information. 

Object Type: Building 

Add to Active Model: Toggle On 

This creates an Object Name of Bldg 1 based on the naming prefix assigned to this Object 
type. We shall use the default Object Name. 

6. Click OK. 

7. Select the New / Edit Element tool (Site Modeler menu: Element > New/ Edit).   

 

8. Click Drape on Model/Object on the Elements tab. 

9. Enter the Element information. 

Feature Type Break Line 

Drape on Object Ex ist Ground 

Offset Height Toggle On, 2.0 

Drape Option Maximum Elevation 

Use Drape Association Toggle On 

10.  Click Select Elements in the Define Elements group box. 

11.  Select the building footprint in MicroStation.   

Note The element highlights when selected.  Ensure it is the same color as your highlight color. 

12.  Click Apply. 
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Once the building pad is successfully added to the model the contours are drawn. 

 
Building Pad and associated contours 

: Adding A Grass Area Around The Building 

We will now add a grass area around the building pad element.  This grass area will have a -2% slope 
away from the building to ensure proper drainage.  It should be noted that an element representing the 
outer boundary of this grassy area has been drawn into the file. 

1. Continuing with the New / Edit Site Elements tool, click Slope/Offset From Site Element 
on the Element tab. 

 

2. Enter the Element information. 

Feature Type Break Line 

Slope %  Enable, -2.0 

Projection Option Maximum Elevation 

Use Reference Element Association Enable 

Use Power Selector Enable 



Workshop: Designing A Site Model 

 

 
GEOPAK Site I Copyright © 2003 Bentley Systems, Incorporated Do Not Duplicate 

5/16/2003 4-25 

3. Click Select Elements  in the Define Elements group box. 

Define Elements are those elements that we will calculate elevation for based on a user 
defined relationship with another previously created site element (The Reference Element).  
In our case the relationship is a –2% slope from the edge of the building pad. 

4. Select the elements which comprise the outline of the grass area. 

Hint The elements are the solid and dashed green lines around the building outline.  

 

 
            Elements selected as part of the grassy area. 

5. Click Select Reference. 

6. Select and accept the previously created building pad site element. 

7. Click Apply. 

The grass area elements are added to the BLDG 1 object.   

 
  Building Pad, Grass Area, and Associated Contours 

This completes our building object for now.  We may come back later and change it in some 
way, possibly raising or lowering it. 

Next we will look at various tools in conjunction with creating a roadway object.  It should be 
noted that the roadway alignment and profile have previously been created and we will simply 
use them in our design process.  Future sections of this training guide will demonstrate in 
more detail how to create alignments and profiles within the GEOPAK software. 
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: Creating A Roadway Object 

1. Select the MicroStation Saved Views  tool (MS: Utilities menu > Saved Views). 

2. Select Main and click Apply. 

3. Disable Display View 1 on the Active Site Object Control dialog. 

 

4. Select the Create New Object tool (Site Modeler menu: Object > New). 

 

5. Enter the Create New Object information. 

Object Type: Roadway  

Object Name: Main Rd 

Add to Active Model: Enable 

6. Click OK. 

: Creating the Roadway Elements - Centerline 

The first step in designing the roadway is to establish the centerline site element.  Again, we have an 
alignment and profile that have been previously created.  Using the GEOPAK New/Edit Element tool, 
we will use those to create our centerline site element.  Then we can continue with other roadway 
features such as edges of pavement, shoulders, curb and gutter, etc. 

1. Select the MicroStation Fit View tool  (MS: Tools >View Control > Fit View).   

Hint As we will create the centerline graphic with Site Modeler tools, we will delete the current 
graphic before proceeding. 

2. Select the MicroStation Delete Element tool  (MS: Tools >Main menu > Delete Element).   

3. Select and accept the main road centerline (dashed green complex element). 
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4. Select the New / Edit Element tool (Site Modeler menu: Element > New/ Edit). 

 

5. Click Alignment. (right tool under the Elements Tab) 

6. In the Element Group Box, set By Feature. 

The By Feature option allows us to select an item from our feature database.  The item we 
select would contain all the information to draw the element in MicroStation.  The element 
would be drawn at the correct level, weight, color, style, etc. that conforms to our 
company/client standards. 

7. Click Select Payitem (paintbrush) and navigate to Drafting Standards > General > Baseline-
Chains. 

 

8. Select the item and click OK. 

9. In the Primary Element Definition group box, click Open GPK File (folder). 

10.  Select job200.gpk .  

11.  Click OK. 

12.  Set the Chain to MAINRD. 

13.  Set the Profile to MAINDES . 

14.  Click Apply. 
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: Creating the Roadway Elements – Edges of Pavement 

Now that the centerline site element has been created, we will use the centerline to establish the 
appropriate elevations for the edges of pavement.  The edges of pavement will be based on a –2% 
cross slope from the centerline element. 

1. On the New/Edit Site Elements dialog, click Slope/Offset From Site Element. 

 

2. Enter the Element information. 

Feature Type Break Line 

Slope %  Toggle on, -2.00 

Projection Option  Entire Element 

Use Reference Element Association Toggle on 

Use Power Selector Toggle on 

Redefine Site Element Toggle on 

3. Click Select Elements from the Define Elements group box.   

4. Select all edges of pavement on the left and right side of the Main Road. 

Hint Do not select the dashed elements in the intersection or the curb return elements joining the 
two roadways.  We will create the design for those in future steps. 

5. Click Select Reference from the Reference Element group box. 

6. Select and accept the centerline element 

7. Click Apply. 
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Now the edges of pavement for the roadway have been created.  Next we will design the 
elements in the intersections of the roadways.  These will also be calculated at a –2% cross 
slope from the centerline.  The only difference is we will create these elements as a boundary 
feature type. 

 

8. Change the Feature Type to Boundary. 

8. Click Select Elements from the Define Elements group box.   

9. Select the two dashed line elements in the intersection of the two roadways. 

10.  Click Select Reference from the Reference Element group box. 

11.  Select and accept the centerline element. 

12.  Click Apply. 

13.  To see the results, enable the Display View toggle on the Active Site Object Control dialog. 

   

Note Use the Display View toggle whenever you wish to navigate the design file quickly.  As long as 
the Display View is enabled, contours are drawn with every view change.  Zoom window, pan, 
fit view, etc. 

: Creating the Roadway Elements – 6’ Outside Shoulder 

Now it is time to design the elements outside the edges of pavement.  For our project we are proposing 
a 6’ paved outside shoulder with a 3% cross slope.  However, as we will see later, one could construct 
any type of roadway feature.  The designer has the ability to make the typical section as elaborate and 
detailed as necessary. 

1. Disable Display View 1 on the Active Site Object Control dialog.  

This will make the edge of pavement elements easier to select. 

2. Select the New / Edit Element tool (Site Modeler menu: Element > New/ Edit). 
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3. Select the Section tab. 

 

4. Enter the Section information. 

Option Table 

Feature Type Boundary 

5. Enter the information in the edit boxes along the bottom. 

Offset Distance 6 

Offset Elevation -0.180 

6. Click Pay Item and navigate to Drafting Standards > Miscellaneous > PVDSHLDR. 

 

This item contains all the necessary information on how to draw the paved shoulder line in 
MicroStation. 

7. Select the item and click OK. 

8. Click Add List Item (right side of the table entries). 

9. Click Select Reference El ements from the Reference Elements group box. 

The reference elements are those elements that we are planning to put the section on.  In our 
case, we plan to place the section off of the edges of pavement. 

10.  Select the edges of pavement elements previously created.  Do not select the dashed lines in 
the intersection of the roadways. 

Hint There should be 8 elements in the selection set. This value is displayed in the bottom right 
hand corner of the Microstation Window. 
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11.  Click Set from the Direction group box. 

12.  Data point outside the edge of pavement. 

 
     Direction of Section Elements 

13.  Click Apply. 

: Cut Profile/Section Across Roadway 

Let’s use the GEOPAK Site Profile Tool to cut a profile across the roadway. 

1. Select the Site  Profile tool.  (Site Modeler: > Analysis > Profiles). 

 

From the Selection tab, we will create a list of Site Objects to cut a profile across.    

2. Select Site Object and Exist Ground. 

3. Set the element symbology (level 1, color 2, style 3, weight 1) by double-clicking the sample 
line graphic. 

4. Click OK to close Set Feature dialog. 

5. Click Add List Item (right side of dialog). 

6. Change the Site Object to Main Rd. 

7. Set the element symbology (level 1, color 3, style 0, weight 1). 
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8. Click on the Profile tab. 

9. Using the Window Area tool located along the bottom of the MicroStation View window.  
Zoom in to any particular area along the roadway. 

 

10.  Click Place Element. 

11.  Data point on each side of the roadway.   

The profile is displayed in the Extracted Profile View area.  To extract a different profile in 
another location, simply place data points in two more locations. 

 

12.  Reset (right mouse button) when done. 

13.  Close the GEOPAK Site Profile dialog. 
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EDIT PROFILE 
The GEOPAK Edit Profile Tool allows site elements to be redefined and edited using the component 
based vertical alignment tools.  It also allows usage of MicroStation tools to place site elements in any 
view in accordance with the curvilinear coordinates settings. 

There are a series of steps the User must undertake to use this tool for the redefinition of vertical 
geometry of existing Site elements. 

1. Create a profile cell based on the elements that are to be redefined. Use the Profile Cell 
Setting Dialog to achieve this step. 

2. Place vertical components over part or the entire profile to accurately define the proposed 
vertical information. 

3. Apply this new vertical geometry back to the existing Site Elements using the Define Site 
Element Profile tool. 

4. The existing elements will be redefined using the vertical information from the vertical 
components. The interval that the new Z values will be replaced is based on the vertices of the 
plan view graphics, the linear and curve stroking tolerance set in the Site Modeler User 
Preferences, the B-Spline Plan stroking tolerance set in the Site Modeler User Preferences, 
critical vertical component points and the B-Spline Profile stroking tolerance set in the Site 
Modeler User Preferences.  

The first step is the creation of a profile cell in which the site profile may be developed or modified.  
This can also be accomplished by utilizing a previously placed Site Element profile cell.    

 

The eight view tools on the right side of the tool frame can be utilized to define the various profile and 
plan views the designer wants to view while developing the profile.  Simply right click on the view, 
then select profile or plan view.  Once the views are defined, right click on the Profile Status tool and 
select the Profile Cell Setting tool.   
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Profile Cell Status tool 

Activates the current Profile system, which is associated to a Profile Cell. If there are 
several Profile cells, it is possible to designate the active one in the Profile Cell Control 
dialog.  When the tool is right clicked, a pop-up menu appears : 

 

The first option of the pop-up menu allows for the selection of a single or multiple 
joining Site elements and the placing of a Profile cell, which opens the dialog depicted 
below. 

 

The second option allows getting information about Profile cells that reside in the master 
and reference files. The User can select and make active a specific profile cell if there are 
several profile cells.  

 

 
Graphically select the Site Element chain in the plan view.   

 

Opens the Vertical Component Tools tool frame.  For a detailed discussion on these 
tools, refer to GEOPAK online help under Site > Horizontal and Vertical Geometry. 

 

 
Click when the profile has been developed in order to redefine the Site Elements based 
on the profile vertical components. 

 
Opens the Precise Curvilinear Coordinates dialog that allows entering precise curvilinear 
coordinates relative to the active chain. This will be discussed later. 
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UTILIZING THE ACTIVE PROFILE CONTROL 

The left side of the toolbox has eight tools that set each view.  Use one of these items to fit the 
corresponding view (left) or to define the type of the view (right).  Two views are supported:  plan and 
profile, whose tools are detailed in the table below. 

 

Corresponding view is a Plan view.  

A Plan view is fitted in such a way that the active chain is entirely displayed in the view. 

 

Corresponding view is a Profile view. 

Note:  A Profile view is fitted in such a way that the origin point of the Profile Cell stays 
at the left bottom corner of the view, and the end of the chain stays at the right side of the 
view. 

If a command is waiting for a curvilinear data-point, a data point in a Profile view will 
produce a curvilinear data-point, corresponding to its [station, elevation] location.  This is 
useful for Vertical alignment element creation commands 

When right clicking on Plan or Profile view, a pop-up menu opens: 

Plan Allows attaching a Plan Representation System to the view. 

Profile Allows attaching an active Profile Representation System to the view. 
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UTILIZING THE PRECISE CURVILINEAR COORDINATES DIALOG 

 
 

The Curvilinear Coordinates dialog enables the user to enter precise curvilinear coordinates relative to 
the site chain.   

 

 

S: Enter station along actual active chain. The left toggle locks the value. 

Ext.: Enter an extension to the station along actual active chain. A negative value means that 
the extension is before the beginning of the chain. A positive value means that the 
extension is after the end of the chain. 

If the lock toggle is on, the cursor follows a perpendicular to the chain in plan views, and 
a vertical line in Profile views. 

O: Enter a horizontal offset from the actual active chain. Use the left toggle to lock the value 
of this field. 

If the lock toggle is on, the cursor follows a parallel line to the chain in plan views. 

Z: Enter elevation.  The left toggle locks the value of this field. 

If the lock toggle is on, the cursor follows a horizontal line in profile views. 

DS: Enter delta station from the previous data point or tentative point.  The left toggle locks 
the value of this field. 

If the lock toggle is on, the cursor follows a perpendicular to the chain in plan views, and 
a vertical line in profile views. 

DO: Use this field to enter delta offset from the previous data point or tentative point. Use the 
left toggle to lock the value of this field. 

If the lock toggle is on, the cursor follows a parallel to the chain in plan views. 

DZ: Use this field to enter delta elevation from the previous data point or tentative point. Use 
the left toggle to lock the value of this field. 

If the lock toggle is on, the cursor follows a horizontal line in profile views. 
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Perm. 
Lock 

When toggled on, coordinate locks remain active even after a data point is issued. 

Apply Send a data point to the input queue. 

Entering a data point by a click in a view has the same effect. 

 

The dialog can be utilized in conjunction with generic MicroStation commands as it allows the user to 
precisely key-in information such as elevation, station, offset, etc., then apply that information to the 
active tool. 

For example, to place a line into MicroStation, data point to start the line and data point again to finish 
the line placement.  Instead of clicking a data point, the user can key-in station and elevation then click 
Apply.  That information is sent to the active tool as the first data point.  Next , the user would then 
key-in the ending station and elevation, click Apply which would be sent to the active tool as the 
second and final data point. 

UTILIZING THE PROFILE CELL CONTROL DIALOG 

The Profile Cell Control dialog enables the user to place or manipulate profile cells and associated 
data. 

 

The dialog is comprised of a list box with information about all the Profile Cells in the current 
MicroStation file.  

 
Place a new Profile Cell 

 
Activate the selected Profile Cell 

 
Delete the selected Profile Cell 
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PLACING A SITE PROFILE CELL 

 

 
Click, and then identify the site elements to be added to the chain utilized in the profile 
cell. 

 
Click to reverse the chain utilized for the profile cell. 

 
Click to erase the chain. 

 
Once the dialog is populated, click to place the site profile cell. 
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The fields are detailed in the table below. 

Station Defines the corresponding station of the reference point (profile cell origin).  

Elevation Defines the corresponding elevation of the reference point (profile cell origin).  

Horizontal / 
Vertical Scale 

Controls the scale, and subsequently the distortion utilized to draw the profile. 

Cell Range: 
 

Top Elevation 
Top Delta 

 

Bottom 
Elevation 

Bottom Delta 

 

 

Use these fields to define the height of the Profile Representation system. These 
values are given in true length (without taking into account horizontal and vertical 
scales). 

 
Care must be given that the Top and Bottom Delta values of the profile cell are set 
large enough such that all elements fall completely within the cell limits.  For 
example, all elements must be between a horizontal line drawn at the top of the cell 
and one drawn at the bottom of the cell.  If any element falls outside these limits 
they will not be recognized as vertical alignment elements. 

By default, the profile cell is placed on level 63, and contains a vertical and horizontal axis, plus a text 
node containing the following information. 

• S=<station> 

• Z=<elevation> 

• HS=<horizontal scale> 

• VS=<vertical scale> 

• GAP or NOGAP 
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WORKSHOP: ADDING THE ENTRANCE ROAD 
Now we will design the entrance road.  The layout of the alignment is complete.  We will explore the 
tools necessary to create the proposed vertical profile.  Following that, we will look at the GEOPAK 
Composite section tool that will aid us in creating all the roadway elements at one time. This approach 
differs slightly from the way in which we designed the Main road. 

: Creating the Entrance Road Object 

1. Select the Create New Object tool (Site Modeler menu: Object > New). 

2. Create the New Object. 

Object Type: Roadway  

Object Name Entrance Rd 

Add to Active Model: Enabled 

: Creating the Entrance Road Elements – centerline 

1. Select the New / Edit Element tool. 

 

2. Click Drape on Model/Object. 

3. Enter the Element information. 

Feature Type: Break Line 

Drape on Model: Tower 

Drape Option: Entire Element 

Use Power Selector: Enable 

4. Click Select Elements from the Define Elements group box.   

5. Select the centerline element of the entrance road. 

6. Click Apply. 

7. Close the New/Edit Site Elements dialog. 
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: Creating the Entrance Road Elements – Profile the Centerline 

We are going to plot a centerline profile of the entrance road off to the side of the project in view 
window 2. 

1. Open View Window 2. (MS: Window>Views>2) 

2. Click Fit View. 

3. Access the Active Site Profile tool frame. (Site Modeler Menu: Elements>Edit Profile). 

 

4. Right mouse click on Profile Cell Status .  

 

5. Select the Profile Cell Setting .  

 

6. Fill in the Profile Cell Setting information. 

Station: 0.00 

Elevation: 5240.00 

Horizontal Scale: 10.00 

Vertical Scale: 1.00 

Top Delta: 60.00 

Bottom Delta: 0.00 

7. Click Add Element PCell Chain. 

8. Select the entrance road centerline element and accept it with a data point. 

9. Click Place Site PCell.  

10.  Place the profile cell in a clear area of the previously opened view window 2. 
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11.  On the Active Profile Control tool frame, right click on View 2 and set it to Profile. 

As you slide your cursor along the profile you will notice a cursor locked on the plan view 
centerline element in view window 1. 

 
Site Element Profile of Entrance Road Centerline 

Now that we can visually see the existing centerline profile, it is time to create the design profile.  
We will do this right on top of the existing profile. 

: Creating the Entrance Road Elements – Design the Centerline Profile 

There are some constraints to consider before starting this profile design.   

Both ends of the Entrance Road join to the Main Road. The cross slope on the Main road is –2%. Our 
profile grade should match this to ensure a smooth transition.   

The roadway passes quite close to the Building Object. We need to make sure that the profile is at a 
similar or lower elevation to the outside of the building grass but still has longitudinal slope for 
drainage purposes.   

With these constraints in mind, we shall begin the profile design. 

1. Click Vertical Component Tools. (Active Profile Control tool frame)  

 

2. Click Curvilinear Coordinates. (Active Profile Control tool frame) 

 

The curvilinear coordinates dialog allows the user to precisely key-in information such as 
elevation, station, offset, etc., then apply that information to the active tool. 
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3. Click Create Profile Line by Points (Vertical Components). 

 

Slope %  Enable, -2 

Length Enable, 40 

4. Enter the Create Line by Points information 

5. Window in on the left hand end of the Profile (in View 2). 

6. Snap to the left end of the Model profile that represents the elevation at the edge of the Main 
Rd Object. Data point to accept the first point to the tangent. 

7. Data point to draw in the tangent. 

 

9. Click Fit View 2 on the Active Profile Control dialog. 

This fits the Profile to View window 2. 

10.  Window in on the right hand end of the Profile (in View 2). 

11.  Snap to the right end of the Model profile that represents the elevation at the edge of the Main 
Rd Object. Data point to accept the first point to the tangent. 

12.  Set the Slope%  to 2. 

13.  Set Length to 40. 

14.  Data point to draw in the tangent. 

15.  Click Fit View 2 on the Active Profile Control dialog. 

Note This satisfies the first part of the profile design criteria – setting the same slope as the Main 
Road pavement to ensure a smooth transition. 

: Determine Station and Elevation of a Critical Point 

We will now find the station and elevation at the center of the front edge of the Building 
Object grass area. We will use both the Site Modeler Height tool and the Active Chain 
Control Curvilinear Coordinates tool to get this information. 

1. Select the Height tool (Site Modeler menu: Analysis > Height).  

Curvilinear Coordinates should already be open. 
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2. Toggle on Model. 

3. Click DP. 

4. Set the MicroStation snap to “midpoint”. 

5. Snap to the dashed green line at the front of the building. 

 

The Curvilinear Coordinates tool displays the 
station at this location along the Entrance road 
centerline as 737.9658. 

The Height tool displays the Model elevation as 
5265.8215. 

From this data we can set the next VPI of our profile. 
 

6. Close the Height tool. 

: Adding the Critical Point as a VPI 

1. Click Create Profile Line by Points. 

2. Toggle off Slope%  and Length in the Create Line by Points dialog. 

3. Set the Station and Elevation values in the Curvilinear Coordinates dialog. 

S: Toggle on, 740.00   

Z: Toggle on, 5265.000 

Permanent. Lock Toggle on 

4. Click Apply. 

This creates  the first tangent point. 

5. Toggle off the S and Z locks. 

6. Set the Create Lines by Points dialog. 

Slope %  Toggle on, 0.5 

Length Toggle on, 220.0 

7. Data point to the left of the first tangent point. 

A tangent line is created. 

8. Snap to the right hand end of the just created tangent line and accept the point.  

This is the first point of our next tangent line. 

9. Set the Create Lines by Points dialog. 

Slope %  Toggle on, -0.5 

Length Toggle on, 260.0 

10.   
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11.  Data point to the right of the first tangent point.  

This creates a tangent line. 

Note This satisfies the second design constraint of staying below the Building grassy area and 
ensuring the roadway drainage is acceptable. 

: Completing the Profile Tangents 

We will now create the remaining tangent line portions of the profile. This will be 
accomplished by simply filling in the gaps. 

1. Click Create Profile Line by Points and create 2 tangent lines in the gap areas. 

 

We shall now create some Vertical curve components. We currently have 7 VPIs in this 
profile – we need to create 5 Vertical Curves. 

We shall start from the left hand end of the profile and work to the right. 

2. Click Create Profile Curve Between 2 Elements (Vertical Component Tools).     

 

3. Turn on the toggle and set the Length to 60. 

4. Select and accept the first tangent. 

5. Select and accept the second tangent. 

The vertical curve is drawn and the tangents are trimmed. 

6. Continue along the profile setting the other four vertical curves with the same procedure. 

CURVE LENGTH 

1 60    (already done) 

2 160 

3 60 

4 160 

5 60 
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: Incorporating the Profile into Site Modeler 

We shall now send the proposed profile information back to the Site Modeler element. 

1. Click Define Site Element Profile (Active Profile Control tool frame). 

2. Select and accept any proposed profile element. 

This strings all of the profile elements together. 

3. Data point to accept the proposed profile. 

The profile information is now returned to the Site Element. The Profile element redraws to 
reflect the new state of the Site Element. 

  

: Creating the Entrance Road Elements – Applying a Composite Section 

1. Select the Composite Section tool (Elements>Composite Section). 
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We will focus our attention on the Define, Method, and Search Extent group boxes at the 
bottom of the dialog.  We will set these to find and create the edges of pavement. 

 

2. Complete the Define group box. 

Element Type: Element 

Feature Type: Break Line 

3. Complete the Method group box. 

Slope: -2.00 

Vertical Offset: 0.00 

Radial To: Primary 

Projection Option: Entire Element 

4. Complete the Search Extent group box. 

Search Extent Symbology: Level=level 8, Co=6, Wt=0, Lc=0 

Maximum Distance: 23 

5. Click Add List Item  (right side of list box). 

: Create the Curb and Gutter Section on the Left Side 

Now we will create the 6” Curb and Gutter section that will run along the edges of pavement. 

1. Complete the Define group box. 

Element Type: Section 

Feature Type: Boundary 

2. Complete the Method group box. 

Section By Table 

Side Left 

This will allow us to create a table of offset distances and elevations to define the curb section 
that will run along the edge of pavement.  Keep in mind that the section we create starts at the 
edge of pavement so all offset values start from that edge and not the centerline of the 
roadway. 
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3. Enter the information in the edit boxes along the bottom. 

 

Offset Distance 1.5 

Offset Elevation -0.2 

Remember that the distances assume that the edge of pavement element is the origin (0,0). 

4. Click Pay Item and navigate to PayItem > Plan > Curbing > Gutter Curb gutter line. 

 

5. Select the item and click OK. 

6. Click Add List Item (right of the table). 

7. Add two more entries to the table using the same procedure. 

OFFSET DISTANCE DESCRIPTION  PAY ITEM 

1.7 0.5 CTF (PayItem > Plan > Curbing) 

2 0.5 CTB  (PayItem > Plan > Curbing 

8. Click the Add List Item (next to the Left Side list box) to add the section definition to the 
Left Side List. 

The left side list is now complete.   
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: Create the Composite Section for the Right Side 

The right side of the roadway is almost the same as the left so we can copy the left side list to 
the right side.  Then we can make the appropriate adjustments to satisfy the slightly different 
right side conditions. 

1. Select all the items in the Left Side list. 

2. Click Copy List Item. 

3. In the Primary Definition group box on the Composite Section dialog, click Right Side. 

4. Click Paste List Item. 

The Right Side list is now populated and we can make the necessary changes.  For example, 
on the right side of the roadway, the curb and gutter is on the right side of the edge of 
pavement.  Additionally, on the right side of the roadway, in front of the building, the edge of 
pavement is only 12’ away from the centerline. 

 

5. Select the first list item. 

This corresponds to the edge of pavement 

6. Change the search distance to 13. 

7. Click Modify List Item. 

8. Select the second list item. 

This corresponds to the curb and gutter section. 

9. In the Method group box, change Side to Right. 

10.  Click Modify List Item. 

In the intersection of the parking lot and the entrance road are dashed lines representing the 
extension of pavement edges through the intersection.  We will set the composite section up 
to locate and define these pavement extensions. 

11.  Complete the Define group box. 

Element Type: Feature 

Feature Type: Boundary 

12.   
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13.  Complete the Method group box. 

Slope: -2.00 

Vertical Offset: 0.00 

Radial To: Primary 

Projection Option: Entire Element 

14.  Complete the Search Extent group box. 

Payitem Click Select Pay Item, navigate to payitem > plan > curbing > valley line 

Max. Distance: 13.00 

When utilizing the payitem option, GEOPAK searches for any MicroStation element where 
the level, weight, color, style, etc. match that of the Valley Line item.  This is a slightly 
alternate method than that used to find the edges of pavement.  However the results are the 
same. 

15.  Click Add List Item. 

The item was added to the bottom of the list.  We will now move it to the top of the list. 

16.  Select the item and click Move Up until it is the first on in the list. 

 

: Applying Completed Composition Section 

Our Composite Section is now complete and ready to apply to the centerline. 

1. In the Primary Element Definition group box, set to By Site Element. 

2. Click ID Element.   

3. Select the entry road centerline element and accept it with a data point. 

4. Click Apply. 

Although the majority of the roadway design is done, both the main road and the entrance 
road are not yet completed.  The intersections between the two still need to be designed.  That 
will be accomplished in a later exercise.  At this point we will turn our attention to the parking 
lot. 
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WORKSHOP: CREATING THE PARKING LOT 
During the next set of exercises we will design and grade the parking lot.  The desired slope across the 
parking lot is 2%.  The parking lot will slope from the back toward the building and entrance road.  In 
order to create this design, we will create a temporary object.   

This object will begin at the current edge of pavement, along the entrance road, and slope at 2% toward 
the Entrance road.  This temporary object will encompass the total area of the parking lot layout.  Once 
this temp object is created we will proceed to drape all the elements representing the various Parking 
Lot edges of pavement onto the temp object.  This will create a nice, simple 2% grade across the 
parking area.   

We can then proceed to place curb and gutter where appropriate. 

: Creating a Temp Object 

1. Use the MicroStation Saved View Parking.  

2. Create a new object with New Object Type Parking and Object Name Temp1. 

Hint Remember to Add to the Active Model. 

There are two yellow lines (drawn on level “Level 1”) in the DGN file. One line runs along 
the edge of pavement of the entrance road in front of the building.  The other line is outside 
the back edge of the parking lot and is parallel to the first.  These two lines will make up the 
elements with in the Temp 1 object. 

3. Select the New / Edit Site Element tool  (Site Modeler menu: Element > New/ Edit). 

 

4. Click Drape on Model/Object.  

5. Enter the element information. 

Feature Type Break Line 

Drape on Object Entrance Rd 

Drape Option Entire Element 

Use Drape Association Enable 

6. Click Select Elements from the Define Elements group box. 

7. Select the yellow line that runs along the entrance road edge of pavement. 

8. Click Apply. 
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9. Click Slope/Offset from Site Element.  

 

10.  Enter the element information. 

Feature Type Break Line 

Slope %  Enable, +2.00 

Projection Option Entire Element 

Use Reference Element Association Enable 

11.  Click Select Elements from the Define Elements group box. 

12.  Select the other yellow line located outside the back of the parking lot. 

13.  Click Select Reference from the Reference Element group box. 

14.  Select and accept the yellow line running along the entrance road edge of pavement. 

15.  Click Apply. 
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: Creating the Parking Lot Object 

We now have a 2%sloped area (Object - Temp 1) which encompasses the entire area of the proposed 
parking lot.  At this point, we can simply select all the parking lot edges of pavement and drape them 
down onto this temporary object.  Thereby effectively and efficiently creating a nice 2%slope from 
element to element throughout the entire parking lot. 

1. Create a new object with New Object Type Parking and Object Name PL 1. 

The object should be added to the active model. 

We will now create all the edges of pavement elements in the parking lot by draping them 
onto the Temp 1 object. 

2. Select the New / Edit Site Element tool. (Site Modeler menu: Element > New/ Edit) 

 

3. Click Drape on Model/Object. 

4. Enter the element information. 

Feature Type Break Line 

Drape on Object Temp 1 

Drape Option Entire Element 

Use Drape Association Enable 

Use Power Selector Enable 

5. Click Select Elements from the Define Elements group box. 

6. Select all the edges of pavement in the parking lot including the curb returns. 

7. Click Apply. 

At this point we are finished with the Temp 1 object and can remove it from the active model. 
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: Remove the Temp 1 Object 

1. Select the Edit Model tool. (Site Modeler Menu: Model > Edit) 

 

2. Select Temp 1. 

3. Click Remove Object. (Scissors)  

4. Click Process. 

: Creating the Parking Lot Elements – Sharing Entrance Road Elements 

The Entrance Road elements that are directly adjacent to the parking lot object need to be shared with 
the parking lot to ensure a direct transition between the two objects.   

1. Select the Edit Object tool. (Modeler: Object > Edit.)  

2. Click Add Elements to Object. 
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3. Select the dashed join lines and the edge of pavement elements. 

 

4. Click Apply. 

: Creating the Parking Lot Elements – Adding Curb & Gutter 

We will now add the appropriate curb & gutter at the edges of pavement throughout the parking lot.  
Around the exterior of the lot we will place the same 6” curb & gutter used on the entrance road.  In 
the interior islands we will place a simple 6” curb with no gutter. 

1. Select the Level Display tool. (MS: Settings > Level > Level Display) 

2. Turn on Level 9.  Close the tool. 

3. Select the New/Edit Site Element tool. (Site Modeler menu: Element>New/Edit) 

 

Note We can import the curb & gutter information into the table from one of the edges of pavement 
that has the desired curb & gutter attached. 

4. Set the Option to Table and Feature Type to Boundary. 

5. Click Query Section from the Manipulate Section group box. 

6. Select an edge of pavement element along the right side of the roadway.  Data point to accept. 

7. Click OK. 

The table is now populated with the correct offset values and pay item information. 

8. Click Select Reference Elements  from the Reference Elements group box. 
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9. Select the parking lot edges of pavement around the outside only.   

 

10.  Click Set in the Direction group box. 

11.  Data point to the outside of the edge of pavement. 

12.  Click Apply. 

We shall now add the curb and gutter section to the northern most median. 

13.  Set the Feature Type to Breakline. 

14.  Select the median edge. 

 

15.  Click Set in the Direction group box. 

16.  Data point to the inside of the median to set the Direction of Section. 

17.  Click Apply. 
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: Create Curb on Islands 

Next create the curb sections on the interior island edges of pavement.  We need to make the 
necessary changes to the table prior to placing the curb sections.   

We will remove the gutter item and modify the offset distances and elevations to the top and 
back of curb items. 

 

1. Select the gutter item and click Delete List Item. 

2. Select the CTF row. 

3. Modify the Offset Distance to 0.20 and Offset Elev to 0.50. 

4. Click Modify List Item. 

5. Select the CTB row. 

6. Modify the Offset Distance to 0.50 and Offset Elev to 0.50. 

7. Click Modify List Item. 

8. Set the Feature Type to Break Line. 

Note Each island is done separately.  Select the island, set the direction of the section and then 
apply the section.  This process is repeated for each island. 

9. Click Select Reference Element in the Reference Elements group box. 

10.  Select one of the islands. 

11.  Click Set in the Direction group box. 

12.  Data point inside the island to set the Direction of Section. 

13.  Click Apply. 

14.  Repeat Steps 9 through 13 for each island. 

 

 
Parking Lot Object 
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DESIGNING A POND 

: Creating a Pond Object 

In this section we will create a pond object between the roadway and the building.  The MicroStation 
element that represents the pond shape has already been created and we will assign the desired 
elevation.  After the pond is created we will use a few analysis tools to analyze pond volume. 

1. Use the MicroStation Saved View Pond. 

2. Create a New Object Pond. Leave the Object name as Pond 1. 

Remember to add the Object to the active Model. 

3. Select the New / Edit Site Element tool (Site Modeler menu: Element > New/ Edit).   

 

4. Click Drape on Model/Object on the Elements tab. 

5. Enter the Element information. 

Feature Type Break Line 

Drape on Object Ground1 

Offset Height Enable, -4.0 

Drape Option Minimum Elev ation 

Use Drape Association Enable 

6. Click Select Elements in the Define Elements group box. 

7. Select the pond element. 

8. Click Apply. 
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:  Creating a Pond Object – Adding a Bench 

We will now add a bench around the pond approximately 5’ higher than the pond bottom.  The bench 
will be 6’wide and will encompass the entire perimeter of the pond. 

1. Click the Side Slope tab. 

 

2. Enter the Side Slope information. 

Option For Delta Vertical, 5.00 

Slope run:rise 3:1, Radial 

Feature Type Break Line 

By Level Symbology  Level 30, color 4, style 0 weight 0. 

Close Elements Enable 

Use Association Enable 

3. Click Select Reference Element in the Reference Elements group box. 

4. Select the previously established pond bottom site element. 

5. Click Set Side . 

6. Data point to the outside of the pond bottom site element to establish the Direction of Slope 
Element. 

7. Click Apply. 

The inside edge of the berm is created.  Next we will create the outside edge 6’ away. 

8. Enter the Side Slope information. 

Option: For Delta Horizontal, 6.00 

Slope %: 1.00%  

Feature Type: Break Line 

By Level Symbology: Level 30, color 4, style 0 weight 0 

Close Elements: Enable 

Use Association: Enable 

9. Click Select Reference Element in the Reference Elements group box. 

10.  Select the side slope element just created (inside edge of the berm). 

11.  Click Set Side . 



Designing a Pond 

 

 
GEOPAK Site I Copyright © 2003 Bentley Systems, Incorporated Do Not Duplicate 

5/16/2003 4-60 

12.  Data point to the outside of the side slope element to define the Direction of Slope Element. 

13.  Click Apply. 
 

 
Pond bottom and side slope elements 

: Saving and Exiting the Project 

1. Close GEOPAK Site Modeler (Modeler: Project > Exit).  

2. Click Yes to save the current project. 

 

3. Click No to the Lock Elements alert. 
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WORKSHOP: DESIGNING THE ROADWAY INTERSECTIONS 
During the next few exercises we will follow the necessary steps to design the two intersections 
between the Main Road and the Entrance Road. 

Note To ensure that all students have the same data, we will use an updated dataset. 

: Change to Updated Dataset 

1. Open the file C:\Data\Geo\Site\Site1\Chapter4\updated_Siteplan2D.dgn (MicroStation: 
File>Open). 

2. Select the Site Modeler tool (Applications>GEOPAK Site>Site Modeler>Site Modeling). 

 

3. Click Browse. 

4. Navigate to and select the file …Site1\Chapter4\updated_siteplan.gsf. 

5. Click OK. 

: Create the North Intersection for the Roadways 

This exercise will focus on the northern intersection of the two roadways.  We are going to design 
the curb returns between the two roads to include the curb & gutter. 

1. Use the MicroStation Saved View North Intersection. 

2. Select the Object Entrance Rd on the Active Site Object Control tool frame. 

This makes the object active by selecting it from the Object Pulldown List. 

 

3. Select the Modeler Element Information tool. (Modeler: Element > Information) 
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4. Click Select Element.  

5. Select and accept the dashed line representing the edge of pavement extension through the 
intersection.   

The Element Data is now populated in the dialog. 

6. Click the Objects tab. 

 

7. Click Add Object To List By Name. 

8. Select Entrance Rd and click OK. 

 

9. Click Update. 

10.  Click Yes to save changes to the Site Modeler Element. 

: Turn Off Element Association 

You may notice that it took a while to finish updating the Entrance road object and rebuild the model.  
By changing the entrance road we are triggering a rebuild of the Temp object, which was used during 
the creation of the parking lot, which in turn triggers the parking lot to update as well.  Element 
Association is an extremely powerful feature of the software.  In this case, and in the interest of time, 
we want to temporarily disable this feature.  The easiest way to do this is to turn off Element 
Association for the element that runs along the entrance road edge of pavement that in the Temp 
Object. 

1. Open View Window 2. (Window>Views>2) 

2. Use the MicroStation Saved View Parking. 

Set the destination view to 2. 
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3. Select the Change Association tool  (Modeler: Element >Change Association). 

 

4. Click Select Reference Element.   

5. Select the yellow line running along the entrance road edge of pavement. 

6. Set Associations  to Off. 

7. Click Apply. 

8. Close View Window 2. 

: Create the Curb Returns in the Northern Intersection 

1. Select the New/Edit Site Element tool. (Modeler: Element > New/Edit) 

 

2. Click Drape on Model/Object on the Element tab. 

3. Enter the Element information. 

Feature Type: Break Line 

Drape on Model: Tower 

Drape Option: Vertices 

Use Power Selector: Enable 

4. Click Select Elements in the Define Elements group box. 

5. Select the two curb return elements in the intersection. 

6. Click Apply. 

Now we will create the curb & gutter for the two curb returns.  The curb & gutter will be the 
same as that on the rest of the entrance road. 
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7. Click on the Section tab. 

 

8. Set the Feature Type to Boundary and the Option to Table. 

9. Click Query Section in the Manipulate Section group box. 

10.  Select and accept an edge of pavement element along the right side of the Entrance Rd 
roadway.   

11.  Click OK on the information dialog. 

The table is now populated with the correct offset values and pay item information. 

12.  Click Select Reference Elements  from in the Reference Elements group box. 

13.  Select the two previously created curb return elements. 

14.  Click Set in the Direction group box. 

15.  Data point to the outside of the curb returns to set the Direction of Section. 

16.  Click Apply. 

We will now look at the profile along each curb return to make sure the transition between the two 
roadways is as smooth as possible. 

: Drawing the Northern Intersection Curb Return Profiles 

1. Open View Window 2. (MS: Window > Views > 2) 

Note We are going to plot a profile of the edge of pavement along the main road leading into the 
curb return and continuing through the curb return and onto the entrance road. 

2. Select the Active Site Profile tool frame. (Modeler: Elements > Edit Profile) 

 



Workshop: Designing the Roadway Intersections 

 

 
GEOPAK Site I Copyright © 2003 Bentley Systems, Incorporated Do Not Duplicate 

5/16/2003 4-65 

3. Right mouse click on Profile Cell Status .  

4. Select Profile Cell Setting . 

 

5. Fill in the Profile Cell Setting information. 

Station: 0.00 

Elevation: 5240.00 

Horizontal Scale: 10.00 

Vertical Scale: 1.00 

Top Delta: 60.00 

Bottom Delta: 0.00 

6. Click Add Element PCell Chain. 

7. Select and accept the edge of pavement just before the south side curb return in the northern 
intersection. 

8. Select and accept the south side curb return element. 

9. Select and accept the adjacent edge of pavement on the entrance road. 

 

Hint Accept each selection with a data point.  You should notice arrows pointing to the elements 
that have been successfully selected. 

10.  Click Place Site PCell.  

11.  Place the profile cell in the previously opened view window 2. 

12.  Right click on the View 2 and set it to Profile (Active Profile Control).  

  

The profile is now drawn in view window 2.  As you slide your cursor along the profile you 
will notice a cursor locked on the plan view centerline element in view window 1. 
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Site Element Profile 

: Creating the North Intersection Curb Return Design Profiles 

Now that we can visually see the profile, it is time to create the design profile.  We will do 
this right on top of the existing profile. 

1. Click Vertical Component Tools. (Active Profile Control). 

 

2. Click Place Line By Points. 

3. Data point at the locations shown to create a profile line. 

DP for Tangent  

DP for Curve 

 

4. Click Create Profile Curve by 3 Points. 

5. Data point at the locations shown to create a profile curve. 
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6. Click Create Profile Curve Between 2 Elements.  

 

7. Key-in a curve Radius of 700.00.  Enable the Radius lock. 

8. Select and accept each of the two profile elements previously created.   

9. When prompted to Enter Way Point, data point in view window 2. 

10.  Click Define Site Element Profile.  

11.  Select one of the profile elements drawn in view window 2.   

12.  Following the tool’s prompts, accept the element with a data point.   

13.  Data point one final time to finish applying the profile to the site element. 

14.  Repeat the previous exercise steps using the appropriate Vertical Component tools for the 
curb return on the north side of the intersection between the Main road and the Entrance road 

: Create the South Intersection for the Roadways 

This exercise will focus on the southern intersection of the two roadways.  We are going to design the 
curb returns between the two roads to include the curb & gutter. 

Hint This exercise should be an exact replica of the previous two exercises.  Therefore, some of 
the dialogs and steps may already be completed correctly without any user input.  GEOPAK 
stores RSC (resource) files that contain the dialog settings that were active when the 
GEOPAK dialog was closed. 

1. Use the MicroStation Saved View South Intersection.  

2. Set the Object to Entrance Rd.  

 

3. Select the Modeler Element Information tool. (Modeler:  Element > Information) 

 

4. Click Select Element. 

5. Select and accept the dashed line representing the edge of pavement extension through the 
intersection.   
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6. Click the Objects tab. 

 

7. Click Add Object To List By Name.  

8. Select Entrance Rd and click OK. 

 

9. Click Update. 

10.  Click Yes to save changes to the Site Modeler Element. 

: Create the Curb Returns in the Southern Intersection 

1. Select the New/Edit Site Element tool. (Modeler: Element > New/Edit) 

 

2. Click Drape on Model/Object on the Element tab. 
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3. Enter the Element information. 

Feature Type: Break Line 

Drape on Model: Tower 

Drape Option: Vertices 

Use Power Selector: Enable 

4. Click Select Elements in the Define Elements group box. 

5. Select the two curb return elements in the intersection. 

6. Click Apply. 

Now we will create the curb & gutter for the two Curb Returns.  The curb & gutter will be the 
same as that on the rest of the entrance road. 

7. Click on the Section tab on the New/Edit Site Element dialog. 

 

8. Set the Feature Type to Boundary and the Option to Table. 

9. Click Query Section in the Manipulate Section group box.  

10.  Select and accept an edge of pavement element along the right side of the roadway. 

11.  Click OK on the information dialog. 

12.  Click Select Reference Elements  in the Reference Elements group box. 

13.  Select the two previously created curb return elements. 

14.  Click Set on the Direction group box. 

15.  Data point to the outside of the curb returns to set the Direction of Section. 

16.  Click Apply. 

We will now look at the profile along each curb return to make sure the transition between the 
two roadways is as smooth as possible. 

: Drawing the Southern Intersection Curb Return Profiles 

1. Open View Window 2. 

We are going to plot a profile of the edge of pavement along the main road leading into the 
curb return and continuing through the curb return and onto the entrance road. 
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2. Access the Active Site Profile tool frame. (Modeler: Elements > Edit Profile) 

 

3. Right mouse click on Profile Cell Status .  

 

4. Select Profile Cell Setting . 

 

5. Populate the Profile Cell Setting information. 

Station: 0.00 

Elevation: 5240.00 

Horizontal Scale: 10.00 

Vertical Scale: 1.00 

Top Delta: 60.00 

Bottom Delta: 0.00 

6. Click Add Element PCell Chain.  

7. Select the edge of pavement just before the south side curb return in the northern intersection. 

8. Select the south side curb return element 

9. Select the adjacent edge of pavement on the entrance road. 

 

Accept each selection with a data point.  You should notice arrows pointing to the elements 
that have been successfully selected. 

10.  Click Place Site PCell.  

11.  Place the profile cell in the previously opened view window 2. 
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12.  Right click on View 2 and set to Profile. (Active Profile Control tool frame).  

The profile is now drawn in view window 2.  As you slide your cursor along the profile you 
will notice a cursor locked on the plan view centerline element in view window 1. 

 
Site Element Profile 

: Creating the South Intersection Curb Return Design Profiles 

Now that we can visually see the profile, it is time to create the design profile.  We will do 
this right on top of the existing profile. 

1. Click Vertical Component Tools. (Active Profile Control Tool Frame). 

 

2. Click Place Line By Points. 

3. Data point at the locations shown below to create a profile line. 

DP for Tangent  

DP for Curve 

 

4. Click Create Profile Curve by 3 Points.  
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5. Data point at the locations shown to create a profile curve. 

 

6. Click Create Profile Curve Between 2 Elements. 

 

7. Key-in a Radius of 674.00.   

8. Enable the Radius lock. 

9. Select and accept each of the two lines previously created.  

10.  When prompted to Enter Way Point, data point in view window 2. 

11.  Click Define Site Element Profile. 

12.  Select one of the profile elements drawn in view window 2.   

13.  Following the tool’s prompts, accept the element with a data point. 

14.  Data point one final time to finish applying the profile to the site element. 

15.  We can now repeat the previous steps for the curb return on the north side of the intersection 
between the Main road and the Entrance road. 

: Add A Concrete Walkway to the Building 

1. Use the MicroStation Saved View Bldg. 

2. Set the Object to Bldg 1 in the Active Site Object Control. 

3. Select the New/Edit Site Elements tool. (Site Modeler: Element > New/Edit) 
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4. Click Drape on Model/Object. 

5. Enter the Element Information. 

Feature Type: Break Line 

Drape on Model: Tower 

Drape Option: Vertices 

6. Click Select Elements. 

7. Select the concrete walkway in front of the building. 

8. Click Apply. 

: Saving and Exiting the Project 

1. Close GEOPAK Site Modeler (Modeler: Project > Exit). 

2. Click Yes to save the current project. 

 

3. Click No to the Lock Elements alert. 
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5 
CHAPTER OBJECTIVES 

In this chapter, you will learn more about: 

• editing a site model. 

• modifying a site element or model. 

• working with element associations. 

INTRODUCTION 
In this section we will use various Site Modeling tools to edit Site Elements and Objects with in the 
proposed Site Model.  Some of the tools are simply MicroStation manipulation tools and others are 
specific to GEOPAK Site Modeler.  However all the tools are very intuitive to use.  Explanations of 
most of the tools were included in the beginning of Section 4. 

EDITING WITH SITE MODELER 
During this exercise we will learn how to edit several GEOPAK Site Objects previously created 
including Building 1, Parking Lot 1 and Pond 1.  We will explore several GEOPAK Site Modeler tools 
to aid us in reassigning elevations to elements within each Site Object.  After the successful 
completion of the previous workshop, we will have a GEOPAK Site Model called Tower. 

: Opening Existing Site Project 

1. Open the file C:\Data\Geo\Site\Site1\Chapter5\Siteplan2D.dgn (MicroStation: File>Open). 

2. Select the Site Modeler tool (Applications>GEOPAK Site>Site Modeler>Site Modeling). 

 

3. Click Browse. 

4. Navigate to and select the file …Site1\Chapter5\Siteplan.gsf. 

5. Click OK.  
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MODIFYING A SITE ELEMENT OR SITE OBJECT 
In this section we will modify some of the site elements in our building as well as its position in the 
overall site model. 

: Change Site Element Feature Type 

1. Use the MicroStation Saved View Bldg.  

2. Select the Change Feature tool. ( Site Modeler Menu: Elements > Change Feature). 

 

3. Enable Use Power Selector. 

4. Set the Feature to Boundary. 

5. Click Select Reference Element. 

6. Select the three green MicroStation elements that represent the grass area around the building. 

 

7. Click Apply. 
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: Editing the Model FIFO List 

1. Select the Edit Model tool (Site Modeler: Model > Edit).  

 

2. Select the FIFO tab. 

This FIFO Tab lists all objects currently in the model in the order in which they are merged.  
Roadway 1 is the first object merged in the model with the Base Object Ground 1.  Each 
subsequent object is merged with Ground 1 as well as the objects above it in the FIFO list.  

3. Select Bldg 1 and click Move Object Down until Bldg 1 is below Entrance Rd.  

4. Click Process. 

 
Results of the reordering the FIFO list 
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: Modifying the Pond Object 

In this exercise, we will move the pond bottom to a new location and then increase the pond area by 
scaling the pond bottom element.  The tools to accomplish this are quite simple and can be applied to 
any type of object. 

1. Use the MicroStation Saved View Pond.  

2. Select the MicroStation Move Element tool (MS: Tools > Main > Manipulate).  

3. Select the pond bottom and move it slightly towards the Main roadway.   

 

 

The inside and outside edges of the berm should also move with the pond bottom since we 
associated these elements when we created them. 

5. Select the MicroStation Scale tool. (MS: Tools > Main > Manipulate) 

 

6. Scale the pond bottom by 0.9. 

Again the inside and outside edges of the berm will also be scaled appropriately due to the 
associations. 



Modifying A Site Element or Site Object 

 

 
GEOPAK Site I Copyright © 2003 Bentley Systems, Incorporated Do Not Duplicate 

5/16/2003 5-5 

: Changing the Pond Object Side Slopes 

Moving the Pond closer to the main roadway may cause the slopes coming off of the pond to 
encroach on the roadway shoulder.  There are several ways to address this type of problem.  
Obviously we could move the pond back from the road until the slopes no longer interfere.  We 
will take a look at modifying the Object side slopes that are adjacent to the roadway.  For example 
we will modify the pond object so that we have 2:1 slopes on the side adjacent to the main road 
and 3:1 slopes along the side adjacent to the parking lot. 

1. Select the Edit Object Tool. (Modeler: Object > Edit) 

 

2. Click the Slopes tab. 

3. Set Side Slope to Dynamic Slopes. 

4. Enter 2.0 in Cut H:1 V and Fill H:1V  in the edit fields at the bottom of the dialog,  

5. Click Locate and data point for the location to start the 2:1 slope. 

 
Locations for Dynamic Slopes 

6. Click Add List Item. 
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7. Click Locate. Data point for the location to stop the 2:1 slope. 

8. Click Add List Item. 

9. Enter 3.0 in Cut H:1V and Fill H:1V  in the edit fields at the bottom of the dialog,  

10.  Click Locate and data point for the location to start the 3:1 slope. 

11.  Click Add List Item. 

12.  Click Locate and data point for the location to stop the 3:1 slope. 

13.  Click Add List Item. 

14.  Click Apply. 

 
Pond Contours After Dynamic Slopes Applied 

15.  Close your site project (Modeler:  File > Close). 

16.  Exit MicroStation. 



6 Drainage Design 
CHAPTER OBJECTIVES 

In this chapter, you will learn more about: 

• Drainage components. 
• Computation features. 
• GEOPAK Drainage (GDF) file. 
• Drainage library. 
• Navigation tools. 
• Labeler. 
• Culverts. 
• Routing. 
• DTM Drainage tools. 
• Hydrologic and hydraulic Considerations. 
• GEOPAK Road/Site data. 
• Design conveyance system. 
• Evaluate system. 

INTRODUCTION 
The GEOPAK Drainage workflow mirrors a conventional design process beginning with the design of 
the surface collection system (inlets, drainage areas) followed by the design of the conveyance system 
(subsurface pipes, channels). 

Roadway alignments, vertical profiles, and digital terrain models may be used throughout GEOPAK 
Drainage to provide pertinent information to the drainage design.  All drainage components feature 
interactive graphical placement tools for easy definition of the drainage system. 
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Drainage Components 

 
DRAINAGE COMPONENTS 

GEOPAK Drainage organizes the components of a drainage system according to their spatial 
characteristics.  Spatial information is stored as Nodes, Links and Networks. 

• Nodes:    A node (inlets, manholes, etc.) is a point feature with a user-defined location.  The 
location may be in Cartesian coordinates (x,y) or in curvilinear coordinates (station, offset).  

• Links:   A Link represents a linear feature depicting a path connecting two nodes, traversing 
upstream to downstream.  The path may be straight line or curvilinear (along a graphic element).  

• Networks:   A network is a system of interconnected nodes and links that form a system through 
which water can flow to a single outlet node. A drainage project accommodates any number of 
Networks. 

Other associated components in GEOPAK Drainage include: 

• Areas:   A drainage area can be represented by a closed boundary or simply keyed-in (acres or 
hectares). All flows from a single drainage area are tributary to a single Node. There is a one to 
one correspondence between a node and an area.  Therefore areas and nodes share the same name 
(ID). A drainage area may contain multiple subareas representing homogeneous features such as 
soil types and land uses (“C” values), thereby allowing composite "C" value calculations. 

• Profile:    A profile represents a path connecting any two or more nodes in a Network. Profiles 
provide the visualization of pipes, surface tins, crossings, etc, between any two or more nodes in a 
drainage network. 

COMPUTATION FEATURES 
Hydrologic and hydraulic capabilities include runoff computations, inlet design and analysis, and pipe 
and ditch design and analysis.  All computations follow recommended methodologies in the FHWA 
publication "Drainage of Highway Pavements" as well as the procedures in the AASHTO Model 
Drainage Manual. 

Runoff computations are performed using either the Rational or SCS method where rainfall parameters 
may be specified with common intensity equations, hydrographs, or by tabular intensity-duration data.  
Drainage area delineation tools allow easy creation of contributing areas and the graphical assignment 
of these to drainage features.  The extremely tedious task of compiling different subareas and runoff 
coefficients is practically eliminated by GEOPAK Drainage's graphical shape tool, allowing easy 
creation of drainage areas and land use boundaries.  Once the boundaries are defined, the runoff 
coefficient and associated hydrologic parameters are computed automatically by delineating the land 
use zones inside of the drainage area.  Any subsequent modifications to the boundaries will update the 
runoff coefficient via a single mouse click. 

Inlet design and analysis capabilities include Curb, Slotted Drain, and Grate inlets both on grade and in 
a sump.  Inlet designs may proceed through a user specified library of standard inlet sizes to determine 
the most suitable design for a given set of user prescribed constraints.  Inlets may also be designed or 
analyzed with by pass flows from one inlet to another, including by pass flows between inlets of 
different networks. 

Most standard pipe configurations may be designed and analyzed including arch, box, circular, 
elliptical and pipe arches.  A library of available sizes in most common materials (Aluminum, 
Concrete, Steel, and Plastic) is provided for the designer to select sizes or simply specify types for 
GEOPAK Drainage to select the appropriate size.  Pipe design selections may be optimized for either 
size or depth of cover. Trapezoidal ditches may also be designed or analyzed anywhere within a storm 
drain network.  The pipe and ditch hydraulics include backwater curve computations and junction loss 
options. 
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GEOPAK DRAINAGE FILE  (GDF) 

The main GEOPAK Drainage File has the extension *.GDF.  This binary file contains all the hydraulic 
and hydrologic information about the drainage system.  Each GEOPAK Drainage Project contains 
Preferences, which includes all computational options, visualization symbologies, and project file 
references to other commonly used files.  Spatial data, connectivity and hydraulic properties for each 
drainage feature are stored in the GDF. Sufficient data is maintained to rebuild the graphical 
representation of the Drainage Project with the exception of certain features, which are defined by 
MicroStation elements (i.e. Drainage Areas). 

MICROSTATION DESIGN FILE 
This MicroStation dgn graphics file is utilized for the visualization of the drainage project and 
definition of certain drainage features using MicroStation graphic elements.  The only data stored 
within this file are graphics and their attributes for reference to the GEOPAK Drainage file (.gdf). 

DRAINAGE LIBRARY 
In contrast to the Drainage File and MicroStation graphics file, the Drainage Library is utilized for 
numerous projects, as it contains the standards for an entire organization.  The Drainage Library 
contains the rainfall parameters, standard inlet types, standard pipes configurations, spread sections, 
and land use symbology tables. All of these items are merely referenced by each project to 
accommodate standardization and information sharing among projects. 

NAVIGATOR TOOLS 
The Navigator provides an easy method to guide through the components in a GEOPAK Drainage 
project and affords the following functionality: 

• Navigate components of the drainage system. 
• Query analysis and design violations based on established parameters. 
• Form a list of candidates for investigation or modification based on component query parameters. 
• Cross reference components in the GEOPAK Drainage file database with the graphical 

representation in the design file. 
• Shortcuts to add, edit, and delete drainage components. 
• Tools to identify and graphically locate drainage components. 
• The Global Editor to edit input parameters. 
• Update Graphics tool to redisplay any or all of the graphical representations of the drainage 

components. 
• Update Pay Items tool. 

 

GEOPAK Site I Copyright © 2003 Bentley Systems, Incorporated Do Not Duplicate 

5/16/2003 6-3 



Labeler 

 
LABELER 

The Labeling automates the composition and placement of plan labels onto drawings.  This interactive 
tool permits the creation of very simple to complex labels using many of the following features:  

• Numerous Computed Text Inserts permit standardized computed values to be easily incorporated 
into labels.  These standardized computed values are based on the type of element to be labeled 
and change as different elements are selected by the user. Types of elements available for 
computed inserts include points, lines, arcs, complex graphic elements, COGO features, and 
drainage features. 

• User Text Inserts facilitate the simple inclusion of user defined  text strings into the label. These 
User Inserts can be customized to include frequently used labeling terms and be saved for 
continual use. 

• Standard shapes can be placed around labels and to accommodate different plan label formats. 
• Standard leader lines and leader line terminators can also be utilized to create the desired label 

formats. 
• Frequently utilized labels can be stored as Label Styles for subsequent recall.  The complete label, 

including computed text inserts, user inserts, shapes, and leaders, are all stored within the Style. 
• Tools to edit, move, and extract labels are also provided to make manipulation and plan changes 

easier. 
• Enhanced ASCII is supported by use of the (\) symbol. 
• Styles are supported, whereby often used labels and associated settings can be saved off and 

recalled in subsequent sessions. 
• Updating options provide for efficient changing as the project dictates changes in the design. 

CULVERT 
GEOPAK Culvert is a powerful tool for the design and analysis of culvert structures.  Located within 
GEOPAK Drainage, the Culvert tool can leverage data from a coordinate geometry database (GPK), a 
Site Modeler database file (GSF), the Drainage database file (GDF) or a binary TIN file.  This enables 
the user to utilize roadway and / or storm sewer data, both existing and proposed. 

ROUTING 
The GEOPAK Routing tool supports the creation and manipulation of runoff hygrograph data in 
accordance with SCS TR20 methodologies. Runoff Hydrographs can be created, added, and routed 
through Reaches and Reservoirs. 

DTM DRAINAGE TOOLS 
Located at the bottom of the Utilities pulldown, the DTM Drainage Tools provide a number of 
functions to evaluate DTMs for flow patterns, flow paths, drainage area delineation, and other DTM 
drainage related tools. 
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HYDROLOGIC AND HYDRAULIC CONSIDERATIONS 

When beginning a GEOPAK Drainage project, certain hydrologic and hydraulic design criteria must 
be established.  Of course, changes can be made throughout the design process, however, sound 
criteria from the onset of the project lends to a more productive design.  

Typical hydrologic and hydraulic criteria to establish at the beginning of a GEOPAK Drainage project 
include: 

• The type of rainfall data, supported by GEOPAK Drainage, to be used in the intensity 
calculations.  This may include intensity-duration-frequency tables, SCS Unit Hydrograph, SCS 
Cumulative Hydrograph, or intensity equations.  Attention should be paid to the units of the 
project. 

• The design and analysis frequencies to be used on the project and the availability of rainfall data 
for these frequencies. 

• Any standard runoff coefficients and land uses applicable to the drainage basins within the 
contributing project area. 

• The types of inlets and other Node structures to be included in the project including all the 
dimension information and relevant hydraulic properties for each. 

• The different shapes, materials, and sizes of pipes to be included in the project along with 
pertinent pipe hydraulic information. 

GEOPAK ROAD/SITE DATA 
GEOPAK Drainage is designed to leverage a great deal of GEOPAK Road and DTM design 
information, if such data exists.  While no roadway or DTM data is required to complete a design in 
GEOPAK Drainage, having this information fully exploits the capabilities of GEOPAK Drainage.  The 
availability and accuracy of such data should be an early consideration in the development of a 
GEOPAK Drainage project.  

Most of the Drainage features referenced to the Roadway and DTM are automatically calculated once 
the reference to the source of the information is established. These values are automatically updated as 
features are changed, edited or moved.  This leveraging reduces the amount of user derived and 
computed information and greatly reduces efforts as design features are revised.  

Special attention should be given to the purpose, source, and accuracy of DTM data used in GEOPAK 
Drainage projects.  The terrain model typically needs to contain a model of the proposed roadway 
design. When used for contributing drainage areas, this model may need to be merged with a DTM 
containing the definition of the surface outside the roadway area to have adequate topographic 
coverage.  DTMs used for evaluation of drainage patterns, and not specific elevation data, could be 
created to lesser detail since the patterns are the only item of interest.  Conversely, DTMs used for 
specific elevation and profiles must be created with a detail commensurate with the accuracy required 
for such information.  The DTMs for roadways containing superelevation transitions, sag vertical 
curves, and other profile and elevation anomalies of concern to drainage designers, should be given 
special consideration in their creation. 
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DESIGN SURFACE COLLECTION SYSTEM 

The design of the surface collection system (inlets) proceeds in an iterative fashion similar to 
conventional methods.  The roadway or terrain should be evaluated for critical surface drainage points 
such as low points, zero transverse slope regions, high points etc.  These critical points often indicate 
the initial or required location of inlets. The inlet (Node) is located, the drainage area delineated, the 
inlet hydraulics are performed and checked for compliance with design criteria (i.e. spread, capacity, 
by pass flows).  If a node meets the design criteria and the location acceptable, it is added to the 
database and then the next inlet is placed.  All the surface collection features may be located, their 
respective drainage areas delineated, and then hydraulically analyzed for adequacy. 

The results of any portion or all of the system can be viewed and reported at any time.  Upon 
successful layout of the surface collection, the conveyance system is ready to be designed. 

DESIGN CONVEYANCE SYSTEM 
With the inlets (Nodes) located, decisions regarding pipe (Link) alignment, the location of Junctions 
(Nodes), other confluences and the system outlet completes the initial Node network.  Links are 
defined between the Nodes completing the network connectivity to the outlet.  A Network may then be 
added by defining the outlet Node and the complete Network hydraulic calculations can be computed. 

EVALUATE SYSTEM 
Once the Network computations have been performed, all the features in the network can be evaluated 
for adequacy. Many tools are provided to assist in this phase including Reports, querying within the 
Navigator and drawing profiles. Computation options may be revised in the Preferences or drainage 
components themselves modified and the Network re-evaluated until a satisfactory design is achieved. 
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WORKSHOP: DRAINAGE DESIGN 

� Project Setup 

1. Open the MicroStation design file  ..\Data\Geo\Site\Site1/Chapter6/Siteplan_Drainage.dgn. 

2. Select the GEOPAK Drainage tools (Applications > GEOPAK DRAINAGE > Drainage). 

All tools in Drainage can be accessed through this main GEOPAK DRAINAGE Menu Bar.  
GEOPAK Drainage opens an untitled project file.   

 

3. Open the project file  ../Data/Geo/Site/Site1\Chapter6\Siteplan_Drainage.gdf.   

(Drainage menu:  Project > Open). 

� Setting the Drainage Preferences 

The Project Preferences control the graphic and computational options of the drainage system. The 
Project Preferences may be changed at any time and the system can then be redesigned or analyzed 
utilizing the new preferences.  

1. Select the Preferences tool (Drainage menu:  Project > Preferences). 

2. Select Units and set to English. 

3. Select Project Components. 

These Preferences have already been set for this project.  Preferences may be changed at any 
time during the project, and the network(s) then redesigned to accommodate the new 
Preferences.  Review the other options with your instructor or refer to the On-Line Help > 
Drainage > Project Preferences. 

4. Click OK.  
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WorkShop: Drainage Design 

 
5. Enter the following information. 

Drainage Library (DLB): ..\Data\Geo\Site\Standards\drainlib.dlb 

GPK Job Number:   200 

Drainage Cell Library: ..\Data\Geo\Site\Standards\nodes.cel 

GEOPAK DDB: ..\Data\Geo\Site\Standards\site.ddb 

GEOPAK Site Project:   Enable toggle,  
..\Data\Geo\Site\Site1\Chapter6\Siteplan.gsf 

Original Ground: Site Object; Ground 1 

Design Surface: Site Model; Tower 

Note These Preferences have already been set for this project.  Preferences may be changed at 
any time during the project, and the network(s) then redesigned to accommodate the new 
Preferences.  Review the other options with your instructor or refer to the On-Line Help > 
Drainage > Project Preferences. 

6. Click OK.  

� Reviewing the Drainage Library 

The Drainage Library is used to store hydraulic, hydrologic, and construction standards, which may be 
shared by different projects and designers.  Each GEOPAK Drainage project accesses items from the 
Drainage Library for use on any project. 

1. Select the Drainage Library tool (Drainage menu:  Project > Drainage Library). 

  

TAB DESCRIPTION 

Rainfall Rainfall Data Source 

Land Uses Land Uses and their corresponding “C” values and symbology 

Nodes:  Inlets, Junctions, Manholes, Outlets, etc. 

Links:  Circular Pipes, Elliptical Pipes, Pipe-Arch pipes, Boxes, etc. 

Spread Section:  Inventory of varying Spread Cross Sections 
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WorkShop: Drainage Design 

 
2. Click the Rainfall tab. 

The Rainfall Tab stores the rainfall data information to be used on GEOPAK Drainage 
Projects.  GEOPAK Drainage supports rainfall sources in the form of intensity duration 
frequency (IDF) tables or as coefficients for intensity-duration-equation formats.  Also 
supported are the HYDRO-35 and TP 40 methods of rainfall. 

3. Double-click Zone 1. 

Alternately, highlight Zone 1 and click Modify Library Item (right of list box).  

Note the various Data Type options available in the upper right corner.  

4. Click OK. 

5. Click on the Land Use tab. 

The Land Use Tab is used to store runoff coefficients ("C" values) and corresponding graphic 
symbology for each land use.  Land Uses can then be delineated automatically using the 
selected symbology. 

6. Select Private Land Uses, and click Modify Library Item. 

7. Review the various entries. 

8. Click OK. 

9. Click on the Nodes tab. 

The Nodes Tab contains standard configurations for Curb, Grate and Slotted Drain inlets as 
well as Junctions, Outlets and Other Nodes.  The description, plan view representation and 
dimensional information is stored for each node.  

10. Double click the first Curb Inlet. 

 

11. Click Select to the right of the Plan View Cell to open the Select Cell from Library dialog. 

12. Click Cancel to close.  

13. Review the various entries in the Node Item dialog. 

14. Click OK. 
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WorkShop: Drainage Design 

 
15. Click on the Links tab. 

The Links Tab contains all pipes to be used on the Drainage project.  Each pipe is categorized 
by three properties: Shape, Material, and Type (corrugation); and contains information 
regarding specific pipe geometry, default roughness coefficient, and material combination. 

16. Double click on the first Circular Concrete pipe. 

 

Note the various geometric input required for the Links. 

17. Click OK. 

18. Click on the Spread Section tab. 

The Spread Section stores standard cross sections (for roads, gutters, etc.) to be used on 
GEOPAK Drainage Projects.   

19. Double click on the 50' ROW. 

 

Note the spread cross-section characteristics for each spread item. 

20. Click OK. 

21. Close the Drainage Library without saving changes (File > Close).  

22. Click No to saving changes. 
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WorkShop: Drainage Design 

 
� Locate the Low Points 

Note The “Siteplan.dgn” file is referenced. This referenced DGN file contains the plan view graphics 
used for the Site design. We will initially be focusing on the parking lot. Use MS window 
commands to window in on the parking lot. 

1. Select the Site Modeler Tool (Applications > GEOPAK Site > Site Modeler > Site 
Modeling). 

2. Toggle on Open Existing Project. 

3. Click Browse and select  ..\Data\Geo\Site\Site1\Chapter6\Siteplan.gsf. 

4. Click No when prompted to associate the design file. 

 

5. Select the DTM Drainage Tools tool (Drainage:  Utilities > DTM Drainage Tools). 

6. Select the Delineate Low Points tool. 

 

Note We have set the Minimum Low Point Depth to 0.200. This allows the tool to ignore “false” low 
points in the surface. 

7. Double click on sample graphic element and set symbology as desired. 

8. Enable Set Graphic Group. 

9. Set Arrow Size to 5.0. 

10. Set Minimum Low Point Depth to 0.2. 
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WorkShop: Drainage Design 

 
11. Click Apply. 

 

12. Close the DTM Drainage Tools dialog. 

13. Close the Site Modeler (Modeler: Project > Exit). 

� Placing Inlet CB-1   

1. Select the Navigator tool (Drainage:  Utilities > Navigator). 

 

2. Click Node from short-cut tools at the top of the Navigator. 

3. Click Add Item (right side of list box.) 

 

The default Node ID is set to CB-1 per our project preferences. 
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WorkShop: Drainage Design 

 
4. Click OK. 

 
5. Enter the Properties information. 

Node Type Curb 

Profile Sag 

Library Item 10' Curb Type A 

6. Highlight Location. 

This option defines the inlet's location in the design plane. 

 
7. Enter the Location information. 

Align: Tangent on Element 

Angle 180 

8. Click Select MS Alignment Element  (right of the Align option). 

9. Select and accept the edge of pavement element for the southern most low point. 
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10. Click Station DP to dynamically place the inlet. 

The inlet follows your cursor movement. 

11. Data point to place the inlet at the low point 

12. Highlight  Spread Criteria. 

Assign the roadway cross sectional characteristic directly in front of the inlet.  These values 
will be utilized to calculate inlet capacity and resulting by-pass flow: 

 

13. Enter the Spread Criteria information 

% Slope Left: 2 (Longitudinal slope from the left of the inlet) 

% Slope Right: 0.5 (Longitudinal slope from the right of the inlet) 

% Discharge Left: 10 

% Discharge Right: 90 

Spread Source User Supplied 

Spread Source Width: 63.0 (the width of the parking bays and roadway) 

Spread Source % Slope: 2.0 (Parking Lot cross slope). 

Spread Source Manning’s n: 0.012 

Maximum Pond Depth 0.70 

Pond Width 15.0 
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14. Select Elevations. 

 

15. Assign the inlet's vertical elevation and vertical pipe alignment preferences. 

Reference Surface Site Model; Tower 

Elevation Source Reference Model 

Node Elevation Option Same as Source 

Vertical Alignment Match Soffit 

Minimum Depth 3 

Maximum Depth 10 

16. Highlight Junction Loss. 

17. Toggle on Defined Equations. 

18. Highlight Discharge Options. 

19. Toggle on Use Computed Discharge. 

20. Highlight Computations. 

Note Error Performing Inlet Computations:  The Drainage Area for this node won’t be added until 
the next step.  Therefore, the Computations for the node can’t be completed until a discharge 
is known (next step). 

21. Click Apply. 

22. Close the Node Configuration dialog.   
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� Defining the Drainage Area for CB-1 

1. Select the MicroStation Place Shape tool. (MS:  Polygons tool box > Place Shape). 

2. Draw the closed shape similar to the illustration below.  

This closed shape will be selected as the drainage area (next step).  

 

3. Click Area in the Navigator. 

4. Click Add Item. 

 

Change the Area ID to CB-1. 

Note The Area ID and the Node ID should be the same.  That establishes the relationship between 
the two. 

5. In the Drainage Area Definition dialog, click Select Shape. 
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6. Select and accept the shape that was just drawn to represent the drainage area. 

7. Set the Base C Value to 0.35. 

8. Set the Time of Concentration to 5.00.   

9. Select Subareas. 

10. Toggle on Display Only. 

11. Click Automatic Delineation. 

The file is scanned for closed shapes matching the Land Use symbology specified in the 
Drainage Library (Land Use Tab). 

 

12. Select Computation. 

13. Click Compute Discharge. 

Note the Computed Discharge is now displayed. 

 

14. Click Apply. 

This applies the land uses (and their “C” values) to the Drainage Area. 

15. Use the MicroStation Update View command, if required, to remove the temporary fill.   
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� Define Drainage Area for CB-2 

1. Place the closed shape similar to the illustration below.   

 

2. Click Add Area on the Drainage Area dialog. 

The Area ID should be set to CB-2. 

3. Select Definition. 

4. Click Select Shape 

5. Select and accept the previously placed closed shape. 

The Drainage Area field is populated with the area of the shape. 

6. Set the Base C Value to 0.93. 

This is for the pavement runoff coefficient (no other land use delineation is necessary). 

7. Set the Time of Concentration to 5.0 minutes.   

8. Select Computations. 

9. Click Compute Discharge. 

We have finalized the Drainage Area computations. 

10. Click Apply. 

11. Select Definition. 

 

GEOPAK Site I Copyright © 2003 Bentley Systems, Incorporated Do Not Duplicate 

5/16/2003 6-18 



WorkShop: Drainage Design 

 
� Place Inlet CB-2 

1. Click Edit Node  (located in the top right hand corner of the Details group of the Drainage 
Area Definition dialog). 

 

The Node ID should be CB-2. 

2. Highlight Properties. 

Note that the dialog box settings are defaulted to the previous setting.  No changes are 
required for this inlet. 

3. Highlight Location. 

Note again all stored dialog box settings are appropriate for this inlet location. 

4. Click Select MS Alignment Element.  ( right of the align option) 

5. Select and accept the edge of pavement near the low point on the middle curb island. 

 

6. Set the + Angle to 0. 

7. Click Station DP and data point to place the inlet at the low point 

The inlet follows your cursor movement and place the inlet at the low point. 
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8. Highlight Spread Criteria. 

Assign the roadway cross sectional characteristic directly in front of the inlet.  These values 
are utilized to calculate inlet capacity and resulting by-pass flow. 

 

8. Enter the Spread Criteria information. 

% Slope Left: 2 

% Slope Right: 0.5 

% Discharge Left : 10 

% Discharge Right: 90 

Spread Source: User Supplied 

Spread Source Width: 50 

Spread Source % Slope: 3 

Spread Source Manning’s n: 0.012 

Maximum Pond Depth 0.7 

Pond Width 15 

9. Select Elevations. 

10. Assign the inlet's vertical elevation and vertical pipe alignment preferences. 

Reference Surface Site Model, Tower 

Elevation Source Reference Model 

Node Elevation Option Same as Source 

Vertical Alignment Match Soffit 

Minimum Depth 3 

Maximum Depth 10 

11. Select Computations. 

Note The Junction Loss and Discharge Options should be the same as previously set when 
creating CB-1. 

12. Click Apply.   

13. Close the Node Configuration dialog.   
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� Define Drainage Area for CB-3 

1. Place the closed shape similar to the illustration below. 

 

2. Click Add Area on the Drainage Area Definition dialog.  

3. Set the Area ID to CB-3. 

4. Highlight Definition. 

5. Click Select Shape, select and accept the previously placed closed shape. 

6. Set the Base C Value to .93 

This is for the pavement runoff coefficient (no other land use delineation is necessary). 

7. Set the Time of Concentration to 5.0 minutes. 

8. Select Computations. 

9. Click Compute Discharge. 

10. Click Apply. 

11. Highlight Definition. 
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� Place Inlet CB-3 

1. Click Edit Node. 

The Node ID should be CB-3. 

2. Select Location. 

3. Click Select MS Alignment Element.  

4. Select and accept the gutter flow line near the low point on the upper curb island. 

 

5. Set the + Angle to 0. 

6. Click Station DP to dynamically place the inlet. 

7. Data point to place the inlet. 

8. Highlight Spread Criteria. 

 

9. Enter the Spread Criteria information. 

% Slope Left: 2 

% Slope Right: 0.5 

% Discharge Left : 10 

% Discharge Right: 90 

Spread Source: User Supplied 

Spread Source Width: 50 

Spread Source % Slope: 2 
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Spread Source Manning’s n: 0.012 

Maximum Pond Depth 0.7 

Pond Width 15 

10. Select Elevations. 

11. Assign the inlet's vertical elevation and vertical pipe alignment preferences. 

Reference Surface Site Model, Tower 

Elevation Source Reference Model 

Node Elevation Option Same as Source 

Vertical Alignment Match Soffit 

Minimum Depth 3 

Maximum Depth 10 

12. Select Computations. 

13. Click Apply. 

14. Close the Node Configuration dialog. 

15. Close the Drainage Area Definition dialog.  

� Placing Inlet CB-4 

1. Select the Add Node tool and set the Node ID to CB-4. 

2. Highlight Properties. 

 

3. Set Node Type to Junction. 

4. Set Library Item to 4x4 Junction. 
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5. Highlight Location. 

 

6. Enter the Coordinates / Stationing information. 

Align Tangent to Element 

+Angle 180 

7. Click Select MS Alignment Element.  

8. Select and accept the back of curb element on the north side of the entrance road. 

 

9. Data point behind the curb. 

(Ensure the junction is placed in the region between the curb and gutter and the building 
grassed area). 

10. Click Apply. 

The inlet is added to the project.  No Computations are available for Junctions within this 
dialog box.  

� Placing an Outlet 

1. Click Add Node and set Node ID to Outlet. 

2. Click OK. 
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3. Select Properties. 

 

4. Set Node Type to Outlet. 

5. Set the Library Item should change to Std. Outlet. 

6. Highlight Location. 

 

7. Enter the Coordinates / Stationing information. 

Align At Point 

+Angle 180 

� Determine Location of Outlet 

To find the location to place the outlet, we shall examine the Site Model.  

1. Select the Site Modeler Tool and open the existing project ..\Site1\Chapter6\Siteplan.gsf. 

2. Click No when prompted to associate the design file. 

3. Select the DTM Drainage Tools tool (Drainage:  Utilities > DTM Drainage Tools). 
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4. Click Downstream Trace.  

 

5. Click Apply. 

6. Data point near the previously created junction node. 

A downstream trace (path of overland flow) is drawn from the DP location.  

Note We will place the Outlet node near the end of this trace. 

 

8. Close Downstream Trace. 

9. Exit Site Modeler. (Modeler: File > Exit). 

Return the focus to the Node Configuration dialog. 

10. Click Dynamic Place.  

11.  Place the outlet at the location shown in the figure above. 

12. Click Apply to add the outlet to the project. 

13. Close the Node Configuration dialog. 
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STORMWATER CONVEYANCE  

This section utilizes tools necessary for connecting the Surface Drainage (areas, inlets) to the 
Collection System (pipes, ditches, channels). 

� Placing a Storm Drain Pipe 

Visually determine the tentative location of the first storm sewer pipe.  This link will connect 
Nodes CB-1 and CB-2. Window in to this area using MS view controls. 

1. Select the Add Links tool (Drainage:  Component > Link > Add). 

The Add Link tool can also be accessed from the Drainage Navigator by clicking on Links at 
the top of the Navigator and clicking Add Item. 

 

2. Set the Link ID to SS-1. 

3. Highlight Definition. 

In this dialog, we set the pipe's From Node and To Nodes ID’s.  

 

4. Set the From Node to CB-1. 

Alternately, click From Node, then select and accept the CB-1 plan graphic element. 

5. Set the To Node to CB-2. 

A temporary graphic element is drawn connecting the two inlets. 

6. Set Shape to Circular in the Configuration group box. 

7. Set Material to Concrete.  

8. Toggle on Design Size. 

 

GEOPAK Site I Copyright © 2003 Bentley Systems, Incorporated Do Not Duplicate 

5/16/2003 6-27 



WorkShop: Drainage Design 

 
9. Select Conditions. 

The elevations shown are based on the From-Node and To-Node elevation minus the min/max 
depth, as specified in the Node Definition Dialog Box for Nodes CB-1 and CB-2 respectively.  
In this case, no entries are necessary; Drainage will design all the profiles for this project. 

 

10. Select Constraints. 

 

11. Establish the min/max design criteria for Links. 

Rise - Minimum 1 

Rise – Maximum 4 

% Slope – Minimum 0.5 

% Slope – Maximum 12 

Velocity – Minimum 0.5 

Velocity - Maximum 12 

12. Select Computations. 

The computed hydraulic properties of the Link are displayed. 

Note Note: Link hydraulics are not available for review until a Network has been established and 
designed or analyzed (next step) successfully.  Check back here for computations after the 
Network has been added and designed or analyzed. 
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13. Click Apply. 

Note that the Link graphic should connect to the inlets properly (i.e. the upstream end of the 
pipe should connect to the downstream area of the inlet, whereas the downstream end of the 
pipe should connect to the upstream area of the inlet) as shown below. 

 

Warning If the pipe did not connect as shown above, simple click the ID buttons again and reselect the 
To and From Nodes (hint: data point closest to the connection point desired). 

14. Add Links between all of the following Nodes. 

LINK FROM NODE TO NODE 

SS-2 CB-2 CB-3 

SS-3 CB-3 CB-4 

SS-4 CB-4 Outlet 

Adding the three links completes the remainder of the link conveyance system.  As Links are 
added, most dialog values default from the previous Link with the exception of the (From and 
To) Node and elevation information.  

 

15. Close the Link Configuration Definition dialog. 

16. Save the Drainage Project. (Drainage menu bar. Project>Save). 

17. Close GEOPAK Drainage. (Drainage menu bar. Project>Exit). 
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DESIGNING THE NETWORK 

The Network computations serve as the final calculation process in the design or analysis of a storm 
drain system.  A GEOPAK Drainage Network is defined as a series of interconnected Nodes, Links, 
and Areas, draining to a single outlet.  GEOPAK Drainage accommodates multiple Networks in a 
single project. 

To ensure that all students have the same data, we open a completed design file and drainage project. 

� Open Updated Dataset 

1. Open the MicroStation file C:\Data\Geo\Site\Site1\Chapter6\updated_drainage.dgn. 

2. Open the Drainage project 
C:/Data/Geo/Site/Site1\Chapter6_NetworkDesign\updated_Drainage.gdf.  (Drainage menu:  
Project > Open). 

� Create Network - Tower 

1. Select the Add Drainage Network tool (Drainage menu:  Network > Add). 

 

2. Enter the Network ID as Tower.  

Since we only have one outlet in the project, the Outlet Node is already set. 

3. Click OK. 

 

4. Click Build Network in the Validation group box.  

This feature verifies the nodal topology and link connectivity. An Information dialog is 
displayed indicating whether the network was successfully built.  If your network did not 
build, advise the instructor who will assist you in locating the problem link or node.  

The Select Network option highlights all components (areas, inlets, pipes, etc.) connected to 
the active Network. 
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5. Click OK on the information dialog. 

 

6. Click Apply. 

The Network Tower has been added to the project. 

7. Click Compute Network in the Computations group box.  

This command initiates the hydraulic design of the components contained in the Network.  

8. Click OK on the information dialog. 

If the network is computed with warnings, a text file 
(..Data/Geo/Site/Site1Chapter6/drgmsg.txt) is displayed with a list of hydraulic warnings. 

 

9. Close the Text Editor dialog. 

Note The Network has now been built and analyzed. We need to make it active. 

10. Close the Network Configuration dialog. 

11. Select the Active Network tool (Drainage menu:  Network > Active). 

 

12. Highlight Tower. 

13. Click OK. 
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� Profile Creation 

The Profile tool is utilized to construct customized drainage profiles (including groundline, pipes, 
depth of cover, hydraulic gradeline, etc. according to the Preferences > Design Symbology > Profile 
View) along any drainage path.   

1. Open MicroStation View Window 2. (MS: Window > View > 2) 

2. Click MS Fit View. 

3. Click MS Window Area.  Find an unused portion of the DGN file. We will place our profiles 
here. 

4. Select the Add Profile tool (Component > Profile >Add). 

 

5. Enter Profile Information. 

Profile ID: Profile A 

Description: Left Parking 

From Node: CB-1 

To Node: Outlet 

6. Click Apply. 

 

7. Select File > Open  ..\Data\Geo\Site\Standards\Drainage_Profile_Prefs.ppf. 

The predefined preferences for drawing profiles are stored in the preferences (ppf) file.  By 
using preferences files, you can develop your own standards to be utilized on numerous 
projects.   

8. Click DP and select a data point in MicroStation view window 2 for the bottom left of the 
profile to be drawn.  
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9. Click on the other tabs to review some of the profile drawing options. 

10. Click Apply.  

 
Profile A From CB-1 through Outlet 

� Dynamically Editing the Profile 

As can be seen from the screen capture of the profile, there is a problem. The proposed drainage 
system link between CB-4 and Outlet protrudes above the proposed finished surface. This is generally 
not a desirable outcome. We will look at what steps are required to modify this system to correct the 
problem. 

1. Select the Link Profile tab. 

2. Click ID. (left of the Link List box). 

3. Select and accept a component of the problem link (SS-4) from the Profile view. 

This will make the SS-4 Link active. 

4. Click Edit Invert from the Downstream Node group box. 

5. Move your mouse cursor into the Profile view. 

There is a circle around the downstream invert at Node CB-4. 

6. Move the cursor into the circle and drag the invert down.  

The link SS-4 will dynamically follow your cursor. 

7. Data point to define a new invert location in the Profile view. 

8. Click Apply. 

9. Click No to the Alert. 

10. Close the Edit Drainage Profile dialog. 

The link SS-4 now looks good – but the link SS-3 is very steep. The problem is when we 
dragged the outlet at CB-4 down, the invert at that upstream node was dragged down also. 
The reason this occurred is the Node has been set to match inverts.  We need to reset this 
Node to allow for a drop manhole. 
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� Reset Node to Drop Manhole 

1. Select the Edit Node tool. (Component > Node > Edit). 

2. Select CB-4 from Node ID. 

 

3. Select Elevations. 

4. Set Vertical Alignment to Allow Drop Manhole. 

5. Click Apply. 

6. Close the Node Configuration dialog. 

We reset the allowable pipe configuration for this Node, now GEOPAK Drainage needs to 
redesign the system. 

7. Select Network Compute. 

8. Click OK. 

Take note of what happens to the profile. 

 
Note There were no network warnings during this computation. Allowing this node to have drops 

has allowed GEOPAK Drainage to redesign this system and fix the previous “above maximum 
velocity” issues.
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� Generating Reports 

Drainage provides a number of tools to create and generate both standard and customized report files.  

1. Select the Drainage Area Report tool (Drainage menu:  Reports > Drainage Areas). 

2. Select the Sag Inlets Report tool (Drainage menu:  Reports > Inlets >Sag Inlets). 

3. Select the Sag Inlets Report tool (Drainage menu:  Reports > Storm Drain /Links >Link 
Configuration). 

A customized report via the Report Builder will consist of row and column data as prescribed 
by the designer; and may be easily imported into other applications that are designed for 
processing row and column data. 
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7 
CHAPTER OBJECTIVES 

In this chapter, you will learn more about: 

• water and sewer project components. 
• water and sewer line tools. 
• water and sewer node tools. 
• water and sewer profile tools. 
• navigator. 
• conflict finder. 
• designing a water and sewer system. 

INTRODUCTION 
GEOPAK Water and Sewer is a comprehensive system for designing Water and Sewer systems.  A 
GEOPAK Water and Sewer project may contain multiple water and sewer runs; each comprised of any 
number of topologically connected water and sewer nodes and pipes.   

GEOPAK Water and Sewer is extremely flexible, in that the designer can create and manipulate 
elements of the system, while simultaneously seeing the effects.  Interactive dialogs and design 
visualization make the process easy to learn and can efficiently produce results.  Manipulations and 
redesign are accomplished quickly and easily, whether it's moving a single node or developing an 
entire system.  The Conflict finder tool enables the designer to identify potential problems where 
sewer, water and utilities conflict.   

Roadway alignments, vertical profiles, and digital terrain models created as part of the surface design 
process may be used throughout GEOPAK Water and Sewer to provide pertinent information to water 
and sewer design.  All water and sewer components feature interactive graphical placement tools for 
easy spatial definition of the water and sewer system. 

WATER AND SEWER PROJECT COMPONENTS 

GEOPAK Water and Sewer has three major components within each project:  the GEOPAK Water and 
Sewer File (*.GWS), MicroStation design file (*.DGN), and Water and Sewer Preferences (*.WSP). 

GEOPAK WATER AND SEWER FILE (*.GWS) 

The first component is the GEOPAK Water and Sewer File (*.GWS).  This binary file contains all 
information about the Water and Sewer system.  Each GEOPAK Water and Sewer Project contains 
Preferences, which include visualization symbology, and project file references to the GEOPAK Site 
Project (.GSF), Design and Computation Manager (.DDB), GEOPAK Drainage project file (.GDF), 
Water and Sewer Library and GEOPAK coordinate geometry (.GPK) files.  Spatial data and 
connectivity for each Water and Sewer feature are stored in this external file. Sufficient data is 
maintained to rebuild the graphical representation of the Water and Sewer Project.  The main 
components of the water and sewer system are called nodes and lines.   



Water and Sewer Project Components 
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• A node is a point feature with a defined location.  The location may be in Cartesian coordinates 
(x,y) or in curvilinear coordinates (station, offset).   

• A line represents a linear feature depicting a path connecting two nodes, running from upstream to 
downstream.  The path may be straight line or curvilinear (along any graphics element).   

DESIGN FILE 

The graphics file is utilized for the visualization of the Water and Sewer project and definition of 
certain Water and Sewer features using MicroStation graphic elements.  The only data stored within 
this file are attributes attached to the graphics for reference to the GEOPAK Water and Sewer file 
(.GWS). 

WATER AND SEWER PREFERENCES 

In contrast to the Water and Sewer File and MicroStation graphics file, the Water and Sewer 
Preferences file may be utilized for numerous projects, as it contains the standards for an entire 
organization.  The Water and Sewer Preferences includes units option, paths and file names for site and 
drainage projects, symbology and text parameters for labeling and saving options.  At the beginning of 
a project, the designer may open the standard preferences, then edit the project specific files and paths.  
In this way, the designer may carry standards from one project to the next, without redundant entering 
of each parameter.  The file is saved off to the project with an .WSP extension. 

Computation options in the Preferences may be changed easily and the systems completely redesigned 
utilizing the new computation options.  The Water and Sewer Preferences are invoked via Project > 
Preferences menu selection or the Project Tools tool box. 

 
GEOPAK Water and Sewer Preferences dialog 

The general groupings of Options are displayed in a list box in the left side of the dialog, while the 
right side displays parameters for the highlighted Option.  As different Options are selected in the list 
box, the right side of the dialog will change dynamically to reflect the parameters for highlighted 
Option. 
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UNITS 

 

The first Preference is Units, which establishes the input and output units for the current project.  Two 
supported options are English and Metric.  Within each group box is a listing of the units utilized for 
GEOPAK Water and Sewer.  These are display only and cannot be changed. 

Note Projects with mixed units are not supported within GEOPAK.  There are no other unit 
specifications within the project.  The data input is expected to be in the proper units (English 
and Metric).  As fields are entered in the dialogs the units required will be displayed in the 
MicroStation Command Prompt. 

PROJECT COMPONENTS 

 

The Project Components option defines the location of GEOPAK files utilized by the water and sewer 
project. 
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TERRAIN 

 

To leverage data from a GEOPAK Site project, activate the toggle, and then select the directory and 
GEOPAK Site Project  (.GSF) file.  The option becomes available to select components from the Site 
Project (Models or Objects) as the Original Ground and Design surfaces. 

Alternately, a TIN file (created with GEOPAK DTM tools) can be used to define existing or original 
ground.   
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NAMING 

 

The Naming option sets symbology and labeling parameters for water and sewer lines and nodes. 

The parameters are utilized for the labels only, as the symbology for the line or node itself is 
determined from the Item ID within the Design and Computation Manager.  This prefix is added to the 
beginning of the each defined Node or Line label automatically. When By Number is selected, each 
pipe (or node) added to the system is incremented by the specified number. 

SEWER MANHOLES 

 

You can specify dimension, type, and symbology options for sewer manholes drawn into profile.  As 
each of the three types is selected, the dialog dynamically changes to reflect the selection. 

SEWER LINES 

You can specify the minimum slope and updating options for sewer lines. 

SAVE OPTIONS 

There are options to create a backup file when the project is opened as well as automatically saving the 
project at a user specified interval. 
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WATER AND SEWER LINE TOOLS 
In GEOPAK Water and Sewer, Lines connect the various Nodes within a system.  A multitude of 
options for sizing and profiling Lines are supported.  

A Line represents a linear feature depicting a path connecting two or more Nodes.  The path may be a 
straight line, line string, curvilinear, or a combination and series of linear MicroStation elements. 

Several options are supported to add, edit, and delete Lines and are invoked via the Lines pull down on 
the main menu bar. 

Alternately, the Line tools are invoked by selecting Tool Bars > Water Lines or Sewer Lines, then 
identifying the desired tool from the toolbox as depicted below. 

 

The tools for Water and Sewer are functionally identical and are detailed in the table below. 

Add 

    

Utilized to add a water or sewer line to the current GEOPAK Water and Sewer 
project. 

Edit 

   

Utilized to select and edit any previously defined and stored Line within the 
current project.  Note the Line Edit dialog is identical to the Line Add dialog, 
however, when the Line is identified, all associated data is displayed. 

ID 

    

Selecting the icon or from the pulldown, GEOPAK prompts the designer to 
select a previously drawn line.  When selected and accepted, GEOPAK opens 
the Line Edit dialog populated for the selected line. 

Delete 

    

Utilized to select and delete the specified Line and associated data. 

Update 

    

Updates all water or sewer line graphics. 

Miscellaneous utilities can be stored within a water and sewer project and checked via the utility 
conflict tool.  Each group of utilities is stored as a group, then the group is referenced for conflicts.  
Therefore, it is prudent to group by location for subsequent location of conflicts, rather than grouping 
by utility type.  For example, all utilities in an intersection, (i.e., gas, power, cable TV) can be placed 
within a single group, rather than all gas for an entire subdivision as a group. 

Three tools are supported for miscellaneous utilities: 

• Add Miscellaneous Utility 

• Edit Miscellaneous Utility 

• Delete Miscellaneous Utility 



Water and Sewer Line Tools 
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LINES > WATER OR SEWER ADD TOOL 

    

When the Add Water Line or Add Sewer tool is selected, the Line ID prefix is displayed, along with 
the next water or sewer pipe number.  Note the designer may change the Line ID if desired.  An 
optional Description field is supported.  When complete, click OK which opens the Water Line or 
Sewer Line dialog as depicted below.  Clicking Cancel closes the Add Water Line or Add Sewer Line 
dialog with no new line created. 

      

There are options for specifying the water line are within the dialog box.  This includes size of the line, 
whether the element is defined via a GEOPAK chain or MicroStation element, and associated pay 
item.  Additionally you can specify Minimum Clearance in master units (i.e., feet or meters).  This 
value can also be utilized in the utility conflict tool. For Water Lines only, you can specify a default 
depth to the invert of the line (in master units; i.e., feet or meters). 

LINES > WATER OR SEWER EDIT TOOL 

When the Edit tool is selected, GEOPAK prompts the designer to identify a previously defined water 
or sewer line.  When the water or sewer line is selected and accepted, the Water Line dialog opens, 
populated with the data associated with the selected water line. 

Modify the desired data, then click Apply to complete the editing procedure.  Note the Chain or 
Element cannot be edited, as they are ghosted.  If these change, simply delete the line and add a new 
line. 

LINES > WATER OR SEWER > ID TOOL 

Selecting the ID tool, GEOPAK prompts the designer to select a previously drawn water or sewer line.  
When selected and accepted, GEOPAK opens the Line Edit dialog populated for the selected line. 



Water and Sewer Node Tools 
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LINES > WATER OR SEWER > DELETE TOOL 

 

The previously stored Water Line may be selected from the Line ID list.  Alternately, the ID icon on 
the right side of the dialog may be clicked, then any Water Line selected graphically.  Once the 
candidate water line has been displayed, click Apply to delete.   

LINES > WATER OR SEWER > UPDATE TOOL 

 

The previously stored Line may be selected from the Line ID list.  Alternately, the ID icon on the right 
side of the dialog may be clicked, then the Water Line selected graphically.  Once the candidate water 
line has been displayed, click Apply to update. 

WATER AND SEWER NODE TOOLS 
Nodes in GEOPAK Water and Sewer are used to define key points within a sewer or water system.  
Nodes provide for the connectivity of the Lines.  Nodes are also used to indicate physical changes in 
Line sizes or slopes.  Lines cannot change size or slope, other than at Nodes.   

Several options are supported to define, edit and delete Nodes and are invoked via the Nodes pull 
down on the main menu bar. 

Alternately, the Node tools are invoked by selecting Tools Bars > Nodes, then selecting the desired 
tool from the toolbox as depicted below. 

 

Five tools are supported under each of the Node menus as described in the table below. 

Add 

    

Utilized to add a Node to the current GEOPAK Water and Sewer project. 

Edit / Modify 

     

Edit any previously defined and stored Node within the current project by 
selecting the Node from the Node ID list.  Note the Node Edit dialog is 
identical to the Water / Sewer Node dialog, however, when the Node is 
identified, all associated data is displayed. 

ID 

     

Utilized to graphically select and edit any previously defined and stored Node 
within the current project.  Note the Node Edit dialog is identical to the Water 
/ Sewer Node dialog, however, when the Node is identified, all associated data 
is displayed. 



Water and Sewer Profile Tools 
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Delete 

    

Utilized to select and delete the specified Node and associated data.  The 
dialog also supports options to Window Center and Highlight the candidate 
node. 

Rename 

    

Utilized to rename the specified Node. 

WATER AND SEWER PROFILE TOOLS 
Water and Sewer profiles can be drawn, edited or deleted via the Profiles toolbox or Profiles menu.  
Alternately, the Profiles tools are invoked by selecting Tools Bars > Profiles, then identifying the 
desired tool from the toolbox. 

 

Seven tools supported in the Profile Tools toolbox and are detailed in the table below. 

Select Water Line Profile 

 

Click  then select any plan view water line.  The Edit Water Line 
Profile dialog opens, automatically populated with all data associated 
with the selected profile.  Clicking the Center Profile  displays the 
profile if previously drawn. 

Select Water Profile Grid 

 

Click , then select any previously drawn water line grid.  The Edit 
Water Line Profile dialog opens, automatically populated with all data 
associated with the selected profile. 

Water Line Profile List 

 

Click , then select any previously drawn water line from the list.  The 
Edit Water Line Profile dialog opens, automatically populated with all 
data associated with the selected profile. 

Select Sewer Line Profile 

 

Click  then select any plan view sewer line.  The Edit Sewer Line 
Profile dialog opens, automatically populated with all data associated 
with the selected profile. 

Select Sewer Profile Grid 

 

Click , then select any previously drawn sewer line grid.  The Edit 
Sewer Line Profile dialog opens, automatically populated with all data 
associated with the selected profile. 

Sewer Line Profile List 

 

Click , then select any previously drawn sewer line from the list.  The 
Edit Sewer Line Profile dialog opens, automatically populated with all 
data associated with the selected profile. 

Update All Profiles 

 

Either Water Line Profiles or Sewer Line Profiles or both can be 
updated.  Activate the desired toggle(s), then click Apply . 

 



Water and Sewer Profile Tools 
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DRAWING WATER OR SEWER LINE PROFILES 

The first step to drawing Water or Sewer profiles is defining the line to be profiled.  This can be done 
by selecting the line from the appropriate list via the Water Line Profile List or Sewer Line Profile 
List. 

 

Highlight the desired line, then click OK, which opens the Edit Water Line Profile or Edit Sewer Line 
Profile dialog.  One sample dialog is depicted below. 

 

Another method of identifying the line to be profiled is graphically.  Clicking the Select Water Line 
Profile or Select Sewer Line Profile tool and graphically identifying a line opens the appropriate Edit 
Profile dialog automatically populated with the associated Line data. 

The profile can be drawn using a myriad of user-defined features to provide maximum flexibility to the 
designer.  These are discussed in detail within each dialog section of the Water and Sewer help. 

Once profiles have been drawn, GEOPAK supports tools for editing.  The profile can be selected from 
the Profile List or via the Select Water Line Grid or Select Sewer Line Grid tool.  Click, and then 
select the grid of a previously drawn profile.  The Edit Profile dialog opens. It is automatically 
populated with the data of the selected profile. 



Navigator 
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NAVIGATOR 
The Navigator tool is an easy method of maneuvering through the components of a GEOPAK Water 
and Sewer Project.  It provides a means to identify, add, edit, and delete the components of the current 
project.  The Navigator also provides graphical maneuvering tools to move through the design file and 
view the components with highlighting and window centering functions. 

The Navigator is accessed via Utilities > Navigator. Alternately, the Navigator tool can be invoked by 
selecting Tool Bars > Utilities, then identifying the Navigator tool from the Main toolbox.  It can also 
be accessed via the Utilities toolbox. 

 

Six tools are across the top of the dialog and are detailed in the table below.   They list all defined 
elements of the specified Component and their respective descriptions. 

Water Node 

 

When selected, the list box displays all water nodes in the current Water and 
Sewer project. 

Sewer Node 

 

When selected, the list box displays all sewer nodes in the current Water and 
Sewer project. 

Water Line 

 

When selected, the list box displays all water lines in the current Water and 
Sewer project. 

Sewer Line 

 

When selected, the list box displays all sewer lines in the current Water and 
Sewer project. 

Water Line 
Profile 

 

When selected, the list box displays all water line profiles in the current Water 
and Sewer project. 

Sewer Line 
Profile 

 

When selected, the list box displays all sewer line profiles in the current Water 
and Sewer project. 

When the desired component has been selected, and all current items are displayed, the user can 
highlight any item within the display box.   



Conflict Finder 

 

 
GEOPAK Site I Copyright © 2003 Bentley Systems, Incorporated Do Not Duplicate 

5/16/2003 7-12 

Two action toggles are located at the bottom of the dialog and are detailed in the table below. 

Highlight When activated, the MicroStation highlight color is applied to the selected item 
in the list box, for easy visual reference.  Note:  the user must be zoomed in 
close enough to see the selected item. 

Window Center When activated, it window centers around the selected item in the list box.  Note 
the relative window size is maintained, so the user must be zoomed in close 
enough to see the selected item. 

Four action buttons are supported on the right side of the dialog. A component in the list box must be 
highlighted to unghost the buttons, which are detailed in the table below. 

ID 

 

First, set the component to the desired type.  Click ID , and identify the 
graphic element or label on the screen.  GEOPAK reads the label, then 
highlights the item in the list box.   

New / Edit / Delete 

 

To add another element of the specified type, click Add  to invoke the Add 
dialog for the specified type.  To edit an element, highlight the desired 
element in the list box, then click Edit , invoking the specified type dialog in 
an update mode.  To delete an element, highlight any element in the list box, 
then click Delete . 

CONFLICT FINDER 
The Conflict Finder tool is an easy method of locating conflicts between components of a GEOPAK 
Water and Sewer Project, Drainage project, and miscellaneous utilities.  When a conflict is found, a 
textual label is displayed or drawn in the design file, based on user-defined parameters. 

The Conflict Finder is accessed via Utilities > Conflict Finder from the main menu bar. Alternately, the 
Conflict Finder tool can be invoked by selecting Tool Bars > Utilities, then identifying the Conflict 
Finder tool from the Main toolbox.  It can also be accessed via the Utilities toolbox. 

 



Conflict Finder 
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The dialog is divided into three group boxes: 

• Check Feature 

• Display Options 

• Conflicts 

Three types of conflict checking are supported under Check Feature: 

• Single Feature 

• Water Lines  

• Sewer Lines 

When Single Feature is utilized, the ID Element is available and used to graphically identify any 
current Water or Sewer line in the project.  Once identified, GEOPAK checks the element against any 
other elements identified in the Conflicts group box. 

A variety of display options are supported, which are found in the Display Options group box and 
detailed in the table below. 

Display Only The conflicts are labeled with display only, not written into the file.  
Therefore, they disappear when a View Control or Window command is 
issued.  When not activated, the label is drawn into the design file. 

Conflict Elevation When the toggle is activated, the elevation of the conflicting feature is 
displayed.  Note this corresponds to the feature defined in the Conflicts group 
box.  When the toggle is not activated, no elevation is displayed. 

Feature Elevation When the toggle is activated, the Elevation of the feature is displayed.  Note 
this corresponds to the feature(s) defined in the Check Feature group box.  
When the toggle is not activated, no elevation is displayed. 

Surface Elevation When the toggle is activated, the Elevation of the Design Surface at the X, Y 
location of the conflict is dis played.  The Design Surface is defined in the 
Water and Sewer Preferences > Terrain dialog, as depicted below. When the 
toggle is not activated, no elevation is displayed. 

Clearance When the toggle is activated, the elevation difference (in master units) 
between the Check Feature and the Conflict Feature is displayed.  When the 
toggle is not activated, no clearance is displayed. 

Depth When the toggle is activated, the elevation difference (in master units) 
between the Surface Elevation and the Check Feature is displayed.  When the 
toggle is not activated, no depth is displayed. 

View Center When activated, either the plan view or profile view may be centered in the 
specified view. 

Plan View Number When activated and a conflict is found, and the View Center toggle is 
activated, the numbered view is utilized to window center about the plan view 
area of conflict. 

Profile View 
Number 

When activated and a conflict is found, and the View Center toggle is 
activated, the numbered view is utilized to window center about the area of 
conflict in the profile drawing of the Check Feature. 
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WORKSHOP: DESIGNING A WATER AND SEWER SYSTEM 
The workflow within GEOPAK Water and Sewer is organized in much the same way conventional 
Water and Sewer design methods and the technical aspects of Water and Sewer design dictate.  A 
certain amount of information should be obtained in the beginning of a project to properly define all 
the factors contributing to the Water and Sewer system.  Upon obtaining this information, the specific 
goals of the design, criteria to be used in the design, and features to be used in the design must be 
established.  The design features are then applied to the project within the given criteria and then 
checked against the goals of the project to determine the adequacy of the design. 

: Opening the Water and Sewer Project 

1. Open the MicroStation file  ..\Data\Geo\Site\Site1\Chapter7\Siteplan_WatSew.dgn. 

2. Start the Water and Sewer application. (Applications > GEOPAK Water Sewer > Water 
Sewer). 

3. Select Project > New and create the project  
..\Data\Geo\Site\Site1\Chapter7\Siteplan_WatSew.gws. 

: Setting the Project Preferences 

1. Select the Project Preferences  tool (Water and Sewer menu: Project > Preferences). 

2. Select Files > Open and navigate to   
..\Data\Geo|Site\standards\water_sewer_proj_prefs.wsp . 

3. Review each of the Preference Options along the left hand side of the dialog. 

 

4. Highlight Project Components. 

5. Enter the following information. 

GEOPAK DDB ..\data\geo\site1\standards\site.ddb 

GPK Job Number:    200 

Cell Library  ..\Data\Geo\Site\site1\standards\nodes.cel 

GEOPAK Drainage Project ..\Data\Geo|Site\Site1\Siteplan_Drainage.gdf 

 

6. Highlight Cells , enable Scale Node Cell and set to 10. 
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7. Highlight Terrain. 

 

8. Enter the following information. 

GEOPAK Site Project Enable, ..\Data\Geo|Site\Site1\Siteplan.gsf 

Original Ground Site Object, Ground 1 

Design Surface Site Model, Tower 

9. Highlight Naming and review the defaults. (No user input required.) 

10.  Highlight Sewer Manholes. 

 

11.  Enter the following information. 

Type Funnel 

a 2 

b 2 

c 0.25 

d 4. 
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12.  Highlight Sewer Lines and review the defaults. (No user input required.) 

13.  Highlight Save Options and review the defaults. (No user input required.) 

14.  Click OK to close the dialog. 

: Adding Water Lines 

In this exercise, we will create one water line in our project.  This water line runs along the entrance 
road and in front of our building.  Water lines consist of MicroStation elements with supplemental 
data.  The supplemental data includes line sizes, pay items information, default clearances, and other 
variables as required for storing data into a water line.  Water line graphics can be selected from the 
MicroStation design file (Graphic Elements) or from the *.GPK database (Chains). 

1. Select the Add Water Line tool. (Water and Sewer Menu:  Lines > Water > Add) 

 

The Line ID defaults to WL-1.  The description is optional. 

2. Click OK. 

 

3. Enter the required Water Line information. 

Size: 0.667 

Minimum Clearance: 2 

Default Depth: 3 
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4. Click Select Pay Item  and navigate to PayItem > Water Utility > Pipe PVC  > 026-686-2950 
8” PVC Water Line.  

 

5. Highlight the item and click OK. 

6. Toggle on Element and click Select. 

7. Select and accept the water line.  (White line string running along entrance road and in front 
of building) 

The line string you selected has arrows pointing to the direction of stationing.  The arrows are 
pointing to station zero (0). 

 

 
Water Line with Flow Arrows 

8. Data point to define the elements stationing (downstream/upstream). 

9. Click Apply. 

Now that all the supplemental data for this water line has been defined, it is added to our 
project 

10.  Close the Water Line dialog. 
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: Adding Water Nodes 

Now that we have our water lines in the project we will proceed with adding water nodes.  These can 
include gate valves, fire hydrants, water meters, etc.  A MicroStation cell representing the node type is 
placed at the location of each node. 

1. Select the Add Water Node Tool  (Water and Sewer Menu: Nodes>Water>Add). 

 

The Node ID defaults to WL-1.  The description is optional. 

2. Click OK. 

We are going to place 8” Gate Valves in the water line near the southern and northern 
intersections of the entrance road. We will also locate a fire hydrant near our building.  

 

3. Enter the required Water Node information. 

Water Line: WL-1 

4. Click Select Pay Item and navigate to Payitem > Water Utility > Gate Valves > 026-686-
2010 8” Gate Valve.  

5. Highlight the item and click OK. 

6. Click End Station.  

7. Click Apply.  

The MicroStation cell that represents the Gate Valve is placed and GEOPAK creates a text 
label with the node number. 

: Adding Additional Water Nodes 

Don’t close the Water Node dialog just yet.  We have a couple of more nodes to add to our project.  
We will now add a water node at the other end of the water line WL-1.   
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1. Click Add Water Node. 

The Node ID automatically increments to WN-2. 

2. Click OK. 

3. Click Begin Station to set the station to 0+00. 

 

4. Click Apply. 

The water node WN-2 is added to the project.  The MicroStation cell representing the Gate 
Valve is placed and GEOPAK creates a text label with the Node ID.   

: Adding a Fire Hydrant 

We will add one more node to our water line WL-1.  Let’s put a fire hydrant at some location along the 
line.   

1. Click Add Water Node. 

The Node ID automatically increments to WN-3. 

2. Click OK. 
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3. Enter the required Water Node information. 

Water Line: WL-1 

Align Angle: 180 

 

4. Click Select Pay Item and navigate to Payitem > Water Utility > Fire Hydrants > 026-670-
1000 5 ¼” Fire Hydrant . 

5. Highlight the item and click OK. 

6. Click Dynamic Place. 

7. Data point at a location around Station 8+36.00. 

8. Click Apply. 

9. Close the Water Node dialog. 

: Adding a Water Profile 

Having successfully completed adding water line WL-1 with three water nodes WN-1, WN-2, and 
WN-3, we can now create a water line profile.   

1. Select the Water Profiles  tool. (Profiles > Water > Edit List) 

The first step to drawing water profiles is defining the water line to be profiled. 

2. Select WL-1 and click OK. 

3. Click Yes when prompted to create a new profile. 

The Alert dialog lets us know that the water line profile does not exist. 

 

4. Select File > Open and navigate to C:\Data\Geo\Site\Standards\Site1WaterProfile.ppf. 

We have a standard preference file that we will open and use for drawing our profiles.  This 
preference file has been set up to display various items such as pipe soffits/inverts, existing 
and proposed ground, pipe centerline, profile grids, and labels in our company standard 
symbology.   

5. Open MicroStation View Window 2. (MS: Window > View > 2) 

6. Click MS Fit View. 
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7. Click MS Window Area.     

Find an unused portion of the DGN file. We will place our profiles here. 

8. Click DP and data point in MicroStation View 2. 

This sets the Registration Point for our profile by establishing the lower left corner of the 
profile grid. 

9. Click Apply. 

 
        Sample profile drawn with the Water Profile tool 

10.  Fit the profile to View 2. 

11.  Click on the Display tab and review the settings. 

Note You can make a change to any setting.  To see that change reflected on the profile, click 
Apply. 

12.  Click the Grid & Labels Tab and review the settings. 

Again, any changes you make can be seen graphically on the profile by clicking Apply. 

13.  Click the Pipe Profile Tab and review all the Pipe Segments for water line WL-1. 

 

14.  Highlight each point in the list from station 0+04.83 through Station 5+11.74. 

15.  Click Delete Profile Points .  



Workshop: Designing a Water and Sewer System 

 

 
GEOPAK Site I Copyright © 2003 Bentley Systems, Incorporated Do Not Duplicate 

5/16/2003 7-22 

16.  Click Apply. 

The profile automatically updates to reflect your changes. 

 
The updated profile illustrates the changes when profile points were deleted. 

17.  Close the Edit Water Line Profile dialog. 

18.  Save the Water-Sewer project  (Project > Save). 

19.  Close MS  Window 2.  

: Adding Sewer Lines 

1. Select the Add Sewer Line tool (Lines > Sewer > Add). 

 

The default Line ID is SL-1.  The description is optional. 

2. Click OK. 

 

3. Enter the required Sewer Line information. 

Size: 0.833 

Minimum Clearance: 2.0 
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4. Click Select Pay Item and navigate to Pay Items > WasteWater Utility > Pipe PVC > 027-
162-1030 10” PVC Wastewater Line.  

5. Highlight the item and click OK. 

6. Toggle on Element and click Select. 

7. Select and accept the sewer line. 

 

 

The line string you selected has arrows pointing to the direction of stationing.  The arrows are 
pointing downstream to station zero (0). 

8. Data point to set the flow going away from the building. 

9. Click Apply. 

Now that all the supplemental data for this sewer line has been defined, it is added to our 
project. 

10.  Close the Sewer Line dialog. 

: Adding Sewer Nodes 

We will place several wastewater manholes along the newly placed sewer line.   

1. Select the Add Sewer Node tool (Nodes > Sewer > Add). 

 

 The Node ID is correct.  The description is optional.   

2. Enable Auto Locate Sewer Node. 
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3. Click OK. 

 

4. Enter the required Sewer Node information for the Location Tab. 

Sewer Line  SL-1 

Critical Points. Enable 

Align Angle + 180 

Only the MicroStation vertices on the line graphic are considered critical points.  GEOPAK 
applies the selected sewer node payitem to each vertex on the sewer line. 

5. Click Select Pay Item and navigate to Pay Item > Wastewater Utility > Manholes > 027-152-
0150 4' Dia. 8' Deep WW MH.  

6. Click OK. 

7. Click the Elevation Tab. 

 

8. Enter the required Sewer Node information for the Elevation Tab. 

Source Design Surface 

Min. Depth 4 

Max. Depth 25 

Align. Option Soffits 

GEOPAK calculates elevations based off of our Site Model (Tower), which we selected in the 
Water and Sewer project preferences.   
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9. Click Apply. 

GEOPAK places manholes at each of the sewer line vertices in the symbology on the item 
selected.   

10.  Close the Sewer Node dialog. 

: Adding a Sewer Profile 

Creating a Sewer Profile is very similar to creating a water line profile. 

1. Select the Sewer Profile tool (Water and Sewer Menu: Profiles>Sewer> Edit List). 

The first step to drawing sewer profiles is defining the sewer line to be profiled. 

2. Highlight SL-1 and click OK. 

3. Click Yes when prompted to create a new profile. 

4. Select File > Open and navigate to  C:\Data\Geo\Standards\Site1SewerProfile.ppf. 

 

We have a standard preference file that we will open and use for drawing our sewer profiles.  
This preference file has been set up to display various items such as pipe soffits/inverts, 
existing and proposed ground, pipe centerline, profile grids, and labels in our company 
standard symbology.   

5. Open MicroStation View Window 2. (MS: Window>View>2) 

6. Click MS Fit View.    

7. Click MS Window Area.    

Find an unused portion of the DGN file. We will place our profiles here. 

8. Click DP and data point in MicroStation View 2. 

This sets the Registration Point for our profile by establishing the lower left corner of the 
profile grid. 
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9. Click Apply. 

 
Sample profile drawn with the Sewer Profile tool 

: Modify Sewer Line and Sewer Profile 

1. Select the Microstation Modify Element tool. (MS: Tools > Main > Modify). 

We are going to move the line vertex closest to sewer node SN-4 further down the slope on 
the back side of the building toward the property boundary 

2. Move the vertex of the sewer line SL-1. 

   
Before and after plan view of modifying vertex. 

The profile automatically updates with the new position and re-labels the pipe. 

3. Select the Sewer Profile tool. (Water and Sewer Menu: Profiles>Sewer> ID Grid) 

4. Select and accept a grid line from the sewer profile graphic in Window 2. 

Note The Edit Sewer Line Profile tool opens and is populated with the sewer profile SL-1 data. 

5. Click the Pipe Profile tab. 

6. Enlarge Window 2. 

7. Click Center Profile.  

This centers the profile in Window 2. 
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8. Highlight Seg.  # 2 . 

 

9. Click Edit Invert  in the right Node group box (right of 5226.098). 

This is for the upstream node SN-3. 

10.  In the profile, move over the invert for SN-3 until the pipe is attached to your cursor. 

11.  Data point on the profile to establish the new invert location/depth. 

12.  Click Apply. 

 

Note The profile dynamically updates, extending the MH to the depth required to accept the 
modified segment invert level. 

13.  Close the Edit Sewer Line Profile dialog. 



 



8 Plans Preparation 
CHAPTER OBJECTIVES 

In this chapter, you will learn more about: 

• annotating alignments and profiles. 
• labeling. 

INTRODUCTION 
In this workshop we will explore many of the tools available for generating site plans.  We will use 
tools to draw the existing and proposed contours into MicroStation, label pertinent information with 
GEOPAK Plan Labeler, and annotate our roadway alignment and profiles with Design and 
Computation Manager.  If time permits we will also perform quantity takeoffs for various features on 
our project.  Let’s begin. 

� Open Existing Site Project 

1. Open the design file  ..:\Data\Geo\Site\Site1\Chapter8\Siteplan2D.dgn. 

2. Select the Site Modeling tool (Applications > GEOPAK Site > Site Modeler> Site Modeling). 

 

3. Enable the Open Existing Project radio button. 

4. Click Browse and select ..\Data\Geo\Site\Site1\Chapter8\Siteplan.gsf. 

� Exporting The Contours To Graphics 

In this exercise, we will set up the display to show our model contours only in the areas of proposed 
construction - ready for export into the MicroStation DGN file. 

1. Select the Edit Model tool (Site Modeler menu: Model>Edit). 

2. Click the Display Model tab. 

3. Set the Major contour interval to 5.0 and the Minor interval to 1.0. 

4. Click Apply. 
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5. Click the Display Objects tab. 

 

Clip Objects from Model: Enable, View With Objects Only 

6. Click Apply. 

GEOPAK clips the proposed contours in the composite area of the objects.   

 

Hint This shows the contours to the internal boundary of the Objects. If the desired result is to 
display the contours to the slope toes of the Object, the user would need to toggle ON Display 
with Object from the Object > Edit > Slopes dialog. 

7. Select the Export Visualization to DGN tool (Site Modeler> Project> Export> 
Visualization to DGN). 
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8. Enter the Export information. 

Model Enable, set to Tower 

Set Graphic Group Enable 

9. Click Apply. 

10. Click OK when prompted if you want to proceed. 

The graphics are permanently drawn into the MicroStation file. 

Hint Turn on the display of the attached contours.dgn reference file to see existing contours as 
well. 

� Annotate A Roadway Alignment 

In this exercise, we will annotate our Main Road centerline.  We will place station labels and tick 
marks along the alignment and then draw and annotate its corresponding profile.   

1. Select the Design and Computation Manager tool  (Applications> GEOPAK Site> Design 
and Computation Manager).  

2. Open site.ddb located in the ..\Data\Geo\Site\Standards folder (File > Open).  

3. Highlight Drafting Standards > BL & CL category > BL20   C.L. & B.L.– 20 Scale.  

 

This item has all the necessary information set up to label our roadway alignment. 

4. Click Draw Plan & Profile. 

 

5. Select Job 200 and click OK. 
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6. Set the Operation to Chains. 

 

The Chain Operation draws and labels the centerline of our roadways. 

7. Set the Label Scale to 20. 

8. Enable the label information. 

Line Direction Label: Enable 

Line Length Labels: Enable 

Curve Label: Enable 

9. Click on MAINRD. 

Clicking on each chain name draws and labels the roadway centerlines.  Each time you click 
on the Chain Name GEOPAK draws the selected information into MicroStation.  However, 
GEOPAK does not erase any old graphical elements and replace them with new elements.  It 
simply draws on top of the existing graphic elements there by creating multiple lines, multiple 
text labels, etc. 
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10. Double click Drafting Standards > Stationing category > 20STA Ticks, N. Arrow at 20 Scale.   

 

This item places tick marks along the centerline alignment, station labels and PC & PT labels. 

11. Change the Operation option to Stationing. 

 

12. Enable the labels. 

Tick Marks Enable 

Tick Marks Stations: Enable 

PC & PT & CS.. labels: Enable 

Small Ticks Ticks LT, Labels LT 

Large Ticks: Ticks Both, Labels RT 

Label Scale 20 

13. Click on MAINRD. 

14. Close Design & Computation Manager 
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� Annotate A Roadway Profile 

Now we can annotate the profile for the Main Road.  The profile will be drawn in MicroStation View 
2.  We will use the Draw Profile tool to draw and annotate the profile.   

1. Open MicroStation View Window 2. (MS: Window>View>2) 

2. Click MS Fit View. 

3. Click MS Window Area. 

Find an unused portion of the DGN file. We will place our profiles here. 

4. Display all MS levels. (MS > Settings > Level > Display).  

5. Select the Draw Profile tool (Site Modeler: Object> Draw Profile). 

 

6. Enter the Job Number and Chain information. 

Job Number 200 

Chain MAINRD 

We need to create a profile cell first before we actually draw the profile information.  We can 
do this  within the Draw Profile dialog by using the Profile Cell Control tool. 

7. Click Profile Cell Control.  

8. Click Place Profile Cell in the Profile Cell Control dialog,  

 

9. Enter the Profile Cell information. 

Station: 0+00.00 

Elevation: 5240 

Horizontal Scale: 10 

Vertical Scale: 1 

Top Delta: 80 

Bottom Delta: 20 

10. Data point in MicroStation View 2 to place the profile cell. 

11. Close the Profile Cell Control dialog. 
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12. Enter the Details group information. 

 

Model Base: Tower 

Method: Triangles 

Display Settings: By Feature, ExistP 

13. Click Browse Feature and navigate to Drafting Standards > Profiles > ExistP. 

14. Highlight the item and click OK. 

15. Click Add Surface Setting.  

The surface is added in the list box and drawn on the profile cell. 

16. Click the COGO tab. 

13. In the Details group box, set the Profile Name to MAINDES and Vertical Offset to 0. 

14. Set the Display Settings to By Feature.   

15. Click Browse Feature and navigate to  Drafting Standards > Profiles > DesignP. 

16. Highlight the item and click OK. 

17. Set the Label Scale to 100 (top right hand corner of Draw Profile dialog). 

18. Click Add COGO Profile Settings along the right side of the list box.  

This adds the profile to the list and draws it into the Profile Cell.   

19. Close the Draw Profile dialog .  
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� Plan View Labeling 

In this section we will use the GEOPAK Plan View Labeler to create a typical Bearing/Distance Label.  
We will then place the label at various locations along our property line.  We will also add this label to 
a library of other plan view type labels that can then be used on future projects by others.  This process 
of creating and saving the label can be used to create any type of label you may need and aid you in the 
development of your company standard labels.   

1. Select the Plan View Labeler tool (Applications > GEOPAK Site > Plan Preparation > Plan 
View Labeling).  

   
2. Set the project specific information. 

Job No. 200 

Chain MAINRD 

TIN File Ground.tin 

Model Tower 

3. Click Select GEOPAK or MS Element,  then select and accept one of the property boundary 
elements. 

Once you have accepted the element to label, GEOPAK puts a circle at the midpoint of the 
line segment.  Now we can construct the text portion of our label.  There is a list of computed 
text in the center of the dialog.  To see any particular computed value, simply highlight it in 
the list. 

4. Highlight Bearing -> DMS in the Computed Text list box. 

The value of the computed text is displayed below the list box. 

5. Double click Bearing -> DMS in the Computed Text list box. 

Double clicking on any computed text places the item in our label.  This sends the value to the 
text editor portion of the GEOPAK Plan View Labeler dialog. 

6. Click Return. 

This moves the cursor to the next line below the bearing.   

7. Select Length from the Computed Text list. 

8. Set the number of decimal places to 2.  
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9. Double click on Length to add that information to our label. 

Warning Adjust the number of decimal places prior to adding the value to the text editor. 

10. Click on the Params. Tab and set your parameters as illustrated. 

This is where we set up the text preferences and symbology. 

 

11. Click on the Shape Tab and review the options (no user input required). 

We will not put a shape around our label but there are several supported shapes if needed.  
Just review the options for shape geometry and symbology. 

12. Click on the Leader tab and review the options.   

Again we will not have a leader on our label but this is where we could select the leader type 
and symbology.  Several leader types are supported with various types of terminators 
including and Active Terminator from a cell library in MicroStation. 

13. Click on the Rotate tab.   

 

14. Click Element Angle to set the rotation of the text. 

15. Click Place Label. 

 

GEOPAK Site I Copyright © 2003 Bentley Systems, Incorporated Do Not Duplicate 

5/16/2003 8-9 



Introduction 

 
16. Snap to the midpoint of the line to place the label. 

 

� Continuous Text Placement 

Warning Please read the following steps in their entirety before completing.   

1. Click on the Text tab. 

2. Click Select GEOPAK or MS Element. 

3. Select and accept another line to label. 

Notice how the bearing and length values are automatically updated. 

4. Click Continuous Place. 

5. Snap to the midpoint of the line to place the label. 

6. Select and accept another line to label. 

The label should have been automatically placed.  Continue to label the rest of the property 
lines in this continuous mode. 

� Saving a Label Style 

In this exercise, we will save the label to a style file which contains all our standard label styles. 

1. Click on the Styles tab.   

 

2. Double click on Line Labels. 
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3. Click New Style. 

 

4. Enter the Style Name as MyStyle. 

5. Click OK.  

The style is added to the library. 

� Updating Labels 

We will  modify two of the property lines using MicroStation Modify Element tool, then update the 
labels. 

1. Select the Modify Element tool (MS:  Modify toolbox > Modify Element). 

2. Relocate the endpoints of the property lines to a new location in the MicroStation view. 

 

Now that the property lines have been changed, we will have GEOPAK update the labels.   
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3. Select the Update Labels tool (Plan View Labeler Menu: Tools > Label Updater). 

 

4. Set Select By to All Labels.  

5. In the Highlight Labels group box, set to Content Needs Updating. 

6. Click Highlight. 

The two labels that need to be changed will highlight. 

7. Click Start. 

GEOPAK searches through all the labels in the design file and presents you with ones that 
need to be updated.  You will see the new label content in the dialog. 

8. Click Update Label. 

The label on the line is replaced. 

9. Continue until each label has been updated. 

 

10. Close the Update Labels dialog. 

11. Close the Plan View Labeler dialog. 

12. Click Yes to the alert dialog. 
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� Export Entrance Road Object to Coordinate Geometry 

In this section we will export the back of our entrance road curb to coordinate geometry so that later 
we can upload those points to a data collector for stake out. 

1. Select the Export to COGO tool (Site Modeler Menu: Project>Export>To COGO). 

 

2. Enter the required information. 

Object: Enable, Entrance Rd 

Feature: Enable, CTB (PayItems>Curbing>CTB) 

Export: Elements Only 

Linear Stroking: 25 

Curve Points: 3 

Job Number: 200 

Operator Code: jd 

Point Prefix: Enable, BC 

Beginning Point #: 1 

Feature: CG 

Description: BC Ent Rd 

3. Click Apply. 
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4. Select the Coordinate Geometry tool (Applications > GEOPAK Site > Geometry > 

Coordinate Geometry).  

 

Job Number: 200 

Operator Code: jd 

5. Click OK. 

6. Set Visualization to Temporary. (GEOPAK Coordinate Geometry Menu: User > 
Preferences > Visualization) 

7. Select the Navigator Tool. (GEOPAK Coordinate Geometry Menu: Tools >  Navigator) 

 

8. Highlight points BC1 through BC85. 

9. Click Visualize Elements (eyeglasses) .  

The points are displayed in MicroStation until you close coordinate geometry. 
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� Export Points to ASCII Coordinate File 

1. Select the Export GPK Points to ASCII Coordinate File tool. (Coordinate Geometry 
Menu: File > Export > ASCII Points) 

 

2. Set the Output Format group box to the following. 

 

3. Set Compute Station value from Chain. 

4. Set Chain to measure Station and Offset from to Entry. 

5. Highlight points BC1 through BC85. 

6. Click Apply. 

7. Click OK to the dialog informing you of the text file creation. 
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8. Open the file with the GEOPAK Text Editor and review. (Applications > GEOPAK Site > 

Text Editor) 

 

Note There is a new for V8 GEOPAK tool that works similar to this, but creates a table for you to 
place into your MS DGN file. This tool is accessible from Applications > GEOPAK Survey > 
Plans Production > Coordinate Table. Used in combination with COGO > Navigator 
(permanent visualization), COGO points can be mapped to and their associated stake out 
table created and written to the DGN file very quickly. 

9. Close the Text Editor. 

10. Close COGO. 

� Quantity Takeoffs (Optional) 

In this section, we will  use GEOPAK Design and Computation Manager to calculate quantities for our 
project.  In our case we will calculate the quantities for all of the elements we have created in the Site 
Modeler, Drainage and Water/Sewer classes. The same process is used to calculate any type of plan 
view quantity.   

1. Fit the entire site plan into MicroStation View 1.   

2. Turn the display ON for the referenced Drainage and Water/Sewer DGN files.                  
(MS: File>Reference). 

3. Select the Design and Computation Manager tool (Applications > GEOPAK Site > Design 
& Computation Manager).  

4. File > Open C:\Data\Geo\Site\Standards\site.ddb. 

5. Click Compute  at the top of the dialog. 

6. Highlight the PayItem Category. 
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7. Right click and select Add to Collection. 

 

8. On the [Collection] dialog,  set the Output to Item Report and Preview. 

 

9. Click Compute. 

GEOPAK searches the view for any element matching an item in the PayItem category. 

A dialog opens prompting you to define a computational unit for Pay Item Base.  This means 
that GEOPAK has found a shape in the view which represents the pavement area for the 
roadways.  In the Design & Computation manager Pay Item category, there is a pavement 
design item having symbology that matches the symbology of our pavement area shape.  This 
pavement design consists of a layer of Base and a layer of Asphalt. 

 

10. Enter a value of 10. 

The value is in inches and is converted to tonnage by the program. 

11. Click OK. 

12. Click OK to continue. 

Next we are prompted for the asphalt layer thickness. 

13. Enter a value of 6. 

The value is in inches and will be converted to tonnage by the program. 
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14. Click OK. 

15. The Alert dialog appears, click OK to continue 

16. GEOPAK displays the item report in the Output dialog. 

 

Hint This process can be used to calculate a quantity for any Design & Computation Manager item 
that has an associated computational unit assigned to it.  These items have a calculator icon 
by them in the Design and Computation Manager dialog. 
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