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Exploring Template Points and
Constraints

Templates
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This module is an introduction to the Create Template tool. You will learn the basics of
creating and editing templates and the components and points that make up the
templates.
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Objectives

In this lesson we will...
e Learn about template point constraints and components
»  Create template components
*  Create a complete template from the components
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Constraints on Template Points
P

Constraints on Template Points

e (Constraints

- Used to manage the behavior of template
points
e How points move with respect to one another

— A single point can have up to 2 constraints

-~ Fully constrained points are red (two
constraints)

— Partially constrained points are yellow
(one constraint)

- Unconstrained points are green (no
constraints)

Point constraints are used to manage the behavior of template points. They are used so
that if a point is moved in a template, either by you editing the template or by the
application of point controls during design processing, all the points related to the point
being moved will behave in a predictable manner.

e Atemplate point has a maximum of two constraints on it. A point with two
constraints is considered “fully constrained.” A point that is fully constrained
is represented by a red plus sign.

* A point that has only one constraint on it is considered “partially constrained”
and is shown as a yellow plus sign.

* A point with no constraints (unconstrained) is shown as a green plus sign.

Constraints can also be labeled so that during the design process the value of labeled
constraints may be changed. For example, the template may have a constraint label
called Thickness that controls the thickness of the asphalt wearing surface. This
thickness can be changed so that one template can be used for different asphalt depths,
without having to edit the template.
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Types of Constraints

Roadway Designer provides a variety of constraint types for roadway template design as
described below. This course discusses the Horizontal, Vertical, and Slope constraints.

Horizontal

The child point remains at the specified horizontal distance from the parent point.
Vertical

The child point remains at the specified vertical distance from the parent point.
Slope

The child point maintains the specified slope from the parent point. Slope constraints
can, additionally, have rollover values assigned to them. Rollover values are used to set
the slope constraint based on a high side slope difference and a low side slope
difference relative to a reference point which defines the controlling slope to the parent
point. Slope constraints are absolute. Slopes going from lower-left to upper-right are
positive regardless of whether the child point is to the left or right of the parent.
Horizontal Maximum

The child point has two parent points and remains at the specified horizontal distance
from the parent point that is farthest to the right (has the maximum horizontal or X value).

Horizontal Minimum

The child point has two parent points and remains at the specified horizontal distance
from the parent point that is farthest to the left (has the minimum horizontal or X value).

Vertical Maximum

The child point has two parent points and remains at the specified vertical distance from
the parent point that is highest (has the maximum vertical or Y value).

Vertical Minimum

The child point has two parent points and remains at the specified vertical distance from
the parent point that is lowest (has the minimum vertical or Y value).
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Vector Offset

The child point is projected onto the vector defined by two parent points. If the offset is
not zero, then the child point will maintain a perpendicular offset from the parent vector
at the specified offset value. Negative values indicate an offset to the left of the vector
defined by the parent points. Positive values indicate an offset to the right. If the offset is
zero, the child point is located on the parent vector.

Project to Surface

This constraint must be used in conjunction with one of the previously defined
constraints. The other constraint will define the projection direction. The child point will
then be projected to the surface with the specified name. If the surface does not exist, or
no solution is found, the point will remain where it is placed in the template.

Project to Design

This constraint is similar to Project to Surface, except that the point is projected to the
design surface of the template. A projection value is given to indicate whether the
projection is to be to the left or to the right. Again, the point must also be constrained by
one of the previous constraints, excluding the Project to Surface constraint, so that a
direction for the projection may be determined. If no solution is found, then the point will
remain where it is placed in the template.

Angle Distance

Use this command to fully constrain a point in the template. This constraint requires two
parent points, a distance, and an angle. The point is constrained to the location defined
by the distance from the first parent, and the angle from the first parent relative to the
vector defined by the two parent points. This constraint creates a rigid-body rotation.
When selected, no other constraint types are available.
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Visual Indicators for Parent-Child Relationship
P

Constraints on Template Points

e Parent-Child point
relationship

—  Point B is the Child of A
Parent point A B

- Arrow points from
Parent point to Child
point

e Horizontal Constraint "

- Child is horizontally =
constrained to parent

Parent-Child Point Relationship

When a point is constrained, it is constrained from either one or two other points. Points
are constrained in a two dimensional (cross section) plane. Constraints can affect only
the point’s offset and elevation, which is the X and Y coordinates in a cross section
view. Point constraints are also directional. The direction forms a parent-child
relationship between points. If point B is constrained by point A, point A is said to be the
parent of point B. When viewing the constraints, the parent point has a blue arrow
pointing to the child point. To see the constraints in a template, set the Constraints radio
button located in the Display portion of the Create Template dialog.

Horizontal Constraint

A horizontal constraint is when a child is horizontally constrained to the parent. When
you move the parent point, the child point moves at a constant horizontal distance from
that point, which is specified when the constraint is established. A white horizontal line
crossing over the blue arrow indicates a horizontal constraint.
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Visual Indicators for Vertical, Horizontal, and Slope
Constraint

Constraints on Template Points

e Vertical Constraint

- Child is vertically A
constrained to Parent

e Horizontal and Vertical
Constraint

- Child is horizontally and
vertically constrained to B
Parent

e Slope Constraint

- Child and Parent are
constrained by slope A

Vertical Constraint

A vertical constraint is when a child is vertically constrained to the parent. When you
move the parent point, the child point moves at a constant vertical distance to that point,
which is specified when the constraint is established. A white vertical line crossing over
the blue arrow indicates a vertical constraint.

Horizontal and Vertical Constraint

A horizontal and vertical constraint is when a child is horizontally and vertically
constrained to the parent. When you move the parent point, the child point moves at a
constant horizontal and vertical distance to that point, which is specified when the
constraint is established. A white horizontal and vertical line crossing over the blue arrow
indicates a horizontal and vertical constraint. When a point has two constraints, such as
horizontal and vertical constraints, that point is fully constrained and is shown in red.
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Slope Constraint

A slope constraint is when a child is constrained to the parent by the slope between the
two points. When you move the parent point, the child point moves at a constant slope
with respect to the parent point, which is specified when the constraint is established. A
white diagonal line crossing over the blue arrow indicates a slope constraint. When a
point has only one constraint, such as a slope constraint, it is called a partially
constrained point and is shown in yellow.
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LESSON NAME: OPENING A PROJECT (INROADS USER)

LESSON OBJECTIVE:
In this lesson the student will learn to access an InRoads project in preparation for designing

a model in Roadway Designer. Note, this lesson is for InRoads users only. For GEOPAK
users, please proceed to the next lesson on the next page.

» EXERCISE: GETTING STARTED (INROADS USER)

This exercise will guide you through the steps to get started

1. Goto Start > Programs > Bentley > InRoads Group Athens > InRoads
Suite.

2. The instructor will provide the appropriate path location for this project.
When the MicroStation Manager appears select the file:

Plan.dgn and press OK.

3. When the InRoads Explorer appears, go to File > Open from the InRoads
menu.

4. When the Open dialog appears select the InRoads project file:
My_Project.rwk and press OK.
Opening the RWK project file opens the following files:
CMJOBO001.alg
Templates.itl

Original.dtm
Default_Styles.xin

5. Select Modeler > Create Template from the InRoads Explorer menu to
access the Create Template Application.

s Bentley InRoads Suite VEL

Fle Suface Geometry Bridoe Dreinage Survey Evaluation | Modeler Drafing Tools Help

Geometry Proj..  De fanj Create Template... By Whom Last Rewvised

=R-Y Geometry Projects CITNC106 D Chucklawson  9/26/2008 11:2...
= Default (22 Default L BTl Chuck.lawson  9/26/2008 11:2...

% Surfaces| = Geometry [- i al

Defines and manages templates for use with Roadway Designer
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LESSON NAME: OPENING A PROJECT (GEOPAK USER)

LESSON OBJECTIVE:
In this lesson the student will learn to access a GEOPAK Corridor Modeler project in prep-

aration for designing a model in Roadway Designer. Note, this lesson is for GEOPAK
users only.

» EXERCISE: GETTING STARTED (GEOPAK USER)

This exercise will guide you through the steps to get started

1. Goto Start > Programs > Bentley > MicroStation V8i > Bentley MicroStation
Vai.

2. The instructor will provide the appropriate path location for this project. When the
MicroStation Manager appears select the file:
Plan.dgn and press OK.

3. Goto Applications > Road > 3D Tools > Corridor Modeling.

IMPORTANT: A prompt will appear asking to re-import the DDB file. Make sure
to select Cancel.

Select the GPK job number 001
Choose File > Load from the Corridor Modeling dialogue.
Load the Corridor Modeler project file entitled My_Project.rdp.

Choose the Open Create Template icon from the Corridor Modeling dialogue to
access the Create Template Application.

No s

A Carridor Madeling - C:\2008 REUC\Explaring Template Points and Constraints\My Project.rdp.
File

i +4 A
sb:[001 | Q @“ =
=1 Preferences
= DDE Open Create Template

B D0TM
B Geometry Station Lock: |Ewen -

8 Plan Graphics Slope Readout:

Horizontal Chord Height: | 0.010000
Vertical Chord Height: | 0.010000
Template Library: | Templates il
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LESSON NAME: OBSERVING TEMPLATE CONSTRAINTS BEHAVIOR

LESSON OBJECTIVE:
In this lesson the student will learn to select a template, move points and observe the be-

havior, change point constraints, and delete components.
» EXERCISE: THIS EXERCISE WILL GUIDE YOU THROUGH MAKING A TEMPLATE ACTIVE AND
DISPLAYING A COMPONENT’S CONSTRAINTS.

1. Double-click the Template named Constraints Behavior from the Constraints
folder.

This makes the template Constraints Behavior the current template.

2. Setthe Constraints and Display Point Names in the Display portion of the Create
Template dialog.

* Point 1 is the parent of Point 2.

* Point 2 is the child of Point 1.

* Point 2 is horizontally and vertically constrained to Point 1.
* Point 2 is the parent of Paint 3.

e Point 3 is the child of Point 2.

e Point 3 is horizontally and vertically constrained to Point 2.

» EXERCISE: THIS EXERCISE WILL GUIDE YOU THROUGH MOVING TEMPLATE POINTS AND
MODIFYING POINT CONSTRAINTS.

1. Right-click on Point 1 and select Move Point.
Observe how the Points 1, 2 and 3 move as a rigid body.
Right-click to exit Move Point.
Right-click on Point 2 and notice that Move Point is no longer available.
It is not possible to move a fully constrained point.
Let’s see what happens when we remove the vertical constraint from Point 2.
4. Double-click Point 2.
The Point Properties dialog opens.
5. Change Constraint 2 from Vertical to None and click Apply, then Close.
Notice the color of the point turned from red to yellow.
6. Move Paoint 1.
Notice the horizontal distance between Points 1 and 2 remains the same.
7. Move Point 2.
Notice the horizontal distance between Points 1 and 2 remain the same.
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Also notice that the horizontal and vertical distance remains the same between
Points 2 and 3.

8. Double-click Point 2 again.
9. Change Constraint 1 from Horizontal to Slope and click Apply, then Close.
10. Move Points 1 and 2.

Notice the behavior is similar to before. However, Point 2 is now constrained at a
constant slope from point 1 instead of at a constant horizontal distance.

» EXERCISE: THIS EXERCISE WILL GUIDE YOU THROUGH DELETING COMPONENTS FROM A
TEMPLATE.

11. Delete the component by right-clicking with your cursor directly over the
component and selecting Delete Component.

Notice there is also a Delete Components command that is used to delete
multiple components.
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Adding and Deleting Constraints Graphically
P

Constraints on Template Points

e Adding and Deleting Constraints
Graphically

— Right-click on points to add and delete
constraints

— Horizontal and vertical constraints are
important
e Pavement layers
e Superelevation
¢ Transitioning
- Helps to relocate points

In addition to editing the template point constraints using the Point Properties dialog, you
can right-click on any point to access Add Constraint or Delete Constraints. This is
very handy for making quick adjustments to the template constraints.

Delete Constraints removes all constraints from the point.

Add Constraint lets you pick the type of constraint you want to add to the point.

Full Constraint adds both horizontal and vertical constraints to a point.

Right-click on the child point you want to constrain, select Add Constraint, and select
the point constraint you want to add. Then click the parent point and key in the offsets or
slope values of the child point from the parent. Setting the appropriate constraints on
points is important to achieve the desired results when pavement layers, superelevation,

and transitioning are introduced to the design. Using the Point Properties dialog is
helpful for adjusting point constraints after the initial point placement.
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LESSON NAME: OBSERVING TEMPLATE CONSTRAINTS BEHAVIOR

LESSON OBJECTIVE:
In this lesson the student will learn to add and delete constraints and components.

» EXERCISE: THIS EXERCISE WILL GUIDE YOU THROUGH MAKING A TEMPLATE ACTIVE AND
DISPLAYING A COMPONENT’S CONSTRAINTS.

1.
2.

10.

11.
12.

13.

14.
15.

16.
17.

T, .
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Continue working on the template library used in the last practice activity

Select the Add and Delete Constraints template and make it the current
template.

Set the Components and Display Point Names options in the Display area of the
Create Template dialog.

Right-click on the CL_AGGR_B_BOT point and select Delete Both
Constraints.

Notice the color of the point turns from red to green.

Delete the constraints on the EOP_AGGR_B_BOT and SHDR_AGGR_B_BOT
points.

Right-click on the CL_AGGR_B_BOT point and select Add Constraint > Full
Constraint.

Click on the CL_AGGR_A_BOT point.
The Add Full Constraint dialog opens.
Key-in a Horizontal Offset of 0.0 and a Vertical Offset of -1.0 and click OK.

Right-click on the EOP_AGGR_B_BOT point and select Add Constraint > Full
Constraint.

Click on the EOP_AGGR_A_BOT point.
The Add Full Constraint dialog opens.
Key-in a Horizontal Offset of 0.0 and a Vertical Offset of -1.0 and click OK.

Right-click on the SHDR_AGGR_B_BOT point and select Add Constraint >
Slope.

Click on the EOP_AGGR_B_BOT point. The Add Slope Constraint dialog
opens.

Key-in a Slope of -6.0% and click OK.

Right-click on the SHDR_AGGR_B_BOT point again and select Add Constraint
> Slope.

Click on the SHDR_AGGR_A BOT point.
Key-in a Slope of -25.0% and click OK.
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18. Right-click on the Current Template Window and select Delete Components.
19. Hold down the left mouse button and draw a line across a few components.
Release the left mouse button when done.

To undo the deletion, press the CTRL+Z buttons on the keyboard.

The Sign of the Distance and Slope B
I
Add New Component Commands

e Component Slopes and Distances

- Parent point is placed first

e Child placed to the right (x) of Parent is positive
distance

e Child placed to the left (x) of Parent is negative distance
e Child placed above (y) the Parent is positive distance
e Child placed below (y) the Parent is negative distance

- Slope is algebraic slope

Vertical Vertical
Positive (+) (-) Negative
Slope Distance Distance Slope
/ Horizontal (+) Distance

Horizontal (-) Distance

When defining components with precision input, the sign of the distance is dependent on
the parent-child relationship. The parent is always the first point placed when creating
template components. The distance is positive if the parent has a lower X or Y value
than the child. The distance is negative if the parent has a higher X or Y value than the
child. The sign of the component slope is based on the mathematical slope.
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Simple Component

Add New Component Commands

e Simple Component
Creates constrained parallelogram for
pavement layers and sidewalks

Provide the following data:
e Component Name and Style
e Slope, Thickness and Width

|

I

OP_ASPHALT_BOT

A component is a set of points that define an open or closed shape. Each component,
whether open or closed, can represent a different material or area of interest.

Components are saved in the template library and are normally stored in a separate
folder in the Template Library folder structure.

To create a component, first select File > New Template and name the template
component. Then, use Add > Simple or Add > Constrained to build the component.
Each component has a name and an assigned feature style.

There are five types of components:
e Simple
* Constrained
* Unconstrained
* Null Point

12/1/08
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« End Condition

As you add template components, the area under the graph changes to represent the
parameters for the component input type. This is called the Current Component area.

A simple component typically represents a section of pavement or sidewalk. It is a
closed parallelogram that is defined by slope, thickness, and width. The top points are
constrained by haorizontal and slope constraints. The lower points are constrained to the
points directly above them by horizontal and vertical constraints.

The Constrained, Unconstrained, and End Condition component types are discussed
later in this chapter. Null Points are more advanced than this course and are therefore
not discussed during this training.

Note for GEOPAK Users:

The type of template components used affect how GEOPAK end area volumes are
computed and how cross section reports are generated.

If your workflow only requires dirt quantities, and not individual pavement layer end
area volumes, you can use any type of component as described in this training
guide.

However, if your workflow requires end area volumes for each pavement layer or if
the workflow requires detailed cross section reports, your templates must be defined
using non-closed components. The issue with closed components is that the top,
bottom, and sides of the component all share the same feature and graphic
symbology. Since these are all the same GEOPAK cannot determine what each line
represents. Furthermore, closed shapes also result in multiple lines at the same
location in the cross section. For example, the line representing the bottom of the
pavement is coincident with the line representing the top of the base.

The recommended workflow to combat this issue is to create templates from
non-closed components. The top of the surfacing layer is created as one non-closed
component. The sides and bottom of subsequent pavement layers for base, sub
base, etc. are created using additional non-closed components. Each component
should be associated with a different feature so the resulting graphic symbology is
unique. Having unique graphic symbology for each pavement layer allows the
GEOPAK end area volume and cross section report tools to process correctly.

Simple components are closed shapes by definition and therefore should not be
used when pavement layer end area volumes are required. Both Constrained and
Unconstrained components can be closed or non-closed. To create non-closed
components, right click and disable the Closed Shape option. Null Points and End
Condition components are non-closed by definition.
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LESSON NAME: CREATING A TEMPLATE OF SIMPLE COMPONENTS

LESSON OBJECTIVE:
In this lesson the student will learn to create templates by adding simple components and

saving the template library.

» EXERCISE: CREATING A TEMPLATE

1.
2.

Browse to the folder named Components in the Create Templates dialog.
Create a template named 12’ Concrete Pavement w/8’ Shoulder.

» EXERCISE: STARTING DYNAMIC SETTINGS

3.
4.
5.

Select Tools > Dynamic Settings.
If set, clear the Apply Affixes option in the Dynamic Settings dialog.
Set the Horizontal and Vertical Step to 0.1.

» EXERCISE: ADDING A SIMPLE COMPONENT

6.

10.

Right-click on the Current Template window and select Add New Component >
Simple.

Setup the Current Component portion of the Create Template dialog as follows:
Component Name: CONCRETE

Style: P_ROAD_Concrete

Slope: -2.000%

Thickness: 1.000

Width: 12.000

Place the component at the origin of the Current Template window.

Right-click on the Current Template window and select Add New Component >
Simple.

Setup the Current Component portion of the Create Template dialog as follows:
Component Name: CONCRETE

@® Since this is the same name as the first component created, the name is
automatically appended with a 1 resulting in Concretel as the component name.

Style: P_ROAD_Concrete
Slope: -6.000%
Thickness: 1.000

Width: 8.000
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11. Place the component at the right edge of pavement point of the Current
Template window.

Save Template Library
12. Select File > Save in the Create Template dialog.

Template Point Names
P

Add New Component Commands

e Template Point Names
— Create surface feature names during modeling

- Naming conventions are important during
template transitioning

- Point names and component names must be
unique on a single template

- Change names by double-clicking any point
¢ Brings up the Point Properties dialog

- Point Name List
e Select the point names from a list

Templates are used by the Roadway Designer to create surfaces of the proposed
roadway. Each template point will be connected longitudinally to the next template drop,
based on the interval, to form longitudinal breakline surface features. The names of
those features are the name of the template points. Therefore, establishing a standard
naming convention for template points is important to the quality of the proposed
surface.

Likewise, individual component names also appear in the ensuing surfaces. These
components are used for volume calculations, so standard naming conventions should
be applied to ensure consistent results.

When transitioning between two templates (going from a two-lane to a four-lane
roadway, for example), the Roadway Designer attempts to connect template points of
the same name to model the transition. Template transitioning makes consistent
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template component and template point naming even more important. Each template
point name and component name must be unique within a template. For accurate
volume calculations and surface creation (especially during template transition),
different templates should use consistent component and template point names.
Roadway Designer automatically appends the name with a unique number if the same
name is chosen during template creation. Also, Roadway Designer provides for
automatic prefixes and suffixes (such as LT_ and RT_) when components are created or
added to the left or right side of the origin point. Prefixes and suffixes for template point
names are defined using Tools > Options in the Create Template dialog.

Editing template point names is accomplished by right-clicking on a template point and
selecting Edit Point. Double-clicking the point also invokes Edit Point. This opens the
Point Properties dialog, where the point name and surface feature style are changed.
After you change the point name, click Apply. The Next > and < Previous buttons help
to change multiple points by moving from point to point within the same template.
Enabling the Display Points Names option in the Display portion of the Create Template
dialog allows you to visually verify the point names.

The Point Name List is used to create template point names. These names are then
selected during component creation or editing to reduce time spent keying in the names.
To add names to the Point Name List, right-click on Point Name List in the Template
folders and select Edit, or double-click on Point Name List.
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LESSON NAME: EDITING TEMPLATE POINT NAMES

LESSON OBJECTIVE:
In this lesson the student will learn to create and edit template point names.

» EXERCISE: CONTINUE TO WORK ON THE TEMPLATE NAMED 12" CONCRETE PAVEMENT
W/8' SHOULDER. THE TEMPLATE COMPONENTS HAVE BEEN ADDED, BUT THE NAMES
SHOULD BE CHANGED TO REFLECT A STANDARD NAMING CONVENTION.

1. Right-click on the Point Names List and select Edit.

The Point Name List dialog opens.

Key-in CL_CONC_BOT in the Name field.

Select the Style P_COGO_MainCL and click Add.

Key-in EOP_CONC_BOT in the Name field.

Select the Style P_ROAD_EdgeOfPavement and click Add.
Key-in SHDR_CONC_BOT in the Name field.

Select the Style P_ROAD_Shoulder and click Add, then Close.
Double-click the point located at the template origin.

© N o O bk wDN

The Point Properties dialog opens.
9. Change the point Name to CL and click Apply.
10. Click the Next > button which will move you down one point.
11. Change the Name as follows: Click Apply, then Next > and repeat.
Name
CL_CONC_BOT
EOP
EOP_CONC_BOT
SHDR
SHDR_CONC_BOT
12. Close the Point Properties dialog.

13. Right-click on the vertical segment separating the road and shoulder and select
the Merge Components command.

Now the merged component is named CONCRETE.
14. Double-click on the component to verify the name.
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15. Select File > Save in the Create Template dialog.

Constrained and Unconstrained Components B
I

Add New Component Commands

e Constrained

- Creates any component

» Median barrier, curb and gutter, complex pavement sections,
retaining walls, etc.

- Points are automatically constrained horizontally and
vertically

e Unconstrained
- Creates any component

— No points are constrained
— Constraints are added manually

Add New Component > Constrained is used to create open and closed shaped
template components using precision input. You can access this command by either
right-clicking on the Current Template window or selecting it from the pull-down menu.

Examples of constrained components include median barriers, curb and gutter sections,
retaining walls, and complex pavement sections.

Constrained components are created with horizontal and vertical constraints already
applied to each point.

Both closed and open shaped components can be created. The option to make the
component closed or open is selected by right-clicking on the Current Template window
during component creation.

When creating template points, the Dynamic Settings dialog is used to define point
names and styles. The Dynamic Settings dialog is also used to enter the precise location
for the points.

12/1/08
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The basic workflow for creating a constrained component is to:

Select Add New Component > Constrained.
Key-in the Component Name and select the Style in the Current Component area.
Key-in the Point Name and select the Style in the Dynamics Settings dialog.

Select the key-in type (hs= for example) and key-in the precision value (12.0,2.0%
for example) in the Dynamics Settings dialog.

Press the Enter or Tab key on the keyboard.
Repeat these steps until the last template point is placed.
Right-click on the Current Template window and select Finish.

Add New Component > Unconstrained is also used to create open and closed shape
template components using precision input. You can access this command by either
right-clicking on the Current Template window or selecting it from the pull-down menu.

This command works the same as using Add New Component > Constrained except
the components are created without any constraints on the points. The constraints are
added manually using Edit Point or Add Constraint, accessed by right-clicking on any
template point.

T .
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LESSON NAME: ADDING A CONSTRAINED COMPONENT

LESSON OBJECTIVE:
In this lesson the student will learn to create a concrete curb comprised of a constrained

component.

» EXERCISE: CREATE A TEMPLATE NAME
1. Browse to the folder named Components in the Create Templates dialog.
2. Create a template named Curb.

» EXERCISE: PREPARING THE SETTINGS BEFORE COMPONENT CREATION

3. If the Dynamic Settings dialog is not displayed, select Tools > Dynamic
Settings.

4. |If set, clear the Display Point Names check box.

Practice - Adding a Constrained Component (continued)

I
Exercise...
° Curb Detail | 5_1/2ﬂ
TOC BOC i
6"
Pavement
R SHDR
16"
TOC_BOT BOC_BOT
| 7-3/4"
12/1/08
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» EXERCISE: CREATING A CONSTRAINED COMPONENT

5. Right-click on the Current Template window and select Add New Component >
Constrained.

6. Setup the Current Component portion of the Create Template dialog as follows:
Component Name: CONCRETE CURB
Style: P_ROAD_ConcreteCurb
7. Setup the Dynamic Settings dialog as follows:
Point Name: SHDR (Select from the list)
Apply Affixes: disabled
Precision Input: xy = 0,0
8. Press the Enter key

® The default units for precision input are feet. You can enter other units with the
proper specification, such as 6” instead of 0.5.

® Watch the prompts in the lower left corner of the Create Template dialog. When
creating a component using precision key-in, an ESC allows you to go back.

9. Set up the Dynamic Settings dialog as follows:
Point Name: TOC
Apply Affixes: disabled
Precision Input: xy = 0.07,0.5 (from similar triangles)
10. Press the Enter key.
11. Set up the Dynamic Settings dialog as follows:
Point Name: BOC
Apply Affixes: disabled
Precision Input: hs = 5.5",0.0
12. Press the Enter key.
13. Set up the Dynamic Settings dialog as follows:
Point Name: BOC_BOT
Apply Affixes: disabled
Precision Input: dl = 0.0,-16"
14. Press the Enter key.
15. Set up the Dynamic Settings dialog as follows:
Point Name: TOC_BOT
Apply Affixes: disabled
12/1/08
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Precision Input: dl =-7.75",0
16. Press the Enter key.
17. Right-click on the Current Template Window and select Finish.
18. Enable the Display Point Names option.

Save the Template Library
19. Select File > Save in the Create Template dialog.

12/1/08
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Basic Component Creation Workflow

Creating Components

e Basic Component Creation Workflow
- Open a Template Library
— Select Create Template

— Navigate to folder where template will be
stored

— Create a new template

- Select the Dynamic Settings
- Create components

— Save the Template Library

Basic Component Creation Workflow

¢ Open the Template Library.

¢ Select Open Create Template icon. This brings up the Create Template dialog.
* Navigate to the template folder used for components.

» Select File > New > Template from the Create Template dialog. Name the new
template, which is a component.

e Select Tools > Dynamic Settings if the Dynamic Settings dialog is not open.
e Select Add > Simple or Add > Constrained from the Create Template dialog.

« Add template components by using the Dynamic Settings dialog to specify the Point
Name and Style, and the point locations.

e Select File > Save from the Create Template dialog to save the template library.

12/1/08
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Creating End Conditions

Creating End Conditions

e End Conditions
- Used to create cut and fill treatments
— Consist of End Condition Components
- Target Types

e Surface

- Specify any surface or select Active Surface
» Elevation
e Feature XY, Feature Elevation, Feature XYZ

e Alignment XY, Alignment Elevation, Alignment
XYZ

End conditions are template components which are used to model cut and fill
treatments. They are added to the end of simple, constrained, and unconstrained
components.

End conditions are created like other template components. End conditions consist of
template points and individual components, and appear as line segments. They are
different than simple and constrained components because they have the ability to
target surfaces, elevations, alignments and surface features.

An example of this targeting is a design criteria which specifies a 4:1 fill slope if a fill
height under 6 feet is encountered. The target type is the original ground surface.

To create an end condition, first select File > New Template and name the template.
Then use Add New Component > End Condition to build the end conditions. End
conditions are stored in the template library and normally are created in a separate
folder in the template library.
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Target Types

Target types are specified in the Current Component portion of the Create Template
dialog, which appears below the Current Template window during end condition
creation.

Target types are defined only for end condition components, and are a property of that
component. To edit a target type, open the Component Properties dialog by
double-clicking on the component or by right-clicking on the component and selecting
Edit Component.

A solution can intercept multiple targets and target types. A ditch design, for example,
may intercept an alignment that represents the bottom of the ditch and then intercept the
original ground surface to form the backslope of the ditch.

Surface — targets the active surface or any specified surface. Using the active
surface as the target helps when you are applying the end conditions to different
projects. This is because the end condition will still work even though the target
surface name may be different, so long as it is designated as the active surface.

Elevation — targets any specified elevation.
Feature XY — targets the horizontal offset of any specified surface feature.
Feature Elevation — targets the vertical elevation of any specified surface feature.

Feature XYZ — targets the horizontal offset and vertical elevation of any specified
surface feature.

Alignment XY — targets the horizontal offset of any specified alignment.
Alignment Elevation — targets the vertical elevation of any specified alignment.

Alignment XYZ — targets the horizontal offset and vertical elevation of any specified
alignment.

Style Elevation — targets the elevation of any specified style.
Style XY — targets the horizontal offset of any specified style.
Style XYZ — targets the horizontal offset and vertical elevation of any specified style.
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End Conditions Settings

P |
End Conditions Settings

e Priority
- Establishes the order in which components are

- Applies to segments branching from a single point

applied and tested

e Check for Interception
- Component searches for target
e Place Point At Interception
- Places a point when target is hit
e End Condition is Infinite
- Extends the last segment to target
e Do Not Construct
- Point is used to solve position of other points
- Point is skipped when drawing component
End Condition Priority
Simple end conditions consist of cut and fill segments. When creating the roadway
design, each condition will be tested in a specific order. That order is called the priority,
which is numeric, and is assigned during end condition creation. The most desirable
conditions are assigned the lowest priority numbers. The most desirable condition, and
the first condition to be tested, has a priority of 1. The next condition to be tested has a
priority of 2, and so on.
For example, a design criteria calls for two fill conditions; 4:1 fill slope for an 8 foot fill
height and a 3:1 fill slope for a 10 foot fill height. In this example, the target of each
condition is the original ground surface. Each condition will be tested starting with lowest
priority number. The first condition to successfully intersect the target, which is the
original ground surface in this example, will be applied.
Priority is used when more than one end condition starts at the same point. In order for
an end condition segment to be placed and used in the design, a segment or one of the
12/1/08
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segments connected to that segment must successfully intercept its target. If a segment
or its connected segments do not intercept their targets, that group of segments fails and
the next group of segments, with the next higher priority, are tested. It is important that
end conditions have at least one solution that will not fail to intercept their targets.

End Condition Settings

As you create the end conditions, there are several settings that will have to be
considered to obtain the desired results. These settings are enabled or disabled and are
set using the Dynamic Settings dialog during end condition point creation. To edit end
condition settings, open the Point Properties dialog by double-clicking on the end
condition point or by right-clicking on the point and selecting Edit Point.

Check for Interception — when set, the line segment will search for the specified
target. If not set, the line segment will be created at its full width regardless of
whether it intersects the target, provided that one of the segments connected to this
segment successfully intersects the target.

Place Point at Interception — when set, a point will be placed at the location of the
interception. If not set, the line segment will be created at its full width, provided that
one of the segments connected to this segment successfully intersects the target.

End Condition is Infinite — when set, the line segment will automatically be
extended to intercept the target. If not set, the line segment will only extend to its
maximum constraint to meet its target. This applies only to the last line segment in
an end condition.

Do Not Construct — If set, the end point of the line segment will be used as a
reference point to find a subsequent point. The point will be solved like any other end
condition point, but that point will be skipped when drawing the final component
segments. This is normally not set and is used only for more complex condition
testing.
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LESSON NAME: CREATING END CONDITIONS

LESSON OBJECTIVE:
In this lesson the student will learn to create an end condition and save the template library.
» EXERCISE: CREATE A NEW TEMPLATE NAME
1. Browse to the folder named End Conditions in the Create Templates dialog.
2. Create a template named Simple Cut and Fill.
» EXERCISE: START THE DYNAMIC SETTINGS
3. Select Tools > Dynamic Settings, if not already displayed.
4. Set the Display Point Names check box.
» EXERCISE: CREATE END CONDITION COMPONENTS

5. Right-click on the Current Template Window and select Add New Component >
End Condition.

The example design criteria calls for a 6:1 fill slope at fill heights between 0’ to 5'.
6. Setup the Current Component portion of the Create Template dialog as follows:

Name: 6:1 FILL FOR 30°

Style: P_ROAD_FillLine

Target Type: Surface

Priority: 1

Surface: <Active>
7. Setup the Dynamic Settings dialog as follows:

Point Name: BOC  (select from list)

Apply Affixes: Disabled

Precision Input: xy = 0,0

With your cursor in the xy=0,0 field, press the Enter key on your keyboard.

Setup the Dynamic Settings dialog as follows:

Check for Interception: Enable

Place Point at Interception: Enable

End Condition is Infinite: Disabled

Do Not Construct: Disabled

Point Name: 6:1 FILL  (key-in the name)

Point Style: P_ROAD_FillLine
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10.

11.

12.

13.

14.

15.

16.
17.

18.

Apply Affixes: Disabled
Precision Input: hs = 30.0,-1:6

With your cursor in the hs = 30.0,-1:6 field, press the Enter key on your
keyboard.

Right-click on the Current Template window and select Finish.

Right-click on the BOC point on the Current Template Window and select Add
New Component > End Condition.

The example design criteria calls for a 3:1 fill slope for fill heights greater than 5'.
Setup the Current Component portion of the Create Template dialog as follows:
Name: 3:1 FILL

Style: P_ROAD_FillLine

Target Type: Surface

Priority: 1

Surface: <Active>

Setup the Dynamic Settings dialog as follows:

Check for Interception: Enable

Place Point at Interception: Enable

End Condition is Infinite: Enable

Do Not Construct: Disabled

Point Name: 3:1 FILL

Point Style: P_ROAD_FillLine

Apply Affixes: Disabled

Precision Input: hs = 40.0,-1:3

With your cursor in the hs = 40.0,-1:3 field, press the Enter key on your
keyboard.

Right-click on the Current Template Window and select Finish.

Right-click on the BOC point in the Current Template window and select Add
New Component > End Condition.

The example design criteria calls for a 3:1 cut slope for all cut conditions.
Setup the Current Component portion of the Create Template dialog as follows:
Name: 3:1 CUT

Style: P_ROAD_CutLine

Target Type: Surface

Priority: 1
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Surface: <Active>
19. Setup the Dynamic Settings dialog as follows:
Check for Interception: Enable
Place Point at Interception: Enable
End Condition is Infinite: Enable
Do Not Construct: Disabled
Point Name: 3:1 CUT
Point Style: P_ROAD_CutLine
Apply Affixes: Disabled
Precision Input: hs = 40.0,33.3%

20. With your cursor in the hs = 40.0,33.3% field, press the Enter key on your
keyboard.

21. Right-click on the Current Template Window and select Finish.

Save the Template Library
22. Select File > Save in the Create Template dialog.
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LESSON NAME: ADDING A DITCH END COMPONENT

LESSON OBJECTIVE:
In this lesson the student will learn to create a ditch end component.

» EXERCISE: CREATE DITCH END COMPONENTS

Continue to work on the end condition template named Simple Cut and Fill.

1. Right-click on the 3:1 FILL point in the Current Template window and select Add
New Component > End Condition.

2. Setup the Current Component portion of the Create Template dialog as follows:
Name: DITCH
Style: P_ROAD_Ditch
Target Type: Surface
Priority: 1
Surface: <Active>
3. To place the second point, set up the Dynamic Settings dialog as follows:
Point Name: DITCH BOTTOM (select from list)

Check for Interception: Disabled

@® This forces this line segment to be placed.

End Condition is Infinite: Disabled

Do Not Construct: Disabled

Apply Affixes: Disabled

Precision Input: hs =5,-1:4

With your cursor in the hs = 5,-1:4 field, press the Enter key.
5. Setup the Dynamic Settings dialog as follows:

Point Name: DITCH BACKSLOPE (select from list)

Check for Interception: Disabled

@® This forces this line segment to be placed.
End Condition is Infinite: Disabled
Do Not Construct: Disabled
Apply Affixes: Disabled
Precision Input: hs = 5,0
6. With your cursor in the hs = 5,0 field, press the Enter key.
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7. Setup the Dynamic Settings dialog as follows:
Point Name: DAYLIGHT (select from list)
Check for Interception: Enable
Place Point at Interception: Enable
End Condition is Infinite: Enable
Do Not Construct: Disabled
Apply Affixes: Disabled
Precision Input: hs = 5,25%
8. With your cursor in the hs = 5,25.0% field, press the Enter key.
9. Right-click on the Current Template window and select Finish.
Save the Template Library
10. Select File > Save to save the template library.
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Testing the End Conditions

Testing End Conditions

e Testing End Conditions
- Verify the solutions and priority
- Test multiple targets

e Workflow
— Select Test button
* Brings up Test End Conditions dialog
— Edit the Priority if necessary
— Select Draw
— Move cursor over End Conditions

Testing End Conditions

End Conditions can be tested prior to and during end condition creation. Testing
simulates how the end conditions will behave during modeling, without using the

Roadway Designer.

To test that the end conditions produce the desired results, select the Test button
located under the Current Template window. This opens the Test End Conditions dialog.
The window in the Test End Conditions dialog displays non-end-condition components
as solid lines and end conditions as dotted lines. The scale of this window is dynamic

and view controls are located at the bottom.

To test the end conditions, select one of the available targets and select the Draw button
located on the right side of the dialog. Move your cursor over the testing window. The
end conditions will change from a dotted line to a solid line, revealing the final solution for
the proposed target intercept. If there are any priority conflicts, you will receive a warning
message. Select the Check Priorities button to review and edit the priority of each end

condition.
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LESSON NAME: TESTING THE END CONDITIONS

LESSON OBJECTIVE:
In this lesson the student will learn to test end conditions and change their priority.

Continue to work on the end condition template named Simple Cut and Fill.

» EXERCISE: TEST THE END CONDITIONS AND CHANGE THE PRIORITY

1.

© © N O

Select Test located under the Current Template window.
A warning will be given about the template having end condition priority conflicts.
Select Check Priorities on the right side of the Test End Conditions window.

Notice that BOC point is a bold white color, which is an indicator of the point that
has the priority conflicts.

Select Edit.
Notice that all the end conditions have the same priority number.
Put your cursor in each of the fields and notice the segments highlighting.

Assume that fill is the most desirable condition and change the Priority of the 3:1
FILL to 2 and the Priority of the 3:1 CUT to 3.

Click OK, then Close.

Click Draw on the right side of the Test End Conditions window.
Move your cursor over the end conditions.

Change the Use Surface Slope to 10.00% and click Draw again.

10. Move your cursor over the end conditions.
11. Close the Test End Conditions dialog.

Save the Template Library

12. Select File > Save to save the template library.
13. Exit MicroStation.
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Basic End Condition Component Creation Workflow

Creating End Conditions

e Basic End Condition Component Creation
Workflow
- Open a Template Library
— Select Create Template

- Navigate to folder where template will be
stored

- Create a new template

— Create End Condition components
- Test the End Conditions

— Save the Template Library

Basic End Condition Component Creation Workflow

¢ Open the Template Library.

¢ Select Open Create Template icon. This brings up the Create Template dialog.
* Navigate to the template folder used for End Condition components.

» Select File > New > Template from the Create Template dialog. Name the new
template, which is an end condition component.

e Select Tools > Dynamic Settings if the Dynamic Settings dialog is not open.
e Select Add > End Condition from the Create Template dialog.

« Add end condition components by using the Dynamic Settings dialog to specify the
Point Name and Style, and the point locations.

« Select File > Save from the Create Template dialog to save the template library.
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Summary and Review

Summary and Review

You are now able to... _'

Pl
Before continuing let’s
reinforce what
you have learned!
Summary

You are now able to:

« Understand template point constraints and components
» Create template components

e Create a complete template from the components
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Questions

Before continuing, let’s reinforce what you have learned.

1.

True or False, Point constraints are used to manage the behavior of template
points?

e True
 False

A “Fully Constrained” point contains a maximum of how many constraints?
A - None

B - One

C-Two

D - Three

Name three types of Constraints?
A -
B -
C -

True or False, the top points of a simple component are constrained to points
directly below them by horizontal and vertical constraints?

e True
 False

Which template component that is used to model cut and fill treatments?
A - Constrained

B - Simple

C - End Condition

D - Unconstrained
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Answers

1. True or False, Point constraints are used to manage the behavior of template
points?

True - Point constraints are used to manage the behavior of template points.
They are used so that if a point is moved in a template, either by the user editing
the template or by the application of point controls during the design processing,
all the points related to the point being moved will behave in a predictable
manner.

2. A *“Fully Constrained” point contains a maximum of how many constraints?

C - A point with two constraints is considered “fully constrained”.

3. Name three types of Constraints.
A - Horizontal Constraint
B - Vertical Constraint

C - Slope Constraint

4. True or False, the top points of a simple component are constrained to points
directly below them by horizontal and vertical constraints?

False - The lower points are constrained to points directly above them by
horizontal and vertical constraints.

5. What is the template component that is used to model cut and fill treatments?

C — End Conditions are template components which are used to model cut and
fill treatments. They are added to the end of simple, constrained, and
unconstrained components.
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