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Lesson Name: Opening a Project (InRoads User)
Lesson Objective:
In this lesson the student will learn to access an InRoads project in preparation for creating templates to design a model in Roadway Designer.  Note: this lesson is for InRoads users only. For GEOPAK users, please proceed to the next lesson on the next page.

Exercise: Getting Started (InRoads User)
This exercise will guide you through the steps to get started
1. Go to Start > Programs > Bentley > InRoads Group V8i (SELECTSeries 1) > InRoads Suite.
2. Open the file SR 2067 Bypass.dgn in the C:\EW-9\Advanced EC\DGN\ folder.
3. When the InRoads Explorer appears, go to File > Open from the InRoads menu.
4. When the Open dialog appears select the InRoads project file: 
C:\EW-9\RWK Files\Advanced EC.rwk and press OK.
Opening the RWK project file opens the following files:
SR 2067 Bypass.alg
EW-9 Template Standards.itl
Existing Ground.dtm
Bentley Training.xin
5. Select Modeler > Create Template from the InRoads Explorer menu to access Create Template. 
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Lesson Name: Opening A Project (GEOPAK User)
Lesson Objective:
In this lesson the student will learn to access a GEOPAK Corridor Modeler project in preparation for designing a model in Roadway Designer.  Note, this lesson is for GEOPAK users only.

Exercise: Getting Started (GEOPAK User)
This exercise will guide you through the steps to get started
1. Go to Start > Programs > Bentley > MicroStation V8i > Bentley MicroStation V8i.
2. The instructor will provide the appropriate path location for this project. When the MicroStation Manager appears select the file:
Plan.dgn and press OK.
3. Go to Applications > Road > 3D Tools > Corridor Modeling.
4. Select the GPK job number 001
5. Choose File > Load from the Corridor Modeling dialogue.
6. Load the Corridor Modeler project file entitled My_Project.rdp.
7. Choose the Open Roadway Designer icon from the Corridor Modeling dialogue to access Roadway Designer.
[image: ]

 Lesson Name: End Condition Overview
Lesson Objective:
To understand End Condition Processing Logic to be able to provide conditional solutions.

What are End Components?
	They Daylight
	They Seek
	They Sequence

End Components tie the Design Surface into the existing surface. End Conditions seek Targets. 
They provide a logical branching and sequencing capability.

• Engineering Criteria, for slope treatment in particular, are often specified in Ifthen‐
else terms:If a 1:6 cut slope can find daylight in less than 18 feet [6 m], then use a 1:6 slope; else

• if it can find daylight in less than 32 feet [8 m] at 1:4, then use a 1:4 slope, else

• if it can find daylight in less than 45 feet [12 m] at 1:3, then use a 1:3 slope, else use a 1:2 slope to  
   intersection. End Condition components provide solutions to these conditional engineering  
   specifications by providing the following abilities

• The ability to seek the existing ground (and other targets) within width limits, if desired.

• The ability to succeed or fail in the search.

• The ability to logically branch depending on the seek results.







Examples of End Conditions
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Examples of End Condition solutions we will build in class include:

• Multiple Slope Cut and Fill Solutions, with a Fill Ditch
• Retaining Walls that seek a horizontal wall location then seek the surface
• A Cut Solution that places a Brow Ditch if and only if the existing surface drains
   towards the road
• A Template that automatically forces the daylight line to the ROW limit if the steepest             
   standard slope intrudes beyond the right of way line.

 End conditions cannot be closed shapes. Closed shapes, such as a ditch lining, can be constrained to end condition points, however.
EC Concepts
EC’s Seek Targets
Succeed or Fail
Multiple Options = Branching
Priorities

Seek Targets

End Conditions seek targets such as surfaces. The seek can succeed or fail, different things happen based on the success or failure.

Multiple End Condition Components can start from the same template point. The Components are processed in a user‐defined order. If a component fails, the next component starting at the point attempts to find its target. The first component to succeed is placed. In this way a sequenced engineering specification can be applied.

Succeed or Fail

An End Component Solution is a collection of one or more End Condition Components. Each End Component has a Target it is seeking. It can succeed or fail in finding that target. The Success or Failure of a Component affects the processing of other Components in the solution.


Multiple options = Branching

A Branch Point is any Point with more than one EC Component or EC Path starting at the same point. At Branch Points Paths are processed in order of Priority (lower numbers are processed first). Once an End Condition Path ends with Success the solution is found; there is no need to continue solving other paths. If a Branch Point is found within a Path all Paths at that point are evaluated for success.

Priorities

Given two End Conditions starting from the same point, Roadway Designer will start processing 
with the Component with the lowest priority number. While two components having the same Priority will process, they may not process properly and it is poor technique. Multiple solutions for cut or for fill tend to have clearpriorities: tying in with a flat slope is better than tying in with a steep slope when possible. For example, a typical cut solution might have the following clear priorities:
		
Try to tie in at 1:6, then 25%, then 1:3. Use 1:2 for the deepest cuts.


 	End Condition Point Properties

Common: Name/Style

Special EC:
· Check for Interception
· Place Point at Interception
· End Condition is Infinite
· Do Not Construct	


Check for Interception

To intercept a target such as a surface the Point’s Check for Interception property must be set. Sometimes segments such as Ditch Foreslopes are not meant to intercept a target. They are meant to be placed only if a later segment finds the target. These segments’ Check for Interception property should be clear.

Place Point at Interception

In order to place a point at the target the Place Point at Interception property must be set. Sometimes a point needs to be placed at the end of a segment even if the target is intercepted prior to the end of the segment. An example is a minimum depth ditch foreslope. In this case, clearing the Place Point at Interception property will place a 5 foot [1.5 m] ditch foreslope even if the surface is found before that at three feet [1 m].

End Condition is Infinite

Very often the constraints of an End Condition Point are Slope and Horizontal. The Horizontal Constraint value represents the maximum width within which to check for the target. For example a 1:6 slope may be appropriate for a maximum width of 18 feet [4 m]. This would be represented as a segment with a 1:6 slope and a Horizontal Constraint of 18 feet [4 m], with the End Condition is Infinite check box clear. If the End Condition is Infinite check box is set the segment seeks the surface without limit. This check box is generally set on the final cut or fill alternative. For example, 1:6 slopes may have a Horizontal Constraint of 18 ft. [4 m], 1:4 24 ft.[6 m], 1:3 30 ft.[10 m], and 1:2 infinite.

                             Do Not Contruct

                             The Do Not Construct check box specifies the point will be solved like all other points in the                
                             end-condition, but the point will be skipped when drawing the component segments. This is                                                
                             useful in many situations, including variable slope solutions.
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There are many side slope solutions with a sequence of dependent targets. One common example is  
to fill to the existing ground and then add an exterior fill ditch which must then tie in to the existing 
ground. A more elaborate example might be to fill to the ground, put in a ditch to within one foot of 
the water table and finish with an exterior berm.

These are examples of serial targets: once an initial target is found additional earthwork is performed prior to tying back in to the existing surface.

The software logic follows the engineering logic. If the first target is not found further operations are not attempted. If, for example, you have a cut specification but are in fill, the initial cut seek will never find the existing ground. Following further cut specifications are moot. Any component failure in an End Condition path stops the path processing.



Path Rules
• When a component Succeeds keeping going.

• Once a Component in a path fails the whole Path fails. Processing returns to the next path at a   
    branch point, if one exists.

• A single End Condition component follows the same rules and behaves as a Path.


A Component or Path that has no Seeking segments counts as a Success, but is only placed if the subsequent path succeeds. An example of this is might be a single‐segment EC component from shoulder to the hinge point from which a series of related EC Components start. This is shown in a later Practice Exercise.



Lesson Name: Build a Fill Ditch Template
Lesson Objective:
In this lesson the student will learn how to create a Fill Ditch Template by intercepting the Active Surface twice, set up a 3:1 Fill End Condition, place and create the Fill Ditch components and points and finally test the template to insure it works as designed.
Exercise: Build a Fill Ditch

Create a New Template

1 In the EW-9Template Standards.itl file, open the Build_A_Fill_Ditch folder.
2 Right‐click the Build_A_Fill_Ditch folder. Select New > Template.
3 Rename the New Template to Fill Ditch_2SurfaceSeeks.


Set up the Fill_1:3 End Condition Component

1 Select the Add New Component > End Condition menu item.
2 Set the Component Name to Fill_1:3.
3 Set the Style to P_Road_FillLine.
4 Set the Priority to 5.
5 Set the Target Type to Surface.
6 Set the Surface to <Active>.
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Place the First Component Points
1 In the Dynamic Settings dialog, select a Point Name of Hinge. The Point Style should automatically 
    be set to P_ROAD_Hinge.
2 Place the point at xy= 0,0.
3 In the Dynamic Settings dialog, key in a Point Name of 1st_Seek and select a Point Style of  
   P_DRAIN_DitchForeslope; set the Check for Interception, Place Point at Interception and End Condition is  
   Infinite check boxes; clear the Do Not Construct check box.
4 Place the next point at hs=30,‐1/3 [hs=10,‐1/3].
5 Right‐click in the window and select Finish.
6 Test the Template.
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Create the Fill Ditch Component

1 Select the Add New Component > End Condition menu item.
2 Set the Component Name to Fill_Ditch.
3 Set the Style to P_ROAD_Ditch.
4 Set the Priority to 5. 
    This step is probably unnecessary. It is unlikely that there will be a branch from this point.
5 Set the Target Type to Surface.
6 Set the Surface to <Active>.



Place the Fill_Ditch points

1 Place the first point at the 1st_Seek point.

   Make sure the point turns white indicating that the new point will merge with the old.

2 In the Dynamic Settings dialog, set Point Name to Fill_Ditch and the Point Style to P_ROAD_Ditch;  
   clear the Check for Interception, Place Point at Interception, End Condition is Infinite and Do Not  
   Construct check boxes.
3 Place the next point at hs=2,‐50% [hs=1,‐50%].
4 Place the next point at hs=5,0% [hs=2,0%].
5 In the Dynamic Settings dialog, set Point Name to Fill_Ditch_Daylight and the Point Style to 
    P_ROAD_FillLine; set the Check for Interception, Plac3 Point at Interception and End Condition is   
    Infinite check boxes; clear the Do Not Construct check box.
6 Place the next point at hs=2,50% [hs=1,50%].
7 Right‐click in the window to select Finish.
8 Test the template.
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Lesson Name: Multiple Options > Tree Branching
Lesson Objective:
In this lesson the student will learn how the Branching abilities of end conditions enable setting 
up templates that enact even the most complex engineering specifications. You’ll review component
priorities, predict the behavior of the template and test to confirm your predictions.
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End Condition Processing Sequence

First, the End Condition Start Points are found.

A Start Point is any point the starts an End Condition that is not at the end of another End Condition.

There is no limit to the number of start points in a template. The order in which the start points are processed is based on priority. All the End Condition Components attached to the Start Point is referred 
to as an End Condition Tree.

For each start point in a template Roadway Designer attempts to solve all the End Condition paths 
starting from that start point. The first path that succeeds is placed and processing of the End Condition 
Tree stops.

         Exercise‐Multiple Branches

Select the Template

1 In the EW-9 Template Standards.itl file, open the Review_A_MultiBranchfolder.
2 Double‐click the Fill_Branch_&_BranchPath template to make it active.


Review the Component Priorities

1 Review the component Priorities
2 Predict the behavior of the template
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Test the Template

1 Use the Test button to confirm your predictions about the template behavior.

    Did the behavior differ from what you expected? If so, review the Priorities and the 
    Branch/Path logic rules.



     Target Types
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The Targets for End Condition Component consist of three types. Tying into a surface, particularly 
the existing surface, is perhaps the most obvious Target type.

End Conditions can target an absolute Elevation value. An example of this is when having a single 
cut bench at a specific elevation.

The other category of End Condition Targets uses the horizontal and/or vertical geometry of InRoads alignments or features as targets.

The user can select Alignment, Feature or Feature Style as the element type. Horizontal and/or Vertical targeting is specified as follows:

• XY is horizontal only
• Elevation is vertical only
• XYZ is both horizontal and vertical only    
Lesson Name: Advanced Techniques for creating Exterior Ditches
Lesson Objective:
In this lesson the student will learn the steps to create an Exterior Fill Ditch.

     Minimum Width Exterior Ditches


[image: ]


Cut or fill ditches can be defined by a template seeking the existing ground twice, once for the cut 
or fill slope and again for the outside ditch slope, these dual‐seek templates only provide an optimum solution if the existing ground is level at the ditch. If not level the ditch slope either does not provide 
enough freeboard or too much freeboard.

Targeting the surface for the inside wall of the ditch is actually unnecessary:generally there is no need in 
the final solution to tie the inside ditch wall to where the existing surface used to be. The true requirement 
is to provide the required ditch in the narrowest footprint.



Single‐Seek (Min. Width) Exterior Ditches
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Exterior ditch solutions generally have one variable: the length of the cut or fill slope; the rest 
of the geometry is fixed. The trick to building a single‐seek template is to position the origin of 
the seeking segment at an offset equivalent to the fixed geometry, which in simple cases is the 
ditch. From this offset origin the seek point finds the Daylight point.

None of the points in the template used find the daylight point have engineering value and should 
not become part of the resulting surface. The Components owning the placeholder points should 
have their “Exclude from Triangulation” property set so that the points do not get triangulated in the 
surface. Using keywords or prefixes, such as “xDNC_” may make segregating and deleting points and components easier.

Once the Daylight point is found, enough information exists to build the side slope and ditch components. These components should not be End Conditions; they should, however, be children of the seeking segment, so that if the seek fails, they are not placed. The fixed ditch portion should be defined from the Daylight point. The hinge point and the ditch portion interior point should not be constrained to each other; 
this is the variable segment whose geometry has been determined by the seek segment.


Exercise‐Create a Single‐Seek Cut Ditch
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Create the Brow Ditch Template

1 In the EW-9Template Standards.itl file, right‐click the folder SingleSeekDitch, select New >    
   Template.
2 Rename the new Template to Ditch_Cut_Tight.

Create the Placeholder Ditch End Condition Component

1 Select the Add New Component > End Condition menu item.
2 Set the Component Name to xDNC_Cut_Ditch.
3 Set the Style to DNC.
4 Set the Priority to 3.
5 Set the Target Type to Surface.
6 Set the Surface to <Active>.



      Place the placeholder points

       1 In the Dynamic Settings dialog, set Point Name to Hinge and the Point Style to DNC.
       2 Place the point at xy= 0,0.
       3 In the Dynamic Settings dialog, clear the Check for Interception, Place Point at Interception 
          and End Condition is Infinite check boxes; set the Do Not Construct check box.
       4 Place the next point at hs= 5,0 [hs= 2,0].
       5 Place the next point at hs= 4,‐50% [hs= 1.2,‐25%].
       6 Place the next point at hs= 4,0%[hs= 1.2,25%].
       7 Place the next point at hs= 4,50% [hs= 1.2,25%].
       8 In the Dynamic Settings dialog, set the Check for Interception, Place Point at Interception, 
          End Condition is Infinite and the Do Not Construct check boxes.
       9 In the Dynamic Settings dialog, set Point Name to Cut_Ditch_Daylight and the Point Style to    
          P_ROAD_CutLine.
       10 Place the next point at hs= 5,50% [hs= 2,50%].
       11 Right‐click in the window to select Finish.
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Create the Cut Ditch Component

1 Select the Add New Component > Constrained menu item. 

Since the points are constrained to the previous point we need to work from the 
outside to the inside.

2 Set the Component Name to Cut_Ditch.

3 Set the Style to P_ROAD_CutLine.


Place the Ditch points

1 In the Dynamic Settings dialog, set Point Name to Cut_Ditch and the Point Style to   
   P_ROAD_CutLine.
2 Place the point at the Cut_Ditch_Daylight point. (May want to right click and turn off Closed Shape)
3 Place the next point at hs= ‐4,50% [hs= ‐1.2,50%].
4 Place the next point at hs= ‐4,0% [hs= ‐1.2,0].
5 Place the next point at hs= ‐4,‐50% [hs= ‐1.2,‐50%].
6 Place the next point at hs= ‐5,0 [hs= ‐1.5,0].
7 Place the next point at the Hinge point.
8 Right‐click in the window to select Finish.
9 Right‐click on the Cut_Ditch component, select Edit Component.
10 In the Component Properties dialog, select xDNC_Cut_Ditch for the Parent Component.
11 Select Apply.
12 Test the template.
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Exercise‐Create a Single‐Seek Fill Ditch
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              This exercise complements the Cut Ditch Exercise by providing the steps to create a Fill Ditch.

Create the Fill Ditch Template

1 Right‐click the SingleSeekDitch folder, select New > Template.
2 Rename the new Template to Ditch_Fill_Tight.

Create the Placeholder Ditch End Condition Component

1 Select the Add New Component > End Condition menu item.
2 Set the Component Name to xDNC_Fill_Ditch.
3 Set the Style to DNC.
4 Set the Priority to 3.
5 Set the Target Type to Surface.
6 Set the Surface to <Active>.


      Place the placeholder points

        1 In the Dynamic Settings dialog, set the Point Name to Hinge and the Point Style to P_ROAD_Hinge.
        2 Place the point at xy= 0,0.
        3 In the Dynamic Settings dialog, set the Point Name to xDNC_Fill_Ditch and the Point Style to DNC.
        4 In the Dynamic Settings dialog, clear the Check for Interception, PlacePoint at Interception, and End    
           Condition is Infinite check boxes; set the Do Not Construct check box.
        5 Place the next point at hs= 8,‐25% [hs= 2,‐25%].
        6 Place the next point at hs= 4,0% [hs= 1.2,0%].
        7 Place the next point at hs= 8,25% [hs= 2,25%].

       Create the Daylight Seek Point

1 In the Dynamic Settings dialog, set all four check boxes: Check for Interception, Place Point at 
    Interception, End Condition is Infinite, and Do Not Construct.
        2 In the Dynamic Settings dialog, set the Point Name to Fill_Ditch_Daylight and the Point Style to  
            P_ROAD_FillLine.
        3 Place the next point at hs= 5,‐50% [hs= 1.5,‐50%].
        4 Right‐click in the window to select Finish.
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Create the Fill Ditch Component

1 Select the Add New Component > Constrained menu item.

Since the points are constrained to the daylight point we need to work from the outside to the inside.

2 Set the Component Name to Fill_Ditch.

3 Set the Style to P_ROAD_FillLine.


Place the Ditch points

1 In the Dynamic Settings dialog, set Point Name to Fill_Ditch and the Point Style to  P_ROAD_FillLine.
2 Place the point at the Fill_Ditch_Daylight point.
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3 Place the next point at hs= ‐8,25% [hs= ‐2,25%].
4 Place the next point at hs= ‐4,0% [hs= ‐1.2,0%].
5 Place the next point at hs= ‐8,‐25% [hs= ‐2,‐25%].
6 Place the next point at the Hinge point.
7 Right‐click in the window to select Finish.
8 Test the template
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Make the Ditch a Child of the End Condition

While the template behaves properly as is, making the Fill Ditch component a child of the End Condition   
component simplifies managing these components when used in more complex template.

1 Right‐click on the Fill_Ditch component, select Edit Component.
2 In the Component Properties dialog, select xDNC_Fill_Ditch for the Parent Component.
3 Select Apply.
4 Close the dialog.




Lesson Name: Advanced Techniques for creating Exterior Ditches
Lesson Objective:
In this lesson the student will learn how to create a template that will deal with
common erosion control and rockfall protection requirements for high cuts 
and fills to break up long slopes with flatter sections known as benches.
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The requirements typically specify a maximum slope distance or height allowed without a bench. 
Very long slopes may require many benches.

End Condition components, by definition, seek a target subject to the constraints of their geometry. 
Any End Condition component can be looped up to a userspecified maximum iterations searching 
for its target. Like all End Conditions, if the target is found the solution is placed otherwise the End 
Condition fails.

Roadway Designer accommodates both bench elevation methods:

• Relative to the start point.
• Relative to a datum with defined elevation steps.

Exercise‐Benching

	We will be defining a benched cut solution.

Create the Bench Cut Template

1 Right‐click the Benching folder and select New > Template.
2 Rename the new Template to BenchCut.

Create the End Condition

1 Select the Add New Component > End Condition menu item.
2 Set the Component Name to Cut_Bench.
3 Set the Component Style to P_ROAD_CutLine.
4 Set the Target Type to Surface.
5 Set the Surface to <Active>.
6 Set the Benching Count to 5.
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Place the Bench points

1 In the Dynamic Settings dialog, set Point Name to Hinge and the Point Style to P_ROAD_Hinge.
2 Place the point at xy= 0,0.
3 In the Dynamic Settings dialog, key in a Point Name of Cut_Bench and set the Point Style to  
   P_Road_CutLine; set the Check for Interception, Place Point at Interception check boxes; clear the End  
  Condition is Infinite and Do Not Construct check boxes.
4 Place the next point at hs= 20,100% [hs= 5,100%].
5 Place the next point at hs=5,‐5% [hs= 1.6,‐5%].
6 Right‐click and select Finish.
7 Test the template.
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Lesson Name: Creating a Barrier – Mountable Gutter Template
Lesson Objective:
In this lesson the student will design a template that When the template encounters a 
driveway style, place a mountable gutter and draw a driveway from the back of the 
gutter to the 3D driveway feature. Also, When the template does not encounter a 
driveway style, place a barrier gutter and normal cut and fill slopes.
 	
	Exercise: Building the End Condition

	Opening the File and Template Library

1. Open C:\EW-9\Tasks\End Conditions\working.dgn.
2. Open C:\EW-9\RWK\End Conditions.rwk
		3. Open Modeler > Create Template
		4. Go to the End_Conditions template folder and select the Task_Driveways folder.
		5. Right click > New Template and name it End_Conditional_Curbs.
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Placing the Gutter Templates

1. Drag the Curb_Barriers into the active template at the origin and fit the template.
2. Drag the Curb_Mountable into the active template at the origin making sure the point turns white   
     and fit the template.
         
            [image: ]

3. Open Tools > Dynamic Settings and Key-in xEndCond_Mountable for the point 
     name and Point Style = DNC.


Create the End Condition

1 Select the Add New Component > End Condition menu item.
2 Set the Component Name to xEndCond_Mountable.
3 Set the Component Style to DNC.
4 Set the Target Type to Surface.
5 Set the Surface to <Active>.
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	Place the Gutter Mountable points

1 Place the point by clicking on the Curb_Face point.
2 In the Dynamic Settings dialog, clear the Check for Interception, Place Point at Interception and Do   
   Not Construct check boxes check boxes; set the End Condition is Infinite check box.
3 Place the next point at Gutter_FloLine_Barrier
4 Place the last point at Curb_Back_Mountable
5 Right‐click and select Finish.


	Place the Gutter Barrier points

1 In the Dynamic Settings dialog, key-in xEndCond_Barrier for the Point Name.
2 Select the Add New Component > End Condition menu item.
3 Set the Component Name to xEndCond_Barrier and Priority = 2.
4 Place the 1st point by clicking on the Curb_Face point.
5 Place the next point at Gutter_FloLine_Barrier
6 Place the next point at Curb_Top_Barrier
7 Place the last point at Curb_Back_Barrier
8 Right‐click and select Finish.


	Editing the xEndCond_Mountable Component Properties 

1 Right Click on the xEndCond_Mountable component > Edit Component.
2 Select xEndCond_Mountable
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3 The Components Properties dialog opens. Select End Conditions Properties > Target.
4 Set the value to Style XYZ.
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5 Set the Style to E_RW_Driveway_3D_R
6 Click > Apply then Close


Editing the xEndCond_Barrier Component Properties 

1 Right Click on the Curb_Barrier component > Edit Component.
2 Click the Locate Button adjacent to Parent Component
3 Select the curb face and then Select > xEndCond_Barrier
                 [image: ]
4 Click > Apply



Setting the xEndCond_Mountable Parent Component 

1 Click on the Locate Button adjacent to Name.
2 Select the Curb_Mountable Component
3 Set the Parent Component to xEndCond_Mountable 
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4 Click Apply then Close


Attaching a Cut/Fill End Condition 

1 Drag template Cut n Fill into the active template and place it on the Curb_Back_Barrier point.
2 Click the Scroll Bar to move to the right


Create the Driveway End Condition

1 Select the Add New Component > End Condition menu item.
2 Set the Component Name to Driveway.
3 Set the Component Style to P_ROAD_Driveway.
4 Set the Target Type to Style XYZ.
5 Set the Surface to <Active>.
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 6 In the Dynamics Settings dialog set the Point Name to Driveway
      7 Set the Style to P_Road_Driveway; 
    	      8 Click on the Curb_Back_Mountable point. Set End Condition is Infinite; Check for Interception,	
         and Place Point at Interception; Clear Do Not Construct
      9 Place the Driveway point somewhere to the right and down
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Edit the Driveway Component

1 Select the Component Name Driveway; right click > Edit Component.
3 Set Parent Component to xEndCondition_Mountable.
4 Set the Style to E_RW_Driveway_3D_R.
5 Click Apply then Close
6 Test the template 

Edit the Cut N Fill Components

1 Select the Component Name clear_R; right click > Edit Component.
Set Parent Component to Curb_Barrier_R.
3 Click Apply 
4 Set the Parent Component to Curb_Barrier_R for the two cut and two fill conditions
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5 Click Apply then Close
4 Test the template 
Lesson Name: Creating a Four Lane Template
Lesson Objective:
In this lesson the student will create a 4-Lane template that will utilize the previously created Barrier – Mountable Gutter end condition.

Exercise: Building the 4 Lane Template

	Creating the Four-Lane_UrbanDrivewaysL&R Template 

1. Continuing in C:\EW-9\Tasks\End Conditions\working.dgn.
2. Staying in the EW-9Template Standards.itl file, Tasks_Driveways >  folder
		3. Right click > New Template and name it Four-Lane_UrbanDrivewaysL&R.
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	Assembling the template
		
		1, Drag the four lane component into the active template window (use Mirror)
	2. Fit the template.
	3.Toggle On Apply Affixes in the Dynamic Settings dialog
	4. Drag the End_Conditional_Curbs template into the active template (use Mirror)
	5. Fit the template
	6. Window area around the left gutter assembly
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6. Select the Driveway_L component, right click > Edit Component   
7. Set End Condition Properties > Style to E_RW__Driveway_3D_L
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8. Click Apply then Close
9. Fit the template



Lesson Name: Pushing the Four Lane Template and Creating the Sections
Lesson Objective:
In this lesson the student will push the newly create 4-Lane template onto a corridor that will utilize the Barrier – Mountable Gutter end condition and make the appropriate decision as to whether a barrier or mountable curve will be designed.

Exercise: Pushing the 4 Lane Template

	Saving your template

1. Select File > Close and Yes when prompted to save your work.

Managing the Corridor

1. Open Roadway Designer
2. Click the Manage Corridor icon or go to the Corridor menu and select Corridor Management
3. Set the dialog as shown below
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4. Click Add then Close


Dropping the Template
1. Click the Template Drops icon or go to the Corridor menu and select Template Drops
2. Open to the EW-9\Standards\Templates\EW-9 Template Standards.itl file
3. Navigate to the Task)Driveways Folder and select the Four-Lane_UrbanDrivewaysL&R
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4,    Click Add then Close 
5. Click the Display References icon or go to the Corridor menu and select Display References
6. Select the Filter radio button and set the value to Driveways_only

        		  [image: ]

7. Click Add then Close
8. Double click in the plan view 
           [image: ]
9. Scroll through the cross sections to view the remaining driveway locations
Creating the Surface

1. Click the Create Surfaces icon or go to the Corridor menu and select Create Surface
2. Key-in sr2067_4LN_Driveways for the finished surface name
3. Set the remainder of the dialog box as shown below

[image: ]

4. Click Apply the Close
5. Exit Roadway Designer and Save your work as sr2067_wDriveways.ird
OPTIONAL: Creating the Cross Sections
	
1. For InRoads Users, Select Evaluation>Create Cross Sections
2. For Geopak Users, Select Create Cross Sections from the Corridor Manager
3. Select the sr2067 4LN_Driveways surface
4. Set the alignment to SR2067Bypass
5. Click Apply, DP the location then Close


       [image: ]






Lesson Name: End Condition Exceptions
Lesson Objective:
In this lesson the student will use End Condition Exceptions to override end conditions 
along a range of corridor stations.

Exceptions are used when end conditions are not desired in the design. For example when a 
corridor passes  through an intersection or over a bridge.

End condition exceptions are shown as a cyan colored shape in the plan view that can be double clicked to access the End Condition Exceptions dialog.

Exercise: Create an End Condition Exception

	1 Open SR 2067 Bypass.dgn in the C:\EW-9\Advanced EC\DGN\ folder.
	2 Place the sr2067 Bypass corridor and drop the Task Driveways > Four-Lane_UrbanDriveways     
    template onto the corridor.
3 Navigate to the cross section at station 185+00. We will place a Fill Bench end condition starting 
    at this location, ending at station 199+00.
4 Open Corridor > End Condition Exceptions.
5 Set the station range accordingly and provide a description if desired.
6 Set the Apply to Left Override option.

[image: ]

         7 Click Add then Edit. This displays the Left Override – 185+00 to 199+00 dialog.
         8 Right Click on the left fill slope (a cyan colored line) and select Delete Component.
            Note that the Fill_2to1_L point disappears
         9 Navigate to the End Conditions > Benching folder and select the Fill Bench template.
      10 Drag the Fill Bench template into the active template view and right click. With the left    
            mouse button still held down, select Reflect.
      11 Move the Fill Bench end condition to the Hinge_L point (make sure the point becomes a bold  
   white plus sign) and click.

[image: ]

12 Click OK on the Left Override – 185+00 to 199+00 dialog.
13 Close the End Conditions Exception dialog.
      Note that the end condition exception displays in the Plan View as a cyan shaded area.


                      Review and Save the Roadway Design

  1 Process All, close the Results dialog and review the design.
  2 Save the roadway design
  3 Optional: Create the End Condition Exception on the right side and save the design.
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