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Preface  
In this workshop, you will explore how OpenRoads Technology exposes design data.  You will review 
and create common roadway and site designs.  You will understand how OpenRoads Technology 
works. 

This workshop is equally applicable for the MX, InRoads or GEOPAK families of products.  Each 
product contains the identical toolset and identical workflow.  The only differences between the 
three products for the tools are slight differences in the use of feature definitions and some 
differences in the back-end interaction with other native toolsets, such as drainage.  In this 
workshop, we will use Power InRoads V8i SELECT series 3 released version, along with the Civil 
Workspace. 

There are more exercises in this manual than we will have time to cover today.  We will all complete 
the basic set of exercises, and for those veteran users in the group who complete them and still have 
time left in the exercise session, you are welcome to work on the optional.   

In order for all participants to design the same layout and to stay on course and on time, we request 
that all participants utilize the files as listed in the workshop materials.  At the beginning of each 
chapter, we will start with a fresh set of data.  This ensures that everyone is using the same data.  
Plus, we have added data to avoid redundant work.  For example, we draw some of the edges of 
pavement in the lab so you can understand the workflow, but have drawn the remainder in for 
expediency of time. 

The workshop guide is yours to take with you.   

 

Note Prerequisite Knowledge Level: Participant should have a basic understanding of road 
and/or site design principles and have some basic familiarity with civil engineering design 
software. 
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SESSION DESCRIPTION 

 

 

This hands-on, four-hour workshop empowers casual or new users to get productive in SELECTseries3 
quicker!  Learn the built-in CAD tools and how to navigate the new Civil data format - the dgn!  Evaluate civil 
models!  Import Existing Terrain!  Learn "the Rules"! Intelligently and Directly Edit Designs by Click-and-
Type!  Build Roads!  Create new corridors!  Grade Pads,  Save time with Civil Cells!   For all Bentley civil users. 
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LEARNING OBJECTIVES 

 
After this course you will be able to: 

• Open an OpenRoads Technology Design and describe its contents 
• Edit Civil Rules to change engineering/geometric properties 
• Describe why we use Civil Geometry Tools rather than “simply” “Add Civil Rules” to graphics 
• Create Horizontal and Vertical Geometry 
• Create 3D Roads (“Corridors”) 
• Create Building Pads and associated grading 
• Place Civil CellsAt the end of this training session, an assessment will be given. We will review 

all assessment questions and answers to see what you have learned. 
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Chapter 1: Exploring the Environment 
Getting Started in SS3 Bentley Civil Power Products  
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Standards are now in dgnlibs. Dgnlibs are best managed by MicroStation Environmental Variables  

MicroStation Environmental Variable are best managed by Workspaces  

Bentley delivers an Imperial and a Metric Workspace with the product.  
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Throughout this Workshop and the LEARNing Conference, SS3 courses will utilize the 
Bentley‐Civil‐Imperial Workspace  
 

1. Use:  
User: examples  
Project: Bentley‐Civil‐Imperial  

 
1. Open C:\2013 Civil_LEARNing\BCR1WK2 ‐Getting Started in SS3 Bentley Civil Power 

Products\DATA\10_2D‐Exploring\SitePlan2D.dgn  
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Dock the Project Explorer, Tasks, and Element Info dialog or pin them or move them around to be 
visible  
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Ensure that your Task Menu is visible (it can be opened by Tools > Task) Move it somewhere. 

 Consider docking it somewhere. Click the various Tasks Groups to see the tools.  
 

NAVIGATING TASKS 
Within the Tasks dialog, the General Geometry and Vertical Geometry tasks are located in the Civil 
Tools Workflow.  (Note your tabs may vary slightly, depending on what Bentley products are 
installed.) 
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Click Activate Workflow to view the main tasks.  To open the toolset, click Expand Group. Click the 
same icon to Collapse the Group. 
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There are several ways the Groups can be displayed.  For this workshop, we’ll use the Panel Layout 
Mode, which is the default.  

 
If you prefer listings rather than icons, you may prefer the List Layout Mode. 

 
Your preference may be to not use the Task dialog. Other options include: 

• Select any tool from Tools > Civil Geometry from the Power product main menu bar. 
• Select <F2> from your keyboard, which opens the main workflows pop-up menu.  This may 

vary depending on what products are installed and any task customization.   Select Civil 
Geometry. Select <F2> from your keyboard and General Geometry from the pop-up menu.  
Then you can use Q, W, E, R, T, or A (corresponding to the letters to the left of the group). 
For example, selection of W opens the Geometry Import/Export pop-up menu. 
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To use the classic toolbox for any sub-group, right-click   on the line and select Open ‘…’ as Toolbox.  

 
You can also customize which tools are displayed. Other customizing options can be found by right-
clicking on the navigation groups. Customization of task navigation is outside the scope of this 
workshop, but you may want to experiment in your spare time or after the workshop is concluded.  

Hint If the Task dialog disappears or you accidentally close it, select Tools > Tasks from the 
Power product main menu bar to bring it back. 

In this section, we will review some of the tools and settings that will be used throughout the 
workshop. For easy accessibility, we will dock the tools within the MicroStation view.  
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Open the Project Explorer and the Element Information panels Position them somewhere.  

Consider docking them somewhere.  

Explore the Project Explorer.  

Review the Civil Standards tab.  

Review the Civil Model. Clicking on an item highlights it in the design and shows its properties in the 

Element Information dialog. 
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Select elements in the design. Review the Element’s Information.  
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Selecting an Element shows its rules and Editability via the Interface (Manipulators, etc.).  
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We won’t use this in class, but the Civil Message Center (General Geometry > Geometry Toggles > Civil 
Message Center) provides a manageable Error and Warning list.  
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This has been preset for us, but in Settings > Design File >> Civil Formatting, there are a variety of 
setting s for Civil‐related input, display and output properties.  
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Select and inspect the Building and the Sidewalk around it.  

MANIPULATORS 
When any element created by a Civil Geometry tool is selected, certain manipulators are displayed 
dynamically. These manipulators vary by element type. 

Manipulators fall into four main types: 

• Text manipulators 
• Normal Drag Handles 
• Snap icons 
• Civil AccuDraw drag handles 

TEXT MANIPULATORS 
These can be clicked to make them editable, which lets you type in new values. Examples include  
distance and direction text manipulators in horizontal geometry, and length and slopes in vertical 
geometry. 

 
Examples of Horizontal (Left) and Vertical (Right) Text Manipulators 
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NORMAL DRAG HANDLES 
These are handles that you can click and drag to redefine the element. 

• An arrow shaped drag handle – redefines the point with one or more directions constrained. 
For example, the parallel arrows (that are parallel to the line) are constrained to change the 
distance only; the arrows that are perpendicular to the line are constrained to change the 
direction only. 

 
• A circular shaped drag handle – moves the points without constraint 

 
• Interval drag handle – This type of drag handle is present any time one of the MicroStation 

Modify commands are used on a civil element. This drag handle is used to change the 
location of the interval end point. 

SNAP ICONS 
If a point was created by a snap, the manipulator is shown as a circle with the appropriate snap icon 
next to it. 

 
Hovering over the circle will change it to a normal manipulator. Click and move the dot to remove the 
snap constraint and replace with new constraints. 
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Additional information can be found in the “footprints” in Element Information how it was built: It’s 
based on the temp line offset Back wall is offset from front wall Side walls are snapped between front 
and back walls Then it was complexed  

Change the width of the building 

Change the width of the building. Change the offset between the building and the sidewalk.  
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Explore how the road is built Take a look at the parking  
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Let’s invoke the Context menu Pick a Centerline  
(Select, hover…)  

Run a quick report  
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CHAPTER SUMMARY 
In this chapter, we have learned how to explore the OpenRoads Technology interface and to explore 
the engineering relationships of engineering designs. 
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Chapter 2: Using Rules 
USING THE BENTLEY CIVIL STANDARDS 

 Exercise:  Open a Design File. 

Exercise Objective:  In this exercise, we will take some LineStrings and make them Civil Smart.  

 

Procedure: 

1. Double click the Power GEOPAK or Power InRoads icon on the Windows Desktop. 
2. Make sure the Workspace User and Project are set to examples and Bentley-Civil-Imperial. 
3. Browse to C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Power 

Products\Data\20_2D-Building-Road and select 
geom__graphics_010_CL_Neighborhood.dgn as shown below. 
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4. Click Open. 

 Exercise:  Turn “dumb graphics” into Civil Graphics. 

Exercise Objective:  In this exercise, we will make three “ordinary” linestrings into Civil Ruled 
Features.  This method is good practice: it is easy, but it is NOT a Best Practice. 
 

 

 

Procedure: 

5. In the General Geometry workflow, select Create Civil Rule Feature. 
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We’ll do it the quickest and “dirtiest” way first (the way with the poorest technique) 
 

6. Follow the Heads Up Display prompt and select the northeastern road centerline (cyan). 
 

 
 

7. In the Name field of the tool settings, keyin GeomCL 
8. Reset (right-click) to process the command. 
9. There is no feedback (using our poor technique). 
10. Use the selection tool and Element Information to analyze our results. 
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11. In the Feature c of the Element Info dialog, type a better name for the NorthEast Centerline 

(“NE_CL”?). 
12. Change the Feature Definition to Geom_Centerline (it is under Linear > Geometry). 

 

Feature Definitions not only provide a data management benefit (object type), but they 
have settings and properties associated with them.  For example, Geom_Centerline not 
only controls the element symbology (level, color, etc.), but also allows the automatic 
stationing and annotation that you should see on the screen. 
 

 
 

13. Play around with some in-place editing. 
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 Exercise:  Continue turning “dumb graphics” into Civil Graphics. 

Exercise Objective:  In this exercise, let’s create another Civil Centerline – this time with better 
technique.  

 

Procedure: 

14. Open the Feature Definition Toggles Bar. 
 

 
 
This “pre-sets” the Feature Definition default when creating new features. 
 

15. Select Geom_Centerline  
 

 
 

Ensure that the Use Active Feature Definition button is set. 
 

16. In the General Geometry task, select Create Civil Rule Feature. 
17. Notice that the Feature Definition to be assign is the Active Feature Definition shown in the 

Features Definitions Toggle Bar: Geom_Centerline. 
18. Type Central Lane in the Name Field of the Tools Settings dialog. 

 

Follow the Heads Up Display prompt and select the central linestring. 
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This time, we get some visual feedback to confirm our success: the linestring changes level, 
color and gets stationed. 
 

19. Add the southwestern road 

 

 Exercise:  Place a Centerline. 

Exercise Objective:  The goal here is to place a centerline perpendicular to the road it tees into.  The 
Central lane “dumb” graphic used perpendicular snaps to place its linear segments.  As we’ll see 
shortly, the perpendicular geometry was computed, but the perpendicular intent was not captured.  
Using the OpenRoads Technology Line Between Points and a perpendicular snap, the intent is 
captured and remembered for future edits.  

 

Procedure: 

20. Click Horizontal Geometry > Geometry Line > Line Between Points. 
21. Place the first point somewhere along the center of the cul-du-sac road. 
22. Using the Perpendicular Snap, snap to the Central Lane Element. 
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23. Move the Alignments the Central Lane tees into.  Notice that there is no relationship 
maintained between the alignments (even though the graphics were placed perpendicular 
to the roads). 

24. Move the Central Lane.  Notice that the Cul-du-Sac road remains perpendicular to it. 
 

This is one of the primary benefits to using OpenRoads Geometry tools:  the design intent is 
captured, where, in MicroStation, it is lost. 
 

25. Play around with the geometry.  Get familiar with how things interact or do not.  Make 
mistakes. 
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Chapter 3: Creating Horizontal 
Elements 
CREATING HORIZONTAL ELEMENTS 

 Exercise:  Set the Feature Definition. 

Exercise Objective:  Set the Feature Definition.  

 

Procedure: 

1. Browse to C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 
Bentley Civil Power Products\Data\20_2D-Building-Road and select 
geom_Creating_10_Horizontal_Elements_BEGIN.dgn as shown below.Click 
Open. 

2. Click the Feature Definition Toggle Bar icon from the Tasks > Horizontal Geometry menus. 
  

3. In the Feature Definition Toggle Bar, click the Match Feature Definition icon. 
 

4. Select a red alignment in the CAD View. 
 

This will set the Feature Definition to Geom_Centerline. 
 

5. In the Feature Definition Toggle Bar, click the Use Active Feature Definition icon 

 

 Exercise:  Place Geometry Lines.  

Exercise Objective:  Use the Line Between Points Command.  

 

Procedure: 
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6. Click the Line Between Points icon from the Tasks > Horizontal Geometry menus. 
  

7. Snap to starting point of the alignment which is marked with a red circle and the number 6. 
8. Click to accept the Starting Point. 
9. Snap to ending point of the alignment which is marked 

with a red circle and the number 7. 
10. Click to accept the Ending Point. 
11. Snap to starting point of the alignment which is marked 

with a red circle and the number 8. 
12. Click to accept the Starting Point. 
13. Snap to ending point of the alignment which is marked 

with a red circle and the number 9. 
14. Click to accept the Ending Point. 

 

Two lines have been created. 
 

 

 
 

 
 
 
 
 
 
 
 
 
 
 

 Exercise:  Place Geometry Arcs. 

Exercise Objective:  Use the Simple Arc and Simple Arc From Element Commands.  

 

Procedure:  

15. Click the Simple Arc icon from the Tasks > Horizontal Geometry menus.  
 

16. Select the Line between the red circles labeled 6 and 7 as the First Element. 
17. Select the Line between the red circles labeled 8 and 9 as the Second Element. 
18. Snap to red circle labeled 10 as the Through Point and click to accept. 
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19. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to 
Both. 

20. Click to accept the Trim/Extend Option. 
 

An arc has been created between the two lines. 
 

21. Click the Simple Arc From Element icon from the Tasks > Horizontal Geometry menus. 
 

22. Select the line between the red circles labeled 8 and 9. 
23. Snap to red circle labeled 9 as the Start Point and click to accept.  
24. Key-in 297.28 as the Radius and press the Enter key on your keyboard. 
25. Snap to red circle labeled 11 as the End Point and click to accept. 
26. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to 

Back. 
27. Click to accept the Trim/Extend Option. 

 

An arc has been added to the end of the line.  
 
 

 
This time, we get some visual feedback to confirm our success: the linestring changes level, 
color and gets stationed. 
 

28. Add the southwestern road 

 

 Exercise:  Place Geometry Lines. 

Exercise Objective:  Use the Line Between Points Command.  

 

Procedure: 

29. Click the Line Between Points icon from the Tasks > Horizontal Geometry menus.  
 

30. Snap to starting point of the alignment which is marked with a red circle and the number 6. 
31. Click to accept the Starting Point. 
32. Snap to ending point of the alignment which is marked with a red circle and the number 7. 
33. Click to accept the Ending Point. 
34. Snap to starting point of the alignment which is marked with a red circle and the number 8. 
35. Click to accept the Starting Point. 
36. Snap to ending point of the alignment which is marked with a red circle and the number 9. 
37. Click to accept the Ending Point. 
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Two lines have been created. 

 

 Exercise:  Place Geometry Arcs. 

Exercise Objective:  Use the Simple Arc and Simple Arc From Element Commands.  

 

Procedure: 

38. Click the Simple Arc icon from the Tasks > Horizontal Geometry menus.  
 

39. Select the Line between the red circles labeled 6 and 7 as the First Element.  
40. Select the Line between the red circles labeled 8 and 9 as the Second Element. 
41. Snap to red circle labeled 10 as the Through Point and click to accept. 
42. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to 

Both. 
43. Click to accept the Trim/Extend Option.  

 

An arc has been created between the two lines. 
 

44. Click the Simple Arc From Element icon from the Tasks > Horizontal Geometry menus.   
45. Select the line between the red circles labeled 8 and 9. 
46. Snap to red circle labeled 9 as the Start Point and click to accept. 
47. Key-in 297.28 as the Radius and press the Enter key on your keyboard. 
48. Snap to red circle labeled 11 as the End Point and click to accept. 
49. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to 

Back. 
50. Click to accept the Trim/Extend Option. 

 

An arc has been added to the end of the line.  

 

 Exercise:  Place a Line From an Arc.  

Exercise Objective:  Use the Simple Line From Element Command.  

 

Procedure: 

51. Click the Simple Line From Element icon from the Tasks > Horizontal Geometry menus.  
52. Select the arc between the red circles labeled 9 and 11. 
53. Snap to red circle labeled 11 as the Start Point and click to accept. 
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54. Snap to red circle labeled 12 as the End Distance and click to accept. 
55. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to 

Back. 
56. Click to accept the Trim/Extend Option. 

 

A line has been added to the end of the arc 

 

 Exercise:  Create Complex Elements  

Exercise Objective:  Use the Complex By Elements Command.  

 

Procedure: 

57. Select the Complex By Elements icon from the Tasks > Horizontal Geometry menus.  
58. In the Settings dialog, change the Method to Automatic. 
59. Key-in Western Way for the Name. 
60. Click in the CAD View to accept the key-in. 
61. Select the north-south line near the red circle labeled 6. 
62. An arrow will appear pointing in the direction of the ahead stationing (north). 
63. Click in the CAD View 

 
 

   
FOR Bentley LEARNing Conference Session:  STOP here! 
You may continue if you’re done early.  The following additional tool practice will not 
be performed in class due to time constraints. 
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 Exercise:  Place Geometry Curves 

Exercise Objective:  Use the Arc Between Points Command  

 

Procedure: 

1. Select the Line Between Arcs icon from the Tasks > Horizontal Geometry menus.  

2. Select the arc between the red circles labeled 13 and 15 as the First Element. 
3. Key-in 0.0 as the Start Offset and press the Enter key on your keyboard. 
4. Click the CAD View to accept the Start Offset. 
5. Select the arc between the red circles labeled 16 and 17 as the Second Element. 
6. Key-in 0.0 as the End Offset and press the Enter key on your keyboard. 
7. Click the CAD View to accept the End Offset. 
8. Move your cursor to select the Solution that shows the line going between the arcs. 
9. Click the CAD View to accept the Solution. 
10. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to 

Both. 
11. Click to accept the Trim/Extend Option. 

 

 Exercise:  Place a Line to an Arc 

Exercise Objective:  Use the Simple Line to Element Command 

 

Procedure: 

12. Select the Simple Line to Element icon from the Tasks > Horizontal Geometry menus. 
13. Snap to red circle labeled 18 as the End Point and click to accept. 
14. Select the arc between the red circles labeled 16 and 17 as the Element. 
15. Move your cursor to select the Solution that shows the line going to the arc. 
16. Click the CAD View to accept the appropriate Solution. 
17. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to 

Back. 
18. Click to accept the Trim/Extend Option. 

 

A line has been added to the end of the arc 
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 Exercise:  Place Another Line to an Arc 

Exercise Objective:  Use the Simple Line to Element Command 

 

Procedure: 

19. The Simple Line to Element should still active. 
20. Snap to red circle labeled 6 as the End Point and click to accept. 
21. Select the arc between the red circles labeled 13 and 15 as the Second Element. 
22. Move your cursor to select the Solution that shows the line going to the arc. 
23. Click the CAD View to accept the Solution. 
24. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to 

Back. 
25. Click to accept the Trim/Extend Option. 

 

A line has been added to the beginning of the arc. 

 

 Exercise:  Extend a Line 

Exercise Objective:  Use the Extend Line Command 

 

Procedure: 

26. Click the Extend Line icon from the Tasks > Main menus. 
27. In the Settings dialog, enable the Distance option. 
28. In the Settings dialog, key-in 210 for the Distance. 
29. Select the line between the red circles labeled 6 and 13. 

 

A line has been extended. 

 

 Exercise:  Create Complex Elements 

Exercise Objective:  Use the Complex By Elements Command 

 

Procedure: 

30. Select the Complex By Elements icon from the Tasks > Horizontal Geometry menus.  
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31. In the Settings dialog, change the Method to Automatic. 
32. Key-in Southern Street for the Name. 
33. Click in the CAD View to accept the key-in. 
34. Select the west portion of the line just extended before the red circle labeled 6. 
35. An arrow will appear pointing in the direction of the ahead stationing (east). 
36. A Fork may be found at the intersection of Fairway Road and Southern Street. 
37. Move your cursor to continue in the direction of the Southern Street and click to accept. 
38. Click in the CAD View to accept the results. 

 

 Exercise:  Starting Station 

Exercise Objective:  Setting the Start Station 

 

Procedure: 

39. Select the Start Station icon from the Tasks > Horizontal Geometry menus.  
40. Select the Southern Street alignment. 
41. In the Heads-up display, key-in 0.00 for the Start Station Position and press Enter on your 

keyboard. 
42. Click in the CAD View to accept the key-in. 
43. In the Heads-up display, key-in 117+22.65 for the Starting Station and press Enter on your 

keyboard. 
44. Exit MicroStation. 
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Chapter 4: Pavement Edges & Curb 
Returns 
CREATING HORIZONTAL ALIGNMENT ELEMENTS 

 Exercise:  Set the Feature Definition. 

Exercise Objective:  Set the Feature Definition.  

 

Procedure: 

1. Change design files: 

2. Browse to C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Power 
Products\DATA\20_2D-Building-Road and select 
geom_Creating_20_EOPsAndCurbReturns_BEGIN.dgn. 

3. Click Open. 
4. Click the Element Selection icon from the Tasks > Main menus.  
5. Select each of the horizontal alignments. 
6. Review the graphics of the Manipulators. 
7. The blue Manipulators values can be modified and the white Manipulators values are 

informational 

 Exercise:  Set the Feature Definition.  

Exercise Objective:  Set the Feature Definition.  

 

Procedure: 

8. Click the Feature Definition Toggle Bar icon from the Tasks > Horizontal Geometry menus. 
9.    
10.  Navigate to the Linear > Roadway folder and select the Feature Definition named 

Road_EdgeOfPavement. 
11. In the Feature Definition Toggle Bar, click the Use Active Feature Definition icon. 
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This will hold the Feature Definition when we use different commands.  

 

 Exercise:  Create Edge of Pavement Geometries.  

Exercise Objective:  Use the Simple Line From Element Command.  

 

Procedure: 

12. Click the Single Offset Entire Element icon from the Tasks > Horizontal Geometry menus.  
13. Select the horizontal geometry that runs from the circles labeled 6 and 12. 
14. If the entire alignment doesn’t highlight, press the Alt key on your keyboard. 
15. Click to accept the selection. 
16. Key-in 12.0 as the Offset and press the Enter key on your keyboard. 
17. Click to accept the selection. 
18. Use the Up and Down Arrow keys on your keyboard to change the Mirror to Yes. 
19. Click to accept the Mirror option. 
20. Two horizontal geometries have been created. 
21. Select the horizontal geometry that runs from the circles labeled 6 and 18. 
22. Click to accept the selection. 
23. The Offset should still be set to 12.0. 
24. Click to accept the selection. 
25. The Mirror option should still be set to Yes. 
26. Click to accept the Mirror option. 
27. Two more horizontal geometries have been created. 
28. Use the Element Selection tool to review the Manipulators.  

 

 Exercise:  Create Edge of Pavement Radii at the Intersection.  

Exercise Objective:  Use the Simple Arc Command.  

 

Procedure: 

29. Click the Simple Arc icon from the Tasks > Horizontal Geometry menus.  
 

30. Select the blue Line between the red circles labeled 13 and 14 on the north side as the First 
Element. 
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31. Select the blue Line between the red circles labeled 6 and 7 on the east side as the Second 
Element. 

32. Key-in 50.0 as the Radius and press the Enter key on your keyboard. 
33. Move your cursor to the Northeast quadrant of the intersection and click to accept. 
34. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to 

Both. 
35. Click to accept the Trim/Extend Option. 

 

 
 

36. Select the blue Line again between the red circles labeled 13 and 14 on the north side as 
the First Element. 

37. Select the blue Line between the red circles labeled 6 and 7 on the west side as the Second 
Element. 

38. The Radius should still be set to 50.0. 
39. Move your cursor to the northwest quadrant of the intersection and click to accept. 
40. The Trim/Extend Option should still be set to Both. 
41. Click to accept the Trim/Extend Option. 

 
Two arcs have been added 
 



 

 

4 BCR1WK2 - OpenRoads Technology Workshop: Creating EOPs and Curb Returns 
 Copyright © 2013 Bentley Systems, Inc. 

 

 

 Exercise:  Create Edge of Pavement Radii at the Intersection.  

Exercise Objective:  Use the Simple Arc Command.  

 

Procedure: 

42. Click the Element Selection icon from the Tasks > Main menus.  
 

43. Select the last radius placed in the northwest quadrant of the intersection. 
44. Click the radius value labeled 50.00. 
45. Key-in 60.00 and press the Enter key on your keyboard. 

 

The radius is now changed to 60.00 and the original Trim/Extend Option was honored.  
 

46. Select the blue line again between the red circles labeled 13 and 14 on the north side. 
47. Click the offset value labeled -12.00 on the left end of the line. 
48. Key-in -30.00 and press the Enter key on your keyboard. 

 
The offset is now changed to -30.00 and the original radius at the intersection were 
maintained.  Since the Civil Rule was based on an Offset command, changing the offset at 
the beginning, middle, or end of the line, changes the offset of the entire line. <<< It seems 
as if changing the middle keeps a constant offset.  Changing an End seems to make it a 
variable offset.>>> 

 
49. Select the blue line between the red circles labeled 8 and 10 on the west side. 
50. Click the offset value labeled -12.00 on the middle end of the line. 
51. Key-in -20.00 and press the Enter key on your keyboard. 
52. Select the blue Line between the red circles labeled 8 and 10 on the east side. 
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53. Key-in 20.00 and press the Enter key on your keyboard. 
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Chapter 5: Building Pad Layout 
OVERVIEW 

Browse In this lesson we will create a design for a building pad on our commercial site project. 

CREATING A BUILDING PAD LAYOUT - HORIZONTAL 

 Exercise:  Design a Building Pad. 

Exercise Objective:  This exercise will guide you to create a building pad.  

 

Procedure: 

1. Change Design files. 

2. Browse to C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Power 
Products\DATA\30_2D-Building-Site and select Open SitePlan2D_Building_Layout-
Horizontal.dgn. 

3. Click Open.  
4. To the south of the parking lot is construction line.  We will use it as a reference for 

constructing a building pad.  Zoom in to the area. 
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5. Click the Horizontal Geometry > Geometry Complex > Single Offset Entire Element tool.  

 

 
 

6. Pick the construction line. 
 

 
 

7. Offset the line 5 feet.  Do NOT Mirror. 
 



Chapter 5: Building Pad Layout 

 

 - Building Pads Horizontal 3 
Copyright © 2013 Bentley Systems, Inc. 

 
 

8. Offset another line 80 from the new line. 
9. Click the Horizontal Geometry > Geometry Complex > Single Offset Entire Element tool. 

 

 
 

10. Place two lines between the offset lines to make a rectangle. 
 

 
 

11. Because the Feature Definition of the resulting Pad is important, select Site_Pad as the 
Feature Definition.  It is found under Linear > Site.  Ensure that the Use Active Feature 
Definition toggle is set. 
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12. Click the Horizontal Geometry > Geometry Complex > Complex by Elements tool. 
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13. Select the Automatic Method and select the first of the offset lines (the northwestern 
side). 
 

 
 

Note there is a “direction arrow”, which changes sides, depending which side of line 
midpoint you select.  Callouts in the book assume that the direction of the pad is clockwise.  
If you select the other directions, some offsets may be opposite than the book 
 

14. Accept the rectangular complex solution. 
 

 
 

15. Select the new pad to see the rules. 
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16. Change some of the values.  Drag an end to the reference line around.  See the rules in 
action. 

 
 

 
 

 
You may continue if you’re done early.  The following additional tool practice will not 
be performed in class due to time constraints. 
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 Exercise:  Extra Work (Time Permitting). 

Procedure: 

17. If you finish early, add a building footprint 10 feet inside the pad boundary. 
 

 
 

18. If you’re feeling bold, create a Civil Cell of the new building Pad. 
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19. If you’re successful creating the Civil Cell, you can Place a Cell by right-clicking it in the 
Project Explorer Civil Model and selecting Place Civil Cell.  You will need to identify a line in 
the design file.  
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Chapter 6: Create and Analyze Terrain 
CREATE AND ANALYZE TERRAIN 

 Exercise:  Create Terrain Model from 3D Graphical Elements. 

Exercise Objective:  In this lesson, we will prepare a terrain model of the existing ground from 
graphical contours provided to us.    

 

Procedure: 

1. Browse to C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley 
Civil Power Products\DATA\30_2D-Building-Site and select Contours.dgn. 

2. Click Open. 
 

 
 

3. Using Power Selector, select all the contour graphical elements. 
4. Start the Terrain Model By Elements command. 
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5. Populate the feature definition in the command dialog as shown below. You can also 
populate the feature type and edge method as shown if you wish but these will be 
prompted. 
 

 
 

6. Datapoint to accept the selected elements. 
 

 
 

7. Set feature type to Contour.  Use up/down arrows on keyboard. Then DP to accept. 
 

 
 

8. Set edge method to slivers. DP to accept. Note that max triangle length is also a valid 
option. 
 

 
 

9. So we can tell the difference in the graphics we were given and our new terrain, turn off 
levels named Exist_Contour_Major and Exist_Contour_Minor. 
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 Exercise:  Using Element Information to Change the Terrain Model Display.  

Exercise Objective:  In this lesson, we will learn how to change the display of the Terrain Model for 
various needs.  We will explore a long-hand method as well as a method that can be automated as 
part of your organizations standards.  

 

Procedure: 

10. Select the terrain model that we created above. 
11. Open Element Information (Element > Element Information) 

 

 
 

12. Notice the Display Toggles.  These are divided into Calculated Features (those things which 
are used to represent the Terrain Model) and Source Features (those things which were 
used to create the terrain model).  Try double click on the label to toggle various of these 
on and off.  
 

NOTE: we’ll review symbology for these various features below. 
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13. Review other settings.   
i. The edge method allows you to control the boundary determination.  Methods are 

None, Sliver and Max Triangle Length. In this case, DEM files are rectangular so all 
edge methods would provide identical results. 

ii. The Feature panel allows editing of the terrain model name and feature definition. 

iii. The Information panel provides read-only data for the nature of the Terrain Model. 

 

 
 

14. So what about the symbology for these various feature types (triangles, contours and 
such)? In the tree pane, expand the tree until you see Triangles as shown below. 
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15. By drilling into the tree, we can define the desired symbology for each feature type.   
16. Make sure triangles display is ON and then change its color. 
17. Notice the property titled  “Thematic Display Style”.  Change this to “Thematic: Height”. 
18. Deselect the Terrain Model to see the effect.   

 

NOTE: Thematic display is a new concept in Microstation V8i (Select Series 3).  It is available 
for a view attribute or as a property for an individual element. 

 

 Exercise:  Using Element Templates to Control Display.  

 

Procedure: 

19. Select the terrain model that we created above and open Element Information.  
20. Notice the property for “Template” in the General panel. 
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21. The use of templates allows us to automate the change of display settings while also 
providing ability to save and reuse your organization standards.   

22. Experiment with different templates.  When finished set the template back to Terrain\ 
Existing Ground. 

23. Now, deselect the Terrain Model and hover your cursor over the contours.  The tooltip will 
report the elevations. 
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 Exercise:  Analyze Point. 

 

Procedure:  

24. In Task Navigation choose the Analyze Point Command 
 

 
 

25. Select the Terrain Model 
26. Now you get X,Y,Z information feedback at the heads up prompt. 

 

 
 
Now look at the dialog and notice you can toggle on settings to show the contour, triangle 
or flow arrow. Try different combinations of this as you analyze.  
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27. With one or more of these options toggled on, DP will draw the contour, slope label and/or 
triangle as graphic elements. 

 

 Exercise:  Trace Slope 

Exercise Objective:  This exercise will guide you through the steps to get started.  

 

Procedure: 

28. In Task Navigation choose the Analyze Trace Slope command 
 

 
 

29. Select the Terrain Model. 
 

 
 

30. The downstream flow path is traced from the cursor. 
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31. Take a couple minutes to experiment with the other options on the dialog. 
 

 
• Slope – when locked forces the path to follow an exact slope instead of most direct 

slope. 
• Length – when locked limits the length of the trace. 
• Direction – trace can be upstream or downstream. 

 
32. DP in the view while this command is running will draw the trace as a graphic element. 
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Chapter 7: Exploring the 3D 
Environment 
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In the C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Power 
Products\DATA\50_3D-Exploring\Sections folder, open _NB_Corridor_Sections_BEGIN.dgn 
 
Open the Models dialog (File > Models) Open the References dialog (File > Reference)  
Click from one View to another.  
 
Note how the active Model changes.  
Notice how the Reference File Attachments change. 
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In order to grip the Corridor, it must be displayed. In the NB_Geometry+refs.dgn, the 3D model has all 
references ON. In the 2D model the 3D stuff is turned OFF. Need to make sure the corridor reference is 
ON  
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In the Project Explorer Civil Model, explore a Corridor Notice that all the properties you’re used to 
seeing in the old Roadway Designer are listed as Corridor properties. Lo  
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This is discussed more thoroughly in the Building Vertical sections of the workshop. 
 
The shortcut is to right-click on ruled horizontal element and click Open Profile Model. 
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Chapter 8: Creating Vertical Geometry 
CREATING VERTICAL GEOMETRY 

 Exercise:  Getting Started. 

Exercise Objective:  Starting Power InRoads V8i (SELECTseries 3) or Power GEOPAK V8i (SELECTseries 
3).  

 

Procedure: 

1. Browse Launch MicroStation and set the following in the File Open dialog. 

User: examples 
Project: Bentley-Civil-Imperial 
Interface: Bentley-Civil 
 

2. Open geom_Creating_30_Vertical_Profiles.dgn from the folder C:\2013 
Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Products\DATA\60_3D-
Building-Road. 

 

 Exercise:  Set the Active Terrain Model.  

Exercise Objective:  When working in Vertical or other 3D, it is good technique to ensure that a 
Terrain Model is Active.  

 

Procedure: 

3. Click on the Terrain Model boundary, hover, and wait for the Context Menu. 
Select Set As Active Terrain Model. 
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 Exercise:  Open a Profile Model. 

Exercise Objective:  To prepare to create Vertical Geometry we need to open the Profile Model of 
the road we are working on.  

 

Procedure:  

4. Click the Element Selection icon from the Tasks > Vertical Geometry > Vertical Geometry 
Main > Open Profile Model menu.  
 

 
 

5. At the Locate Plan Element  prompt, select the centerline of Southern Street.  
 

 
 

6. At the Select or Open View  prompt, click on View 2 (or place a datapoint in View 2 if it 
open). 
 

 
 
A Profile View opens of Southern Street: 
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 Exercise:  Place Vertical Elements. 

Exercise Objective:  Place Individual Vertical Elements.  

 

Procedure:  

7. Click the Profile Curve Between Points icon  from the Tasks > Vertical Geometry 
menu. 

8. Clear all the check boxes, we will place two parabolas by snapping to three points each – 
no pre-defined parameters.  We will want to use the Start\End\Pass-through Placement 
Method. 
 

 
 

9. Place two Profile Curves by snapping to the existing terrain at the points indicated. 
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Your results should look like this (more or less). 
 

 
 

10. Click the Parabola Between Elements icon  from the Tasks > Vertical Geometry 
menu. 

11. We will want to Trim/Extend Both elements 
 

 
 
Use any length you want (although 740 works well), trim both 
 

12. Click the Parabola Between Elements icon  from the Tasks > Vertical Geometry 
menu. 
 
We will want to Trim/Extend Both elements. 
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13. Click the Tangent Profile Line to Element icon from the Tasks > Vertical Geometry 
menu. 
 
We will want to Trim/Extend Back (the prompt really should be Yes/No). 
 

14. At the End Point prompt, click on the left end of the existing terrain. 
 

 
 

15. At the Locate Reference Profile prompt, we need to identify which of the profiles to 
connect to (the existing does count as a profile).  Select the new curve. 
 

 
 

 
 
After clicking through the prompts, we have a “solution,” but it is made up of individual 
elements. 

 
 
We will want to group them into a single unit. 

 

 Exercise:  Make a “Full-Length” Vertical Solution. 

Exercise Objective:  Use Profile Complex By Elements to make a single object that spans the full 
length of the profile. 
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Procedure:  

16. Click the Profile Complex By Elements icon  from the Tasks > Vertical Geometry menu. 
 

 
 

17. Try the Automatic Method.  If it does not select the new four elements correctly, you can 
Undo and either increase the gap or use the Manual Method. 
 

 
 
Note: at the Locate First Element prompt, make sure that you select the proposed element 
and not the existing: 
 

 
 

18. Finally, make this the Active Profile, either by using the Context Menu. 
 

 
 

Or by right-clicking in the Civil Model or Element Info and clicking Set As Active Profile 
 



Chapter 8: Creating Vertical Geometry 

 

BCR1WK2 - Creating Vertical Geometry 7 
Copyright © 2013 Bentley Systems, Inc. 

 
 

 

 





 
 

 

BCR1WK2 - OpenRoads Technology Workshop: 1 
Copyright © 2013 Bentley Systems, Inc. 

 
Bentley Civil Workshop 

 

 

2013 Bentley LEARNing Conference 
 

 

 

 

BCR1WK2 

OpenRoads Technology Workshop:  

Creating a Corridor 
 

 

 

Team Leader:   Jeff Martin, PE 

 

 

 

 

 

Bentley Systems, Incorporated 
685 Stockton Drive 
Exton, PA 19341 
www.bentley.com 

 

  

http://www.bentley.com/�


Chapter 8: Creating Vertical Geometry 

 

2 BCR1WK2 - Creating a Corridor       

 

 

 

 



 
 

 

BCR1WK2 - Creating a Corridor 1 
Copyright © 2013 Bentley Systems, Inc. 

 

Chapter 9: Creating a Corridor 
CREATING VERTICAL GEOMETRY 

 Exercise:  Getting Started. 

Exercise Objective:  Starting Power InRoads V8i (SELECTseries 3) or Power GEOPAK V8i (SELECTseries 
3).  

 

Procedure: 

19. Browse Launch MicroStation and set the following in the File Open dialog. 
User: examples 
Project: Bentley-Civil-Imperial 
Interface: Bentley-Civil 
 

20. Open geom_Creating_40_Corridors.dgn from the folder C:\2013 Civil_LEARNing\BCR1WK2 
- Getting Started in SS3 Bentley Civil Products\DATA\60_3D-Building-Road. 

 

 Exercise:  Set the Active Terrain Model.  

Exercise Objective:  When working in Vertical or other 3D, it is good technique to ensure that a 
Terrain Model is Active.  

 

Procedure: 

21. In view 1, select the main road alignment again.  Hover over it and in the context toolbox 
select Create Corridor. 
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22. The second prompt is to choose profile.  We have the option here of picking one from the 
profile model (view 2) or if we just click Reset Button then it will use whichever is active.  
Click Reset. 
 

 
 

23. The corridor which we create needs a name.  By default it uses the same name as the 
alignment.  Just DP to accept this name or type a new one, then DP. 
 

 
 

24. Next we need to choose which template to use. This prompt may be blank for you or It may 
list the wrong template. 
 

 
 

25. Click ALT>Down on keyboard to open the template library and choose 2 Lane Urban Curb 
and Gutter with Sidewalk as shown below. 
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26. For start station, you can dynamically move cursor to the beginning (south end) or click ALT 
on keyboard to lock to the beginning. 
 

 
 

27. For end station, you can dynamically move cursor to the end (north end) or click ALT on 
keyboard to lock to the end. 
 

 
 

28. For drop interval use 25. 
29. For minimum transition drop length enter zero for both prompts.  This is used to transition 

between different templates which does not apply to this design. 
30. Inspect view 1 to see the changes: 

i. A corridor was created – indicated by the green outline.  This is what we will select 
in case any future edits are required. 

ii. The following features were created: 

1. Edge of Pavement left and right 

2. Curb lines left and right. 

3. Sidewalk left and right. 
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31. Open view 3 to inspect the 3D model. 
 

 
 

32. You may notice that the 3d model is a little jaggy.  The resolution is probably fine for this 
stage of development, but we can increase the resolution. 

33. In view 1, select the corridor and open the properties. 
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34. In the Design Stage Property, change it to Final, which will improve the resolution of the 3d 
model. 
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Chapter 10: Building Pads Vertical 
CREATING A BUILDING PAD 

 Exercise:  Designate  Existing Ground. 

Exercise Objective:  In this lesson we will create a design for a building pad on our commercial site 
project.  

 

Procedure: 

1. Open SitePlan3D_BEGIN_CivilCells.dgn in the C:\2013 
Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Power 
Products\DATA\70_3D-Building-Site folder.  Most of the horizontal geometry has 
been laid out for you. We’ll inspect some of it as we go along while designing the site. 

 

 
 

2. Notice too, that the existing ground terrain model we created above exists in a reference 
file and has been displayed with only the boundary shown. 

3. Select the terrain model. 
 



 

 

2 BCR1WK2 - Building Pads Vertical 
 Copyright © 2013 Bentley Systems, Inc. 

 
 

4. After you select it, hover the cursor over the terrain model and a toolbox will appear, as 
shown above. 

5. The second command is Set As Active Terrain Model.  Active Terrain Model is, for most 
projects, existing ground.  
 
Note:  The Active Terrain Model is used for a few different things. It is automatically shown 
in all profile views and is used by default as the target for commands which seek a surface.. 

 

 Exercise:  Design a Building Pad  

Exercise Objective:  This exercise will guide you to create a building pad.  

 

Procedure: 

6. Zoom in on the building.  Our goal is to set the building pad elevation at 2.0 feet above 
maximum existing elevation found under the pad. 
 

 
 

7. In Task Navigation, start the command, Profile From Surface 
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8. Pick the building pad element 
 

 
 

9. Reset to continue 
 

 
 

10. Then pick the existing ground surface, which will be used to determine elevation. 
 

 
 

11. Click the ALT key on keyboard to lock start station to beginning 
 

 
 

12. And ALT key to lock end station to end.  This computes elevation for the entire perimeter of 
the pad. 
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13. Set point selection to all. Use Up/Down arrow on keyboard to change this value if needed. 
This means that the pad is evaluated all around the perimeter. 
 

 
 

14. Set Profile Adjustment to Maximum, which means that after evaluating around the 
perimeter, it will use the maximum found value for the pad. 
 

 
 

15. Set Draping option to triangles to evaluate at every triangle leg. 
 

 
 

16. Set Horizontal Offset to zero. 
 

 
 

17. Set vertical Offset to 2.0, which will add 2 feet to the above noted maximum. 
 

 
  



Chapter 10: Building Pads Vertical 

 

BCR1WK2 - Building Pads Vertical 5 
Copyright © 2013 Bentley Systems, Inc. 

 
18. Let’s inspect the computed profile.  Select the building pad element, and on the context 

toolbox, click Open Profile. 
 

 
 

19. If view 2 is not already open, open it and click in the view, which opens the profile for the 
building pad. 
 

 
 

20. This will open the profile.  You should have a flat profile at about elevation 5266. 
 

 
 

21. Now, open view 3 and in view attributes, set the model to Default 3D 
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22. Rotate the view into isometric and see our building pad model.  There are no side slopes 
yet and the pad is incomplete. 
 

 
 

23. We’ll return to view 3 from time to time to inspect the progress of our model. 
24. Back in View 1, we need to compute a slope from the pad element out to the green 

rectangle which serves for sidewalks and etc. 
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25. Start the command, Profile By Slope From Element 
 

 
 

26. Pick the green sidewalk edge.  This is the element we want to define vertically. 
 

 
 

27. Reset to continue 
 

 
 

28. Pick the building as reference element.  This is the element used to compute slope from. 
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29. Set slope to -2.0% 
 

 
 

30. Point Selection is All. 
 

 
 

31. Adjustment is None 
 

 
 

32. Vertical offset is zero. 
 

 
 

33. Review View 3 to see your progress. 
 

. 
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 Exercise:  Make a Terrain of the Building Elements.  

 

Procedure: 

34. In view 3, Select the two 3D elements and create a terrain model like we did in Chapter 1, 
except the elements will be break lines instead of contours. 

35. Start the Terrain Model By Elements command. 
 

 
 

36. Populate the feature definition in the command dialog as shown below. You can also 
populate the feature type and edge method as shown if you wish but these will be 
prompted. 
 

 
 

37. Datapoint to accept the selected elements 
 

 
 

38. Set feature type to Break line.  Use up/down arrows on keyboard. The DP to accept. 
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39. Set edge method to slivers. DP to accept. Note that max triangle length is also a valid 

option. 
 

 

 

 Exercise:  Add tie slopes  

 

Procedure 

40. Start the Linear Template command. 
 

 
 

41. In view 1, Select the green sidewalk edge as the element to apply the template. You can 
also attach the linear template to the terrain model we created of building. 
 

 
 

42. The template we need is probably not listed.  
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43. On keyboard, click ALT > Down Arrow, which will bring up the template library.  Choose  
template named Straight 2:1 Slopes as shown. 
 

 
 

44. For start station use the locked beginning station.  Use ALT to lock it if it is not locked. 
 

 
 

45. For end station lock to end. 
 

 
 

46. Use the cursor to set side on the outside of the element. 
 

 
 

47. Set corner sweep angle to 5.  This determines how to compute the tie slopes on sharp 
corners. If value of zero is used then side slope will be sharp.  Non-zero makes rounded 
corners. 
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48. Now, inspect view 3 again and see our side slopes. 
 

. 

 

 Exercise:  Add Sub-layers  

 

Procedure: 

49. We lack one thing now for our building pad.  We need some sort of layers of paving 
material.  This might be just gravel, or perhaps multiple layers of bitumen or concrete. Start 
the Area Template command. 
 

 
 

50. Select the terrain model we made of pad earlier. 
 

 
 

51. At the prompt for template, use ALT > Down Arrow… 
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52. …to open template library and choose as shown below. 
 

 
 

53. Then data point to accept. 
 

 
 

54. With Smooth Shading t[RG1]urned on in view 3, we can now see our finished building pad. 
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Chapter 11: Place Cells – Building 
Pads 
CREATE A BUILDING PAD USING CIVIL CELL 

 Exercise:  Designate  Existing Ground 

Exercise Objective:  In this lesson we will use an alternate method utilizing civil cells to design the 
building pad.  A civil cell is pre-constructed set of geometry and model elements that can be reused 
across many projects.  The complexity is as simple or complex as you choose to make it.  The layout 
can be 2D geometry only or include profile and 3D designs as well.  

 

Procedure: 

1. Open SitePlan3D_BEGIN_CivilCells.dgn in the C:\2013 
Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Power 
Products\DATA\70_3D-Building-Site folder.  Most of the horizontal geometry has 
been laid out for you. We’ll inspect some of it as we go along while designing the site. 

2. You will note that instead of a full building pad drawn in, we have only a line to indicate location and 
direction of the building. 

 

 
 

3. Select the terrain model. 



 

 

2 BCR1WK2 - Place Cells – Building Pads 
 Copyright © 2013 Bentley Systems, Inc. 

 

 
 

4. After you select it, hover the cursor over the terrain model and a toolbox will appear, as 
shown above. 

5. The second command is Set As Active Terrain Model.   
6. Open Project Explorer to Civil Standards (File > Project Explorer) 

 
Note: If you do not see the Civil Standards tab as shown above, go to Settings > Project 
Explorer to turn it on. 
 

7. There are a number of function-specific Civil Cell Libraries, right click on the Civil Cell 
named Fancy3DPad in the Buildings.dgnlib and choose Place Civil Cell. 
 

 
 
Alternatively, you can Place Civil Cells via the Civil Cells > Place Civil Cell task: 
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Note: the tool assumes that you are placing the previously-place Civil Cell.  To select a 
different one, right-click once to enable the Browse button and then select it. 
 

 
 
This opens the Pick Civil Cells dialog.   
 

 
 
Select Fancy3DPad from the Buildings.dgnlib. 
 

8. The first prompt is to select the reference element.  In this case, the reference element is 
the orange line which defines the front face of the building. For any given civil cell, the 
number and type of reference elements will depend on how the civil cell is constructed. 
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9. The next step is to choose elements to reverse.  This is because the final reference 
elements may be drawn different direction than the cell elements.  In order to properly 
construct the cell then these elements will need to operate in a reverse fashion.  Note: the 
elements are not reversed.  The rules from the cell are reversed. 
 

 
 

10. Once the element rules are properly configured then DP to accept the cell placement. 
 
 

 
 

11. The building is designed in one step, 2D and 3D. 
 

 
 

12. You’ll notice that the dimensions are a little different than above.  This is because, we 
created the cell to be fairly simple.  But, we can adjust the dimensions.  Select the green 
sidewalk element. 
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13. Notice the width of building is set to 63.  Click on the text manipulator and type -100 in 
place of 63. 
 

 
 

14. Now the proportions look more like our original design. 
15. Lessons learned for discussion: 

i. The civil cell can automate complex geometry and modeling workflows. 

ii. In the cell we used above, we designed it to be simple.  There was only required a 
single reference element pick.  This control element defines the length and direction 
of the building. 

iii. We could have made the cell with a second control line to control width as well.  

iv. But, since it is easy to edit after the fact, our cell was kept simple. 

v. Editing the cell after placement does not negate the fact that it is a cell.  

vi. The exact nature and usage of a particular civil cell is dependent on how it is 
designed.  System Administrators will need to document expected usage and 
required reference elements. 
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16. We can further edit the final building by editing manipulators, as we did above, or by 
editing the control element 
 

 
 
In this case, the control element is a simple Line Between Points.   
 

17. Place a new reference line anywhere within the terrain limits.  Make it 150 feet long or so. 
Use g Line Between Points. 

18. Place a new Building cell “on” the new reference line. 
19. Move the new reference line of the new building. 

 

Note that if you move the reference line of the original Building, you’ll notice that a great 
many other things change.  This is because the entrance road and parking lot are dependent 
on the reference line of the building. 
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Chapter 12: Dynamic Cross Sections 
OVERVIEW 

This section will cover the Cross Section View tool. The cross section view is powerful tool to aid the 
engineer to make design decisions. These sections use Dynamic Section Technology from 
MicroStation. This gives the sections the ability to cut through any Elements that are displayed in the 
DGN file. The graphics can be created from Bentley Civil or any other discipline, which makes this 
technology a valuable asset.  

This section will also examine the 2D and 3D MicroStation models with the Civil Model particularly 
with use of the Dynamic Section tool. 

 

OPENING A DYNAMIC CROSS SECTION VIEW 

 Exercise: Opening a Cross Section View. 

Exercise Objective:  In this exercise, the user will learn to open a view and set it to a cross section 
model view.  

Corridor Modeling Tool Used:  

CORRIDOR MODELING PANEL ICON TOOL 

  
Open Cross Section View 

 

 

Procedure: 

20. Open SitePlan3D_BEGIN_CivilCells.dgn in the C:\2013 Civil_LEARNing\BCR1WK2 - 
Getting Started in SS3 Bentley Civil Power Products\DATA\70_3D-Building-Site folder.  
Most of the horizontal geometry has been laid out for you. We’ll inspect some of it as we go along while 
designing the site. 

21. Using the MicroStation Select tool,  Select the North_bound corridor south of the bridges 
by its green markers near the boundary of the corridor to Context Tool Bar and navigate to 

22. Open Cross Section Model. 
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23. Data Point in View 7 to display the corridor’s Dynamic Sections. 

 

Note The Civil Model managed the required 3D Model needed to accurately Cut dynamic 
Sections. This intelligence helps stream line the management of referencing of the 2D and 
3D models that OpenRoads creates and uses.   

 

24. Navigate and examine the section.  

 
25. Make View 8 with Default-3D  model active and then Reference in the Drainage.dgn 
26. Cut Dynamic Sections for corridor North_bound1. Using the MicroStation Select tool,  

Select the northbound corridor, North_Bound1, north of the bridges by its green markers 
near the boundary of the corridor to Context Tool Bar and navigate to Open Cross Section 
Model. 

27. Data Point in View 7 to display the corridor’s Dynamic Sections. 
28. Use the Navigation Tools at the top of the cross section view to examine the cross sections. 

Examine the area near the drainage structures on the northerly limits of the North_Bound1 
corridor. 

29. Navigate to 1299+00. Note the drainage structure’s depth. 

 

Hint Right Clicking in the Cross Section View and selecting View Properties will 
display a variety of tools that are specific to Cross Sections. 
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Note The Cross Section view instantly provides feedback to the designer; in this case the pipes 
do not have enough cover. Remember, superelevation has not been applied to this corridor 
so this condition will be made worse. This allows the issue to be rectified earlier in the 
design instead of waiting to do clash detection or publish cross section sheets to find 
issues. 

 

30. Dismiss the Cross Sections by closing View 7.  

CHAPTER SUMMARY 
In this chapter, we have introduce and learned to use Open Cross Section View. 
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Learning Paths 
All of our training through Bentley is accessible via learning paths, ready-made training plans that 
provide the recommended progression of skills training for a product, solution, job role, or 
experience level.  

In developing your team, you can choose from Bentley-recommended learning paths or configure 
your own to meet your teams specific needs.  

Learning paths help us: 

• Develop our internal talent pool 
• Make our employees more productive  
• Prioritize learning topics by what is important to us as a company 
• Reinforce our corporate culture of continuous learning 
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Assessment (original) 
1. True or False:  Civil Rules are the way that OpenRoads remembers your 

Design Intent.   

- True. 

2. What is the quickest way to change the cross slope of a simple road? 

  click the Edge of Pavement, key in a new value in the Slope field. 

3. Which of the following are true about Profile from Surface?  

a. It’s a good way to create an existing Profile Grade Line for a road 

b. It’s a good way to drape a building at least 1’ above ground 

c. It’s an easy way to create a ditch bottom that slopes directly from 2’ 
below the ground at the upper end to 2’ below the ground at the 
downstream end.  

All of the above 

4. What time-saving Rule-based design technology minimizes re-work on similar 
objects? 

Civil Cells 
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Assessment (revised) 
1. True or False:  Civil Rules are the way that OpenRoads remembers your 

Design Intent.   

- True. 

2. True or False:  Adding Rules to MicroStation graphics is just as powerful as 
using OpenRoads Technology Tools from the beginning?   

False. 

3. What is the quickest way to change the radius of a Curb Return? 

click the radius element, key in a new value for the radius. 

4. True or False:  A Complex Element has far more software features and 
dependencies associated with it than a single geometry element like one created 
from a tool like “Place Line Between Points”.   

False. 

5. True or False:  Creating Vertical Geometry use very different software 
technology for Site workflows than for Corridor Workflows.   

False. 

6. What time-saving Rule-based design technology minimizes re-work on similar 
objects? 

Civil Cells 
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Glossary 
2D Point Feature Contains no elevation (Z).  2D Point Features are defined and stored in plan model. 

3D Geometry 3D geometry is created in 3D model by mathematically combining the horizontal 
and vertical geometry to create 3D elements.  These 3D geometry elements in turn 
define a design model. 

3D Model This is created and managed automatically.  User can interact with it but this is not 
usually required.  The mathematical combination of Plan Geometry and Profile 
Geometry is stored in the 3D model. 

3D Point Feature 3D points can be defined in plan model or 3D model.  They are stored in 3D model 
but represented in both plan and 3D. 

Active Object The current object to which is added all geometry which is created. 

Active Profile Of the multiple possible profiles for an element, the active profile is the one used 
for design.  The active profile is combined with the horizontal geometry to build a 
3D element which is used in the 3D model. 

Active Terrain 
Model 

One terrain model can be designated as “Active”.  The active terrain model is the 
one used to display “existing ground”; in other words the one which displays 
automatically in a profile model when it is opened.  The active terrain model is also 
the one which is targeted by side slopes unless the template defines a different 
target by name. 

ALG A legacy (proprietary) InRoads file containing coordinate geometry information, 
superelevation, and alignment information for a specific geometry project. 

Alignment A linear feature which serves the special purpose of defining the centerline or 
baseline of a roadway. 

Apply Linear 
Template 

Applies a corridor template along a feature while hiding some of the complexity of 
creating a corridor. 

Apply Surface 
Template 

Applies a corridor template to a terrain model for the purpose of creating 
components (such as pavement layers) under the terrain model. 

Arc Definition Curve definition method generally used in roadway applications. The radius R is 
used to define the curve and is defined by the equation R=5729.58/D where the 
degree of curvature D is the central angle subtended by a 100-foot arc.   Set in the 
Design File Settings > Civil Formatting under Radius Settings.  See also Chord 
Definition.  

Aspect An angular measure of the direction that the face of a surface is oriented. The 
format of the value is dependent on angular settings In the DGN file. 
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Base Geometry In many instances the geometry element will be trimmed. The original (or base), 
untrimmed element is always preserved as it is the storage for the rule. 

Boundary  (Terrain 
Model)  

Used to constrain the external boundary of the terrain model. No triangles are 
created outside the boundary. In addition, any point data outside the boundary is 
ignored. 

Break Line A surface feature consisting of a collection of spatial coordinates that have an 
implied linear relationship. No triangle side (in the triangulated surface) can cross 
over a break line. 

Break Void A closed area of missing or obscured data that uses the elevations of each vertex, 
while the void lines between successive void coordinates are inserted as break 
lines. Therefore, break voids change the slope and elevations of the TIN surface. 

Cardinal Points One of the points used to define the geometry of an alignment. Cardinal points 
include PC, PT, PI, and CC points for horizontal geometry and VPC, VPI and VPT for 
vertical geometry.  

Centroid (triangle) Geometric center of a triangle in a terrain model.  

Chord Definition Curve definition method generally used in railway applications.  The radius R is 
used to define the curve, and is defined by the equation R=50/SIN(0.5*D) where 
the degree of curvature D is the central angle subtended by a 100-foot chord.  See 
also Arc Definition.  

Civil Cell Used as a mechanism to preconfigure commonly used complex geometric layouts.  
These layouts will commonly be stored in DGNLIB files for reuse across multiple 
projects but it is possible and sometimes useful to store directly in an active DGN 
file for use in that single location.  The civil cell will contain horizontal geometry 
and can also contain the vertical geometry. 

Civil Message 
Center 

Used to display a continuous updating log of Civil messages, including warnings 
and errors. As errors and warnings are resolved, they are removed from the list.  
New messages are added whenever the conditions warrant. Most messages relate 
to civil geometry, superelevation, and corridor modeling. 

Civil Template A civil design concept used most often for corridor modeling but also has other 
applications.  The Civil Template defines the cross-sectional shape of the object 
being modeled.  This cross-section is then “extruded along” a 3D geometry 
element to form the final model. The corridor template can create or target 
features such as road edges.  The result is the creation of a corridor. 

Clipping Reference Clipping allows you to remove areas of overlap when working with multiple 
corridors in a single surface.  For example, in a corridor intersected by a crossing 
roadway, clipping would be used to remove all overlapped features within the 
intersection. 

Complex Terrain 
Model A terrain model created by merging or appending two or more terrain models.  
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Context Toolbox When an element is selected, hovering over the element provide a heads-up and 
context sensitive toolbar which pops up at the cursor.  This toolbar provides a few 
of the most commonly used tools which operate on the element selected element 
type. The first tool in this toolbar is always Quick Properties. 

Contour A linear symbol representing points of equal elevation relative to a given datum. 

Contour, Isopach Contours of a delta terrain model which represent cut and fill values as contours, 
not elevations. A positive contour represents fill, while a negative contour is cut.   

Contour, Major The primary elevation line indicating a specific elevation in a surface model. 
Usually major contours are drawn with a heavier line weight or using a different 
color. Elevation text labels are usually drawn in association with major contours. 

Contour, Minor A secondary elevation line indicating a specific elevation in a surface model. Minor 
contours are often drawn without special color or weight indexing and without 
elevation text labels. 

Corridor A civil object used for modeling a roadway and is automatically managed by the 
corridor modeling tools. 

Cross Section 
Model 

DGN models (extracted perpendicular to defined horizontal geometry) with special 
station elevation coordinates defined and other specialized capabilities such as 
view exaggeration. Cross section stations match the interval in the template drop 
when a corridor is used as the basis. When horizontal geometry is utilized, the left 
/ right offsets and interval are user-defined. 

Curve Stroking Stroking is the process of automatically adding shots to the terrain model or 
corridor by interpolating new shots from the curved sections of the data. This 
distance is used to interpolate new shots along the curved element in corridor 
processing and applying linear templates. This value is used as a perpendicular 
minimum distance from chords generated along the arc. Chords are drawn along 
the arc and the perpendicular distance is measured from the middle of each chord 
to the arc. If this distance is larger than the Curve Stroking, the process is repeated 
with a shorter chord length. This process is repeated until the end of the curve is 
reached. The flatter the curve, the fewer number of points will be calculated. The 
steeper the curve, the greater number of points that will be calculated. 

DDB File GEOPAK file (Design DataBase) which contains features definitions, associated 
symbology and annotation settings.  

Delta Terrain 
Model 

A surface containing data derived from the difference in elevation between two 
terrain models or a terrain model and a plane.  

Dialog The tool settings box for the active command.  The dialog shows all available 
options for a command.  For most civil commands, most of the time, the dialog can 
be hidden and ignored since the user is given all necessary instruction and inputs 
by way of the cursor prompt.  The dialog is necessary for configuring command 
customizations. 

Drape The process of vertically projecting elements onto a surface so that the element 
elevations are defined by the surface. 
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Drape Void A closed area of missing or obscured data where the void coordinates are not 
included in the triangulation. Voids are inserted post triangulation. The void 
coordinates and lines are draped on the TIN surface. Even though a user must 
provide an elevation for the Drape Void vertices, the user elevations are changed 
to the elevation of the TIN surface at the XY Drape Void coordinate position. 

Element Template MicroStation concept which allows preconfigured definitions for symbology and 
other miscellaneous display of MicroStation elements and civil features. 

End Condition A specialized component of a corridor template which provides information tie 
into active surface. 

End Condition 
Exception 

Used to modify the behavior of an end condition solution without requiring the 
use of additional template drops.  When an end condition exception is added, it 
must be edited to change its behavior. 

Export to Native Option to automatically or manually push horizontal and vertical geometry into 
native products (InRoads - ALG, MX - PSS and GEOPAK - GPK).   

Feature A Feature is anything that can be seen or located and is a physical part of your 
design, representing a real world thing.   A feature’s definition is one of its 
properties.  At any given time in the design process, the feature will have a 
Horizontal Geometry, a Vertical Geometry, 3D Geometry or a combination to 
define its location. 

Feature Definition Used to define options when creating features.  These are the items which are 
created in advance, usually used across multiple projects and define symbology, 
annotation and quantities.  The feature definition is assigned (usually) in the plan 
model and profile/3D feature definitions follow from there. 

Feature Name Each Feature can have a name. 

Gap When a feature is trimmed the part(s) which are invisible on the base geometry. 

GPK A legacy (proprietary) GEOPAK database containing coordinate geometry 
information. 

Graphical Filter Using in developing terrain models, an automated way of storing search settings 
for graphic elements when creating terrain models using 3D element. A graphical 
filter can be created for each feature (i.e., spots, breaks, voids) then the filters can 
be defined as a Graphical filter group.   

Heads Up  Prompt Command instructions are given in a heads up and dynamic prompt which floats at 
the cursor. 

Horizontal 
Geometry 

The elements which define the horizontal layout of the design.  These elements 
are 2D elements even if the DGN model is 3D. Horizontal Geometry may be points, 
lines, arcs, spirals, splines or any combination in a complex element. 

Interval When a feature is trimmed the part(s) which are visible on the base geometry. 

Island Closed area used to place within a void, i.e., islands in the middle of rivers, lakes, 
etc. 
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Key Station Additional station added to the corridor to force processing at the particular 
location.  

LIDAR (Light Detection And Ranging) is an optical scanning technology which scans 
ground and other physical features to produce a 3D model.  

Linear Feature In plan model, composed of lines, arcs, spirals, splines or combinations of these.  In 
profile model, composed of lines, parabola, splines or combinations of these. 

Linear Stroking Stroking is the process of automatically adding shots to the terrain model or 
corridor by interpolating new shots from the linear sections of the data.  Linear 
stroking is measured along the element.  Interpolated vertices are added 
whenever the distance between the vertices is greater than the linear stroking 
value (in master units). 

Manipulators The heads up, on-screen editing interface.  Only the most common properties are 
presented in manipulators.  Manipulators are in two types:  graphical and text 

Overlay Vertical 
Adjustment 

Within Corridor Model, tool used to develop a vertical geometry (based on milling 
and overlay parameters) and apply to the corridor. 

Parametric 
Constraints Used to set up constraint value overrides for specified station ranges.  

Plan Model The usual DGN model, used for laying out horizontal geometry.  Best practices will 
dictate that this is a 2D DGN model but 3D DGN model can be used.  This is where 
geometric layouts and corridor definitions are kept. The geometric layouts are not 
only alignments but also edges, parking, striping, sidewalks, etc. 

Point  Features Defined by a single X, Y  (Z optional) location. A point need not be a feature.  It may 
be defined as a non-featurized point by way of AccuDraw, Civil AccuDraw, Snap or 
a data point.  Non featurized points are use to control the construction of Linear 
Features. 

Point Cloud A set of vertices in a 3D coordinate system and these vertices are defined the by X, 
Y and Z coordinates. Point clouds are usually created by 3D scanners. These 
devices measure a large number of points on the surface of an object and output a 
point cloud as a data file. The point cloud represents the visible surface of the 
object that has been scanned or digitized. 

Point Control Used to modify the behavior of points in a template. These controls take 
precedence (they override) over existing constraints on the point. 

Project Explorer MicroStation's interface for browsing elements in a DGN file.  Extended by civil to 
accommodate specialized civil needs. 

PSS File MX file (Plans Style Set) which provides the graphical representation for the MX 
string features.  

Reference Element The rule for some geometry is a calculation from another element.  This other 
element is the reference element. 
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Secondary 
Alignment 

Used to modify the direction of cross section processing.  By default, as any given 
station, the cross section is created orthogonal to the main alignment/feature.  If a 
secondary alignment exists, then that portion of the cross section which lies 
outside the secondary alignment will be orthogonal to the secondary alignment 
instead of the main alignment. 

SEP File / Method Uses the superelevation settings which originated in GEOPAK. 

SMD File GEOPAK file (Survey Manager Database) which contains survey features definitions 
and associated element and textual settings.  

Spot Elevation A set of X, Y, Z coordinates representing a point on the terrain model surface. 
There is no implied relationship between regular points. 

SRL File / Method Uses the superelevation settings which originated in MX 

Superelevation 
Lane 

The closed area defined by the superelevation tools used for the limits of 
transition calculations and pivoting location.  

Superelevation 
Section 

Area along a horizontal geometry element, where superelevation will be 
calculated.   

Target Aliasing Used to create the desired results when working with multiple surfaces without 
having to edit the template from the template library.  Target aliases can also be 
used so that one corridor can target the solution of another corridor. 

Template Drop An area (usually defined by station limits) along a corridor to which a specific 
template is applied.  

Template Library A file that stores definitions for templates, generally with an ITL file extension. 

Template 
Transition 

The transition indicator occurs in the corridor between templates of differing 
names. 

Terrain Model A three-dimensional DGN element defined by spots, break lines, voids, holes, 
contours to model a surface on the earth. 

Tooltips When hovering the cursor over an element or a handle, a tooltip is shown which 
gives explanatory information. 

Trace Slope Upstream - The indicated path follows the steepest ascent from a user-defined 
point through the terrain model terminating at a high point or the edge of the 
terrain model.  
Downstream - The indicated path follows the steepest descent from a user-defined 
point through the terrain model terminating at a low point or the edge of the 
terrain model. 

Vertical Alignment A linear feature in profile model which serves the special purpose of defining the 
elevations of an alignment. 

Vertical Geometry The elements which define the vertical layout of a corresponding horizontal 
geometry element.  These vertical elements are 2D and are stored in a profile 
model. 
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Void Closed shape to demarcate areas of missing data or obscure areas. No point or 
break data located within the void area is utilized and no triangles are created 
inside the void areas. The Void coordinates are included in the triangulation and 
void lines between successive void coordinates are inserted as drape lines on the 
surface. Therefore, they do not change the slope or elevations of the surface. 

Watershed Defined by either a low point within the terrain model or a low edge point along 
the terrain model edge, it's the closed area wherein all water would drain to the 
low point.  

XIN File InRoads file which contains features definitions, associated styles, annotation, and 
other settings.  
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	 Exercise:  Turn “dumb graphics” into Civil Graphics.

	5. In the General Geometry workflow, select Create Civil Rule Feature.
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	We’ll do it the quickest and “dirtiest” way first (the way with the poorest technique)

	6. Follow the Heads Up Display prompt and select the northeastern road centerline (cyan).
	/

	7. In the Name field of the tool settings, keyin GeomCL
	8. Reset (right-click) to process the command.
	9. There is no feedback (using our poor technique).
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	13. Play around with some in-place editing.
	/
	 Exercise:  Continue turning “dumb graphics” into Civil Graphics.

	14. Open the Feature Definition Toggles Bar.
	/
	This “pre-sets” the Feature Definition default when creating new features.

	15. Select Geom_Centerline
	/
	Ensure that the Use Active Feature Definition button /is set.

	16. In the General Geometry task, select Create Civil Rule Feature.
	17. Notice that the Feature Definition to be assign is the Active Feature Definition shown in the Features Definitions Toggle Bar: Geom_Centerline.
	18. Type Central Lane in the Name Field of the Tools Settings dialog.
	Follow the Heads Up Display prompt and select the central linestring.
	/
	This time, we get some visual feedback to confirm our success: the linestring changes level, color and gets stationed.

	19. Add the southwestern road
	 Exercise:  Place a Centerline.

	20. Click Horizontal Geometry > Geometry Line > Line Between Points.
	21. Place the first point somewhere along the center of the cul-du-sac road.
	22. Using the Perpendicular Snap, snap to the Central Lane Element.
	/

	23. Move the Alignments the Central Lane tees into.  Notice that there is no relationship maintained between the alignments (even though the graphics were placed perpendicular to the roads).
	24. Move the Central Lane.  Notice that the Cul-du-Sac road remains perpendicular to it.
	This is one of the primary benefits to using OpenRoads Geometry tools:  the design intent is captured, where, in MicroStation, it is lost.

	25. Play around with the geometry.  Get familiar with how things interact or do not.  Make mistakes.
	26.
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	1. Browse to C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Power Products\Data\20_2D-Building-Road and select geom_Creating_10_Horizontal_Elements_BEGIN.dgn as shown below./Click Open.
	2. Click the Feature Definition Toggle Bar icon from the Tasks > Horizontal Geometry menus.
	/

	3. In the Feature Definition Toggle Bar, click the Match Feature Definition icon.
	4. Select a red alignment in the CAD View.
	This will set the Feature Definition to Geom_Centerline.
	/

	5. In the Feature Definition Toggle Bar, click the Use Active Feature Definition icon
	 Exercise:  Place Geometry Lines.

	6. Click the Line Between Points icon from the Tasks > Horizontal Geometry menus.
	7. Snap to starting point of the alignment which is marked with a red circle and the number 6.
	8. Click to accept the Starting Point.
	9. Snap to ending point of the alignment which is marked with a red circle and the number 7.
	10. /Click to accept the Ending Point.
	11. Snap to starting point of the alignment which is marked with a red circle and the number 8.
	12. Click to accept the Starting Point.
	13. Snap to ending point of the alignment which is marked with a red circle and the number 9.
	14. Click to accept the Ending Point.
	Two lines have been created.
	 Exercise:  Place Geometry Arcs.

	15. Click the Simple Arc icon from the Tasks > Horizontal Geometry menus.
	16. Select the Line between the red circles labeled 6 and 7 as the First Element.
	17. Select the Line between the red circles labeled 8 and 9 as the Second Element.
	18. Snap to red circle labeled 10 as the Through Point and click to accept.
	19. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to Both.
	20. Click to accept the Trim/Extend Option.
	An arc has been created between the two lines.

	21. /Click the Simple Arc From Element icon from the Tasks > Horizontal Geometry menus.
	22. Select the line between the red circles labeled 8 and 9.
	23. Snap to red circle labeled 9 as the Start Point and click to accept.
	24. Key-in 297.28 as the Radius and press the Enter key on your keyboard.
	25. Snap to red circle labeled 11 as the End Point and click to accept.
	26. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to Back.
	27. Click to accept the Trim/Extend Option.
	An arc has been added to the end of the line.
	This time, we get some visual feedback to confirm our success: the linestring changes level, color and gets stationed.

	28. Add the southwestern road
	 Exercise:  Place Geometry Lines.

	29. Click the Line Between Points icon from the Tasks > Horizontal Geometry menus.
	30. Snap to starting point of the alignment which is marked with a red circle and the number 6.
	31. Click to accept the Starting Point.
	32. Snap to ending point of the alignment which is marked with a red circle and the number 7.
	33. Click to accept the Ending Point.
	34. Snap to starting point of the alignment which is marked with a red circle and the number 8.
	35. Click to accept the Starting Point.
	36. Snap to ending point of the alignment which is marked with a red circle and the number 9.
	37. Click to accept the Ending Point.
	Two lines have been created.
	 Exercise:  Place Geometry Arcs.

	38. Click the Simple Arc icon from the Tasks > Horizontal Geometry menus.
	39. Select the Line between the red circles labeled 6 and 7 as the First Element.
	40. Select the Line between the red circles labeled 8 and 9 as the Second Element.
	41. Snap to red circle labeled 10 as the Through Point and click to accept.
	42. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to Both.
	43. Click to accept the Trim/Extend Option.
	An arc has been created between the two lines.
	/

	44. Click the Simple Arc From Element icon from the Tasks > Horizontal Geometry menus.
	45. Select the line between the red circles labeled 8 and 9.
	46. Snap to red circle labeled 9 as the Start Point and click to accept.
	47. Key-in 297.28 as the Radius and press the Enter key on your keyboard.
	48. Snap to red circle labeled 11 as the End Point and click to accept.
	49. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to Back.
	50. Click to accept the Trim/Extend Option.
	An arc has been added to the end of the line.
	 Exercise:  Place a Line From an Arc.

	51. Click the Simple Line From Element icon from the Tasks > Horizontal Geometry menus.
	52. Select the arc between the red circles labeled 9 and 11.
	53. Snap to red circle labeled 11 as the Start Point and click to accept.
	54. Snap to red circle labeled 12 as the End Distance and click to accept.
	55. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to Back.
	56. Click to accept the Trim/Extend Option.
	A line has been added to the end of the arc
	 Exercise:  Create Complex Elements

	57. Select the Complex By Elements icon from the Tasks > Horizontal Geometry menus.
	58. In the Settings dialog, change the Method to Automatic.
	59. Key-in Western Way for the Name.
	60. Click in the CAD View to accept the key-in.
	61. Select the north-south line near the red circle labeled 6.
	62. An arrow will appear pointing in the direction of the ahead stationing (north).
	63. Click in the CAD View
	/
	FOR Bentley LEARNing Conference Session:  STOP here!
	You may continue if you’re done early.  The following additional tool practice will not be performed in class due to time constraints.
	 Exercise:  Place Geometry Curves

	1. Select the Line Between Arcs icon from the Tasks > Horizontal Geometry menus.
	2. Select the arc between the red circles labeled 13 and 15 as the First Element.
	3. Key-in 0.0 as the Start Offset and press the Enter key on your keyboard.
	4. Click the CAD View to accept the Start Offset.
	5. Select the arc between the red circles labeled 16 and 17 as the Second Element.
	6. Key-in 0.0 as the End Offset and press the Enter key on your keyboard.
	7. Click the CAD View to accept the End Offset.
	8. Move your cursor to select the Solution that shows the line going between the arcs.
	9. Click the CAD View to accept the Solution.
	10. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to Both.
	11. Click to accept the Trim/Extend Option.
	 Exercise:  Place a Line to an Arc

	12. Select the Simple Line to Element icon from the Tasks > Horizontal Geometry menus.
	13. Snap to red circle labeled 18 as the End Point and click to accept.
	14. Select the arc between the red circles labeled 16 and 17 as the Element.
	15. Move your cursor to select the Solution that shows the line going to the arc.
	16. Click the CAD View to accept the appropriate Solution.
	17. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to Back.
	18. Click to accept the Trim/Extend Option.
	A line has been added to the end of the arc
	 Exercise:  Place Another Line to an Arc

	19. The Simple Line to Element should still active.
	20. Snap to red circle labeled 6 as the End Point and click to accept.
	21. Select the arc between the red circles labeled 13 and 15 as the Second Element.
	22. Move your cursor to select the Solution that shows the line going to the arc.
	23. Click the CAD View to accept the Solution.
	24. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to Back.
	25. Click to accept the Trim/Extend Option.
	A line has been added to the beginning of the arc.
	 Exercise:  Extend a Line

	26. Click the Extend Line icon from the Tasks > Main menus.
	27. In the Settings dialog, enable the Distance option.
	28. In the Settings dialog, key-in 210 for the Distance.
	29. Select the line between the red circles labeled 6 and 13.
	A line has been extended.
	 Exercise:  Create Complex Elements

	30. Select the Complex By Elements icon from the Tasks > Horizontal Geometry menus.
	31. In the Settings dialog, change the Method to Automatic.
	32. Key-in Southern Street for the Name.
	33. Click in the CAD View to accept the key-in.
	34. Select the west portion of the line just extended before the red circle labeled 6.
	35. An arrow will appear pointing in the direction of the ahead stationing (east).
	36. A Fork may be found at the intersection of Fairway Road and Southern Street.
	37. Move your cursor to continue in the direction of the Southern Street and click to accept.
	38. Click in the CAD View to accept the results.
	 Exercise:  Starting Station

	39. Select the Start Station icon from the Tasks > Horizontal Geometry menus.
	40. Select the Southern Street alignment.
	41. In the Heads-up display, key-in 0.00 for the Start Station Position and press Enter on your keyboard.
	42. Click in the CAD View to accept the key-in.
	43. In the Heads-up display, key-in 117+22.65 for the Starting Station and press Enter on your keyboard.
	44. Exit MicroStation.
	Chapter 4: Pavement Edges & Curb Returns
	Creating Horizontal Alignment Elements
	 Exercise:  Set the Feature Definition.


	1. Change design files:
	2. Browse to C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Power Products\DATA\20_2D-Building-Road and select geom_Creating_20_EOPsAndCurbReturns_BEGIN.dgn.
	3. /Click Open.
	4. Click the Element Selection icon from the Tasks > Main menus.
	5. Select each of the horizontal alignments.
	6. Review the graphics of the Manipulators.
	7. The blue Manipulators values can be modified and the white Manipulators values are informational
	 Exercise:  Set the Feature Definition.

	8. Click the Feature Definition Toggle Bar icon from the Tasks > Horizontal Geometry menus.
	9.
	10. / Navigate to the Linear > Roadway folder and select the Feature Definition named Road_EdgeOfPavement.
	11. In the Feature Definition Toggle Bar, click the Use Active Feature Definition icon.
	This will hold the Feature Definition when we use different commands.
	 Exercise:  Create Edge of Pavement Geometries.

	12. Click the Single Offset Entire Element icon from the Tasks > Horizontal Geometry menus.
	13. Select the horizontal geometry that runs from the circles labeled 6 and 12.
	14. If the entire alignment doesn’t highlight, press the Alt key on your keyboard.
	15. Click to accept the selection.
	16. Key-in 12.0 as the Offset and press the Enter key on your keyboard.
	17. Click to accept the selection.
	18. Use the Up and Down Arrow keys on your keyboard to change the Mirror to Yes.
	19. Click to accept the Mirror option.
	20. Two horizontal geometries have been created.
	21. Select the horizontal geometry that runs from the circles labeled 6 and 18.
	22. Click to accept the selection.
	23. The Offset should still be set to 12.0.
	24. Click to accept the selection.
	25. The Mirror option should still be set to Yes.
	26. Click to accept the Mirror option.
	27. Two more horizontal geometries have been created.
	28. Use the Element Selection tool to review the Manipulators.
	 Exercise:  Create Edge of Pavement Radii at the Intersection.

	29. Click the Simple Arc icon from the Tasks > Horizontal Geometry menus. /
	30. Select the blue Line between the red circles labeled 13 and 14 on the north side as the First Element.
	31. Select the blue Line between the red circles labeled 6 and 7 on the east side as the Second Element.
	32. Key-in 50.0 as the Radius and press the Enter key on your keyboard.
	33. Move your cursor to the Northeast quadrant of the intersection and click to accept.
	34. Use the Up and Down Arrow keys on your keyboard to change the Trim/Extend Option to Both.
	35. Click to accept the Trim/Extend Option.
	/

	36. Select the blue Line again between the red circles labeled 13 and 14 on the north side as the First Element.
	37. Select the blue Line between the red circles labeled 6 and 7 on the west side as the Second Element.
	38. The Radius should still be set to 50.0.
	39. Move your cursor to the northwest quadrant of the intersection and click to accept.
	40. The Trim/Extend Option should still be set to Both.
	41. Click to accept the Trim/Extend Option.
	Two arcs have been added
	/
	 Exercise:  Create Edge of Pavement Radii at the Intersection.

	42. Click the Element Selection icon from the Tasks > Main menus.
	43. Select the last radius placed in the northwest quadrant of the intersection.
	44. Click the radius value labeled 50.00.
	45. Key-in 60.00 and press the Enter key on your keyboard.
	The radius is now changed to 60.00 and the original Trim/Extend Option was honored.

	46. Select the blue line again between the red circles labeled 13 and 14 on the north side.
	47. Click the offset value labeled -12.00 on the left end of the line.
	48. Key-in -30.00 and press the Enter key on your keyboard.
	The offset is now changed to -30.00 and the original radius at the intersection were maintained.  Since the Civil Rule was based on an Offset command, changing the offset at the beginning, middle, or end of the line, changes the offset of the entire l...

	49. Select the blue line between the red circles labeled 8 and 10 on the west side.
	50. Click the offset value labeled -12.00 on the middle end of the line.
	51. Key-in -20.00 and press the Enter key on your keyboard.
	52. Select the blue Line between the red circles labeled 8 and 10 on the east side.
	53. Key-in 20.00 and press the Enter key on your keyboard.
	Chapter 5: Building Pad Layout
	Overview
	Creating a Building Pad Layout - Horizontal
	 Exercise:  Design a Building Pad.


	1. Change Design files.
	2. Browse to C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Power Products\DATA\30_2D-Building-Site and select Open SitePlan2D_Building_Layout-Horizontal.dgn.
	3. Click Open.
	4. To the south of the parking lot is construction line.  We will use it as a reference for constructing a building pad.  Zoom in to the area.
	/

	5. Click the Horizontal Geometry > Geometry Complex > Single Offset Entire Element tool.
	/

	6. Pick the construction line.
	/

	7. Offset the line 5 feet.  Do NOT Mirror.
	/

	8. Offset another line 80 from the new line.
	9. Click the Horizontal Geometry > Geometry Complex > Single Offset Entire Element tool.
	/

	10. Place two lines between the offset lines to make a rectangle.
	/

	11. Because the Feature Definition of the resulting Pad is important, select Site_Pad as the Feature Definition.  It is found under Linear > Site.  Ensure that the Use Active Feature Definition toggle is set.
	/

	12. Click the Horizontal Geometry > Geometry Complex > Complex by Elements tool.
	/

	13. Select the Automatic Method and select the first of the offset lines (the northwestern side).
	/
	Note there is a “direction arrow”, which changes sides, depending which side of line midpoint you select.  Callouts in the book assume that the direction of the pad is clockwise.  If you select the other directions, some offsets may be opposite than t...

	14. Accept the rectangular complex solution.
	/

	15. Select the new pad to see the rules.
	/

	16. Change some of the values.  Drag an end to the reference line around.  See the rules in action.
	/
	You may continue if you’re done early.  The following additional tool practice will not be performed in class due to time constraints.
	 Exercise:  Extra Work (Time Permitting).

	17. If you finish early, add a building footprint 10 feet inside the pad boundary.
	/

	18. If you’re feeling bold, create a Civil Cell of the new building Pad.
	/

	19. If you’re successful creating the Civil Cell, you can Place a Cell by right-clicking it in the Project Explorer Civil Model and selecting Place Civil Cell.  You will need to identify a line in the design file.
	/

	Chapter 6: Create and Analyze Terrain
	Create and Analyze Terrain
	 Exercise:  Create Terrain Model from 3D Graphical Elements.


	1. Browse to C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Power Products\DATA\30_2D-Building-Site and select Contours.dgn.
	2. Click Open.
	/

	3. Using Power Selector, select all the contour graphical elements.
	4. Start the Terrain Model By Elements command.
	/

	5. Populate the feature definition in the command dialog as shown below. You can also populate the feature type and edge method as shown if you wish but these will be prompted.
	/

	6. Datapoint to accept the selected elements.
	/

	7. Set feature type to Contour.  Use up/down arrows on keyboard. Then DP to accept.
	/

	8. Set edge method to slivers. DP to accept. Note that max triangle length is also a valid option.
	/

	9. So we can tell the difference in the graphics we were given and our new terrain, turn off levels named Exist_Contour_Major and Exist_Contour_Minor.
	/
	 Exercise:  Using Element Information to Change the Terrain Model Display.

	10. Select the terrain model that we created above.
	11. Open Element Information (Element > Element Information)
	/

	12. Notice the Display Toggles.  These are divided into Calculated Features (those things which are used to represent the Terrain Model) and Source Features (those things which were used to create the terrain model).  Try double click on the label to ...
	13. Review other settings.
	/

	14. So what about the symbology for these various feature types (triangles, contours and such)? In the tree pane, expand the tree until you see Triangles as shown below.
	/

	15. By drilling into the tree, we can define the desired symbology for each feature type.
	16. Make sure triangles display is ON and then change its color.
	17. Notice the property titled  “Thematic Display Style”.  Change this to “Thematic: Height”.
	18. Deselect the Terrain Model to see the effect.
	 Exercise:  Using Element Templates to Control Display.

	19. Select the terrain model that we created above and open Element Information.
	20. Notice the property for “Template” in the General panel.
	/

	21. The use of templates allows us to automate the change of display settings while also providing ability to save and reuse your organization standards.
	22. Experiment with different templates.  When finished set the template back to Terrain\ Existing Ground.
	23. Now, deselect the Terrain Model and hover your cursor over the contours.  The tooltip will report the elevations.
	/
	 Exercise:  Analyze Point.

	24. In Task Navigation choose the Analyze Point Command
	/

	25. Select the Terrain Model
	26. Now you get X,Y,Z information feedback at the heads up prompt.
	/
	Now look at the dialog and notice you can toggle on settings to show the contour, triangle or flow arrow. Try different combinations of this as you analyze.
	/

	27. With one or more of these options toggled on, DP will draw the contour, slope label and/or triangle as graphic elements.
	 Exercise:  Trace Slope

	28. In Task Navigation choose the Analyze Trace Slope command
	/

	29. Select the Terrain Model.
	/

	30. The downstream flow path is traced from the cursor.
	/

	31. Take a couple minutes to experiment with the other options on the dialog.
	/

	 Slope – when locked forces the path to follow an exact slope instead of most direct slope.
	 Length – when locked limits the length of the trace.
	 Direction – trace can be upstream or downstream.
	32. DP in the view while this command is running will draw the trace as a graphic element.
	Chapter 7: Exploring the 3D Environment
	Chapter 8: Creating Vertical Geometry
	Creating Vertical Geometry
	 Exercise:  Getting Started.


	1. Browse Launch MicroStation and set the following in the File Open dialog.
	User: examples
	Project: Bentley-Civil-Imperial
	Interface: Bentley-Civil

	2. Open geom_Creating_30_Vertical_Profiles.dgn from the folder C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Products\DATA\60_3D-Building-Road.
	 Exercise:  Set the Active Terrain Model.

	3. Click on the Terrain Model boundary, hover, and wait for the Context Menu.
	Select Set As Active Terrain Model.
	/
	 Exercise:  Open a Profile Model.

	4. Click the Element Selection icon from the Tasks > Vertical Geometry > Vertical Geometry Main > Open Profile Model menu.
	/

	5. At the Locate Plan Element  prompt, select the centerline of Southern Street.
	/

	6. At the Select or Open View  prompt, click on View 2 (or place a datapoint in View 2 if it open).
	/
	A Profile View opens of Southern Street:
	/
	 Exercise:  Place Vertical Elements.

	7. Click the Profile Curve Between Points icon / from the Tasks > Vertical Geometry menu.
	8. Clear all the check boxes, we will place two parabolas by snapping to three points each – no pre-defined parameters.  We will want to use the Start\End\Pass-through Placement Method.
	/

	9. Place two Profile Curves by snapping to the existing terrain at the points indicated.
	/
	Your results should look like this (more or less).
	/

	10. Click the Parabola Between Elements icon / from the Tasks > Vertical Geometry menu.
	11. We will want to Trim/Extend Both elements
	/
	Use any length you want (although 740 works well), trim both

	12. Click the Parabola Between Elements icon / from the Tasks > Vertical Geometry menu.
	We will want to Trim/Extend Both elements.

	13. Click the Tangent Profile Line to Element icon /from the Tasks > Vertical Geometry menu.
	We will want to Trim/Extend Back (the prompt really should be Yes/No).

	14. At the End Point prompt, click on the left end of the existing terrain.
	/

	15. At the Locate Reference Profile prompt, we need to identify which of the profiles to connect to (the existing does count as a profile).  Select the new curve.
	/
	/
	After clicking through the prompts, we have a “solution,” but it is made up of individual elements.
	/
	We will want to group them into a single unit.
	 Exercise:  Make a “Full-Length” Vertical Solution.

	16. Click the Profile Complex By Elements icon / from the Tasks > Vertical Geometry menu.
	/

	17. Try the Automatic Method.  If it does not select the new four elements correctly, you can Undo and either increase the gap or use the Manual Method.
	/
	Note: at the Locate First Element prompt, make sure that you select the proposed element and not the existing:
	/

	18. Finally, make this the Active Profile, either by using the Context Menu.
	/
	Or by right-clicking in the Civil Model or Element Info and clicking Set As Active Profile
	/

	Chapter 9: Creating a Corridor
	Creating Vertical Geometry
	 Exercise:  Getting Started.


	19. Browse Launch MicroStation and set the following in the File Open dialog.
	User: examples
	Project: Bentley-Civil-Imperial
	Interface: Bentley-Civil

	20. Open geom_Creating_40_Corridors.dgn from the folder C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Products\DATA\60_3D-Building-Road.
	 Exercise:  Set the Active Terrain Model.

	21. In view 1, select the main road alignment again.  Hover over it and in the context toolbox select Create Corridor.
	/

	22. The second prompt is to choose profile.  We have the option here of picking one from the profile model (view 2) or if we just click Reset Button then it will use whichever is active.  Click Reset.
	/

	23. The corridor which we create needs a name.  By default it uses the same name as the alignment.  Just DP to accept this name or type a new one, then DP.
	/

	24. Next we need to choose which template to use. This prompt may be blank for you or It may list the wrong template.
	/

	25. Click ALT>Down on keyboard to open the template library and choose 2 Lane Urban Curb and Gutter with Sidewalk as shown below.
	/

	26. For start station, you can dynamically move cursor to the beginning (south end) or click ALT on keyboard to lock to the beginning.
	/

	27. For end station, you can dynamically move cursor to the end (north end) or click ALT on keyboard to lock to the end.
	/

	28. For drop interval use 25.
	29. For minimum transition drop length enter zero for both prompts.  This is used to transition between different templates which does not apply to this design.
	30. Inspect view 1 to see the changes:
	3. Sidewalk left and right.
	/

	31. Open view 3 to inspect the 3D model.
	/

	32. You may notice that the 3d model is a little jaggy.  The resolution is probably fine for this stage of development, but we can increase the resolution.
	33. In view 1, select the corridor and open the properties.
	/

	34. In the Design Stage Property, change it to Final, which will improve the resolution of the 3d model.
	Chapter 10: Building Pads Vertical
	Creating a Building Pad
	 Exercise:  Designate  Existing Ground.


	1. Open SitePlan3D_BEGIN_CivilCells.dgn in the C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Power Products\DATA\70_3D-Building-Site folder.  Most of the horizontal geometry has been laid out for you. We’ll inspect some of it a...
	/

	2. Notice too, that the existing ground terrain model we created above exists in a reference file and has been displayed with only the boundary shown.
	3. Select the terrain model.
	/

	4. After you select it, hover the cursor over the terrain model and a toolbox will appear, as shown above.
	5. The second command is Set As Active Terrain Model.  Active Terrain Model is, for most projects, existing ground.
	Note:  The Active Terrain Model is used for a few different things. It is automatically shown in all profile views and is used by default as the target for commands which seek a surface..
	 Exercise:  Design a Building Pad

	6. Zoom in on the building.  Our goal is to set the building pad elevation at 2.0 feet above maximum existing elevation found under the pad.
	/

	7. In Task Navigation, start the command, Profile From Surface
	/

	8. Pick the building pad element
	/

	9. Reset to continue
	/

	10. Then pick the existing ground surface, which will be used to determine elevation.
	/

	11. Click the ALT key on keyboard to lock start station to beginning
	/

	12. And ALT key to lock end station to end.  This computes elevation for the entire perimeter of the pad.
	/

	13. Set point selection to all. Use Up/Down arrow on keyboard to change this value if needed. This means that the pad is evaluated all around the perimeter.
	/

	14. Set Profile Adjustment to Maximum, which means that after evaluating around the perimeter, it will use the maximum found value for the pad.
	/

	15. Set Draping option to triangles to evaluate at every triangle leg.
	/

	16. Set Horizontal Offset to zero.
	/

	17. Set vertical Offset to 2.0, which will add 2 feet to the above noted maximum.
	/

	18. Let’s inspect the computed profile.  Select the building pad element, and on the context toolbox, click Open Profile.
	/

	19. If view 2 is not already open, open it and click in the view, which opens the profile for the building pad.
	/

	20. This will open the profile.  You should have a flat profile at about elevation 5266.
	/

	21. Now, open view 3 and in view attributes, set the model to Default 3D
	/

	22. Rotate the view into isometric and see our building pad model.  There are no side slopes yet and the pad is incomplete.
	/

	23. We’ll return to view 3 from time to time to inspect the progress of our model.
	24. Back in View 1, we need to compute a slope from the pad element out to the green rectangle which serves for sidewalks and etc.
	25. Start the command, Profile By Slope From Element
	/

	26. Pick the green sidewalk edge.  This is the element we want to define vertically.
	/

	27. Reset to continue
	/

	28. Pick the building as reference element.  This is the element used to compute slope from.
	/

	29. Set slope to -2.0%
	/

	30. Point Selection is All.
	/

	31. Adjustment is None
	/

	32. Vertical offset is zero.
	/

	33. Review View 3 to see your progress.
	/.
	 Exercise:  Make a Terrain of the Building Elements.

	34. In view 3, Select the two 3D elements and create a terrain model like we did in Chapter 1, except the elements will be break lines instead of contours.
	35. Start the Terrain Model By Elements command.
	/

	36. Populate the feature definition in the command dialog as shown below. You can also populate the feature type and edge method as shown if you wish but these will be prompted.
	/

	37. Datapoint to accept the selected elements
	/

	38. Set feature type to Break line.  Use up/down arrows on keyboard. The DP to accept.
	/

	39. Set edge method to slivers. DP to accept. Note that max triangle length is also a valid option.
	/
	 Exercise:  Add tie slopes

	40. Start the Linear Template command.
	/

	41. In view 1, Select the green sidewalk edge as the element to apply the template. You can also attach the linear template to the terrain model we created of building.
	/

	42. The template we need is probably not listed.
	/

	43. On keyboard, click ALT > Down Arrow, which will bring up the template library.  Choose  template named Straight 2:1 Slopes as shown.
	/

	44. For start station use the locked beginning station.  Use ALT to lock it if it is not locked.
	/

	45. For end station lock to end.
	/

	46. Use the cursor to set side on the outside of the element.
	/

	47. Set corner sweep angle to 5.  This determines how to compute the tie slopes on sharp corners. If value of zero is used then side slope will be sharp.  Non-zero makes rounded corners.
	/

	48. Now, inspect view 3 again and see our side slopes.
	/.
	 Exercise:  Add Sub-layers

	49. We lack one thing now for our building pad.  We need some sort of layers of paving material.  This might be just gravel, or perhaps multiple layers of bitumen or concrete. Start the Area Template command.
	/

	50. Select the terrain model we made of pad earlier.
	/

	51. At the prompt for template, use ALT > Down Arrow…
	/

	52. …to open template library and choose as shown below.
	/

	53. Then data point to accept.
	/

	54. With Smooth Shading t urned on in view 3, we can now see our finished building pad.
	/

	Chapter 11: Place Cells – Building Pads
	Create a Building Pad Using Civil Cell
	 Exercise:  Designate  Existing Ground


	1. Open SitePlan3D_BEGIN_CivilCells.dgn in the C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Power Products\DATA\70_3D-Building-Site folder.  Most of the horizontal geometry has been laid out for you. We’ll inspect some of it a...
	2. You will note that instead of a full building pad drawn in, we have only a line to indicate location and direction of the building.
	/

	3. Select the terrain model.
	/

	4. After you select it, hover the cursor over the terrain model and a toolbox will appear, as shown above.
	5. The second command is Set As Active Terrain Model.
	6. Open Project Explorer to Civil Standards (File > Project Explorer)
	Note: If you do not see the Civil Standards tab as shown above, go to Settings > Project Explorer to turn it on.

	7. There are a number of function-specific Civil Cell Libraries, right click on the Civil Cell named Fancy3DPad in the Buildings.dgnlib and choose Place Civil Cell.
	/
	Alternatively, you can Place Civil Cells via the Civil Cells > Place Civil Cell task:
	/
	Note: the tool assumes that you are placing the previously-place Civil Cell.  To select a different one, right-click once to enable the Browse button and then select it.
	/
	This opens the Pick Civil Cells dialog.
	/
	Select Fancy3DPad from the Buildings.dgnlib.

	8. The first prompt is to select the reference element.  In this case, the reference element is the orange line which defines the front face of the building. For any given civil cell, the number and type of reference elements will depend on how the ci...
	/

	9. The next step is to choose elements to reverse.  This is because the final reference elements may be drawn different direction than the cell elements.  In order to properly construct the cell then these elements will need to operate in a reverse fa...
	/

	10. Once the element rules are properly configured then DP to accept the cell placement.
	/

	11. The building is designed in one step, 2D and 3D.
	/

	12. You’ll notice that the dimensions are a little different than above.  This is because, we created the cell to be fairly simple.  But, we can adjust the dimensions.  Select the green sidewalk element.
	/

	13. Notice the width of building is set to 63.  Click on the text manipulator and type -100 in place of 63.
	/

	14. Now the proportions look more like our original design.
	15. Lessons learned for discussion:
	16. We can further edit the final building by editing manipulators, as we did above, or by editing the control element
	/
	In this case, the control element is a simple Line Between Points.

	17. Place a new reference line anywhere within the terrain limits.  Make it 150 feet long or so. Use g Line Between Points.
	18. Place a new Building cell “on” the new reference line.
	19. Move the new reference line of the new building.
	Note that if you move the reference line of the original Building, you’ll notice that a great many other things change.  This is because the entrance road and parking lot are dependent on the reference line of the building.
	/
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	20. Open SitePlan3D_BEGIN_CivilCells.dgn in the C:\2013 Civil_LEARNing\BCR1WK2 - Getting Started in SS3 Bentley Civil Power Products\DATA\70_3D-Building-Site folder.  Most of the horizontal geometry has been laid out for you. We’ll inspect some of it ...
	21. Using the MicroStation Select tool,  Select the North_bound corridor south of the bridges by its green markers near the boundary of the corridor to Context Tool Bar and navigate to
	22. Open Cross Section Model.
	23. Data Point in View 7 to display the corridor’s Dynamic Sections.
	24. Navigate and examine the section.
	/

	25. Make View 8 with Default-3D  model active and then Reference in the Drainage.dgn
	26. Cut Dynamic Sections for corridor North_bound1. Using the MicroStation Select tool,  Select the northbound corridor, North_Bound1, north of the bridges by its green markers near the boundary of the corridor to Context Tool Bar and navigate to Open...
	27. Data Point in View 7 to display the corridor’s Dynamic Sections.
	28. Use the Navigation Tools at the top of the cross section view to examine the cross sections. Examine the area near the drainage structures on the northerly limits of the North_Bound1 corridor.
	29. Navigate to 1299+00. Note the drainage structure’s depth.
	30. Dismiss the Cross Sections by closing View 7.
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