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4.1 Objectives 
The purpose of this chapter is to show the user how to use the multiple tools available in 
Roadway Designer to achieve desired results for the design of the corridor. 

4.2 Setting up a Corridor 
Creating a corridor is the first step in starting the Roadway Designer File.  One corridor should 
be established for each alignment.  Setting up a corridor is equivalent to setting up a “Project 
Manager File” in Geopak.  The corridor file remembers all your design information to be used 
for this particular alignment.  
 

The name of the corridor should 
be the name of the cogo 
alignment or chain.    
 
The surface symbology is simply 
the symbology used to sisplay the 
corridor surface in the cross 
sectional view when the corridor 
is displayed as a target alias. The 
user can choose any of the 
symbologies from the drop down 
menu. 
 
The type refers to the geometric 
control for this corridor.  For 
Geopak this means the cogo 
alignments. 

Once the type is selected to Alignment, the user can choose the horizontal and vertical 
alignments to be used for the geometric control for this corridor.  The “PI Rounding Tangent” 
needs to be defined when using point to point chains and/or profiles.  This tells Roadway 
Designer how to round between your PI’s. 
 
If only designing a portion of the entire alignment for a corridor, then the user can select station 
limits.  Once the information is populated, select the Add button to add to the list box on the 
bottom half of the dialog. 
 
One Roadway Designer file (*ird) may contain multiple corridors. Remember this is a single 
user environment so if needing an alignment another designer is designing, it can be copied from 
another IRD file in ProjectWise.  This can be accomplished by selecting the “Copy From” 
option. 
 
The Change option is used for modifying an existing corridor.  The Copy option is used for when 
the same corridor needs to be created for alternate versions of the design.  So, for example, 
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designer A is to design 3 preliminary alternates for a main line.  Once one corridor is created, it 
can now be copied and modified slightly without having to start all over again from the 
beginning. 
 
The Close button is used to dismiss the dialog box. 

4.3 Basic Workflow for Creating a New Corridor 

1. Open the Roadway Designer Tool from the Corridor Modeler dialog box. 
2. Select Corridor Management from the “Corridor” Pulldown menu and populate the 

dialog box using the appropriate parameters. 
3. Select the “Close” button. 
4. Save *ird file. 

4.4 Multiple Templates 
Roadway Designer is a versatile tool that allows the user to use multiple design templates for one 
corridor.  The user should review the corridor and identify the possible locations for changes in 
the template before starting the corridor design in Roadway Designer. 

4.4.1.1 MULTIPLE TEMPLATE DROPS 
Anytime there is a situation where the design changes for example from a 2-lane to 4-lane, or 
from rural to urban; the user needs to insert or “drop” multiple templates in the corridor to 
achieve the desired results. This is accomplished thru the “Template Drop” command from the 
Corridor pulldown menu in Roadway Designer. 
 
The template drop command copies the templates from the library into the corridor file (*ird).  
The user can make modifications to the template within the IRD file without affecting any of the 
templates in the library. 

4.4.1.2 THE TEMPLATE DROP DIALOG 
 
Corridor - Selects the corridor available in the IRD file. 
 
Station Field - This field is the beginning of the station 
range for the template. 
 
Interval Field - This is the interval that Roadway 
Designer will view your cross sections.  Pay extra 
attention to this interval as it will affect the interval at 
which you can cut Geopak cross sections for sheets.  
The interval of Geopak cross sections can be a multiple 
higher than the interval specified thru the template drop 
dialog.  So for example, the interval set here is 25 feet, a 
user can then cut Geopak cross sections every 25, 50 or 
100 ft; however, not at 10 ft intervals. 
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The Library Template box allows the user to select any library available.  Once the library has 
been selected, the user can browse the folders to select the desired template. 
 
Once all the parameters have been defined as described above, then the user selects the “Add” 
button to add it to the “Current Template Drops” list.  The list will give specific information 
about that template drop such as station range and interval, name of template used, whether or 
not transitions from one template to another are enabled, where the template revisions are made 
and what library the template belongs to. 
 
This dialog box has colored text to alert the user of changes in alignment or templates in the 
library.  Red station text indicates the geometry of an alignment has been modified and the sation 
value is no longer valid.  To correct this issue, select the template drop, adjust the station in the 
field and select the “Change” option. A red template text indicates the template has been 
modified and is different from what is stored in the template library.  A red ITL indicates the 
template library from which the template was placed is not the template library currently open 
OR that the original template in the library has been modified.  The user at this point can ignore 
the changes in the original template OR synchronize his applied template to the library.  
However, any changes made within the IRD will be lost.  
 
The Preview window displays the template selected in the library template tree list in this dialog. 

4.5 Template Transitioning 
When multiple templates are used within one corridor, a 
transition from one to the other is introduced, and it will be 
shown in the plan view window of the Roadway Designer.  These 
transitions are shown as colored rectangles between the template 
drops. Template drops are shown as brown “pattern” (transverse) 
lines in the Roadway Designer plan view window.  
 
Different color transitions indicate the transition condition.  If template points of two different 
templates have the same name points, they will be automatically connected. This is the preferred 
condition; however, if the point names aren’t the same, then the point connection must be done 
manually by the user.  In this case, all transitions must be reviewed prior to processing the 
model. Below is a description of the different color transitions: 
 

1. A red color transition means that none of the template points are connected because the 
point names between the two templates are not similar. 

2. A yellow color transition means that some of the points are connected by similar name, 
but connections still need to be made. 

3. A light blue color means that not all the points are connected, but the transition has been 
reviewed. 

4. A dark blue color means all the points are connected and reviewed. 
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4.5.1 Transition Editing 
To review the transition areas, double-click on the transition area in the Plan View window.  This 
displays the Edit Transition dialog which shows the point connections between the two 
templates. 
 

 
 
Bold color points indicate no connection.  Point connections 
can be made by clicking on any bold color point followed by 
a click on appropriate connecting point.  A single point can 
have more than one connection to that point. To remove a 
connection line, right-click on the line and select Delete. 
 

 
This window provides a 3D view and it can be 
manipulated using the view controls located a 
the bottom of the view. To move the template 
in the view, right-click on any template point 
and select Move Template.  Moving template 
makes it easier to edit. 
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4.5.2 Transition Testing 
After te points are connected, the transitioning is reviewed and edited in the Edit Transition 
Midpoint dialog.  This dialog display a cross section view of two templates as they transition.  
The display starts at the transition midpoint between the two templates, but can be viewed at the 
beginning, ending or any point in between.   
 
If the user desires to change point properties, double click on any point to bring the Point 
Properties dialog. 
 

 

4.6 Template Point Controls 
Point controls are used to override the established horizontal and vertical locations of points  
from the original template in the library.  Point controls are the equivalent of the criteria adhocs 
placed on plan graphics with D&C Manager to control widths, ditch slopes, etc.  Point controls 
then are used to control horizontal and vertical locations for EOP, EOS, sidewalks, retaining 
walls, barriers, special ditch profiles and ditch widths, etc. 
 



Chapter 4  GEOPAK Roadway Designer 

4-6 Missouri Department of Transportation 8/9/11 

This tool can be accessed thru the “Corridor” pulldown menu.  It displays the active corridor 
name.  It is highly recommendable to type in a description of what the point control is 
controlling.  For example “controlling the PGL to the inside of pavement for EBL”.  
 
Point controls are extremely powerful and they override any other type of template constraints.  
 

 
 

Point - It allows the user to select the point in the template to be controlled. It can either be 
selected from the dropdown menu, or the user can graphically selected from the cross-sectional 
view in the Roadway Designer dialog. 
 
Station Limits - Specify the range of stations to apply the point controls. 
 
Mode - Allows you to select the method of controlling the specific point.  The choices include 
horizontal, vertical, or both. The user can also apply offsets to the horizontal or vertical control 
points. 
 
Control Type - The choices available will depend on the mode selected. When selecting 
Horizontal or Both, the control type choices will include: Alignment, Feature, Style, or Corridor 
Point.  When selecting Vertical, valid control types will include Alignment, Feature (an InRoads 
option only – IGNORE for Geopak), Style, Corridor Point, Superelevation, Cant, Elevation 
Difference, Elevation and Grade. 
 
The most commonly used control types are Alignment, Superlevation, Corridor Point.  
Alignments allow you to control points based on cogo chains and profiles, often used for 
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controlling location and elevation of EOP’s, PGL’s, Special Ditch Profiles.  Superelevation is a 
special type of point control and it will be covered in a later section.  Corridor Point is used when 
a point needs to be tied to another corridor point like a “matchline” concept.  
 
Use as Secondary Alignment - Only toggle on this option if that point control should be used as 
a secondary alignment location.  Secondary alignments are used as a method to change the 
direction of the cross section processing.  This would be the equivalent of a “bent” pattern line.  
This option is used when needing to connect to entrance radius returns. 
 
Priority - is set for determining which control point overrides another in the case there is a 
conflict.  Lower numbers have highest priority, so priority 1 overrides priority 2. 
 
Add - This button allows the user to add the point control to the list box on the bottom of the 
dialog. 
 
Change - Allows for modification of an already created point control. 
 
Help - Will bring up the help for this particular dialog. 
 
Close - Will dismiss the dialog. 
 
Delete - Will delete the point control selected in the list box. 

4.7 Superelevation 
The superelevation points are special types of point controls.  Roadway Designer has various 
methods for calculating superelevation for the corridor. For the purposes of this class, importing 
superelevation input file from Geopak will be shown. 
 
The superelevation tools can be accessed from the “Superelevation” pull down menu in the 
Roadway Designer dialog. Superelevation>>Import Superelevation From INP file. 
 

Section - Type in the name 
of the alignment. 
 
File - Select the GEOPAK 
input file from the stored 
location. 
 
Point - Identifies the left 
range point of the section.   
 
 

Offset - Similar to the offset in Geopak, it identifies the offset at which the cross slope is being 
applied. 
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Pivot Point - Identifies the reference pivot point for the cross slope being applied. 
 
Station - Identifies the beginning station where the cross slope is being applied. 
 
Cross slope - Identifies the % cross slope being applied. 
 
Apply - It applies the superelevation points for establishing the control points in Roadway 
Designer. 
 
Cancel - It dismisses the dialog box without applying the superelevation points. 
 
Help - It brings up the help for this particular tool. 
 

4.8 Parametric Constraints 
Parametric constraints are used to override the original constraints established in the template 
from the library being used.  The tool can be accessed thru the Tools pulldown menu in the 
Roadway Designer dialog. 
 
The parametric constraints are the equivalent of a redefinable variable.  So, the names of the 
parametric constraints established in MoDOT Template Library mirrors the criteria names as 
much as possible.   

Corridor - Displays the name of 
the active corridor. 
 
Constraint Label - Lists all 
labeled constraints in the design. 
He selected label receives the 
override. 
 
Start/Stop Value - Specifies the 
transition from the first parametric 
value at the start and stop values. 
 
Station Limits - Specify the 
start/stop station for the override. 
 
Override Values List Box - It 
lists all the override values 

established for this corridor. 
 
Add - Adds values to the override values list box. 
 
Close - Dismisses the dialog box. 
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Change - Changes values of the selected item in the list box. 
 
Help - Brings up the help for this particular tool. 
 
Import/Export - Allows the user to either import/export parametric constraints from/to an 
ASCII file. 
 
Delete - Allows you to delete the selected parametric constraint value in the list box. 

4.9 Design Changes 
The lifecycle of a roadway project is long, and complex.  Changes must be done to accommodate 
for unforeseen situations or to stay within budget.  The Roadway Designer tool offers the 
flexibility to allow these design changes. 

4.9.1 Coordinate Geometry Alignment Changes 
Once the alignments are 
imported from the GPK file 
into Roadway Designer via 
the Corridor Modeler, the 
user can go back to Geopak 
and modify alignments thru 
COGO. If that happens, 
next time the user opens the 
Corridor Modeler dialog, 
the alignments in the 
Geometry tab will appear in 
different colors.  Red means an alignment has been deleted, and blue means it has been modified 
alerting the user to find a solution. Geometry will need to be reimported. 

4.9.2 Planview Geometry Changes 
Similarly, if planview 
graphics are deleted or 
modified, next time the user 
opens the Corridor Modeler 
dialog, he/she will be alerted 
of such changes. 
 
The user must re-import any 
changes or modifications thru 
the Plan Graphics tab in 
corridor modeler and verify 
the modifications thru the ALG viewer tab. 
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4.9.3 Template Library Synchronization 
As discussed previously, changes to the template can be made either in the Roadway Design file 
(IRD) or in the template library.  Where a user makes the changes for his/her template depends 
on the circumstances and needs to be reviewed on a case by case basis. 
 
Template Drop Indicators 
 
Station – Red: Station does not exist on alignment 
 
Template – Red: Edited or not synchronized 
 
Template – Blue: Does not exist in template library 
 
Revised in – Red: Edited single station or wrong template library 
 

 
 
Any changes made in the template library can be obtained by synchronizing the template drops 
with the library. 

4.10 Basic Design Workflow with Roadway Designer 
1. Set up a corridor 
2. Insert template drops as needed 
3. Create any template point controls 
4. Design superelevation 
5. Set parametric constraints as needed 
6. Review design 
7. Make revisions as needed and re-review 
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4.11 Group Exercise 4-1: SuperElevation, Template Transition, and 
End Condition Exceptions. 

 
1) Select the Open Roadway Designer icon. 

 

 
 

 
2) From the Roadway Designer Corridor pull-down select Corridor Management: 
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3) Add in the following corridor information for Road1. 
 

 
 

 
4) From the Roadway Designer Corridor pull-down select Template Drops. 
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5) Under the Road1 folder, apply the 2-Lane Urban template to the Road1 corridor at 
Station 0+00 and 25+29. 

 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Chapter 4  GEOPAK Roadway Designer 

4-14 Missouri Department of Transportation 8/9/11 

6) This time apply the 2-Lane Rural template to the Road1 corridor stating at Sta. 25+30.    
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7) Before moving onto other topics in Roadway Designer, save the Roadway Designer 

settings by selecting File > Save As 
 

 
 

 
 

 
 

8) Open the dtm.dgn 
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9) From the Roadway Designer Corridor pull-down select Create Surface. 

 

 
 

 
10) Setup the Create Surface dialog as follows.  Use a Surface Name that has not been used 

already. 
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11) Modify the Display Style in the dgn’s View Attributes to Filled Hidden Line. 

 

 
 

 
12) Using the View Rotation tool rotate the view to see 3D effects of Road1 corridor. 

 

 
 

 
13) Open the plan.dgn 
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14) Apply SuperElevation using the Import Superelevation from .INP file Tool. 
 
Select Superelevation > Import Superelevation from INP file. 
 
Section:ROAD1 
File: Shape_Road1.inp 
Point at -12 offset: Pvmt_Surf_Conc_T1_L 
Point at 12 offset: Pvmt_Surf_Conc_T1_R 
Pivot Point: Pvmt_Surf_Conc_T 
 

  
 

 
 
 

 
 
 
 
 
 
 
 
 
 

Pvmt_Surf_Conc_T1_L 
 

Pvmt_Surf_Conc_T1_R 
 

Pvmt_Surf_Conc_T 
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15) Review the Superelevation View in Roadway Designer. 
  

Toggle on Superelevation in the lower right corner of Roadway Designer.  
 

 
 
Before going to the next step switch back to the Normal View. 
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16) Review the Point Control dialog in Roadway Designer. 
 

Select Corridor > Point Control 
 

  
 

Point Control    Highest Priority  
 
Style Constraint     
 
Parametric Constraint 
 
Point Constraint   Lowest Priority 

 
 

17) Next the shoulders need to be fixed to follow the superelevation transitions.  To do this 
we will need to apply a shoulder rollover lock. 

 
Select Superelevation > Apply Shoulder Rollover Lock 
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18) Within the shoulder rollover lock dialog set the Station Range for the sections of Road1 

where there are shoulders. 
 

  
 
 

Apply the Rollover Lock two times at the following locations by selecting the button that is 
to the left of the “Apply” button: 
 

 
 

 
19) Once again review the Point Control dialog in Roadway Designer. 
 

Select Corridor > Point Control 
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20) Next we want to tell Roadway Designer how to transition from a Urban to the Rural 

template.   At station 25+29 double click on the “Yellow Shape”   (You might have to 
zoom in to see the shape, its only 1ft wide) 

 
Remember “Yellow” means that some of the points are connected by similar names, but 
connections still need to be made. 
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21) In the following dialog connect the point on how the templates should transition. 

 
Tip: When joining points that have similar linestyles, connect all in the same direction.  For 
example; with the C&G linestyles it would be best to go from 25+29 to 25+30, with the 
pavement linestyles it would be best to go in the opposite direction.  
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22) Connect points as indicated below:   
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23) When done connecting the points select “OK” button in upper right hand corner of 

dialog. 

 
 

 
24) In the Edit Midpoint Dialog below release the following constraints:  When the 

constraints are release the points will change color from Red to Green (No Constraints) or 
Red to Yellow (One Constraint). 

 
  Delete both Constraints. 
 
 Release Vertical Constraint. 
 

 
 

Once the points constraints are released test the transition using the side bar in the bottom 
left-hand corner. 
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25) You should now see a Dark Blue shape in the 1ft wide transition area. 
 
Remember “Dark Blue” means all the points are connected and reviewed. 
 
 
 

 
 
 

26) Open the dtm.dgn.  If in the DGN select all graphics and delete. 
 

 
27) From the Roadway Designer Corridor pull-down select Create Surface. 
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28) Add in the following Create Surface information; type in a Name that has not been used 
before.  Roadway Designer will not automatically replace a existing surface file. 

 
 

  
 

 
29) Review Transition area.  You can see a gap because when tapering a component from its 

full section down to nothing, it will not display over the last interval because it 
technically does not exist at the last station.  For example, in your dataset, the curb and 
gutter component is gone by station 25+30, so there is nothing to display. 

  
There are ways to fill in the gaps in the “Component View” but that will be covered in a 
more advanced class. 
 
Using the Load DTM tool, display the tin file from surface created above to see that the 
transition has truly resolved the “GAP” area. 
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30) Next adjust the shoulder width to 10ft from Sta. 28+00 to the end of the Road1 chain. 

 
 

 
 
 
 
 
 
 
 
To do this we are going to use a Parametric Constraint.  Think of Parametric Constraints as 
the same as a Redefinable Variable with the Typical Section Generator. 
 
Select Tools > Parametric Constraints.  Set the Shldr_Layer_1_Aggr_Width = 10ft 
 

 
 
Review the sections in the Roadway Designer XS view:  Notice the added Green Points that 
have been added to the outside of the shoulders. 
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31) In the next section we are going to address a subject called End Condition Exceptions.  

Observe in the plan view section of Roadway Designer the  several Red Rectangles on 
each side of the roadway.  These indicate areas of transition zone for the end condition 
from one section to the next. 
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32) Between stations 9+50 to 10+00 on the left side of Road1 view the End Condition 

conflict depicted by a red rectangle in the Plan View of Roadway Designer. 
 

At section 9+50 we are in a “Cut” situation. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 

At section 10+00 we are in a “Fill” situation. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
Red Color - End Condition points are not connected because the point names between two 
End Condition are not similar. 
 
Light Blue Color - End Condition has been reviewed. 
 
Dark Blue Color - End Condition has been resolved. 
 
 
 
Double click on red rectangle and continue to next page. 
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33) After double clicking on Red Rectangle the following dialog should appear.  Toggle on 

“Left Transition” and select the “Add” button. 
 

 
 

After selecting the add button the red rectangle should then appear Dark Blue. 
 

Select the Edit buton in the lower right hand corner to edit the End Condition. 
 

Thick Green (+) symbols are points that have not been connected to a point at the other end 
of the transition. To graphically begin the connections, left click over a point. You can move 
the templates to get a better view of how the points are connected. To move a template, right 
click over one point and select the Move Template command. Multiple points can connect to 
a single point. To remove a connection, right click over the connecting line and select Delete. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Once connections have been made select OK 
 

Once the connections have been made select “Okay”. 
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34) The Edit Transition Midpoint state of the dialog allows you to review how the 

components appear at the midpoint of the transition. Use the slider to visually test the 
connections along the entire transition. To modify the connections, select Cancel to return 
edit mode. 
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35) Once done editing the End Condition Transition review results in Roadway Designer plan 

view: 
 

 
 
 

36) Continue to resolve remaining end condition transition conflicts for Road 1  
 

 
37) After resolving last conflict build a model (dtm) for Road1.  This will be model (dtm) 

will be used in the next chapter when we create Cross Sections. 
 

 
38) Save J2P0200.ird file. 
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