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2.1 Objectives 
The objective of this chapter is to give the user an overview of the Roadway Designer Tool and 
the design workflow using this tool.  The user will learn how to access the tool, set preferences, 
navigate through the create template and roadway designer dialog boxes.  

2.2 Roadway Designer Workflow 
Roadway Designer is one of many tools designers can use to design highway corridors.  This 
concept utilizes a model-centric approach.  Consequently, the user must create the model before 
creating cross sections, which is the opposite of the traditional GEOPAK highway design cross 
section design approach. 
 
The flowchart below shows a design workflow for preparing highway construction contract plans 
using GEOPAK.  Please note the addition of the model-centric design workflow. 
 

 

 

 
 

 
 

 
 

 
 
 
 
 
Once all alignments, profiles and superelevation are designed, the designer can start using the 
Roadway Designer tool to create the roadway(s) model(s).   

2.3 Create Template Dialog 
The first step to creating a 3D model is to create templates for the roadway design. Templates are 
dynamic typical sections used in Roadway Designer that use transverse geometry to create 3D 
models.  Each template contains a series of points and components that represent breaklines, 
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which are used to create the roadway surfaces.  All these points, components, and templates are 
stored in the template library (itl). 
 
CADD Support has created a default template library.  This library contains most used 
components and end conditions at MoDOT.  A limited number of templates are available 
through this template library.  The intent is for the user to assemble his/her own templates giving 
the districts more flexibility in their design; therefore, the default MoDOT library is copied the 
user’s working directory using the Start Job routine when creating new projects. 
 
The user accesses all templates available in the standard MoDOT template library.  In addition, 
this is the tool to use to create new components and templates to be used within Roadway 
Designer. 
 
To access the Create Template Dialog, select the icon 
through the Corridor Modeler dialog. 
 
The Create Template Dialog is composed of three major areas: Folder Tree Window, Current 
Template Window, and the Template Preview Window, which are shown below. 
 

 

 

2.3.1 Folder Tree Window 
This view allows the user to navigate through the template library selected.  The folder tree 
structure begins with the template library.  Underneath, the user will find the following 
categories: Point Name List, Components Folder, End Conditions Folder, CADD Support 
Templates, and District User Templates. This window is completely user definable, and it has all 
windows capabilities like right click functions, copy, paste, drag and drop. 
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2.3.1.1 POINT NAME LIST 
This list contains previously created names to be utilized in the creation of new points for 
creating components for templates. Each point on a template must be unique, so no point can 
have the same name.  CADD Support has created a point name list for standardization. 

2.3.1.2 COMPONENTS 
A component is a set of points defining an open or closed shape that represent different portions 
of the template.  For example, pavement structure, curbs, gutters, shoulders, medians, retaining 
walls, etc.  MoDOT default library has many components from which to choose to create 
templates.  These components are organized in categories according to functionality.  These 
components do not include side slope conditions. 

2.3.1.3 END CONDITIONS 
End conditions are simply side slope condition components that tie to existing ground.  These 
include fill slope, cut slopes, ditches and/or combination thereof. 

2.3.1.4 CADD SUPPORT TEMPLATES 
The MoDOT standard template library will contain a limited number of templates.  Only these 
templates will be housed in this folder.  

2.3.1.5 DISTRICT USER TEMPLATES 
The user will save the template library in his/her working directory and 
will be able to modify the library by adding new templates or 
components.  Any templates created by a district user should be stored in 
this folder.   

2.4 Preview Template Window  
The template preview window shows the template that is highlighted in the folder tree view.  A 
Cyan color box denotes the placement location for that template.  Usually this is at the origin of 
the template, but the user can click on any point to move the placement point location. The user 
can drag and drop from the preview are to the current template window. 

2.5 Current Template Window 
This is the large window on the right hand side of the Create Template Dialog where templates 
are assembled and edited.  The current template window shows the user the name, description 
and design of the template currently being edited, reviewed or assembled.   
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2.5.1 Display Options 
The two radio buttons allow the user to choose what to display in the center window.  The 
components option shows the typical section component/template picture.  The constraints 
option show how each point in the component/template is constrained to each other.  Constraints 
will be covered in another section. 
 
There are two check boxes the user can select for displaying various portions of the template.  
When the Display Point Names option is checked on, all the point names in the current template 
are displayed.  Point names are long and when displayed the window can be too cluttered. 
Sometimes templates have hidden components controlled by certain design design situations. 
This concept will be discussed in a later chapter. When the Display All Components option is 
selected, these hidden components are displayed.  

2.5.2 Center Window 
The center window is the main graph for creating/modifying templates.  This window has its 
own graphics engine and so it is not a MicroStation window. The scale of the graph is dynamic 
and changes as you zoom in and out.   
 
The center point of the window is marked by the dynamic origin, which is a magenta-colored 
box.  The dynamic origin is used as a reference point and can be moved to any location in the 
graph. 

2.5.3 View Commands 
These commands are similar to the MicroStation view commands.  They allow the user to 
perform the standard zoom in/out, zoom in/out in the X direction, zoom in/out in the Y direction; 
window in an area, and fit the view, undo, redo, and set dynamic settings.  
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2.5.4 Testing End Conditions 
Test – Opens the Test End Conditions dialog box.  This tool allows the user to test the end 
condition solutions. 
 

 
This tool displays the current template; the non-solved end conditions and their child 
components are displayed in dashed lines.  The normal components and solved end conditions 
are displayed as solid lines. 
 
The Available Targets area lists all of the targets available whether they are surfaces or specific 
styles. The user simply selects the desired target, sets the Surface Slope, and then clicks on 
Draw to test. The Surface Slope is the slope of the surface that is being placed. The Reset button 
clears all the drawn targets. 
 
Display Rules - list the display rules for the current template. Left-click over a value to toggle 
between True and False.  Press the Reset button to restore the original Display Rules values. 
 
Failure Report – activates the Results dialog.  When a template fails to get a solution on one or 
both sides, the results show which components failed and which end condition start points were 
not solved. 
 
Check Priorities – tests the template for priority conflicts.   Each end conditions starting at the 
same point has a priority assigned, and must be unique.  When a conflict exists, a message is 
displayed indicating there are end conditions starting at the same point having the same priority 
assigned.  If there are no conflicts, a message box indicating no conflicts is displayed. 
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Check Duplicates – checks for duplicate feature and component names for the given solution. If 
duplicate feature or component names are found, the Duplicate Feature Name List dialog is 
displayed. If no duplicates are found, a message to this effect is displayed.  
 
Close – dismisses the dialog. 
 
Help – displays the help for this dialog. 

2.6 Dynamic Settings 
Similarly to the MicroStation Accudraw tool, the Dynamic Settings 
are used for precision input of the template components and to 
assign point names and styles when creating components. 
 
It also serves as a compass for the cursor location with respect to the 
dynamic origin.  The dynamic origin can be modified by using the 
“Set Dynamic Origin” at the bottom of the dialog box. 

2.6.1 Accessing the Dynamic Settings 
The Dynamic Settings can be accessed by selecting Tools>Dynamic Settings or by using the 
view control icon . The dynamics settings should be set to x = 0.1, y = 0.1 before creating 
templates. 

2.6.2 Precision Key-In Commands 
XY = Key-in absolute coordinates (x, y) 
DL = Key-in delta coordinates from last point placed (defaults to the dynamic origin if it is the 

first point of a component 
HS = Key-in horizontal delta distance and slope from last point placed 
VS = Key-in vertical delta distance and slope from last point placed 
OL = Key-in delta coordinates from dynamic origin 
OS = Key-in horizontal delta distance and slope from dynamic origin 
  

2.7 Creating Templates from Components 
Templates can be assembled by dragging and dropping components and end conditions into the 
Current Template window one at a time.   
 
Each point on a component has a unique point name.  These point names are created without 
being specific to “left” or “right” side of the roadway.  The user assigns a prefix or suffix to 
determine “left” or “right” when creating the template via the Dynamic Settings. 
 
Creating components will be covered in a later chapter. 

2.7.1 Dragging and Dropping Components 
When two points coincide, a heavy white plus sign will appear.  When connecting two 
components together, the existing connection point name will override the dropped point name.  
Dynamic Settings should be set before starting to drag and drop components to create a template. 
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Once a component is created, it can be modified by editing any property, inserting new points, or 
creating display rules. Once two or more components have been combined, they can also be 
merged. 
 
To edit components, simply right-click between the components to access the editing commands.  
 

 

2.7.2 Basic Template Creation Workflow 
• Open Template Library 
• From the folder tree view, right-click and select Create > New Template 
• “Drag and drop” template components 
• Merge Components 
• Verify Point Names 
• Save the Template Library 

2.8 Pull Down Menus 
File – allows the user to create a new template library, new folder, or new template; open another 
library, save the current library, or import a template from another library. 
 
Edit – has the common Windows commands undo, redo, cut, copy, paste, clear, delete, and 
rename. 
 
Add – has all the options for developing new components. Components are covered in a later 
chapter. 
 
The Tools menu offers several tools to manage the template library, but the only two tools 
pertaining to the MoDOT template library are the Dynamic Settings covered in section 2.6 and 
the Template Library Organizer, which allows the user to copy components and templates 
from one library to another. 
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2.9 Roadway Designer Dialog 

2.9.1 Roadway Designer Fundamentals 
Roadway Designer combines all alignments, surfaces and templates to create a proposed 
roadway model.  It also applies superelevation to the design, and all of this design data is stored 
in “the Roadway Design file” known as an *.ird file. 
 
This tool is used for managing and designing corridors and producing surface models in 3D.  In 
order to use the Roadway Designer tool, the user must have the following: 

• Existing Surface (from photogrammetry, survey, or both) 
• Horizontal and Vertical Alignments 
• Detailed Typical Section(s) for the corridor(s) 
• Superelevation information 
• Plan view geometry of the corridor such as EOP’s, EOS, sidewalks, C&G, entrances, etc. 

 
Once all the design information is entered in Roadway Designer, the user saves it to a Roadway 
Designer File (.ird extension). 
 
The Roadway Design tool can be selected from the Corridor 
Modeler dialog. 
 
The main dialog is occupied by 3 views (4 views when 
superelevation or overlay is displayed). The main three 
views are Plan, Profile, and Cross-Section view at the 
current station. 
 
The bottom portion of the dialog displays the name of the 
current corridor, active surface, current station, cross 
section interval, and the template being used at that 
particular section.  The user can navigate through the 
corridor by using the navigation buttons.  
 
For each view there are three display modes: normal, superelevation and overlay.  Depending 
which one of the modes is selected, the threw windows will display different contents. 
The Process All button processes all the cross sections in the corridor using the specified criteria, 
and updates all the display windows with the results.  Process Visible Range processes only 
within the visible range of the windows. 

2.9.2 Plan View Window 
This window shows the corridor’s centerline alignment, cut-fill lines, and original ground surface 
perimeter.  It also shows civil design data and associated stationing, but not Microstation 
graphics. 

2.9.2.1 NORMAL MODE 
In this view, it displays the plan view of the current corridor design.  The outlines of other 
corridors that have already been processed can also be shown. 
 



GEOPAK Roadway Designer Chapter 2: Overview 

7/5/11 Missouri Department of Transportation 2-9 

Transition zones are displayed in yellow.  A transition happens when there is a change in 
template from one station to the next. 

2.9.2.2 SUPERELEVATION OR OVERLAY MODE 
The plan view displays the top of the back bone (center of template with no end conditions) in 
various colors that represent the cross-slopes. 
 
White: cross-slopes with values less than 0.5% 
Green-blue: cross-slopes with values 0.5% to 10% to the right 
Dark Blue: cross-slopes with values greater than 10% to the right 
Yellow-Red: cross-slopes with values 0.5% to 10% to the left 
Dark Red: cross-slopes with values greater than 10% to the left 

2.9.3 Profile View Window 
This window shows the profile view of the 
current corridor design.  

2.9.3.1 NORMAL MODE 
In this mode, the active corridor vertical 
alignment and the existing ground profile 
from the active surface are displayed.  The 
vertical points appear as white “+” symbols.  
Hovering over the point displays the point 
type and station. 

2.9.3.2 SUPERELEVATION MODE 
In this mode, the profile diagram displays the profile grade line of all the top of backbone points 
in the design.  To control which points are displayed, right click in the view to bring up the point 
display list and select or de-select the appropriate points.  The color of the lines represents the 
cross-slope color to the right of the line.  The rightmost line is always white. 
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2.9.3.3 OVERLAY MODE 
In this mode, the profile grade is displayed as defined in the Corridor management dialog, and 
the adjusted profile grade is displayed. 

2.9.4 Cross Section View Window 
This window displays the cross-section design solution at the current station. The view shows 
original ground for the active surface selected as well as the proposed template solution. 

2.9.4.1 NORMAL MODE 
In this mode, the entire cross section is shown. Hover over 
any line to display information about that line and about the 
component it belongs to. Hover over a vertex to display 
information about that point. 
 
Right click on a point in the cross-section view to directly 
edit the point control(s) and/or parametric constraints 
affecting a point. This applies only to points that have a 
point control or parametric constraint affecting it.  

2.9.4.2 SUPERELEVATION MODE 
In this mode, only the top of the backbone is displayed.  The 
line segments are color-coded based on their cross-slope 
using the same color values as described under 
superelevation mode for the plan display.  

2.9.4.3 OVERLAY MODE 
In this mode, the overlay adjustment value is displayed. The overlay adjustment value is the 
difference between the profile defined in profile management and the adjusted profile. 

2.9.5 Pull Down Menus and Icons 
Pull down menus and icons corresponding to the 
menus are located at the top of the dialog.  
 
These tools will be covered in full detail in later chapters. 

2.9.5.1 FILE MENU 
This menu contains the common Windows file commands: Open, Save, Save as, and Close 

2.9.5.2 CORRIDOR MENU 
The corridor menu contains all the commands to create or set up the corridor design.  These 
commands can be accessed via pull down menu or via icons across the top, and they include: 
Corridor Management, Template Drops, Point Controls, end Condition Exceptions, Display 
References, Secondary Alignments, Key Stations, and Create Surface. 
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2.9.5.3 SUPERELEVATION MENU 
As the name indicates, this menu provides all the tools to input the superelevation design for the 
corridor. Even though Roadway Designer reads GEOPAK shape input files, the tool offers a 
variety of options for superelevation input. 

2.9.5.4 TOOLS MENU 
This menu offers another set of tools to add design features and options to maximize the design. 
A design corridor must exist in order to utilize these tools. 

2.9.5.5 OVERLAY TOOLS 
This menu provides tools to optimize the design for overlay projects such as cross-slope 
optimization, making vertical overlay adjustments, etc.  This pull-down menu is only activated 
when the overlay mode is selected from the cross sectional view. 

2.9.6 Corridor Management Command 
This tool is used to specify the horizontal and vertical alignment to be used for the design 
corridor.  Each corridor must be entered individually.  This information is then saved to the IRD 
file. 

2.9.7 Template Drops Command 
This tool is used to specify what template(s) to use for the corridor.  There can be multiple 
template drop locations. 

2.9.8 Create Surface Command 
This command is the last to use in the workflow of a Roadway Design project.  It combines the 
alignment created through the Corridor Management command and the templates specified in the 
through the Template Drop command to create a 3D model (an InRoads DTM) of the proposed 
Roadway Design corridor. This surface consists of the top surface of the roadway design and the 
subgrade components, which are “Excluded from Triangulation” points and children of the top 
surface.  Components can be displayed in cross sections and used for volume calculations. 

2.10 Roadway Designer Basic Workflow 
Once the existing TIN and the alignments and profiles are created in GEOPAK, and the typical 
sections are determined for the project, the following workflow should be followed: 

• Launch corridor modeler from the GEOPAK 3D tools 
• Create the RDP file and set up the preferences, import the geometry and original ground 

TIN, and select the template library  
• Load the template library 
• Load Roadway Design and create the IRD file 
• Create new corridor 
• Assign template drops 
• Create surfaces 
• Save IRD file 
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2.11 Group Exercise: Creating a Corridor and Surface 

1) Open the plan.dgn. 
  

 
2) Using Project Manager open the following project: 
 
    pw:\District CADD\Design\Cole\J2P0200\project\J2P0200.prj 
 

  
 

 

3) Select ClsUser as the project user. 
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4) From the GeoPak Road Tool Palette, select Corridor Modeling: 
 

 
 

 

5) Load the J2P0200.rdp file and verify the settings in the Preference section: 
 

 
 

 
6) Select the Open Create Template icon. 
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7) In Create Template dialog select “File > Save As” and save the MoDOT Library to the 
User’s Working Directory.  Name the file J2P0200.ITL 

 

 
 

 
8) In Create Template dialog select “File > New > Folder” and create a folder called 

“J2P0200”. 
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9) In Create Template dialog under the J2P0200 folder select “File > New > Folder” and 
create a folder called “Road1”. 

 

  
 

 
10) From the Templates folder Right click and copy and paste the “2 Lane Rural” and        

“2 Lane Urban” Templates into the Road1 Folder. 
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11) Review the 2-Lane Rural and Urban Templates in the Road1 folder. 
 

 
 

Save and then close your changes to the J2P0200.itl  
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12) In the Preferences section of Corridor Modeler, set the Template Library to the 
following: 

 
pw:\District CADD\Design\Cole\J2P0200\data\J2P0200.ITL 

 

 
 

 
13) In Corridor Modeling, select File > Save 
 

 

 
14) Select the Open Roadway Designer icon. 

 

 
 

 
 
 
 
 
 
 
 
 
 



Chapter 2: Overview  GEOPAK Roadway Designer 

2-18 Missouri Department of Transportation 7/5/11 

15) From the Roadway Designer Corridor pull-down select Corridor Management: 
 

 
 

 

16) Add in the following corridor information for Road1. 
 

 
 

 
17) From the Roadway Designer Corridor pull-down select Template Drops. 
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18) Under the Road1 folder, apply the 2-Lane Urban template to the Road1 corridor. 

 

 
 

 
19) This time apply the 2-Lane Rural template to the Road1 corridor stating at Sta. 25+30.  

Make Sure “Enable Transition” is clear
 

. 
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20) Open the dtm.dgn 
 

 
21) From the Roadway Designer Corridor pull-down select Create Surface. 

 

 
 

 
22) Setup the Create Surface dialog as follows.  Use a Surface Name that has not been used 

already. 
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23) Modify the Display Style in the dgn’s View Attributes to Filled Hidden Line. 
 

 
 

 
24) Using the View Rotation tool rotate the view to see 3D effects of Road1 corridor. 
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25) Save and Close Roadway designer. 
 

 
 
 
*** When typing in the Name and File name the ird extension must
 

 be included. 

 
Note:  The User might notice some gaps and no superelevation applied to the corridor, these 
issues will be addressed in future chapters. 
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2.12 Individual Exercise: Creating a Corridor and Surface 

1) Open the plan.dgn. 
  

 
2) Using Project Manager open the following project: 
 
    pw:\District CADD\Design\Cole\J2P0200\project\J2P0200.prj 
 

  
 

 

3) Select ClsUser as the project user. 
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4) From the GeoPak Road Tool Palette, select Corridor Modeling: 
 

 
 

 

5) Load the J2P0200.rdp file and verify the settings in the Preference section: 
 

 
 

 
6) Select the Open Create Template icon. 
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7) In Create Template dialog under the J2P0200 folder select “File > New > Folder” and 
create a folder called “Route63”. 

 

  
 

 
8) Right click, copy and paste the “4 Lane Major Rural” Templates into the Route63 

folder. 
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9) Review the 4 Lane Major Rural Templates in the Route63 folder. 
 

 
 

Save and then close your changes to the J2P0200.itl  
 

 
10) In Corridor Modeling, select the Open Roadway Designer icon. 
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11) In Roadway Designer make sure the J2P0200.ird is the active file. 
 

12) From the Roadway Designer Corridor pull-down select Corridor Management: 
 

 
 

 

13) Add in the following corridor information for Route63. 
 

 
 

 
14) Make sure the J2P0200 surface is active.       
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15) From the Roadway Designer Corridor pull-down select Template Drops. 
 

 
 

 
16) Under the Route63 folder, apply the 4-Lane Rural template to the Route63 corridor. 

 

 
 

 
17) Open the dtm.dgn.  In the DGN select all graphics and delete. 
 

 
 
 
 
 
 



GEOPAK Roadway Designer Chapter 2: Overview 

7/5/11 Missouri Department of Transportation 2-29 

18) From the Roadway Designer Corridor pull-down select Create Surface. 
 

 
 

 

19) Setup the Create Surface dialog as follows.  Use a Surface Name that has not been used 
already. 
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20) Modify the Display Style in the dgn’s View Attributes to Filled Hidden Line. 

 

 
 

 
21) Using the View Rotation tool rotate the view to see 3D effects of J2P0200 corridor. 

 

 
 
Note:  The User might notice some gaps and no superelevation applied to the corridor, these 
issues will be addressed in future chapters. 
 

 
22) Save and Close Roadway designer. 
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2.13 Review Quiz 
1. Which method is used to set a template as active in the Create Template dialog (select all 

that apply). 
A – Double click on the template name in the Template Library list 
B – Right click on the template name in the Template Library list and select Set Active 

 
2. True or False: The template preview window always shows the same template as the 

editing window. 
 

3. True or False: Points in a template (top surface and sub surface) are included in a single 
resulting design DTM. 
 

4. True or False: Multiple corridors can be created for a single project. 
 

5. True or False: Roadway Designer cannot use GEOPAK shape input files for setting 
superelevation. 
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