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Introduction to Bentley OnSite

Module Overview
In this module you will take intelligent electronic design data and move it to a handheld device, to provide field personnel the use of the data to perform stakeouts and inspections. This workshop demonstrates the steps to automate the movement of inspection, stakeout, and data collection information into a Field Data Product Database to increase inspector productivity.
Module Prerequisites

· Understanding of surveying principles

· Understanding of inspecting principles

· General understanding of D&C Manager
· General understanding of Quantity Manager
Module Objectives
Upon completion of this module, you will be able to:

· Create a Design Archive from multiple sources
· Inspect the data created from the Design Archive
· Create stake points and stakeout multiple parts of the design
· Use the Diary command to document detailed site information
· Generate as-builts from the Field Product Database
Introductory Knowledge
Before you begin this module, let’s define what you already know.
Questions

1.  Is a design archive the same thing as a project?
2.  Is a fence a linear feature?

3.  When you stake out a curb and gutter, what offset do you use to set your hub and tack?

a.
2’

b.
3’

c.
4’

d.
Whatever the contractor requires.

4.  Have you ever written notes on a piece of paper and when you needed the information, couldn’t find it?

5.  Have you ever been on a job site and thought things just didn’t look right?

 Answers
1. Yes. 

For InRoads users a project consists of Geometry files (*.alg), Drainage files (*.sdb), Quantity Manager files (*.mdb), Project Model Surfaces (*.dtm), Cad files (*.dgn or *.dwg)

For GEOPAK users a project could consist of Geometry files (*.xml), Drainage files (*.gdf), Quantity Manager files (*.mdb), Project Model Surfaces (*.gsf or *.tin), Cad files (*.dgn)

For Bentley MX users a project could consist of Cad Files (*.dgn),  Geometry files, Drainage files, Quantities files, Surfaces files. 
2. Yes

Inspection is broken up into 3 types: Each, Linear, and Area.

Features classified as Each typically include fire hydrant, power pole, mail box, light standard, and inlet.

Features classified as Linear typically include curb and gutter, striping for roads, piping, fencing.

Features classified as Area typically include sidewalks, concrete pads, asphalt, concrete ditches.

3. Whatever the contractor requires.
With Bentley OnSite you can stake points at any offset the contractor requires and if you need to change an offset at one station you can do it on the fly. 

4. Probably yes.

With Bentley OnSite you can take notes, pictures, make a sketch, even make a short audio file. The information can be stored at the location where the notes apply.

5. I think everyone has.

Eyes can be deceiving. With Bentley Onsite you have the drawings on your laptop or Pocket PC and you can walk to the exact point North, East, and Elevation.

Design Archive Creation

Bentley OnSite is broken up into two distinct applications: Bentley OnSite Administrator and Bentley Inspect/Stakeout. Bentley OnSite Administrator is used for creating the Design Archive, managing users, transferring projects, and creating reports. Bentley Inspect/Stakeout is used in the field for inspection, stakeout, data collection, and surface analysis.
The Design Archive is the common read-only format where design data is stored that enables you to Inspect and Stakeout those records in the field. Design Archives can be composed of one or multiple types of data. The following design data is supported: Geometry (from LandXML or InRoads .alg), Drainage (LandXML, GEOPAK.gdf, InRoads.sdb), Quantity Manager Databases (common format across Bentley Civil products), Surfaces (LandXML, GEOPAK.tin, GEOPAK.gsf, InRoads.dtm) CAD files (Microstation.dgn, AutoCad.dwg).
· Exercise: In this exercise we will import at least one of each of the different types of data, create a Design Archive and review the data in Bentley OnSite Administrator.

1. Start Bentley OnSite Administrator from either the shortcut on the desktop or from Start > All Programs > Bentley > OnSite > Administrator.
The Log in screen appears
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2. The User Name should be left as Administrator and there is no Password. Select Log In. 
User Names are used to keep track of all changes in a project. Every time a change is made to a project a User Name and time stamp is stored. This is used for keeping track of who did what and when in the field. For this topic we will be using only Administrator.
The main Administrator dialog appears.
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3. The project location needs to be set. Set the Project Data Location by selecting Preferences > Project Data Location, then browse and select the following directory C:\2008 RBUC\Introduction to Bentley OnSite\Data\Projects.
4. Select OK.
5. We now can begin creating a new project. Select New from the tool bar or select Project > New from the pull down menu.
The New Project dialog appears.
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6. Enter WS08 as the project name and OnSite Training as the Description. Select Imperial for the Unit and 2006 for the Spec Year.
7. Select Next.

8. Select the different types of design data to add to the Design Archive. On the New Project dialog select Geometry.
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9. From the Select Geometry Files dialog set the files of type to InRoads Geometry files (*.alg), then browse to: C:\2008 RBUC\Introduction to Bentley OnSite\Data\Design Data\ and select Meadow Park.alg.
The Geometry Filter dialog appears, allowing you select some or all of the data contained in the geometry file.
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10. Select OK.
The New Project dialog reappears. Notice that the Geometry file is added to the File List.
11. Select the Drainage button, set the files of type to InRoads Storm and Sanitary (*.sdb), the select the Meadow Park.sdb. Select Open
The Quantity Manager Database is next. Quantities can be extracted from Bentley GEOPAK, InRoads, and MX, through multiple tools. 
12. Select Quantity Manager DB, then select the Quantities.mdb and select Open.

Surfaces are handled a little differently. Bentley Administrator allows you to create categories for the surfaces to reside in. These categories enable you to quickly identify and turn on and off multiple items.
13.  Select the Project Model Surfaces button, then set the files of type to InRoads DTM (*.dtm), and select both the surfaces Meadow Park Existing.dtm and Meadow Park Proposed.dtm.
The Importing Surfaces from: dialog appears.
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14. Key in Existing in the Category for the Meadow Park Existing surface. Select Add and OK.
15. Key in Proposed for the Meadow Park Proposed surface. Select Add and OK.
16. Next select CADD File on the New project dialog. Notice you can add categories here also.
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17. Select Browse then select the Meadow Park Existing.dgn, next select Browse again and select Meadow Park Proposed.dgn and select OK.
We are now finished adding data to the Design Archive and your File List should look like this.
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18. Select Next, toggle on Administrator as the Username, and select Finish.
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19. Select OK on the Successful dialog.
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We have now completed creating the Design Archive.

· Exercise: Now that we have created the Design Archive let’s look at some of the common tools for navigating and review.

1. Select Open from the toolbar or from the pulldown menu select Project > Open, then select the newly created project and select Open.
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Notice the dialog has two tabs Feature and Spatial, the feature tab is a list view of what can be viewed in the spatial tab, and the spatial tab is a graphical view of what is turned on in the feature tab. The feature tab can be equated to the level manager in MicroStation. Here you can also see the categories as described in the previous exercise.

2. Take a few minutes toggling different parts of the design on and off through the feature tab and see how the view in the spatial tab is affected.
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Now that you have an understanding of how to modify the display, let’s take a look at how to navigate. At the bottom of the spatial tab you will find a tool bar, this toolbar is standard across both applications in Bentley OnSite. The first five buttons from the left are used for navigating, much like in MicroStation. Take a moment a use these five navigation commands.
The next three buttons are used for selection; the Plus button adds to the current selection the Minus button removes items from the current selection, and the C button clears the current selection. Being able to accurately create a selection set is very important, as it is the main tool for identifying objects to act upon in Bentley Inspect/Stakeout. 
3. Select one or more items and then select the Information button.

The Information button works much like the element information command in MicroStation giving you specific information about the current items in your selection set.

The last button is used to turn on and off the display of the Field Product Database, which is any field collected information. We will review this button in a different exercise.

4. Close Bentley Administrator by selecting Project > Exit.
Inspection

Inspection can be broken up into three types: Each, Linear, and Area. Depending upon what kind of inspection is done some of the options will differ. We will start with the simplest (Each) from a quantity database. A quantity database is not required to use inspection, but is the simplest way to do an inspection. In the next exercise we will do an inspection from graphics.

Note: When you are in Bentley Inspect/Stakeout, hover the mouse pointer over a button to see the name of the command.
· Exercise: Now that we’ve created a Design Archive and used Bentley Administrator, let’s take a look at the field software and how to do inspections.
1. Start Bentley Inspect/Stakeout from the shortcut on the desktop or from Start > All Programs > Bentley > OnSite > Inspect Stakeout.
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2. Select Accept (the green check). Just as with Bentley Administrator, we use the default User Name Administrator with no password.
Next we need to set the Project Directory.
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3. Use the Set Project Directory button to browse and select the following path: C:\2008 RBUC_West\Data\Projects. Select the WS08 project and select Accept.

The Bentley Inspect/Stakeout Main Menu appears.
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4. From the Main Menu you can access the core parts of the software. Select Inspection.

The Inspection Main View screen appears.
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Notice the toolbar at the bottom is the same navigation toolbar as in Bentley Administrator. The toolbar at the top will dynamically change depending upon what command you are in.
5. Hover the mouse pointer over the second button from the left to see the tool tip description. This is Feature/Spatial Query. It works much like the Feature/Spatial tab in Bentley Administrator.

6. Select Feature/Spatial Query.
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7. Under the Feature tab select the main category of WS08.

8. Select Unselect All (middle button on the right side), then toggle Quantities back on. Your feature tree should look like the one below.
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9. Select Accept to return to the Inspection Main View.

10. Window into the intersection in the center of the design, then using the selection tools add the Fire Hydrant in the SE quadrant of the intersection to your selection.
11. Select Inspection (first button on the left on the upper toolbar).
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Notice the dialog dynamically changes with the command. Select the GPS Shot button (second button from the left on the upper toolbar), and data point close to the fire hydrant. This simulates taking a shot on the hydrant as if you were in the field.
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12. Select the Notes tab. This allows you to add pictures, audio comments, sketches, and notes about the inspection. Then select the Sketch Tab, next select the camera button in the sketch, this will take a snapshot of what is currently on the screen, allowing you to do a markup. After taking a snapshot, take a moment and markup the sketch.
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13. After making your sketch, select the Graphics tab and select Accept. You have now completed your first inspection.

14. Select Back until you are back to the Inspection Main View.
· Exercise: Now that you have done a QM inspection let’s move on to inspecting cad graphics. In order to inspect graphics you must have a Master Pay Item list attached to your project. A Master Pay Item list had been previously assigned to your preferences, so your project already has one attached

1. Select Feature/Spatial Query and toggle off Quantities, Toggle on the CADD, then under the CADD category toggle off the Meadow Park Existing.cad file. 

We are now left with only the Meadow Park Proposed.cad, but we want all the levels under that file turned off except P_ROAD_CURB-BACK. Once you have finished isolating that level select Accept.
2. We now want to navigate to the east end of the project and inspect some of the Curb & Gutter on that end of the project.
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3. Select the curb line to the north that consists of the transition and the turnout.
4. Select Inspection.

5. The dialog will change to the PayItem/Feature tab, this is where we will assign a payitem to the graphics.

6. Select the All Records button to the right, this will load the entire payitem list.

7. Navigate to payitem 027710025, select the payitem, and select Accept.
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8. We are now ready to take simulated GPS shots on the selected curb. Ensure your point type is set to Line, then starting from the north end of the curb, take a GPS shot on the beginning of the transition and the end.

9. While still inspecting, change your point type to Curve and take three shots – one on the PC, one on the mid point, and one on the PT.
Notice as you take a GPS shot your amount of Curb is being totaled, also the design amount is displayed at the bottom.
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10. Select Accept, then select the Back button to return to the main inspection view.

· Exercise: Now that you have done a few inspections, let’s review the data.

1. Select Feature/Spatial Query, turn off the entire project category and select Accept. This will turn everything off except the field collected information.
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2. Window in on the Fire Hydrant we inspected earlier.

3. Select the Inspection record, and then select the Info button. This will display all the information pertaining to this inspection record.
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4. Scroll down until you see the underlined information about the sketch that you did earlier. The underline indicates a link. Select the link and a picture of the sketch will appear.
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5. Select the Back button, dismiss the Info dialog and review your other inspection record.
6. Once you are finished, review the data select the Back button until you have returned to the Main Inspect/Stakeout menu.
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Stakeout
We’ve done a few inspection records; let’s now take a look at the other side of the product, Stakeout.
· Exercise: When creating stake points, care must be taken that the preferences are set up for the type of stakes to be created, including staking interval, offset, and point types to be staked. Another consideration is what surfaces are active. For every surface that is active you will get a cut/fill to that surface for each point staked.

1. Select Stakeout from the Main Inspect/Stakeout menu.
2. Select Feature/Spatial Query. Turn on the project category, Drainage, Meadow Park Proposed.cad with all the levels, and Meadow Park Proposed Surface.
3.  Select Accept.
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4. Navigate and zoom into the East portion of the project, where the first curve is around station 17+50.
5. Select Stakeout (first button on the left on the upper toolbar).

6. Add the pipe that is crossing the roadway at about station 17+40 to your selection set.

7. Select Stakeout. This will create blue X’s at each end of the pipe, these are the points to be staked.
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8. Add the pipe to your selection set again, this time both the stake points will highlight. We are now ready to navigate to the points.

9. Select Navigate to Stake Point (first button on the left on the upper toolbar).

10. Notice the dialog changes to the Navigation screen. Since we are in the class room, we are using the GPS simulator and you will have to select the GPS shot multiple times until you get to the point. In the field, once you select navigate, your position constantly updates. Select the GPS shot button. The bottom portion of the dialog will tell you what direction and how far until you’ve reached your stake point.
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11. Continue to select the GPS shot button until the information screen opens. This indicates you are within acceptable tolerance. Select Accept. The information screen updates.
Notice the information given. You are given the cut/fill to any surfaces active and also to the pipe inverts.
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12. Since you selected both points to stakeout, continue to select the GPS shot button until you have completed staking out the other point.

13. Select the Back button until you have returned to the main Stakeout menu.

· Exercise: Bentley Inspect/Stakeout allows you to select an alignment, provide an interval, and create stake points perpendicularly at every surface vertex.
1. Select Active Alignment (fourth button from the left on the upper toolbar) and set the active alignment to Meadow Park Drive. Select Accept.
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2. Select XSections (fifth button from the left on the upper toolbar).
The screen changes to Cross Section Options.
3. Select Alignment Based (first button on the left on the upper toolbar). This allows us to specify the interval and offset used to create cross sections.
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4. Set the beginning station to 16+00 and the interval to 50. Select Accept.

5. Navigate to station 24+50. 

[image: image35.png]‘L a 9 <&
Plan
Elev: 219.96
20502

Sta: 24+50.00 ot 3897

™ G{ Q A ‘; ;’\24+50.oo -
PDOP: 1.10

XSec Views Sv: 4





6. Select Stakeout XSection (first button on the left on the upper toolbar). This generates stake points for every vertex the cross section line crosses.

7. Select Back until you return to the Stakeout Main View.
8. Navigate to station 24+50. You should see the stake points you’ve created. Select Stakeout (first button from the left on the upper toolbar) twice until you are at the navigation screen, then select one or more of your newly created points, 
9. Select Navigate to Stake Point (first button on the left on the upper toolbar) and take a moment to stake out a few of these points.
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10. Select Back until you return to the Bentley Inspect/Stakeout Main Menu.
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Diary Entry

Diary Entries can be used to capture detailed information about the site that might otherwise not have a place to be stored.
· Exercise: Entries can be broken down into two categories, non-graphical and graphical. Just as in Inspection and Stakeout you can attach notes, sketches, pictures, and audio clips.
1. Select Diary from the Main Menu.
The screen changes to the Diary Entries Main View. On the right is a pull down menu with the different types of diary entries that have previously been created in the preferences.
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2. Select the Daily Entry Category.

3. Fill in the four values. Notice the last has a pull down menu limiting your options.

4. Once the data is filled in select New Diary Entry (first button on the left on the upper toolbar). 
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5. Select the entry and the select the Notes tab, then select the Text tab. Here you can enter more detailed information about the Daily Entry.
6. Once finished entering the data select the Diary tab.

· Exercise: Graphical diary entry.
1. Select Diary from the Diary Entries Main View.

2. Change the Category to Site Mark up.
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3. Enter a reason for the markup.

4. Select New Diary Entry (first button on the left on the upper toolbar).
5. Select the entry and then select the Notes tab.

6. Select the Picture tab, then select the Select button, brows to C:\2008 RBUC_West\Introduction to Bentley OnSite\Data\Design Data\ and select the Bentley.bmp picture. This will attach the picture to the diary record. You can preview the picture by selecting the image in the list.
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7. Select the Graphics tab, and then select Attach Diary (second button from the left on the upper toolbar).
8. Data point anywhere inside the graphics. This will geospatially locate your Diary entry.
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9. Select Back, then select Exit.

Project Review
Now that we’ve done some field inspection and stakeout, we’ll take that data back into Bentley Administrator.
· Exercise: Review, report, and generate as-built drawings.
1. Start Bentley OnSite Administrator from either the shortcut on the desktop or from Start > All Programs > Bentley > OnSite > Administrator.

The Log In screen appears. The User Name should be left as Administrator and there is no Password.
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2. Select Log In.
3. Select Project > Open, and select project WS08.
4. Turn fon the Main Project Category under the Feature tab.
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5. Select the Spatial tab. The screen should be blank.

6. Select FPDB Display (last button on the right on the lower toolbar).

7. Under the Users, Activities, and Status tabs select Select All. Select Accept. This will turn on everything that you have done in the field.
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8. Take a moment to review a few of the activities.
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· Exercise: As Built Creation
1. Select Reports > Field Data > FPDB -> DGN.
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2. The Select DGN File dialog opens. Browse to C:\2008 RBUC_West\Introduction to Bentley OnSite\Data\As Built\ and select MeadowParkAsBuilt.dgn.
3. After the Drawing file opens, you will see the FPDB -> DGN dialog. Select Apply.
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4. Select OK on the Import Complete dialog.
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5. Select File -> Models.
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6. Notice the three models in addition to the Default. These models were created at import and each corresponding activity has its own model. Double click on the Diary model.

7. Select the MicroStation Fit View command. You should see a single Diary Entry.
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8. Select Utilities -> MDL Applications. Select the Browse button and browse and select the following MDL Application: C:\Program Files\Bentley\OnSite\OnSiteAdministrator\fpdbviewer\fpdbrecordviewer.ma. 
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9. Select Open
10. Close the MDL and FPDB -> DGN dialogs.

11. The FPDB Record Viewer dialog should now be open. Toggle on Active.
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12. Hover over the Diary Entry and notice the MicroStation Tooltip. All the collected information about this item appears in the tooltip. Also any pictures or audio clips will open in the FPDB Links dialog.
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13. Single click on the picture in the FPDB Links dialog. The attached picture will open.
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14. Take a few minutes to switch to the other models and review that data.

Module Review
Now that you have completed this module, let’s measure what you have learned:
Questions

1. When you create a project using Bentley OnSite Administrator can you perform a feature/spatial query just like in Bentley Inspect/Stakeout?

2. Can you use curves and lines while inspecting a curb and gutter in Bentley Inspect/Stakeout?
3. When you draw a cross section in Stakeout are the stakeout points placed every ten feet?

4. Once you attach a diary to graphics can you add to the selection and get information on the diary symbol?

 Answers
1. Yes

You can look at all the features in the project you just created. You can also turn features on and off as in Bentley Inspect/Stakeout.

2. Yes
You select line when drawing a line. You select curve when drawing a curve, but you must have at least three points for a curve.

3. No
Stakeout points are placed at every vertex the cross section line crosses.

4. Yes
You can add the diary entry in the graphics to a selection set and select Information to review your diary entry. 

Module Summary

You are now able to:

· Create a Design Archive from multiple sources
· Inspect the data created from the Design Archive
· Create stake points and stakeout multiple parts of the design

· Use the Diary command to document detailed site information

· Generate as-builts from the Field Product Database
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