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Advanced Modeler
Overview
This workshop introduces experienced PowerCivil and GEOPAK Site designers to more advanced Modeler tools and procedures than are presented in the beginner level courses.  

The lessons contained herein cover a variety of situations that demonstrate use of Modeler tools in more complex design or in ways that are perhaps not readily anticipated by the average user.  The dataset used is a subdivision project but the tools and methods employed are applicable to a wide range of site design projects.

This workshop is an advanced course and assumes the student is already intimately familiar with the site modeler and its various tools.
Prerequisites

· User should have an intimate knowledge of the site modeler found in Bentley PowerCivil and GEOPAK Site.

· User should be fluent in terminology used in Bentley PowerCivil and GEOPAK Site.

· User should be a fluent and proficient user of Bentley MicroStation or Bentley PowerDraft

· User should have a strong knowledge of the engineering principles used on a site design project.

· The road network tools will be used in a portion of this workshop.  The user should be aware of the purposes and uses of the road network tools but not necessarily fluent in their use.  There is a companion workshop that covers the road network tools in detail.
Objectives
After completing this course, you will be able to:

· Apply the roadway design wizard to designing an existing road which will be widened.

· Add a raised median to a roadway which was previously designed using the road network tools.

· Edit a road’s composite section to add information to the template.

· Add a mid-block cul-de-sac to a roadway.

· Produce new revised cross-sections based on the previous two edits.

· Create a pond using the pond wizard.

· Add a retaining wall between two objects.

· Create a channel using the channel wizard.

· Edit the profile of the channel.

· Add a low-flow key-way to a pond.
Introduction

Warning: The user is encouraged to save the site project regularly and often for the duration of this workshop.  This is simply good practice for everyday use.  This manual will not instruct you to save since the target audience is of an advanced nature.   

This workshop will cover a wide range of tools and methods for dealing with more advanced aspects of site design.    The lessons contained herein are applied to specific examples on a subdivision dataset but are applicable in a general sense to a wide array of situations.

The tools we will use are:

· Road Network tools (Tools > Roadway Tool > Network (shown below))
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· Road design wizard (Tools > Roadway Tool > Create/Edit (shown above))

· Pond Wizard (Tools > Pond Design (shown above))

· Channel Wizard (Tools > Channel Design (shown above))

· New Site element tool (Element > New/Edit)

· Edit site profiles tools (Element > Edit Profile)

· Open an existing site project

1. Open the MicroStation file: …SubdivisionPlan.dgn.

2. Select the Site Modeling tool (Civil > Modeler) 

Hint: (In GEOPAK, the menu item is: Applications > GEOPAK Site > Site Modeler > Site Modeling).
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3. Enable Open Existing Project.

4. Click Browse and select: …SubdivisionPlan.gsf.
5. Click OK.

6. The Design and Computation manager has been set by the Modeler preferences. Let’s ensure that is the file currently in use.  Open Design and Computations Manager (Civil>Plans & Quantities>Design & Computations Manager).
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7. The current file should be site.ddb. 

Hint: If the current file is not site.ddb; Click File>Open, navigate to this file location and select the file.

8. Close the Design and Computation Manager tool.

· Review the project

In the MicroStation file you will find four roadways plus the existing road at the entrance.  Also, the road right-of-way lines and, a pond base has been drawn.  The graphics were created ahead of time using standard MicroStation drawings tools and represent the minimum geometric definitions that we need to perform the exercises.  The graphics shown represent the following:

· Centerlines – These must be complex elements (complex chains or line strings) not individual lines and curves.  They are drawn in the DGN using D&C feature “DesChains”

· Proposed Edges of Pavement – including the curb returns at intersections and cul-de-sac geometry.  They are drawn in the DGN using D&C feature “DesEofP”

· Join Lines in the intersections – these are the dashed lines drawn across the intersections which represent the edge of the through pavement between two intersecting roads.  This element will be included in both roadways to ensure a smooth transition between Objects.  They are drawn in the DGN using D&C feature “DesJoinLine”

· Cul-de-sac markers – These are circles drawn at the center of the cul-de-sacs so the tools know where to search for the cul-de-sac elements.  They are drawn in the DGN on level named “Culdesacmarker”

· Proposed Right-of-Way Lines – In this case, these are integral to the roadway grading design.  They are drawn in the DGN using D&C feature “LotsBlocks” 

· Pond base – this represents the floor of the detention pond.  It is drawn with D&C feature “DesPondBase”

· There are some lot lines and building locations that are not used in this manual but are a routine part of the layout of a subdivision.

Note: A careful review of the site topology will reveal that the pond is not located in the low point of the site.  This is due to the fact that a sizeable percentage of the site is covered by a power line easement on the south.  The easement does not allow permanent construction underneath.  In order to maximize the developable area the pond was located under the power line easement.  This created some unique drainage challenges.  The easement also serves as a common area for the subdivision for various recreational activities.

Use the Road Wizard to Design Widening on an Existing Road

During this portion of the workshop we will learn how to use Roadway Wizard to design the widening on an existing roadway at a proposed subdivision entrance.

1. Zoom in to the area of the subdivision entrance.
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Note: The existing road will use the existing grade (no profile changes) with widening on the west sufficient to accommodate possible future 5 lane construction.  While the widening may never happen and existing grade may be insufficient for the future, the widening is often required by various jurisdictions and will at least provide a short acceleration/deceleration area for subdivision traffic.

2. Start the Roadway Wizard (Modeler > Tools > Roadway Tool > Create/Edit).
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3. Open the preference file (Preferences > Open > RoadPrefs-Ex.srp).  Click OK when the preferences are displayed.
4. Click Next.  The active chain control will start and dialog changes as shown below.
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5. Set input in dialog as shown above:

· “Add to active Model” = ON

· Type =  Roadway

· Name = ExRoad

· Job Number = 01

· Start Station = 0+00

· Method (located under job number) = By element

· Start Point number will be auto populated to next available point number.

· Composite Section = ExistRoad.sec

· Profile Existing = Ground 1

6. Using the Select button pick the centerline for the existing road and set direction of station to be up the screen.
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7. Message center will report that the chain is created and stored.
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8. Click Next. – The road is designed on left side only.  The cross-section settings are as shown below.
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9. Click Next.
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10. Now we get a chance to edit the profile.  What we want is to match the existing ground profile as closely as possible.  The road preferences have been configured to attempt this but we will need to insert additional vertices to complete the design.

11. Click Vertical Design Tools button.  This will launch the VPI based vertical alignment tool.
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Hint: Our intent is to match the existing ground profile as supplied from the survey data as closely as possible.  So we will insert vertices as needed, snapping to the existing ground vertices.

12. At the bottom of the profile tool, click next until the cursor is on VPI #4.
13. Now click the button labeled “<<Insert” to insert a new vertex before VPI #4.  VPI #4 becomes VPI#5 because of the new vertex.

14. And click DYNAMIC to place the new vertex, snapping to the existing ground.
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15. Continue entering vertices until the proposed profile matches the existing ground profile.  You will probably need to zoom in very close for some of this.

Hint: The author opted for a profile without vertical curves, simply going from PI to PI to match the data collected from survey which tends to be collected in similar manner.  It is designers responsibility to determine the exact profile geometry.  On your project you may decide to construct a profile with best fit vertical curves.

16. Click to File > Save As and save the profile.  The old profile will be redefined.
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17. Close the profile generator.
18. Now we need to re-compute the model and cross-sections based on the updated profile.  Click Update Design
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19. When prompted to update curb returns and profiles as shown below click OK with both checkmarks off.  There are no curb returns nor cul-de-sacs on this roadway.
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20. The model and cross-sections will be updated as shown below.  Click NEXT.
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21. The remainder of the wizard concerns plans production issues which we will not cover in this class.  Click Finish.  Then close window 2.
· Review the comp section used for the existing road
1. Start the site element information tool. (Modeler > Element > Information)
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2. Pick the existing road centerline.

3. Switch to the Associations tab and click on the comp section button.
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4. This opens the comp section tool with the section file which is attached to the centerline shown in the tool.
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5. There are no entries on the right side because our intention is to do all work on the left side.

6. The left side has only three entries:
· The first entry builds a 2% cross-slope to the join line.

· The second entry builds a 2% cross-slope to the edge of pavement.

· The third entry adds a curb to the edge of pavement elements.
Hint: Close the Composite Section and Element Information dialogs.

· Examine the roadway preferences used on the existing road

1. Open the roadway preference file (Modeler > Tools > Roadway Tools > Preferences)

2. Open the Roadprefs-Ex.srp preference file (File > Open)

3. There are really only two important differences here from the preferences used on a normal roadway design.  One is that it calls for a different composite section file which is shown on the first screen of the preferences:
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4. The other is that the vertical design parameters are set to 1.0 foot vertical curves to try to force as close a match to existing ground as possible.
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Hint: The user might also consider using the Vertical component tools (arrow above) instead of the vertical alignment generator when needing to match the existing profile.  It could be that the component tools provide more flexibility when trying to best fit vertical curves.

Hint: For a full discussion of the road preferences the user is referred to the workshop on Road Network Tools.

Add a Raised Median to A Road Object

In this section we will examine a method of adding a median island to a roadway which has been designed with the road network tools.  The process is as follows:

1. Design the road network including all profile edits.

2. Add a median as a separate object.

3. Edit the roadway containing the median to add the median to the cross-sections
· Build the Road Network

First we need to build the roadways for the remainder of the subdivision.

Start the roadway network tool (Modeler > Tools > Roadway Tools > Network) 
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1. Open the saved road list. (File > Open > RoadsA-D.rnp)  This will populate the list as shown above.

2. Choose the job number as shown above.

3. Click Process Network. 

4. Close the Road Network tool.

Hint: Modeler>Project>Save
· Examine Results from Road Network Tool

An examination of the results will show that:

· The four roadways have been designed.

· Cross-sections and profiles have been designed for each roadway.

· Curb returns at intersections have been designed.
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· Cul-de-sacs have been designed
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· The curb returns between roads ExRoad and RoadA have not been designed.  This because the network tool only designs the curb returns for roads in the list.

· RoadC is incomplete.  
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Note: The next step in the design process would normally be to use the Road Wizard to check the profile design and re-design as necessary.  This process is covered in the Road Network tools workshop.  For this workshop we will simply accept the profile as designed by the network tool.

· Complete the Curb Returns at the Intersection of RoadA and ExRoad

We need to complete the design of the curb returns at the intersection.

Start the curb return tool (Modeler > Tools > Curb Returns)
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1. Select the preference file (roadprefs-Curb-Gutter.srp) using the Select File button on the top right.

2. Set Primary and Secondary road as shown above.

3. Change the search radius to 60 as shown above.

The search radius must be extended because the distance from the intersection is longer because of the wider lanes on both roads.

4. Select the Job number 01.

5. Click APPLY
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Warning: The curb return tools and cul-de-sac grades should always be checked for adequacy before accepting the designs.  The tools cannot anticipate every variation and certain situations can produce undesirable results.

· Add the Raised Median Object

Now we can add the raised median.

1. First create a new median object.  (Modeler > Object > New)
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2. Now add the purple median element to the Med1 object by draping on RoadA.
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3. Finally, we add a gutter section to the inside of the median.  Switch to the Section tab of the new element tool.
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4. Click the Query Section button then pick one of the edges of pavement which already has a curb to populate the list.

5. Use the Select element button to choose the median island element then set the direction to the inside.
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6. Click APPLY.  The median is complete.

· Update the RoadA cross-sections to show the median.

First let’s see what the cross-sections look like now.

1. Start the road wizard (Modeler > Tools > Roadway Tools > Create/Edit)
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2. Make sure the preference file is loaded. (Preferences > Open > RoadPrefs-Curb-Gutter.srp)

3. Click the radio button under Select Existing Project.
4. Then click the first button which is Select Alignment Element.
5. Select the site element that is the centerline of RoadA.

6. Click NEXT. 
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7. Answer No to editing pattern lines.

8. On the Active Chain Control, right click the button for view 3 and choose cross-section navigate.
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9. The cross-section navigator opens.  Cycle through the sections and note that the median is not drawn on stations 0+50, 0+75 nor 1+00

10. Now click the BACK button.  This takes you back to the cross-section screen of the wizard.
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11. Answer NO to the delete pattern lines prompt.
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Note: The bottom of the cross-section page of the wizard.  Our preferences have asked for existing ground to be produced from object named Ground 1.  Proposed ground is using the roadway object (RoadA in this case) plus its slopes.  But there is one more option.  We can draw a third object on the cross-section.

12. Enable the third checkmark and choose object name Med1 as shown below.
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13. Click Next.

14. Start the cross-section navigator again and take a look at station 0+75.  Note the median has been added.
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15. Click Next, then Finish on the wizard.

Hint: Modeler>Project>Save
Finalize Design of Road C

· Add the parking area

Zoom in to the end of RoadC (south end of project near the pond) and note that RoadC was not completely designed.
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The parking area needs the following:

· -2% cross-slope centerline to edge of valley gutter (dashed line at EofP)

· 1.5” drop to center of valley gutter

· 1.5” rise from center of valley to opposite side of valley

· +2% slope to outside edge of parking area

· Curb on outside of parking area

[image: image40.jpg]



Detail of valley gutter

The cul-de-sac needs the following:

· Edge of pavement around cul-de-sac

· Curb on outside of cul-de-sac 

· Modify Composite Section on RoadC for parking area

We will use the road wizard to edit RoadC to account for the parking area elements.

Note: We could have configured the composite section with the edits shown below in advance.  The road network tool would then have designed the parking area from the start.  But then we would have missed this learning opportunity.

1. Start the Road Wizard (Modeler > Tools > Roadway Tools > Create/Edit)

2. Open the preference file roadprefs-curb-gutter.srp

3. Enable the radio button under Select Existing Project and click the Select Alignment button. Select the RoadC centerline element.  This will produce the dialog below.
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4.  Click Edit Composite Section
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Note: This is the same comp section used on all the roadways except existing road.   We need to make a few additions to build the parking area.  The parking area is on left side so we only need to make the edits there.

5. First, we need to add a line to search for the edge of the valley gutter as shown below.  This segment will behave identically to the edge of pavement except the line is drawn with a different feature.  

Note: I used feature DesLane1 because it was handy.  If valley gutters are a common thing on your projects then you probably should consider creating a dedicated feature.
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6. Next we need to design the gutter line of the valley.  According to the detail above, this line is designed at a 1.5 inch drop from the edge of the valley.  Thus:

· User Slope = 0%

· Radial To = Adjacent

· Vertical Offset = -0.125
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7. Next we need the opposite edge of gutter which is 1.5 inches above the gutter center.
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8. Then we look for the back edge of the parking area which is +2% from edge of gutter.
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9. And finally we add the curb to the outside of the parking area.

Note: Remember, the section gets added to the segment immediately previous in the list.

[image: image47.png]‘Section Manager | Left Side Detais | Right Side Detais. |

Bem.Type |Feat. Type | Defintion [Sope [Offsst | Max Dis ~
Festre  Break Line  DesGutter 0000 0125 17000
Festre  Bresklne  Deslane? 0000 0125 20000 _
Festre  Bresklne  TempEcfP 2000 0000 32000

|Sectn  Boundary By Table. na  na  nA <

Defne.
Bement Type: Feature Type: (Boundany _v)
Method

Secton'y: (Tale—v) S (Lo 7]

‘Section Name: Select

Offset Dist_ Offet Bov_Pay tem
0100 0500 DesCTF
0500 0500 DesCTB

0500 | [0500 || DesCTB





10. Click Apply.  This will update the calculations and should include the parking area.
Hint: Answer “Modify ALL” to the pop up message.
11. Close the composite section tool.
Note: The ends of the parking area are not complete – we will return to these later.
12. On the Wizard dialog, click NEXT.

Warning: Do not click the Process Composite Section button on the Wizard dialog or the original section will be applied (without the parking area).
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13. Answer NO to modify existing pattern lines alert.

Note: Now you should be in a 3 port view with cross-sections in View/Window 3.

14. Right click on View 3 in the Active Chain Control and open the cross-section navigator.
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15. Navigate to station 10+50 and note that the parking area is not shown on the cross-section.

16. Click the Back button on wizard.
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17. Answer NO to “Delete XS Pattern Lines” dialog
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18. Click Next on Cross Sections dialog.

[image: image52.png]Roadway Tool - Cross Sections - .\roadprefs-Curb-G... [ = |

Preferences

Cross Sections
[ diional Locatons!
Addiional Locations:
By Intersection
Side: (Symbology ]
Frortage: (Symbology ~
Scan Distance: [0.000 Draw X Patiems

Exstng: (DispeonObjedt ~) Gound 1)
Proposed: Use New Roadway Object + Slope
([ Proposed: Use Other

Sufaces

<o
[Fn





Note: This will recreate the XSs that will include the modified Object.

19. Navigate back to station 10+50 to see the updated cross-sections.

20. Click Next, then Finish to close the wizard.

Add a Mid-Block Cul-de-sac 

· Add the mid block cul-de-sac to RoadC

Because of the way we approached this roadway design, the cul-de-sac ended up being a mid-block design.  The roadway tools will not design a mid-block cul-de-sac.  We will add the bulbous portion of the cul-de-sac. 

Note: This dataset is derived from a real world subdivision designed by the author a number of years ago.  In the real project, there was no parking area nor a valley gutter.  Thus, these portions are “invented” merely to serve as a training exercise.  

First, notice that because of the power line easement, the road right of way line ended at the last building lot.
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1. Open the New/Edit element tool (Modeler > Element > New Edit) and switch to the Section tab.
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2. Use the Query Section button to pick one of the edge of pavement where the sidewalk area is missing to populate the dialog as shown above.  There are couple changes that need to be made:

3. Change feature type to boundary and add the one additional segment for the sidewalk area (shown in the dialog below).
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4. Now using the Select Elements button pick the edges of pavement with curb already attached to add the sidewalk area.
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5. Click Set Direction button and set direction to outside.

6. Click APPLY.  This adds the sidewalk area to these three segments.
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7. Now switch the New/Edit tool to the Element tab
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8. Set the dialog as shown above.  

· Feature type = Break Line

· Slope = -2%

· Projection Option = Entire Element

· Use Reference Element Association = ON

9. Use the Select Element button to pick the edges of pavement around the cul-de-sac.
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10. Click Select Reference and Pick/Accept the dashed line across cul-de-sac. This dash line was added to design when we updated the parking area because it uses same feature as the edge of gutter.
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11. Click APPLY.  This builds the edge of pavement.
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12. Now switch back to section tab and add the curb and sidewalk area to the cul-de-sac edges.
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Finalize Parking Area

· Add the parking area ends to the Object

1. Elements>New/Edit>Drape on Model/Object

2. Set the dialog as shown below and select the two (2) parking area end elements.
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3. Click Apply.

· Add the missing section elements

1. Elements>New/Edit>Section

2. Query the existing section element at the outer edge of the parking area.

3. Select the connected edge of pavement elements as shown below.
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4. Set the direction (indicate that the section should be applied OUTSIDE the pavement area).

5. Click Apply.

Note: Save your project! (Modeler>Project>Save)

· Update Cross Sections

Finally, we would want to go back to the road wizard and update the cross-sections.  In the interest of time we will not work through this now.  It is the same process used previously when we added the raised median to the entrance.
Channel Wizard

· Check the ground profile along proposed channel route

We need to check the channel profile to insure we have not exceeded any design parameters and have not created any sags in the channel. We will check this using the Analysis>Profile tool.

1. Analysis>Profile

2. Populate the dialog with the Ground Object as shown below.
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3. Click Create Profile button.

4. Use the Select Element option and select the graphical centerline of the channel.
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Note: We can see from this profile that the channel centerline is sloping downhill for its entire length. We need to match the existing ground elevation at the roadway ditch (on the RHS of this profile).  We need to determine what the existing grades are to decide if we have enough slope available to create the required ditch.

· Use Analysis>Height tool to determine existing ground slopes.

1. Analysis>Height.

2. Set to Slope Mode
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3. Ascertain the existing ground slope along the proposed channel centerline by DP at the plan element vertices.

4. The slopes returned show grades of 2.2% for the first segment and 1.1% for the second segment. 
Note: Given this information, we shall create a channel with a 0.75% longitudinal slope to ensure the channel centerline remains below existing ground.
· Design a Channel using the Channel Wizard

Next we will design the channel which drains the pond outflow into the roadway ditch.

Why am I designing the channel first?  Because the elevation of the channel is controlled by the existing roadway ditch.  Our new ditch in turn affects the low point of the pond.

1. Zoom into the pond outflow channel on the south of project
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2. Start the channel wizard (Modeler > Tools > Channel Design)
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3. Click Next
4. Create a new Object from the “Define Channel Name” panel. Click New.
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5. Set type to Channel and name as desired. Enable “Add To Active Model”.  Click OK.
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6. Click Next.

[image: image72.png]M Create a Channel - Define the elements -> Along Element from Point | | & [l
CrannelCenter Line
TP ———
Offse Heigt

(Drape on Object 7] [Ground 1

e e

~
4

Select olements that define Defne a point.

the channel
X: 261752810
DP || Y: 65813528

< ] ( >
G e ) O b7 e





Note: The previous analysis we did gives us a strong indication that these settings should provide a solid first design scenario attempt.

7. Populate the dialog as shown above.

8. Select the channel centerline element.

9. Use the DP button to snap to and select the right hand end of the channel centerline.

10. Click Next.
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11. We will design a 6 feet wide ditch with flat bottom and 2:1 sides.  Enter the above information to accomplish this.

Note: The berm is only added if the ditch jumps out of the ground into a fill situation.  If this happens then a berm of the specified width is designed and the fill slopes at bottom come into play.  The fill condition is determined in relationship to the object specified in Rel. To.

12. Click Finish to complete the design of the ditch.
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13. On the inside of the middle vertex, the triangles are cutting across. We could correct this with the site element information tool and change the outside element to Boundary.  You may do this on your own or at a later time.

Note: Use the Analysis>Profile tool to check the grade of the channel relative to existing ground to ensure you have achieved the desired result… (a channel that flows the correct way…)

14. Project>Save.

 Pond Wizard

· Design a Pond using the Pond Wizard

1. Zoom into the area of pond at south of the project.  The blue shape indicates the bottom of the pond.
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2. Start the pond wizard. (Modeler > Tools > Pond Design)
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3. Click Next
4. Define Pond Name > New. Create a new Pond Object (Pond 1).
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Note: With the new pond object created as shown above, we can set the first of our design parameters.  We’ve decided to do a bottom up design because our constraints come upstream from the roadway ditch and channel we designed earlier. We will design to a water elevation.  
5. Enter Water Elevation of 1056.0 and Use a Freeboard of 0.5.
6. Click Next.

7. We want a pond with a 1% slope on the bottom so set the dialog as shown above.

· Design option = radial from point (top right button)

· Slope = 1.0%

· Drape on Model = SubDivision Plan

· DP = a point at the end of the channel as shown below.
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8. Click DP to set the location to derive the elevation (see above image).

9. Select the blue shape as the pond element.
10. Click Next
11. Populate the Pond Slopes and Berm details as shown below.

[image: image79.png]M Create a Pond - Define pond slopes and berm

===
Interor Side Sope.
(Sopennrse 7] (300 |:[100
[ (DesPondTop

Bem Detais
) Creste Bem Vidh: (6000 | (7] Fil Oy
Relstve To: (Obieet_v) (Ground 1

(Sope% _+) [1.000
Festure Type: (Bounday 7]

(Bem Festure

— [DesPondBem B3]
DesPondBem~ | )

Exteror Side Siope

Cut: (Slope Unt/Un_v) 0333
Fil: (Slope Unit/Unk_~) 0333





12. Enter the design parameters as shown above

· Interior side slopes = 3:1 using feature DesPondTop

· Berm checkmark ON

· Berm width 6.0 

· Berm checkmark in fill only ON relative to object Ground 1

· Berm slope = 1.0%

· Berm feature type = Boundary
· Berm D&C Feature = DesPondBerm

· Exterior side slopes = 3:1

13. Click Finish. And you should see a successful completion message.
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14. Click OK to see the finished pond.
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· Review interaction of pond and channel

1. Open the pond object for edit (Modeler > Object > Edit).  Switch to the Slopes tab and turn on the checkmark to display with object.
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2. Click APPLY.

3. Now zoom in to where the pond and channel objects meet.
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4. Note how the pond contours take precedence and flow down into the channel.  This is exactly what we want.  It happens this way because the pond follows the channel in the FIFO list.

[image: image84.png]



· Review interaction of  Pond and RoadC

The pond appears to be encroaching on the limits of RoadC.  We can check this with the profile analysis tool.

1. Start the profile analysis tool (Modeler > Analysis > Profile)
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2. Enter the objects to the list as shown above.  For each object:

· Choose the object from pull-down list

· Set the desired symbology in the sample (we are mainly interested in having different colors)

· Click the Add button

3. Click the Create Profile button (middle button)
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Note: The display will be blank to begin with.

4. Click the Place profile element button (second from right) and strike a line across the side of the pond as shown below.
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Note: The pond is undercutting the road.
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Create a Retaining Wall

We want to add a retaining wall between Road C and the pond.  

Note: In the real world, the designer would evaluate the cost of the retaining wall as compared to other options.  For example, it might be more cost effective to relocate the pond or relocate Road C. 

Many users overlook the simplicity of modeling a retaining wall, which is why we’ve included this section in this manual.

The process we will use for this situation is :

· Drape an element on the higher object (Road C) to set the elevation of the top of wall.  

· Then compute the elevation to the base of the wall at a slope from the bottom of  Pond 1.  

· These are the only two elements that will be in the retaining wall object

Warning: This does not design a retaining wall of course.  It models the face of the wall as a surface in our design.  The specifics of the actual retaining wall design would require a structural engineering approach.  Our surface design could be used by the structural engineer to set wall elevations however.

1. Zoom into the area where pond and Road C meet.  You’ll find two lines already drawn for the wall.  The red line will represent the top of the wall and the green line will represent the bottom.  (The image below has some levels turned off.)
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2. We need to be aware of the boundaries of the road object so we can make sure the top line can be draped entirely on Road C.  So, let’s turn on the boundary display of Road C.  (Modeler > Object > Edit)
[image: image90.png]1 Edit Object - Display =EEE
st e
Propertes | Bements | Sopes | Dspay | Sope indstors |

] Vetcss: XY
Major Cotour
Place: —

Bev. terval: [1.000

0200

°
0000





3. For Road C, turn on the boundary checkmark and set the color to purple.

4. Click APPLY

5. The red line will be top of wall.  It must drape entirely within the boundary.  Zoom in close to each end of the red line to make sure it is drawn OK.  Also scan along the length of the line.

6. Create a new retaining wall object (Modeler > Object > New)
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7. Now, add the top of wall element with the New element tool (Modeler > Element > New/Edit)
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· We are using the drape option.

· Since we have only two elements in this object we can make them both boundaries.

· Disable the offset height (It might be reasonable to add a little extra height.  For example, if you wanted a barrier rail to prevent falling into pond you could add maybe 2 feet offset)

· Drape option = Entire element

· Use reference element association so that future changes to the road will update the wall.

· Select the red line

8. Click APPLY

Note: We will compute the base of the wall at a slope from the Pond bottom.

9. Switch the New element tool to the Slope/Offset Option

[image: image93.png]W New / Edit Site Elements-> Slope/Offset From Site Element e &

Addto Actve Obiect: BWT_ v [New..] [ oy ]

[ Boment ot | ecton [ Depay |

iAﬂvNam

(Sopemnzse _v) (300 |:[100 [][Fecels Povert
[ Offset Height: | -0.500 Reference Element
Projction Opton: (Eréire Bement__~) Source

Use Reference Blement Assocition Select Reference.





· Feature type will be boundary

· Slope = 3 : 1.  This will continue the Object Side Slope.

· No offset height

· Projection option = Entire element

· Turn on Use Reference Element Association
10. Define Elements: Select the green line to be defined

11. Reference Elements: Use the Select Reference button and Pick/Accept the pond bottom shape.

12. Click APPLY
Add a Low Flow Keyway to Pond 

Adding a low-flow keyway is as easy as adding another channel object.  We have already drawn the path of the keyway.  It begins at a drainage network outlet at the head of the pond and flows downward in a meandering path towards the outlet structure.
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1. Create a new Channel object (Modeler > Object > New)
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2. Name Object as shown above.

3. Start the channel wizard. (Modeler > Tools > Channel Design)
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4. Click NEXT
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5. We will use the Pond Keyway object we created above.

6. Click NEXT
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7. Since the pond already slopes, we can simply drape the channel on top of the Pond object with a -0.5 offset as shown above.

8. Select the keyway centerline and click NEXT.
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9. Set the parameter as shown above.  The berm will never come into play because we are working on the regular grade of the pond bottom and the channel depth is less than the offset we used above.

10. Click Finish.

11. The channel is designed, but notice how the contours are jumping across the insides of the arcs.  This is because the channel edges were designed as breaklines.
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12. We can change the outside elements to Boundary elements to improve the modeling of the channel. 
13. Element > Change Feature.
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14. Set Feature to Boundary.
15. Select both of the outside channel elements.

16. Click Apply.

17. The keyway is now correctly modeled.

Advanced Model Visualization Topics

You may have noticed during this workshop that the model contours are displayed differently than in other workshops you have attended.

During this workshop we have used some different visualization settings to point out some of the possibilities, particularly in plans production.

· The existing contours are shown as dashed lines wherever the ground is undisturbed.

· Existing ground contours are not shown where proposed grading is to take place.

· The proposed surface contours are shown as solid lines

· The tie slopes for objects which make up the model are shown.
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These are common settings for plans production display of contours and are easily configured.

1. Open the model for editing (Modeler > Model > Edit) and switch to the Display Objects tab.
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2. At the bottom we have turned on the checkmark for Clip Objects From Model and set the option to View with Object Only.  This tells modeler to only show the proposed contours where there are actual design objects shown.

3. We have also set the check mark for Display Base Object.  This tells modeler to show the existing ground contours.

4. The Display Base Object option is set to View Without Objects.  This tells modeler to clip out the existing ground contours where design objects are located.

5. Switch to the Display Model Tab
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6. This is where we set the proposed contours to be solid lines at a 1.0 foot interval.

7. Now open object Ground 1 for edit (Modeler > Object > Edit) and switch to the Display tab.
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8. This is where we set the existing ground contours to dashed lines.  Note we set the same contour interval which is probably a good idea.  We used the same colors but this is not required.

9. Now switch the object name in the object edit dialog to Pond 1 and switch to the Slopes Tab.
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10. Here is where we set the option to display the tie slopes as proposed contours by turning on the Display With Object checkmark.

Module Summary and Review

Summary

You should now able to:
· Apply the roadway design wizard to designing an existing road which will be widened.

· Add a raised median to a roadway which was previously designed using the road network tools.

· Edit a road’s composite section to add information to the template.

· Add a mid-block cul-de-sac to a roadway.

· Produce new revised cross-sections based on the previous two edits.

· Create a pond using the pond wizard.

· Add a retaining wall between two objects.

· Create a channel using the channel wizard.

· Edit the profile of the channel.

· Add a low-flow key-way to a pond.
· Modify the contouring of a Model in preparation for Plans Production.

Questions

1. Can the Road Wizard be applied to existing roadway widening project?
2. If yes; what specific steps or input is needed?
3. Will the Roadway Network tool create intersections for Roadways that are not in the Roadway Network Object list?
4. Can the simple Modeler tools be used on an Object that was created with a Wizard?
5. Is it mandatory to use Design and Computations Manager with Modeler?
6. If I manually modify a Roadway that was created with the Wizard, how do I update the XS’s?
7. ALL cul-de-sacs be created with the Roadway Wizard tools.
· True

· False
8. What slope settings should retaining wall Objects typically have?

Answers

1. Can the Road Wizard be applied to existing roadway widening project?
Yes!
2. If yes; what specific steps or input is needed?
The Composite Section file must be created with a widening project in mind.
The Alignment needs to be “designed” with the widening project in mind (may be a case of using the existing surface profile rather than a “design” profile.)
3. Will the Roadway Network tool create intersections for Roadways that are not in the Roadway Network Object list?
No.
4. Can the basic Modeler tools be used to add to or modify elements in an Object that was created with a Wizard?

Yes. 

Adding or modifying Site Elements within an Object created using a Wizard is a regular option or workflow. The Wizards are designed to create data quickly… they will not always be able to provide the exact result you want. Using the regular tools to make modifications is an expected design scenario.
5. Is it mandatory to use Design and Computations Manager with Modeler?

No. 

But… there are many advantages to using the D&C Manager in Modeler and in general. It is recommended to set up and use D&C Manager… it is not mandatory when working with Modeler.

6. If I manually modify a Roadway that was created with the Wizard, how do I update the XS’s?

You need to go into the Wizard and select that Object’s roadway alignment to set the tool for manipulation. You then need to step through the Wizard without modifying anything to the Update dialog – then step “Back” and “Next” to update the XS’s without the Wizard modifying the Object.
Another option is to change to the XS Model (DGN Model) and open the Draw XS tool. From there, you can manually re-cut the XS’s. 

7. ALL cul-de-sacs be created with the Roadway Wizard tools.
· False

Mid-road cul-de-sacs will require the use of the simple Modeler tools though, in general, cul-de-sacs (no matter where they are located) are a very easy design item with Modeler.

8. What slope settings should retaining wall Objects typically have?

Typically, retaining wall Objects should have the Object Slope settings set to “no slopes”. Typically, retaining wall elements are created by draping onto a surface using entire element. The desired result is to exactly follow the surface. So slopes are not required or desired… typically.
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