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Introduction 

In this workshop we will review the workflow, processes and tools used to generate and report 

quantities. The Design & Computation Manager (D&C Manager) settings will be reviewed as 

they relate to quantity computations. D& C Manager recommended defaults will be discussed 

along with project specific modifications. Each student will compute graphical quantities and 

export these quantities to a database format that can be opened in Quantity Manager. After an 

introduction to Quantity Manager, its functions and interface, we will review the steps involved 

in defining project properties, project preferences and the project funding. We will add 

categories, pay items and quantities for non-graphical quantities and graphically review all the 

quantities. Additional functions such as generating reports will be covered.  

 

 

Workshop Objectives 

Upon completion of this module, you will: 

 Know the recommended workflow for generating and managing quantities. 

 Understand how Design and Computation Manager (D&C Manager) 

generates quantities and know how to navigate its various modes of operation. 

 Compute quantities from graphical elements that were drawn or modified by 

the D&C Manager. 

 Export the quantities computed by D&C Manager to Quantity Manager. 

 Be able to navigate and customize the Quantity Manager interface. 

 Review quantities created by D&C Manager. 

 Define the project properties and preferences in Quantity Manager. 

 Assign funding rules and define payers. 

 Review the quantities in a Quantity Manager database graphically. 

 Add categories, pay items and quantities manually. 

 Define report style sheets and create various reports. 
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Workflow 
The figure at right demonstrates the 

recommended workflow for generating pay item 

quantities. Any quantities that can be generated 

from measuring an element in a design file or 

that can be based on the existence of different 

item in the design file should be quantified via 

the D&C Manager database. This procedure 

reduces errors because quantities are then a by-

product of the design drawings. However, there 

are some quantities that have no graphical 

representation, such as calculating man-hours for 

certain construction tasks. These items are 

entered “manually” into Quantity Manager. 

 

Once the quantities for these elements are computed, the data is taken into Quantity Manager for 

review and/or modification. Then the pay items that are computed manually or computed 

external to CAD are entered in Quantity Manager. After the pay items and quantities have been 

entered, funding sources are assigned. Finally, reports are generated and the pay items and their 

respective quantities are exported from Quantity Manager to Trns*Port.   

 

D&C Manager Overview 

The D&C Manager standardizes graphic elements for drafting and quantity purposes. It is a 

proprietary hierarchical database that contains categories of items. The database file extension is 

DDB, hence this file is commonly referred to as the ddb file (*.ddb). 

 

Categories are used to group and classify the items into functional and relative folders. 

 

Each item represents a definition of a specific design 

feature.  An icon is shown with each item that 

represents the function of the item as defined in the 

database. The 3 icons are: 

 Calculator (Defines quantity parameters) 

 Paintbrush (Drafting settings) 

 Report icon (default – minimum settings) 
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Starting the Design and Computation Manager in GEOPAK 
The D&C Manager can be accessed by selecting 

Applications > GEOPAK ROAD > Design & 

Computation Manager.  It can also be invoked from the 

GEOPAK ROAD Tools tool frame and the Plan View 

Design tool box in Project Manager. In GEOPAK V8i, it can be 

accessed from the Task Navigation tools – GEOPAK Suite. 

 

 

 

Getting Started 
The D&C Manager File > Open command allows the user to navigate to the 

desired database. Databases may be company specific, project specific or user 

specific. The last opened database is stored in a resource file and is the one opened 

initially unless a specific database is forced by a configuration variable.  

 

 

The main D&C Manager dialog is composed 

of two distinct areas: 1) across the top are icons 

for the various modes of operation, below that 

is the second area, 2) the Path list box.  This 

area displays the name of the attached database 

file and your current position within the 

database structure.  It lists the categories, sub-

categories and items available for selection.  

This hierarchical data structure functions much 

like a directory. Double clicking enables the user to move up or down within the database. 

D&C Manager Operational Modes 
The D&C Manager dialog changes to accommodate nine different modes of operation: Display, 

Design, Set, Compute, Shape, Pavement Marking and Preferences.  When certain modes are 

selected, additional icons are displayed within this area. 

 

 Switch to Toolbox Mode - This is a toolbar version of the D&C Manager dialog that is 

dockable.  The most common use of this option is for drawing with Place Influence 

activated. 

  

Identify - Identifies the D&C item that corresponds to a selected MicroStation element 

and highlights the item in the database. If no matching item is found in the specified 

database, the message “No matching database item” is displayed in the prompt field. 

 

Display – Uses D&C Manager to create display filters for the view to manage the 

viewing and location of elements in the design file. The items to be shown or hidden 

are added to the Collection box, at the bottom of the D&C Manager dialog.  Individual 

1 

 

2 
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items or entire categories can be placed in the collection by using the “Add to Collection” drop 

down menu as shown below. This menu is activated by right clicking on an item or category.  

 

 

 

 

 

 

 

 

 

 

 

 

 

Four options are available for controlling the display of elements in the design file. These are 

described below from left to right. 

 

Normal Display – The MicroStation view display is normal. 

Highlight Selection - Highlights those items stored in the 

collection area in the MicroStation highlight color. 

Hide Selection - Turns off the display of the collection items while 

leaving all other elements as is. 

Display Only Selection - Turns off the display of everything but the collection items. 
 

 

Design – This mode is used for plan and profile plans production. COGO elements are 

drawn into MicroStation files via the Draw Plan and Profile dialog. The Design mode 

enables the user to draw each roadway COGO element (and associated attributes) in the 

design file based on standard drafting parameters. This mode also allows the user to set 

MicroStation symbology when using native MicroStation commands for drawing or modifying 

elements. This is achieved by selecting a specific item in the database and toggling on the “Place 

Influence” toggle. “Place Influence” sets the active MicroStation symbology as defined in the 

selected D&C Manager item and tags any defined attributes to the elements that are drawn.   

 

To draw a COGO element in design mode the desired item is highlighted from the path list box, 

i.e., alignment, edge of pavement, etc., 

from the second dialog box, “Draw Plan 

& Profile” is selected. The user is then 

prompted for a COGO database name. 

After the COGO database is entered, the 

user can select the name and type of 

COGO element to be plotted according 

to the definition of the D&C Manager 

database feature that has been selected. 

 

Collection Box 
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If the D&C Manager item selected is not a drafting 

item, then the button changes to display “Draw COGO 

Element”. 

 

 

 

Set - The Set mode is used to change existing MicroStation elements to the symbology 

and attributes of the selected item from the D&C Manager database. Elements can be 

selected by a Complex Chain, View, Fence, or Selection Set. The Set mode will append 

or modify the user data linkage to match the attribute assigned to the active Item.  

 

If the database Item has Adhoc Attributes associated with 

it, select the “Adhoc Attribute” check box to Append or 

Replace the attributes.  

 

 

Compute – The Compute mode is used for generating quantities of items that have been placed 

as pay items by the Design or Set mode. This tool expands the D&C Manager dialog to add the 

collection bin. Multiple pay items or entire categories can be processed in one computation. In 

Compute mode the second toolbox shown below is opened. 

 
Note: The Compute mode is discussed in detail later in this workshop. 

 

 

Shape (GEOPAK only) - Creates shapes in 2d for 

generating area quantities. In order to place a 

shape, D&C Manager must identify a closed area.  

This area can be defined by intersecting elements, which do 

not have to be clipped or shortened to define the closed 

area.  There are three options for placing shapes:  

 Semi-auto - Used when the plan view has conflicting elements or where the selection of 

an area produces very small shapes.  In this method, the user is prompted as each element 

is selected to determine the path the software takes to produce the shape. 

 Automatic – Works best when the elements forming the shape do not conflict with other 

elements in the view. 

 Exclusive - This option uses the automatic option, but in addition prompts the user to 

identify an area inside the original shape that is excluded from the external area quantity.   
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Adhoc Attributes can optionally be placed at the time of creating the shape. If enabled, a new 

window will open prompting the user for value(s) for each adhoc before the shape is created. 

 

 

 

Pavement Marking – Four options are available for drawing pavement striping. The 

various tools from left to right are detailed below. This is not covered in this workshop 

 

 Striping - Places single or double, 

solid or skip pavement stripes. 

 Separation - Places traffic separation 

pavement marking. 

 Chevron Diverge - Places pavement 

chevrons in areas of diverging traffic. 

 Chevron Merge - Places pavement 

chevrons in areas of merging traffic. 

 

Preferences – Configuration of an item. This includes the symbology for drawing the 

element and if and how the item is to be quantified. The compute parameters can be set 

to “Standard Unit, Criteria File, Equation, or Adhoc Attributes”. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

There are several GEOPAK applications that use D&C Manager in the background to automate 

the drawing of elements with D&C Manager attributes and facilitate automated quantities. Some 

examples are the DrawSign application and the Landscape application. These applications not 

only provide a mechanism to create discipline specific elements but also to continue the 

workflow of generating quantities for all types of designs.  
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Exercise: Using the Identify option and the Display Mode in D&C 
Manager 

1. Start MicroStation. In the MicroStation open file dialog select the untitled 

workspace then navigate to the QM worshop directory as defined by the 

instructor. 

2. Open the file dsgnrd01.dgn. 

3. Activate D&C Manager. 

4. Select File > Open from the D&C Manager dialog. 

5. Select the D&C Manager database file „workshop.ddb‟ from the workshop 

project directory. 

6. Make sure all the levels are on in the design file then select the id icon. 

7. Data point and accept one of the filled yellow shapes in the view. 

8. Review the item in the database. 

9. Data point and accept one of the filled green shapes in the view. 

10. Review the item in the database. 

11. Navigate to the Quantity Features folder under the Roadway folder.  

12. Click on the Display mode 

icon. 

13. Right click on the Quantity 

Features folder and add it to 

the collection box. 

14. Select the Display Only 

Selection from the Display 

mode supplemental dialog. 

15. Review the results in the 

view. 

16. Right click in the collection 

box area, and then select the option to clear the collection box and again 

using the ID icon select one of the yellow shapes. 

17. Find the pay item 0110  1  1 in the database using the Edit > Find 

command, then with only the item 0110  1  1 selected, click on the Display 

mode and select the Display Only Selection icon.  

18. Also try the Highlight Selection and Hide Selection icons. 

19. Select the Normal Display icon. 
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D&C Manager Settings and Prefs 

D&C Manager Settings 

The D&C Manager Settings menu contains several commands that are 

important to the quantity computation process.  Defining the options and 

values within these dialogs are fundamental to accurate results.  The key 

dialogs on the Settings pull down menu are:  

 Display   

 Design  

 Compute 

 Computation Units. 

 

Display Settings – The “One Color Display” toggle temporarily 

changes the display of elements on the screen to one common color, and 

then the user may specify additional elements to be viewed in their original 

colors.  This tool enhances visualization when reviewing quantities. The 

toggle “Highlight in Computation” highlights each element as it is 

computed. 

Design Settings  
Element Connectivity - sets the maximum gap tolerance and 

deduction tolerance used in computations and the drawing scale 

for cells and line styles.  

 

If the distance between two specified elements in a MicroStation 

file is smaller than the Maximum Gap Tolerance, the software 

assumes the two elements intersect and treats the elements as if 

they are connected and continuous when computed.  If the 

distance is larger than the 

Maximum Gap Tolerance, 

GEOPAK assumes the two 

elements do not connect and 

are separate instances of the 

same item. In the following figure, Line A and B are 0.05 

feet apart, which is less than the Max Gap Tolerance of 0.1. 
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However, Line C is 0.2 feet from either of the other two lines and as such is not considered 

connected. Element Connectivity is used in computing quantities and generating reports. The 

Deduction Tolerance is also used when computing quantities. For example, if the pay item 

specified is a curb line, and within its compute parameters a deduction of six feet is defined for 

each curb inlet when a curb inlet is found within the deduction tolerance of the curb line, the 

length is automatically deducted from the quantity of the curb.  

Compute Settings - The Compute Settings are applied during the computation process and 

impact the resulting output.  Compute Settings contains four sections:   

 Baseline Chain Reference  

 CSV Export Properties 

 DBMS Properties  

 Project Specific Supplemental Descriptions. 

 

When quantities are computed a single baseline is referenced for station/offset values.  The 

Adhoc Attribute Name field is used to attach an adhoc to one or more elements that tie those 

elements to a specific chain for any station/offset values derived during computation by the Plan 

Quantity Computation dialog. 

 

The CSV Properties are used when exporting any pay item quantities to a CSV file.  Two CSV 

file formats are supported. 

These will not be covered in this workshop. 

The DBMS Properties are applied when exporting quantity information to a database for use 

with Quantity Manager.  

Driver – This determines the database format to be used for the resulting Quantity Manager 

database.  Supported databases are Microsoft Access, Oracle or SQL Server. 

Username/Password – Secures the database with a username and password. 

Purge Quantities for Deleted DGN Elements - As quantities are computed, GEOPAK checks 

if the element has been previously computed. If it has been 

computed, it checks to see if the element has been modified and 

adjusts the quantity according to the modification. If the 

element has been added since the last computation, the quantity 

is added to the database. However, if an element has been 

deleted, GEOPAK does not automatically delete the quantity, 

as this may not be the action desired by the user. For example, 

if the quantity was originally calculated in a reference file, and 

then file is detached by mistake, the user still needs the 

quantities. Therefore, the user must decide when to delete 

quantities for which there are no longer graphic elements. If 

toggled on any quantity which does not have an associated 

element is eliminated. 

Update Quantities for Designated Phase Only – When the 

toggle is disabled, an element can appear in multiple phases. 

This was the behavior prior to the 8.08 release.  With the toggle 

enabled, an element appears in only the selected phase and 

removed from any other phases when appending to an MDB 

file. 
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Create Adhoc Attribute Table - When toggled on, adhocs attached to elements being computed 

are stored in the ad hoc table within the Quantity Manager database. 

Project Specific Supplemental Descriptions - When toggled on, the specified Prefix and Suffix 

are used for the Supplemental Descriptions.  By default, if you create multiple items with the 

same name, then the quantities for the separate items will be summed into a single quantity when 

computed and exported to Quantity Manager.  Supplemental descriptions are a provision by 

which multiple items that have the same name and general description will be treated as distinct 

items during quantity computation.  For example: 

Item = "123-456"  Description = "Removal {Concrete}"  

Item = "123-456"  Description = "Removal {Pavement}"  

Item = "123-456"  Description = "Removal {Building}"  

The three items above are all separate items, with the same item ID.  The description is 

composed of two parts: a "general" description (normally identical, in this case "Removal") and a 

"supplemental" description.  The supplemental description is being embedded between "{ }".  

Basically any character may be used but the recommended characters are: { } or < > or ( ) or [ ] 

or others.  The selected character is then defined in the Compute Settings dialog. The three items 

shown above when computed will be quantified individually and maintained as unique item 

quantities even when exported to Quantity Manager and eventually to Trns*prt.   

 

Computation Units – D&C Manager 

supplies standard units of measure in 

both English and Metric format. To 

access a listing of these units, select 

Settings > Computation Units.  The 

units are stored in .CSV files 

contained in the product installation 

folder.  The file names are: 

ComputationUnitDefinitionEnglish.cs

v and 

ComputationUnitDefinitionMetric.csv.  

If additional units are needed, these 

files can be modified for custom units.  

 

Adhoc Attribute Manager  
The Adhoc Attribute Manager is used to attach, review and 

modify adhoc attributes. Adhoc Attributes are tags that are 

linked to graphic elements to provide more information 

about that element, like an adjective to a noun. These tags 

can then be retrieved and used by subsequent processes. 

One of the main uses of adhocs is to define quantity 

information on elements, especially to define quantities for 

items that are based on the presence of another and separate 

item. An adhoc is comprised of pieces of information that must be defined for each adhoc:  

 Name - An identifier used by applications when searching for a specific Adhoc Attribute. 
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 Type - Defines the nature of the information. The options are Numeric, String, Unit, 

Quantity, and Remarks. 

 Value - The actual information used by the application. What the value can be is 

restricted by the Type. For example, if the Type is set to Numeric then the Value must be 

a number.  

To access Adhoc Attribute Manager, click on Applications from the MicroStation menu, then 

select GEOPAK Road  > GEOPAK 3pc Adhoc Attributes.  

  

The Adhoc Attribute Manager has four buttons on the tool bar for viewing and tagging elements 

with Adhoc Attributes. From left to right these buttons are:  

 Attribute Display Filter 

 Identify Element  

 Set Attribute 

 Adhoc Scooper.  

The two buttons on the right side are Create New Row and Delete Row. 

 

To add an Adhoc to an element(s), define the adhoc 

in the Adhoc Attribute Manager dialog as shown 

right using the New icon to add it to the list, then 

either by selection set or by individually selecting 

the elements use the Set attribute icon  

to tag it to the selected elements.  

 

To define a specific chain for generating 

computation reports for certain elements, create an 

adhoc named “chain” or whatever was defined in 

the compute settings dialog for baseline chain 

reference. Set the type to string and the value to the 

chain name that the reports should be based on. See 

image right. 

 

Examples of Adhocs used for generating quantities are shown in the image below. 
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Exercise: Configure Design and Compute Settings 

1. Open the design file (dsgnrd01.dgn) from the previous lab. 

2. Activate D&C Manager and select Settings > Design from the D&C Manager 

dialog. 

3. Set the Maximum Gap Tolerance to 0.2. 

4. Set the Deduction Tolerance to 1.0. 

5. Close the Design Settings dialog. 

6. Select Settings > Compute from the D&C Manager dialog. 

7. Set the Adhoc Attribute Name to Chain. 

8. Enable the toggle for Purge Quantities for Deleted DGN Elements. 

9. Close the Compute Settings dialog. 

10. Select all of the elements that are on the side street at the approximate station 

85+50 using PowerSelector and place in selection set. Open the Adhoc 

Attribute Manager dialog and  a new adhoc. Define the adhoc as: Adhoc name 

= chain, type = string, value = bl10st. Click on the Set Attributes button on 

Adhoc Manager to add the adhoc to the elements. 
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D&C Manager Computations 

Once the desired graphical elements have been drawn into a design file, the process of 

computing quantities to export to Quantity Manager is a relatively simple process.  After 

verifying the values in the Settings > Design and Settings > Compute dialog is correct, the pay 

items to be computed are added to the collection box. The next step is to define the extents of the 

design file from which the elements are calculated and the reference element/chain from which 

the station/offset will be oriented.  The final step is to output the quantities to a DBMS formatted 

file to be opened in Quantity Manager. 

 

Compute Mode 

An important, yet time-consuming part of any project is the computation of quantities. Through 

the Compute mode of the D&C Manager, the completion of this task is much quicker and easier.  

In addition, since the application uses the plan view of the design to compute quantities, 

discrepancies between the drawings and the bid quantities should be virtually non-existent.    

 

When the D&C Manager Compute mode 

is selected an additional dialog is invoked 

as depicted right.   

 

The next step is the selection of the pay 

items and/or categories to be computed.  

Even though a drawing may contain 

many graphical elements representing 

various pay items, the user determines 

which pay items will be selected for the 

computation process.  Just like Display 

mode, Compute mode has a collection 

pane at the bottom of the dialog.  When 

computing quantities for a single pay 

item it is not necessary to use the 

collection box as long as the collection 

box is empty. 

 

Two selection methods can be employed.   
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 The first method is to select an entire category.  D&C Manager computes quantities for 

every item found in the selected category as well as any child categories.  To do this 

single click on the desired category and then right click and select the Add to Collection 

option at the top of the list.  

 The second method is the selection of individual items.  This is accomplished by 

selecting the desired item from the hierarchy list box, then right clicking to select Add to 

Collection to place the item in the Collection box. 
 Note:  It is recommended to individually check the quantities for each item 

during a preliminary compute, to ensure all of the elements are being 
calculated. Also the design file should be checked for duplicate and 
overlapping elements prior to running quantities. This can be 
accomplished with the MicroStation cleanup tool. 

After the selected items have been computed, a second dialog will open that contains the 

computed quantities.  The dialog is shown below.  

 

 
 

The Export Format must be set to DBMS to create the correct file type for Quantity Manager. 

The database is created using the software format defined in the D&C Compute settings dialog. 

The database contains detailed information about each item including calculated and rounded 

quantities, geometric properties, pay item numbers, descriptions, station/offset values, etc. When 

the DBMS option is selected from the Computation Results dialog several other enter data fields 

are made available for input. These fields are: 

 

 Advanced Project Settings - Additional Project specific information that is added to the 

QM database.  This information can be passed to Trns*prt via the aecXML file. 

 Run - A method of grouping various quantities and / or pay items. 

 Phase - A means to group pay items.  Default phases include:  Design, Preliminary, and 

Final.  The user can add new phases, but should be aware of naming limitations if 

exporting to Trns*port. 
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Exercise: Compute Quantities 

1. Ensure the design file dsgnrd01.dgn is open. 

2. Turn on the display of all reference files and turn on all levels. 

3. Add the Roadway Design and Drainage categories to the collection box in the 

D&C Manager dialog as shown below. 

 
4. Click on the Compute mode icon from the D&C Manager dialog. Use the 

following settings 

GEOPAK:  

  Job 817 

  Inside the Active Design File 

  Baseline Reference is Chain BL817 

 

5. Click Compute Quantities.  When the process is complete the Computation 

Results window will open. Set the Export Format to DBMS and fill out the dialog 

box as shown below. Click on Export. When the process is complete close the 

Computation Results window. 

 

6. Close D&C Manager. 
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Using Quantity Manager 

Quantity Manager (QM) is a standalone Java application that manages all project quantities 

including those from D&C Manager in addition to quantities that are keyed into Quantity 

Manager manually.  Quantity Manager can receive data from GEOPAK, MX and InRoads. The 

data for Quantity Manager is stored in one of three user selectable database formats – Access, 

Oracle or Microsoft Sequel as previously discussed. 

 

Accessing Quantity Manager 

In GEOPAK, Quantity Manager can be accessed from 

MicroStation by selecting Applications > GEOPAK Road > 

Quantity Manager or by selecting the icon next to D&C Manager 

on the Road Tools tool frame.  

 

Some of the preferences and functionality of QM is set in the QM configuration file. The 

configuration file is „qm.cfg‟ and it is located in the \program files\bentley\geopak\classes\ 

folder.  

This file contains variables 

that define the format and 

location of reports and style 

sheets for formatting 

reports. The configuration 

file also controls the default 

settings of the interface. 

This file contains variables 

for station formatting, report 

and export paths, and the 

default locations of the 

aecXML.files. There are 

descriptions and instructions 

in the file for each variable.  
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Some of the new configuration variables in the QM.cfg file are: 

new_phase_label=PES Category (or whatever you want to call it) 

new_phases_label=PES Categories (or whatever you want to call it) 

import_aecxml_groups_as_phases= true  (the default is false which exports as payers) 

 

To implement a “company” QM.cfg file across a worksite, add the MicroStation environment 

variable GPK_QUANTITYMANAGER_CFGFILE to define the location of your configuration 

file. This is a customized version of the QM configuration file that is delivered with the product, 

which Quantity Manager will use at startup. 

 

Syntax examples:  

GPK_QUANTITYMANAGER_CFGFILE < \\server name\directory name\cfg file name.cfg 

GPK_QUANTITYMANAGER_CFGFILE < c:\directory name\cfg file name.cfg  

Quantity Manager Interface 

The Quantity Manager interface contains a pull down menu, icons and three windows or panes. 

One pane shows the pay items in a tree or table format, another pane displays the pay item 

quantities and the third pane contains the element information for each quantity. 

 

 

 

Payitem Pane  

The Payitem pane is located on the left side 

of Quantity Manager in Normal View and is 

the top pane when the display is „Tiled 

Horizontally‟.  



Using Quantity Manager 

 

 

Nov-08  Quantity Manager 

 Copyright © 2007 Bentley Systems, Incorporated  
 

21 

Two tabs control the display type of the Pay item pane; Payitem Tree and 

Payitem Table. The Payitem Tree tab displays the contents in a 

hierarchical structure which is easily navigated in the same manner as 

Design and Computation Manager.  

The Payitem Table tab displays the pay items in a table. The pane is 

customizable and is useful when selecting multiple items. It is also the best 

display option when generating reports.  

 

 

Quantity Pane  

 

 

 

The Quantity pane displays quantity 

information about the selected Pay item or 

Category. The information displayed can be 

customized by selecting which columns to 

display. Quantity information can be sorted by 

clicking on any of the column headers. Only 

the quantities under the current Phase, as 

selected on the Tool bar, are displayed.  

 

 

 

 

 

Element Pane  

The Element pane displays information about the 

elements specific to the selected Quantity. Each tab 

in the Elements pane displays different attributes 

defined for that element. These tabs are: 

 Elements - shows all the elements that make 

up that Quantity. 

 Adhoc Attributes - displays any adhoc tags 

related to the Quantity or tagged to the 

element.  

 Funding Participation – the amount of 

participation per payer. 

 Funding Rules – how the cost is distributed.  

 Payer Participation - funding sources.  

 

To access commands specific to a pane, right-click in any view pane and a drop-down menu is 

displayed that has shortcuts to the tools that relate to that pane. 

 

To customize which columns are displayed in the quantity or element pane, right-click on the 

column header and toggle on and off the available columns.  
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QM Toolboxes 

Located directed below the pulldown menu bar are toolboxes. There are four dock-able 

toolboxes with ten shortcut icons and one combo box. 

 

 
New Project 

 
Open Project (Project > Open) 

 
Refresh (View > Refresh) 

 
Normal View (View > Normal) 

 
Tile Horizontally (View > Tile Horizontally) 

 
Expand Tree (View > Expand Tree) 

 
Collapse Tree (View > Collapse Tree) 

 
Hide / Show Payitem Table Columns (View > Columns > Payitem 

Table) 

 
Hide / Show Quantity Table Columns (View > Columns > Quantity 

Table) 

 
Hide / Show Element Table Columns (View > Columns > Element 

Table) 

 
The active phase. 

 

 

QM Pull down Menus 

Below is a list of the commands available from the pull down menus.  Refer to the online help 

for complete documentation for each option.  

 

Project Menu 

 New – Creates a new QM database. 

 Open - Opens an existing QM database. 

 New Phase – Creates a new phase in the database. 

 New Phase – Creates a new phase in the database  

 Import – Mechanism to import pay items and cost. 

 Export – Exports pay item information to various formats. 

 Merge – Will merge multiple QM databases. 

 Properties - Defines the project number, description, units, 

Spec Year, and advanced project settings. 

 Preferences - Provides a toggle for enabling adhoc editing, 

defining aecXML document file names and setting accuracy.  
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Edit Menu 

 Select all – Selects all quantities for the selected pay item. 

 Unselect all – Deselects all quantities. 

 Delete - Deletes the highlighted item or category from the database. If a category is 

deleted, all child categories and pay items are deleted. An Alert message is displayed 

prior to deleting. 

 Rename - Renames the selected category or pay item. The highest level category (root) 

may not be renamed. 

 Phase - Opens the Phase Properties dialog where phases can be added, deleted. 

 Funding –  

 Payer – List of Payers and description used when defining funding rules. Payers 

can be added, deleted or imported from an aecXML funding source document.  

 Rule (Funding Properties) - Defines the payers and their respective percentages 

of participation to be associated with quantities. 

 Boundary – creates or edits boundaries. Boundaries can be defined as sheets or station 

ranges. 

 

View Menu 

 Refresh – View refresh. 

 Columns – opens dialogs to modify to various columns displayed in each pane. 

 Expand Category Quantities – This toggle specifies the content of the quantity pane 

when a category is selected.  If toggled on, the quantity of the selected category is 

displayed, along with all quantities in all subcategories.  If toggled off, the quantity pane 

only shows quantities in the current selected category, one level deep.  

 Expand Tree - When chosen, all categories, sub-categories, and pay items are expanded 

in the Payitem Tree (not the Payitem Table).  

 Collapse Tree - When chosen, all categories, sub-categories, and pay items are collapsed 

in the Payitem Tree (not the Payitem Table), so that only the highest level category in the 

hierarchy is shown. 

 Normal – Displays the panes in normal viewing mode.  

 Tile Horizontally – Display the 3 panes horizontally. 

 

Insert Menu 

 Category - New categories can be added anywhere within the database hierarchical 

structure and are inserted from the current selected category. Three operations are 

supported: Above, Below, Sub-Category.  

 Pay Item - Insert a pay item from the current selected category or pay item. Three 

operations are supported: Above, Below, In Category. New pay items can be added 

anywhere within the database hierarchical structure. To add a single item above or below 

a pay item already in the table, select that pay item, then use the Above or Below modes. 

To add an item at the bottom of a category, select the category first, then use the In 

Category mode. 

 Quantity - Insert a quantity to the current selected pay item. Based on the source of the 

computations, some data may be dimmed and not available for modification. The 

quantity property dialog is divided into a general tab and a location tab. 
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Tools Menu 

 Reports - Tools to define custom report styles and create reports.  

 Reports > Create - Creates a report of the selected payitems for the active phase. 

The user can choose the report style and the report document type such as PDF, 

CSV, HTML. 

 Reports > Define Styles - 

Opens the Report Styles 

dialog shown right, from 

which new report styles 

can be added, existing 

report styles can be 

modified and report styles 

deleted. New styles are 

added by clicking on the 

New icon, which opens 

the dialog box depicted 

below.  

 

 

 

 

 

 

 

 

 

 

 

 

 Graphic Viewer - A viewer of the information stored in the QM database.  The graphics 

can be saved as a .SVG (Scalable Vector Graphics) file.  SVG is a language for 

describing two-dimensional graphics and graphical applications in XML.  
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Exercise: Reviewing Quantities in QM 

1. From Windows Explorer, navigate to the installation folder for QM, this will 

be supplied by the instructor (the default location is:                        

C:\Program Files\Bentley\Geopak\V8.11\Classes\). Open the configuration 

file QM.cfg. Review the contents. Change the variable 

“aecxml_import_documents_path=   $(QM)\samples\standards\aecxml” to 

look in the workshop folder. Close the file 

2. Open the dsgnrd01.dgn file again and from the GEOPAK menu start 

Quantity Manager. 

3. Select Project > Open from the QM pull down menu. 

4. Click the Select Database Filename icon.  

5. Navigate to the class dataset folder. 

6. Select workshop.mdb file created in 

the previous exercise and click Open. 

 

 

 

 

 

 

 

 

 

 

7. From the Tree view select the Roadway category and click on the Expand 

Tree icon.   

8. Swap to the Table view and try various sorting options of the pay items. 

9. Review the various panes in QM then modify what columns are displayed. 

10. Customize the display of the panes to tile them horizontally, then reset to 

normal view. 
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Setting Up a QM Project 

Prior to working with the actual quantities it is recommended that the user define and setup the 

project information. Typical information to be set up includes Project Numbers, Funding 

Sources, Payers, and Phases. 

 

If the quantities are to be exported to Trns*port from Quantity Manager, the project information 

in QM must exactly match the project information in Trns*port. 

 

Project Properties 

After a project is created in MicroStation 

and exported to Quantity Manager, the 

Project Properties need to be set. If 

Trns*port is used, the project information 

can exported from Trns*port into an XML 

file that can then be imported into QM. 

This file contains most of the QM project 

properties.  If this file is accessible to you, 

save the file to your a local drive from 

Trns*port then follow the steps below to 

import it into QM. 

1. From the Quantity Manager File 

menu select Project > Properties.  

2. From Project Properties dialog box 

select Project > import aecXML 

Infrastructure V33 Project.   

3. Set the location and file name of 

the XML file. 

4. Click OPEN, the project properties are now populated in QM, click the OK button. 

 

If this information is not available in the XML format, fill it in manually. See the description of 

each field below: 

 Project Number - Used to identify the Quantity Manager project. 

 Description - Allows for a brief description of the project, such as the associated road 

number.  
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 Unit System – Defines which units of measurement are used on the project, English or 

Metric.  

 Spec Year - Used to specify the governing Specification year for the project.  

 Project Chain- Project baseline. 

 Station Range Begin/End – Station range on baseline chain. 

 Mile Post/Reference Post Begin/End – used as a means of referencing the location of 

the project. 

 Midpoint Coordinates Latitude/Longitude - used as a means of referencing the 

location of the project. 

 

Project Preferences  

When a project is created the accuracy of formatting 

notations is automatically set. The Project Preferences dialog 

displays the current settings and allows the user to modify 

these settings. In addition files containing the valid pay items 

and payer information in XML format can be imported. See 

the QM help for more information on the required format. 

 
Note:  Pay items can also be imported from a CSV file by 

using the option File > Import >Payitems >CSV 

 

Funding 

QM supports the management of quantities grouped by their Payers and Funding Rules. Funding 

Rules defines who is paying what and how much or what percentage. A Default Funding Rule is 

created and applied automatically if no other Funding Rule is applied. The Default Funding rule 

is automatically assigned to the Default Phase.  

 

Funding Rules are created and edited 

in the Funding Properties dialog. To 

open Funding Properties, from the QM 

menu select Edit > Funding > Rule.  

 

The Funding Properties dialog contains 

a list of the available Funding Rules 

and a table displays the Payers, their 

Descriptions and percentage of 

participation for each Payer in the 

selected funding Rule.  Station ranges 

can also be defined for the funding 

rule.  
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Payer 

A Payer in QM is a funding source. When a new project is started in QM a Default Payer is 

created. Additional Payers can be 

created manually or imported from 

the Payer aecXML file specified in 

the Project Properties. Importing 

payers is preferred because it 

ensures that the naming convention 

of the Payer matches exactly what is 

found in Trns*Port. 

 

To open the Payers dialog box from the QM menu select Edit > Funding > Payer.  

To create a new Payer, on the Payers dialog, click on the New Payer icon . A new Payer is 

added to the list. The payer information can be edited by clicking on the field in the dialog box, 

the field is editable. 

 

To import a Payer from the previously defined XML file, click the Browse Master Payer 

Document icon . Select the desired Payer. The Payer is added to the project. 

 

Phase 

Phases in QM are used for grouping quantities when creating reports and when assigning default 

Funding Rules. All QM projects are created with a Default Phase. In the case of databases 

created with D&C Manager, the Phase defined during export is carried over into QM.  

 

The Default Phase has the Default Funding Rule assigned to it automatically. Additional Phases 

default to a “Default Funding Rule” with the value of none. Multiple Phases can be created to 

help divide the project into smaller parts for reporting, alternate designs and cost comparisons.  

 

Phase Properties are managed through the Phase Properties dialog box shown below. From 

Quantity Manager, click Edit > Phase. The Phase Properties dialog contains a table of available 

Phases and displays the Default Funding Rule assigned to each Phase.  

  

The three buttons in the lower right 

corner of the Phase Properties dialog 

are from left to right:  

 New Phase 

 Delete Phase 

 Open Funding Dialog.  

  
Note: For quantity data exported to Trns*Port, the Phase must be DesignEstimate.  
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Exercise: Setting up the Workshop Project 

1. From the Project menu select Project > Preferences dialog and fill in the 

PayItem, and Payer fields using the files in the workshop folder. Set the 

remaining options as shown in the image below. Click OK to complete.  

 

 
 

2. Select Project > Properties and populate as shown below.   

3. Now import the Project information from an XML file by clicking on Project 

in the upper left corner of the dialog and select the file 22807915201.xml. 

This will update the fields with the correct info from Trns*port. Click OK 

when completed.  

 

4. Create two new Payers: 

 Payer: State, Description, State funds 

 Payer: Federal., Description Federal funds 
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5. Remove all payers except Default, State and Federal. 

 

6. Define a funding rule named 80/20, that is an 80/20 split between federal 

funds and State funds. Then create a state funding rule called State, that is 

100% state funds. 

 

  
 

7. In the Phase Properties dialog, delete the phase default and set the funding 

rule for DesignEstimate to 80/20. Create a new phase, for the purpose of 

grouping quantities. The phase is to be called Alternate and define it with a 

Default Funding Rule of 80/20 as well.  

 

8. Set the payitem pane to table and select all. Right click on the quantity pane. 

The Apply Funding Rule dialog 

will open. Select 80/20 from the 

drop down then click Apply.   

 

  



QM Graphic Viewer 

 

 

Nov-08  Quantity Manager 

 Copyright © 2007 Bentley Systems, Incorporated  
 

31 

QM Graphic Viewer 

Graphic Viewer 

The graphic viewer dynamically draws the selected pay items in an elemental format. The 

graphics can then be saved as a SVG (Scalable Vector Graphics) file.  SVG is a language for 

describing two-dimensional graphics and graphical applications in XML. This option is accessed 

from Tools > Graphic Viewer. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The options available for navigating the drawing are: 

 

 
Window Area 

 
Zoom in/out 

 
Rotate View 

 
Pan View 

 
Fit View 
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In addition, the view can be navigated by toggling on Window Center and/or Zoom to Selection. 

This allows the user to review each item graphically to see if the Quantity Manager quantities 

look correct. 

If there is a need to save the drawing of the quantity elements for reporting purposes this can be 

done by entering a file name with the SVG extension and then clicking on Export. 

 

Since this is an XML graphics file, this file cannot be reviewed in Microstation or GEOPAK, 

however there are free SVG viewer/editors available for download on the Internet. One such 

product is Inkscape. This program will open the file for viewing and editing as shown in the 

image on the following page. This product will not be covered or used in this workshop. 
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Exercise: Review graphical quantities 

1. Using the same project database from the previous lab, from the Quantity 

Manager menu select Tools > Graphic Viewer.  

2. Zoom in on a specific area then click on the Fit view icon on the Graphic 

Viewer.  

3. Review several different payitems graphically. 

4. Test the different viewing options available with the Graphic Viewer. 

5. Create an SVG file. 
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Adding Manual Quantities 

Every project has pay items for entities that are not drawn into a CAD design file and therefore 

cannot be computed by D&C Manager. These quantities are referred to as „manual‟ quantities. 

These non-graphical items are manually entered into QM. This allows all quantities for projects 

to be contained in and reported from a single source, QM. 

 

Pay items are defined inside categories. Before quantities can be entered into a Quantity 

Manager database for a pay item, you must first create the category and pay item name for which 

the quantity belongs. The following sections discuss these items in details.  

 

Categories 

Categories are containers of pay items and 

other categories. There is no limit to the 

number of categories that can be created or 

how deep the categories are nested. A category 

name is limited to 256 characters.  

 

To create a new sub-category, select a 

category, then select Insert > Category from 

the QM pulldown menu or from the popup 

menu displayed by „right-clicking‟ in the pane 

as shown in the image below.  

 

 

 

 

 

 

 
9 

 

 

 

 

Category 
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Payitems 

Payitems are containers of quantities. There is no limit to how many payitems may be created. 

 

To create a new payitem, select a 

category or a payitem, then invoke 

Insert > Payitem from the QM 

pulldown menu or Insert Payitem from 

the popup menu. The New Payitem 

Properties dialog is then activated.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The PayItem Properties dialog can be filled out 

manually or from a previously defined XML file 

that contains valid pay items and their 

corresponding definition. This is the recommended 

method. The fields are defined below: 

 

 

 

 

 

 

 

 Payitem Name - The Payitem name 

or number. Limited to 256 characters. 

The Browse Master Payitem List icon 

allows payitems stored in the 

current aecXML payitem document to 

be selected for import as shown 

below.  Filters are supported for 

Payitem and Description. 
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 Description – A description of the Pay item. Limited to 256 characters 

 Unit Cost - Cost of a single unit.   

 Lump Sum - If toggled on, the item is paid as lump sum. There are two types of lump 

sum payitems; true lump sum and hybrid lump sum. A true lump sum payitem is one with 

Unit = "LS" and the Lump Sum toggled on. Payitems of this type will always total 1 unit. 

Mobilization and training are payitems typically in this category.  A hybrid lump sum 

payitem is one with Unit not equal to "LS" but with the Lump Sum toggled on. These 

payitems are measured in standard units (SY, LF etc.) but paid in lump sum. One 

example would be for clearing and grubbing areas which is normally measured in SY and 

still paid in lump sum. The total quantity will be measured in the specified units. 

 Unit - Unit of measure for the payitem, i.e. SF, SY, LF, TN etc.  

 Total Rounding – The total quantity rounded to the user-desired decimal places. 

 Rounded Value - This can be used for entering quantities for payitems that will have a 

single quantity such as Mobilization.  This eliminates the additional step of adding a 

quantity to a payitem by adding the payitem and its corresponding quantity with a single 

dialog. 

 

Quantities - To add a new quantity, select a payitem, then select Insert > Quantity from the 

pulldown menu or Insert Quantity from the popup menu.  Two tabs are supported. The General 

tab has a variety of different quantity options, as well as descriptions and other general 

information. The Location tab has key-in fields for minimum and maximum station / offset 

values. Many of the fields in the Quantity Properties dialog are optional. However, you should 

provide as much information as possible, as some fields may be utilized and relied upon when 

reports are generated.  

 

General 

 Measurement Basis - The 

measurement basis refers to 

the graphic element type 

which was used to derive 

the quantity. Typically, cells 

are measured per each, lines 

and line strings are 

measured linearly and 

shapes are measured as 

areas. An exception would 

be counts of standard length 

pipes, which may be drawn 

as line elements. Three 

measurement types are 

supported: Each, Linear, 

Area. 

 Measurement Value - The 

actual measurement with no formulas, adjustments, rounding, etc. For example, when 

doing pavement computations, the Measurement is the square feet (or square meters) of 

the closed shape representing pavement. 
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 Computed Quantity - If a formula was used, this field is the result of the computation. 

Using the pavement example, a formula that uses the square feet of the area from which 

tons are computed based on thickness would provide a computed tonnage quantity. 

 Rounded Quantity – the rounded Computed Quantity. This is sometimes referred to as 

the gross quantity. 

 Deduction Quantity – A quantity to be deducted from the Rounded Quantity. 

 Net Quantity – the resulting quantity from the summation of the Rounded Quantity – 

Deduction Quantity. This is the quantity which contributes to the total quantity for the 

payitem. 

 Boundary Type – A defined boundary for the quantity limits. The options are: None, 

Fence, View, Sheet, Station Range or Element. This can be useful when computations are 

tabulated by sheets or specific limits. 

 Boundary Name – The name of the Boundary element. To review boundary properties, 

click the Boundary button to invoke the Boundary dialog. In this dialog boundaries can 

be added, reviewed, and / or changed.  

 Run Name – This is defined by the user. The run name is a grouping mechanism to 

permit segregation of quantities or payitems.  

 Phase - The phase to which the quantity belongs. The currently available phases are 

listed in a drop-down list. To review phase properties, click the phase button to invoke 

the phase dialog. In this dialog phases and funding rules may be added, reviewed, and / or 

changed.  

 Date / Time – This button documents the Date and Time the quantity was computed or 

updated. Click the Set Current to reset the date / time to the current. 

 Remarks - Key-in field for remarks. Limited to 256 characters. 

 Description - Key-in field for Description. Limited to 256 characters. 

 Extended Description - Key-in field for Extended Description. Limited to 256 

characters. 

   - Activates the Windows standard calculator for quick access for manual 

calculations. 
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Location 

Most quantities are referenced to their 

location on a project. Since the means 

of reference used for civil projects is a 

baseline chain, it is often 

advantageous to define the quantity 

based on its location in respect to the 

project baseline. In the dialog right, 

the Baseline Chain is selected from 

the list of chains defined in the 

Quantity Manager database.  

 

Based on the selected baseline, 

Minimum and Maximum Stations and 

Offsets are to be entered. Note that for 

a linear quantity, minimum and 

maximum stations do not always 

correspond to begin and end stations, 

but to the lowest and highest station 

points. Similarly for an area item, minimum and maximum stations do not correspond to the 

lower left / upper right points of a rectangular shape, but to the lowest & highest station points in 

relation to the baseline.  A drop-down list of the valid Regions on the Baseline Chain for station 

equations is provided. Minimum and maximum stations/offsets are optional items, and are not 

required unless they are needed for reporting or funding computations. 

 

Adhoc Attributes 

The Adhoc Attribute tab allows the 

user to add adhoc information to any 

quantity. The value of the adhocs can 

be added to reports. For example if 

an Adhoc is added named Remarks, 

its value is automatically displayed 

on many of the reports. 

 

Bulk Loading Pay Items with Quantities 

In addition to adding payitems and quantities individually, payitems with their respective 

quantities can be imported into QM via a CSV file. The CSV file should contain the payitem 

name, description, unit, and quantity. See the example CSV file below.  
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This is simply a text file with a header for each delimited field. The items can be in any order 

and the header can be any test. The header text is mapped to the appropriate field in the Import 

PayItems dialog box. 

 

To import payitems and quantities into QM activate the import dialog from File > Import > 

Payitems > from CSV. The fields that are to be imported must be defined with the appropriate 

header. See the image below. The category that these items are to be imported into must be 

selected then click on Import. 
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Exercise: Adding Quantities Manually 

1. Continuing in the same database from the 

previous workshop, from the PayItem 

pane, right click on the PayItems category 

and select Insert Subcategory. Name the 

category “Manual Quantities”. 

2. Right click on the “Manual Quantities” 

category and select Insert Payitem….  

From the New PayItem Properites dialog 

box, click on the Browse Master PayItem Icon.   Set the PayItem Filter as 

shown in the dialog below.    

 

 

 

 

                                                                                                                                                                                         

 

 

 

 

 

 

3. Select the PayItem Mobilization. The dialog is automatically filled out with 

the required information. Click OK when completed. 

4. Select the PayItem 

Mobilization and 

right click to select 

Insert Quantity. 

Enter a value of 1 for 

Measurement Value 

and Computed 

Quantity. Set Phase 

to DesignEstimate 

and click on Create. 

Click Close to close 

this dialog. 

5. Following the same 

steps add the 

PayItem 

„Maintenance of 

Traffic‟ with a value 
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of 1 and arbitrarily fill out additional fields in the general and location tabs. 

The QM dialog should appear as follows.  

6. Right click on the category 

Manual Quantities and 

again select to add a new 

payitem. Select the payitem 

0102 73 Guardrail 

(temporary). Fill out the 

dialog boxes as shown 

below. Click on Create and 

then on Close. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7. Import Payitems and Quantities using the Import dialog and the file 

payitems_ex.csv. 
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Merging QM Databases 

If the quantities for a project were created by multiple users and stored in separate databases, the 

databases should be merged together prior to exporting the quantities to Trns*port or creating 

final reports. The main consideration is that the databases must be the same version.  

 

 

To merge a database into the active database, from the QM 

menu select Project > Merge Database.  
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The Merge Database process will merge an entire database or the user has the option to restrict it 

to specific categories, payitems, descriptions, and phases. If the preliminary check of the 

database shows that the 2 databases are compatible then the user is prompted to Continue. When 

the Merge is complete it is displayed in the text box. 
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 Exercise: Merging Databases 

1. In dsgnrd01.dgn, activate the 

D&C Manager and open the 

workshop.ddb file. Set the 

mode to compute and add the 

Categories “Pavement 

Markings” and “Signing” to 

the collection box. Compute 

quantities for Signing and 

Pavement Markings as shown 

in the dialog boxes below. 

Export the computation 

results to signs_pm.mdb 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. While still in the Quantity Manager database created in the previous labs, 

workshop.mdb, select Project > Merge Database. Select the database created 

for Signing and Pavement Markings and Signals (if created). 

3. Click on Merge. After the database is analyzed and the Continue button is 

activated, click on Continue to complete the merging of the database. Click on 

close exit the dialog. 
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Cost Comparisons in QM 

Importing Pay Item Cost 

The cost of each valid pay item can be imported into a QM project to do cost comparisons. By 

using phases to segregate payitems, cost comparisons can easily be done for proposed alternates. 

The import function is accessed from the File > Import > Unit Cost > From CSV (comma 

separated) Document. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Since the file format is CSV it is very flexible. Therefore the fields to import are defined within 

the dialog, based on key words in the first row of the CSV file.  There can be extra fields which 

are ignored or columns in a different order than shown in the dialog.  

 To Import unit cost from a CSV document 

1. Open the Import Unit Cost from CSV Document dialog. 
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2. Click the Browse icon  and navigate to the CSV file. 

3. Set Search filter if you want to import all items, set the filter to *. 

4. Toggle on the items that are in the CSV file.   

5. For each toggled item, enter the keyword from row 1 in the CSV file in the From:  CSV 

Field in the dialog. It is case sensitive. It must match exactly. 

6. If a value for a particular item is missing (for example the UnitCost), enter the Default 

value (in this case 0.) 

7. Click on Import Unit Cost.   
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Exercise: Creating cost estimates 

1. From the Quantity Manager menu select File > Import > Unit Cost > From 

CSV (comma separated) Document.  

2. Populate the dialog as shown below.  

 
 

3. Click on Import Unit Cost. 

4. Select a payitem 0520 1 10 and review its properties as shown below. 
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Creating Reports in QM 

A variety of reports of the payitems and their respective quantities in a Quantity Manager 

database can be created using report styles. These styles are defined by the type of Payitems 

selected. The type is Each, Area, Linear or General.  

 

A basic report may contain only payitems, while a detailed report may have payitems, quantities, 

and data from the Element Table. XSL style sheets controls the amount of detail in the report and 

the formatting of the report. A report style must be created prior to the generation of a report. 

Report styles are not stored in the Quantity Manager database but in an external XML file so it 

may be shared between projects. 

 

The Behind-the-Scenes Process 

When a report is being created, Quantity Manager first exports a temporary XML file from the 

data stored in the database. This XML file is then "Transformed and Rendered" into the final 

report. Currently Quantity Manager supports Adobe PDF, CSV, Text and HTML formats. The 

diagram below depicts this process.  
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Creating a Report 
Once the Report Style has been created, reports can be generated. To create a report, select the 

categories and / or pay items to be included in the report.  

 

Select Tools > Reports > Create to open the dialog depicted below. 

 

 
 

 Active Phase - If All Phases is selected, the Create button is disabled unless all phases 

are supported for this report. Although the Active Phase cannot be changed (display only) 

in this dialog, a Phase change made in the main dialog automatically changes the Create 

Report dialog box.  

 Report Style - Select the Report Style from the list of all Report Styles. 

 Report Type - PDF, CSV, HTML and TXT are supported.  Note the type is display only, 

as it is determined from the Report Style. 

 Report File Name - Enter the Report File Name or click the Folder icon to select a pre-

existing report. 

 Create / Append - Click Create to generate the report or Append to append to a 

previously created report. Once the report is created, the document will be opened by the 

default associated application. 

 

Creating Report Styles 
Report styles can be created, reviewed, modified and deleted from the Report Styles dialog box, 

which is opened by selecting Tools > Reports > Define Styles.  
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Click the New icon  at the bottom to open the New Report Style dialog seen below. 

 
 

 Style Name - Name of Style. Limited to 256 characters. 

 Description - Description of Style. Limited to 256 characters. 

 Payitem Type - This specifies the intended payitem type for this style. Four options are 

supported: 

o EACH 

o LINEAR 

o AREA 

o GENERAL – summary of payitems 

 Export Style - Nine options are supported which controls the amounts of data in the 

report: 

o Payitem (Bentley QM XML) 

o Payitem + Finding(Bentley QM XML) 

o Payitem + Quantity (Bentley QM XML 2) 

o Payitem + Quantity + Element (Bentley QM XML) 

o Payitem + Quantity + Element Sorted (Bentley QM XML) 

o Payitem + Quantity Sorted(Bentley QM XML) 

o aecXML 

o aecXML + Funding 
Note: Typically, you would want to specify the minimum granularity you need for 

your report. For example, if you are creating a summary report of payitem 
with totals, the best option is "Payitem". If you select "Payitem + Quantity" 
the report will still work, but it may be slower in rendering, because extra 
data is being "published" that is not necessary for the report. 

 Document Type - HTML, CSV, PDF, and TXT (ASCII text) are supported.  

 XSL File Name - Name of XSL stylesheet for formatting. 

 All Phases Support - This report can be used for any Phase. 
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Exercise: Create Quantity Reports 

1. Click on the PayItem Table tab. This will allow us to easily select and sort 

payitmes for creating reports. Customize the panes to look like the image below. 

 

2. Set the phase to design estimate 

3. Select the payitem  0520 1 10 and select all quantities. 

4. Create a report, using the report Style FDOT Form 700-050-02 Curb and 

Gutter Computations (PDF). Use the file name of candg.pdf. 

5. Create and review the resulting report. 

6. Select the payitem 0110 1  1 Clearing and Grubbing. 

7. Create a report using the report style FDOT Form 700-050-01 Area 

Computations (PDF). Use the file name of clearing.pdf. 

8. Create and review the resulting report. 

9. Create a new report style called „MyStyle‟. Complete the dialog box as shown. 

Set the XSL file to “Sample pay item by funding report CSV.xslt”. Click OK to 

save the style.  
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10. Create a report of all the payitems in your database using the „MyStyle‟ report 

style just created. Name the report funding.csv. 

 

11. Review the new CSV file in Excel. The file should look similar to the image 

below. 
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Exporting Quantities from QM to 

Trns*port 

Quantity Manager includes a utility that facilitates exporting the quantity information into a 

format that can be imported into Trns*port. The format of the file is a predefined XML format. 

Only the items displayed in the Quantity Manager payitem table widow will be exported.  The 

Quantity Manager Project Export XML file is used for Trns*port CES and PES which will 

add/update the pay items, their quantities and funding into Trns*port. The steps required to 

create this file is listed below: 

1. From QM menu, select Project >Export > Export 

2. Select Export Style “aecXML + Funding” 

3. Toggle on Rename Phase As “DesignEstimate” 

4. Choose file location and name to save XML file.   

5. Click the EXPORT button 

 
 

Naming convention when exporting to Trns*port: 
 

Data Restrictions 

Project Names <= 13 characters 

Funding Rules > 1 and < 9999 

Phases DesignEstimate 

Quantity Value Maximum of 999,999,999.999 

Pay Items Must Exist in Trns•prt 

Payers Must Exist in Trns•prt 
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Exercise: Exporting Data from Quantity Manager into an XML File for 
Trns*port. 

4. From QM menu, select Project >Export > Export 

5. Select Export Style “aecXML + Funding” 

6. Rename Phase As “DesignEstimate” 

7. Set the file location to the workshop folder and name the file Trnsport.xml as 

shown below.  

 

 

 

 

 

 

 

 

 

 

 

 

8. Click the EXPORT button. 

9. Review the resulting XML file. 

 


