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Exploring Template Constraints and 
Display Rules 

 

This module is an introduction to the Create Template tool. You will learn the basics of 
creating and editing templates and the components and points that make up the 
templates. 
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In this lesson we will… 

•   Learn about template point constraints and components 
•   Create template components 
•   Create a complete template from the components 
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Constraints on Template Points

 
Point constraints are used to manage the behavior of template points. They are used so 
that if a point is moved in a template, either by you editing the template or by the 
application of point controls during design processing, all the points related to the point 
being moved will behave in a predictable manner. 

•  A template point has a maximum of two constraints on it.  A point with two 
constraints is considered “fully constrained.” A point that is fully constrained 
is represented by a red plus sign. 

•  A point that has only one constraint on it is considered “partially constrained” 
and is shown as a yellow plus sign. 

•  A point with no constraints (unconstrained) is shown as a green plus sign. 

Constraints can also be labeled so that during the design process the value of labeled 
constraints may be changed. For example, the template may have a constraint label 
called Thickness that controls the thickness of the asphalt wearing surface. This 
thickness can be changed so that one template can be used for different asphalt depths, 
without having to edit the template. 
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Types of Constraints 

Roadway Designer provides a variety of constraint types for roadway template design as 
described below. This course discusses the Horizontal, Vertical, and Slope constraints. 

Horizontal 

The child point remains at the specified horizontal distance from the parent point. 

Vertical 

The child point remains at the specified vertical distance from the parent point. 

Slope 

The child point maintains the specified slope from the parent point. Slope constraints 
can, additionally, have rollover values assigned to them. Rollover values are used to set 
the slope constraint based on a high side slope difference and a low side slope 
difference relative to a reference point which defines the controlling slope to the parent 
point. Slope constraints are absolute. Slopes going from lower-left to upper-right are 
positive regardless of whether the child point is to the left or right of the parent. 

Horizontal Maximum  

The child point has two parent points and remains at the specified horizontal distance 
from the parent point that is farthest to the right (has the maximum horizontal or X value). 

Horizontal Minimum 

The child point has two parent points and remains at the specified horizontal distance 
from the parent point that is farthest to the left (has the minimum horizontal or X value). 

Vertical Maximum   

The child point has two parent points and remains at the specified vertical distance from 
the parent point that is highest (has the maximum vertical or Y value). 

Vertical Minimum   

The child point has two parent points and remains at the specified vertical distance from 
the parent point that is lowest (has the minimum vertical or Y value). 
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Vector Offset 

The child point is projected onto the vector defined by two parent points. If the offset is 
not zero, then the child point will maintain a perpendicular offset from the parent vector 
at the specified offset value. Negative values indicate an offset to the left of the vector 
defined by the parent points. Positive values indicate an offset to the right. If the offset is 
zero, the child point is located on the parent vector. 

Project to Surface 

This constraint must be used in conjunction with one of the previously defined 
constraints.  The other constraint will define the projection direction. The child point will 
then be projected to the surface with the specified name. If the surface does not exist, or 
no solution is found, the point will remain where it is placed in the template. 

Project to Design 

This constraint is similar to Project to Surface, except that the point is projected to the 
design surface of the template. A projection value is given to indicate whether the 
projection is to be to the left or to the right. Again, the point must also be constrained by 
one of the previous constraints, excluding the Project to Surface constraint, so that a 
direction for the projection may be determined. If no solution is found, then the point will 
remain where it is placed in the template. 

Angle Distance  

Use this command to fully constrain a point in the template. This constraint requires two 
parent points, a distance, and an angle. The point is constrained to the location defined 
by the distance from the first parent, and the angle from the first parent relative to the 
vector defined by the two parent points. This constraint creates a rigid-body rotation. 
When selected, no other constraint types are available. 
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Visual Indicators for Parent-Child Relationship

 
Parent-Child Point Relationship 

When a point is constrained, it is constrained from either one or two other points. Points 
are constrained in a two dimensional (cross section) plane. Constraints can affect only 
the point’s offset and elevation, which is the X and Y coordinates in a cross section 
view. Point constraints are also directional. The direction forms a parent-child 
relationship between points. If point B is constrained by point A, point A is said to be the 
parent of point B. When viewing the constraints, the parent point has a blue arrow 
pointing to the child point. To see the constraints in a template, set the Constraints radio 
button located in the Display portion of the Create Template dialog. 

Horizontal Constraint 

A horizontal constraint is when a child is horizontally constrained to the parent. When 
you move the parent point, the child point moves at a constant horizontal distance from 
that point, which is specified when the constraint is established. A white horizontal line 
crossing over the blue arrow indicates a horizontal constraint. 
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Visual Indicators for Vertical, Horizontal, and Slope 
Constraint

s 
Vertical Constraint 

A vertical constraint is when a child is vertically constrained to the parent. When you 
move the parent point, the child point moves at a constant vertical distance to that point, 
which is specified when the constraint is established. A white vertical line crossing over 
the blue arrow indicates a vertical constraint. 

Horizontal and Vertical Constraint 

A horizontal and vertical constraint is when a child is horizontally and vertically 
constrained to the parent. When you move the parent point, the child point moves at a 
constant horizontal and vertical distance to that point, which is specified when the 
constraint is established. A white horizontal and vertical line crossing over the blue arrow 
indicates a horizontal and vertical constraint. When a point has two constraints, such as 
horizontal and vertical constraints, that point is fully constrained and is shown in red. 
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Slope Constraint 

A slope constraint is when a child is constrained to the parent by the slope between the 
two points. When you move the parent point, the child point moves at a constant slope 
with respect to the parent point, which is specified when the constraint is established. A 
white diagonal line crossing over the blue arrow indicates a slope constraint. When a 
point has only one constraint, such as a slope constraint, it is called a partially 
constrained point and is shown in yellow. 
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LESSON NAME: OPENING A PROJECT (INROADS USER) 

LESSON OBJECTIVE: 
In this lesson the student will learn to access an InRoads project in preparation of con-
structing templates and component display rules.  Note, this lesson is for InRoads users 
only. For GEOPAK users, please proceed to the next lesson on the next page. 

 EXERCISE: GETTING STARTED (INROADS USER) 
This exercise will guide you through the steps to get started 

1. Go to Start > Programs > Bentley > InRoads Group V8i (SELECTse-
ries 1) > InRoads Suite. 

2. The instructor will provide the appropriate path location for this project. 
When the MicroStation Manager appears select the file: 
Plan.dgn and press OK. 

3. When the InRoads Explorer appears, go to File > Open from the InRoads 
menu. 

4. When the Open dialog appears select the InRoads project file:  
My_Project.rwk and press OK. 
Opening the RWK project file opens the following files: 
CMJOB001.alg 
Templates.itl 
Original.dtm 
Default_Styles.xin 

5. Select Modeler > Create Template from the InRoads Explorer menu to 
access the Create Template Application.  
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LESSON NAME: OPENING A PROJECT (GEOPAK USER) 

LESSON OBJECTIVE: 
In this lesson the student will learn to access a GEOPAK Corridor Modeler project in prep-
aration of constructing templates and component display rules.  Note, this lesson is for 
GEOPAK users only. 

 EXERCISE: GETTING STARTED (GEOPAK USER) 
This exercise will guide you through the steps to get started 

1. Go to Start > Programs > Bentley > MicroStation V8i > Bentley MicroSta-
tion V8i (SELECTseries 1). 

2. The instructor will provide the appropriate path location for this project. When the 
MicroStation Manager appears select the file: 
Plan.dgn and press OK. 

3. Go to Applications > Road > 3D Tools > Corridor Modeling. 
 
IMPORTANT: A prompt will appear asking to re-import the DDB file.  Make sure 
to select Cancel. 
 

4. Select the GPK job number 001 
5. Choose File > Load from the Corridor Modeling dialogue. 
6. Load the Corridor Modeler project file entitled My_Project.rdp. 
7. Choose the Open Create Template icon from the Corridor Modeling dialogue to 

access the Create Template Application. 
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Lesson Name: Observing Template Constraints Behavior 

LESSON OBJECTIVE: 
In this lesson the student will learn to select a template, move points and observe the be-
havior, change point constraints, and delete components. 

 EXERCISE:  
This exercise will guide you through making a template active and displaying a 
component’s constraints. 

1. Double-click the Template named Constraints Behavior from the Constraints

This makes the template 

 
folder. 

Constraints Behavior
2. Set the 

 the current template. 
Constraints and Display Point Names in the Display

•  Point 1 is the parent of Point 2. 

 portion of the Create 
Template dialog. 

•  Point 2 is the child of Point 1. 
•  Point 2 is horizontally and vertically constrained to Point 1. 
•  Point 2 is the parent of Point 3. 
•  Point 3 is the child of Point 2. 
•  Point 3 is horizontally and vertically constrained to Point 2. 

 EXERCISE:  
This exercise will guide you through moving template points and modifying point 
constraints. 

1. Right-click on Point 1 and select Move
Observe how the Points 1, 2 and 3 move as a rigid body. 

 Point. 

2. Right-click to exit Move Point. 
3. Right-click on Point 2

It is not possible to move a fully constrained point. 

 and notice that Move Point is no longer available. 

Let’s see what happens when we remove the vertical constraint from Point 2. 
4. Double-click 

The Point Properties dialog opens.  

Point 2. 

5. Change Constraint 2 from Vertical to None and click Apply, then 

Notice the color of the point turned from red to yellow. 

Close. 

6. Move 

Notice the horizontal distance between Points 1 and 2 remains the same. 

Point 1. 
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7. Move 

Notice the horizontal distance between Points 1 and 2 remain the same. 

Point 2. 

Also notice that the horizontal and vertical distance remains the same between 
Points 2 and 3. 

8. Double-click Point 2
9. Change 

 again. 
Constraint 1 from Horizontal to Slope and click Apply, then 

10. Move 
Close. 

Notice the behavior is similar to before. However, Point 2 is now constrained at a 
constant slope from point 1 instead of at a constant horizontal distance. 

Points 1 and 2. 

 EXERCISE:  
This exercise will guide you through deleting components from a template. 

11. Delete the component by right-clicking with your cursor directly over the 
component and selecting Delete Component
Notice there is also a Delete Components command that is used to delete 
multiple components. 

. 
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Adding and Deleting Constraints Graphically

 
In addition to editing the template point constraints using the Point Properties dialog, you 
can right-click on any point to access Add Constraint or Delete Constraints. This is 
very handy for making quick adjustments to the template constraints.  

Delete Constraints removes all constraints from the point.  

Add Constraint lets you pick the type of constraint you want to add to the point.  

Full Constraint 

Right-click on the child point you want to constrain, select 

adds both horizontal and vertical constraints to a point. 

Add Constraint, and select 
the point constraint you want to add. Then click the parent point and key in the offsets or 
slope values of the child point from the parent. Setting the appropriate constraints on 
points is important to achieve the desired results when pavement layers, superelevation, 
and transitioning are introduced to the design. Using the Point Properties dialog is 
helpful for adjusting point constraints after the initial point placement. 
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LESSON NAME: OBSERVING TEMPLATE CONSTRAINTS BEHAVIOR 

LESSON OBJECTIVE: 
In this lesson the student will learn to add and delete constraints and components. 

 EXERCISE:  
This exercise will guide you through making a template active and displaying a 
component’s constraints. 

1. Continue working on the template library used in the last practice activity 
2. Select the Add and Delete Constraints 

3. Set the 

template and make it the current 
template. 

Components and Display Point Names options in the Display

4. Right-click on the 

 area of the 
Create Template dialog. 

CL_AGGR_B_BOT point and select Delete Both 
Constraints
Notice the color of the point turns from red to green. 

. 

5. Delete the constraints on the EOP_AGGR_B_BOT and SHDR_AGGR_B_BOT

6. Right-click on the 

 
points. 

CL_AGGR_B_BOT point and select Add Constraint > Full 
Constraint

7. Click on the 
. 
CL_AGGR_A_BOT

The Add Full Constraint dialog opens. 

 point. 

8. Key-in a Horizontal Offset of 0.0 and a Vertical Offset of -1.0 and click 
9. Right-click on the 

OK. 
EOP_AGGR_B_BOT point and select 

10. Click on the 

Add Constraint > Full 
Constraint.  

EOP_AGGR_A_BOT

The Add Full Constraint dialog opens. 

 point. 

11. Key-in a Horizontal Offset of 0.0 and a Vertical Offset of -1.0 and click 
12. Right-click on the 

OK. 
SHDR_AGGR_B_BOT point and select 

13. Click on the 

Add Constraint > 
Slope.  

EOP_AGGR_B_BOT

14. Key-in a 

 point.  The Add Slope Constraint dialog 
opens. 

Slope of -6.0% and click 
15. Right-click on the 

OK. 
SHDR_AGGR_B_BOT point again and select Add Constraint 

> Slope
16. Click on the 

. 
SHDR_AGGR_A_BOT point. 
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17. Key-in a Slope of -25.0% and click 
18. Right-click on the Current Template Window and select 

OK. 
Delete Components

19. Hold down the left mouse button and draw a line across a few components. 
. 

Release the left mouse button when done. 

To undo the deletion, press the CTRL+Z
 

 buttons on the keyboard. 

The Sign of the Distance and Slope

 

When defining components with precision input, the sign of the distance is dependent on 
the parent-child relationship. The parent is always the first point placed when creating 
template components. The distance is positive if the parent has a lower X or Y value 
than the child. The distance is negative if the parent has a higher X or Y value than the 
child. The sign of the component slope is based on the mathematical slope. 
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Simple Component

 
A component is a set of points that define an open or closed shape. Each component, 
whether open or closed, can represent a different material or area of interest.   

Components are saved in the template library and are normally stored in a separate 
folder in the Template Library folder structure.  

To create a component, first select File > New Template and name the template 
component. Then, use Add > Simple or Add > Constrained

There are five types of components:  

 to build the component. 
Each component has a name and an assigned feature style.  

•  Simple 
•  Constrained 
•  Unconstrained 
•  Null Point 
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•  End Condition 

As you add template components, the area under the graph changes to represent the 
parameters for the component input type. This is called the Current Component area. 

A simple component typically represents a section of pavement or sidewalk. It is a 
closed parallelogram that is defined by slope, thickness, and width. The top points are 
constrained by horizontal and slope constraints. The lower points are constrained to the 
points directly above them by horizontal and vertical constraints. 

The Constrained, Unconstrained, and End Condition component types are discussed 
later in this chapter. Null Points are more advanced than this course and are therefore 
not discussed during this training. 

Note for GEOPAK Users: 

The type of template components used affect how GEOPAK end area volumes are 
computed and how cross section reports are generated.  

If your workflow only requires dirt quantities, and not individual pavement layer end 
area volumes, you can use any type of component as described in this training 
guide. 

However, if your workflow requires end area volumes for each pavement layer or if 
the workflow requires detailed cross section reports, your templates must be defined 
using non-closed components. The issue with closed components is that the top, 
bottom, and sides of the component all share the same feature and graphic 
symbology. Since these are all the same GEOPAK cannot determine what each line 
represents. Furthermore, closed shapes also result in multiple lines at the same 
location in the cross section. For example, the line representing the bottom of the 
pavement is coincident with the line representing the top of the base.  

The recommended workflow to combat this issue is to create templates from 
non-closed components. The top of the surfacing layer is created as one non-closed 
component. The sides and bottom of subsequent pavement layers for base, sub 
base, etc. are created using additional non-closed components. Each component 
should be associated with a different feature so the resulting graphic symbology is 
unique. Having unique graphic symbology for each pavement layer allows the 
GEOPAK end area volume and cross section report tools to process correctly. 

Simple components are closed shapes by definition and therefore should not be 
used when pavement layer end area volumes are required. Both Constrained and 
Unconstrained components can be closed or non-closed. To create non-closed 
components, right click and disable the Closed Shape option. Null Points and End 
Condition components are non-closed by definition. 
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LESSON NAME: CREATING A TEMPLATE OF SIMPLE COMPONENTS 

LESSON OBJECTIVE: 
In this lesson the student will learn to create templates by adding simple components and 
saving the template library. 

 EXERCISE: CREATING A TEMPLATE 
1. Browse to the folder named Components
2. Create a template named 12’ Concrete Pavement w/8’ Shoulder

 in the Create Templates dialog. 

 EXERCISE: STARTING DYNAMIC SETTINGS 
. 

3. Select Tools > Dynamic Settings.
4. If set, clear the 

  
Apply Affixes 

5. Set the Horizontal and Vertical Step to 0.1. 
option in the Dynamic Settings dialog. 

 EXERCISE: ADDING A SIMPLE COMPONENT 
6. Right-click on the Current Template window and select 

7. Setup the 

Add New Component > 
Simple. 

Current Component portion of the Create Template dialog as follows: 

Component Name: CONCRETE 
Style: P_ROAD_Concrete 
Slope: -2.000% 
Thickness: 1.000 
Width: 

8. Place the component at the origin of the Current Template window. 
12.000 

9. Right-click on the Current Template window and select Add New Component > 
Simple

10. Setup the 
. 

Current Component

Component Name: 

 portion of the Create Template dialog as follows: 

 Since this is the same name as the first component created, the name is 
automatically appended with a 1 resulting in 

CONCRETE 

Concrete1 as the component name. 

Style: P_ROAD_Concrete 
Slope: -6.000% 
Thickness: 1.000 
Width: 8.000 
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11. Place the component at the right edge of pavement point of the Current 
Template window. 

Save Template Library 
12. Select File > Save

 
 in the Create Template dialog. 

Template Point Names

 

Templates are used by the Roadway Designer to create surfaces of the proposed 
roadway. Each template point will be connected longitudinally to the next template drop, 
based on the interval, to form longitudinal breakline surface features. The names of 
those features are the name of the template points. Therefore, establishing a standard 
naming convention for template points is important to the quality of the proposed 
surface.  

Likewise, individual component names also appear in the ensuing surfaces. These 
components are used for volume calculations, so standard naming conventions should 
be applied to ensure consistent results.  

When transitioning between two templates (going from a two-lane to a four-lane 
roadway, for example), the Roadway Designer attempts to connect template points of 
the same name to model the transition. Template transitioning makes consistent 
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template component and template point naming even more important. Each template 
point name and component name must be unique within a template. For accurate 
volume calculations and surface creation (especially during template transition), 
different templates should use consistent component and template point names. 
Roadway Designer automatically appends the name with a unique number if the same 
name is chosen during template creation. Also,  Roadway Designer provides for 
automatic prefixes and suffixes (such as LT_ and RT_) when components are created or 
added to the left or right side of the origin point. Prefixes and suffixes for template point 
names are defined using Tools > Options 

Editing template point names is accomplished by right-clicking on a template point and 
selecting Edit Point. Double-clicking the point also invokes Edit Point. This opens the 
Point Properties dialog, where the point name and surface feature style are changed. 
After you change the point name, click 

in the Create Template dialog. 

Apply. The Next > and < Previous buttons help 
to change multiple points by moving from point to point within the same template. 
Enabling the Display Points Names option in the Display

The Point Name List is used to create template point names. These names are then 
selected during component creation or editing to reduce time spent keying in the names. 
To add names to the Point Name List, right-click on Point Name List in the Template 
folders and select 

 portion of the Create Template 
dialog allows you to visually verify the point names.  

  
Edit, or double-click on Point Name List. 
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LESSON NAME: EDITING TEMPLATE POINT NAMES 

LESSON OBJECTIVE: 
In this lesson the student will learn to create and edit template point names. 

 EXERCISE:  
Continue to work on the template named 12’ Concrete Pavement w/8’ Shoulder.  
The template components have been added, but the names should be changed to 
reflect a standard naming convention. 

1. Right-click on the Point Names List and select 

The Point Name List dialog opens. 

Edit. 

2. Key-in CL_CONC_BOT in the Name
3. Select the Style 

 field. 
P_COGO_MainCL and click 

4. Key-in 
Add. 

EOP_CONC_BOT in the Name
5. Select the Style 

 field. 
P_ROAD_EdgeOfPavement and click 

6. Key-in 
Add. 

SHDR_CONC_BOT in the Name
7. Select the Style 

 field. 
P_ROAD_Shoulder and click Add, then Close.

8. Double-click the point located at the template origin. 
  

The Point Properties dialog opens. 
9. Change the point Name to CL and click 
10. Click the 

Apply. 
Next >

11. Change the Name as follows: Click 
 button which will move you down one point.  

Apply, then Next >
Name  : 

 and repeat. 

CL_CONC_BOT     

EOP       

EOP_CONC_BOT    

SHDR      

12. Close the Point Properties dialog. 
SHDR_CONC_BOT    

13. Right-click on the vertical segment separating the road and shoulder and select 
the Merge Components
Now the merged component is named 

 command. 

14. Double-click on the component to verify the name. 
CONCRETE. 
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15. Select File > Save
 

 in the Create Template dialog. 

Constrained and Unconstrained Components

 

Add New Component > Constrained 

Examples of constrained components include median barriers, curb and gutter sections, 
retaining walls, and complex pavement sections.  

is used to create open and closed shaped 
template components using precision input. You can access this command by either 
right-clicking on the Current Template window or selecting it from the pull-down menu.  

Constrained components are created with horizontal and vertical constraints already 
applied to each point.  

Both closed and open shaped components can be created. The option to make the 
component closed or open is selected by right-clicking on the Current Template window 
during component creation.  

When creating template points, the Dynamic Settings dialog is used to define point 
names and styles. The Dynamic Settings dialog is also used to enter the precise location 
for the points. 
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The basic workflow for creating a constrained component is to: 
•  Select Add New Component > Constrained
•  Key-in the 

. 
Component Name and select the Style

•  Key-in the
 in the Current Component area. 

 Point Name and select the Style
•  Select the key-in type (hs= for example) and key-in the precision value (12.0,2.0% 

for example) in the Dynamics Settings dialog. 

 in the Dynamics Settings dialog. 

•  Press the Enter or Tab key on the keyboard. 
•  Repeat these steps until the last template point is placed. 
•  Right-click on the Current Template window and select Finish. 

Add New Component > Unconstrained 

This command works the same as using 

is also used to create open and closed shape 
template components using precision input. You can access this command by either 
right-clicking on the Current Template window or selecting it from the pull-down menu.  

Add New Component > Constrained

  

 except 
the components are created without any constraints on the points. The constraints are 
added manually using Edit Point or Add Constraint, accessed by right-clicking on any 
template point. 
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LESSON NAME: ADDING A CONSTRAINED COMPONENT 

LESSON OBJECTIVE: 
In this lesson the student will learn to create a concrete curb comprised of a constrained 
component. 

 EXERCISE: CREATE A TEMPLATE NAME 
1. Browse to the folder named Components
2. Create a template named Curb

 in the Create Templates dialog. 

 EXERCISE: PREPARING THE SETTINGS BEFORE COMPONENT CREATION 
. 

3. If the Dynamic Settings dialog is not displayed, select Tools > Dynamic 
Settings

4. If set, clear the Display Point Names check box. 
. 

 

Practice - Adding a Constrained Component (continued)

 



 

  9/23/09 
 

26   Copyright © 2008 Bentley Systems, Incorporated 

 

  EXERCISE: CREATING A CONSTRAINED COMPONENT 
5. Right-click on the Current Template window and select 

6. Setup the 

Add New Component > 
Constrained. 

Current Component portion of the Create Template dialog as follows: 

Component Name: CONCRETE CURB 

Style: 
7. Setup the Dynamic Settings dialog as follows: 

P_ROAD_ConcreteCurb 

Point Name: SHDR (Select from the list) 

Apply Affixes: disabled 

Precision Input: 
8. Press the Enter key 

xy = 0,0 

 The default units for precision input are feet. You can enter other units with the 
proper specification, such as 6” instead of 0.5. 

 Watch the prompts in the lower left corner of the Create Template dialog. When 
creating a component using precision key-in, an ESC allows you to go back. 
9. Set up the Dynamic Settings dialog as follows: 

Point Name: TOC 

Apply Affixes: disabled 

Precision Input: xy = 0.07,0.5
10. Press the Enter key. 

   (from similar triangles) 

11. Set up the Dynamic Settings dialog as follows: 

Point Name: BOC 

Apply Affixes: disabled 

Precision Input: 
12. Press the Enter key. 

hs = 5.5”,0.0 

13. Set up the Dynamic Settings dialog as follows: 

Point Name: BOC_BOT 

Apply Affixes: disabled 

Precision Input: 
14. Press the Enter key. 

dl = 0.0,-16” 

15. Set up the Dynamic Settings dialog as follows: 

Point Name: TOC_BOT 

Apply Affixes: disabled 
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Precision Input: 
16. Press the Enter key. 

dl = -7.75”,0 

17. Right-click on the Current Template Window and select Finish
18. Enable the Display 

. 
Point Names

Save the Template Library 

 option. 

19. Select File > Save in the Create Template dialog. 
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Basic Component Creation Workflow

 
Basic Component Creation Workflow 
•  Open the 
•  Select Open Create Template icon. This brings up the 

Template Library. 
Create Template

•  Navigate to the template folder used for components. 
 dialog. 

•  Select File > New > Template

•  Select 

 from the Create Template dialog. Name the new 
template, which is a component. 

Tools > Dynamic Settings
•  Select 

 if the Dynamic Settings dialog is not open. 
Add > Simple or Add > Constrained

•  Add template components by using the Dynamic Settings dialog to specify the 
 from the Create Template dialog. 

Point 
Name and Style

•  Select 
, and the point locations. 

File > Save from the Create Template dialog to save the template library. 
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Creating End Conditions

 
End conditions are template components which are used to model cut and fill 
treatments. They are added to the end of simple, constrained, and unconstrained 
components.  

End conditions are created like other template components. End conditions consist of 
template points and individual components, and appear as line segments. They are 
different than simple and constrained components because they have the ability to 
target surfaces, elevations, alignments and surface features.  

An example of this targeting is a design criteria which specifies a 4:1 fill slope if a fill 
height under 6 feet is encountered.  The target type is the original ground surface. 

To create an end condition, first select File > New Template and name the template. 
Then use Add New Component > End Condition to build the end conditions. End 
conditions are stored in the template library and normally are created in a separate 
folder in the template library.  
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Target Types 

Target types are specified in the Current Component portion of the Create Template 
dialog, which appears below the Current Template window during end condition 
creation.  

Target types are defined only for end condition components, and are a property of that 
component. To edit a target type, open the Component Properties dialog by 
double-clicking on the component or by right-clicking on the component and 
selecting Edit Component

A solution can intercept multiple targets and target types. A ditch design, for example, 
may intercept an alignment that represents the bottom of the ditch and then intercept the 
original ground surface to form the backslope of the ditch. 

. 

 
Surface – targets the active surface or any specified surface. Using the active 
surface as the target helps when you are applying the end conditions to different 
projects. This is because the end condition will still work even though the target 
surface name may be different, so long as it is designated as the active surface.  
Elevation – targets any specified elevation. 
Feature XY – targets the horizontal offset of any specified surface feature. 
Feature Elevation – targets the vertical elevation of any specified surface feature. 
Feature XYZ – targets the horizontal offset and vertical elevation of any specified 
surface feature. 
Alignment XY – targets the horizontal offset of any specified alignment. 
Alignment Elevation – targets the vertical elevation of any specified alignment. 
Alignment XYZ

Style Elevation – targets the elevation of any specified style. 

 – targets the horizontal offset and vertical elevation of any specified 
alignment. 

Style XY – targets the horizontal offset of any specified style. 
Style XYZ – targets the horizontal offset and vertical elevation of any specified style. 
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End Conditions Settings

 
End Condition Priority 

Simple end conditions consist of cut and fill segments. When creating the roadway 
design, each condition will be tested in a specific order. That order is called the priority, 
which is numeric, and is assigned during end condition creation. The most desirable 
conditions are assigned the lowest priority numbers. The most desirable condition, and 
the first condition to be tested, has a priority of 1. The next condition to be tested has a 
priority of 2, and so on.  

For example, a design criteria calls for two fill conditions; 4:1 fill slope for an 8 foot fill 
height and a 3:1 fill slope for a 10 foot fill height. In this example, the target of each 
condition is the original ground surface. Each condition will be tested starting with lowest 
priority number. The first condition to successfully intersect the target, which is the 
original ground surface in this example, will be applied.  

Priority is used when more than one end condition starts at the same point. In order for 
an end condition segment to be placed and used in the design, a segment or one of the 
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segments connected to that segment must successfully intercept its target. If a segment 
or its connected segments do not intercept their targets, that group of segments fails and 
the next group of segments, with the next higher priority, are tested. It is important that 
end conditions have at least one solution that will not fail to intercept their targets.  

End Condition Settings 

As you create the end conditions, there are several settings that will have to be 
considered to obtain the desired results. These settings are enabled or disabled and are 
set using the Dynamic Settings dialog during end condition point creation. To edit end 
condition settings, open the Point Properties dialog by double-clicking on the end 
condition point or by right-clicking on the point and selecting Edit Point. 

Check for Interception – when set, the line segment will search for the specified 
target. If not set, the line segment will be created at its full width regardless of 
whether it intersects the target, provided that one of the segments connected to this 
segment successfully intersects the target. 
Place Point at Interception – when set, a point will be placed at the location of the 
interception. If not set, the line segment will be created at its full width, provided that 
one of the segments connected to this segment successfully intersects the target. 
End Condition is Infinite – when set, the line segment will automatically be 
extended to intercept the target. If not set, the line segment will only extend to its 
maximum constraint to meet its target. This applies only to the last line segment in 
an end condition. 
Do Not Construct

  

 – If set, the end point of the line segment will be used as a 
reference point to find a subsequent point. The point will be solved like any other end 
condition point, but that point will be skipped when drawing the final component 
segments. This is normally not set and is used only for more complex condition 
testing. 
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LESSON NAME: CREATING END CONDITIONS 

LESSON OBJECTIVE: 
In this lesson the student will learn to create an end condition and save the template library. 

 EXERCISE: 
Create a New Template Name 

1. Browse to the folder named End Conditions
2. Create a template named Simple Cut and Fill. 

 in the Create Templates dialog. 

 EXERCISE: START THE DYNAMIC SETTINGS 
3. Select Tools > Dynamic Settings, if not already displayed.
4. Set the 

  
Display Point Names

 EXERCISE: CREATE END CONDITION COMPONENTS 
 check box. 

5. Right-click on the Current Template Window and select Add New Component > 
End Condition
The example design criteria calls for a 6:1 fill slope at fill heights between 0’ to 5’. 

. 

6. Setup the Current Component portion of the Create Template dialog as follows: 

Name: 6:1 FILL FOR 30‘   

Style: P_ROAD_FillLine 

Target Type: Surface    

Priority: 1 

Surface:
7. Setup the Dynamic Settings dialog as follows: 

 <Active> 

Point Name: BOC   (select from list) 

Apply Affixes: Disabled 

Precision Input: 
8. With your cursor in the 

xy = 0,0 
xy=

9. Setup the Dynamic Settings dialog as follows: 
0,0 field, press the Enter key on your keyboard. 

Check for Interception: Enable 

Place Point at Interception: Enable 

End Condition is Infinite: Disabled  

Do Not Construct: Disabled 

Point Name: 6:1 FILL   (key-in the name) 
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Point Style: P_ROAD_FillLine 

Apply Affixes: Disabled  

Precision Input: 
10. With your cursor in the 

hs = 30.0,-1:6 
hs = 30.0,-1:6 

11. Right-click on the Current Template window and select 

field, press the Enter key on your 
keyboard. 

12. Right-click on the 
Finish. 

BOC point on the Current Template Window and select 

The example design criteria calls for a 3:1 fill slope for fill heights greater than 5’. 

Add 
New Component > End Condition. 

13. Setup the Current Component portion of the Create Template dialog as follows: 

Name: 3:1 FILL     

Style: P_ROAD_FillLine 

Target Type: Surface    

Priority: 1 

Surface: 
14. Setup the Dynamic Settings dialog as follows: 

<Active> 

Check for Interception: Enable  

Place Point at Interception: Enable 

End Condition is Infinite: Enable 

Do Not Construct: Disabled  

Point Name: 3:1 FILL 

Point Style: P_ROAD_FillLine 

Apply Affixes: Disabled  

Precision Input: 
15. With your cursor in the

hs = 40.0,-1:3 
 hs = 40.0,-1:3

16. Right-click on the Current Template Window and select 

 field, press the Enter key on your 
keyboard. 

17. Right-click on the BOC point in the Current Template window and select 
Finish. 

The example design criteria calls for a 3:1 cut slope for all cut conditions. 

Add 
New Component > End Condition. 

18. Setup the Current Component portion of the Create Template dialog as follows: 

Name: 3:1 CUT        

Style: P_ROAD_CutLine 

Target Type: Surface    
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Priority: 1 

19. Setup the Dynamic Settings dialog as follows: 
Surface: <Active> 

Check for Interception: Enable 

Place Point at Interception: Enable 

End Condition is Infinite: Enable 

Do Not Construct: Disabled  

Point Name: 3:1 CUT 

Point Style: P_ROAD_CutLine 

Apply Affixes: Disabled  

Precision Input: 
20. With your cursor in the 

hs = 40.0,33.3%  
hs = 40.0,33.3%

21. Right-click on the Current Template Window and select 

 field, press the Enter key on your 
keyboard. 

Save the Template Library 

Finish. 

22. Select File > Save
  

 in the Create Template dialog. 
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LESSON NAME: ADDING A DITCH END COMPONENT 

LESSON OBJECTIVE: 
In this lesson the student will learn to create a ditch end component. 

 EXERCISE:  
Create Ditch End Components 

Continue to work on the end condition template named Simple Cut and Fill. 
1. Right-click on the 3:1 FILL point in the Current Template window and select Add 

New Component > End Condition
2. Setup the 

. 
Current Component portion of the Create Template dialog as follows: 

Name: DITCH  

Style: P_ROAD_Ditch 

Target Type: Surface    

Priority: 1 

Surface: 
 

<Active> 

3. To place the second point, set up the Dynamic Settings dialog as follows: 

Point Name: DITCH BOTTOM              (select from list) 

Check for Interception: Disabled

 This forces this line segment to be placed. 

  

End Condition is Infinite: Disabled 

Do Not Construct: Disabled  

Apply Affixes: Disabled  

Precision Input: 
4. With your cursor in the 

hs = 5,-1:4 
hs = 5,-1:4 

5. Setup the Dynamic Settings dialog as follows: 
field, press the Enter key. 

Point Name: DITCH BACKSLOPE         (select from list) 

Check for Interception: Disabled

 This forces this line segment to be placed. 

  

End Condition is Infinite: Disabled 

Do Not Construct: Disabled 

Apply Affixes: Disabled 

Precision Input: hs = 5,0 
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6. With your cursor in the hs = 5,0 
7. Setup the Dynamic Settings dialog as follows: 

field, press the Enter key. 

Point Name: DAYLIGHT               (select from list) 

Check for Interception: Enable  

Place Point at Interception: Enable 

End Condition is Infinite: Enable 

Do Not Construct: Disabled 

Apply Affixes: Disabled 

Precision Input: 
8. With your cursor in the 

hs = 5,25% 
hs = 5,25.0%

9. Right-click on the Current Template window and select 
 field, press the Enter key. 

Save the Template Library 
Finish. 

10. Select File > Save to save the template library. 
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Testing the End Conditions

 
Testing End Conditions 

End Conditions can be tested prior to and during end condition creation. Testing 
simulates how the end conditions will behave during modeling, without using the 
Roadway Designer. 

To test that the end conditions produce the desired results, select the Test

To test the end conditions, select one of the available targets and select the 

 button 
located under the Current Template window. This opens the Test End Conditions dialog. 
The window in the Test End Conditions dialog displays non-end-condition components 
as solid lines and end conditions as dotted lines. The scale of this window is dynamic 
and view controls are located at the bottom.  

Draw button 
located on the right side of the dialog. Move your cursor over the testing window. The 
end conditions will change from a dotted line to a solid line, revealing the final solution for 
the proposed target intercept. If there are any priority conflicts, you will receive a warning 
message. Select the Check Priorities button to review and edit the priority of each end 
condition. 
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LESSON NAME: TESTING THE END CONDITIONS 

LESSON OBJECTIVE: 
In this lesson the student will learn to test end conditions and change their priority. 

Continue to work on the end condition template named 

 EXERCISE:  
Simple Cut and Fill. 

Test the End Conditions and Change the Priority 

1. Select Test
A warning will be given about the template having end condition priority conflicts. 

 located under the Current Template window. 

2. Select Check Priorities
Notice that 

 on the right side of the Test End Conditions window. 

BOC

3. Select 

 point is a bold white color, which is an indicator of the point that 
has the priority conflicts.  

Edit
Notice that all the end conditions have the same priority number. 

. 

4. Put your cursor in each of the fields and notice the segments highlighting. 
5. Assume that fill is the most desirable condition and change the Priority of the 3:1 

FILL to 2 and the Priority of the 3:1 CUT to 
6. Click 

3. 
OK, then 

7. Click 
Close. 

Draw
8. Move your cursor over the end conditions. 

 on the right side of the Test End Conditions window. 

9. Change the Use Surface Slope to 10.00% and click Draw
10. Move your cursor over the end conditions. 

 again. 

11. Close the Test End Conditions dialog. 

Save the Template Library 
12. Select File > Save
13. Exit MicroStation. 

 to save the template library. 
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Basic End Condition Component Creation Workflow

  
Basic End Condition Component Creation Workflow 
•  Open the 
•  Select Open Create Template icon. This brings up the 

Template Library. 
Create Template

•  Navigate to the template folder used for 
 dialog. 

End Condition
•  Select 

 components. 
File > New > Template

•  Select 

 from the Create Template dialog. Name the new 
template, which is an end condition component. 

Tools > Dynamic Settings 
•  Select 

if the Dynamic Settings dialog is not open. 
Add > End Condition

•  Add end condition components by using the Dynamic Settings dialog to specify 
the 

 from the Create Template dialog. 

Point Name and Style
•  Select 

, and the point locations. 
File > Save from the Create Template dialog to save the template library. 
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Summary and Review

 

Summary 

You are now able to: 
•  Understand template point constraints and components 
•  Create template components 
•  Create a complete template from the components 
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Questions 

Before continuing, let’s reinforce what you have learned. 
1. True or False, Point constraints are used to manage the behavior of template 

points? 
•  True 
•  False 

 
2. A “Fully Constrained” point contains a maximum of how many constraints? 

A - None 

B - One 

C - Two 

D 
 

- Three 

3. Name three types of Constraints? 

A -  

B -  

C
 

 -  

4. True or False, the top points of a simple component are constrained to points 
directly below them by horizontal and vertical constraints? 
•  True 
•  False 

 
5. Which template component that is used to model cut and fill treatments? 

A - Constrained 

B - Simple 

C - End Condition 

D - Unconstrained 
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ANSWERS 
1. True or False, Point constraints are used to manage the behavior of template 

points? 

True

 

 - Point constraints are used to manage the behavior of template points. 
They are used so that if a point is moved in a template, either by the user editing 
the template or by the application of point controls during the design processing, 
all the points related to the point being moved will behave in a predictable 
manner. 

2. A “Fully Constrained” point contains a maximum of how many constraints? 

C
 

 - A point with two constraints is considered “fully constrained”. 

3. Name three types of Constraints. 

A - Horizontal Constraint 

B - Vertical Constraint 

C
 

 - Slope Constraint 

4. True or False, the top points of a simple component are constrained to points 
directly below them by horizontal and vertical constraints? 

False

 

 - The lower points are constrained to points directly above them by 
horizontal and vertical constraints. 

5. What is the template component that is used to model cut and fill treatments? 

C

  

 – End Conditions are template components which are used to model cut and 
fill treatments. They are added to the end of simple, constrained, and 
unconstrained components. 
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Exploring Component Display Rules 
 

Component Display Rules (CDRs) allow the user to create variations to a template based on ex-
ternal influences such as Horizontal / Vertical controls and end-conditions. This is a very powerful 
concept that allows the user to apply one template that will actually change based on what is 
happening at a particular station.  
 
This concept frees the user from knowing where a change in conditions might require a different 
template and allows the rules within a template to make modifications. 

There are two main parts to this functionality:  
First, there are the individual rules, which are stored within the template.  The following types are 
supported:  

Horizontal 
Absolute Horizontal (uses absolute values) 
Vertical 
Absolute Vertical 
Slope 
Absolute Slope 
Component is Displayed 

All but the last are conditional expressions between points that use one of the <, <=, =, >=, > op-
erators to compare the specified difference between the two points to a particular value. 

  

EXAMPLES: Rule1 - Horizontal Difference between Point1 and Point2 is less than 10 

  Rule2 - Slope from Point1 to Point2 is greater than -10% 

  Rule3 – Slope from Point1 to Point2 is less than 10%  

The rule, in general has 5 components: 

Name (no spaces allowed) 
Type ( e.g. Absolute Horizontal Difference ) 
Calculated value ( e.g. Point1.x – Point2.x ) 
Test ( <, <=, =, > , >= ) 
Test Value (e.g. 10 ) 
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The second part of this functionality is the conditional expression that is stored on the component.  
An example of a conditional expression is: 

  Rule1 OR (Rule2 AND Rule3)  

 

MODULE OBJECTIVES 
 

Upon completion of this module, you will be able to: 

 

Define and explain some of the uses of Component Display Rules. 
  
Develop a template that contains a set of Component Display Rules that automatically turns on and 
off a sidewalk depending on whether the sidewalks styles are present at a particular station. 
 
Apply the template to a design and review the results. 
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LESSON NAME: CREATING NULL POINTS 

LESSON OBJECTIVE: 
In this lesson the student will learn to add null points within a component and target a Style.  
The null points will be used to target the front and back of a proposed sidewalk.  The user 
will be modifying a back of curb treatment to target the front and back of the proposed si-
dewalk. 

 EXERCISE:  THIS EXERCISE WILL GUIDE YOU THROUGH ADDING A NULL POINT TO TAR-
GET THE FRONT OF SIDEWALK AND ANOTHER NULL POINT TO TARGET THE BACK OF THE 
SIDEWALK’S STYLES. 
1. Proceed to open the Create Templates dialog and navigate to the Components. 
2. Expand the Components category and make a copy of the Component entitled 

Back of Curb Turf Static SW.  Make a copy by right-mouse clicking and utilizing 
the copy and paste features. 

3. Rename this copied Component to Back of Curb Turf Variable SW by right 
mouse-clicking on the name and selecting rename. 

4. Add a Null point entitled SW_Front_Seek 1’ to the right of the point entitled Hinge 
and 0.6’ above the Hinge point.  To add a Null point simply right click in the 
drawing area and choose ADD NEW COMPONENT > NULL POINT.  Hint: add 
the null point and then assign constraints to move to the proper location. 

5. Edit the SW_Front_Seek Null point by double clicking the point and set the 
properties as shown in the Dialog: 
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6. Add a Null point entitled SW_Back_Seek 1’ to the right of the point entitled Hinge 
and 0.4’ above the Hinge point. 

7. Edit the SW_Back_Seek Null point by double clicking the point and set the 
properties as shown in the Dialog: 

 
 
The modified Component should appear as follows: 
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Hint: Setting a Range value of 0 results in an infinite search in both left and right 
directions.  Using a positive search value limits the search to the right direction 
only up to a distance of 20 master units.  Conversely, using a negative search 
distance yields a search in the left direction up to the maximum distance set. 

Note: The placement of the null points vertically is not relevant in this example but is 
merely an appearance issue.  The horizontal position is relevant in that the 
points need to be to the left of the front of the sidewalk because we will be 
searching outwardly only as established by the Range distance. 
 

8. Save the changes to the Template Library. 

 

LESSON NAME: ASSIGNING SIDEWALK EDGES TO THE APPROPRIATE NULL POINTS. 

LESSON OBJECTIVE:  
In this lesson the student will assign the front and backs of the sidewalks to the appropriate 
Null points. 

 EXERCISE:   
This exercise will guide you through adjusting the properties of the two edges of the 
proposed sidewalk.  Note, after this exercise the sidewalk will appear as a single 
vertical line. 

1. Remaining in the same Component from the previous exercise, edit the point 
entitled SW_Front by double clicking the point. 
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2. Revise the Horizontal Constraint to now follow the Null point placed in the 

previous exercise.  The completed changes are shown below: 

 
Note: This change will modify the front edge of the sidewalk to now lineup with 
the Null point.  Make sure to set the offset value to zero. 
 
The template should now appear as follows: 
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3. Edit the point entitled SW_Back by double clicking the point. 
4. Revise the Horizontal Constraint to now follow the Null point placed in the 

previous exercise.  The completed changes are shown below: 

 
Note: This change will modify the sidewalk back edge to lineup with the Null 
point for the back of sidewalk seek.  Make sure to set the offset value to zero. 
 
The template should now appear as follows: 
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LESSON NAME: CREATING A COMPONENT DISPLAY RULE 

LESSON OBJECTIVE:  
In this lesson the student will create a component display rule and assign it to the sidewalk. 

 EXERCISE: 
In this exercise a Component Display Rule will be created comparing the horizontal 
distance between the two null points used to target the front and back of sidewalk.  
When the distance between the two points is greater than zero, the sidewalk will be 
displayed. 

1. Remaining in the same Component from the previous exercise, edit the 
sidewalk component by double clicking to bring up the properties. 

2. In the Component properties dialog select Edit to create a Display Rule. 
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3. Select Add at the bottom of the Component Display Conditional 
Expression dialog. 
 

 
 

4. Complete the Display Rule dialog as shown: 
 

 
 
Note: This will compare the horizontal distance between the two null 
points.  The null points will be targeting the front and back of sidewalk.  
When no sidewalk is found, the null points will remain at the same offset 
and thus the display rule will be false. 
 

5. Select OK to dismiss the Display Rule creation dialog. 
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6. Highlight the newly created rule and choose Selected Rule to place this 
new rule in the Conditional Expression window. 
 

 
Note: In this dialog, multiple component display rules can be combined 
for more complex design scenarios. 
 

7. Dismiss the dialog to return to the Component Properties dialog. 
8. In the Component Properties dialog select Apply to assign the 

Component Display Rule to the sidewalk. 
 

 
 
Note this will make the sidewalk “disappear” from the drawing view.  
Toggle on Display All Components at the top of the dialog to see the 
sidewalk at all times. 
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9. Right click on the null point SW_Back_Seek and move to the left and 
right.  What happens?  The back of the sidewalk should follow the 
moving null point as long as the point is to the right of the 
SW_Front_Seek point. 

10. Move the SW_Back_Seek point back to the left of the SW_Front_Seek 
point to turn off the display of the sidewalk and establish the “default” 
solution when no sidewalk styles are found. 

11. Save the changes to the template library.  The completed template 
component should appear as follows: 

 

 
 
Note: This is assuming the “Display All Components” toggle it activated. 
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LESSON NAME: COMPLETING THE TEMPLATE 

LESSON OBJECTIVE:  
In this lesson the student will complete the template adding the back of curb treatment and 
appropriate end conditions. 

 EXERCISE: 
In this exercise the newly modified component will be added to the design template.  
Additionally End Conditions will be added to complete the template’s design. 

1. Remaining in the template library from the last exercise, expand the 
Templates folder and make the template 2-Lane Urban Curb and Gutter 
Variable SW active by double clicking the template entry. 

2. In the Create Template top menu, select Tools > Options 
3. Turn on Apply Affixes 
4. In the Left Suffix enter a suffix of “ Lt” without the quotes.  Note the blank 

space before the “L”. 
5. In the Right Suffix enter a suffix of “ Rt” without the quotes.  Note the blank 

space before the “R”. 
6. Dismiss the Template Options dialog by selecting OK. 

 

 
7. Keeping the template Active, single click the Back of Curb component 

modified in the previous exercise so it shows up in the preview window in the 
lower left hand corner. 

8. Drag and drop the back of curb component to the back of the curb making 
sure that the “drag” point is coincident with the right back of curb. 
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Hint: Use the Mirror Option when dragging to place the left and right sides at the 
same time.  

 
The template should now appear as follows:  

 

 
 

9. Repeat steps 7 and 8 above this time dragging and dropping in the End 
Conditions provided. 

 
The completed template should now appear as follows: 
 

 
 

10. Save and close the Template Library  
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LESSON NAME: PROCESSING THE DESIGN 

LESSON OBJECTIVE:  
In this lesson the student learn to synchronize the template library with Roadway Designer 
and verify the variable sidewalk design. 

 EXERCISE: 
In this exercise the revised template will be updates in the Roadway Designer 
project. 

1. Access Roadway Designer and open the included Roadway Designer 
project file entitled “My Project.ird”. 

2. From the pull down menu choose CORRIDOR > TEMPLATE DROPS 
3. Select the template dropped at station 12+34 and select Synchronize with 

Library.   
 

 
 

4. Dismiss the template drop dialog by selecting Close. 
5. Navigate the cross sections paying special attention to the station range from 

station 14+00 to station 16+00. 
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Note: The sidewalk is stored as an alignment with a sidewalk style from station 
14+00 to station 15+00 on the right side and from station 15+00 to station 16+00 
on the left side.  Notice what happens at station 15+00 where the sidewalk is 
drawn on both sides of the roadway which is correct. 

 

 
Sta. 15+00 
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