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 This advanced-level class introduces civil engineering designers to using Bentley PowerCivil for North 

America software for advanced grading projects. This hands-on training walks you through several techniques 

including how to model/design site features, including buildings, roadways and ponds.  The following list details the 

content of each lab. 

 Create a coordinate geometry Chain and Profile 

 Create a Site Modeler Project 

 Create and modify a Roadway  

 Create a Building  

 Create a Parking Lot 

 Create a Pond 
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Lesson Name: Create a Site Modeler Project 

LESSON OBJECTIVE: 

The Modeler enables fast, dynamic development of site models and easy management of the 

many changes that occur on site projects.  It captures design intent as users work and provides 

immediate visual feedback.  The software allows users to perform engineering modeling within a Digital 

Terrain Model (DTM)—without merging or extracting graphics into the DTM.  Many traditionally 

cumbersome processes are reduced to one step: for example, you can dynamically move a building pad 

in a single drag and drop step—without measurement, clipping, merging, and placement steps. 

The Site Modeler offers unprecedented flexibility in interactively working with site designs 

without the limitations of traditional iterative steps.  No cumbersome triangle or point editing is 

necessary.  The software maintains existing ground and provides full control over defining elevations 

and side slopes and balancing cut-and-fill.  Analytical tools are included to afford powerful evaluation of 

site designs. 
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Modeler integrates digital terrain modeling with interactive 3D site design.  The software allows 

you to incorporate design features in the model while maintaining existing ground.  Move building pads. 

Change pond elevations.  Extend retaining walls.  Trim curbs.  Resize berms.  The Site Modeler 

automatically regenerates the DTM, yet retains full integrity of the models and the original DTM.  There 

is no need for merging or extracting graphics into the terrain model. Easy, on-the-fly functions let you 

change elevations and side slopes and balance cut-and-fill. You can add features such as contours to the 

model as needed to define your design.  Tools are supported for evaluating the site design and 

producing drawings and site models. 
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EXERCISE: CREATING A SITE MODELER PROJECT 

This exercise will guide you through the steps to get started 

1. Double-click the PowerCivil for North America V8i icon 

The MicroStation Manager appears 

If there is no icon, then an alternate path for launching InRoads is 

Start > Programs > Bentley > PowerCivil V8i > PowerCivil for North America V8i(SELECTseries 

1) 

2. The instructor will provide the appropriate path location for this project. Open the CAD file 

Siteplan3D.dgn located in the training folder for this workshop 

3. Once PowerCivil has started, open the file Project.rwk located in the same folder as the design 

file. 

4. In the Workspace Bar located, tab over to Site Modeler. 
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5. Right Click on Site Modeler Project and hit New. 

6. For Type: select Site Project and for Name: input Grading. 

 

EXERCISE: CREATING A SITE 

1. Right Click on the Site Project called Grading and hit New. 

2. For Type: select Site and for Name: input Commercial. 
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Lesson Name: Project Preferences 

LESSON OBJECTIVE: 

Modeler supports a wide array of user defined preferences which enables the designer to set project 

specific options, or a larger organization to set parameters to maintain standards.  Each Modeler project contains a 

set of Preferences and they remain with the project.   

Hint Hint:  For efficient workflow, you can set the Preferences for a project, client, or your 
organization, then save them using the File > Save option.  The default file extension is *.spf.  
The file can be opened in subsequent projects (File > Load), saving the time of redundant 
entry.  The files can be placed on a server for multiple users. 

The options are displayed in a list box in the left side of the dialog, while the right side displays parameters for the 

highlighted option.  As different options are highlighted, the right side changes dynamically to reflect the selection.  

OK and Cancel close the dialog and storing the preferences, if required.  Preferences can be  

 

PREFERENCE OPTION DESCRIPTION 

Tolerances Tolerance and stroking options used in the creation of Site Elements. 

Visualization Variety of element symbology and display options. 

Surfaces  Standard List of Surface Types and default values for Surface parameters.  The 

information includes the Surface Type and Naming Prefix, visualization settings 

and default side slopes for that Surface type. 

Update Toggle for automatic updating and setting a Working Boundary 

 



© 2009 Bentley Systems, Incorporated    9 

EXERCISE: DEFINING THE PROJECT PREFERENCES 

1. Select Site Modeler > Tools > Options then Select File > Open > Site Options.spf 

2. Select Surfaces > Existing Ground. 

In the Surface Details, note the Visualization is toggled on, so the surface will be drawn.  

Triangles are turned off; however, Major and Minor Contours are turned on.  No labels are 

placed, as their toggles are off. 

                              

3. Click OK and close dialog. 

 

  



© 2009 Bentley Systems, Incorporated    10 

 

 

EXERCISE: IMPORTING THE EXISTING DTM INTO THE PROJECT 

While existing ground can be imported into a project at any time, it is best to do this first. 

1. Select File > New > Site Modeler.  

Hint:  An alternate way to create a new surface is by Right Clicking on the Site Modeler Project and 
Selecting New as previously done in the exercise.  

2. For Type: select Surface, for Surface Type: select Existing Ground, and for Name: input 
Existing Ground. Toggle from Surface: Existing_Ground, toggle Off Add to Active Site, Toggle On Use 
Base Surface for Active Site. 

 

3. Save the site project. File > Save > Site Modeler Project. 

Note When working on a project, frequent use of the File > Save pull down is important.  Any changes 
made in the project are not recorded in the Modeler File (GSF) file unless a File > Save or File > 
Save As operation is executed.  Hence, any power interruption or other malfunction will result in 
loss of data that can be avoided through the judicious use of the File > Save tool. 
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Lesson Name: Creating a Building Surface with Pad Design 

LESSON OBJECTIVE:  

This exercise will teach the student how to create a simple building pad and gentle sloping grassy area 

around the building pad. 

The conventional design process may typically start by creating the various access roads first.  However, for 

the purpose of this training session, we will start by creating a building.   

We are now going to create a building pad and add the building pad to our Model.  We have a previously 

placed graphic shape that represents the footprint of our building.  We will assign an elevation to this element based 

on the current existing ground conditions; place the element in a building surface that, in turn, will be placed into 

our Site.   

EXERCISE: CREATE BLDG1 

1. Select Site Modeler > Surface > Pad Design 

2. Review steps in Overview, Select Next. 
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3. Select Multiple Pads per New Surface, Surface Type: Building. Toggle On Add to Active Site. 

4. Pad Style: Select P_Site_BuildingPad. Quantity Depth 9.0.  

                            

5. Select Next. 

6. Select Drape on Site/Surface, Toggle Offset On input 2.0. 

7. For Drape Option: Select Maximum Elevation, Toggle Site: Commercial. 

8. For ID: Use Pick Box and Select building graphic  (Element id #1223) . 

 

9. Click Next. 

10. Select Simple Slope, input 1:3 or 33.00% for Cut and Fill Slope. 
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11. Click Apply. 

Building Pad is successfully added to Site called Commercial and contours are drawn. 

 



© 2009 Bentley Systems, Incorporated    14 

EXERCISE: ASSOCIATING A PLANTING AREA AROUND THE BUILDING 

We will now add a grassy area around the building pad element.  This grass area will have a -2% 

slope away from the building to ensure proper drainage.  It should be noted that an elements 

representing the outer boundary of this grassy area has been drawn into the file. 

1. Select the 4 elements that comprise the outline of the grass area. 

Hint The elements are the 4 solid green lines around the building outline.   If you are having trouble 
identifying them, turn off the Display View by Right Clicking on Grading > Display Off.  

2. Select Site Modeler > Element > New/Edit 

 

3. Add to Surface Bldg 1, Name: Bldg, Style: P_Topo_Breakline, Feature Type: Boundary, 

Method: Slope/Offset From Element, Drape Option: Entire Element, Slope: -2.0% and 

Toggle On Redefine Element and Use Reference Association.  
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4. Do Not Select any items with the Element ID Pick Box, those items were already selected 

before we ran the command. 

5. Select the Reference Pick Box and Select the Building graphic from the previous step. 

6. Click Apply. 

 

7. Click OK on Selection Set Dialog Alert. 

The grass area elements are added to the BLDG 1 Surface.  If you turned off the Display View in 

an earlier step, turn it back on now to see the element and associated contours. 

 

This completes our Bldg 1 Surface for now.  We may come back later and change it in some way, 

possibly raising or lowering it. 
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Lesson Name: Creating a Parking Lot 

LESSON OBJECTIVE: 

In this section, we will design and grade the parking lot.  The desired slope across the parking lot is 2%.  The 

parking lot will slope away from the building and entrance road.  In order to create this design, we will create a 

temporary surface.   

This surface is based off of the building elevation, and slope at 2% away from the building.  This temporary 

surface will encompass the total area of the parking lot layout.  Once this temp surface is created we will proceed to 

drape all the elements representing the various Parking Lot edges of pavement onto the temp surface.  This will 

create a nice, simple 2% grade across the parking area.   

We can then proceed to place curb and gutter where appropriate. 

EXERCISE: CREATING TEMPORARY SURFACE 

1. Select File > New > Site Modeler.  

Hint An alternate way to create a new surface is by Right Clicking on the Site Modeler Project and 
Selecting New as previously done in the exercise.  

2. For Type: select Surface, for Surface Type: select Temporary Grading Surface, and for Name: 
input Temp Grading 1. Toggle Off from Surface, Add to Active Site, Use Base Surface for Active 
Site. 

3. Select Site Modeler > Element > New/Edit 

4. Add to Surface Temp Grading 1, Name: Temp Grading, Style: P_Topo_Breakline, Feature Type: 

Boundary, Method: Drape, Drape Option: Centroid, Toggle On Redefine Element and Use 

Reference Association.  

5. Drape on Surface Bldg 1. 

6. Using Element ID Pick Box, Select dashed green line next to Bldg 1. 
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7. Click Apply. 

8. Select Site Modeler > Element > New/Edit 

9. Add to Surface Temp Grading 1, Name: Temp Grading, Style: P_Topo_Breakline, Feature Type: 

Boundary, Method: Slope/Offset From Element, Drape Option: Entire Element, Toggle On Slope: -

2.0%, Toggle On Redefine Element and Use Reference Association.  

10. Using Element ID Pick Box, Select dashed green line at opposite end of parking lot. 

11. Using Reference Pick Box, Select dashed green line near building. 

12. Click Apply. 
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EXERCISE: CREATING THE PARKING LOT 

We now have a 2% sloped area (Surface - Temp 1) which encompasses the entire area of the proposed 

parking lot.  At this point, we can simply select all the parking lot edges of pavement and drape them down onto this 

temporary surface.  Thereby effectively and efficiently creating a nice 2%slope from element to element throughout 

the entire parking lot. 

1. Select the graphical elements defining the parking lot, do not select the returns tying it to the 

entrance road. 

 

2. Select File > New > Site Modeler.  

3. For Type: select Surface, for Surface Type: select Parking, and for Name: input PL 1. Toggle Off 
from Surface, Toggle On Add to Active Site, Toggle Off Use Base Surface for Active Site. Click 
Apply and Close. 

4. Select Site Modeler > Element > New/Edit 

5. Add to Surface PL 1, Name: PL, Style: P_Road_EdgeofPavement, Feature Type: Breakline, 

Method: Drape, Drape Option: Entire Element, Toggle On Redefine Element and Use Reference 

Association.  

6. Drape on Surface Temp Grading 1. 

7. Do Not Select any items with the Element ID Pick Box, those items were already selected before 

we ran the command. 

8. Click Apply.  
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9. Click OK on Selection Set Dialog Alert. 

10. Your Results should be similar to below. 
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 EXERCISE: CREATING THE PARKING LOT ELEMENTS – ADDING CURB AND GUTTER 

We will now add the appropriate curb & gutter at the edges of pavement throughout the parking lot.  

Around the exterior of the lot we will place the same 6” curb & gutter we will be using on the entrance road.  In the 

interior islands we will place a simple 6” curb with no gutter. 

1. Select the 3 outer graphical elements defining the parking lot, do not select the internal islands. 

2. Select Site Modeler > Element > Define Section. 

3. Name: PL, Feature Type: Boundary. 

4. Offset Distance: 1.0, Offset Elevation: -.06, Style: P_ROAD_GutterFlowline. 

5.  Click Add, adds data to Section Table above. 

6. Repeat steps to match Dialog below. 

 

7. Select SaveAs… name curb.txt 

8. Select Direction Button, move cursor so Direction of Section is facing outside of the parking lot. 

9. Repeat the same steps for the internal islands using the settings below. For closed shapes, you 

will need to select each shape one at a time and set direction internal to the island. 

Hint For closed shapes, you will need to select each shape one at a time and set direction internal 
to the island. If you use several different types of sections, you can import a saved version. 
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10. Review your design, should be similar as shown below. 

 

EXERCISE: CREATING THE PARKING LOT ELEMENTS – SHARING BUILDING ELEMENTS 

Several building elements that are adjacent to the parking lot object need to be shared with the parking lot 

to ensure a direct transition between the two objects.   

 

1. Select Site Modeler > Surface > Edit > Elements. 

2. Name: PL 1 

3. Using Selection Pick Box, Select each graphic one at a time, then Add them to Member Elements 

dialog. 
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4. Click Apply > Close. 

5. We have successfully tied the parking lot and building together. Let’s raise and lower the 

elevations and test the connectivity. 

6. Select Site Modeler > Surface > Raise/Lower… 

7. Using the Pick Box, Select the Building graphic. Raise it 5 feet, what happens? Lower it 5 feet. 
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Lesson Name: Creating the Mainline Roadway using Templates 

LESSON OBJECTIVE: 

Now we will design the mainline road.  The layout of the horizontal and vertical alignment is complete.  We 

will look at the Express Modeler that will aid us in creating all the roadway elements in one step.  

EXERCISE: REVIEWING THE TEMPLATE 

1. Select Modeler > Create Template.  

2. Double click in Urban 4 Lane. 

3. Click on Test and place P_ROAD_LaneLine-Style as a target to the left, then right. 

4. Review what is happening. Place Active Surface target and test End Conditions available within 

Templates. 

Hint By using Parent/Child relationships and targeting styles increases the flexibility of Express 
Modeler. Notice the End Condition set to “Not Construct” targeting a style.  
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EXERCISE: RUNNING EXPRESS MODELER 

1. Select Modeler > Express Modeler.  

2. Select Horizontal Alignment: MAINRD, Vertical Alignment: MAINDES, Interval: 5.0. 

3. Select Templates > Urban 4 Lane 

4. Active Surface: Existing_Ground, Design Surface Name: Mainline, Default Preference: Proposed 

5. Toggle On Add Exterior Boundary, Style: P_TOPO_Exterior, Toggle On Triangulate Surface. 

6. Hit Apply. Review Surface in Workspace Bar. 

7. Select File > New > Site Modeler.  

8. For Type: select Surface, for Surface Type: select Roadway, and for Name: input Mainline. 
Toggle from Surface: Mainline, toggle On Add to Active Site, Toggle Off Use Base Surface for 
Active Site. 

 

9. Review Site Project. Save Site Modeler Project. 
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Lesson Name: Creating the Entrance Roadways 

LESSON OBJECTIVE: 

Now we will design the entrance roads.  The layout of the horizontal alignment is complete, but we need to 

create the profile to connect to our designed elevations.  Using the Evaluation Tools we will create a proposed 

profile and run the Express Modeler along our designed profile.  

EXERCISE: EVALUATING THE PROFILE ALONG THE ALIGNMENT 

1. Select File > New > Geometry > Vertical Alignment.  

2. Name: Entrance, Description: Proposed Vertical. 

3. Style: P_Cogo_Vertical, Curve Definition: Parabolic 

4. Click Apply the Close.  

5. Pan design graphics off the screen to place profile. 

6. Select Evaluation > Profile > Create Profile  

 

7. Select General, Toggle On the following Surfaces: Existing_Ground, Mainline, PL 1. 

8. Select Source, Toggle Alignment: Entry. 

9. Click Apply and Accept DP on screen. Click Close on Create Profile Dialog.  

Hint Follow prompts in the lower left portion of the MicroStation window if unsure what to do next. 
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EXERCISE: CREATING THE PROFILE 

1. Select Geometry > Vertical Curve Set > Add PI...  

2. Name: Entrance, Description: Proposed Vertical. 

Hint Follow prompts in the lower left portion of the MicroStation window. 

3. Start Profile on the left, target the edge of the Mainline surface showing in profile. 

4. Open Key-In window from MicroStation. Key-in se=425.00,5257.25 for second point. 

5. Dynamic snap to PL 1 surface at approximate station value 7+65. 

6. Snap across the PL 1 surface again at approximate station value 10+59. 

7. Key-in se=1435.00,5251.90 

8. Dynamic snap to edge of Mainline surface. 

9. Select Geometry > Vertical Curve Set > Define Curve... 

10. Set 2 Vertical Curves with length for 250 feet to achieve a profile similar to below. 

 

Hint Notice the Automatic Annotation! 

11. Save Geometry Project. 
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EXERCISE: RUNNING EXPRESS MODELER ALONG NORTH AND SOUTH ENTRANCE 

1. Select Modeler > Express Modeler.  

2. Select Horizontal Alignment: ENTRY, Vertical Alignment: Entrance, Interval: 5.0. 

3. Select Templates > Entrance 

4. Active Surface: Existing_Ground, Design Surface Name: South, Default Preference: Proposed 

5. Toggle On Add Exterior Boundary, Style: P_TOPO_Exterior, Toggle On Triangulate Surface. 

6. Toggle On Station under Limits, Start: 0+50.56, Stop: 6+88.23 

7. Hit Apply. Review Surface in Workspace Bar. 

8. Repeat steps 2 through 7 for North End. Design surface Name: North, Start:11+60.13, 

Stop:16+21.82 

9. Select File > New > Site Modeler.  

10. For Type: select Surface, for Surface Type: select Roadway, and for Name: input South. Toggle 
from Surface: South, toggle On Add to Active Site, Toggle Off Use Base Surface for Active Site. 

11. For Type: select Surface, for Surface Type: select Roadway, and for Name: input North. Toggle 
from Surface: North, toggle On Add to Active Site, Toggle Off Use Base Surface for Active Site. 

 

EXERCISE: TYING ENTRANCE ROADS TO PARKING LOT 

1. In the Workspace Bar, Navigate to PL 1 and right click to make Active.  

2. Select Site Modeler > Element > New/Edit 

3. Add to Surface PL 1, Name: PL, Style: P_Road_EdgeofPavement, Feature Type: Breakline, 

Method: Drape, Drape Option: End Points, Site: Commercial, Toggle On Redefine Element and 

Use Reference Association.  

4. Select the Following graphics. 

        

 

5. Repeat the steps for the other side of the Parking Lot as shown above. 

6. Now Apply the Section we saved earlier as a Boundary to point the direction to the outside. 
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Lesson Name: Creating a Detention Pond 

LESSON OBJECTIVE: 

In this section we will create a pond object between the roadway and the parking lot.  The MicroStation 

element that represents the pond shape has already been created and we will assign the desired elevation.  There 

are many different ways to create the pond surface, we are going to focus on using the Pond Design tool for this 

workshop. After the pond is created we will use a few analysis tools to analyze pond volume.  

EXERCISE: CREATING A POND WITH THE POND DESIGN TOOL. 

1. Select Site Modeler > Surface > Pond Design.  

2. Review the Steps Outlines in the Overview. Click Next. 

3. Click New at the bottom of the dialog to create a new surface. Match dialog settings below. 
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4. Style: P_SITE_RetentionPond, Toggle On Top-Down Design, To Volume: 160,000. 

5. Click Next. 

6. Toggle Drape on Site/Surface, Drape Option: Minimum Elevation, Site: Commercial. 

7. Using the ID Pick Box, select the blue pond graphic. Click Next. 

8. Interior Side Slope: 1:4 or 25%, Exterior Cut and Fill Slopes: 1:3 or 33.33%. 

9. Toggle On Create Berm Relative To:, Site: Commercial, Width: 10.0, Slope: 2.0%, Feature Type: 
Boundary, Berm Style: P_Site_DesignSurface, Crown Style: P_Site_DitchTop. Do Not Toggle Fill 
Only. 

 
10. Click Apply. 

 
11. Click OK on the verification box. 

12. Using the Surface Move Tool, grab the Pond and move around. 
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Lesson Name: Creating a Simple, Dynamic Retaining Wall 

LESSON OBJECTIVE: 

In this section we will create a simple retaining wall to limit the grading around the building.  There are many 

different ways to create a retaining wall, we are going to focus on using simple graphics for this workshop.  

EXERCISE: CREATING A RETAINING WALL GRADING SURFACE. 

1. Around the north edge of the building, using the Place SmartLine command, create a retaining 

wall location several feet away from the building and planting area, place a 25’ radius at the 

corner. 

 

2. Now offset that line 1’ to the North. 

3. Create a New Surface using Retaining Wall Type called Wall 1 and Add to Active Site. 

4. Drape first element on Site: Commercial using entire element drape as a boundary. 

5. Drape second element on Surface: Existing Ground using entire element as a boundary. 
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Lesson Name: Site Modeler Tools 

LESSON OBJECTIVE: 

In this section we will explore the features located under the Tools Pulldown.  Create Surface will take our 

dynamic design surface and create a DTM for use in creating machine control surfaces and combining with Roadway 

Corridors. Export Visualization will export our dynamic visualization for use in plans production. Site Volume will give 

you interactive volumes within Site Modeler. Site Tracking will allow you to check elevations and slopes anywhere 

on you Site or Surfaces you created on the fly.  Synchronize with Graphics will reapply the proper Site Modeler 

associations to CAD graphics if a graphic is modified outside of Site Modeler. Options controls the preferences for 

our surfaces, we covered in the first lesson.  

EXERCISE: CREATE SURFACE. 

1. Select Site Modeler > Tools > Create Surface.  

2. Select Site: Commercial, under Surface for Name: Proposed, Description: Commercial Site. 

3. Click Apply then Close. 
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Hint This creates a Proposed.DTM for use in plans production and for use in the remainder 
PowerCivil for North America program. 

 

EXERCISE: EXPORT VISUALIZATION. 

1. Save your current Site Modeler Project. Within MicroStation, create a new 3D Model called 

Visualization. 

 

2. Select Site Modeler > Tools > Export Visualization.  

3. Select Site: Commercial, Toggle On Elements, Surface Slopes, Set Graphic Group. For Symbology: 
P_TOPO_Contour. 

4. Click Apply then Close. 

 

Hint This will create a 3D/2D presentation of the surface and elements that created the surface 
based on the Preferences .SPF file.  Alternatively, you can display the information from the 
DTM surface we created previously. 



© 2009 Bentley Systems, Incorporated    33 

 

EXERCISE: SITE VOLUME. 

4. Select Site Modeler > Tools > Site Volume.  

5. Select General.Toggle On Prismoidal, Use Cut Factors, Cut:1.0, Fill:1.3 

6. Select Calculation Options. Select Surface to Site, From:Existing Ground, To:Commercial. Toggle 
Off Use Quantity Depth, By FIFO, and Use Range. 

7. Click Apply, then Reselect General tab to see results. 

 

Hint This will compare our Existing Ground surface to our completed Site called Commercial. 
Review your results. 

 

5. Reselect Calculation Options, Toggle On Use Quantity Depth.  

6. Click Apply, then Reselect General tab to compare results. 

Hint Why did the results change? Remember we applied 9.0 foot Quantity Depth on our Bldg 1. 

 

EXERCISE: SITE TRACKING. 

1. Select Site Modeler > Tools > Site Tracking.  

2. Select Site: Commercial, Toggle On Elevation. 

3. Click Activation and move cursor around on your screen. 

4. Toggle On Slope, Slope Between Points. Click Activate. Select 2 points on the Site. 

5. To Adjust the Visualization of the Arrow, Contour and Elevation Text, Click Settings. 

 

Hint This can be used at any stage of the design process. It is a very powerful tool to evaluate your 
design as you create it. 

 


