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Advanced Modeler 

This workshop introduces experienced GEOPAK Site designers to more advanced Modeler tools, 
procedures and concepts than are presented in the beginner level courses.   

The lessons contained herein cover a variety of situations that demonstrate use of Modeler tools in 
more complex design or in ways that are perhaps not readily anticipated by the average user.  The 
dataset used is a typical site design project but the tools and methods employed are applicable to a 
wide range of site design, subdivision and land development projects. 

This workshop is an advanced course and assumes the student is already intimately familiar with the 
site modeler and its various tools. 

� User should have an intimate knowledge of the Site Modeler found in Bentley GEOPAK Site. 

� User should be fluent in terminology used in Bentley GEOPAK Site. 

� User should be a fluent and proficient user of Bentley MicroStation or Bentley PowerDraft 

� User should have a strong knowledge of the engineering principles used on a site design project. 

After completing this course, you will be able to: 

� Build and apply an advanced Composite Section to co‐ordinate geometry alignment elements. 

� Add a raised median to a roadway which was previously designed using the Composite Section 
tool. 

� Edit a road’s composite section to add information to the template. 

� Determine an appropriate design scenario for an interesting parking lot layout. 

� Grasp the concepts, advantages and application scenarios of a “construction” surface 

� Create a pond using the pond wizard. 

� Add a retaining wall between two objects. 

� Create a channel using the channel wizard. 

� Edit the profile of the channel. 

The user is encouraged to save the site project regularly and often for the duration of this workshop.  This is 
simply good practice for everyday use.  This manual will not instruct you to save since the target 
audience is of an advanced nature.    
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This workshop will cover a wide range of tools and methods for dealing with more advanced aspects 
of site design.    The lessons contained herein are applied to specific examples on a Site Design 
dataset but are applicable in a general sense to a wide array of situations. 

THE TOOLS WE WILL USE ARE: 

• Superelevation Shape Manager Tools (Applications>GEOPAK>Road>Cross Sections> 
Superelevation Shape Manager Tools) (shown below)) 

 
• Composite Section (Modeler>Tools > Roadway Tool > Create/Edit) 

• New Site element tool (Modeler>Element > New/Edit) 

• Edit site profiles tools (Modeler>Element > Edit Profile) 

• Analysis tools (Modeler>Analysis)  

• Pond Wizard (Modeler>Tools > Pond Design (shown above)) 
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Exercise: Open an existing site project 

 

1. Open the MicroStation file: …Commercial1.dgn. 

  
2. Select the Site Modeling tool (Applications > GEOPAK Site > Site Modeler > Site Modeling)  

  
3. Enable Open Existing Project. 

4. Click Browse and select: …Commercial1.gsf. 

5. Click OK. 

The Design and Computation manager has been set by the Modeler preferences. Let’s ensure that is the file 
currently in use.   

6. Open Design and Computations Manager (Applications > GEOPAK Site >Design & Computations 
Manager). 
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7. The current file should be site.ddb.  

If the current file is not site.ddb; Click File>Open, navigate to this file location and select the file. 

8. Close the Design and Computation Manager tool. 
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Review the project 

In the MicroStation file you will find a major urban roadway and a Site Development access road.  
The building graphic has been drawn as well as two (2) interesting shaped parking lots and three (3) 
ponds – one (1) detention pond and two (2) landscape ponds.  The graphics were created ahead of 
time using standard MicroStation drawings tools and represent the minimum geometric definitions 
that we need to perform the exercises.  The graphics shown represent the following: 

Building Pad outline – shows the intricate outer edge of the proposed building platform. This is 
drawn in the DGN using D&C feature “DesBuildPad” 

Centerlines – These would typically (though not necessarily) be complex elements (complex chains or 
line strings) as opposed to individual lines and curves.  They are drawn in the DGN using D&C feature 
“DesChains” 

Proposed Edges of Pavement – including the curb returns at intersections.  They are drawn in the 
DGN using D&C feature “DesEofP” 

Join Lines in the intersections – these are the dashed lines drawn across the intersections which 
represent the edge of the through pavement between two intersecting roads.  These element will be 
included in both roadways to ensure a smooth transition between Objects.  They are drawn in the 
DGN using D&C feature “DesJoinLine” 

Pond base – this represents the floor of the ponds.  It is drawn with D&C feature “DesPondBase” 

Traffic islands/medians – the major roadway, the minor access roadway and the larger of the parking 
lots all contain medians/traffic islands of complex geometric shape. These elements are drawn with 
D&C feature “DesMedianFace” 

A careful review of the site topology will reveal that two (2) of the ponds are poorly located when drainage paths 
and detention are considered. These ponds are included in the site development for purely ornamental 
reasons. 
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Lesson Name: Create Build Pad 

LESSON OBJECTIVE: CREATE BUILDING PAD AND SET ELEVATION 

We shall create the Building pad Object and set its elevation based on a value supplied by the Architect – 
Elev. 408.25. 

EXERCISE: CREATING A BUILDING OBJECT 

We are now going to create a building pad and add the building pad to our Site Model.  We have a 
previously placed MicroStation shape that represents the footprint of our building.  We will assign an 
elevation to this element based on the current existing ground conditions; place the element in a 
building object that, in turn, will be placed into our model.   

1. Select the Create New Object tool (Modeler> Object > New).   

 
2. Enter the New Object information. 

Object Type:  Building 

Add to Active Model:  Enable 

3. This creates an Object Name of Bldg 1 based on the naming prefix assigned to this Object type. 
We shall use the default Object Name. 

4. Click OK. 

5. Select the New / Edit Element tool (MS Menu: Modeler> Elements > New/ Edit).   
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6. Click Constant Elevation on the Elements tab. 

7. Enter the Element information. 

Add to Active Object  Enable 

Feature Type  Break Line 

Elevation  408.25 

Redefine Site Element  Enable 

8. Click Select Elements in the Define Elements group box. 

9. Select the building footprint in MicroStation.   

The element highlights when selected.  Ensure it is the same color as your highlight color. 

10. Click Apply 
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Lesson Name: Create Urban Roadway 

LESSON OBJECTIVE: STEP THROUGH THE PROCESS TO CREATE A COMPLEX URBAN ROADWAY 

The major road to this Site Development project is 4 lanes with medians and turning lanes. Due to the tight 
horizontal geometry and a 35MPH speed environment, the roadway will have super elevation calculated and 
applied.  

EXERCISE: CALCULATE AND CREATE SUPERELEVATION SHAPES 

GEOPAK provides tools for calculation of super elevation for highways. Typically, super elevation is 
not applied to an urban roadway but, on occasions, it is. 

For this exercise, we will assume that super elevation is required and include this as part of our 
exercise.   

1. Superelevation Shape Manager Tools (Applications>GEOPAK>Road>Cross Sections> 
Superelevation Shape Manager Tools) (shown below)) 

 
2. Select the Automated Superelevation tool. 



   

© 2009 Bentley Systems, Incorporated    10 

 
The horizontal and vertical alignment data has been previously created for this roadway.  

3. Populate the details within the dialog as shown above. 

4. Select Quick Entry. 

 
5. Populate the dialog as shown and select OK. 
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The Quick Entry tool will populate both the left and right tabs. These tabs correspond to the lane widths for the left 

and right sides of the road. As both sides are the same, the Quick Entry tool is very useful.  

6. Select the Right tab and set the profile to Roadway1. 

7. Enter the Create Input File name as: MainRdSuper 

8. Select Generate Superelevation Transitions. 

The calculation for the superelevation will be calculated and a shape input file will be written. This shape input file 
is an ASCII file that we will now inspect via the Text Editor that popped up at the end of the process 

9. Close the Text Editor. 

10. Close the Automated Superelevation tool. 
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11. Select Autoshape Builder. 

 
12. Select the Autoshape Input File ShapesRoad1.inp and click Draw Superelevation Shapes. 

This ShapesRoad1.inp input file is different from the file we created as a group. This is to ensure that all students 
have the same data for the following steps. 
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EXERCISE: CREATE AND APPLY A COMPOSITE SECTION FOR ROADWAY 1 

1. Disable the level display for the level Super Shapes. 

2. Create a new Roadway Object: Name = Roadway 1 

3. Select the Composite Section tool (Modeler > Tools > Composite Section). 

 
4. Focus on the Primary Element Definition group box. 

5. Set Primary Element Definition to By Chain‐Profile. 
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6. Select Alignment Definition. 

 
7. Populate the dialog as shown. 

8. Close Alignment Definition dialog. 

9. Enable Superelevation By. 

10. Set Superelevation By option to Shapes. 

11. Set the Tie = 10.000 
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12. Select the Left Side Details. 

CREATE THE INTERSECTION “JOIN LINE” ELEMENT ON THE LEFT SIDE 

We will focus our attention on the Define, Method, and Search Extent group boxes at the bottom of 
the dialog.  We will set these to find and create the edges of pavement. 

 
13. Complete the Define group box. 

Element Type:  Feature 

Feature Type:  Boundary 
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14. Complete the Method group box. 

Superelevation %:   

Vertical Offset:  0.00 

Radial To:  Primary 

Projection Option:  Entire Element 

15. Complete the Search Extent group box. 

PayItem:  DesJoinLine 

Maximum Distance:  47 

16. Click Add List Item (right side of list box). 

 

CREATE THE EDGE OF PAVEMENT ELEMENT ON THE LEFT SIDE 

17. Focus on the Define, Method, and Search Extent group boxes 

 
18. Complete the Define group box. 

Element Type:  Feature 

Feature Type:  Breakline 

19. Complete the Method group box. 

Superelevation %:   

Vertical Offset:  0.00 

Radial To:  Primary 

Projection Option:  Entire Element 
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20. Complete the Search Extent group box. 

PayItem:  DesEofP 

Maximum Distance:  47 

21. Click Add List Item  (right side of list box). 

 

CREATE THE CURB AND GUTTER ELEMENTS ON THE LEFT SIDE 

22. Now we will create the 6” Curb and Gutter section that will run along the edges of pavement. 

23. Complete the Define group box. 

Element Type:  Section 

Feature Type:  Boundary 

24. Complete the Method group box. 

Section By  Table 

Side  Left 

This will allow us to create a table of offset distances and elevations to define the curb section that will run along 
the edge of pavement.  Keep in mind that the section we create starts at the edge of pavement so all 
offset values start from that edge and not the centerline of the roadway. 

25. Enter the information in the edit boxes along the bottom. 

 
 

Offset Distance  1.5 

Offset Elevation  ‐0.2 

26. Remember that the distances assume that the edge of pavement element is the origin (0,0). 
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27. Click Pay Item and navigate to PayItem > Plan > Roadway > DesGutter. 

 
28. Select the item and click OK. 

29. Click Add List Item (right of the table). 

30. Add two more entries to the table using the same procedure. 

OFFSET DISTANCE  OFFSET ELEVATION  PAY ITEM 

1.7  0.49  DesCTF 

2  0.5  DesCTB  

31. Click the Add List Item (next to the Left Side list box) to add the section definition to the Left Side 
List. 

The left side list is now complete.  
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EXERCISE: CREATE THE COMPOSITE SECTION FOR THE RIGHT SIDE 

The right side of the roadway is almost the same as the left so we can copy the left side list items to 
the right side.  Then we can make the appropriate adjustments to satisfy the slightly different right 
side conditions. 

1. Select all the items in the Left Side Details list. 

2. Click Copy List Item. (Bottom Left Icon on Composite Section Dialog) 

3. Select the Right Side Details Tab. 

4. Click Paste List Item. 

The Right Side list is now populated and we can make the necessary changes.  For example, on the right side of 
the roadway, the curb and gutter is on the right side of the edge of pavement.  Additionally, on the right 
side of the roadway, the pavement edge is not as wide. We should modify the Search Extent values for 
the edge of pavement and join line list items. 

  
5. Select the first list item. This item represents the intersection Join Line. 

6. Change the Search Extent>Max. Distance to 35. 

7. Click Modify List Item. (First Column, Second Icon) 

8. Select the second list item. This item represents the edge of pavement. 

9. Change the Search Extent>Max. Distance to 35. 

10. Click Modify List Item. (First Column, Second Icon) 

11. Select the third list item. This item represents the curb and gutter section. 

12. In the Method group box, change Side to Right. 

13. Click Modify List Item. (First Column, Second Icon). 
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EXERCISE: APPLYING COMPLETED COMPOSITION SECTION 

Our Composite Section is now complete and ready to apply. 

  
14. Select File>Save As. 

15. Save the Composite Section file as Main Rd 

16. Click Apply. 

 

The Roadway 1 is now complete.  

Use the Analysis tools to evaluate this design. Discuss options and types of analysis with your Instructor! 
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Lesson Name: Add Entrance Road to Model 

LESSON OBJECTIVE: 

Add the Entrance Road to the Model.  

 

EXERCISE: ADD ENTRANCE RD TO MODEL. 

The Entrance Rd Object has been previously constructed in an attempt to complete this class in the 
time allocated. The steps taken to construct the Entrance Rd are similar to those used for Roadway 1 
(except easier).   

Any questions regarding the construction of this Object will be discussed in the workshop. 

The curb returns proved to be a little more difficult than expected – those should be examined during 
the class. 

1. Model>Edit. 

 
2. Click Add Object to List by Name. 

3. Select Entrance Rd. 

4. Click OK. 

5. Click Process. 
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Lesson Name: Design Large Parking Lot 

LESSON OBJECTIVE: 

The larger of the two (2) Parking Lots is an interesting arrangement. Added to this, there is a significant 
terrain constraint. We shall evaluate what design methodology to use and then pursue this methodology 
while keeping a constant check on earthwork issues and usability issues. 

 

EXERCISE: EVALUATE DESIGN OPTIONS. 

This exercise will guide you through the steps evaluate the design constraints the Parking Lot 
presents and determine how to proceed with the grading design with Site Modeler. 

Step one in any design evaluation should be to be fully conversant with the existing terrain in the 
region of your design. GEOPAK provides a number of Analysis tools that provide the Designer with 
valuable feedback about what conditions and constraints are faced due to the existing terrain.  

1. Analysis>Height/Slope. 

Use the Height/Slope tool to review both the contours and slope directions (in Height mode) and the actual “point 
to point” slopes (in Slope mode) that the terrain presents relative to the layout of the Parking Lot. 

2. Analysis>Profile. 

Use the Profile tool to provide additional insight into the constraints imposed by the existing terrain relative to the 
layout of the Parking Lot. 

3. Analysis>Drainage Tools. 

Use the applicable Drainage Tools to provide additional insight into the constraints imposed by the existing terrain 
relative to the layout of the Parking Lot. The downstream trace would be useful. 
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EXERCISE: CONSTRUCTION OBJECTS. 

Site Modeler provides the designer with powerful design methodologies when dealing with intricate 
geometric design situations. The Parking Lot layout is difficult to design by traditional methods of 
alignment and template OR time consuming if a “point based” design was undertaken. By using the 
“Construction Object” (or Orphan Object) concept, design alternatives can be quickly constructed, 
evaluated, modified and re‐evaluated to significantly reduce overall design and “re‐design” time. 

 

We shall begin evaluating design options though implementation of the “Construction Object” Site 
Modeling technique. 

1. Enable the display for the levels Culdesac Marker and TempCL 

Discuss these graphical “control line” options with your instructor. 

2. Disable the display for the level Culdesac Marker 

3. Enable the display for the level DesConstructionElements 

Discuss with Instructor 

4. Object>New.  

• Object Type: Construction.  

• Object Name: Temp PL 

5. Disable Add to Active Model. 

 
6. Click OK. 
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EXERCISE: CREATING THE TEMPPL CONTROL LINE ELEMENTS – PROFILE THE CENTERLINE 

Assign elevations to the construction object control line and add the element to the Object 

1. Elements>New/Edit. 

2. Drape on Model/Object. 

 
3. Define Elements>Select.  

4. Select the control line elements 

5. Click Apply. 

 

Profile the Control Line Element 

1. Open View Window 2. (MS: Window>Views>2) 

2. Click Fit View. 

3. Access the Active Site Profile tool frame. (MS: Modeler > Elements>Edit Profile). 

  

4. Right mouse click on Profile Cell Status.  

  

5. Select the Profile Cell Setting.  
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6. Click Add Element PCell Chain. 

7. Select the Temp PL control elements 

Hint The Station, Elevation, and Cell Range Data are automatically populated based on the element 
selected. 

8. Click Place Site PCell.  

9. Place the profile cell in a clear area of the previously opened view window 2. 
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10. On the Active Profile Control tool frame, right click on View 2 and set it to Profile. 

As you slide your cursor along the profile you will notice a cursor locked on the plan view 
centerline element in view window 1. 

 
Site Element Profile of Temp PL control elements 

 

Now that we can visually see the existing control elements profile, it is time to create the design 
profile.  We will do this right on top of the existing profile. 
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CREATING THE ENTRANCE ROAD ELEMENTS – DESIGN THE CENTERLINE PROFILE 

The constraints to consider, at this time, are the grading of the entrance road where the control 
elements overlap, the proposed longitudinal grades for the PL and the existing terrain.  

More constraints will be encountered and considered in following steps.   

With these constraints in mind, we shall begin the profile design. 

1. Click Vertical Component Tools. (Active Profile Control tool frame)  

  

2. Click Create Profile Line by Points (Vertical Components). 

  

3. Click Create Profile Curve Between 2 Elements (Vertical Components). 

 

Follow your Instructor to design the “first pass” profile. 
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INCORPORATING THE PROFILE INTO SITE MODELER 

We shall now send the proposed profile information back to the Site Modeler element. 

1. Click Define Site Element Profile (Active Profile Control tool frame). 

2. Select and accept any one of the proposed profile element. 

This strings all of the profile elements together. 

3. Data point to accept the proposed profile. 

 

The profile information is now returned to the Site Element. The Profile element redraws to reflect the new state of 
the Site Element. 

  

 

4. Close the Vertical Component tools. 

5. Close the Edit Profile dialog. 

6. Close View window 2. 
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EXERCISE: COMPLETE CONSTRUCTION OBJECT AND EVALUATE DESIGN. 

Using a reasonable maximum cross slope of 3%, we shall now add the other construction elements to 
the Temp PL object and then evaluate the result. 

1. Elements>New/Edit 

2. Slope/Offset from Site Element. 
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3. Select the elements north of the control line (2 solid green arcs). 

 
4. Reference these elements (at +3%) to the Control Line (arc). 

5. Click Apply. 

 

6. Repeat the process for the construction element to the east of the control line (line element). 

7. Repeat the process for the construction elements south and west of the control line – (use a  
‐3% slope). 
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The resulting construction object surface should look similar to the image above. 

 

Use the Analysis tools to evaluate this conceptual design. 

• Volumes (include Quantity Depth) 

• Drainage tools>Downstream trace 

• Profile 

8. Re‐profile the control element if required and, again, re‐evaluate the resulting surface. 
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EXERCISE: CREATE AND BUILD PARKING LOT OBJECT. 

This exercise will guide you through the steps create the “final design” Parking Lot Object. 

Now that the Construction Object has been created, evaluated and deemed suitable for purpose, the 
act of building the final design Parking lot object is relatively simple irrespective of the complex 
geometric elements/layout that is involved. 

Let’s begin! 

1. Reset the Active Object Control so that the Site Design Model is active. 

 
2. Object>New.  

• Object Type: Parking Lot.  

• Object Name: PL 1 

3. Enable Add to Active Model. 

 
4. Click OK. 
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5. Elements>New/Edit. 

6. Select Drape on Model/Object. 

 
7. Feature Type: Breakline. 

8. Drape on Object: Temp PL. 

9. Offset Height: Disabled 

10. Drape Option: Entire Element 

11. Use Reference Association: Enable. 

12. Click Define Elements>Select. 
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13. Select the outer edges of the parking lot AND the internal medians/island and drape these onto 
the Temp Pl Object.  

Do not select the curb returns that join the PL to the Entrance Rd. 

 
14. Click Apply. 
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15. Element>New/Edit>Section. 

16. Add Curb & Gutter sections to the outside of the PL “edge of pavement” elements. 

Use the Section Query tool to populate the section dialog settings 

17. Add a Curb only section to the inside of each median within the PL Object. 

 

Curb only section settings for medians/islands 

Focus on the plan location where PL joins to Entrance Rd. 

18. Elements>New/Edit>Drape. 

19. Select the 2 return elements and drape them (by vertices) to the Model. 

20. Element>New/Edit>Section 

21. Add Curb & Gutter sections to the 2 return elements. 
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Lesson Name: Design Pond (of minimum volume) 

LESSON OBJECTIVE: 

The improvements to the site will all drain to the Pond located south of the Parking Lot. A drainage analysis 
has determined that the required minimum volume for this pond is 3 Acre‐feet. 

Using the Pond Wizard, we shall create the required Pond. 

EXERCISE: CREATE POND. 

Using the Pond Wizard, we shall create the required Pond. 

1. Tools>Pond Wizard. 

2. Wizard Panel 1. 

 
3. Click New – create a Pond Object 

4. Populate the dialog as shown. 

5. Click Next 
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6. Wizard Panel 2. 

 
7. Populate the dialog as shown. 

8. Select the pond bottom graphic. 

9. Wizard Panel 3. 

 
10. Populate the dialog as shown. 

11. Click Finish. 
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Lesson Name: Resolve Slope Overlaps 

LESSON OBJECTIVE: 

There are some Object side slope overlaps between Objects that need to be resolved. 

EXERCISE: RESOLVE PARKING LOT SIDE SLOPE OVERLAPS. 

There are a number of methods to resolve side slope overlaps. What these really are, in other terms, 
are Object overlaps. Using the Dynamic Slopes option, we shall resolve the slope impacts on adjacent 
Objects. 

 

1. While Pond is still the active Object. 

2. Object>Edit>Display. 

3. Enable the Boundary display and click Apply. 

You will note that the Pond Object impacts on the Parking Lot. This needs to be resolved! 

 

We will first give the Parking Lot more priority in the FIFO list than the Pond. 

4. Model>Edit. 

5. Select the Parking Lot object in the FIFO list and move the object until it is below the Pond. 

6. Click Process. 

7. Make the Parking Lot Object active. 

8. Object>Edit>Display. 

9. Enable the Boundary display and click Apply. 
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You will note that the Parking Lot slopes now impact on the Pond.  

10. Analysis>Drainage Tools>Pond Analysis 

 

11. Set the analysis tool to act on the Model. 

12. Analyze the Pond. 

 

What volume is returned??  

• If the returned volume is greater than 3 Acre‐feet; no need to do anything ☺ 

• If the returned volume is less than 3 Acre‐feet, we need to keep working / 
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13. Object>Edit>Side Slopes. 

14. Set the Side Slopes option to Dynamic Slopes. 

 
Follow your Instructor to modify and apply the slopes.  

15. The steps to set side slope values are repetitive. These are the steps. 

• Enter <slope value> in Cut H:1V and Fill H:1V in the edit fields at the bottom of the dialog.  

• Click Locate and data point for the location at the outer edge of the PL1 Object to anchor the 
slope value. 

• Click Add List Item 

16. Additional Side Slope modifications may need to occur adjacent to the Building… continue editing 
the slope values and locations if this indeed the case. 
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Lesson Name: Adding Roadway Medians 

LESSON OBJECTIVE: ADD THE RAISED MEDIAN OBJECT 

This lesson will describe how to incorporate Roadway traffic islands into your Modeler design. In reality, it’s a 
very simple process but does seem to cause more questions than seems appropriate. 

Typically, traffic island will NOT be part of your Roadway Object. They will be separate Object.  

“Rule of thumb”… if you median/island is across the roadway centerline, it will need to be a separate object. 

1. First create a new median object.  (Modeler > Object > New) 

 

2. Element>New/Edit>Drape on Model/Object. 

3. Select the purple median graphic. 

 

4. Click Apply. 
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To complete the median/traffic island, we add a curb only section to the inside of the median.   

5. Select the Section tab of the new element tool. 

 

6. Click Query Section. 

7. Select one of the Parking Lot median edges that were created earlier. This will populate the 
dialog settings. 

8. Click Reference Elements> Select Element.  

9. Select the edge of median element. 

10. Click Direction>Set and data point inside the median shape. 

11. Click APPLY.   

 

The median is complete. 
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Lesson Name: Design Smaller Parking Lot 

LESSON OBJECTIVE: 

The smaller Parking Lot is somewhat simpler in geometric arrangement but encounters more physical 
constraints that need to be dealt with. Two (2) roadway intersections, the adjacent building pad (close and at 
a non‐negotiable elevation) and the natural terrain all create an interesting design scenario. 

Let’s begin! 

 

EXERCISE: EVALUATE DESIGN OPTIONS. 

While this Parking Lot appears significantly simpler than the larger lot, careful evaluation of all 
constraints prior to beginning design will ensure a better initial design result.  

Use the Analysis tools to evaluate the constraints of the parking lot. 

1. Analysis>Height/Slope. 

Use the Height/Slope tool to review both the contours and slope directions (in Height mode) and the actual “point 
to point” slopes (in slope mode) that the terrain presents relative to the layout of the Parking Lot. 

2. Analysis>Profile. 

Use the Profile tool to provide additional insight into the constraints imposed by the existing terrain relative to the 
layout of the Parking Lot. 

3. Analysis>Drainage Tools. 

Use the applicable Drainage Tools to provide additional insight into the constraints imposed by the existing terrain 
relative to the layout of the Parking Lot. The downstream trace would be useful. 

It appears as though a one way cross slope is applicable. The parking lot should slope towards the 
building. We need to ensure that the curbing around the parking lot is lower than the building 
elevation while not being too low such that retaining walls would be required. We also need to join 
neatly to the surrounding roadways. 
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EXERCISE: DESIGN PARKING LOT 2. 

The profiling of the parking lot control line is a relatively easy thing to do. We have all used Edit 
Profile (or the COGO Vertical alignment tools) before, so that’s not tough and is reasonably easy 
work. The tough part is to know what elevations to assign and how to best grade the lot. 

The Building pad is at elevation 408.25. If we allow a 0.5 vertical offset for slab depth (like 
“freeboard”) and then a min. 1% cross slope to the top back of curb, we will be at elevation 407.70 
(approx). Allow 0.5 drop for the curb height. We are at 407.20 at pavement grade. 

It’s then 6 feet from edge of pavement to control line – this adds 0.12 to our value. 

Our control line high point (adjacent to the building) is 407.32! 

PROCESS: 

1. Create Object. 

2. Drape Control Line on Model. 

3. Re‐profile control line. 

4. Project edges of pavement to control line. 

5. Add curb and gutter sections. 

6. Add join lines at each end of Parking Lot to the Object. 

7. Remove control line from Object 

8. Re‐profile edge of pavement elements as needed. 

9. Finished!!! 

 

This IS the Advanced class… ☺ 
 




