
  

 

 

2009 Roads and Bridges 
Conference 

 
 
 

IW-7 
Plans Production for InRoads V8i 

 
Presenter: Richard Morrow, Senior Solution Engineer 
 

 

Bentley Systems, Incorporated 
685 Stockton Drive 
Exton, PA 19341 
www.bentley.com 

 
 

 

 

 

Introduction  

This is a two hour workshop to learn the basics of InRoads Plan and Profile generator and how to use tools to 
create sheets, annotate and add drainage network which after this workshop you will know how to create 
deliverable plan and profiles using InRoads.  Appendix 1 will give you the opportunity to make adjustments 
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to the sheets. 
 
In this conference class, the topics covered include   
 . Plans Preparation  
 . Using a composite plan file  
 . Using Plan and Profile Generator  
 . Modifying Plan and Profile sheets  
 . Adding Drainage to Profiles  
 . Annotation  
 . Annotating profiles  
 . Annotating storm data in profile  
 . Using InRoads Plan notes  
 
LESSON NAME: PLAN PREPARATION  

LESSON OBJECTIVE:  
The following exercises will walk you through using InRoads to generate finished plan and profiles.  

>EXERCISE: STARTING INROADS AND LOADING PROJECT DATA  

In this exercise you will learn how to start InRoads and how to load project data using a project.rwk file. 
    

1. First we will start MicroStation and InRoads 
.(Start>Programs>Bentley InRoads Group>InRoads) 

2.  When the MicroStation Manager appears open the file 
C:\2009 RBC\IW-
7\DATA\Orthos\Ortho_Composite.dgn                                               
    

 
 

 
 
 
 

3. When MicroStation and InRoads Survey 
starts change the Project Defaults to  IW-7 
(File>Project Defaults) 
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4. Close Set Project Defaults Dialog box. 

5. Open project files C:\2009 RBC\IW-7\DATA\Project.rwk. (On the InRoads Menu: File>Open>(File 
Type: Project.rwk))  

>EXERCISE: CREATE AN ORTHO COMPOSITE FILE  

In this exercise you will attach aerial photographs using raster manager to be used later during plan 



© 2009 Bentley Systems, Incorporated    4 

production.  
1. You should be in Ortho_Composite.dgn from the last exercise. If not open that MicroStation file.  
2. (On the MicroStation Menu: File>Raster Manager)  
3. (On the Raster Manager Menu: File>Attach>Raster) Select all the Johnson.hmr files by holding down 

the shift key. Then select the OK button.  Dialog on next page. 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

>EXERCISE: CREATING A PREFERENCE FOR PLAN AND PROFILE GENERATOR  
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In this section you will learn how to setup the Plan and Profile Generator and save the settings as a 
preference to be used again.  

1. Open MicroStation file C:\2009 RBC\IW-7\DATA\profile.dgn. (On the MicroStation Menu: 
File>Open>(profile.dgn) 

2. On the InRoads Menu: Drafting>Plan and Profile Generator)  
3. On the main tab set the following:   In the Method area: Plan and Profile In the Station Limits area: 

Stop 70+65.09 Length to 1450    
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4. On the Plan Controls tab set the following:   Width Left: -200 Width Right: 200 Overlap: 0 Boundary  

             Chords: 6   This establishes the plan area to be clipped left and right of alignment. 
 
                                          

  
 
 
 

5. Next while on the Plan Controls tab select the Model 
files button. This will allow you to choose the   
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reference files that make up your plan view.   
 

6. Select MicroStation file C:\2009 RBC\IW-7\DATA\ Alignments.dgn, countours.dgn ,drainage.dgn, 
proposed.dgn ,rightofway.dgn, and topo.dgn. Hold down the CRTL key while selecting the reference 
files. Then Select open. 

 
7. Select the Model files button again. Browse to C:\2009 RBC\IW-

7\DATA\Orthos\Ortho_Composite.dgn 

 

8. Next move to the profile controls tab Vertical Alignment: VA1 Profile Elevation Shifts: Shift 
at Major Stations Profile Height: 45 Margins: Top: 20  Bottom: 40  Left: 50 Right:50 
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9. Next select the Sheet Layout tab to define the creation of the new sheets.  

10. Select in the Host file: field and push the three dots next to the field. C:\2009 RBC\IW-
7\DATA\Plan Sheets. In the file name area type the name of the new sheets to be created. 
PlanPro1.dgn Then select save. This is the name of the new files created. 

11. Next put your cursor into the Seed Host File: and push the three dots next to the field. C:\2009 
RBC\IW-7\DATA\Standards\3Dseed.dgn and select open.  
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12. Next on the Sheet location area toggle Layout along Alignment  
13. Change the Round to the Nearest to Degree  

14. Set the clip boundary level Clip Boundary 
15. In the Host file content area toggle to Single Sheet Each    

                                        

16. Next select the View Layout tab.  
17. In the location (Paper Units) set the dimension to locate the view to be created during the plan and 

profile process. Set the following. Plan: X=2.30 Y=16.50 Profile: X=2.30 Y=1.53. These dimension 
come from the lower left corner of  the border file.  

18. In the Scale: Section set it to 1=50 Since we will be creating 1”=50’ plan and profile sheets.  
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19. Next select the Border and Title tab.  

20. Next in the Border area toggle the type from Cell to reference file. And then browse to select the 
border file. C:\2009 RBC\IW-7\DATA\Standards\Border_PNP.dgn  

21. Then select the Title block Data File Name.  Select the browse button to select the title block .dat 
file C:\2009 RBC\IW-7\DATA\Standards\title_block.dat Select the file then open.  
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22. Pick the edit button below the Title Block Data File Name. This opens the file in NotePad. 
23. Next change the line dsgn=RAM to dsgn=YOUR INITALS Then save the file. 

 

 

Above is the information that will populate title block  



© 2009 Bentley Systems, Incorporated    12 

   

Reference File Name:  C:\2009 RBC\IW-7\DATA\Standards\Border_PNP.dgn 
Title Block Data File Name: C:\2009 RBC\IW-7\DATA\Standards\title_block.dat 
 
 

Make sure all information is filled out as shown above 
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24. Next select the Symbols and Details tab  
25. Set the following information North Arrow: Scale: 50 Location (Paper Units)  X= 28 Y=12  
26. Set the following information Miscellaneous: Scale: 50 Location (Paper Units)  X= 29 Y=12 
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27. Next select the Match Lines tab  
28. Set the Stations Format field to SS+SS.SS  

29. In the Symbology area Check on the following Plan Line, Plan Start Station and Plan Stop Station.  

30. Highlight the Plan Start Station and add a prefix  MATCHLINE STA =  

31. Highlight the Plan Stop Station and add a prefix  MATCHLINE STA = .  

 
 

32. Select the Preference button at the bottom of the Plan and Profile generator menu. And save the 
preference change you made as default.  
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33. Next select Apply button and pick a point on the left side of your MicroStation window in the 
Profile.dgn  

34. You have now created your sheets and populated the Sheet Index tab.  
 

 

What the Sheet Index Dialog should look like after creating sheets. 
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>EXERCISE: MODIFY PLAN LOCATION  

In this exercise you will learn how to modify a sheet after running the Plan and Profile Generator. You will 
adjust  the curve in plan view.  

1. If you closed the Plan and Profile Generator open it back up. On the InRoads Menu: 
Drafting>Plan and Profile Generator)  

2. Next in the Sheet Index tab in the Sheet Index area highlight the first sheet 1.  
3. Next in the Sheet Views area highlight the plan view and select the edit button.  
4. Set the Y Anchor point 17.50 and select OK.  
5. In the Show Sheet area change the Clipping Boundary Mode: Calculate  
6. Next select Regenerate Sheet Select Yes on the below dialog. And the sheet is re-calculated based 

on the new plan anchor point.  
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>EXERCISE: PROJECT STORM DATA TO PROFILE  

In the following exercise you will learn how to turn on Storm and Sanitary while in InRoads and project the 
proposed storm data onto a roadway network on the profiles cut from Plan and Profile Generator.  

1. Open the Profile.dgn C:\2009 RBC\IW-7\DATA\Profile.dgn.  
2. If InRoads Suite was not loaded you need to load Storm & Sanitary On the InRoads Menu: Tools>Product 

Add-In)   and Check InRoads Storm & Sanitary.  
3. Next step (On the InRoads Menu: File>Open)  Change the files of type to Drainage.sdb Open the drainage 

file C:\2009 RBC\IW-7\DATA\Drainage\DRAINAGE.sdb  
 
                                    

                               
 
 
 

4. Next open the create profile dialog (On the InRoads Menu: Evaluation>Profile>Create Profile) Select the 
preference tab and load the drainage preference  
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5. Select the Source folder under create profile and set the Network Structures From:IN2 To:P25 This 

accounts for all the structures in our drainage network.   
6. While still under the Source leaf also set the Drainage Network Reference. Existing Profile 
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7. Next select apply and pick the profile set that was created from running the Plan and Profile 
Generator.  

Note: not all profiles will have drainage structure. 
 
 
8. Say OK when you get the dialog saying can not project all structures onto profile.  

 
               Only the first three profile sets have drainage network data on them.  
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LESSON NAME: ANNOTATION  

LESSON OBJECTIVE: During the following exercises you will learn how to annotate your plan and 
profile sheets you created in the previous exercises. You will learn how to use tools within InRoads to 
automate most of you annotation.  

>EXERCISE: PROFILE ANNOTATATION  

In this exercise you will learn different aspects of profile annotation. You will display your proposed vertical 
design as well as display the super elevation diagram in profile.   

1. Next while in the profile.dgn from the last exercise  (On the InRoads Menu: Geometry>View 
Geometry>Vertical Annotation)  

2. Next select the points tab. Set the Point Type: PVI and check on the Station and set the Position: 1 
and the Precision: 0.12 and the Format: SS+SS.SS  

3. Next check on the Elevation and set the Position: -1 and the Precision:0.12  
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4. Next select the Curves tab.  
5. Set the Category to Common Curve and check Length, Entrance Grade, Exit Grade, and Site 

distance.  
6. Next set the Witness Line Minimum Length  100 
 
7. Next in the Named Symbology area select Curve Annotation and double click to edit. Under the 

Named Symbology area select Prop Vertical  
 
8. Next on the Curve Annotation Location: Above 
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9. Next Select the Tangents tab. And check on Grade.  
10. Next in the Symbology area check on the Tangent area.  

11. Next while Tangent highlight double click to edit  symbology.  
12. The next step is to set the Named Symbology for Tangents Annotation. Select Prop Vertical  

 

                     
 

.                                
13. Next select Apply to do the proposed annotation.  
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View after Vertical Annotation  

 
14. Next you will add the Super elevation diagram and existing and proposed elevation annotation 

to the profile.  

15. Next (On the InRoads Menu: Evaluation>Profile>Annotate Profile)   
16. Next select the Selections folder and in the Available area add Existing Superelevation, and 

Proposed.  

 
 

 



© 2009 Bentley Systems, Incorporated    24 

17. Next under the Annotate Profile Select Proposed Settings and set the precision 0.123  

                           
 

18. Next under the Annotate Profile Select Existing Settings and set the following:  

Precisions: 0.12  
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19. Next on the Annotate Profile menu select the Annotate Profile folder.  

20. Set the following, Vertical Alignment: va1, Surface: Exist, Corridor: HA1 and the Annotate 
at: Station Intervals Only 

                                         
21. Next select Super Control Lines: ALL  and Profiles: ALL 
22. Next under the Annotate Profile Select  Superelevation Settings and set the following. 

                                   
 
                             

                                              
Note: Select the three little dots on the right side to access the symbology settings for each areas 

 
  Section2CL-LEP:  Color: Green  Level: DES-PROFILE-SUPER  Weight: 1 

  Section2CL-REP:  Color: Red (3)  Level: DES-PROFILE-SUPER  Weight: 1 
  Reference Line:  Color: (5)  Level: DES-PROFILE-SUPER  Weight: 1 LineStyle: (7) 
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The above view is of the first profile after adding the superelevation diagram, existing and proposed elevations 

>EXERCISE: STORM PROFILE ANNOTATION  

The next exercise will annotate the storm data that we project onto the roadway profile earlier. You will set 
the annotation for the structure IDs and ring elevation as well as pipe slope and length. You will also 
annotate the inverts In and Out.  

1. Next open the annotate drainage profile menu (On the InRoads Menu: Evaluation>Profile>Annotate 
Drainage Profile)  

2. Next select the items to annotate. Select Pipe 
Attribute ID and put an X in the show area  

3. Next do the same as step 2. but for 
PipeSlopeLength, InvertIn and InvertOut.  

4. Next in the Symbology area select pipe and 
edit.  

5. Next set the Symbology Name: Prop 
Vertical    

6. Select the Preview to see what annotation 
will look like on pipe.  
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7. Select Apply to add Drainage Network Annotation to Profile.  

8. Next open the Plan and Profile generator menu On the InRoads Menu: Drafting>Plan and Profile 
Generator)  

9. Next select the Sheet Index tab and in the Sheet Index area highlight sheet 2 and the select the show 
sheet button to change from profile.dgn to PlanProf2.dgn. You could use MicroStation file open 
command as well.  

 

           

Dialog used to change to sheet 2 PlanPro2.dgn, should look like the sheet on next page.  
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PlanPro2.dgn  without Ortho Image turned on 
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>EXERCISE: PLAN NOTE ANNOTATION  

Next on PlanProf2.dgn you will place a plan note using the Intersection note tool. This will get the alignment 
name of the two alignments and stationing from the alg file. This and the other plan notes are great tools to 
use since you can update them if the elevation, offset or alignment name changes automatically.  

1. Next open the drafting notes menu  On the InRoads Menu: Drafting>Place Alignment Intersection Note)  
2. Next in the Note field use the plus sign to navigate to Alignment notes and Highlight the  

 
Align-Align Stationing  

 

                                     
 
 
 

3. Next select Apply and pick the mainline then 
Accept, then select the side road and Accept.  

4. Next define the quadrant location to place the 
note then locate note                              
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5. Next zoom into the title block area to view your initials that were automatically place into the title 
block when you added your initials to the Title_block.dat file earlier when you were setting up the 
Plan and Profile Generator 

                                        

 
view of title block integration  
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6. You have now completed Plan and Profile sheets for this project. View sheet 
PlanPro2.dgn. Your sheet should look the similar to below.    

        

 

Completed Plan and Profile 
 
 
 
 

 
 
Appendix 1: Workflow for Sheet View Modification 

 
EXERCISE: SHEET VIEW MODIFICATION  
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In this exercise you will learn how to make modifications to view length by station and how to adjust 
plan and profile view locations.  You will make adjustments to allow for a legend on the left side of 
the first sheet in plan view. 
 

1. Open the Profile.dgn C:\2009 RBC\IW-7\DATA\Profile.dgn.  
2. In MicroStation select all the graphics that make up the profile cut from the previous exercises and 

delete them. 
3. Next open the Plan and Profile generator menu On the InRoads Menu: Drafting>Plan and Profile 

Generator)  
4. Select the Sheet Index Tab then in the VDF File Name open:  

C:\2009 RBC\IW-7\DATA\Standards\AdjustedViews.vdf  
 

               
 
5. Next select the Main tab. In the Plan Views area set: Use Plan Views 
6. While in Profile.dgn select Apply on the Plan and Profile Generator dialog to create new sheets. 
 



© 2009 Bentley Systems, Incorporated    33 

                  
 
 
7. Select the Sheet Index tab.  Select sheet index 1 and make modification in the Sheet Views:  

Plan:  Anchor X: 10.30 Anchor Y: 17.50 
Profile Anchor X: 10.30 Anchor Y: 1.53 
 

8. Next make sure Calculate is toggled on and sheet 1 is still highlighted then select the Regenerate 
button. This adjusts the view location to accommodate the legend on the first sheet. 

 
 

                                         See next page for dialog 
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9. Open the Profile.dgn C:\2009 RBC\IW-7\DATA\Profile.dgn.  
 
10. Do the annotation for profile that was done in the previous exercises. 
 

(On the InRoads Menu: Geometry>View Geometry>Vertical Annotation)  Apply 
(On the InRoads Menu: Evaluation>Profile>Annotate Profile)  Apply 
(On the InRoads Menu: Evaluation>Profile>Create Profile) Select the preference tab and load the drainage 
preference.  Source Leaf then Network  IN2 to P25 Apply 
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11. Next open the Plan and Profile generator menu On the InRoads Menu: Drafting>Plan and Profile 
Generator)  

12. Next select the Sheet Index tab and in the Sheet Index area highlight sheet 1 and the select the show 
sheet button to change from profile.dgn to PlanPro1.dgn. You could use MicroStation file open 
command as well.  

13. Place Cell Legend using MicroStation place cell command to place cell in the blank area in plan 
view. 

14. Next use the control Key to select the elevations in profile on the left side. 
15. Use MicroStation copy command and copy elevation to the left into the correct location. 
16. Next place a fence as a shape to clip mask in profile the elevation on the left side in the referenced 

profile.dgn. 
 

 
 
                                     Planpro1.dgn completed from adjusted views 
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