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GEOPAK Road for Bridge Chapter 3 Project Manager

3.1 Objectives

e Learn how to set up a project using Project Manager.
e Learn how to utilize Project Manager as a workflow guide.
e Learn how to access GEOPAK dialogs from the Project Manager.

3.2 Definitions

Project Manager is a GEOPAK tool that associates a project with its respective gpk job number,
users, working directories and project files. Project Manager provides the user with an easy
workflow system that keeps records of processes run throughout the design of a project.

33 ACCESSIng applications  window  MoDOT  Add-Ons  Construckion  Help
. GECPAK » i
To access Project Manager: R NeE o i @ T 6 LT @ J [
o Select App“C&thﬂS >> GEOPAK GECPAK ROAD [y GECPAK ROAD Tools
Road >> Project Manager (as shown CEOPAK SITE N
in the figure to the right) or Clieet ey
GEQPAK SURVEY ’

Active Chain Conkrol

G x| o Select the Project Manager icon GECPAK Element Attributes
% :)g— from the GEOPAK Road Tools GECPAK 3PC ||:'|dH|:|_|: akkribute &
i - g (both are shown to the
_____ Y g left), which are opened by Y ] 3
& selecting Applications >>  prgjects  Directory  Admin
mier Ry GEOPAK Road >> T:\de-profColeliSp1 004project’
Q & GEOPAK Road Tools. . e
The following dialog depicted to the right appears: ipri [D]ire':mm j
- . [projdbsz]
3.4 Project Manager Dialog ]
[C]
3.4.1 General Description 2 o
The current directory is displayed at the top of the Job Number 100 Lirit System: English
dialog box, which can be changed by navigating to a .
different directory in the Directories list box. This Description:
Clazs Project

navigation is the first step in selecting an existing
project or creating a new one. Project files (.prj)
are displayed in the Projects list box. The project
files should be located in the
t:\br-proj\A_Geopak\district\jobnumber\project
directory.

I

Cancel I

The remainder of the Project Manager dialog box displays information after a project has been
selected from the Projects list box. At the bottom of the dialog are the OK and Cancel buttons.
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Chapter 3 Project Manager GEOPAK Road for Bridge

If the user wishes to exit Project Manager, the Cancel button should be selected. To continue in
the Project Manager process, the OK button should be selected.

3.4.2 Project Manager Menu Bar

There is three pull down choices on the Menu Bar: Projects, Directory, and Admin. Each of
these choices has options contained in the pull down.

3.4.2.1 Project Tools
_ (0] x| There is four choices under the Projects pull down:

e e New, Edit, Delete, and Exit as shown below.

As can be seen from this dialog box, the Windows

Edi.. motif also keeps track of the last few processes that
Delete, ..
have been executed. These may be recalled as
1 j2p0Z00 mitchal ¥55hests MaDOT needed by selecting the desired process.
2 j2p0200 mitchal ¥S5heets ¥5_Eng
3 j2p0200 mitchal PlanProfileshests NEW 3.4.2.1.1 New...
4 j2p0200 mitchal PlanProfileSheets 1100 The New menu option is used to create a new
5 j7ul436 mitchal X5Sheets k5_Met I project. The .prj file will be stored in the directory
6 j5p0100 mitchal PlanProfileSheets 1100 shown in the Directory path at the top of the Project
7 j7u0436 mitchal PlanProfileSheets M1000 Manager dialog box. When the New menu option is
8 j7u0436 mitchal PlanProfileshests 1100 selected, the Create New Project dialog appears
9 jZp0z00 mitchal SuperEleyationZ000 Roadl (shown at the bottom of the page).
10 j2p0200 mitchal ®55heets ®5_Eng
o The Project_ Name can be any number of _
alphanumeric characters. For MoDOT projects, the

ak. i Cancel ] Project Name needs to be the same as the job
number. (i.e. jJ1p0999.prj) The Working Directory
specifies the location of the project data files. The Working Directory may be keyed in or the
Select button may be chosen and the appropriate directory selected. For MoDOT Bridge, the
Working Directory should be set to t:\br-proj\A_Geopak\district\jobnumber\data.

The next field is for typing in the =10l x
COGO job number, or the Select e .
button may be chosen and the |
appropriate COGO job number Working Directony: | 5e|e.:t...|
selected. Job Murnber: | Select | B

TEfelences I
Next the Preferences button Project Description:

should be chosen and the Project
Preferences dialog appears,
which is depicted on the
following page.

(1] | Cancel |
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GEOPAK Road for Bridge Chapter 3 Project Manager

The user may set the particular
EEEDPAK User Preferences Ol =] y P .
TR parameters for each project as
Init Systerm:  Englizh t AHLE B, i
¥ Engish | Distance 991734 vl well as the Working

Coordinates:  #5v i I
o : Station:  9+39[9).12 - |
Direction:  Bearing - I .......................................

Directory. This keeps the user
from re-setting them when

dngle Seconds? 9799 -| i i ;
Chafiore 17434 v| cha_nglrjg projects since the
project’s preferences are
Waorking Directary: | Q recalled when entering the
Feature Preferences... - PI’OJGCt. _Aftgr all of the
I Show this dialog at GEOPAK startup information is entered, select
COGO Preferences... !
OK to accept the changes, or
oK | Cancel | Cancel to reject them. For

more about User Preferences,
see Section 1.5 in Chapter 1.

Shown below is a sample project that includes a project description, which may be keyed in at
the bottom of the Create New Project or Project Info Edit dialog box. The Working
Directory is set to:

t:\br-proj\a_geopak\d5\j5p0100\data.

#£ Project Info Edit X

Project Mame:  JEP07 00, prj

Working Directony | k:%br-projha_geopakhdBhj5p01 00Y Select... |

Job Number: |'IEIEI Select | e — |

Froject Description:

Sample Clazz Project

Cancel |

3.4.2.1.2 Edit...

The Edit menu option is used to change any settings associated with the currently selected
project. When chosen, the Project Info Edit dialog box shown above appears.

3.4.2.1.3 Delete...

The Delete menu option is used to delete any project that has been stored. The user highlights
the project in the Projects and selects Delete.

3.4.2.1.4 Exit
The Exit menu option closes the Project Manager and writes the settings to a resource file.
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3.4.2.2 Directory Tools

There are two options under the Directory pull down, Create New Directory and Current
Working Directory as shown below.

EPruject Manager =101 x|
Projects | Direckory  Admin

Creake Mew Direckary. ..

Filte  Current Working Directory |t

Projects: Directaries: -
{Bp0100. prj [.]

[Clzll=er]

The Create New Directory option creates a new directory on the disk.

If the Current Working Directory option is chosen, the directory path in Project Manager is
changed to that directory.

3.4.2.3 Administration Tools

The Administration menu option is used to set a password on a project. It is recommended that
a password not be used since the project will need to be accessed by more than one user.

EPruject Manager
Projects  Directory

k5br-praj’ 55RO 00 praject!
Filker: |".|:|ri Type  Project I

Frojects: Directones:

{Bp01 00, pry [.] |~
[projdbas]
[..5project] —
[-a:]
[-b]
[-c] B

Job Mumber: 100

D eszcription:

Sample Clazs Project

ok | Cancel |
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3.5 Project Users Dialog
Once a project is highlighted and OK is selected, the Project Users dialog appears.
This dialog has three sections: Project Users, Project Users: j5p0100.prj

User Info, and Description. The Project Users
Users list displays a list of users that have been

Project zers:

created to work with any project that resides in User Info
the current projects home directory. The names Full Marme:
shown in Project Users will be the userid’s of Clls Ly
the people working on that project as specified OF Code:

in the Start Job dialog. Within the User Info cu
group box, the Full Name field further

identifies the user, and displays the full name of ~ Description:

the user that is currently selected. The OP Usger Id for Clagsroom
Code field displays the GEOPAK Operator
Code of the currently selected user. The
GEOPAK Operator Code is used for all
coordinate geometry operations during this

session. The Operator Code, along with the Job il ﬂl
Number, will be utilized whenever an input or

output file is created by the software. The

Operator Code will be the user’s first and last e

initials. The Description field displays the &
description of the currently selected user. %’ et e——————

] Delate, . Full Mame:
Four tools are supported on the Project Users e Class User
pull down as depicted in the exploded view to Password OF Code:
the right. T cu
e
3.5.1 New

The New pull down menu option creates new users. This option is not to be used in MoDOT.
To create a new user for a project, use Start Job/Add User under the MoDOT menu with Add
Userids to Existing Job activated, as show in the following figure. Start Job/Add User must be
used for the user to have the default MoDOT runs.

i
Job Humber |{Sp0100 Browse. .. I
¥ sppend Job Humber
Fath: | tide-mrafEolel Erowse.., I
V¥ i&dd Userids to Existing J ok Urits | [rnperisl "I
[useriDs 4] [Shests 4]
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3.5.2 Edit

The Edit pull down menu option allows the user to change any of the parameters of the currently
selected user. (Note: The User cannot be changed. This will change the user information for the
current project only.)

3.5.3 Password

The Password tool creates or modifies a password for the selected user. If the selected user
already has a password, the user is prompted to enter the current password before continuing.
3.5.4 Exit

The Exit option closes the User dialog and returns back to the Project Manager dialog.

3.6 Road Project Dialog

After a minimum of one user has been defined, selecting the OK button on the lower left corner
of the Project Users dialog or double clicking on a Project User will open the Road Project
dialog.

i
File Remember Options
Working Directony:  t\br-profha_geopakhd5h5p0100Ndata
v ‘working Alignment Influence Funs

YWhorking Alignment MaDOT

User usernc Job & 100 _I
Drefine | Paort Yigwer |

Exizting | |
Ground _ Existing Ground Existing Ground Yertical
Draw Pattern . . .
Crozz Sections Prafile Aligrirent
Coordinate |
Geametry | |
Calculate Superelewation Fropogzed an
_ Superelevabon | Shapez | CrozsSectionz [ Modelz
Horizontal
Alignment
Plan View J — Earthwark Erngizztztmn
Dezign _
Plan Yigw T abular
[uantities Summaries | |

Plan % Profile Limitz of Reports & =5
Sheets Canstruction Huantities
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3.6.1 General Description

The top of the dialog displays the Working Directory, Working Alignment (if defined), User
and GEOPAK Job Number. In addition, a toggle for Working Alignment Influence Runs is
also supported. The bottom portion of the dialog box displays the various processes supported
during the design process. The small square in the upper right corner (to the right of the Job
Number) will condense the dialog as depicted in the graphic below.

BIC1E

File Remember Options

YWhorking Directory:  tAbr-proja_geopakdahjpp01 00hdata
v ‘working slignment Influence Buns

YWhorking Alignment MaDOT

Uzer usernc Job f: 100 _
Drefine | Paort Yigwer |

3.6.2 Road Project Dialog Menu Bar
The three pull down menu bar options are: File,

Remember, and Options. When the File [Fle Remember Options
option is selected, the choices are Close and : Close g Directory:  Ehbr-projva_geopak'dS4iSp0100hdata
Exit. ?'@ alignment Influence Buns

——mroreng Alignment kMaDOT

If the Close option is selected, the user is
returned to the Project Manager dialog. If Exit is selected, the user is exited from Project
Manager.

When the Remember option is selected, the

user can instruct the software to remember the File | Remember  Options

Project or the User in subsequent sessions. For W Project | bMbrprojha_geopakhdSySp01004data
example, if all both toggles are activated, and W W User  pntInfluence Runs

the Project Manager is completely closed, the Warking Alignment  MoDOT

invocation of the Project Manager immediately
invokes the Road Project dialog (flow chart) and utilizes the project name, username, etc., which
were active when the Remember toggles were selected. If only the Project toggle is activated,
the user is returned to the Project Users dialog in subsequent sessions. If only the User toggle is
activated, the user is returned to the Project Manager dialog in later sessions, but will skip the
Project Users dialog. This option is particularly useful when the user is working on more than
one project but always enters Road using a single user id.

The Options menu allows the user to toggle on

the Auto Sink option. When toggled on, this File Remember | Options

option sinks (move behind the open drawing Wworking Directt Auta Sink |geupakad5ai5pn1nmdata
views) the Road Project Manager dialog whena ¥ ‘warking Alignment Influence Funs

tool is chosen from the Project Manager. When ‘working Alignment  MoDOT

a tool is closed, the Road Project Manager
dialog becomes the active dialog.
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3.6.3 Working Alignment

The concept of a working alignment enables the designer to organize a project and to access
project information without continually typing the required information. On a simple project,
only one working alignment may be needed. However, on a more complicated project, an
unlimited number of working alignments may be defined. The designer can easily change from
one working alignment to another by highlighting the desired alignment listed in the Select
dialog. Three tools relating to working alignments are located at the top of the Road Project
dialog:

e Select Button
e Define Button
e Working Alignment Influence Runs (toggle on left side of dialog)

il x4

File Remember Options
Working Directony: — thbr-projha_geopak\d5hbp0100hdata

¥ ‘wiorking &lignment Influence Funs
YWorking Alignment MoDOT

Uzer userc Job #: 100 _
Drefine | Paort Yigwer |

3.6.4 Select Option

When the Select button is pressed, the Select Working Alignment dialog appears as depicted to
the right. If no working alignments have been defined, MoDOT appears in the Run List box. If
working alignments have been defined, they are listed with the last run time. The description of
the working alignment can be seen in the bottom of the dialog when each Name is highlighted.
To select a previously defined working alignment, highlight the run from the list then press the
OK button at the bottom of the dialog. Double clicking on the Name also selects a previous
working alignment for subsequent processing. Pressing the Cancel button closes the Select
Working Alignment dialog without any

working alignment change. Several file

option are supported as depicted in the =

exploded view below. These include
New, Copy, Rename, and Delete.

D ezcription

PoDOT default mn for Select Working Alignment. Geopak
2004, Lazt Revized on 04/14/2004.

Cancel |
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e Run > New - allows the user to
create a new working alignment.
(Do not use this option as it will
not copy the default MoDOT
settings for the working alignment.
Instead, use Run>>Copy>>Run to
copy the MoDOT run.)

e File > Copy - allows the user to
copy an existing Project, User or
Run.

e File > Rename — allows the user to
change the name of the existing
working alignment.

e File > Delete — allows the user to

delete an existing working
alignment.

3.6.5 Define Option

Select Working Alignment
| Bun
Mew

oL Time

S /10/2003 13:34:21

Modify. ..

Delete

Dezcription

taDOT default run for Select Working Alignment, Geopak
2004, Last Revised on 04./14/2004,

Cancel I

i B i Working Alignment Definition: MoDOT =10 ]
Once a Worklr_\g Allgnme_nt IS 2 it e |
selected, pressing the Define button Bisi o e
invokes the dialog depicted to the slepes B Stdion
right. The information that can be olooson. L
associated with a working alignment is Esisting Ground
listed in the left portion of the dialog o e e
box. As each option is chosen, the
right side of the dialog box changes to o] )
reflect the information needed as can
be seen in the dialog box to the right
after Profile View was selected.

# Working Alignment Definition: MoDOT =10 ]

All information entered in these fields o o e [
can be used in subsequent processes e EvistingProfle: [ _Select |
run from Project Manager. In the e Vi Propased Profes [ _Select |
beginning of a project, much of this ey Saca i Begin Station:
information is not known but, as the e End Station:
user goes through the design process, it o
can be added to the working alignment
definitions. o Caneel |
6/28/05 Missouri Department of Transportation 3-9
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For example, as soon as the chain

R gWurking Alignment Definition: Route50 '8 =10l
has been stored in (_JOGO, t_he _ o e
user can enter that information in e o B
the Plan View fields as depicted Shapes o NS
to the right. For a more complete | “Losuin B
explanation Of eaCh Option Eroéiiitnienc;ig:o\ﬂi;v End Station:  490+84 82
shown, please see the on line Proposed Finish Grade
GEOPAK Help by going to the o

MicroStation menu path:
Applications > GEOPAK Road 3 Cancel |
> Help.

3.6.6 Port Viewer

The Port Viewer is a tool that enables the user to view all three major aspects of a road design
simultaneously even though they are located in different files. The three views include:

e Plan

e Profile

e Cross Section

As a prerequisite to invoking the Port Viewer, a working alignment must be defined with the
following information.

e Alignment Specification

e Plan View Design File and Chain

e Profile Information

e Cross Section File

e Digital Terrain Models

The Port Viewer is covered in more detail in Chapter 16 of the manual. The tool is invoked by
clicking on the accented button in the following figure. A error message is generated if all of the
prerequisite information is not defined prior to activating the tool.

i

File Remember Options
YWhorking Directory: — t\br-projia_geopakd55p01 004data

V¥ ‘working Alignment Influence Funs
Working Alignment  kMoDOT

Uzer usernc Job f: 100 _
Select | Define |
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3.7 Project Manager Process

The primary Road Project dialog is depicted below. The advantage of utilizing the Road
Project dialog rather than selecting functions directly from the Road menu is that pertinent
information stored within the Project Manager is automatically displayed within the invoked
dialog. Therefore, job numbers, chain names, stationing, file names, and data associated with the
project do not have to be typed in each time a dialog is utilized. However, the user can change
information in the fields.

i x4

File Remember Options

Working Directony: — thbr-projha_geopak\d5hbp0100hdata
W wiorking &lignment Influence Funs

YWorking Alignment MoDOT

Uzer userc Job #: 100 _
Define | Part Yiewer |

Exizting | |
Ground _ Existing Ground Eristing Ground Wertical
Cirawe Pattern . . '
Crozs Sectiohz Prafile Alignment
Coordinate |
Geometry | |
Calculate Superelevation Propozed a0
_ Superelevation | Shapes | Crogz Sections | kodels
Haorizontal
Aligrirment
Plan Yiew J —— Eathwark Eru:u;shﬁ etctu:un
Design [ L eefs
Plat igw Tabular
Huantities Summaries | |

Plan & Prafile Lirnitz of Repaorts & =5
Sheetz Congtruction [Huantities

Many of the Project Manager processes function identically to their corresponding dialog’s
invocation from the Road menu. However, some of the procedures invoke the Select Run dialog
prior to invoking the actual dialog. The Select Run dialog allows the user to set up different
options to use in alternative design choices.

Each of the Road Project dialog processes is covered individually in the remaining chapters.

3.7.1 Select Run Option

When certain procedures are selected from the Project Manager dialog, the Select Run dialog
is invoked. The Select Run dialog allows the user to save the settings for each procedure in a
Run that can then be recalled whenever the user needs to execute that same procedure. With the
individual runs, a user can keep a history of the project, and can access the various procedures

6/28/05 Missouri Department of Transportation 3-11
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with the settings that were previously

used. This way a user can repeat various SelectRun
procedures with the same settings Run

previously used. M ame Time

When the Select Run dialog is invoked,
MoDOT appears in the Run List box.
(Some Select Run boxes will display
default run names such as English,
Metric, 1100, 120, etc.) If Runs have
been defined, they are listed with the last
run time. The description of the Runs Description

can be seen in the bottom of the dialog gﬂﬂug?gagfgggi;zg f;;ﬁfgggggg Cross Sections; Geopak
when each Name is highlighted. To

select a previously defined Run,
highlight the run from the list, and then

press the OK button at the bottom of the ﬂl
dialog. Double clicking on the Name
also selects a previous Run for subsequent processing. Pressing the Cancel button closes the
Select Run dialog without any run settings change. Several file option are supported as depicted
in the exploded view below. These include New, Copy, Rename, and Delete.

e File > New — allows the user to m

create a new run. (Do not use this
option as it will not copy the e :

default MoDOT settings for the _—
procedure selected. Instead, use project FlPNER LA ERE
Run>>Copy>>Run to copy the
MoDOT run.)

e File > Copy - allows the user to
copy an existing Project, User or
Run. Description

MoDOT default_run for Propozed Crozs Sechions; Geopak
e File> M0d|fy —allows the user to 2004; Last Revized 04./14/2004

change the name of the existing
Run or its description.

Cancel |

e File > Delete — allows the user to
delete an existing Run.
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