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1) Open the plan.dgn.
 

2) Using Project Manager open the following project:

  		pw:\District CADD\Design\Randolph\J2P0203\project\J2P0203.prj

[image: ] 


Select ClsUser as the project user.

[image: ]



3) [image: ]From the GeoPak Road Tool Palette, select Corridor Modeling:









4) Open Corridor Modeling, load the J2P0203.rdp and then select the Open Create Template icon.

 [image: ]


5) Navigate to the J2P0203 > End Conditions folder and right click to create a new template called “Special Ditch Profile”.

 [image: ]



6) To create the new slope component, right-click on the Template Window and select Add New Component > End Condition.


7) Setup the Current Component portion of the Create Template dialog as follows:

Name:	 	Special Ditch Profile
Style: 		XS Ground Proposed
Target Type: 	Style Elevation
Style:		Special_Ditch_Right
Priority: 		1
Surface:		 <Active>

[image: ]


8) For the first point setup the Dynamic Settings dialog as follows:

Point Name: 	Ditch_Frslp_1_T (select from list)
[image: ]Point Style:	XS_Ground_Proposed
Apply Afhxes: 	Disabled
Precision Input: 	xy = 0,0









With your cursor in the xy=0,0 field, press the “Enter” key on your keyboard.





9) For the second point setup the Dynamic Settings dialog as follows:
[image: ]
Check for Interception: 		Enable
Place Point at interception: 	Enable
End Condition is Infinite:	 	Enable
Do Not Construct: 		Disabled
Point Name: 			Ditch_Frslp_1_B 
Point Style: 			XS Ground Proposed 
Apply Affixes: 			Disabled
Precision Input:			hs = 20,-1:6








With your cursor in the hs = 20,-1:6 field, press the “Enter” key on your keyboard.


10) Right-click on the Current Template window and select Finish.


11) Create the next Ditch Component by Right-clicking in the Current Template window and select Add New Component > End Condition.

Setup the Current Component portion of the Create Template dialog as follows:

Name: 		Flat Bottom Ditch
Style:		 XS Ground Proposed
Target Type: 	Surface
Priority: 		1
Surface: 		<Active>
[image: ]











12) For the first point setup the Dynamic Settings dialog as follows:

X Step: 	0.10 
Y Step:	0.10
 [image: ] 

Start the Flat Bottom Ditch by place it’s first point on top of the Dtch_Frslp_1_B point.


13) To place the Back of Ditch bottom point, set the Dynamic Settings dialog as follows:

Point Name: 			Dtch_Bkslp_1_B (select from list)
Check for Interception: 		Disabled (This forces this line segment to be placed)
[image: ] Place Point at Interception: 	Disable
End Condition is Infinite: 		Disabled
Do Not Construct: 		Disabled
Apply Affixes: 			Disabled
Precision Input: 			hs = 8,0











With your cursor in the hs = 8,0 field,
 Press the Enter key






14) To place Slope-Stake point, set up the Dynamic Settings dialog as follows:

Point Name: 			Dtch_Bkslp_1_T (select from list)
Check for Interception: 		Enable
[image: ]Place Point at Interception: 	Enable
End Condition is Infinite: 		Enable
Do Not Construct: 		Disabled
Apply Affixes: 			Disabled
Precision Input: 			hs = 5 ,25% 


Toggle on End Condition is Infinite






With your cursor in the hs = 5, 25.0%,
 press the Enter key

15) Right-click on the Current Template window and select Finish.


16) Select File > Save to save the template library.


17) Test the End Conditions by selecting the “Test” button located under the Current Template window.  

Try and draw the Active Surface in the test window.  You will notice the ditch does not draw until you introduce the Special Ditch Profile Style Elevation.














18) [image: ]Next we need to account for cases where there will be not be Special Ditch Profile.  To do this drag and drop the following MoDOT standard End Conditions into our new combined End Condition template.  Be sure the Dynamic Settings are active and with a step increment set to 0.01

Right Side						

Fill Slope 1 (6:1) 
Ditch 







19) Once again test the End Conditions by selecting the “Test” button located under the Current Template window.  A warning will be given about the template having end condition priority conflicts.

[image: ]


















20) Select Check Priorities on the right side of the Test End Conditions window.

[image: ]








Notice the Ditch_Frslp_1_T point is the point that has the priority conflicts.



[image: ]

















21) In the End Condition Priorities dialog select Edit.

Notice that all the end conditions have the same priority number.

[image: ]

Put your cursor in each of the fields and notice the segments highlighting.

The Special Ditch Profile is the most desirable condition, therefore set the priorities as follows:

[image: ]

Click OK, and then Close.


22) Select the active surface and click “Draw” on the right side of the Test End Conditions window.  Move your cursor over the end conditions.  

Next introduce the Special Ditch Profile by selecting the Special Ditch Profile style and click “Draw”.  


23) Close the Test End Conditions dialog.  Save the Template Library by Selecting File > Save. 









24) In Create Template navigate to the J2P0203/Road1 folder and remove the End Conditions in the Road1 Two Lane Rural & Urban templates.  


25) Set the following Dynamic Settings:

[image: ]


26) In Create Template go to Tools > Options and confirm the following Affixes are set:

[image: ]










27) In Create Template use the following components to modify the Road1 Two Lane Rural & Urban Templates:

End Conditions:

Left Side						Right Side

Special Ditch Profile				Special Ditch Profile


*Notes

a) In the Special Ditch Profile_L component of both templates change the Style Elevation to Special Ditch Left.
b) Save Template Library
c) Close out of Create Template and Corridor Modeler.


28) Store the following 4 Special Ditch Profiles using separate COGO input command for each:

STORE PROfile ROAD1-LT-1
VPI 1 Station 0+50 Elevation 820.20
VPI 2 Station 12+50 Elevation 820.00
END PROFILE

STORE PROfile ROAD1-LT-2
VPI 1 Station 16+00 Elevation 830.00
VPI 2 Station 25+80 Elevation 848.20
END PROFILE

STORE PROfile ROAD1-RT-1
VPI 1 Station 0+00 Elevation 821.00
VPI 2 Station 11+00 Elevation 818.37
END PROFILE

STORE PROfile ROAD1-RT-2
VPI 1 Station 31+30 Elevation 851.50
VPI 2 Station 35+10 Elevation 855.06
END PROFILE







29) In order to target multiple profiles using a single style elevation the User will need to create a chain that incorporates the station range of the special ditch profiles.  In this case we will offset (offset=0) the Road 1 baseline chain to create the reference chains for the left and right side of the roadway.

[image: ]

[image: ]












30) Back in Corridor modeling import the following Chain and Profiles:

Chain			Profiles				Drafting Standard
LT-DITCH-REF		ROAD1-LT-1, ROAD1-LT-2		Special_Ditch_Left
RT-DITCH-REF		ROAD1-RT-1, ROAD1-RT-2	Special_Ditch_Right


[image: ]


31) Open Roadway Designer (J2P0203.ird) and verify the active corridor is the Road1 corridor.  Next navigate to the template drop dialog (Corridor > Template Drops).

[bookmark: _GoBack]Update the Template Drops by selecting the drops first and then selecting “Synchronize with Library”

[image: ]

Close the Template Drop Dialog






32) Back in Roadway Designer review the section with the special ditch profiles

[image: ]

One thing you will notice very quickly is that it is very hard to visually determine if the Special Ditch is properly drawing.  To help with this we are going to make some addition changes to the Special Ditch Profile End Condition.


33) Open the Template Library from within Roadway Designer by selecting the last icon across the top.

[image: ]














34) Navigate to the J2P0203 > End Conditions folder and double click on the End Condition called “Special Ditch Profile” to make it active.

 [image: ]


35) Make active the Dynamic Setting dialog with a step increment set to 0.01 or greater.

The first thing we are going to add to the end condition is a Special Ditch point. 
 
Right Click and select Add New Component > Null Point and place a point called “Special_Ditch” just above the Flat Bottom Ditch.
[image: ]
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36) Within the Special_Ditch Point Properties modify the following constraints:
[image: ]
Constraint 1 
Type:	Vector-Offset
Parent 1:	Dtch_Frslp_1_B
Parent 2:	Dtch_Bkslp_1_B
Value:	0.0000


[image: ]
Constraint 2 
Type:	Horizontal
Parent 1:	Dtch_Frslp_1_B
Value:	4.0000



To make sure that the Special_Ditch point is always in the middle of the flat bottom ditch we are going to introduce a Value Equation by clicking on the “=” sign just to the right of the horizontal value of 4.

Equation:		=_$(Dtch_Frslp_1_B)-$(Dtch_Bkslp_1_B)*-0.500
Type:		Horizontal Difference
Parent 1:		Dtch_Frslp_1_B
Parent 2:		Dtch_Bkslp_1_B
Multiplier:		-0.5
[image: ]









Now that we have added this point it will show up in all Cross Section where a special ditch is present.








37) Next navigate to the J2P0203/Road1 folder and remove the End Conditions in the Road1 Two Lane Rural & Urban templates.  


38) Set the following Dynamic Settings:

[image: ]


39) In Create Template go to Tools > Options and confirm the following Affixes are set:

[image: ]










40) In Create Template use the following components to modify the Road1 Two Lane Rural & Urban Templates:

End Conditions:

Left Side						Right Side

Special Ditch Profile				Special Ditch Profile


*Notes

d) In the Special Ditch Profile_L component of both templates change the Style Elevation to Special Ditch Left.
e) Save and close the Template Library


41) Open Roadway Designer (J2P0203.ird) and verify the active corridor is the Road1 corridor.  Next navigate to the template drop dialog (Corridor > Template Drops).

Update the Template Drops by selecting the drops first and then selecting “Synchronize with Library”

[image: ]

Close the Template Drop Dialog













42) Back in Roadway Designer review the section with the special ditch profiles

[image: ]

When a special ditch profile is applied a point will be place at the Chain and Profile location.  Therefore with this project the User should see a point at the mid point of our template when a special ditch profile is active for a particular station.




19-18	Missouri Department of Transportation	2/14/13
2/14/13	Missouri Department of Transportation	19-19
image6.png
=1l

Projects Directory  Admin

[ CADD\Design\Randolph\J2P0203\project.
Fitter: [~ prj Type: Project |
Directories: <
[-1
[projdbs]
i1 |
D1
]
(51 =l
Job Number: 203 Unit System: English

e
[Road 3 Special Ditch

La]  [e==]





image7.png




image8.emf



image9.png
2] Cortidor Modeling - pw:\District CADD\Design\Randol

Fle Tools

=1l

sob: [205 Q| e 47 N2

O Preferences
=l

O Geometry

3 Plan Graphics
DI ALG Viewer

Preferences

Station Lock: _Increment ¥

Slope Readout
Horizontal Chord Height
Vertical Chord Height
Template Library:

DTM Files Path:

[50% 3|
0.100000
0.050000

pwiDistrict CADD\Design\Randolph\J2P0203\data\J2P0203 ITL.

pwi\District CADD\Design\Randolph\J2P0203\data\

Q
Q





image10.png
X Create Template

Ble Edt add Tools
Template Library:

= Fill (4:1) Cut (3:1)
= Slopes (6:1)

B Special Ditch Profile
ROAD1

ROUTES3

Templates





image11.png
Current Component

Name: [Special Ditch Profie Style: [Xs_Ground_Proposed
Target Type: [Style Elevation Priority: [1
Style v [Special_Ditch_Right [ Benching Count [0

I~ | FromBaturn: [0.0000

StepElevation  [0,0000

Ofsets: |—|—R«-mgtem I





image12.png
x [93900
Y. [s1100
PointName:
Point Style:

I Apply Afixes

= =

Step: [0.0100
Step: [0.0100

Dch Frslp 1T +]

[xs_Ground_Propo v ]

C—

T ——





image13.png
X [287300

Y. |659%00

Step: [0.0100

Step: [0.0100

[7 Checkfor Interception

[7 Place Pointatlnterception

[¥ End Condition is Infnite:

I~ Do NotConstruct

PointName:

Point Style:

I~ Apply Afixes

Dtch Frslp_ 18 =

hs= -

[xs_Ground_Propo v ]

[20-16

‘SetDynamic Origin





image14.png
‘Current Component:

Name: [Fiat Bottom Ditch Style: xS Ground_Proposed
Target Type: [Surface x| Priority: 1
Surface. ~][<Active> [~ Benching Count [0

= FromBatur: [00000

StepElevation  [0,0000

Offsets: ,—,—Rﬂlﬂalﬂm oo |





image15.png




image16.png
[~ Checkfor Interception

oot00
oot00

¥ | Place Pait et itereeption

[~ End Condition s Infinite

I~ Do NotConstruct

PointName: Dtch_Bkslp_1.8 v

Point Style: XS_Ground_Propo v |





image17.png
X [o2400

v: |00400

Step: [0.0100

Step: [0.0100

[7 Checkfor Interception

[7 Place Pointatlnterception

[¥ End Condition is Infnite:

I~ Do NotConstruct

PointName:

Point Style:

I~ Apply Afixes

[Dch Bkslp_1 T |+

hs= -

[xs_Ground_Propo v ]

[525%

‘SetDynamic Origin





image18.png
99529 Step:
19685 Step:

oot00

oot00

PointName:

PointStyle:
I Apply Afixes

Barrier_Type_A 617





image19.png
RDLinkATRD

WARNING: This template has End Conditon Priority conficts. Use
the "Check Priorties” button to view and fix.

=





image20.emf



image21.png
Edit

Close

Help





image22.png
Priority  End Condition Component

[i ‘Special Ditch Profle.





image23.png
Priority End Condiion Component

[i ‘Special Ditch Profile

g Fill Slope





image24.png
131500 Step:
18400 Step:

oot00

oot00

PointName:

PointStyle:
[¥" Apply Afixes

Barrier_Type_A 617





image25.png
0K
@ FromStyle Cancel
 Specify: Preferences...
Point Seed Name: = Help
IV Apply Afixes.
Prefix Suffx
Left T
Right R
~Step Options
X [oo100 Y: ooi00 Slope: [0.00%





image26.png
Store Offset Chal

Chain Name:

Offset

Begin Point

Begin Curve:
Reference Chain

Chain Name:

1| Begin Station:

End Station

100

€100

ROAD1
0%00.00

35+10,08)

Store Chai





image27.png
Reference Chain
Chain Name:

1| Begin Station:
End Station

ROAD1
0%00.00
35+10,08)

Store Chai





image28.png
]} Corridor Modeling - pw:\District CADD\Design P =1 JE3 |
e Toos
sob: [205 o | Al 2 5
0 Preferences Chain Profile Drafting Standard
=) ROADT ROAD1EX,ROADTPR MoDOT_Baseline_Proposed a
0 Geomery RTEG3 RTEG3EX RTE63PR MoDOT_Baseline_Proposed
1 Plan Graphics LT-DITCH-REF  ROADI-LT-1LROAD1-LT-2  Special_Ditch_Left
01 ALG Viewer RT-DITCH-REF  ROADI-RT-1,ROAD1-RT-2  Special_Ditch_Right x

Chain: [RT-DITCH-REF K

Drafting Standard: [Special_Ditch_Right =

Import

[ROADTEX
ROADIPR





image29.png
Current Template Drops:

Station | Interval [ Template Enable Transition | Revised In

040000 500000 101 wo e Uiban NJA pw\ghpwise10:MoDOT\Dol
252900 500000 12071 Two Lane Uban

Library

pw\ghpwise10:MoDOT\Dol
2543000 500000 20: v Lone sl X pwl\ghpwise10:MoDOT\Do]

<

Synchronize with Library

Delete





image30.emf



image31.png
Fle Corridor Superelevation Tools Overlay Tools

HEz A8 g Ao




image32.png
00000 step: o0 |
00000 step: o0 |
Point Name: [Special Ditch |

Point Style: Barrier_Type_A 61|





image33.png
200000 Step: [o0100

33333 step: o100

PointName:  [Special Dich v

Barier_Type_A 617





image34.png
Type:
Parent1:

Value:

Constraint 1

[VectorOfset

Dich_Frslp_1 B

Dich_Bkslp_1_B

[o.0000

None.





image35.png
Type:
Parent1:

Value:

Constraint 1 Constraint2
[Vector-Offset Horizontal
Dich_Frslp_1_B Dich_Frslp_1_B
Dich_Bkslp_1_B.

|0.0000 [4.0000





image36.png
Value Equation

-_$(Dtch_Frslp_1_B)-$(0tch Bkslp, = [4 oK
Horizontal Difference e
Dich_Frsip_1_B S|

1_Frslp_1_¢ Help
Dich_Bkslp_1_8 |

Muttipler: 05





