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Overview:

There is more to Templates than simple components and end conditions. You can use parametric constraints, layered components, point testing and display rules. Our goal in this exercise is to collect a series of capabilities that provide milling, leveling, overlay, widening, curb & gutter along with retaining walls when cut/fill slopes are inadequate. All of these components are defined in this single template.
	
Display Rules - Establish relationships between items in the template. If conditions are true or false then components can appear or not be placed into the design. Experience shows this to be a powerful tool however overuse can lead to insanity.

Parametric Constraints - These are named variables that can be used to set new values for a defined station range. This capability extends the usefulness of your template libraries across a wide range of projects.

Activities for the resurfacing and widening on the 3 lane roadway

•	Review the template
•	Create wearing component 2” thick
•	Widen left and right from existing edge of pavement to 18’
•	Add milling component for cross slope
•	Add leveling component for additional cross slope as needed
•	Add curbing and sidewalk on both sides
•	Define cut and fill within limits
•	Retaining walls where limits are exceeded
•	Use of Parametric Constraints for design changes

This exercise will guide you through the steps to get started:

1) Project files are in pw:\District CADD\Design\Randolph\J5P0001\


2) Open Plan.dgn.


3) Open Applications > GEOPAK > Corridor Modeling.


4) Select the GPK job number 001




5) Choose File > Load from the Corridor Modeling dialog.


6) Load the Corridor Modeler project called J5P0001.rdp


7) Select Open Create Template.
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Lesson Objective:

There is a completed template in the library that you are going to look at to familiarize yourself with the finished product of this exercise.
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Procedure:

  This exercise provides information on the finished template.

1) Go to Templates folder and select “3 Lane CG widening” and make it active by double-clicking the name.


2) 	Use Test to see the cut/fill and milling and overlay results. 


3) Close Test and right-click on LT_WideningControl, select Test Point Controls > Test Horizontal Point Control and then move the point left and right to see what happens to widening.


4) Do the same action with RT_WideningControl. Notice what happens to the Sub-base when the control reaches the curb line. We will talk about that later.
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Lesson Objective:

In this set of steps you will create a template and the first component.

Procedure:

This exercise provides information on creating a named template and the first component.

1) Right-click on the folder Templates. Select New > Template from menu.


2) Similar to Windows Explorer you can enter in a new name, CG widening, to replace the default name of New Template.


3) Right-click on the new template name to Set Active.


4) Toggle on the Dynamic Settings from the strip menu at the bottom and set Steps for XY to 0.1. This is to make it easier for you to select the 0,0 point which is the only precision placement we will make.  From the Tools>Options menu, change the Prefix values to LT_ and RT_ respectively, then, toggle on the ‘Apply Affixes’ box.


5) From the Components>Pavement>Concrete folder, select the ‘Pavement Surface Concrete’ component, and, holding down the left mouse button drag the component onto the drawing area without releasing the cursor button.  Once on the drawing area depress the right mouse button to open a menu and select Mirror. Now you have two opposite components that will move equidistant from 0,0.  Move the cursor to the Current Template window origin, 0,0 until the point turns bold white. That means you have snapped to the point and when you release the left mouse button the points will be merged when the components are placed.

6) Now, right click on the vertical line between the two components and select ‘Merge Components’.


7) Next edit the ‘RT_Pvmt_Surf_Conc_T1’ and ‘RT_Pvmt_Surf_Conc_T1’ points to each have a horizontal constraint value of 18.0’.





8) Now, select the active template tab, expand the Parametric Constraints folder, change the ‘Pvmt_Surf_Conc_Depth’ to -2” by right clicking on the name and selecting ‘Edit’.


9) Expand the Components folder and rename the component from ‘RT_Pavement Surface Concrete’ to ‘Pavement Surface Concrete’.



10) Last, switch back to the Library tab and save your template library with a Ctrl-S or go to File > Save.
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Lesson Objective:

You will now define additional Base asphalt for widening outside of the existing pavement. This will be a component on both sides of the roadway attached to the XLEP and XREP points.

Procedure:

This exercise will guide you through the creation of the base widening component.

1) From the Components>Pavement>Concrete folder, left click once on the ‘Pavement Layer 1 Concrete’ component.  In the preview window below, left click once on the top right point to redefine the insertion point of the component.  Now, drag and drop the component onto the bottom outer pavement edge point with the Mirror option enabled.  We will add constraints to the two unconstrained points later.

Now we will add four Null Points to the template to control widening maximum and minimum limits.


2) Right click in the Current template window, select Add New Component>Null Point.  Place the first point above the left edge of pavement.  Rename the point ‘LT_MaximumWidth’ and apply the ‘DNC’ style.  Repeat this step for the right side of the road and name the second point ‘RT_MaximumWidth’ and apply the ‘DNC’ style.


3) Right click in the Current template window, select Add New Component>Null Point.  Place the third point above the left inside base widening edge (somewhere above the pavement surface).  Rename the point ‘LT_WideningControl’ and apply the ‘DNC’ style.  Repeat this step for the right side and name the fourth point ‘RT_ WideningControl’ and apply the ‘DNC’ style.

Now we will apply additional constraints to the four newly created points.


4) Right click on the left edge of pavement point ‘LT_Pvmt_Surf_Conc_T1’and change the horizontal constraint parent point to be the ‘LT_ MaximumWidth’ point with a value of 0.0.  Now, add a full constraint: horizontal constraint of -18.0’ and a vertical constraint of 1.5’ with the parent point being ‘Pvmt_Surf_Conc_T’.  Repeat the steps for the right edge of pavement point.  The ‘RT_ MaximumWidth’ point will have a horizontal constraint of 18.0’ and a vertical constraint of 1.5’.



5) Right click on the ‘LT_WideningControl’ point and add a full constraint: Horizontal constraint of -8.0’ and a Vertical constraint of 1.0’ with the parent point being ‘Pvmt_Surf_Conc_T’. Repeat the steps for the ‘LT_WideningControl’ point.  Add a Horizontal constraint of 8.0’ and a Vertical constraint of 1.0’ with the parent point being ‘Pvmt_Surf_Conc_T’.

Now we will apply constraints to the inner top base widening points.


6) Right click on the ‘LT_Pvmt_Layer_1_Conc_T’ and select Add Constraint>Vector Offset.  Use the ‘LT_Pvmt_Surf_Conc_B1’ point and ‘Pvmt_Surf_Conc_B’ point as the two parent points and apply a 0.0 offset value. The second constraint will be a Horizontal Maximum constraint.  Right click the ‘LT_Pvmt_Layer_1_Conc_T’ point again and select Add Constraint>Horizontal Maximum.  Pick the parent points to be  ‘LT_WideningControl’ and ‘LT_ MaximumWidth’.


7) Right click on the ‘RT_Pvmt_Layer_1_Conc_T’ and select Add Constraint>Vector Offset.  Use the ‘RT_Pvmt_Surf_Conc_B1’ point and ‘Pvmt_Surf_Conc_B’ point as the two parent points and apply a 0.0 offset value. The second constraint will be a Horizontal Minimum constraint.  Right click the ‘RT_Pvmt_Layer_1_Conc_T’ point again and select Add Constraint>Horizontal Minimum.  Pick the parent points to be  ‘RT_WideningControl’ and ‘RT_ MaximumWidth’.

Now test the Null Points.


8) Now test the ‘LT_WideningControl’ point by right-clicking on it and choosing Test Point Controls > Test Horizontal Point Control. As you move the point side to side you will see the ‘LT_Pvmt_Layer_1_Conc_T’ point moved and also change the width of the milling. Verify that it does not exceed the ‘RT_Pvmt_Surf_Conc_T11’ point.  Do the same with the ‘RT_WideningControl’ to insure it works. These control points will be used in conjunction with point controls and have a part in Display Rules later.


9) Save your template library with a Ctrl-S or go to File > Save.
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Lesson Objective:

Your next step is to add the milling component. You want it to plane the existing asphalt off at the slope of the new designed wearing surface. This requires that we place it on the bottom of the wearing component. You will also establish a control for left and right as null points and constrain the edges of existing to them.

Procedure:

This exercise provides information on creating a named template and the first component.

This exercise will guide you through the steps to define the milling component and test.

1) From the Components>Pavement>Overlay folder, select the ‘Milling’ component and with the mirroring option toggled off, drag and drop the component to a location under the pavement surface component in the Current Template window.  We will add, edit, and relocate points for this component.


2) Right click on the milling component and select add point.  Place the point somewhere between the left and right points. Right click and select Finish.


3) Be sure that all of the points on the milling component are unconstrained.  Right click and move each point to each bottom point of the wearing course, or, bottom of pavement inside the base widening.  After the points have been moved to the bottom of the pavement, merge each of the three points keeping the pavement points as the original placed points.


4) Now test the template.  Click on the Test button below the Current Template window.  Select Draw with the active surface highlighted and watch the milling component expand and contract from the spine of the Overlay/Stripping component. Close the Test dialog.


5) Go to the Active Template tab and edit the name of the Milling component you just created.  The name should simply be ‘Milling’.


6) Save your template library with a Ctrl-S or go to File > Save.
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Lesson Objective:

Leveling components are the reverse of milling. You are adding material to an existing surface to correct slopes. Where the milling might not get all of a rut out the leveling adds material. Another use is correcting superelevation.

Procedure:

This exercise will guide you through definition of the leveling component.

1) From the Components>Pavement>Overlay folder, select the ‘Leveling’ component and with the mirroring option toggled off, drag and drop the component to a location under the pavement surface component in the Current Template window.  We will add, edit, and relocate points for this component.


2) Right click on the leveling component and select add point.  Place the point somewhere between the left and right points. Right click and select Finish.


3) Be sure that all of the points on the leveling component are unconstrained.  Right click and move each point to each bottom point of the wearing course, or, bottom of pavement inside the base widening.  After the points have been moved to the bottom of the pavement, merge each of the three points keeping the pavement points as the original placed points.


4) Now test the template.  Click on the Test button below the Current Template window.  Select Draw with the active surface highlighted and see the leveling component expand and contract from the spine of the Overlay/Stripping component – just the opposite of the milling component. Close the Test dialog.


5) Go to the Active Template tab and edit the name of the leveling component you just created.  The name should simply be ‘Leveling’.


6) Save your template library with a Ctrl-S or go to File > Save.
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Lesson Objective:

Build rules to display or not display widening components.

Procedure:

This exercise will guide you through the steps to create display rules.

1) Right-click on the ‘LT_Pavement Layer 1 Concrete’ component and select Edit.


2) On the dialog select the Edit button for Display Rules.


3) The Component Display Conditional Expression dialog appears. This looks imposing but it is quite simple.  At the bottom select Add and you will create an expression.


4) In the Display Rule dialog, 

Name=LeftWideningControl
Description=Pavement Widening Rule
Type=Horizontal
Between=LT_WideningControl
And=’ LT_MaximumWidth’, >, 0.000

Then select OK. This creates a rule where we are testing to see if the distance between the left edge of pavement and the left widening control is greater than zero.


5) Now select the LeftWideningControl rule and then the Selected Rule button above. This adds the rule to the selected base component. Then click on the “=” button so that True appears in the next field.  Select OK, the dialog returns to Edit Component Properties with the LeftWideningControl Rule shown. Select Apply and then Close.


6) Test the rule you created by right-clicking the LT_WideningControl point and selecting Test Point Controls > Test Horizontal Point Control. Move the point left and right.

Notice that the component disappears when the LT_WideningControl point is over or to the left of the left edge of pavement point.



7) Now do the same procedure on the right side of the template for the ‘RT_Pavement Layer 1 Concrete’ component except we are once again in an opposite hand to the left side so we are going to test that the condition is less than (<). Another twist to this is for the condition to be set to (<=). This will show the component if the control is on top of the right edge of pavement point. We will use this in a later exercise. Test your work after exiting Component Properties.

8.	Save your template library with a Ctrl-S or go to File > Save.
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Lesson Objective:

You can add pre-prepared components from the template library. This is a quick exercise to show you how to use the drag and drop with Mirroring to speed the process.

Procedure:

This exercise will guide you through the steps to add component to the template.

1) Open the Components folder in the template library.  Then go to the Curb and/or Gutter folder and select the ‘Curb and Gutter Type A - 609-10.51‘ component.  Drag and drop the component, with mirroring enabled, onto the right edge of pavement point until the point turns bold white. That means you have snapped to the point and when you release the left mouse button the points will be merged when the components are placed.


2) Go back to the Components>Sidewalk folder and drag and drop the Sidewalk Surface component out onto the drawing area. This component is already mirrored because the option is on until you change it. Hover over the top back of curb on the right side until you see the point become bold white and then release the component. 


3) Notice the slope of the sidewalk components.  We would like to change the slope of each surface to slope towards the road.  Select the Active Template tab.  Expand the Parametric Constraints folder.  Right click on the ‘Swlk_Surf_Slope’ label.  Change the value to 2.00%.


4) Expand the Components folder and observe the names of the components.  Later we will revisit this folder to rename and edit component relationships.


5) Left click on the Library tab and save your template library with a Ctrl-S or go to File > Save.










[bookmark: _Toc335825822]Section 9 – Sub Base Components:
Lesson Objective:

You will use another component for the Sub Base under the base widening and curb components.  Additional points will be added to the ‘Undergrading Excavation’ component to alter its simple rectangular shape.

Procedure:

This exercise will guide you through the steps to drag and drop and modify the subbase.

1) Open the Components folder in the template library.  Go to the Base folder and select the ‘Undergrading Excavation’ component.  Drag and drop the component, with mirroring enabled, onto the lowest inside point of the base widening component on the right side of the road until the point turns bold white so that the points will be merged when the components are placed.


2) We will now edit the top outside Undergrading Excavation points to be horizontally aligned with the back bottom of the curb and gutter.  Focusing on the right side of the template, right click on the ‘RT_Undrgrd_Excavate_T1’ point and change the horizontal constraint to use the bottom back of curb point ‘RT_Curb_Subsurf_Back’ as the parent with a horizontal constraint value of 0.0.


3) Now, edit the two outer subbase points ‘RT_Undrgrd_Excavate_T1’ and ‘RT_Undrgrd_Excavate_B1’.  Right click each point and select Delete Both Constraints.

We will now add additional points to tie the subbase to the base component above.
















4) Zoom in to the area surrounding the right curb and gutter.  Right-click on the line between the ’RT_Pvmt_Layer_1_Conc_B1’ and ‘RT_Undrgrd_Excavate_T1’ points (just below the curb and gutter).  Select Insert Point and place the first point on top of the ’RT_Pvmt_Layer_1_Conc_B1’ point.  Place the next point on top of the ’RT_Curb_Subsurf_Edge’ point, then the next ‘RT_Curb_Subsurf’, the next ‘RT_Curb_Subsurf_Back’, and place the last point on top of ‘RT_Swlk_Surf_B’.  

Right click and select Finish.

Next, points that were just added will need to be constrained.  We will do this by merging them to the points that were already present with the exception of two base points. 


5) One by one, right click on the points that were just added and select Merge Points. When prompted, delete the point automatically named (it will have a prefix RT_ and number).  There are a total of five points that should be merged.


6) Next, right click on the ‘RT_Undrgrd_Excavate_B1’ point and Add Constraint>Vector-Offset.  Select the two parent points ‘RT_Pvmt_Layer_1_Conc_B’ and ‘RT_Pvmt_Layer_1_Conc_B1’ (the bottom two base widening points) and set the offset value to 0.50.  Right click the ‘RT_Undrgrd_Excavate_B1’ point again and select Add Constraint>Horizontal Constraint, then click on the ‘RT_Curb_Subsurf_Back’ point  and set the value to 0.0.

There should be one remaining point that is unconstrained directly above the outside bottom Undergrading Excavation component, ‘RT_Undrgrd_Excavate_T1’.


7) Right click on the ‘RT_Undrgrd_Excavate_T1’ and select select Add Constraint>Slope, then left click on the ‘RT_Undrgrd_Excavate_B1’ point and set the value to 100.0%.  Right click on the ‘RT_Undrgrd_Excavate_T1’ point again and add Constraint>Vector-Offset.  Select the two parent points ‘RT_Swlk_Surf_B’ and ‘RT_Swlk_Surf_B1’ (the bottom two sidewalk points) and set the offset value to 0.0.


8) Test the component.  Zoom out to get a broader view of the template.  Right-clicking the right edge of pavement point (RT_Pvmt_Surf_Conc_T1) and selecting Test Point Controls > Test All. Move the point left, right, up, and down. The component should behave as expected maintaining the base widening slope and 100% slope tie beneath the sidewalk.  Did you notice the base disappears but not the subbase?  We will fix this in the last step…




9) Double click on the subbase component, click the target button beside the Parent Component field, and then select the base component directly above the subbase.  This establishes the parent child relationship for the base and subbase components.  


10)  Save your template library with a Ctrl-S or go to File > Save.

This entire process must be repeated on the left side of the road. Start at step number 2 and follow the steps.  
 

NOTE:  Another technique is to manually create the component and allow the mirroring function to draw both sides of the template at once.  There are possible advantages and disadvantages to any technique you choose.  Results by trial and error may ultimately help you choose your preferred method.
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Lesson Objective:

You will place and test end conditions for cut/fill and a retaining wall.

1) Open Tools > Options to display the Template Options dialog.

Toggle on Apply Affixes and delete the Suffixes and create Prefixes of LT_ and RT_.

Close the dialog.


2) Open the End Conditions folder in the template library and expand the Ditches folder.


3) Select the ‘Ditch Back Slope 1 (4:1)’ end condition and drag it to the back of the right sidewalk.  Before release the mouse button and placing the end condition on the ‘RT_Swlk_Surf_T1’ point, right-click and turn off Mirror and attach it to the sidewalk.


4) Do the same operation and add the ‘Ditch Back Slope 1 (4:1)’ end condition to the left, using the Reflect option in the right-click menu.


5)	Now, expand the Fill Slopes folder, select the ‘Fill Slope1 (4:1)’ end condition, drag it to the back of the right sidewalk point using the Mirror option in the right-click menu.


6)	There is an end condition and component combined named ‘Retaining Wall Case X - use existing ground cut and fill’ in the Templates folder.  Drag and drop this template to the back of the right on the ‘RT_Swlk_Surf_T1’ point using the Mirror option in the right-click menu.


7)	Now that all end conditions have been placed, test the template by clicking on the Test button on the lower right portion of the dialog.


8)	A Warning Message should appear indicating that there are priority conflicts.  Click OK and select the Check Priorities button in the upper left portion of the Test dialog.





9)	Highlight the RT_Swlk_Surf_T1 point in the End Condition Properties dialog and click Edit.


10)  Open the Test screen and try different combinations.


11) Adjust the value of the priorities for each end condition in the order in which they should be evaluated.  The lowest numbered end condition gets evaluated first.  If there is no solution the next numbered end condition is evaluated, then the next, and so on…


12) Fix the values for the left and right side of the template.  Click Draw and test the template against the <Active> Surface.  Notice the Wall does not solve.  We need to fix the properties of a few end condition points for this to be fixed.


13) Close the Test dialog and return to the Current Template window.

We must edit four points on the Cut and Fill end conditions.  We need to change the point properties and turn off End Condition is Infinite.


14) Double click on the ‘LT_Dtch_Bkslp_1_T’ point and toggle off End Condition is Infinite, then click Apply.  Change the Horizontal Constraint to Vertical and change the value to positive 3.00 for Cut (negative 3.00 for Fill points).  Repeat this step for the following points,  ‘LT_Fill_Slope_1_B’, ‘RT_Dtch_Bkslp_1_T ‘, and ‘RT_Fill_Slope_1_B’.  This forces each of those the End Conditions to only draw at 4:1 for a cut or fill depth of 3’.  Anything above or below 3’ will be substituted with a Retaining Wall.


14) Now, Return to the Test screen and try different combinations.


15) Save your template library with a Ctrl-S or go to File > Save.


16) Now close the Create Template dialog.
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Lesson Objective:

We will modify a corridor with the template and review the results. We will need to create controls for the right and left sides

Procedure:

This exercise will guide you through the steps to create and modify a corridor in Roadway Designer. We are going to copy an existing Corridor, rename it, replace the template with our “CG Widening” template and apply the point controls.

1)  Turn off the Topo.dgn reference file display.

There are Plan Graphics that have been imported using Corridor Modeler.  We will use these imported graphics as controlling alignments for specific points in our template.


2)	Access Roadway Designer from the Corridor Modeler dialog and open J2P0001.ird.


3)	Open the Manage Corridors dialog, highlight the 3 Lane CG widening Corridor, click Copy, and enter in the name ‘9WPROPCL’ for the new Corridor name.


4)	Highlight the newly created Corridor and click close on the dialog.  You will see the name show up in the bottom left of the Roadway Designer dialog as the active corridor.


5)	Open the Template Drops dialog and replace the ‘3 Lane CG widening’ template drops with the ‘CG Widening’ template by highlighting each row, selecting the template from the list, then clicking change on the right side of the dialog.  There are 3 changes to make.













5) Now select Display References and add four alignments to your Plan and Cross Section Roadway Designer view.  Select the Alignment Name from the drop down list, toggle on the Display as Right of Way option, then click Add.  Do this for the following Alignments: 

ExistingLeftEOP		ExistingRightEOP
ProposedLeftEOP		ProposedRightEOP.

Violet colored lines will show up in your views to use as viewing reference.

7)	Navigate to ahead and back along the Corridor to observe the sections.


8)	Go to Tools>Options and enable Null Point display.  Click OK on the dialog and notice the Null Points appear in the Cross Section view.


9)	We will now apply point controls to the four Null Points we added to our template earlier. ‘LT_MaximumWidth’ and ‘RT_MaximumWidth’ are the points we will control with our previously imported proposed edge of pavement.  ‘LT_WideningControl’ and ‘RT_ WideningControl’ are the points we will control with our previously imported existing edges of pavement.


10)	Open the Point Controls dialog.  Select each of the points individually and associate each one of them to their respective controlling alignments.
Point=LT_WideningControl -> Alignment=ExistingLeftEOP
Point=RT_WideningControl -> Alignment=ExistingRightEOP
Point=LT_ MaximumWidth -> Alignment=ProposedLeftEOP
Point=RT_ MaximumWidth -> Alignment=ProposedRightEOP


11)	Navigate to ahead and back along the Corridor to observe the sections.


12)	Click File then Save.

We will now open a 3D design file to draw in our proposed model at the same time when the proposed .DTM and .TIN are created.
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13)	Open the dtm.dgn from the pw:\District CADD\Design\Randolph\J5P0001\data\ folder.


14)	From Roadway Designer, select the Corridor > Create Surfaces option.


15)	Type in ‘9WPROPCL’ for the Name at the top of the dialog. Highlight the ‘9WPROPCL’ Corridor in the ‘Create Surface(s) from’ list.  In the lower left portion of the dialog, toggle on ‘Components’ for the Display in Plan View option.


16)	Click Apply.


17)	Close all of the dialogs and save files as needed.  Do not close MicroStation.


18) Take a closer look at your 3D model...  Also, be sure to take a look at your working directory and review what files were created.
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