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Earthwork Exercise 
 

1. Open the Microstation file t:\de-proj\cole\J5U0441G\data\XS_EARTHWORK_Run#1.dgn 

 

2. In the project J5P0441G.prj, select the working alignment Run#1. 

 

3. Select the Proposed Cross Sections button from the Project Manager dialog.  Copy the 
MoDOT run to Run#1, and enter the run. 

 

4. Setup the Shape Clusters as follows. 
 
 Criteria for Shape Cluster 
   shape cluster baseline  = RTE179 
   shape cluster profile   = RTE179PR 
   shape cluster tie       = 0.000 
    side slope LTRT 
        include t:\gpk_std\criteria\setup.x 
        include t:\gpk_std\criteria\pvmt_layers.x 
        include t:\gpk_std\criteria\shldr_a2_a.x 
        include t:\gpk_std\criteria\sideslope_rock_transition.x 

 

5. In the Define Variables set the following values for the given variables: 
 
"NAME OF PLAN FILE"      RTE179_PLAN.dgn 
"NAME OF CROSS-SECTION FILE"     XS_EARTHWORK_RUN#1.dgn 
"NAME OF SHAPE/PATTERN FILE"     RTE179_pattern_shape.dgn 
"NAME OF BASELINE"      RTE179 
"PAVEMENT LAYER 1 THICKNESS (MM OR IN)"   10.75 
"ROCK FILL BASE THICKNESS (M OR FT)"    2 
"SHOULDER LAYER 1 THICKNESS (MM OR IN)"  10.75 
"SHOULDER LAYER 2 THICKNESS (MM OR IN)"  0.00 
"SHOULDER LAYER 3 THICKNESS (MM OR IN)"  0.00 
"FILL SLOPE 2 (1:X OR X:1)"     3 
"FILL SLOPE 2 PROFILE LEFT"    FILLSLOPE 
"FILL SLOPE 2 PROFILE RIGHT"    FILLSLOPE 
"FILL SLOPE 1 WIDTH (M OF FT)"    20 

 

6. Process the cross sections. 

 

7. From Project Manager select Earthwork. Copy the MoDOT run to RUN#1 & enter the 
run. 
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8. In the XS DGN File section adjust the tolerance to 0.10000 

 

9. In the Soil Types section of the dialog, create the following classifications and soil types 
with the given parameters: 

 
Class    Soil Type Search Criteria          Excavation Multi-Factor
Existing Ground   ClassA  Level = 57   0.87000 

Color = 90 
Proposed Undercut  Rockbase Level = 46   0.87000 

Color = 71 
Proposed Finish Grade  ClassA  Level = 18,20, 24, 33  0.87000 

Color = 0, 4, 35,60-63 

 

10. Change the Output Format to: 
 

Excavation 
Fill 

 

11. In the Add/Subtract Volume section of the dialog, add the following Add Volumes: 
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12. In the Skip Area section of the dialog, skip the following section: 
 

 

 

13. Process the earthwork. 
 
Set the Log File setting to Log File and name the log file Earthwork Run #1.log  

 

14. Earthwork log file reports shortage of 48,929 cu yards of material 
 
At this point you would go in and tweak your chain and more likely the profile until you get a 
closer earthwork  balance.  But for this exercise we’re going to continue on. 

 

15. Save the MicroStation file XS_Earthwork_Run#1.dgn 

 
The Soil Survey Report has just Arrived. 

 

16. Next do a Save As and save the drawing as XS_Earthwork_Run#2.dgn 
 
Do a MicroStation Edit > Select All and then select the Delete icon. 

 

17. In Microsoft Excel, open the file Borehole_Location.xls.  Save this file as a CSV (comma 
delimited) file.  Rename Borehole_Location.csv to Borehole_Location.brh. 

 

18. In Microsoft Excel, open the file Borehole_Material.xls.  Save this file as a CSV (comma 
delimited) file.  Rename Borehole_Material.csv to Borehole_Material.mtl. 
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19. Choose the Geotechnical Tools from the menu or from the Geopak Road toolbox.   

 

20. Create a new Geotechnical Data File by choosing File>>New.  Name the file Rte179.gtd 
 

Job  441 
Ground Tin 179 Existing Ground.TIN 
Toggle on Override user provided elevation using tin file. 

 

21. Import the borehole location file boring_location.brh by going to 
File>>Import>>CSV>>Borehole. 

 

22. Import the borehole material file boring_material.mtl by going to 
File>>Import>>CSV>>Material. 

 

23. Verify the material alignment, and adjust if necessary. 

 

24. Create the material tin models as shown. 
 

 
 

25. Open the Microstation file t:\de-proj\cole\J5U0441G\data\Rte179_Pattern_Shape.dgn 

 

26. Select the DTM Tools Icon from the GeoPak Road Tools.  Copy the MoDOT run             
to Rte179, and enter the run. 

 

27. From the DTM Tools select Edit Triangles. 
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28. In the Edit Triangle Display Settings Dialog set the following items: 
 

Triangle Color = 4 (Green) 
Hull Color = 2 (Red) 

 

 
 

29. Use the Delete Line option to Clean up the Rock.tin by removing bogus triangle legs: 
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30. Open the MicroStation file t:\de-proj\cole\J5U0441G\data\XS_EARTHWORK_Run#2.dgn 
 

31. Select the Working Alignment button from the Project Manager dialog.  Copy the Run#1 
run to Run#2, and enter the run.. 

 

32. In the Run#2 working alignment, under the Cross Section View, change the XS DGN file 
to XS_EARTHWORK_Run#2. 

 
Close the working alignment definition box.   

 

33. Select the Existing Ground Cross Sections button from the Project Manager dialog.  
Copy the MoDOT run to Rock, and enter the run. 

 

34. Set up the Draw Cross Section Dialog as Follows: 
 

  
 

Rock.tin symbology  Level=58, Color=8, Weight=2, Style=2 
 
Add the Rock Surface to the following section ranges 
 
Begin Station  End Station 
    62+00      72+00 
    87+00       99+00 
  103+00    109+00 
  116+00    133+00 
  141+00    142+71.63 
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35. Use the MicroStation SmartMatch to match the subsurface layer (Rock) symbologies, and 
draw the subsurface layers to the end of the cross sections. 

 
36. Select the Proposed Cross Sections button from the Project Manager dialog.  Copy the 

MoDOT run to Subsurf, and enter the run. 
 

37. Under the Shapes section, Toggle off “Use Working Alignment Definition”, and set the 
mode to “Shapeless.” 

 

38. Setup the Shape Clusters as follows:  
 

side slope LT 
       include d:\Criteria\subsurf_layers.x 

 
 
 
 

 

39. In the Define Variables set the following values for the given variables: 
 
"DIST. BELOW EX. GRN TO DRAW SUBSURFACE (M OR FT)"  100 
"NAME OF CROSS-SECTION FILE"      XS_Earthwork_Run#2.dgn

 "PLOT TOP OF ROCK LAYER (Y OR N)"     Y  
"PLOT BOTTOM OF ROCK LAYER (Y OR N)"    N 

 
40. Process the cross sections.  Once sections are processed, close down the Proposed XS 

dialog.  Then process the following commands: 
 
         Select Edit > Select All 
         Select Edit > Lock 
    Select Edit > Select None 
         Select File > Save 

 

41. Open the MicroStation file t:\de-proj\cole\J5U0441G\data\XS_Earthwork_Run#X.dgn 
      Save the MicroStation file t:\de-proj\cole\J5U0441G\data\XS_Earthwork_Run#2.dgn 

 
42. Select the Proposed Cross Sections button from the Project Manager dialog.  Copy the 

Run#1 run to Run#2, and enter the run. 
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43. In the Define Variables set the following values for the given variables: 
 
"NAME OF CROSS-SECTION FILE"     XS_Earthwork_Run#2.dgn 
"BENCH WIDTH"       15 
"ROCK WALL HEIGHT (M OR FT)"     30 
 
Process the cross sections. 

 

44. From Project Manager select Earthwork. Copy the Run#1 run to RUN#2 & enter the run. 

 
45. In the Soil Types section of the dialog, create/modify the following classifications and soil 

types with the given parameters: 
 
Class    Soil Type Search Criteria          Excavation Multi-Factor 
Existing Ground   ClassC Level = 57   1.20000 

Color = 90 
Proposed Undercut  ClassC Level = 46   1.20000 

Color = 71 
Existing Suitable Material ClassA Level = 58   0.87000 

Color = 8 
Proposed Finish Grade  ClassA  Level = 18,20, 24, 33  0.87000 

Color = 0, 4, 22,35,60-63 
            

Save Setting and then Process Earthwork Run 
 

46. Earthwork log file reports shortage of 49,602 cu yds of material. 
 
Using the Vertical Alignment Generator, modify the profile Fillslope with the following 
parameters: 
 
       Station      Elevation (Slope value) 
       61+00.00                 3:1 
       86+00.00      3:1 
       87+00.00       2:1 

   143+00.00      2:1 

 

47. Do a MicroStation Edit > Select All and then select the Delete icon.  Then select Save. 

 

48. Select the Proposed Cross Sections button from the Project Manager dialog.  Select 
Run#2, and reprocess the cross sections run. 
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49. Select the Earthwork button from the Project Manager dialog.  Select Run#2, and 
reprocess the Earthwork run 

 
Set the Log File setting to Log File and name the log file Earthwork Run #2.log 

 

50. Save the MicroStation file XS_Earthwork_Run#2.dgn 

 

51. Next do a Save As and save the drawing as XS_Earthwork_Run#3.dgn 

 

52. Do a MicroStation Edit > Select All and then select the Delete icon.  Then select Save. 

 
The Bridge Memorandum has just Arrived. 

 

53. Select the Working Alignment button from the Project Manager dialog.  Copy the Run#2 
run to Run#3, and enter the run.. 

 

54. In the Run#3 working alignment, under the Pattern Section, change the Color to 2. 
 
Also under the Cross Section View, change the XS DGN file to XS_EARTHWORK_Run#3. 
 
Close the working alignment definition box. 

 

55. Open the file t:\de-proj\j5p0441G\data\Rte179_Pattern_Shape.dgn. 

 

56. Select the Draw Pattern button from the Project Manager dialog.  Copy the MoDOT run 
to Run#3, and enter the run. 

 

57. Create pattern lines for the alignment (at Bridge Exception Location). 
 

Job:  441 
Chain:  Rte179 
Beginning     Ending 
 Offset LT: 300    Offset LT: 300   
 Station: 74+34.76   Station: 81+02.94 
 Offset RT: 300    Offset RT: 300 
   
Once (Each)  
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58. Open the file t:\de-proj\j5p0441G\data\ XS_Earthwork_Run#3. 
 
59. Select the Existing Ground Cross Sections button from the Project Manager dialog.  

Enter the Rock run. 
 

60. Set up the Draw Cross Section Dialog as Follows: 
 

  
 

179Existing Ground.tin sybology  Level=57, Color=90, Weight=3, Style=2 
 
Add the Existing Ground Surface to the following section ranges 
 
Begin Station  End Station 
    74+34.76     74+34.76 
    81+02.94     81+02.94 
 
 
   

 

61. Select the Proposed Cross Sections button from the Project Manager dialog.  Enter the 
Subsurf run. 

 
Modify the following Variable: 
 
"NAME OF CROSS-SECTION FILE"    XS_Earthwork_Run#3.dgn 

 

62. Process the cross sections. 
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63. In the Run#3 working alignment, under the Pattern Section, change the Color to 0 and 2. 
 
Close the working alignment definition box. 

 

64. Select the Proposed Cross Sections button from the Project Manager dialog.  Copy the 
Run#2 run to Run#3, and enter the run. 

 

65. In the Define Variables set the following values for the given variables: 
 
"NAME OF CROSS-SECTION FILE"     XS_Earthwork_Run#3.dgn 

 

66. Process the cross sections. 

 

67. From Project Manager select Earthwork. Copy the Run#2 run to Run#3 & enter the run. 

 

68. In the Add/Subtract Volume section of the dialog, modify the following Add Volumes: 
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69. In the Skip Area section of the dialog, skip the following section: 
 

 

 

70. In the Sheet Quant. Section, toggle on the Write Sheet Quantities File. 
 

ASCII file:   Earth.txt 
Decimal Places:   0 
Total Quantity Length 15 

 
Col. Soil Type  EW Operation  Quantity Type  +/- 
1  ClassA   Common Exec  Endarea  + 
1  ClassA   Subgrade Exec Endarea  + 
1  ClassA   Subsoil Exec  Endarea  + 
2  ClassA   Fill   Endarea  + 
3  ClassA   Common Exec  Unadjusted Volumes + 
3  ClassA   Subgrade Exec Unadjusted Volumes + 
3  ClassA   Subsoil Exec  Unadjusted Volumes + 
4  ClassA   Fill   Unadjusted Volumes + 
5  ClassC   Common Exec  Endarea  + 
5  ClassC   Subgrade Exec Endarea  + 
5  ClassC   Subsoil Exec  Endarea  + 
6  ClassC   Common Exec  Unadjusted Volumes + 
6  ClassC   Subgrade Exec Unadjusted Volumes + 
6  ClassC   Subsoil Exec  Unadjusted Volumes + 

 

71. Process the earthwork. 

 
 



 Earthwork Exercise 
 

Rev. 5-24-04 Missouri Department of Transportation 13 

72. Earthwork output Dialog reports surplus of 13,675 cu yds of material. 
 
Using the Vertical Alignment Generator, modify the profile Fillslope with the following 
parameters: 
 
       Station      Elevation (Slope value) 
       61+00.00                 3:1 
     112+00.00      3:1 
     114+00.00       2:1 

   143+00.00      2:1 

 

73. Select Edit > Select By Attributes and select all levels except for 57-61 and 63 and then 
select the Delete icon.  Then select Save. 

 

 
 

74. Select the Proposed Cross Sections button from the Project Manager dialog.  Select 
Run#3, and reprocess the cross sections run. 

 

75. Select the Earthwork button from the Project Manager dialog.  Select Run#3, and 
reprocess the Earthwork run 

 
Set the Log File setting to Log File and name the log file Earthwork Run #3.log 
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76. Save the MicroStation file XS_Earthwork_Run#3.dgn 

 

77. Open D&C Manager, and use the Earthwork Text File Labels 3PC Tool to set up the 
cross section sheet labels as shown below. 

 

 
 

78. Open the Earthworks tool.     
 
Open the MicroStation file T:\de-proj\Cole\J5U0441G\data\Rte179_Mass_Diagram.dgn 
 
Load the file T:\de-proj\Cole\J5U0441G\data\Earthwork.Run #3.log 
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79. Draw the mass diagram with the following settings.  Set the DP X and DP Y by using the 
DP button. 

 
 

 
 

 
 



 Earthwork Exercise 
 

Rev. 5-24-04 Missouri Department of Transportation 16 

80. Calculate the amount of overhaul using the following settings.  Use the same DP as used 
for the mass diagram. 

 

 
 

81. Force a balance point at station 142+71.63. 
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82. Calculate the volumes with the new balance point. 
                                                            Name the output file Earthwork Run #3 Modified.log. 
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