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3.1 Point Constraints 
Templates and components are defined by the points making their shapes. Thus point constraints 
are used to manage the behavior of all template points. The purpose of point constraints is to 
create relationships between the points in a template so that if one point moves, the other points 
follow in a predictable manner. 
 
Each template point has a maximum of two constraints on it.  A template point with two 
constraints is considered “fully constrained” and is represented graphically by a red plus sign on 
the template display. A template point with only one constraint is considered “partially 
constrained” and is represented graphically by a yellow plus sign. A point with no constraints is 
considered “unconstrained” and is shown as a green plus sign. 

3.1.1 Types of Constraints 
There are a total of 11 different types of constraints:  
 
Horizontal - Allows the placement of a new point (or child point) a specified horizontal distance 
from a reference point (or parent point). 
 
Vertical - Allows the placement of a new point (or child point) a specified vertical distance from 
a reference point (or parent point). 
 
Slope - Allows the placement of a new point (or child point) using a specified slope from the 
reference point (or parent point).  Slope constraints are absolute.  Slopes going from lower-left to 
upper right are positive regardless of whether the child point is to the left or right of the parent. 
 
Horizontal Maximum - The child point has two parent points and remains at the specified 
horizontal distance from the parent point that is farthest to the right (has a maximum horizontal 
or X value).   
 
Horizontal Minimum - The child point has two parent points and remains at the specified 
horizontal distance from the parent point that is the farthest to the left. 
 
Vertical Maximum - The child point has two parent points and remains at the specified vertical 
distance from the parent point that is the highest (has a maximum vertical or Y value). 
 
Vertical Minimum - The child point has two parent points and remains at the specified vertical 
distance from the parent point that is lowest (has the minimum vertical or Y value). 
 
Vector-Offset - The child point is projected onto the vector defined by two parent points.  If the 
offset is not zero, then the child point will maintain a perpendicular offset from the parent vector 
at the specified offset value.  Negative values indicate an offset to the left of the vector defined 
by the parent points. Positive values indicate an offset to the right. If the offset is zero, the child 
point is located on the parent vector. 
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Project to Surface (to Existing Ground) - This constraint must be used in conjunction with one 
of the previously defined constraints. The other constraint will define the projection direction. 
The child point will then be projected to the surface with the specified name.  If the surface does 
not exist, or no solution is found, the point will remain where it is placed in the template. 
 
Project to Design - This constraint is similar to Project to Surface, except that the point is 
projected to the design surface of the template.  A projection value is given to indicate whether 
the projection is to be to the left or to the right.  Again, the point must also be constrained by one 
of the previous constraints, excluding the Project to Surface constraint, so that a direction for the 
projection may be determined.  If no solution is found, then the point will remain where it is 
placed in the template. 
 
Angle distance - This command is used to fully constrain a point in the template.  This 
constraint requires two parent points, a distance, and an angle.  The point is constrained to the 
location defined by the distance from the first parent, and the angle from the first parent relative 
to the vector defined by the two parent points.  This constraint creates a rigid-body rotation.  
When selected, no other constraint types are available. 

3.1.2 Parent-Child Point Relationship 
When a template point is constrained by either one or two other points, it is considered the 
“child” of those reference points.  The reference points are then known as the “parent” point(s). 
If the parent point moves, the child also moves based on the constraints established. 
 

Example:  
Point B is a child of point A.  Point A is unconstrained and shown as a green plus sign on the 
screen.  Point B is fully constrained.  Point B has a horizontal and a slope constraint, and is 
shown as a red plus sign.  In addition, the parent point (Point A) has a blue arrow pointing to the 
child point (Point B). 
 
Visual Indicators for Vertical, Horizontal and Slope Constraints 

 
 
 

  

Point B 

Point A 

Child is vertically constrained to parent.  When the parent 
point moves, the child point follows at a constant vertical 
distance to that point.   

Child is horizontally constrained to parent. When the 
parent point moves, the child point follows at a constant 
horizontal distance to that point. 

Child is constrained to parent by a slope. When the parent 
point moves, the child point follows a constant slope with 
respect to the parent point. 
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3.1.3 Modifying Constraints 
Once a point has been created with or without constraints in a template, it can still be modified. 
Modifications include: adding or deleting constraints, or changing the type of constrained 
originally set for a point. 

3.2 Template Components 

Templates are a grouping of several components, and each component is a set of points that 
defined an open or closed shape.  Each component represents a material for the typical section at 
a particular location.  Each component is given a name and assigned a style.  A style is simply 
the Microstation symbology used to draw the component both in cross section view as well as 
plan view. 

There are six types of components: Simple, Constrained, Unconstrained, Null Point, Overlay, 
and End Condition. 

Once created, components can be modified as desired. There is no limit to the number of points 
or components in a template. When templates are paired with horizontal and vertical alignments 
and superelevation, they define the surface of a corridor. Templates are flexible design 
components that allow you to model simple highway design items such as ditches and sidewalks 
to the more complex multi-lane highways with superelevated curves and variable side slopes. 

3.2.1 Simple Component 
A simple component is a closed parallelogram (4 constrained points) that is defined by the slope 
and thickness (for example, a pavement layer). In this case, if any point is moved, the entire 
shape moves keeping the same relationships determined by the original slope and thickness, 
making this a rigid shape. 

3.2.2 Constrained 
A constrained component consists of points that are all restricted to the movement of the first 
point. A constrained point is typically used to manage the behavior of other points in the 
template. When a point (parent) is moved, any constrained point (child) also moves. This 
restriction only affects the offset and elevation (x,y) of the restrained point and, the relationship 
is unidirectional (movement of child point does not move the parent point).  

3.2.3 Unconstrained 
An unconstrained component is open or closed-shaped with no movement restrictions. This type 
of component is only used for very specific purposes, such as “tracing” a previously placed 
component. 

3.2.4 Null Point 
A null point is a template point that is purposely not related to any particular component. It’s 
most often used as a reference for controlling other points.  A null point is considered a “check 
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or test point”. For example, a null point is used to check if there is an entrance to the right or left 
of the alignment. 

3.2.5 Overlay 
This is a special type of component that allows the user to add overlay/stripping properties in 
order to calculate milling, and/or leveling (overlay) quantities.  

3.2.6 End Conditions 

An end condition is a special open-shaped component that targets a surface, a surface style, an 
elevation, or an alignment.  In other words, the end condition components are simply the 
fill/cut/ditch slopes or benching which tie back to ground. The integrity of end conditions can 
now be routinely tested while the roadway template is being created. 

3.3 Creation Basic Components 

3.3.1 Point Name List and Styles 
Each point used for creating a component must be given a name and a style associated with such.  
CADD Support has created a point name list from which to select.  Point naming convention is 
extremely important in the creation of templates, so especial 
attention must be paid while creating individual components. 

3.3.2 Setting Display Options 
The dynamic settings need to be set prior to creating a 
component, end condition or template.  
 
Key-In 
 
Specifies the type of key in to be performed. 
 

• XY= key in absolute coordinates 
• DL= key in delta coordinates from last point placed (defaults to the dynamic origin if it is 

the first point of a component. 
• HS= key in horizontal delta distance and slope from last point placed. 
• VS= key in vertical delta distance and slope from last point placed. 
• OL= key in delta coordinates from dynamic origin. 
• OS= key in horizontal delta distance and slope from dynamic origin. 
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3.3.3 The Sign of the Distance and Slope 
 

 
 
When defining components with precision input, the sign of the distance is dependent on the 
parent-child relationship. The parent is always the first point placed when creating template 
components. The distance is positive if the parent has a lower X or Y value than the child. The 
distance is negative if the parent has a higher X or Y value than the child. The sign of the 
component slope is based on the mathematical slope. 

3.3.4 Adding Components  
Adding components is a simple process guided by dialog boxes, but point name and placement 
must be carefully thought of before starting the process.  The steps are as follow:  

1. Create the component structure in the library folder tree to the left. 
2. Activate and set and activate the setting display options. 
3. Right click on the current template window and select “Add New Component”. 
4. Select the type of component desired. 

5. Populate the display setting options and current component dialog 
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6. Data point to the origin to place the component.  

 
7. Add points by using the precession key-in commands in the dynamic settings to finish the 

desired shape. For unconstrained and constrained components, once the shape has been 
drawn, right click and select “Finish” to complete. 
 

Once a component has been created, it can be modified visually by adding, deleting points or 
taking away/adding constraints.  In addition, the entire component can be deleted. 
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Also, the component can be modified through the point properties dialog box.   
 
NOTE:

3.3.3 Point Properties Dialog  

 In order to modify a component, the user must modify the points making up the 
component. 

To access the point properties dialog box, right click on the point to modify and select “Edit 
Point”. 
 

 

3.3.4 Basic Component Creation Workflow 
1. Open a template library 
2. Navigate to folder where component will be placed 
3. Right click on folder, and select “create template” 
4. Select and set dynamic settings 
5. Create components by using the point names in the point list 
6. Edit any points if necessary 
7. Save template library 

3.4 Creating an Overlay/Stripping Component 
Creating an overlay/stripping component is similar to creating a basic component.  The only 
difference is that overlay/stripping components are a single line “closed” components and they 
have additional attributes to determine overlay/milling quantities.  Detail creation of an 
overlay/stripping component will be covered in the Overlay Tools Chapter. 
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3.5 Creation of Basic End Conditions 
End conditions are components of the template used to create cut and fill treatments.  These end 
condition components have a specific target such as, surfaces, elevations, horizontal and vertical 
alignments.  

3.5.1 Target Types 
Target types are defined only for end condition components, and are a property of that 
component.  An end condition solution can intercept multiple targets and target types.  For 
example when designing a special ditch, the sideslope condition “targets” the special ditch 
profile elevation, and then intercepts the original ground surface to form the ditch bottom and 
backslope. 

3.5.2 End Condition Settings 
End conditions will draw based on the targets and settings set.  These settings are considered 
specifically end condition properties and are enabled/disabled through the point property dialog 
box. The end condition settings are described below. 
 
Check for Intersection – when set, the 
line segment will search for the specified 
target. If not set, the line segment will be 
created at its full width regardless of 
whether it intersects the target, provided 
that one of the segments connected to this 
segment successfully intersects the target. 
 
Place Point at Interception – when set, a 
point will be placed at the location of the 
interception. If not set, the line segment 
will be created at its full width, provided 
that  one of the segments connected to this segment successfully intersects the target. 
 
End Condition is Infinite – when set, the line segment will automatically be extended to 
intercept the target. If not set, the line segment will only extend to its maximum constraint to 
meet its target. This applies only to the last line segment in an end condition. 
 
Do Not Construct  - If set, the end point of the line segment will be used as a reference point to 
find a subsequent point. The point will be solved like any other end condition point, but that 
point will be skipped when drawing the final component segments. This is normally not set and 
is used only for more complex condition testing. 
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3.5.3 Testing End Conditions 
Testing end conditions gives the user the ability to verify the solutions and priorities as well as 
testing multiple targets without entering the Roadway Designer tool. 
 
When creating end conditions, the user should test to see if desired results are generated.  This 
can be done before, during or after creation of the end condition.   

3.5.4 Basic End Conditions Creation Workflow 
1. Open a template library 
2. Navigate to the folder where templates will be stored 
3. Select create template 
4. Create a new template 
5. Create end condition components 
6. Test end conditions 
7. Save the template library 
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3.6 Group Exercise: Creating Templates 

1) Select the Open Create Template icon. 
 

 
 

 
2) In Create Template dialog select “File > Save As” and save the MoDOT Library to the 

User’s Working Directory.  Name the file J2P0200.ITL 
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3) In Create Template dialog select “File > New > Folder” and create a folder called 
“J2P0200”. 

 

  
 

 
4) In Create Template dialog under the J2P0200 folder select “File > New > Folder” and 

create a folder called “Road1”. 
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5) Within the Road1 folder and create a new template called “Road1 Two Lane Rural” by 
right clicking on the Road1 folder. 

 
 

6) Set the following Dynamic Settings: 
 

 
 

 
7) In Create Template go to Tools > Options and confirm the following Affixes are set: 
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8) In Create Template select the Pavement > Asphalt > Pavement Combined Asphalt 
component.  

 
When placing the component right click and select “Mirror”.  Then place the component at 
the 0,0 coordinate. 
 

  
 

 
9) Right Click in the Template Display Window and select Delete Components.  Then 

remove the bottom three layers from the template.  
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10) In Create Template select the Shoulder > Aggregate > Shoulder Layer 1 Aggregate 
component.  

 
Then place the shoulder component at the Pvmt_Surf_Conc_T1 location. 
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11) In Create Template modify the two lower inner shoulder point constraints to follow the 
pavement wedge slope.  

 
 

 
 
 
Double click on Right Shoulder Point first to get the Points Properties Box to edit point. 
 
See next page to see how to adjust Point Constraints: 
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12)  In the Point Properties dialog adjust the constraint that controls the Horizontal Control 
to a Vector-Offset.  Set the Parent points to be the top and bottom pavement points (See 
below), also set vector offset “Value” to zero.  Modify both shoulder points. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Pvmt_Surf_Asph_T1_R 
 
 
 
 

 
Pvmt_Layer_1_Asph_B2_R 
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13) In Create Template select the End Conditions > Ditches > Ditch 1 End Condition.  
 
Then place the ditch component at the Shldr_Layer_1_Aggr_T1 location. 

 

  
 

 
14) In Create Template select the End Conditions > Fill Slopes > Fill Slope Combined 

component.  
 
Then place the fill component at the Shldr_Layer_1_Aggr_T1 location. 
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15) In Create Template select the Test button to view the End Condition Priorities. 

 
 

 
 

 
16) In the next step we are going to show how to copy items from one template library to 

another. 
 
We have an existing template library (ITL) that has a Two Lane Rural Template that we 
can use in the current project. 
 
To do this in Create Template select Tools > Template Library Organizer. 
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17) Copy the Road1 Two Lane Urban template from the ITL located in the following 

location: 
 

T:\de-proj\Randolph\J9P1234\J9P1234.itl 
 

 
 
 
When prompted save the J2P0200.itl 
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18) In the Preferences section of Corridor Modeler, set the Template Library to the 

following: 
 

T:\de-proj\Randolph\J2P0200\data\J2P0200.itl 
 

 
 

 
19) In Corridor Modeling, select File > Save 
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