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1 
CHAPTER OBJECTIVES 

In this chapter we will: 

• overview the original data supplied for this project. 

• formulate a design strategy. 

INTRODUCTION 

Designers will realize that every “at grade” intersection has its own specific design issues. 

What may look the same from plan view may be a totally different design vertically due to the existing 
vertical conditions or specific requirements. 

The amount of reconstruction of existing roadway can completely change the designers approach to 
two seemingly similar geometrical layouts. 

We shall investigate the design constraints of this particular project and formulate an initial design 
strategy.  This strategy may need to be varied or modified further along the design path based on 
outcomes at each step, but we need some strategy to begin with to make a start. 

We will overview the supplied data and constraints for this specific situation. 

PROJECT OVERVIEW 
This training session evolved from an actual project sent to GEOPAK by a client who was seeking 
assistance. The steps we will undertake in this training session mirror those formulated during the 
process of assisting the client. 

We shall look at the information that was originally supplied when this project first started. 

• The Client had completed a survey of the existing conditions and created a TIN file. They had 
completed the geometric layout of the new intersection and had designed a controlling Chain and 
Profile. 

• The Chain (VAN1) and Profile (PROPVAN1), together forming the Control Alignment, have been 
approved by the Project Engineer and could not be modified. 

• Other constraints included the strict requirement to tie down to original within the existing right of 
way and a maximum length reconstruction on the service roads of 150 feet. 
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: Review the Project Data 

1. Open the file C:\Data\Geo\Site\Roundabout\Chapter2\LHSRAB.dgn.  

This file will initially display the reference file that contains the survey information from the 
existing intersection arrangement. 

In class, we shall discuss the existing arrangement on the intersection.  Note that the 
controlling alignment is based on an existing overpass bridge. 

2. Select the File Reference tool (MS: File > Reference). 

3. Toggle off existing.dgn and toggle on proposed.dgn. 

We shall discuss the proposed layout and based on this layout, what are the requirements to 
begin a Site Modeler project. 

4. Toggle off proposed.dgn. 

5. Select the MicroStation Level Display tool (MS: Settings > Level > Display). 

6. Turn on all levels in the active design file. 

This shows all of the plan view graphical elements required to begin this project. 

We shall discuss the graphical elements that are displayed and their significance. 

7. Select the Design and Computation Manager tool  (Applications > GEOPAK Site > Design 
and Computations Manager) . 

8. Open the file C:\Data\Geo\Site\Roundabout\site.ddb  (File > Open). 

9. Close the Design and Computation Manager dialog. 

DESIGN STRATEGY 

We need to formulate a Design Strategy based on the constraints of the project, the given information 
and the desired project outcome. 

This strategy could change during the course of this project due to design issues or constraints that are 
either unknown or unforeseen at this time.  

Modification of a design strategy is typical of a lot of intricate design projects and the GEOPAK Site 
Modeler tools provide the User with the type of flexibility required to take changes into consideration 
as they arise. 

PROJECT CONSTRAINTS 

The Control Alignment is set. It cannot be changed. 

Maximum allowable reconstruction of the services roads is 150 feet. 

Right of way cannot be altered. 

Hint This means we stay as close as possible to the existing intersection elements and elevations. 
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FORMULATE A DESIGN STRATEGY 

There are a number of different design philosophies for designing roundabouts. We will not be 
examining all of the different theories in this class. The philosophy that we will use is one that treats 
the traffic circle portion of the intersections as an “upside down plate”. This means that irrespective of 
the orientation of the traffic circle, the outside edge is always forms a plane surface. 

1. Given the project constraints, we need to design the intersection based around the control 
alignment and create the traffic circle portion of the intersection so it is as close to the existing 
intersection elevations as possible. 

2. Creation of the Traffic Circle will be based on a plane that is defined relative to the Control 
Alignment. After the plane is created the outside edge of the Traffic Circle will be draped 
onto the construction plane and then the inside edge of the Traffic Circle will be created at a 
positive 2% slope from the outside edge. 

3. We shall then analyze the difference in elevation between the outside edge of the Traffic 
Circle and the existing surface at critical points and, if required, redesign the Traffic circle 
until we are achieved a satisfactory stage of the design.  

4. The incoming roadway profiles (other than the Control Alignment) will be designed based on 
the Traffic Circle elevations. 

5. The incoming roadways will be modeled based on the design profiles. 

6. Curb returns will initially be defined based on the most appropriate adjacent element then 
modified as required. 

7. The median islands will be created based on the finished pavement surface. 
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2 
CHAPTER OBJECTIVES 

In this chapter we will: 

• create a Construction Object based on the Control Alignment. 

• create and analysis the Traffic Circle. 

• modify and re-analysis the Traffic Circle. 

INTRODUCTION 
Based on the design strategy that we have set, we need to devise a way to assign elevations to the 
outside edge of the traffic circle. 

As an additional consideration, we should formulate this step with the thought that it may need to be 
redesigned (probably will need to be redesigned) and that we should create this element with the 
redesign issue in mind. 

The use of Construction Objects with GEOPAK Site Modeler is a very powerful way to assign 
elevations to irregular or complex elements AND provide a way to make redesign a very fast and 
painless process. 

TOOLS TO BE USED 
The tools we will use in this chapter are: 

• Site Modeler > Object > New. 

• Site Modeler > Elements > Composite Section. 

• Site Modeler > Elements > New/Edit > Drape on Model/Object. 

• Site Modeler > Elements > New/Edit > Section. 

• Site Modeler > Elements > Information. 

• Site Modeler > Analysis > Profile. 



Create a Construction Object 

 

Intersection/Roundabout Design with  
GEOPAK Site - Advanced Copyright © 2003 Bentley Systems, Incorporated Do Not Duplicate 

8/1/2003 2-2 

CREATE A CONSTRUCTION OBJECT 
A Construction Object is defined as a Site Modeler Object that is in the Modeler project but not 
necessarily part of the Model. Its primary use is to simplify the process of assigning, and then 
reassigning, elevations to irregular or complex Site Modeler Elements. 

The methodology we shall use to create the construction object is to create a new Object and, within 
that Object, define a surface plane based on the Control Alignment. 

:  Open an Existing Project 

1. Select the Site Modeler tool (Applications > GEOPAK Site > Site Modeler > Site Modeling). 

 

2. Click Browse. 

3. Navigate to and select C:\Data\Geo\Site\Roundabout\Chapter2\LHSRAB.gsf.  

This is a Site Modeler project that has already been created that includes the existing ground 
TIN file as the Object “Ground 1” and a Model called “RAB” that has the Ground 1 Object as 
its base. 

3. Click OK. 

: Create a Construction Object 

1. Select the Create New Object tool (Site Modeler menu: Object > New). 

 

2. Enter the New Object information. 

Object Type Construction 

Object Name Temp1 

Add to Active Model Disable 

3. Click OK. 
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: Create the Construction Surface Using Composite Section 

1. Select the Composite Section tool  (Site Modeler:  Elements > Composite Section). 

2. Select the Composite Sections setting file: 
C:\Data\Geo\Site\Roundabout\Chapter2\TempObjectZeroPercentSlope.sec. (Site Modeler: 
File > Open).  

 

3. Define the Primary Element Definitions.   

Add to Active Object Enable 

By Chain-Profile 99  (Job Number) 

Chain: VAN1 

Profile: PROPVAN1 

Primary Element: Feature 

Payitem \Drafting Standards\General\TempCL 

Use Station Range Enable 

Begin 12+79.98 

End 17+21.85 

Warning  Ensure that the Active Object is “Temp 1”. Check the Active Object Control dialog. 

4. Click Apply.  

We have now created a surface that is 190 feet wide (95 feet both sides of the control 
alignment) and is projected at 0% from on the control alignment.   

While this surface has no slope in the north/south direction, it will still drain based on the 
longitudinal slope of the alignment it was created from. 
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CREATE THE ROUNDABOUT OBJECT 
Based on the design strategy that was discussed earlier, we will now start to create the elements that 
will make up our intersection (roundabout). 

First, we need to create an Object to place the roundabout elements into. 

Then we will drape the outside edge of the traffic circle onto the Construction Object. 

The last step is to create the inside edge of the traffic circle to give us the 2% pavement cross slope 
within the traffic circle. 

: Create the Roundabout Object 

1. Select the Create New Object tool (Site Modeler menu: Object > New). 

2. Enter the New Object information. 

Object Type Roadway  

Object Name RAB1  (overwrite default) 

Add to Active Model Enable 

3. Click OK. 

: Create Outside Edge of Traffic Circle Element 

1. Select the New / Edit Element tool (Site Modeler menu: Element > New/ Edit).   

 

2. Click Drape on Model/Object on the Elements tab. 

3. Enter the Element information. 

Add to Active Object Enable 

Feature Type Break Line 

Drape on Object Temp 1 

Offset Height Disable 

Drape Option Entire Element 

Use Drape Association Enable 

Use Power Selector Enable 

Redefine Site element Enable 
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4. Click Select Elements in the Define Elements group box. 

5. Select the outside edge of the traffic circle. 

The element highlights when selected.  Make sure it is the same color as your highlight color. 

6. Click Apply. 

: Create the Inside Edge of the Traffic Circle 

1. Select the New / Edit Element tool (Site Modeler menu: Element > New/ Edit).   

2. Select the Section tab. 

 

3. Enter the Section information. 

Option Table 

Feature Type Break Line 

4. Enter the information in the edit boxes along the bottom. 

Offset Distance 30 

Offset Elevation 0.6 

5. Click Select to find the DDB Pay Item and navigate to PayItem > Plan > Curbing > RAB 
Edge of Pavement. 

6. Select the item and click OK. 

7. Click Add List Item. 

8. Click Select Reference Elements  in the Reference Elements group box. 

9. Select and accept the outside edge of the traffic circle . 

Hint It is important that the outside edge element changes color to the color displayed in the 
Reference Elements group box. 

10.  Click Set in the Direction group box. 

11.  Point the direction of the dynamic graphic inside the selected element. Data point to accept 
the direction. 

12.  Click Apply. 

There should be a new element created and the contours of the RAB1 Object should indicate a 
2% pavement cross slope. 

Note This can be interrogated using the Analysis > Height tool. 
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ANALYZE THE TRAFFIC CIRCLE 
At this time, we need to determine if this first attempt at the traffic circle meets the design constraints.  
Specifically, how close do we match the existing elevations? We need to determine the difference in 
elevation between the proposed and the existing. 

The critical locations to check this difference in elevation are at the centerline of the incoming ramps 
and service roads. 

Note As the control alignment has previously been set as a constraint, there is no need to check the 
elevation differences for these roads. 

There is more than one tool that would be suitable for the analysis task that we have. The tool we will 
use is the Site Profile tool. Another option would be the Elevation Differences tool. 

We will opt for the Profile tool in this case due to the very visual and specific feedback it provides. 

: Using the Site Profile Tool 

1. Select the MicroStation Saved Views  tool (MS: Utilities menu > Saved Views). 

2. Select PROFILE and click Apply. 

Location to create 
Analysis Profile. 

 

3. Select the Site  Profile tool.  (Site Modeler: > Analysis > Profiles). 
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4. Select Site Object. 

5. Set the Site Object to RAB1. 

6. Set the element symbology by double-clicking the sample line graphic. 

7. Click OK to close Set Feature dialog. 

8. Click Add List Item (right side of dialog). 

9. Change the Site Object to Ground1. 

10.  Set the element symbology by double-clicking the sample line graphic. 

11.  Click OK to close Set Feature dialog. 

12.  Select the Profile tab. 

13.  Click Place Element and place two data points to create the line. 

Note The line should pass from the traffic circle surface onto the North Ramp roadway at 
approximately the ramp centerline. 

The profile view of the Site profile tool displays the two surfaces. We can immediately see the 
difference in elevation between them. 

13.  Select the Preferences  tab. 

14.  Toggle on the Major and Minor Vertical Grid intervals. 

15.  Select the Profile tab.  

The Profile is displayed showing the vertical grid intervals. 

 

Note Investigate the elevation difference in the same manner at the South Ramp and the North and 
South Service Roads. 

MODIFY THE TRAFFIC CIRCLE 

It has been determined that the current elevations of the traffic circle are not acceptable. We will 
modify these elevations and analyze the result. 

As the traffic circle elevations are based on the plane created in the construction object, all we need to 
do is modify the construction object and the traffic circle automatically reflects these changes. 

This can be accomplished due to the GEOPAK Site Modeler “association” technology. Site Modeler 
tracks and remembers the way that elements are created. Using this tracking system provides the user 
with a powerful tool to automatically update linked data. 

If we remember back to what we have done, the construction object is a simple surface based on the 
control alignment chain and profile. The outside of the traffic circle is dependent on that construction 
surface and was created from it (Elements > New/Edit > Drape on Object). The inside of the traffic 
circle was created based on the outside element (Elements > New/Edit > Section). Therefore, if we 
modify the construction surface, all of the traffic circle elements update to reflect the surface change. 

: Modify the Construction Object 

1. Select the Site Modeler Element Information tool (Elements > Information). 

2. Click ID. 
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3. Select and accept the construction centerline element. 

4. Select the Associations  tab. 

 

 

 
Composite Section 

 

5. Set the Options to Dependent Associations. 

6. Click Composite Section (to the right of profile).   

The Composite Section dialog opens with the settings used to create this element. 

Note We will edit the Left Side and Right Side element so they provide a 1% cross slope from left to 
right. 

7. Click Section Side Left Side. 

8. Select the parallel element. 

9. Change the slope to 1%. 

10.  Click Modify (right side of list box). 

11.  Click Section Side Right Side. 

12.  Select the parallel element. 

13.  Change the slope to -1%. 

14.  Click Modify (right side of lis t box). 

15.  Click Apply. 

This updates all of the elements that are linked to the construction surface. 

16.  Refresh the MicroStation view to see the effect that this has had on the traffic circle. 

17.  Use the Site Profile tool to repeat the analysis of the incoming roadways to visually see the 
difference that this has made. 

Note We will accept this design and move on to the next design stage. 
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: Closing the Project 

1. Close GEOPAK Site Modeler (Site Modeler: Project > Exit). 

2. Click Yes to the Save alert. 

3. Click No to the Lock Elements alert. 
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3 
CHAPTER OBJECTIVES 

In this chapter we will: 

• design the incoming profiles for the ramps and service roads. 

INTRODUCTION 
Now that we have decided that the first design step is acceptable, the next logical step is to design the 
incoming roadway profiles. 

This could have been completed earlier in the design process but would have been quite difficult and 
resulted in data that may have needed to be revised. 

Starting this process now gives us a distinct advantage in that we now know what the elevations of the 
traffic circle are and we can use this information to make intelligent design decisions. 

The process we shall use is as follows. 

1. Create existing surface profiles based on the Model for each incoming roadway. 

2. Design the proposed profile for each incoming roadway. 

TOOLS TO BE USED 
The tools we will use in this chapter are: 

• Site Modeler > Object > Draw Profile. 

• Applications > GEOPAK Site > Active Profile Control. 

• Applications > GEOPAK Site > Geometry > Layout Profile (Component Based). 
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CREATE MODEL SURFACE PROFILES 
To ensure that all students have the same data, we are using another dataset. 

: Open the Site Project 

1. Open the file C:\Data\Geo\Site\Roundabout\Chapter3\LHSRAB.dgn (MicroStation: 
File>Open). 

2. Select the Site Modeler tool (Applications > GEOPAK Site > Site Modeler > Site Modeling). 

 

3. Click Browse.  

4. Navigate to and select the file C:\Data\Geo\Site\Roundabout\Chapter3\LHSRAB.gsf. 

5. Click OK. 

: View Chain Locations 

 We shall look at the location and extents of the chains before creating the profiles and discuss the 
significance of the chain ending point. 

1. Select the Coordinate Geometry tool (Applications > GEOPAK Site > Geometry > 
Coordinate Geometry). 

 

2. Select Job Number 99. 

3. Click OK. 

4. Set Visualization to temporary. 

5. Click Navigator. 

6. Lower (minimize) the COGO window. 

7. In the Navigator dialog, set Element to Chain. 

8. Select and visualize the chains – RampSth, RampNth, ServSth and ServNth. 

9. Close Navigator – leave COGO open. 
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: Create Model Surface Profiles 

1. Select the Object Draw Profile tool (Site Modeler: Object>Draw Profiles). 

Note The Draw profile dialog should be familiar to most students as it is a standard GEOPAK tool. 
When used as a Site Modeler tool, it has additional functionality. It has the ability to not only 
create profiles from TIN files, but also from Site Objects and Models. 

2. Set Job Number to 99. 

3. Set Chain to RampNth. 

 

 

 
Dialog Profile Cell Control 

 
Update Profile 
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4. Click Dialog Profile Cell Control. 

 

 

 Place Profile Cell 

 Activate Profile Cell 

 
Delete Profile Cell 

 

5. Click Place Profile Cell.  

 

6. Enter the Profile Cell information. 

Station 0+00 

Elevation 6200 

Horizontal Scale 10 

Vertical Scale 1 

Gap Option No Gap 

Cell Range: Top Delta 100 

Cell Range: Bottom Delta 0 

 

7. Place the Profile cell into a clear part of the graphics (in Window 2). 
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8. Select the Active Chain Control tool (Applications>GEOPAK Site>Site Modeler>Active 
Chain Control). 

 

 

 
Active Job Number 

 Active Chain 

 
Identify Curvilinear Reference 

 
Curvilinear Coordinates 

 
Profile Cell Status 

 
Cross Section Cell Status 

 
Fit View Buttons (Right Click to Define Status). 

 

9. Set Window 2 to a Profile view in the Active Chain Control.  

This is accomplished by right clicking on the View 2 button in the dialog and setting the view 
to profile. 

Note This will coordinate between the plan and profile views of RampNth chain. 
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10.  Enter the Draw Profile information. 

 

Job Number 99 

Chain RAMPNTH  

Details Model > RAB, Method > Triangles 

Display Settings By Feature: Pay Item (Drafting Standards > Profiles > ExistP) 

 

11.  Click Add Surface Settings. 

When the surface is added to the list box, it is immediately drawn into the Profile Cell. 

Note The same process will now be repeated to create the Model profiles for the Chains RampSth, 
ServNth and ServSth. 

12.  Exit and save the Site Modeler project.  

It is not required for the remainder of this chapter. 
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CREATING DESIGN PROFILES 
Now that we have drawn the Model surface profiles, we are in the position where we can create design 
profiles.  We already have some constraints that affect this next step.  The Model profiles show us the 
elevation at the proposed traffic circle edge, so the design profiles must start at that elevation. 

The cross slope of the traffic circles is 2%. For us to get a smooth transition for the incoming roadways 
to the traffic circle, we must start the design profiles using a 2% tangent from the location that we join 
to the traffic circle. 

The service roads cannot be reconstructed any more than 150 feet. We will draw this location into the 
plan and profile to give us a visual indication of this design constraint. 

: Locate the Maximum Reconstruction Constraint in Plan 

1. Select the Place Line tool. (MicroStation > Place Line). 

2.  Draw a line that is perpendicular to the tangent sections of the Chains ServSth and ServNth 
at there ending stations. 

3. Copy the line parallel 150 feet back along the respective chain. 

This gives us the 150 feet reconstruction constraint in plan view. 

 

150 feet 
reconstruction limit 

150 feet 
reconstruction limit 

 

: Locate the Maximum Reconstruction Constraint in Profile 

1. Set Active Chain Control (ACC) to the Chain ServNth and synchronize the views. 

Note Synchronize the views by clicking in the ACC Plan View window and Profile View window. 

2. Click Curvilinear Coordinates (Active Chain Control toolbox). 

As you move in plan view the curvilinear coordinates will display station and offset. As you 
move in profile view the curvilinear coordinates will display station and elevation. 

3. In Plan, snap to the line that indicates the maximum extent of reconstruction.  
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4. Lock (toggle on) the Station and Permanent Lock controls in the Curvilinear Coordinates 
dialog. 

The stations may be different as we did not accurately draw the reconstruction limit line. 

 

5. Select the Place Line tool (Microstation>Place Line). 

6. Draw a line in the profile view. 

Note Due to the effect of the curvilinear coordinates tool, the line is drawn at the correct station and 
can only be drawn vertically. 

7. Unlock the Station and Permanent Lock controls. 

8. Set Active Chain Control (ACC) to the Chain ServSth and synchronize the views. 

9. Follow Step 3 to Step 7 for the ServSth Chain. 

This gives us the 150 feet reconstruction constraint in profile view.  

: Creating Design Profiles Using the Vertical Component Tools 

Warning Wait and follow you Instructor before you attempt these steps if you have not used these tools 
before. 

1. Set ACC to the chain ServNth. 

2. Synchronize the views. 

3. Use MicroStation view controls to set the allowable reconstruction portion to fill the plan and 
profile designated views. 

4. Select the Layout Profile (Component Based) tool (Applications > GEOPAK Site > 
Geometry > Layout Profile (Component Based)). 

 

 
Tangent Tools 

 
Curve Tools 

 
Store Alignment Button/tool 
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5. Tear off the tangent tools and the curve tools. 

    

Hint These tools provide an alternate to the VPI based Vertical Alignment Generator. They allow 
the user to place vertical components (tangents and curves) to assemble a profile. Where the 
user has many constraints (as it the situation here) they are a very useful alternative to the 
traditional GEOPAK design profile method. 

6. Click Create Profile Line by Points (Place VA Line toolbox). 

 

7. In Profile View, Snap to the end of the Model profile that represents the elevation at the edge 
of the traffic circle. 

8. Set the slope to 2%. 

9. Draw in the tangent. 

10.  Set the MicroStation snap control to nearest (MS: Settings > Snaps > Nearest). 

11.  Click Create Profile Curve by 3 Pts (Place VA Curve toolbox). 

12.  Snap to 3 locations on the Model profile in the area of the extent of reconstruction.  

Note This gives us a vertical curve that represents the existing service road centerline – so w can 
join back to existing. 

13.  Click Create Tangent Profile Curve  (Place VA Curve toolbox). 

14.  Select the profile tangent, data point in the profile view to designate a “through” point on the 
curve and then data point again to finish the curve. 

15.  Click Create Profile Curve between 2 Elements (Place VA Curve toolbox). 

16.  Select and accept the first profile curve.  

17.  Select and accept the second profile curve. 

18.  Data point to complete the new profile curve. 

: Storing the Proposed Profile 

1. Select the Store Alignment (Vertical Components toolbox). 

 

2. Key in the Name ServNth. 

3. Select any proposed profile component from the profile view (Window 2). 

4. Data point again to string the components together. 

5. Data point again to actually store the alignment to COGO. 

6. Click COGO – this will raise the COGO window.  
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You can see the commands that have been created to store the profile. 

Hint Remember to follow the prompts displayed in the MicroStation message area during the 
design and store profile process. 

: Determine the Extent of Reconstruction 

While we have the ServNth profile activated, we shall use this to determine the extent of 
reconstruction.  Effectively, where the proposed profile joins back to the existing surface is the end of 
proposed reconstruction. 

1. Set MicroStation snap to intersection mode. 

2. Click Curvilinear Coordinates. 

3. In the profile view, snap to the intersection of the existing and proposed profiles. 

4. Lock the Station and Permanent Lock controls in the Curvilinear Coordinates dialog. 

5. Click MicroStation Partial Delete. 

6. In plan view, partial delete both of the ServNth edge of pavement elements. 

Note As the Curvilinear Coordinates dialog locks us to a specific station, we are cutting the edge of 
pavement elements at the same location that the design profile joins to the existing profile. 

: Design the remaining Proposed Profiles.  

1. Design the proposed profiles for the ServSth, RampNth and RampSth in the same way. 

Hint Remember to partial delete the ServSth edge of pavement elements similar to exercise 
above. 
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4 
CHAPTER OBJECTIVES 

In this chapter we will: 

• model the incoming roadway pavement areas based on the profiles we just designed and the 
alignment we were provided with. 

INTRODUCTION 

Now that chains and profiles have been created for all of the incoming roadways, the next step is to 
model the incoming roadway surfaces based on those design alignments.  This involves defining the 
alignment elements, edge of pavements and curb and gutter sections in the Site Model.  There are two 
methods that can be employed to do this.  We will attempt both methods and discuss reasons to choose 
one method over the other.  First, we will add the control alignment and then define the associated 
edge of pavement elements using the basic Site Modeler tools.  Then we will define the other 4 
incoming roadways using the Composite Section tool. 

TOOLS TO BE USED 
The tools we will use in this chapter are: 

• Site Modeler > Elements > New/Edit > Alignment. 

• Site Modeler > Elements > New/Edit > Slope/Offset from Site Element. 

• Site Modeler > Elements > New/Edit > Section. 

• Site Modeler > Elements > Composite Section. 

 

: Open the Site Project 

Note To ensure that all students have the same data, we are using another dataset. 

1. Open the file C:\Data\Geo\Site\Roundabout\Chapter4\LHSRAB.dgn (MicroStation: File > 
Open). 

2. Select the Site Modeler tool (Applications > GEOPAK Site > Site Modeler > Site Modeling). 

 

3. Click Browse. 
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4. Navigate to and select the file C:\Data\Geo\Site\Roundabout\Chapter4\LHSRAB.gsf. 

5. Click OK. 

CREATE A ROADWAY SURFACE FROM THE CONTROL ALIGNMENT 

: Add the Control Alignment 

1. Click Level Display (MicroStation: Settings>Level>Display). 

2. Disable Level 55. 

3. Select the Alignment tool. (Site Modeler: Elements>New/Edit>Alignment). 

Note We do not want the alignment element to impact on the traffic circle, only the pavement 
outside it. Because of this, we will add the Control Alignment to the Object in 2 parts, leaving 
out the portion across the Traffic Circle. 

 

2. Enter the Alignment information.  

Element By Feature: Drafting Standards>General>Baseline-Chains 

Job 99 

Chain VAN1 

Profile PROPVAN1 

Use Station Range Enabled 

Begin Station 12+79.98 

End Station 14+73.36 

Hint The Instructor will discuss the Station Range settings. 

3. Click Apply. 
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4. Reset the Station Range as shown below. 

 

5. Click Apply. 

This adds the two required portions of the control alignment to the Object.   

: Add the Edge of Pavement Elements Relative to the Control Alignment 

1. Click Slope/Offset from Site Element. (Site Modeler: Element > New/Edit > Slope/Offset 
from Site Element). 

 

2. Enter the Slope/Offset information. 

Add to Active Object Enabled 

Feature Type Breakline 

Slope %  Enabled, -2 

Projection Option Entire Element 

Use Reference Element Association Enabled 

Use Power Selector Enabled 

Redefine Site Element Enabled 

Note There are two (2) different sections of the control alignment. The cross slope for the road area 
is -2%. The cross slope for the bridge area is -1.56%. We will need to project the edge of 
pavement elements to the centerline in 2 steps. 
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3. Click Select Element from the Define Elements group box. 

4. Select the 2 western “edge of pavement” complex chains. 

5. Click Select Reference. 

6. Select and accept the western portion of the control alignment element. 

7. Click Apply. 

Note Now we shall repeat these steps for the right hand portion of the control alignment – the 
pavement over the bridge. 

8. Modify the Slope/Offset information. 

 

Add to Active Object Enabled 

Feature Type Breakline 

Slope %  Enabled, -1.56 

Projection Option Entire Element 

 

9. Click Select Element from the Define Elements group box. 

10.  Select the two (2) eastern “edge of pavement” complex chains. 

11.  Click Select Reference. 

12.  Select and accept the left hand portion of the control alignment element. 

13.  Click Apply. 
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: Add the Curb and Gutter Sections to the Edge of Pavement 

1. Select the Section tool (Site Modeler: Elements>New/Edit>Section). 

 

2. Enter the Section information. 

OFFSET DISTANCE OFFSET ELEVATION PAY ITEM 

1.500 -0.200 PayItem > Plan > CURBING > Gutter 

1.600 0.500 PayItem > Plan > CURBING > CTF 

2.000 0.500 PayItem > Plan > CURBING > CTB 

 

3. Set the Feature Type to Boundary. 

4. Click Select Reference Elements from the Reference Elements group box. 

5. Select the four (4) previously defined edge of pavement Site Elements. 

6. Click Set. 

7. Move the cursor into the graphics. 

Note There is a dynamic graphic that is attached to the selected elements. GEOPAK is waiting for 
the User to set the positive horizontal (offset) direction for the section elements. 

8. Click outside of the selected graphics (so the positive direction is to the outside of the edge of 
pavement). 

9. Click Apply. 

We have added the curb and gutter to the edge of pavement elements.  

We will now create the other 4 incoming roadways in a more automated manner using 
Composite Section. 
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: Add the North Service Road 

1. Select the Composite Section tool (Elements>Composite Section). 
 

Set Active Object 

Define the Primary 
Element. 

Add List Item 

List of commands 
for left or right side 
of section 

Element Definition 

Method of Element 
Definition 

Search Parameters 

 

Note A number of steps are required to populate this dialog with the required information. Below are 
dialog captures of each of these steps. 

2. Select and delete the current “Left Side” row items. 

3. Enter the Primary Element Definition group box information. 

By Chain-Profile 99 

Chain SERVNTH  

Profile SERVNTH  

Primary Element Feature 

Use Station Range Enable 

Begin Station 7+01.48 

End Station 7+87.43 

Payitem Drafting Standards>General>Baseline-Chains 

 



Create A Roadway Surface From The Control Alignment 

 

Intersection/Roundabout Design with  
GEOPAK Site - Advanced Copyright © 2003 Bentley Systems, Incorporated Do Not Duplicate 

8/1/2003 4-7 

4. Enter the information required to define the edge of pavement elements.  

Define: Element Type Feature 

Define: Feature Type Breakline 

Method: Slope -2.0 

Method: Vertical Offset 0.0 

Method: Radial To Primary 

Method: Projection Option Entire Element 

Search Extent: Payitem PayItem>Plan>CURBING>E of P 

Search Extent: Max. Distance 32.0 

5. Click Add List Item (right of the list box). 

6. Enter the curb and gutter information.  

 

 

Define: Element Type Section 

Define: Feature Type Boundary 

Method: Section By Table 

Method: Side Left 
 

OFFSET DISTAN CE OFFSET ELEVATION PAY ITEM 

1.500 -0.200 PayItem>Plan > CURBING > Gutter 

1.600 0.500 PayItem > Plan > CURBING > CTF 

2.000 0.500 PayItem > Plan > CURBING > CTB 
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7. Click Add List Item. 

8. Select both list items.  

9. Click Copy List Item. 

 

Right Side 

Paste List Item 

Copy List Item 

 

10.  Click Right Side.  

11.  Click Paste List Item. 
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12.  Select the first row item for the right side. 

 

 

13.  Reset the Max. Distance value to 25.50. 

14.  Click Modify List Item. 
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15.  Edit the right side Section row.  

16.  Set the Method: Side to Right. 
 

Modify List Item 

Section Side Right 

 

17.  Click Modify List Item. 

18.  Click Apply. 

Hint Composite Section settings files can be saved and reused. To save a file, use the File>Save 
option at the top of the dialog. 
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: Add the South Service Road 

Note The Composite Section files have been saved for the other roadways. We can open these 
files to complete the incoming roadways. 

1. Continuing with the Composite Section tool. 

2. Open the file C:\Data\Geo\Site\Roundabout\Chapter4\ServSth.sec (File>Open). 

 

 

3. Enter the Primary Element information. 

By Chain-Profile 99 

Chain SERVSTH  

Profile SERVSTH  

Primary Element Feature 

Use Station Range Enable 

Begin Station 7+82.46 

End Station 9+14.51 

Payitem Drafting Standards>General>Baseline-Chains 

4. Click Apply. 

Hint The Begin and End stations can be dynamically set. Click Set Station and snap to specific 
points in the DGN. Follow your instructor. 
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: Add the North Ramp 

1. Continuing with the Composite Section tool. 

2. Open the file C:\Data\Geo\Site\Roundabout\Chapter4\RampNth.sec (File>Open). 

 

 

3. Enter the Primary Element information. 

By Chain-Profile 99 

Chain RAMPNTH  

Profile RAMPNTH  

Primary Element Feature 

Use Station Range Enable 

Begin Station 4+41.67 

End Station 5+07.95 

Payitem Drafting Standards > General > Baseline-Chains 

4. Click Apply. 
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: Add the South Ramp 

1. Continuing with the Composite Section tool. 

2. Open the file C:\Data\Geo\Site\Roundabout\Chapter4\RampSth.sec (File>Open). 

 

 

3. Enter the Primary Element information. 

By Chain-Profile 99 

Chain RAMPSTH  

Profile RAMPSTH  

Primary Element Feature 

Use Station Range Enable 

Begin Station 5+93.04 

End Station 6+55.89 

Payitem Drafting Standards>General>Baseline-Chains 

4. Click Apply. 

 

This completes the areas of the incoming roads that can be defined based solely on the Chain 
and Profile for each roadway. 
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: Saving and Exiting the Project 

1. Close GEOPAK Site Modeler (Site Modeler: Project>Exit). 

2. Click Yes to the Save alert. 

3. Click No to the Lock Elements alert. 
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5 
CHAPTER OBJECTIVES 

In this chapter we will: 

• create the curb return elements and then, where required, edit these to ensure that all pavement 
areas provide smooth transitions and drain correctly. 

INTRODUCTION 

At this point, we have defined all of the larger pavement areas that have a direct relationship to a 
specific geometric element. 

The traffic circle was defined based on a surface generated from the original control alignment. The 
incoming roadways have been based on their respective chains and profiles. 

The curb return elements, in general, will be defined based on extending recently created pavement 
areas. Deciding where and how these elements will be created will require some educated Engineering 
design “best guesses”. 

TOOLS TO BE USED. 
The tools we will use in this chapter are: 

• Site Modeler > Elements > New/Edit > Slope/Offset from Site Element. 

• Site Modeler > Elements > New/Edit > Drape On Model/Object. 

• Site Modeler > Elements > Edit Profile. 

• Site Modeler > Elements > Section. 
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DEFINE THE REMAINING EDGE OF PAVEMENT ELEMENTS 
To ensure that all students have the same data, we are using another dataset. 

1. Open the file C:\Data\Geo\Site\Roundabout\Chapter5\LHSRAB.dgn (MicroStation: 
File>Open). 

2. Select the Site Modeler tool (Applications > GEOPAK Site > Site Modeler > Site Modeling). 

 

3. Click Browse. 

4. Navigate to and select the file C:\Data\Geo\Site\Roundabout\Chapter5\LHSRAB.gsf.    

5. Click OK. 

: Define the Curb Return Elements.  

1. Select the Slope/Offset from Site Element tool. (Site Modeler: Element > New/Edit > 
Slope/Offset from Site Element). 

Note Most of the remaining curb return elements can be defined by projecting from the outside 
edge of the traffic circle at –2%. 

 

2. Enter the Slope/Offset From Site Element information.  

Feature Type Break Line 

Slope %  Enabled, -2.0 

Projection Option Entire Element 

Use Reference Element Association Enable 

Use Power Selector Enable 

Redefine Site Element Enabled 
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3. Click Select Element from the Define Elements group box. 

Select all of the curb return elements that are shown in heavy weight below. 

 

4. Click Reference Element>Select Reference. 

5. Select and accept the outside edge of the Traffic Circle. 

6. Click Apply. 

7. Select the Drape on Model/Object tool. (Site Modeler: Element > New/Edit > Drape on 
Model/Object). 

 

8. Enter the Drape on Model/Object information 

Drape on Object RAB1 

Drape Option Vertices 
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9. Click Select Element from the Define Elements group box. 

Select all of the curb return elements that are shown in heavy weight below. 
 

Select these 
elements.  

 

10.  Click Apply.  

: Redefine the Curb Return Elements using Edit Profile 

The GEOPAK Site Modeler Edit Profile tool is a very powerful design tool. It allows the User to 
redefine any existing Site Element or series of Site Elements by creating a Profile view of the elements 
and then using Vertical Component tools to modify the elevations. 

1. Access the Active Site Profile tool frame (Site Modeler Menu: Elements>Edit Profile). 

 

 
Profile Cell Status 

 
Identify Site Element Chain 

 
Vertical Component Tools 

 
Define Site Element Profile 

 
Curvilinear Coordinates 

 
Fit View Buttons 

  
2. Turn on View 2. (MS:  Windows > View 2). 

3. Use the Zoom/Window Area (MS: View Controls). 

Find a clear drawing space to place the Element Profile. 
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4. Right click Profile Cell Status  and select Profile Cell Setting. 

 

 

 

Select Element 

 

Change Direction 

 

Delete Selection Set 

 

Place Site PCell (Profile Cell) 

 

5. Enter the Site Profile Cell Settings information. 

Station 0.0 

Elevation 6240.0 

Horizontal Scale 10.0 

Vertical Scale 1.0 

Cell Range: Top Delta 60.0 

Cell Range: Bottom Delta 0.0 

6. Click Add Element PCell Chain.  

7. Select all of the edge of pavement elements shown in heavy line weight below. 

 

Hint Each element needs to be selected and accepted. When the elements are correctly selected, 
they will highlight with a series of light blue dots over the element. 

8. Click Place Site PCell. 

9. Place the profile cell in a clear area of the previously opened view window 2. 
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10.  On the Active Profile Control tool frame, right click on View 2 and set it to Profile. 

Hint This will synchronize between Plan and Profile views. 

11.  Click Vertical Component Tools. (Active Profile Control tool frame).. 

 

Use the Vertical Component tools to redefine the portions of the current profile where 
required.  

Warning Follow your instructor. There will be a discussion on what portions of this profile need to be 
redefined and what portions must not be modified. 

After the proposed vertical components have been added to the Profile, we need to return this 
new vertical information back to the Site Elements. 

12.  Click Define Site Element Profile (Active Profile Control tool frame). 

13.  Select and accept any proposed profile element. 

This strings all of the profile elements together. 

14.  Data point to accept the proposed profile. 

The profile information is now returned to the Site Element. The Profile element redraws to 
reflect the new state of the Site Element. 

We shall redefine the other five (5) curb returns using the same steps. 
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ADD CURB AND GUTTER SECTION TO CURB RETURNS 
The curb returns have been defined to ensure a smooth pavement surface within the intersection.  We 
now need to add the missing pieces of curb and gutter to the curb return elements. 

: Add Curb and Gutter Section 

1. Select the Section tool (Site Modeler: Elements > New/Edit > Section). 

 

2. Enter the Section information. 

OFFSET 
DISTANCE OFFSET ELEVATION PAY ITEM 

1.500 -0.200 PayItem > Plan > CURBING > Gutter 

1.600 0.500 PayItem > Plan > CURBING > CTF 

2.000 0.500 PayItem > Plan > CURBING > CTB 

 

3. Set the Feature Type to Boundary. 

4. Click Select Reference Elements from the Reference Elements group box. 

5. Select the eight (8) previously defined edge of pavement Site Elements. 

6. Click Set. 

7. Move the cursor into the graphics. 

Note There is a dynamic graphic that is attached to the selected elements. GEOPAK is waiting for 
the User to set the positive horizontal (offset) direction for the section elements. 

8. Click outside of the selected graphics (so the positive direction is to the outside of the edge of 
pavement). 

9. Click Apply. 

We have added the curb and gutter to the curb returns.  

: Saving and Exiting the Project 

1. Close GEOPAK Site Modeler (Site Modeler: Project>Exit). 

2. Click Yes to the Save alert. 

3. Click No to the Lock Elements alert. 
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6 
CHAPTER OBJECTIVES 

In this chapter we will: 

• create the complex traffic circle center island. 

INTRODUCTION 
In Chapter 2 we originally defined the inside edge of the traffic circle. This was a temporary (and fast) 
method to give us a visual indication of what a 2% pavement slope would look like. 

We now need to create the more complex median/island arrangement that was requested by the client.  

TOOLS TO BE USED 

The tools we will use in this chapter are: 

• Site Modeler>Elements>New/Edit>Section. 

• Site Modeler>Elements>Composite Section. 

CREATE THE CENTER ISLAND 

: Open the Site Project 

Note To ensure that all students have the same data, we are using another dataset. 

1. Open the file C:\Data\Geo\Site\Roundabout\Chapter6\LHSRAB.dgn (MicroStation: 
File>Open). 

2. Select the Site Modeler tool (Applications > GEOPAK Site > Site Modeler > Site Modeling).    

 

3. Click Browse. 

4. Navigate to and select the file C:\Data\Geo\Site\Roundabout\Chapter6\LHSRAB.gsf.    

5. Click OK. 
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: Remove the Inside Traffic Circle Element 

1. Select the Section tool (Site Modeler: Elements > New/Edit>Section). 

Note The inside element of the traffic circle was created as a GEOPAK Site section element. To 
remove this element we use the Section tool. 

 

 

2. Click Select Reference Elements from the Reference Elements group box. 

3. Select and accept the outside edge of the traffic circle. 

4. Click Delete Section from the Manipulate Section group box. 

The section element is removed and the intersections re-triangulated. 
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: Create the Complex Center Traffic Island 

1. Select the Composite Section tool (Elements>Composite Section). 

 

2. Open the file C:\Data\Geo\Site\Roundabout\Chapter6\RABCenterIsland.sec (File>Open).    

This will populate the Composite Section tool with all of the elements required for the traffic 
island.  The inside of the traffic circle has 2 pavement areas and 2 different types of curbing. 

The first row of the dialog creates the first pavement edge. The pavement is 15 feet wide at a 
pavement slope of 2% (shown in the dialog above). 
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The second row creates the first of the curbing sections. 

 

The “gutter” portion of this section is actually created at the same slope as the adjacent 
pavement (2%). Then there is a curbing. 
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The third row creates the second pavement surface – in the finished intersection this will be a 
concrete pavement. 

 

 

This pavement is also at a 2% slope but note that the elevations for this pavement edge will be 
based on the adjacent element rather than the primary element. 

In effect, the edge of pavement elevations will be calculated from the top back of the curb. 
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The forth row creates the second of the curb and gutter sections. 

 

This section also has a positive slope on the gutter section, thus forcing all surface water 
towards the outside of the traffic circle.  

Note Draining water to the outside of the traffic circle is a typical design arrangement for this type of 
intersection. While it means that the circulating traffic have an adverse cross slope to 
maneuver, it does prevents ponding at the center island.  If the cross slope falls towards the 
center island and the drainage inlets become blocked, the drainage runoff could pond 
(submerge) the entire intersection before it would drain away. 

3. Click ID Element from the Primary Element Definition group box. 

4. Select the outside edge of the traffic circle. 

5. Click Apply. 

: Saving and Exiting the Project 

1. Close GEOPAK Site Modeler (Site Modeler: Project>Exit). 

2. Click Yes to the Save alert. 

3. Click No to the Lock Elements alert.  
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7 
CHAPTER OBJECTIVES 

In this chapter we will: 

• Create the median islands for the incoming roadways. 

INTRODUCTION 
The only portion of the project that has not been modeled is the traffic medians/islands.  

These will now be created.   

TOOLS TO BE USED 
The tools we will use in this chapter are: 

• Site Modeler > Elements > New/Edit > Drape on Model/Object. 

• Site Modeler > Elements > Section. 

 

: Open the Site Project 

Note To ensure that all students have the same data, we are using another dataset. 

1. Open the file C:\Data\Geo\Site\Roundabout\Chapter7\LHSRAB.dgn (MicroStation: 
File>Open). 

2. Select the Site Modeler tool (Applications > GEOPAK Site > Site Modeler > Site Modeling).   

 

3. Click Browse. 

4. Navigate to and select the file C:\Data\Geo\Site\Roundabout\Chapter7\LHSRAB.gsf.    

5. Click OK. 
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CREATING A MEDIAN 

: Create a Median Object 

1. Select the Create New Object tool (Site Modeler menu: Object > New). 

 

2. Enter the New Object information. 

Object Type Median 

Object Name Median1 

Add to Active Model Enable 

3. Click OK. 

: Drape Outside of Median onto the RAB Object 

1. Select the New / Edit Element tool (Site Modeler menu: Element > New/ Edit). 

2. Click Drape on Model/Object on the Elements tab. 

 

3. Enter the Element information. 

Feature Type Boundary 

Drape on Object RAB1 

Offset Height Disable 

Drape Option Entire Element 

Use Drape Association Enable 

Use Power Selector Enable 

Redefine Site element Enable 

4. Click Select Elements in the Define Elements group box. 

5. Select the purple graphic that represents the outside edge of one of the Medians. 

6. Click Apply. 
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: Add a Section to the Median Object 

1. Select the Section tool. 

 

2. Modify the Section information. 

OFFSET DISTANCE OFFSET ELEVATION PAY ITEM 

0.200 0.500 PayItem > Plan > CURBING > CTF 

0.600 0.500 PayItem > Plan > CURBING > CTB 

 

3. Set the Feature Type to Breakline. 

4. Click Select Reference Elements from the Reference Elements group box. 

5. Select and accept the edge of median element that was created in the previous step. 

6. Click Set. 

7. Move the cursor into the graphics. 

8. Click inside of the selected graphics (so the positive direction is to the inside of the median 
edge). 

9. Click Apply. 

This completes the creation of the first of the four (4) medians. 

: Create remaining Medians.  

1. Create the other 3 medians using the same process. 

This completes our intersection. 



 



 




