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GEOPAK Corridor Modeling 

Overview 

This course teaches the Corridor Modeling workflow which includes the Create Templates 

and Roadway Designer applications. The user will import GEOPAK data into the Corridor 

Modeling application and then proceed to design, create and then cut/label cross sections 

from the finished model. 

Prerequisites 

 Working knowledge of Microsoft Windows operating system 

 Experience in Road Design 

 Working knowledge of MicroStation functionality equivalent to the topics taught in the 

Bentley Institute Essentials MicroStation or Moving to MicroStation courses. 

 Working knowledge of GEOPAK functionality equivalent to the topics taught in the 

Bentley Institute GEOPAK Road 1 course. 

Objectives 

After completing this course, you will be able to: 

 Access Corridor Modeling 

 Change Preferences  

 Import DDB features 

 Import GEOPAK TINs 

 Import Geometry 

 Import Plan Graphics – Using Symbology 

 Import Plan Graphics – Using Selection Set 

 Understand Smart Update 



Objectives 
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 Access Create Templates 

 Create a Template 

 Access Roadway Designer 

 Create a Corridor 

 Assign Template Drops 

 Display References 

 Assign Key Stations 

 Import Superelevation 

 Apply End Condition Exceptions 

 Create a Surface 

 Use Drive Roadway 

 Cut Proposed Cross Sections 

 Label Proposed Cross Sections 
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Access Corridor Modeling 

Before we can begin, let’s make sure everyone knows where and how to access the Corridor 

Modeling application. 

 

 Open Design File 

1. Open the file Plan.dgn.  

 

 Activate GEOPAK 

1. If GEOPAK is not already activated, select Applications > Bentley Civil > Activate 

Bentley Civil. 

 

 Activate Corridor Modeling 

1. Select Applications > Road > 3D Tools > Corridor Modeling. 

2. The Corridor Modeling application should now be open and available for use. 

Note: The Corridor Modeling application is also available from the Road Tools Palette 

under the 3D Tools option. 

 

3. Open Windows Explorer and review the project directory. Note the creation of a new 

subdirectory /rddbs. 

Note: This subdirectory is where files are created that are needed exclusively by the 

Corridor Modeling application. 

 

 Select GPK File 

1. Using the Select GPK File icon, select job314.gpk. 
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Change Preferences 

There are several preferences on the Corridor Modeling dialog that are specific to it’s use. In 

this exercise, we’ll review and change these preferences. 

 

 Access Preferences 

1. Select the Preferences tree option on the left of the dialog. 

 

 Change and Review Preferences 

1. Change the Station Lock to Even. 

2. Review the other Preferences options. 

Note: GEOPAK delivers a template library (default.itl) in the /bin directory that is 

being used for this course. If you want to use a different template library, you can 

point to it using the GPK_RD_TEMPLATE_LIBRARY configuration variable. 
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Import DDB Features 

As we move through the Corridor Modeling application, we’ll want to be able to use DDB 

features to control symbologies. This exercise teaches how to import ddb features into the 

Corridor Modeling application. 

 

 Import DDB Features 

1. Select the DDB tree option on the left of the dialog. 

2. The dialog should change and show you which DDB database is being used. 

Note: GEOPAK delivers a default_styles.ddb file in the /bin directory that is being used 

for this course. If you want to use a different DDB file, you can point to it using 

the GPK_ACBOOK_DDBFILE_STYLES configuration variable. 

3. Click the Import button. 

Any Drafting Standard in the DDB will be imported and you should get an information 

dialog stating as much. 

4. Dismiss the Information dialog. 

5. Open Windows Explorer and navigate to the /rddbs subdirectory previously created 

within the project. 

You should see a new file (default_styles.xin) has been created. 

Note: This file is needed exclusively by the Corridor Modeling application. It should 

not be deleted. 
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Import GEOPAK TINs 

In order to use a GEOPAK TIN in the Corridor Modeling application, it has to be imported. 

This importation process will result in the creation of a new file with a .DTM extension. This 

exercise teaches how to import TIN files. 

 

 Import TIN File 

1. Select the DTM  tree option on the left of the dialog. 

2. Use the Select Tin File icon to select the tin file fm314-dtm.tin. 

3. Use the Add Tin to List icon to add the selected tin file to the list box. 

Note: You are not limited to importing one tin file at a time. You can add multiple tin 

file names to the list box and they can all be imported simultaneously. 

4. Click the Import button. 

After a few seconds of processing, you should see an information dialog stating that the 

tin file has been imported. 

5. Dismiss the Information dialog. 

6. Go to Windows Explorer and review the project directory.  

You should see a new file has been created fm314-dtm.dtm. 

Note: When the TIN file is imported,a new file is created with the same name as the 

original tin, only using a .dtm extension. 
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Import Geometry 

We have chains and profiles in our GPK file that need to be imported into the Corridor 

Modeling application in order to use them. This exercise teaches how to select and import 

geometry data from the GPK. 

 

 Import Geometry 

1. Select the Geometry tree option on the left of the dialog. 

2. From the Chain combo box, select the chain BASE. 

3. From the Drafting Standard combo box, select Centerline. 

Note: The names in the Drafting Standard list are the same ones that we imported from 

the DDB in a previous exercise. 

4. In the Profile(s) list box, use the Shift or CTRL keys to select BOTH the Exist and 

Proposed profiles. 

5. Click the Add Chain to List icon to add the Chain and Profiles to the list box. 

6. Click the Import button. 

You should see an information dialog stating that the geometry has been imported. 

7. Dismiss the Information dialog. 

8. Open Windows Explorer and navigate to the /rddbs subdirectory previously created 

within the project. 

You should see a new file (cmjob314.alg) has been created. 

Note: This file is needed exclusively by the Corridor Modeling application. It should 

not be deleted. 
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Import Plan Graphics – Using Symbology 

Roadway Designer does not read plan graphics. So in order to make Roadway Designer 

aware of our plan graphics, we need to import them into the Corridor Modeling application.  

When we import the plan graphics, they are stored in the /rddbs subdirectory in the .alg file. 

Once they are in the .alg file, they can be accessed by the Create Templates and Roadway 

Designer applications. Templates can be used to target the alignment names or they can target 

the style/drafting standard of the alignment. 

This exercise teaches how import graphical elements by specifying the symbology of the 

graphical elements. 

 

 Specify Search Symbology for Edge of Pavement 

1. Select the Plan Graphics tree option on the left of the dialog. 

2. Next to the Symbology combo, click on the graphic icon to access the Element Symbology 

dialog. 

 

3. On the Element Symbology dialog, enable the Lv Names toggle. 

4. Use the Match button and select one of the dark blue lines (edge of pavement) in the 

design file. 

The level name D_EOT_1 should be placed in the Lv Names field. 

Note: You could have also used the Select Levels icon on the dialog to manually select 

the level name. Or you could have just typed it in.  

5. Click the Display button on the Element Symbology dialog. 

Both edges of pavement (dark blue lines) should hilite. 

6. Click the Undisplay button on the Element Symbology dialog. 

7. Close the Element Symbology dialog. 

 

 Specifying the Left Edge of Pavement 

1. From the Chain combo box, select the chain BASE. 

2. In the New Chain Name field, enter the name LEFT_EOP. 

3. From the Drafting Standard combo box, select Pavement Outside Edge. 
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Import Plan Graphics – Using Symbology (cont). 

4. Set the Side option to L.  

5. Set the Begin Offset = 0 and the End Offset = 100. 

6. Click the Add Search Criteria to List icon to add the item to the list box. 

 

 Specifying the Right Edge of Pavement 

1. In the New Chain Name field, enter the name RIGHT_EOP. 

2. Set the Side option to R.  

3. Click the Add Search Criteria to List icon to add the item to the list box. 
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Import Plan Graphics – Using Selection Set 

In the previous exercise we learned how to import plan graphics by searching for a particular 

graphical symbology within a specified search “window”. However, there are times when 

graphical elements don’t fall nicely into such a “window”. This exercise will show you how 

to handle cases like this by manually specifying the elements to be imported using a 

MicroStation Selection Set. 

 

 Specifying a Selection Set  

1. Change the option on the dialog from Symbology to Selection Set. 

 

2. In the New Chain Name field, enter the name WALL. 

3. From the Drafting Standard combo box, select Wall. 

4. In your design file view, there should be 3 light blue lines representing a retaining wall. 

Place these 3 light blue lines into a MicroStation Selection Set. 

5. Click the Add Search Criteria to List icon to add the item to the list box. 

6. Clear the MicroStation Selection Set. 

 

 Importing the Plan Graphics  

1. Click the Import button. 

After a few seconds of  processing, you should see an information dialog stating that 5 

chains have been successfully stored. 

2. Dismiss the Information dialog. 

 

 Saving the Dialog Settings 

1. Close the Corridor Modeling dialog. 

You will receive an Alert dialog prompting you to Save Settings. 

2. Click Yes on the Alert dialog. 

3. Key-in a name (e.g. MyProject.rdp) for your settings file and click Save. 

4. Close the Information dialog stating that your settings have been saved. 
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Understanding Smart Update 

In our previous exercises, we have imported both geometric and graphical data into the 

Corridor Modeling application. However, the data in the geometry database as well as our 

graphical data has a tendency to change throughout the life of a project. With that in mind, we 

need some way to keep our data in synch. This exercise will show how a functionality called 

Smart Update does just that. 

 

 Modifying Geometric Data  

1. Open Coordinate Geometry using job 314 and the operator code dg. 

2. Select File > Input File Utility. 

You should see the file “prof” listed in the dialog. 

3. Select the file name listed in the dialog then click the Apply button on the Input File 

Utility dialog. 

This will load the input file commands into the COGO window. 

4. Close the Input File Utility dialog. 

5. Enable the toggle for Redefine. 

 

6. Select Edit > Read All. 

This will update the Proposed profile. 

7. Exit Coordinate Geometry. 

 

 Modifying Graphical Data  

1. In the design file, delete the 3 light blue lines that represent our retaining wall. 

 

 Geometry - Smart Update  

1. Access Corridor Modeling. 

2. Select the Geometry tree option on the left of the dialog. 

Note: The profiles are now listed in BLUE. When something is denoted with the color 

BLUE it means that it has been modified. In this case, the Proposed profile has 

been changed in the geometry database and is out of synch with the geometry 

data that was previously imported. 
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Understanding Smart Update (cont.) 

3. Click the Import button. 

You should see an information dialog stating that the geometry has been updated. 

4. Dismiss the Information dialog. 

Note: The profiles are now listed in BLACK, denoting that the geometry database and 

the imported geometry are now in synch. 

 

 Plan Graphics - Smart Update  

1. Select the Plan Graphics tree option on the left of the dialog. 

Note: The wall item is now listed in RED. When something is denoted with the color 

RED it means that it has been DELETED. In this case, the graphical elements 

that were used to import the wall have been deleted, so the design file data is out 

of synch with the Corridor Modeling application. 

2. Select the wall item in the list box. 

3. Click on the Delete Search Criteria of Selected Row icon. 

 

You will be prompted with an Alert dialog to make sure you want to remove the 

previously imported data.  

4. Click the Yes button on the Alert dialog. 

Note: The wall item is removed from the list box AND it is also removed from the .alg 

file in the /rddbs subdirectory. 
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Summary and Review 

Summary 

You are now able to: 

 Access Corridor Modeling 

 Change Preferences 

 Import DDB Features 

 Import GEOPAK TINs 

 Import Geometry 

 Import Plan Graphics – Using Symbology 

 Import Plan Graphics – Using Selection Sets 

 Understand Smart Update 

Questions 

1. How many ways are there to access the Corridor Modeling application? 

2. What is the name of the subdirectory that is created when the Corridor Modeling 

application is first opened? 

A  -  \prjdbs 

B  -  \rddbs 

C  -  \cmdbs 

1. What is the name of the configuration variable that is used to specify which template 

library is to be used by the Corridor Modeling application? ______________________ 

2. What is the name of the configuration variable that is used to specify which DDB file is 

to be used by the Corridor Modeling application? ______________________________ 

3. When I import a DDB, all items in the DDB are imported. 

 True 

 False 

4. Only one TIN file at a time can be imported. 

 True 

 False 
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5. If I were to import geometry from job999.gpk, what would be the name of the resulting 

file that is created in the /rddbs subdirectory? _________________________________ 

6. When you save a Corridor Modeling settings file, what extension is it given? _______ 

7. When an item in Geometry or Plan Graphics is shown in blue, that means the item has 

been modified.  

 True 

 False 
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Summary and Review (cont.) 

Answers 

1. How many ways are there to access the Corridor Modeling application? 

2  -  The Applications pulldown and the Road Tools Palette. 

2. What is the name of the subdirectory that is created when the Corridor Modeling 

application is first opened? 

B  -  \rddbs 

3. What is the name of the configuration variable that is used to specify which template 

library is to be used by the Corridor Modeling application?  

GPK_RD_TEMPLATE_LIBRARY 

4. What is the name of the configuration variable that is used to specify which DDB file is 

to be used by the Corridor Modeling application?  

GPK_ACBOOK_DDBFILE_STYLES 

5. When I import a DDB, all items in the DDB are imported. 

False – Only the Drafting Standards items are imported. 

6. Only one TIN file at a time can be imported. 

False – Multiple TIN files can be imported simultaneously. 

7. If I were to import geometry from job999.gpk, what would be the name of the resulting 

file that is created in the /rddbs subdirectory?  

cmjob999.alg 

8. When you save a Corridor Modeling settings file, what extension is it given? 

.rdp 

9. When an item in Geometry or Plan Graphics is shown in blue, that means the item has 

been modified.  

True – blue means modified/changed while red indicates it’s been deleted. 
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Access Create Templates 

Now that we’ve imported all of our data into the Corridor Modeling application, we’re ready 

to begin our work with templates. This exercises teaches how to access the Create Templates 

application. 

 

 Access Create Templates  

1. From the Corridor Modeling dialog, click on the Open Create Template icon. 

 

Note: The application is opened using the default.itl file delivered with GEOPAK in the 

/bin directory. Remember this is controlled with the setting in the Corridor 

Modeling preferences. 

2. Double-click on the template library name to expand the view to see the Components, 

End Conditions and Templates folders. 
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Create a Template 

There is a lot to know when it comes to creating templates. A user may want to start from 

“scratch” and create their own components, or they may want to assemble a template from 

previously created components. Because of time limitations, this exercise will take a look at 

the second option and explain how to create a template by using previously created 

components. 

 Create a New Template  

1. Right-Click on the Templates folder and select New > Template. 

2. Key-in the template name Workshop. 

 

 Template Options  

1. Enable the Template Options dialog using Tools > Options. 

2. Enable the Apply Affixes option. 

3. Key-in a suffix of _L for the Left and _R for the Right. 

 

4. Click OK to close the Template Options dialog. 

 

 Enable Dynamic Settings  

1. Enable the Dynamic Settings dialog using Tools > Dynamic Settings. 

Note: There is also a small icon at the bottom of the template view that can be used to 

enable and disable this dialog. 

 

2. In the Dynamic Settings dialog, set both Step fields to 0.1. 

 

 Drag and Drop Pavement Component  

1. Navigate to the Components > Pavement folder. 

2. Select 12’ Travel Lane component and drag it into the template view. 
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Create a Template (cont.) 

3. With the component still attached to your cursor, right-click to access the template 

placement options. 

4. Release your left mouse button. Select Mirror using a left-click. 

5. Move your mouse to the Dynamic Origin location (0,0) and drop the components. 

6. Fit the view. 

 

 Merging Components 

1. Select the middle blue line that connects both the left and right asphalt pavement 

components. 

2. Right-click and select Merge Components. 

3. Repeat the process for both the Base (red) and Aggregate (yellow) components. 

 

 Drag and Drop Curb Component  

1. Navigate to the Components > Curb Gutter and Sidewalk > Curb folder. 

2. Select the component 30” C&G 6” Curb and drag it into the template view. 

3. Move your cursor to the point name EP_R and drop the component. 

4. Fit the view. 

 

 Drag and Drop End Condition  

1. Navigate to the End Conditions folder. 

2. Select the End Condition 4:1 Cut/Fill and drag it into the template view. 

3. Move the cursor to the point name BC_R and drop the end condition. 

4. Fit the view. 

 

 Exit and Save 

1. Click the Close button to exit the Create Template application. 

2. When prompted, click Yes to save the changes to the template library. 
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Access Roadway Designer 

In the next few exercises, we’ll be taking a look at the different functionalities of Roadway 

Designer. We’ll start with this simple exercise that shows how to access the application. 

 

 Access Roadway Designer  

1. In the design file, change the model from DEFAULT to 3D MODEL VIEWS. 

2. From the Corridor Modeling dialog, click on the Open Roadway Designer icon. 

 

Note: In the lower left corner of the application, you’ll see the option for selecting an 

Active Surface. There you’ll also see the previously imported surface fm314-dtm 

listed. In order for a surface to be listed here in Roadway Designer, it MUST be 

listed in the Corridor Modeling  Import Tin list box. 
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Create a Corridor 

When using Roadway Designer, we always begin by creating our corridor. A corridor is just a 

name we give to a specific chain and profile combination that we want to design along. We 

can have a single corridor or multiple corridors for our project. This exercise shows what is 

involved in creating a corridor. 

 

 Accessing Corridor Management   

1. Select Corridor > Corridor Management. 

Note: The Manage Corridors dialog can also be accessed via the use of an icon 

positioned along the top portion of the Roadway Designer application. 

 

2. Key-in the name WS1 for the name of the corridor. 

3. Select the Horizontal Alignment BASE and the Vertical Alignment PROPOSED. 

4. Click the Add button to add the corridor to the list box. 

5. Close the Corridor Management dialog. 

Note: The Roadway Designer is divided into 3 views: Plan, Profile and Cross Section. 

You should now see your plan and profile displayed. 

6. Fit the view in either the Plan or Profile views.  
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Template Drops 

Now that we have our corridor created, we are ready to apply templates.  

When we apply a template to a corridor, we specify a beginning station at which to begin the 

template and then give an interval. The interval we use is very important. When determining 

an interval, we want to keep in mind the interval that we will use to cut our proposed cross 

sections. 

You never want to cut a final proposed cross section at a location where you did not have a 

section in Roadway Designer. To facilitate this, always make sure that the interval of your 

final proposed cross sections is divisible by the interval used in Roadway Designer. 

For example, let’s say in Roadway Designer that we use an interval of 10’. So we would have 

cross sections at 100+00, 100+10, 100+20, etc.. When we cut our final proposed cross 

sections, an interval of 5, 10, or 20 would work fine because any of these intervals would 

generate sections that also exist in Roadway Designer. But if we tried to use a final cross 

section interval of 25 we would end up with cross sections (e.g. 100+25, 100+75) at locations 

that did not exist in Roadway Designer.  

We can apply single or multiple templates along our corridor. The process is simple, as we’ll 

see through this exercise. 

 

 Template Drops   

1. Select Corridor > Template Drops. 

Note: The Template Drops dialog can also be accessed via the use of an icon 

positioned along the top portion of the Roadway Designer application. 

 

2. Double-click on the template library name to expand it. 

3. Double-click on the Templates folder. 

4. Select the template Workshop that we created previously. 

5. Click the Add button to add the template to the list box. 

6. Close the Template Drops dialog. 

7. Review several of the cross sections.  
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Display References 

There are times that we may want to display alignments on our cross sections for review 

purposes. For example, we may want to make sure that our templates are properly following 

our edge of pavement alignments, or make sure that our toe of slopes are falling within our 

right of way limits. To do this, there is a tool called Display References. This exercise will 

review how to access and use this application. 

 

 Access Display References   

1. Select Corridor > Display References. 

Note: The Display References dialog can also be accessed via the use of an icon 

positioned along the top portion of the Roadway Designer application. 

 

 

 Using Display References   

1. From the Display References dialog, select the alignment Left_EOP. 

Note: This is one of the plan graphics that we imported earlier. 

2. Enable the Display as Right of Way toggle. 

3. Click the Add button to add the entry to the list box. 

4. Select the alignment Right_EOP. 

5. Click the Add button to add the entry to the list box. 

6. Close the Display References dialog. 

7. Review the references displayed in the cross section view. 

 

 

 

 

 

 

 



 Critical Stations 

 

Nov-08 25 GEOPAK Corridor Modeling 

Copyright © 2008 Bentley Systems Incorporated 

 

Critical Stations 

When we applied our templates earlier, we applied them at a particular interval. But in order 

to get the most accurate model possible, we will need sections at other locations. Critical 

Stations allows us to automatically generate sections at the horizontal and vertical control 

points of our alignments and profiles. This exercise explains how to access and use this 

functionality. 

 

 Access Critical Stations  

1. Select Tools > Options. 

This will open the Roadway Designer Options dialog. 

 

 Enable Critical Stations  

1. Under the section of the dialog entitled Include Critical Sections, enable the toggles for 

the following options: 

Horizontal Cardinal Points 

Vertical Cardinal Points 

External Control Points 

2. Click OK to close the Roadway Designer Options dialog. 

3. Review the cross sections in Roadway Designer. Notice that new sections are generated 

at Stations 75+62.30, 78+62.30, 78+91.20, etc.. 
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Key Stations 

So far we have sections at a specified interval as well as the Critical Stations we enabled in 

the previous exercise. However, our goal is to generate an accurate model, and to do that the 

need may arise to cut sections at odd locations, or what are called “key stations”. This 

exercise shows you how to force the Roadway Designer to cut sections wherever the user 

deems necessary. 

 

 Using Key Stations   

1. Review your cross sections and note that there is no section at 79+20. 

2. Select Corridor > Key Stations. 

3. In the Station field of the Key Stations dialog, key-in 79+20. 

4. Click Add to add the stations to the list box. 

5. Click Close to dismiss the Key Stations dialog. 

6. Review the cross sections and note the creation of a station at 79+20. 

Note: An easier way to have done the same thing is to just key-in the desired station 

directly on the cross section view dialog. Keep in mind that when you enter a 

station this way you must use the TAB key to accept the entry. 
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Import Superelevation 

Now that we have assigned our template drops along the corridor, we are ready to apply 

superelevation to the template. Even though Roadway Designer has its own superelevation 

preferences and calculation methods, you can also import your superelevation directly from a 

GEOPAK shape input file. This allows the user to continue to use the GEOPAK 

superelevation preferences and workflows. This exercise explains how this process works. 

 

 Import the Shape Input File  

1. In the cross section view, navigate to Station 293+00. 

2. Select Superelevation > Import Superelevation from INP file. 

3. Key-in a Section name (this can by anything). 

4. From the project directory, select the file shape.inp. 

5. Click Apply. 

Note: In the cross section view the superelevation has been applied. 

6. Click Cancel to close the Import Superelevation from INP File dialog.  
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End Condition Exceptions 

Before we create our surface, we have a problem that we need to address. If you review your 

sections from 122+98.20  through 126+50, you’ll notice that the end condition was unable to 

solve on the left side for several of the sections. In other words, it just wasn’t possible to 

place a 4:1 slope. This exercise will explain how to address an issue like that using the End 

Condition Exceptions dialog. 

 

 Creating an End Condition Exception. 

1. Navigate to the cross section at Station 122+98.20. 

Note: The cross section is missing the End Condition on the left side. This also occurs 

at other stations in this general area. 

2. Select Corridor > End Condition Exceptions. 

Note: The End Condition Exceptions dialog can also be accessed via the use of an icon 

positioned along the top portion of the Roadway Designer application. 

 

3. Change the Start and Stop stations as shown. 

Start: 122+98.20 

Stop: 126+50.00 

4. Click Add in order to add the station range to the list box. 

 

 Adding the End Condition 

1. At the bottom of the End Condition Exceptions dialog, click Edit. 

2. In the template library, navigate to the Components > Walls and Barriers folder. 

3. Select the component Retaining Wall and drag it into the template view. 

4. With the component still attached to your cursor, right-click to access the template 

placement options. 

5. Release your left mouse button. Select Mirror using a left-click in order to disable that 

option. 

6. Move your mouse to the back of the left curb and drop the component. 

7. Fit the view. 

8. Click OK to close the dialog. 
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End Condition Exceptions (cont.) 

 Review 

1. Close the End Condition Exceptions dialog. 

2. Review the cross sections from 122+98.20 through 126+50 to see that the wall has 

been added.  
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Create a Surface 

At this point we are ready to create a surface. Remember that the surface will be created from 

the sections that we’ve generated, so it’s important that we’ve created sections at all critical 

locations in order to create an accurate model. This exercise will explain how a surface is 

created and review some of the options that a user has when creating a surface. 

 

 Access the Create Surface dialog  

1. Select Corridor > Create Surface. 

Note: The Create Surface dialog can also be accessed via the use of an icon positioned 

along the top portion of the Roadway Designer application. 

 

 

 Choosing Options  

1. Enable the toggle for New Surface for Each Corridor. 

2. Enable the toggle for Densify Horizontal Curves using Chord Height Tolerance. 

Note: Chord Height Tolerance was one of our preference options on the Corridor 

Modeling dialog. 

3. Enable the toggle for Add Transverse Features. 

4. Set the style for the Transverse Features to Miscellaneous. 

Note: The style is the same as a drafting standard. 

5. Enable the toggle for Display Features in Plan View. 

 

 Create the Surface  

1. Click Apply. 

2. When the surface creation is complete, close the Results dialog. 

3. Close the Create Surface dialog. 
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Create Surface (cont.) 

 Saving the .IRD file 

1. Click the Close button in order to close out Roadway Designer. 

2. When prompted to save your data, click Yes. 

3. Save the file MyProject.ird. 

 

 Reviewing Data 

1. Review the plan features that were drawn when we created the surface. 

2. Open Windows Explorer and note the creation of two files in the project directory: 

WS1.dtm 

WS1.xml 

Note: The .xml file is created for the user automatically, in case there is a need to 

import the surface and create a GEOPAK TIN file. 
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Drive Roadway 

Now that we have created our surface and we have the plan features of that surface drawn in 

plan view, we can use the Drive Roadway application to help us review the model. This 

exercise details how to use this simple tool. 

 

 Using Drive Roadway  

1. From the Corridor Modeling dialog, click on the Drive Roadway icon. 

 

2. Minimize the Corridor Modeling dialog to move it out of the way. 

3. Set the Vertical Alignment to PROPOSED. 

4. Set the Speed to 45. 

5. Set the Target Distance to 150. 

6. Click Run. 

After a few seconds, the view will update and the application will begin to drive down 

the model. 

Note: Once the application begins to drive down the roadway, you can quit at any time 

by pressing the <ESC> key. 

7. Close the Drive Roadway dialog. 
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Summary and Review 

Summary 

You are now able to: 

 Access Create Templates 

 Create a Template 

 Access Roadway Designer 

 Create a Corridor 

 Perform Template Drops 

 Display References 

 Enable Critical Stations 

 Assign Key Stations 

 Import Superelevation 

 Create a Surface 

 Drive the Roadway 

Questions 

1. What is the name of the template library that GEOPAK delivers _________________? 

2. Multiple corridors can be created for a single project. 

 True 

 False 

3. If I used an interval of 10 in Roadway Designer when applying my templates, which of 

the following would be an incorrect interval for my final proposed cross sections? 

A - 5 

B - 20 

C - 50 
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4. Where do we go in Roadway Designer if we want do display our alignments as 

references on the cross section? 

A - Critical Stations 

B - Corridor Management 

C - Display References 

5. If I want a section to occur at the VPC of one of my vertical curves, what dialog would I 

use to accomplish that? _______________________ 

6. I can import my superelevation directly from a GEOPAK shape input file. 

 True 

 False 

7. Where do I control my Chord Height Tolerance? 

A - Corridor Modeling Preferences 

B - Create Template Preferences 

C – Roadway Designer Preferences 

8. When I create a surface named TEST, what two files are created in my working 

directory? 

A – test.tin, test.xml 

B – test.dtm, test.xml 

C – test.dtm, test.tin 

9. What <ESC> key can be used to stop the Drive Roadway application as its processing.  

 True 

 False 

10. A Style is another name for what?  _______________________ 
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Summary and Review (cont.) 

Answers 

1. What is the name of the template library that GEOPAK delivers _________________? 

default.itl – This template library is delivered in the /bin directory. 

2. Multiple corridors can be created for a single project. 

True – You can create multiple corridors for a single project. 

3. If I used an interval of 10 in Roadway Designer when applying my templates, which of 

the following would be an incorrect interval for my final proposed cross sections? 

A – 5   

4. Where do we go in Roadway Designer if we want do display our alignments as 

references on the cross section? 

C - Display References 

5. If I want a section to occur at the VPC of one of my vertical curves, what dialog would I 

use to accomplish that? _______________________ 

Tools > Options 

6. I can import my superelevation directly from a GEOPAK shape input file. 

True – This can be done via Superelevation > Import Superelevation from INP file 

7. Where do I control my Chord Height Tolerance? 

A - Corridor Modeling Preferences 

8. When I create a surface named TEST, what two files are created in my working 

directory? 

B – test.dtm, test.xml 

9. The <ESC> key can be used to stop the Drive Roadway application as its processing.  

True 

10. A Style is another name for what?  _______________________ 

Drafting Standard 
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Cut Proposed Cross Sections 

Now that our surface has been created, we are ready to step back into our “normal” GEOPAK 

workflow. The first thing we need to do is to cut cross sections from our proposed model. 

This exercise will explain how to do this using the Draw Cross Sections application. 

 

 Switch Design Files  

1. Use the MicroStation File > Open pulldown to open the file xs.dgn. 

 

 XS Cells Tab  

1. From the Corridor Modeling dialog, click on the icon Draw Cross Sections from 

Surfaces. 

This will open the Draw Cross Sections application. 

2. Select Job Number 314 and Chain BASE. 

3. For the XS Cells tab, set the options as follows: 

By Station 

Begin Station 76+00 

End Station 200+00 

Even 100 

Left Offset 100 

Right Offset 100 

4. Leave all other options under the XS Cells tab the same. 

 

 Surfaces Tab  

1. Select the Surfaces tab. 

2. Change the selection option from Tin File to Dtm File. 

Note: This is a new option that has been added to the dialog to allow the user to cut 

sections from files with a .DTM extension. 

3. Select the existing DTM file fm314-dtm.dtm. 
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Cut Proposed Cross Sections (cont.) 

4. Set the Level Symbology as shown for the Existing Ground. 

 

5. Click the Add Surface icon in order to add the existing surface to the list box. 

6. Select the proposed surface WS1.dtm. 

7. Click the Add Surface icon in order to add the proposed surface to the list box. 

Note: Even though the previous existing ground symbology is added to the list box 

along with the proposed surface name, this is not a problem. When the sections 

are cut, the symbology of the proposed elements will come from the components 

themselves and the symbology in the list box will be ignored. 

 

 Process the Proposed Cross Sections 

1. Click Draw in order to process the sections. 

2. When processing is complete, close the Draw Cross Sections dialog. 

3. Use Cross Section Navigator to review the cross sections. 

Note: Notice that the component point names are placed on the cross sections as part 

of the process when the sections are cut from a proposed surface. These point 

names are placed using the active text symbology of the design file. 
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Label Proposed Cross Sections 

In our last exercise, we noticed that when we cut the proposed cross sections, the component 

point names are placed on the cross sections as part of the process. This exercise will explain 

how to use the point names in order to label our cross sections. 

 

 Cross Section Labeling 

1. From the Corridor Modeling dialog, click on the Cross Section Labeling icon in order to 

access the Cross Section Labeler application. 

 

2. Minimize the Corridor Modeling dialog to move it out of the way. 

3. From the Cross Section Labeling dialog, click on the Open an Existing Preference File 

icon. 

 

4. Select the preference file MyProject.xlp. 

5. Review the Slope Label tab. 

6. Review the Elev/Off Label tab. 

7. From the General Tab, make sure you stations are set as follows: 

Begin Station – 76+00 

End Station – 200+00 

8. From the General tab, click Draw Labels. 

9. Close the Cross Section Labeling dialog. 

10. Review the cross sections using XS Navigator. 
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Summary and Review 

Summary 

You are now able to: 

 Process Proposed Cross Sections 

 Label Proposed Cross Sections 

Questions 

1. In the Corridor Modeling workflow, what application is used to cut proposed cross 

sections? 

A  -  Process Cross Sections 

B  -  Draw Cross Sections 

C  -  Cross Section Labeler 

2. What new option has been added to the Draw Cross Sections dialog? 

A  -  Tin File 

B  -  Triangles File 

C  -  Dtm File 

3. The symbology of the proposed cross sections comes from the components. 

 True 

 False 

4. When the component point names are placed on the proposed cross sections, where does 

the text symbology come from? ______________________________ 

5. The Cross Section Labeling preference file uses what extension? 

A  -  .ird 

B  -  .xlp 

C  -  .xld 
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Summary and Review (cont.) 

Answers 

1. In the Corridor Modeling workflow, what application is used to cut proposed cross 

sections? 

B  -  Draw Cross Sections 

2. What new option has been added to the Draw Cross Sections dialog? 

C  -  Dtm File 

3. The symbology of the proposed cross sections comes from the components. 

 True 

4. When the component point names are placed on the proposed cross sections, where does 

the text symbology come from?  

Active Design File – It’s taken from the Active Design File text settings. 

5. The Cross Section Labeling preference file uses what extension? 

B  -  .xlp 

 

 

  


