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Lesson Name: Opening Project data. 

LESSON OBJECTIVE: 

In this lesson, the student shall load InRoads Project data  to examine point constraints in the template 

library.  Note this is for InRoads users, for GEOPAK users skip to the next lesson. 

EXERCISE: GETTING STARTED (INROADS USER) 

This exercise will guide you through the steps to get started 

1. Go to Start > Programs > Bentley > InRoads V8i (SELECTseries1) > InRoads Suite. 

2. The instructor will provide the appropriate path location for this project. When the 

MicroStation Manager appears select the file: 

Model.dgn and press Open. 

3. When the InRoads Explorer appears, go to File > Open from the InRoads menu. 

4. When the Open dialog appears select the InRoads project file:  

Project.rwk and press OK. 

Opening the RWK project file opens the following files: 

Civil.xin 

Existing.dtm 

Design.alg 

Point constraints.itl 

Design.ird 

5. Select Modeler > Create Template from the InRoads Explorer menu to access Create 

Template dialog.  

 
Lesson Name: Opening A Project (GEOPAK User) 

LESSON OBJECTIVE: 

In this lesson the student will learn to access a GEOPAK Corridor Modeler project in preparation for 

examining point constraints in the Create Template command.  Note, this lesson is for GEOPAK users 

only. 

 



© 2009 Bentley Systems, Incorporated    4 

EXERCISE: GETTING STARTED (GEOPAK USER) 

This exercise will guide you through the steps to get started 

1. Go to Start > Programs > Bentley > MicroStation V8i > Bentley MicroStation V8i 

(SELECTseries1). 

2. The instructor will provide the appropriate path location for this project. When the 

MicroStation Manager appears select the file: 

Model.dgn and press Open. 

3. Go to Applications > Road > 3D Tools > Corridor Modeling. 

4. Select the GPK job number 001 

5. Choose File > Load from the Corridor Modeling dialogue. 

6. Load the Corridor Modeler project file entitled Project.rdp. 

6. Choose the Create Template icon from the Corridor Modeling dialogue to access Create 

Template dialog.  

 

 

 

Lesson Name: Examining Point Constraints  

LESSON OBJECTIVE: 

In this lesson the student will examine point constraints in the Create Template command.   

EXERCISE: EXAMINING POINT CONSTRAINTS 

This exercise will familiarize you with the various point constraints defined within a template. 

7. Select the template and set active “h&s” from the root folder of the template library. 

8. Set the template display mode the Constraints 
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Note the change in behavior of the template grid display. 

9. Toggle the display type back to components. 

10. Select the template “V-maximum” and set active 

 

 

 

11. Select points A or B and right click menu Move the point(s). Note the behavior of child point 

C. 

12. Select template “Vector Offset”. 

13. Select point D and right click menu Move the point. Note the behavior of child F. 

14. Select the “Angle distance” template and repeat the process of analyzing the constraint 

behavior. 
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Lesson Name: Basic Point Constraints  

 
 

EXERCISE: BASIC CONSTRAINTS 

Constraints are used to control the relationships between points. These relationships are one-way in that if a 

point is constrained to another point (the parent point).  Moving the parent point will affect the child point, but 

moving the child will not affect the parent.  A point can have only one or two constraints applied to it.  A point 

with two constraints applied is said to be fully constrained.   

The real power of constraints will not be fully appreciated until we get to adding Horizontal and Vertical controls 

in the Roadway Designer. 

Let’s examine the different types of basic constraints. 

15. Create a new template and place a 3 point Unconstrained Component. 

16. Toggle the display to Display Constraints using the radio button at the top of the dialog box. 

17. Right click over any one of the points and select Add Constraint\Horizontal.  A prompt will 
show up at the bottom of the dialog box telling you to select a parent point.  Go ahead and 
select one of the other points. 

Hint As soon as you select the parent point, a dialog box pops up to allow you to set 
the horizontal offset from the parent point to the child point.  The initial value is 
the current horizontal distance between the points.  Set this value to something 
else and note the change in the display. 

18. There is now a constraint line between the points.  The blue colored line represents the 
constraint, and it points from parent to child.   

Note Note that if you move the mouse over the constrained point, the color of the 
constraint changes from dark to light blue.  This makes it easier to review 
constraints in a complex template.  The small white line represents the type of 
constraint.  In this case a horizontal line represents a horizontal constraint.  The 
child point is now yellow, which indicates that it is partially constrained.  As you 
place constraints, note the ways the constraints are represented. 
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19. Move the parent point and then move the child point.  Note the different behavior. 

20. Add a vertical constraint to the child point from the third point in the display.  Again move 
the parent points around and note the behavior.  You can no longer move the child point 
because it is now fully constrained. 

 

21. Using the popup menu, delete the constraints on the child by selecting the Delete 
Constraints command. 

22. Move the points so that they are in an approximate line with the middle point about halfway 
between the other two and slightly lower (No need to be precise). 
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23. Add a slope constraint to the middle point using the left point as the parent.  Set the slope to 
-20%.   

Warning  Do not turn on the Apply rollover values checkbox 

 

24. Now add a slope constraint to the middle point using the right point as the parent.  Set the 
slope to 20%. 
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25. Now check out the behavior of the points. 

Note All the rest of the constraint types require a pair of points to define the parent.  

26. Delete the constraints on the current child point. 

27. Add a Horizontal constraint to the middle point from either of the other points. 

A Vector Offset constraint constrains a point to be on the vector defined by the two parent points offset by the 

specified offset.  Negative values are to the left of the vector, positive values are to the right.  A Vector Offset 

constraint is shown by a dashed yellow line connecting the two parents, then light blue arrow from the middle of 

that line to the child point. 

28. Add a Vector Offset constraint to the middle point and select the left point as the first parent 
and the right point as the second parent.  Set the offset to 0.0.  Note the behavior as the 
points are moved. 

29. Delete just the Vector Offset constraint form the child point by using the Edit Point command 
and setting the second constraint to None. 

30. Add the Vector Offset command again, but this time set the offset to 2.0.  Note behavior. 
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31. Repeat the last two steps with an offset of -2.0.   

32. Delete all constraints. 

33. Add a Horizontal Maximum constraint to one of the points using the other two points as the 
parent pair.  Set the offset to 0.0.  Note the behavior as the parent points are moved across 
one another. 

34. Repeat the last two steps for Horizontal Minimum, Vertical Maximum, and Vertical 
Minimum. 

 

LESSON NAME – USING CONSTRAINT COMBINATIONS 

EXERCISE: COMBINING CONSTRAINTS 

This exercise will demonstrate the practical use of constraint combinations to get the behavior desired from a 

template. 

35. Open the template “Constraint combination” by double clicking on it in the Template Library.  
Set your Display to Components. 

36. Referring to the illustration, imagine that this component represents one-half of the road 
surface with point 1 being the centerline and point 2 being the edge of pavement. 
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37. Now imagine that we want to super elevate the road by moving point 2 in a vertical direction. 

38. To mimic the superelevation, delete just the vertical constraint from point 2, and then move 
it.  Is this the behavior we want? 

39. Press ESC to abort the move, or if you have already finished the move, press the undo button 

 to get the component back to its original orientation. 

40. Delete the constraints from point 4 and re-constrain it so it is directly below point 1 at a 
vertical distance of -2.0.  Use the Full Constraint command. 

 

41. Move point 2 again.  The results are better, but we still have a problem.  The top and bottom 
of the surface are not parallel.  As a matter of fact they weren’t to begin with.  We can tell 
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this by returning the component to its original orientation and looking at the properties of 
the component segments. 

Note To look at the properties of a particular component segment, place the mouse 
cursor over the segment you want to query.  Tool tips will popup with the 
component information.  

42. When the top segment slope is 2%, what is the bottom component slope? 

43. What we really want is to make the bottom of the component parallel to the top at a vertical 
value of -2.0.   

We could do this by introducing a Null Point.  A Null Point is a point in the template that is 
not part of any component. Null Points can be used in locations where we need a point for 
constraint purposes, but we don’t necessarily want it in the final design surface. 
Instead we want to utilize a new concept introduced in (SELECTseries1). This is the constraint 
value equation. 

 

44. Make a copy of this template in the library by highlighting it in the library and doing a Ctrl-C, 
Ctrl-V.  You should end up with “Constraint combination1”. 

 

LESSON NAME – MORE ON CONSTRAINT COMBINATIONS 
Suppose we wanted to make it so that the actual thickness is consistent and slope of the component is parallel.  

We will want to use constraint variable equation for this point and component behavoir. 

45. Open template “Constraint combination1”. 

46. Edit point 3 by either a double click operation or right click > edit on the point. 
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47. Change the Vector Offset constraint to a slope constraint 

48. Select Point 4 as the parent. Key-in 0.02 for the slope and Apply the change. 

 

49. Now select the   sign next to the slope constraint value. This brings up the constraint 
Value Equation dialog. 

 

50. Select the parents using the [+] select buttons or key-in the equation as shown. Note the 
value multiplier value of 1.  

Note The constraint value equation contains three components: 
=/$(1)-$(2)*1 
Type: /slope _horizontal |vertical 
Parents: $(ParentA) - $(ParentB) 
Multiplier: *numeric value  -this is optional 
The software evaluates the A-B and applies the multiplier. Then it takes that 
value and substitutes it for the constraint value defined. 
Horizontal and Vertical evaluations can be mixed and matched. 

 

51. Apply this change and repeat the process of removing the slope constraint from point 2 and 

then moving the point the emulate superelevation. 

52. Save your template library. 
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LESSON NAME - COMPONENT DISPLAY RULES OVERVIEW 
Component Display Rules allow the user to create variations to a template based on external influences such as 

H/V controls and end-conditions. This is a very powerful concept that allows the user to apply one template that 

will actually change based on what is happening at a particular station.  

 

This concept frees the user from knowing where a change in conditions might require a different template and 

allows the rules within a template to make modifications. 

There are two main parts to this functionality:  

First, there are the individual rules, which are stored on the template.  The following types are supported:  

 Horizontal 

 Absolute Horizontal (uses absolute values) 

 Vertical 

 Absolute Vertical 

 Slope 

 Absolute Slope 

 Component is Displayed 

All but the last are conditional expressions between points that use one of the <, <=, =, >=, > operators to 

compare the specified difference between the two points to a particular value. 

  

Example: Rule1 - Horizontal Difference between Point1 and Point2 is less than 10 

  Rule2 - Slope from Point1 to Point2 is greater than -10% 

  Rule3 – Slope from Point1 to Point2 is less than 10%  

The rule, in general has 5 components. 

 Name (no spaces allowed) 

 Type ( e.g. Absolute Horizontal Difference ) 

 Calculated value ( e.g. Point1.x – Point2.x ) 

 Test ( <, <=, =, > , >= ) 

 Test Value (e.g. 10 ) 
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The second part of this functionality is the conditional expression that is stored on the component.  An example 

of a conditional expression is: 

  Rule1 OR (Rule2 AND Rule3)  

 

OBJECTIVE: 

Upon completion of this module, you will be able to: 

 Define and explain some of the uses of Component Display Rules. 
  

 Develop a template that contains a set of Component Display Rules that automatically 
changes the template based on design conditions. 
 

 Apply the template to a design and review the results. 

Lesson Name - Adding a retaining wall template to a 4 lane template. 

LESSON OBJECTIVE: 

This lesson will take an existing template and combine another template that defines a median retaining wall. 

Then define a set of Component Display Rules displays this wall when the vertical elevation between the 

roadways is exceeded. 

 EXERCISE : COMBINING A TEMPLATE 

This exercise will copy an existing 4 lane template. The copied template will be edited and a median retaining wall 

template (group of components) will be added. 

53. Activate the Create Template dialog by selecting Modeler > Create Template. 
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54. Navigate the tree view to the Typical Section Folder and select the “4 Lane” template. 

55. Right-click Copy the 4 Lane template and Paste it to the same location. This creates a 
template of the same name, incremented by “1”. 

 
56. Set the template “4 Lane1” active by double-clicking on the template name in the tree view.  

 

Note The active template is identified in the tree view by the red square highlighting the template 
icon. 
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57. Expand the “Components” folder and single-click select the “Median Retaining Wall” 
template. The retaining wall template should appear in the Preview Window at the same time 
the template “4 lane1” appears in the active template window. 
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58. Turn on Display Point Names. Zoom in using the view control or middle mouse wheel on the 
point “RIS” 

 

 

 

 

59. Verify the affixes in the Tools > Settings. Drag and Drop the “Median Retaining Wall” from the 
right side insertion point onto the point “RIS”. 
The resulting typical section should appear similar to the following: 
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 EXERCISE : CREATE A COMPONENT DISPLAY RULE. 

This exercise will create 3 display rules that determine when the retaining wall will be constructed if a certain set 

of criteria is met. 

60. Edit one of the retaining wall shoulders. Notice the parent component. 

 

Note The parent component “Retaining Wall Barrier”, tells the software that whatever action is 
applied to the parent component will also be applied to this “child” component.  

61. Cancel the Component Properties dialog. 

62. Right-click on the Retaining Wall Barrier component and select Set Component Display Rules. 
This will activate the Component Display Conditional Expression dialog. 
Notice the component name in the Conditional Expression portion of this dialog. 

 

63. Add a new Template Display Rule. Select the Add... Button at the bottom of the dialog. 

64. This rule checks to see if the bottom of the median ditch point “CMD” is above the “RIS” 
(Right Inside Shoulder) point. 
 
Key-in the Name: “CMD>RIS” 
Description: “Median ditch is higher than RT shoulder” 
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Set the Type: Vertical 
Between: RIS 
And: CMD 
>= -0.50 

 

65. Select OK to add this rule and dismiss that add dialog. 

66. Add a second rule that tests for the median ditch with the LIS (Left Inside Shoulder). 

 

67. Add a Third rule that determines whether or not the Retaining Wall Barrier is displayed. This 
rule is applied to the “Median” component. 
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68. Add the Conditional Expression to the “Retaining Wall Barrier” component. 
Because the retaining wall needs to be displayed when the CMD point is above either LIS OR 
RIS, both of the vertical tests are added. 
Select the first rule in the rules list and press Selected Rule.  
Select the OR button. 
Select the Second rule in the rules list and press Selected Rule. 

69. Evaluate the expression by using the [=] button. Note that this expression evaluates to 
“False”. 

 

70. Select OK to dismiss the Component Display Conditional Expression dialog. 



© 2009 Bentley Systems, Incorporated    22 

71. Set the component display rule for the Median component. Right-click Edit component on 
the Median ditch and select the Edit… button next to the Display Rules: read only field. 

 

72. Because we want the median to display when the Retaining Wall Barrier component is NOT 
displayed, add a NOT before adding the “component is displayed” expression. 

Notice that by adding the “NOT” to this expression, it evaluates to True even though the actual expression 

evaluates to False. 
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73. Select OK to dismiss the Component Display Conditional Expression dialog and OK to dismiss the 
Component Properties dialog.  

74. Turn on Display All Components. 

75. Move one of the unconstrained points to check your results. 

 

Results 

76. Save the ITL file by selecting File > Save. 
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Lesson Name- Evaluating the Design. 

OBJECTIVE: 

This lesson takes the template from the previous exercise and applies it to the corridor design.  

 EXERCISE : REVIEWING EXISTING DESIGN. 

This exercise reviews the existing 4 lane design. The areas that apply the component display rules are noted and 

various design elements discussed. 

77. Activate the Roadway Designer dialog by selecting Modeler > Roadway Designer. 

Note the “Right of Way” reference in the Cross Section view of the designer.  

 

78. Window in on the plan view at the south end of the corridor (at the first Median crossover). 
Key-in station 705+00 in the Station navigation field and press tab. 

79. Note the automatic width change based on the LIEP and RIEP alignment “Styles”. 
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80. Process ahead station to station 735+00 and note the issue with the median.  
This is the area that is addressed by the component display rule.  
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 EXERCISE 7: REVISING THE DESIGN. 

In this lesson, the 4 lane design is updated with the template that contains the component display rules 

completed in the previous exercises. The areas that require design revision using component display rules are 

noted and various automated design elements reviewed. 

81. Use the Station Navigation arrow to go to the first station of the corridor. 

 

82. Activate the Template Drops dialog by selecting the icon on the main Roadway Designer 
dialog. 
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83. Select the Current template Drop entry. 

84. Navigate the Tree view of the Template Library to the Typical Sections folder.  
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85. Select the copied template from Exercise 4 “4 Lane1” and press Change. 

86. Close the Template Drops dialog. 

87. Key-in station 734+00 and check the results. 

 

 


